Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Один запрос вместо нескольких с циклом [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор bizisoft — 26.05.20, 11:23 — 0 комментариев
1С 8.2 Альфа-Авто 4.1.

Для выбранного товара первым запросом получаю список Аналогов, а потом для них получаю продажи (квартал, 6 мес, год), но знаний хватило только на получение продаж отдельным запросом для каждого периода.

//Получаем список значений с набором всех Аналогов по выбранному Артикулу

        Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ГруппыАналогов.Артикул,
        |    ГруппыАналогов.Производитель,
        |    ГруппыАналогов.тАртикул
        |ИЗ
        |    РегистрСведений.ГруппыАналогов КАК ГруппыАналогов
        |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ГруппыАналогов КАК ГруппыАналогов1
        |        ПО ГруппыАналогов.ИдентификаторГруппы = ГруппыАналогов1.ИдентификаторГруппы
        |ГДЕ
        |    ГруппыАналогов1.Артикул = &Артикул";

    Запрос.УстановитьПараметр("Артикул", Товар);
    Результат = Запрос.Выполнить();
    Выб = Результат.Выбрать();
    СпЗн = Новый СписокЗначений;
    СпЗн.Очистить();    
    Пока Выб.Следующий() Цикл
        СпЗн.Добавить(Выб.Артикул,Выб.Артикул);
    КонецЦикла;

//Для полученного списка (Аналогов) получаем продажи (Квартал, 6 мес, Год)

        Для Счетчик = 1 По 3 Цикл
        Если       Счетчик = 1 Тогда    
             НачПериод = НачалоДня(ДобавитьМесяц(ТекущаяДата(),-3));    // квартал
        ИначеЕсли Счетчик = 2 Тогда    
            НачПериод = НачалоДня(ДобавитьМесяц(ТекущаяДата(),-6));    // пол года  
        ИначеЕсли Счетчик = 3 Тогда    
            НачПериод = НачалоДня(ДобавитьМесяц(ТекущаяДата(),-12));// год
        КонецЕсли;        
        КонПериод = КонецДня(ТекущаяДата());

        Запрос = Новый Запрос;
        Запрос.Текст =     
            "ВЫБРАТЬ
            |    Продажи.Период,
            |    Продажи.Номенклатура,
            |    Продажи.Количество,
            |    Продажи.Номенклатура.Артикул КАК Артикул,
            |    Продажи.Номенклатура.тАртикул КАК тАртикул,
            |    Продажи.Номенклатура.Производитель КАК Производитель
            |ИЗ
            |    РегистрНакопления.Продажи КАК Продажи
            |ГДЕ
            |    Продажи.Период МЕЖДУ &НачПериод И &КонПериод
            |    И Продажи.Номенклатура.Артикул В(&СпЗнАртикул)";
        
        Запрос.УстановитьПараметр("КонПериод", КонПериод);
        Запрос.УстановитьПараметр("НачПериод", НачПериод);
        Запрос.УстановитьПараметр("СпЗнАртикул", СпЗн);  

        Результат = Запрос.Выполнить();  
        ТЗВыб = Результат.Выгрузить();
        Для Каждого стр Из ТЗВыб Цикл
            НСтр = ТЗРез.Добавить();        
            НСтр.Номенклатура = стр.Номенклатура;        
            НСтр.Артикул = стр.Артикул;
            НСтр.тАртикул = стр.тАртикул;
            НСтр.Производитель = стр.Производитель;
            Если       Счетчик = 1 Тогда    НСтр.ПродажаКвартал = стр.Количество;    
            ИначеЕсли Счетчик = 2 Тогда    НСтр.ПродажаПолгода = стр.Количество;
            ИначеЕсли Счетчик = 3 Тогда    НСтр.ПродажаГод = стр.Количество;
            КонецЕсли;                     
        КонецЦикла;  
    КонецЦикла;
    ТЗРез.Свернуть("тАртикул, Производитель","ПродажаКвартал, ПродажаПолгода, ПродажаГод");



Попробовал сделать так:
ВЫБРАТЬ
            |    Продажи.Номенклатура,
            |    Продажи.Номенклатура.Артикул КАК Артикул,
            |    Продажи.Номенклатура.тАртикул КАК тАртикул,
            |    Продажи.Номенклатура.Производитель КАК Производитель,
            |    Продажи.Количество КАК ПродажаКвартал,
            |    Продажи1.Количество КАК ПродажаПолгода,
            |    Продажи2.Количество КАК ПродажаГод
            |ИЗ
            |    РегистрНакопления.Продажи КАК Продажи1
            |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрНакопления.Продажи КАК Продажи
            |            ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрНакопления.Продажи КАК Продажи2
            |            ПО Продажи2.Номенклатура = Продажи.Номенклатура
            |        ПО Продажи1.Номенклатура = Продажи.Номенклатура
            |ГДЕ
            |    Продажи.Период МЕЖДУ &НачПериодК И &КонПериод
            |    И Продажи.Номенклатура.Артикул В(&СпЗнАртикул)
            |    И Продажи1.Период МЕЖДУ &НачПериодПГ И &КонПериод
            |    И Продажи2.Период МЕЖДУ &НачПериодГ И &КонПериод


Но что-то мне подсказывает, что это не верно в корне.
Забил запрос в Запросник, но результата нет, да и запрос выполняется гораздо дольше чем если через цикл с запросами.


Подскажите пожалуйста, как правильно создать запрос, чтобы исключить цикл со вложенными запросами и как правильно обозначить параметры с разделением по периодам (квартал, 6 мес, год), чтобы вывести периоды были в столбцах
Номенклатура | Квартал | 6 мес | Год
Просмотров: 3, оставить комментарий   
Реализация - Возврат [раздел Программирование в 1С Предприятие 8.3]
Автор Bon Jovi — 26.05.20, 9:28 — 1 комментариев
Конфигурация: Trade (10.3.29.1) (http://v8.1c.ru/trade/), версия: 8.3.11.2867, обычные формы.
Добрый день. Подскажите пожалуйста, как можно реализация следующий функционал (саму логику): Мне нужно запросом получить количество документов реализации и возврата по позиции так, чтобы они шли друг за другом. То есть идёт документ РЕАЛИЗАЦИИ, за ним документ ВОЗВРАТА. Если же идёт документ РЕАЛИЗАЦИИ, за ним опять документ РЕАЛИЗАЦИИ, то это ошибочная ситуация.
Просмотров: 37, последний комментарий от sava1   
Как программно выбрать и изменить один документ 1с 7.7 конф 7.7.00 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 25.05.20, 22:33 — 1 комментариев
Здравствуйте! Возникла следующая задача.
У меня есть документ АктПриема. Он имеет реквизит СсылкаРасх со ссылкой на соответствующую ему РасходнуюНакладную. В РасходнойНакладной имеется реквизит Имя. Мне нужно программно изменить реквизит Имя в этой РасходнойНакладной из документа АктПриема. Для этого в АктеПриема я написал следующий код:

Процедура РН()
    Расх=СоздатьОбъект("Документ.РасходнаяНакладная");
        Расх.ПолучитьДокумент(СсылкаРасх);
        Расх.Имя="Гарик";
        Расх.Записать();
КонецПроцедуры

и повесил его на кнопку.
Синтакс говорит, что все ОК, а программа матерится на строку
Расх.ПолучитьДокумент(СсылкаРасх);

говорит, что слишком много параметров.
Подскажите, пожалуйста, где ошибка. Или в чем я неправ. Спасибо!
Просмотров: 37, последний комментарий от volodya1122   
Как программно закрыть таблицу печатной формы 1с 7.7 конф 7.7.00 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 23.05.20, 0:20 — 3 комментариев
Здравствуйте!
Есть у меня таблица печатной формы. В модуле формы есть строка
Таб.Показать();

Потом мне нужно эту таблицу программно закрыть. Какой оператор это делает? не могу найти. Что нужно написать?
Таблица печатной формы.
Спасибо!
Просмотров: 111, последний комментарий от ZUBR   
Подключение к базе через OLE. [раздел Программирование в 1С Предприятие 7.7]
Автор Talkman — 22.05.20, 15:37 — 9 комментариев
Добрый день. Есть две базы 1С 7.7 ПУБ глубоко переработанные. 1С 7.7 0,27. Конфигурации идентичные. Сделал отчет анализа продаж с подключением из одной базы 1С в другую по OLE. Отчет работает, показывает нужные данные, но после завершения процедуры анализа сеанс 1С, созданный OLE подключением не закрывается. Итого 5-7 нажатий кнопки анализировать и в системе висит куча сеансов 1С. Вопрос: как правильно завершать подключение по OLE, чтобы оно закрывалось после завершения процедуры. Мой пример подключения по OLE (кусок кода).
Код
    Там = СоздатьОбъект("V77.Application"); 
    КаталогБазыОЛе  = СокрЛП(Константа.Туда);
    ПользовательОле = "***";
    ПарольОле       = "***";
    МонопольныйРежимOLE = ""; // для немонопольного запуска указать пустую строку!
    ЗапускБезЗаставки = 0;       // для появления заставки (например, чтобы наблюдать
    // процесс запуска базы OLE визуально) поставьте здесь "0"
    РезультатПодключения = Там.Initialize ( Там.RMTrade , "/d" + СокрЛП(КаталогБазыОле) + " /n" + СокрЛП(ПользовательОле) +    " /p" + СокрЛП(ПарольОле) + МонопольныйРежимOLE, ?(ЗапускБезЗаставки = 1,"NO_SPLASH_SHOW",""));
    Если РезультатПодключения = 0 Тогда
        Предупреждение("Не удалось подключится к указанной базе - проверьте вводные!");
    КонецЕсли;  

        Би = СоздатьОбъект("БухгалтерскиеИтоги");
    Би.ИспользоватьСубконто(ВидыСубконто.МестаХранения,Склад,2);
    Би.ИспользоватьСубконто(ВидыСубконто.ТМЦ,СТМЦ);
    Би.ВыполнитьЗапрос(КонДата, КонДата, "281");
    Би.ВыбратьСубконто(ВидыСубконто.ТМЦ);
    Пока Би.ПолучитьСубконто(ВидыСубконто.ТМЦ) = 1 Цикл                                    //Анализ остатков на магазине эта база
        Если Би.СКД(3) <= 0 Тогда
            Продолжить;
        КонецЕсли;
        Ы = "";
        Т.НайтиЗначение(Би.Субконто(ВидыСубконто.ТМЦ),Ы,"Т");
        Т.ПОлучитьСтрокуПоНомеру(Ы);
        Т.ОстМ = Би.СКД(3);  
        Состояние("Заполнение остатками в этой базе");
    КонецЦикла;        
    
    СкладТам = Там.CreateObject("Справочник.МестаХранения");
    Если СкладТам.НайтиПоНаименованию(СокрЛП(Склад.Наименование),0) = 0 ТОгда
        Сообщить("Не могу там найти склад "+СокрЛП(Склад.Наименование));  
        возврат;
    КонецЕсли;    
    СТМЦТам = Там.CreateObject("СписокЗначений");
    ТМЦТАМ = Там.CreateObject("Справочник.ТМЦ");
    Т.ВыбратьСтроки();
    Пока Т.ПолучитьСтроку() = 1 Цикл
        Если ТМЦТам.НайтиПоКоду(Т.Код,0) = 1 Тогда
            СТМЦТам.ДобавитьЗначение(ТМЦТам.ТекущийЭлемент());
            Состояние("Формирование списка товаров для анализа в ТОЙ базе")
        КонецЕсли;    
    КонецЦикла;    
    БиТам = Там.CreateObject("БухгалтерскиеИтоги");
    БиТам.ИспользоватьСубконто(Там.ВидыСубконто.МестаХранения,СкладТам,2);
    БиТам.ИспользоватьСубконто(Там.ВидыСубконто.ТМЦ,СТМЦТам);
    БиТам.ВыполнитьЗапрос(КонДата, КонДата, "281");                                           //Анализ остатков на магазине ТА база
    БиТам.ВыбратьСубконто(Там.ВидыСубконто.ТМЦ);
    Пока БиТам.ПолучитьСубконто(Там.ВидыСубконто.ТМЦ) = 1 Цикл
        Если БиТам.СКД(3) <= 0 Тогда
            Продолжить;
        КонецЕсли;
        Ы = "";  
        Т.НайтиЗначение(БиТам.Субконто(Там.ВидыСубконто.ТМЦ).Код,Ы,"Код");
        Т.ПОлучитьСтрокуПоНомеру(Ы);
        Т.ОстМ = Т.ОстМ + БиТам.СКД(3);
        Состояние("Заполнение остатками в Той базе");
    КонецЦикла;
Просмотров: 127, последний комментарий от Talkman   
Произвольное условие (запрос) для разных документов [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 22.05.20, 12:06 — 3 комментариев
Приветствую, Форумчане!
1с8.3.12, УФ, самопис

В одном из документов есть вкладка с произвольным условием запрос в текстовом формате (упрощенный пример) Условие_ПроизвольноеУсловие:

Контекст.Подходит = Ложь;
Запрос = Новый Запрос;

Запрос.Текст =
"ВЫБРАТЬ
|    ЗаказМодельИКомплектация.Номенклатура КАК Номенклатура
|ИЗ
|    Документ.Заказ.МодельИКомплектация КАК ЗаказМодельИКомплектация
|ГДЕ
|    ЗаказМодельИКомплектация.Ссылка = &Ссылка";

Запрос.УстановитьПараметр("Ссылка", Контекст.Объект);

Если НЕ Запрос.Выполнить().Пустой() Тогда
    Контекст.Подходит = Истина;
КонецЕсли;


Запускается это в одном из модулей

    Контекст = Новый Структура("Объект, Акция, Подходит", Объект, Акция, Ложь);
        Попытка
            Выполнить(Акция.Условие_ПроизвольноеУсловие);
        Исключение
            ОписаниеОшибки = ОписаниеОшибки();
        КонецПопытки;


Всё это работает, но вот пришла беда.
Если посмотреть код, то это произвольное условие срабатывает жестко только на один тип документов "Заказ"
Документ.ЗАКАЗ.МодельИКомплектация КАК ЗаказМодельИКомплектация


Теперь решили эту гадость распространить и на другой документ "Консультации", т.е. каким-то волшебным способом этот текст произвольного условия должен превратиться в
Документ.КОНСУЛЬТАЦИИ.МодельИКомплектация КАК ЗаказМодельИКомплектация


Сможете посоветовать как можно программно это изменить?
Типа

Контекст = Новый Структура("Объект, Акция, Подходит, ДокументПоиска", Объект, Акция, Ложь, "Заказ"/"Консультации");
Документ.[ДокументПоиска].МодельИКомплектация КАК ЗаказМодельИКомплектация


Просмотров: 87, последний комментарий от Vofka   
ограничение прав доступа к записям справочника в зависимости от текущего пользователя [раздел Программирование в 1С Предприятие 8.3]
Автор Pashkevich — 21.05.20, 12:24 — 3 комментариев
всем доброго дня!

есть два справочника Сотрудники и АрбитражноеДело. нужно установить разграничение доступа к записям, то есть чтобы пользователь(роль АрбитражныйУправляющий) видел только себя в сотрудниках и свои арбитражные дела.

в справочнике сотрудник ограничение делаю по реквизиту Наименование, а в справочнике арбитражное дело - по реквизиту Ответственный.

вот сами ограничения







также создал параметр сеанса ТекущийПользователь (СправочникСсылка.Сотрудники)

и в модуле сеанса написал следующую процедуру:

Процедура УстановкаПараметровСеанса(ТребуемыеПараметры)
    
    
    ТекПользователь = Справочники.Сотрудники.НайтиПоНаименованию(ИмяПользователя());
    
    Если ТекПользователь.Пустая() Тогда
        
        НовПользователь = Справочники.Сотрудники.СоздатьЭлемент();
        НовПользователь.Наименование = ИмяПользователя();
        НовПользователь.Записать();
        ТекПользователь = НовПользователь.Ссылка;
        
    КонецЕсли;
    

    ПараметрыСеанса.ТекущийПользователь = ТекПользователь;
    
    
КонецПроцедуры


но все-равно, когда заходишь под арбитражным управляющим, в справочнике арбитражное дело нет ни одной записи, а справочник сотрудники в принципе отсутствует, хотя галка просмотр в роли стоит.

подскажите, пожалуйста

p/s/ версия 8.3.16.1063, конфа самописная, УФ
Просмотров: 111, последний комментарий от Vofka   
УПП 1.3 В управленческом начислении не найдена расчетная база [раздел 1С Управление производственным предприятием 8]
Автор anna_v — 21.05.20, 8:12 — 0 комментариев
В формуле расчета "Доплата" указан тип - зависимое первого уровня и формула -РасчетнаяБаза* Процент/Показатель. Оклад по часам определен как базовое начисление.
Сам оклад по часам считается , его часы определяются. Процент и показатель указываются явно в начислении зарплаты. При расчете пишет ошибку "показатель "Расчетная база" не найден.
Пробовала поставить расчетную базу в часах, чтоб хоть понять, определяется база или нет. Тогда ошибки нет, просто результат расчета=0.
Как проверить, почему не видится расчетная база?
Просмотров: 53, оставить комментарий   
нажатие на поле ввода програмно [раздел Программирование в 1С Предприятие 8.1 (8.0)]
Автор 4andriy — 20.05.20, 20:03 — 2 комментариев
1С 7.7: Предприятие

Есть документ "Доверенность". В форме Сотрудников я добавил поле ввода с типом "Документ.Доверенность". Потом зашел в сотрудника и в поле ввода выбрал доверенность с его реквизитами.

Я могу без проблем очень быстро открыть типовую для сотрудника доверенность и поправить уже существующий документ:

Элемент=СоздатьОбъект("Справочник.Сотрудники");
Элемент.найтиЭлемент(ТекущийЭлемент());
ОткрытьФорму(Элемент.Дов);


Но код открывает документ, а мне нужно програмно инициировать нажатие на поле ввода что-бы отрылся журнал довереностей, был выбран но не открыт именно тот документ который надо и уже потом можно было скопировать либо изменить либо удалить документ.

Код открытия формы не подходит поскольку он открывает журнал но не указывает на нужный документ как это происходит когда поле ввода нажимаем мышкой:
ОткрытьФорму("Журнал.Общий");
Просмотров: 91, последний комментарий от denis84   
Расчет итогов тормозит получение остатка [раздел Администрирование и настройка 1С]
Автор lex2707 — 20.05.20, 10:12 — 0 комментариев
Добрый день.
При заполнении инвентаризации по регл остаткам если указать дату из периода за кот. произведен расчет итогов то заполнение длится 1 час, если указать тек дату то выполняется за 30 сек.
Итоги пересчитывал, переиндекацию выполнял ничего не изменилось.
8.2.19.130 УТП клиент сервер SQL
Просмотров: 67, оставить комментарий   
поиск в строке [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 19.05.20, 22:18 — 2 комментариев
1с 7.7: Предприятие
Есть 2 текстовых поля. 1 поле - строка с текстом, 2 - то, что ищу.
Например. 1 поле: Иванов Иван Иванович. Второе: Иван.

Если (Найти(ФИО, имя))=1 Тогда
    Сообщить("Имя: Иван");      
КонецЕсли;

Если (Найти(ФИО, имя))=0 Тогда
    Сообщить("Имя: Не Иван");      
КонецЕсли;


Но это не работает, возможно не та функция.
Просмотров: 115, последний комментарий от volodya1122   
заполнение реквизита код в зависимости от выбранного элемента в форме выбора справочника [раздел Программирование в 1С Предприятие 8.3]
Автор Pashkevich — 19.05.20, 20:47 — 5 комментариев
всем привет!

на форме есть реквизиты: код окопф (строка) и наименование окопф(СправочникСсылка), нужно чтобы при выборе определенного элемента изменялось не только наименование на нужное, но и код.

скрин для наглядности:


подскажите, как лучше сделать?

все, что удалось написать:

&НаКлиенте
Процедура НаименованиеОКОПФНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    

    СтандартнаяОбработка = Ложь;
    
    ОткрытьФорму("Справочник.КлассификаторОКОПФ.Форма.ФормаВыбора", , Элементы.НаименованиеОКОПФ);
    
КонецПроцедуры


или лучше сделать перечисление (НаименованияОКОПФ) и в зависимости от выбранного значения программно задавать код, только минус в том, что при добавлении постоянно придется прописывать код.

p/s/ конфа самописная, версия 8.3.16.1063, УФ


 ! 

Правила: 8
 
Просмотров: 98, последний комментарий от denis84   
Удаление подчинённых объектов [раздел Программирование в 1С Предприятие 8.3]
Автор Bon Jovi — 18.05.20, 15:06 — 4 комментариев
Конфигурация: Trade (10.3.29.1) (http://v8.1c.ru/trade/), версия: 8.3.11.2867, обычные формы.
Добрый день. Подскажите пожалуйста. У меня есть справочник ЗначенияХарактеристик, также есть справочник Характеристики (который в свою очередь является владельцем справочника ЗначенияХарактеристик). Сделал обработку, с помощью которой я могу выбрать характеристику и удалить (пометить на удаление) её и её значения (пометить на удаление в справочнике ЗначенияХарактеристик и также очистить записи по нужным регистрам). Появилась нужда доработать обработку таким способом, чтобы можно было выбрать характеристику и удалить (пометить) только её значения, а саму характеристику не трогать. Раньше удалял (помечал) характеристики таким способом:
УдаляемаяХарактеристика = Выборка.Характеристика.ПолучитьОбъект();
УдаляемаяХарактеристика.УстановитьПометкуУдаления(Истина, Истина);
УдаляемаяХарактеристика.Записать();


Теперь, когда пытаюсь удалить (пометить) значения характеристики с помощью похожей конструкции:
УдаляемоеЗначение = Выборка.Значение.ПолучитьОбъект();
УдаляемоеЗначение.УстановитьПометкуУдаления(Истина);
УдаляемоеЗначение.Записать();


Элемент значения характеристик помечается, но связь между ним и характеристикой всё же остаётся, так как при повторном добавлении через обработку такого же значения той же характеристики, значение не добавляется, так как в базе он есть, но он помечен и в этом загвоздка. Пробовал так:
УдаляемаяХарактеристика = Выборка.Характеристика.ПолучитьОбъект();
УдаляемаяХарактеристика.УстановитьПометкуУдаления(Ложь, Истина);
УдаляемаяХарактеристика.Записать();

В таком случае пометок вообще нет.
Просмотров: 161, последний комментарий от Bon Jovi   
«Інформація за сегментами» форма 6 [раздел 1С Управление Торговым Предприятием 8]
Автор kihor — 18.05.20, 11:10 — 0 комментариев
Коллеги, добрый день!

Хотел задать вопрос по поводу отчета «Інформація за сегментами» форма 6. Мы используем конфигурацию 1С УТП и в ней нет такого встроенного регламентированного отчета. Кто как решает эту проблему? Как формируете этот отчет?
Заранее спасибо за ответы.
Просмотров: 79, оставить комментарий   
Подбор приложения 1с для web,IOS,WIN [раздел Прочее 1С 8]
Автор vl_joker — 17.05.20, 12:07 — 3 комментариев
Добрый день! Нужен сервис для работы небольшого склада с продажами клинтам . Сейчас использую 1с boss, устраивает все кроме цены и поддержки(ответ на вопрос можно ждать днями),нет контакта мобильного, только почта. Кто может помочь в подборе другого сервиса.
Просмотров: 139, последний комментарий от Bernet   
Как сделать реквизит видимым только в одном слое расходной накладной? 1с 7.7 конф 7.7.00 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 15.05.20, 23:17 — 4 комментариев
Здравствуйте! Не могу решить проблему - не хватает знаний.
Есть у меня флажок. Он же реквизит Спл. Расположен на слое "Основной" РасходнойНакладной.
Привожу кусок кода:

Процедура ПриВыбореЗакладки(Номер,Значение)        
    Форма.ИспользоватьСлой(" Совместный,"+Значение,2);
    УстДоступность();
    УстДоступностьКнопок();
    глУстановкаРеквизитаТип(Контекст);
    
    Если (НазваниеНабораПрав() <> "Администратор") Тогда        //Моя вставка для СПЛАЧЕНО
        
        Форма.Спл.Видимость(0);
        Форма.Спл.Доступность(0);  
    КонецЕсли;
..................................................................................................................................................


В этом случае флажок Спл виден только на слое "Основной".
Если же код программы изменить:

Процедура ПриВыбореЗакладки(Номер,Значение)        
    Форма.ИспользоватьСлой(" Совместный,"+Значение,2);
    УстДоступность();
    УстДоступностьКнопок();
    глУстановкаРеквизитаТип(Контекст);
    
    Если (НазваниеНабораПрав() <> "Администратор") Тогда        //Моя вставка для СПЛАЧЕНО
        
        Форма.Спл.Видимость(0);
        Форма.Спл.Доступность(0);
         Иначе
               Форма.Спл.Видимость(1);
    КонецЕсли;
.................................................................................................................................................


то в этом случае флажок Спл виден во всех слоях.

Мне же нужно, чтобы в последнем случае он тоже был виден только в родном слое.
Моя программа сложнее, и флажков и полей больше, которые видны в неродных слоях.
Я специально максимально упростил, чтобы ясно показать суть проблемы.
Как использовать метод Видимость только для родного слоя? Чтобы он не светил во все слои?
Спасибо!
Просмотров: 105, последний комментарий от ZUBR   
Самодельная Регламентированная отчетность XSD схемы. [раздел Программирование в 1С Предприятие 8.3]
Автор Alex_2C — 15.05.20, 22:50 — 0 комментариев
Нужно создать регламентированный отчет с выгрузкой в XML. На сайте налоговой есть схема. Но она не импортируется в пакет XDTO. И на основании её фабрику не создать. Есть еще common_types.xsd. Как вся эта дичь работает? В типовых конфигурациях этого отчета нет. Данные получу, а вот запись в xml вызвала проблемы. Интересует технология для конфигураций на БСП (например Бухгалтерия 2.0).
Просмотров: 91, оставить комментарий   
Реализация = Возврат (нулевой оборот при наличии продаж) [раздел Программирование в 1С Предприятие 8.3]
Автор Bon Jovi — 15.05.20, 8:37 — 4 комментариев
Конфигурация: Trade (10.3.29.1) (http://v8.1c.ru/trade/), версия: 8.3.11.2867, обычные формы.
Добрый день. Начинающий программист. Подскажите пожалуйста, в чём может быть проблема. Есть запрос, мне нужно сделать так, чтобы когда я задавал параметр (число) он анализировал заданное значение и по запуску запроса в табличной части отображался результат где кол-во документов с нулевым оборотом >= "выставленного значения" (за указанный день). Если в качестве параметра я указываю 0 или 1, то выдаётся такой результат: Результат. Как я понимаю, за указанную дату по номенклатуре было проведено два возврата, то есть условие >= 0 или 1, работает. Но стоит мне изменить на 2 и выше, то результат пустой. Подскажите, где я совершил ошибку?
ВЫБРАТЬ
    ПродажиОбороты.Номенклатура КАК Номенклатура,
    СУММА(ПродажиОбороты.КоличествоОборот) КАК КоличествоОборот
ПОМЕСТИТЬ ЗапросПоНоменклатуре
ИЗ
    РегистрНакопления.Продажи.Обороты(&Дата_Начала, &Дата_Окончания, Регистратор, ) КАК ПродажиОбороты

СГРУППИРОВАТЬ ПО
    ПродажиОбороты.Номенклатура

ИМЕЮЩИЕ
    СУММА(ПродажиОбороты.КоличествоОборот) = 0
;

////////////////////////////////////////////////////////////­////////////////////
ВЫБРАТЬ
    ПродажиОбороты.Регистратор КАК Регистратор
ПОМЕСТИТЬ ЗапросПоВозвратам
ИЗ
    ЗапросПоНоменклатуре КАК ВТ
        ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.Продажи.Обороты(&Дата_Начала, &Дата_Окончания, Регистратор, ) КАК ПродажиОбороты
        ПО ВТ.Номенклатура = ПродажиОбороты.Номенклатура
ГДЕ
    ПродажиОбороты.КоличествоОборот < 0
    И НАЧАЛОПЕРИОДА(ПродажиОбороты.Период, ДЕНЬ) = &ДатаВозврата

СГРУППИРОВАТЬ ПО
    ПродажиОбороты.Регистратор

ИМЕЮЩИЕ
    КОЛИЧЕСТВО(РАЗЛИЧНЫЕ ПродажиОбороты.Регистратор) >= &КоличествоВозвратов
;

////////////////////////////////////////////////////////////­////////////////////
ВЫБРАТЬ
    ВозвратТоваровОтПокупателяТовары.Номенклатура КАК Номенклатура,
    ВозвратТоваровОтПокупателяТовары.ДокументПартии КАК Реализция,
    ВозвратТоваровОтПокупателяТовары.Ссылка КАК Возврат,
    ВозвратТоваровОтПокупателяТовары.Склад КАК СкладВозврата
ИЗ
    Документ.ВозвратТоваровОтПокупателя.Товары КАК ВозвратТоваровОтПокупателяТовары
ГДЕ
    ВозвратТоваровОтПокупателяТовары.Ссылка В
            (ВЫБРАТЬ
                ЗапросПоВозвратам.Регистратор КАК Регистратор
            ИЗ
                ЗапросПоВозвратам КАК ЗапросПоВозвратам)

СГРУППИРОВАТЬ ПО
    ВозвратТоваровОтПокупателяТовары.Номенклатура,
    ВозвратТоваровОтПокупателяТовары.ДокументПартии,
    ВозвратТоваровОтПокупателяТовары.Ссылка,
    ВозвратТоваровОтПокупателяТовары.Склад

УПОРЯДОЧИТЬ ПО
    Реализция УБЫВ,
    Номенклатура
ИТОГИ
    КОЛИЧЕСТВО(Реализция),
    КОЛИЧЕСТВО(Возврат)
ПО
    Номенклатура
АВТОУПОРЯДОЧИВАНИЕ
Просмотров: 252, последний комментарий от Bon Jovi   
Разработка конфигурации платежный календарь [раздел Остальные конфигурации 1С 8]
Автор anna2212 — 14.05.20, 22:40 — 6 комментариев
Добрый вечер, подскажите, пожалуйста.
Требуется разработать конфигурацию в 1с 8.3 "Платежный календарь".
Но не могу понять. что именно должно быть в данной конфигурации, чтобы ее можно было представить для дипломной работы.
Хотела попросить у Вас помощи, чтобы Вы объяснили, какие справочники нужно создавать, какие документы должны быть в конфигурации, отчеты, регистры и все необходимое. Возможно у кого-то есть готовая конфигурация, чтобы можно было посмотреть и понять вообще.
Заранее большое спасибо!
Просмотров: 155, последний комментарий от Fitzgerald   
Как программно очистить поле на форме РасходнойНакладной? в 1С 7.70.003 торговля склад для Украины? [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 14.05.20, 13:00 — 2 комментариев
Здравствуйте!
У меня на форме расходной есть поле ввода реквизита с типом Перечисление.
Возникла необходимость его очистить, чтобы оно было пустым. Перечисление пустую строку не допускает. Как это сделать? Программно и вручную.
Спасибо.
Оператор Очистить используется только для очистки поля Окна Сообщений.
Просмотров: 228, последний комментарий от volodya1122   
RSS Текстовая версия Сейчас: 26.05.20, 11:48
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!