Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Объединение виртуальных таблиц. [раздел Программирование в 1С Предприятие 8.3]
Автор Bon Jovi — 24.09.20, 17:05 — 0 комментариев
Конфигурация: Trade (10.3.29.1) (http://v8.1c.ru/trade/), версия: 8.3.11.2867, обычные формы.
Добрый день. Подскажите пожалуйста в следующем. Хочу написать запрос, который будет формироваться по ходу обхода цикла, то есть каждая строка будет добавлять часть кода. Проблема в том, что я хочу объединить очень много таблиц в одну (полей всего два и они общие, есть у всех таблиц). Но на сколько я понимаю, нельзя объединять виртуальные таблицы. То есть такой метод не работает и выдаёт ошибку "Содержимое объекта данных может быть выбрано только во временную таблицу":
ВЫБРАТЬ
    ТЗ.Элемент1 КАК Элемент1 ,
    ТЗ.Элемент2 КАК Элемент2
ИЗ
    &ТЗ КАК ТЗ

ОБЪЕДИНИТЬ

ВЫБРАТЬ
    ТЗ2.Элемент1 ,
    ТЗ2.Элемент2
ИЗ
    &ТЗ2 КАК ТЗ2


Поделитесь информацией по этому поводу. Нужно именно таким способом, то есть каждая строка цикла должна добавить очередной кусок объединения.
Просмотров: 20, оставить комментарий   
Выгрузка движений Корректировки записей регистров [раздел Конфигурация "1С:Конвертация данных"]
Автор Bernet — 24.09.20, 13:52 — 0 комментариев
Всем привет, Конвертация данных, редакция 2.1 (2.1.8.2)

Есть правила обмена между двумя УПП.
Нужно донастроить правила обмена, чтобы выгружались движения документа "Корректировка записей регистров" - сейчас приходит только сам документ.

Мои действия:
1. включил в состав плана обмена все регистры накопления и бухгалтерии
2. прописал правила регистрации - чтобы регистрировались только те движения, которые созданы корректировками (остальные появятся в результате проведения документов в базе-приемнике).
3. и вот беру тестовый док, регистрирую его движения, пробую обменяться иии... ошибка - При загрузке в базу-приемник ругается на набор записей РН - смотрю, а обработка ОбменДаннымиXML какого-то рожна пытается этот набор записей загрузить как набор РС (регистра сведений).

Походу переносить движения с помощью КД не так просто, как я думал.
Дальше нашел эту статью , тут в 19 комментарии есть пример как сделали, но у меня не получается воспроизвести, там человек добавлял в ПКС группу свойств:
Цитата
две табличные части - ТаблицаРегистровНакопления и ЗаказыПокупателей. Галки получать из входящих данных для табличных частей нет. В ПКС ПередОбработкой указываем...

так вот "ТаблицаРегистровНакопления" - понятно - это таб часть в составе метаданных документа, а как она смогла добавить "ЗаказыПокупателей" я не понял - ведь такой ТЧ нет, и КД не дает сделать произвольную таб часть, которой нет в составе. или я что-то не так делаю... Получается ПВД есть как в примере, ПКО тоже, а вот ПКС не соображу как сделать

Вопрос следующий: если смотреть на этот пример из статьи - что я делаю не так? или может у кого-то есть пример как перекинуть движения Корректировки записей регистров?

Благодарю за внимание.
Просмотров: 31, оставить комментарий   
ПоказатьОтметкуЭлементов: на форме выбора галочки выделить все и отменить все [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 24.09.20, 11:38 — 0 комментариев
Приветствую, Форумчане!
1с8.3.12, самопис, УФ

Нажатием кнопки вызываю список значений с галочками выбора

СписокПочтовыхАдресов().ПоказатьОтметкуЭлементов(



Как можно добавить в эту форму выбора галочки выбрать всё и отменить всё, т.е. кнопкой выделить или снять выделение?
Просмотров: 27, оставить комментарий   
MEDoc или Fredo звіт [раздел 1С Управление Торговым Предприятием 8]
Автор stark — 23.09.20, 14:21 — 4 комментариев
Уважаемые, коллеги.
Поделитесь опытом, пожалуйста.
Используем "Управление торговым предприятием для Украины", редакция 1.2. (1.2.56.2), 1С:Предприятие 8.3 (8.3.17.1496). и MEDoc.
Смотрю в сторону упростить инфраструктуру и использовать Fredo звіт.
Просмотров: 91, последний комментарий от kihor   
Как создать ссылку на определенную строку ТаблицыЗначений? 1с 7.7 конф 7.7.003 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 22.09.20, 17:12 — 5 комментариев
ЗДРАВСТВУЙТЕ!

Есть кусок программы примерно такой
            Пока Расх.ПолучитьДокумент()=1 Цикл
    ...........................................................................................................................................................................                                                    
            ТЗ.НоваяСтрока();
            Если ((НачДата1<=Расх.ДатаВыд)и(Расх.ДатаВыд<= КонДата1) Тогда
                ТЗ.ДатаДок = Расх.ДатаДок;
                .................................................................................................................................................................................
                                .....................................................................................................................................................................................
                ИначеЕсли   (Расх.СтатусЗаказа=Перечисление.Статусы.АКС)и(ПустаяСтрока(Расх.Модель)=0) Тогда  
                    ТЗ.СуммаАкс = Расх.Итог("СуммаСНДС");                
                    ....................................................................

                                         А=ТЗ.ТекущаяСтрока();                    // ЗАПОМИНАЕМ СТРОКУ И ПРИСВАИВАЕМ ЕЕ ПЕРЕМЕННОЙ А

                    ТЗ.ВыбратьСтроки();
                    Пока ТЗ.ПолучитьСтроку()=1 Цикл
                        Если (ТЗ.ЗАКАЗ=Расх.НомерЗаказа) Тогда
                                  ТЗ.СуммаАкс =  Расх.Итог("СуммаСНДС");
                                       ............................................................................
                        КонецЕсли;  
                    КонецЦикла;

                    ТЗ.ВыбратьСтроки();

                    ТЗ.ПолучитьСтроку(А);                   //ПЫТАЕМСЯ ПОЛУЧИТЬ СТРОКУ А

                        Если (ТЗ.ЗАКАЗ=Расх.НомерЗаказа)и(ТЗ.СТАТУС=Перечисление.Статусы.АКС)  Тогда  
                            ТЗ.К=К;
                        КонецЕсли;
                                            .......................................................................................................................


Суть в том, что в определенном месте цикла мне надо запомнить строку ТЗ, чтобы потом ее вызвать без поиска и цикла и произвести в ней некоторые изменения.
Синтакс выдает ошибку что при выполнении ТЗ.ПолучитьСтроку(А); слишком много параметров.
Как мне это сделать? Где ошибка? Спасибо!)
Просмотров: 115, последний комментарий от Sharzem   
Відпускні не підтягуються в відомість [раздел 1С Управление Торговым Предприятием 8]
Автор larai — 22.09.20, 14:19 — 1 комментариев
Доброго дня!
Хелпніть, чому нараховані відпускні не підтягуються в кінцеву відомість по нарахуванню зп?
Дякую!



"Управління торговим підприємством для України", редакція 1.2. (1.2.53.1) (http://1c.ua/v8/RegionalSolutions_UA_UTP.php)
Copyright © Molenari OU, 2017-2019. All rights reserved
1С:Предприятие 8.3 (8.3.10.2650)
Просмотров: 50, последний комментарий от Gazulo   
Дубли данных при проходе через цыкл [раздел Программирование в 1С Предприятие 8.3]
Автор burza — 22.09.20, 12:50 — 0 комментариев
Вот есть меню там есть блюдо и к нему должны подтягиваться компоненты, они тянуться только не один а от общего числа
Вот 6 сыра и должно быть один. цыкл кудато не туда втулил чтоли?
Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    МенюБлюда.Ссылка.Дата,
        |    МенюБлюда.Ссылка.ДатаМеню,
        |    МенюБлюда.Ссылка.Подразделение,
        |    МенюБлюда.Ссылка.ГруппаПитания,
        |    МенюБлюда.Ссылка.ПриёмПищи,
        |    МенюБлюда.Ссылка.КоличествоПитающихся,
        |    МенюБлюда.Блюдо,
        |    МенюБлюда.Выход1,
        |    МенюБлюда.ЕдиницаВыхода,
        |    МенюБлюда.Выход2,
        |    МенюБлюда.Выход3,
        |    МенюБлюда.КоличествоПорций,
        |    МенюБлюда.Меню1,
        |    МенюБлюда.Меню2,
        |    МенюБлюда.Ссылка.Номер КАК Номер,
        |    МенюБлюда.Ссылка.Ответственный,
        |    МенюБлюда.Ссылка.Комментарий,
        |    МенюБлюда.ИдентификаторБлюда
        |ИЗ
        |    Документ.Меню.Блюда КАК МенюБлюда
        |ГДЕ
        |    МенюБлюда.Ссылка.ДатаМеню МЕЖДУ &ДатаМенюС И &ДатаМенюПо";
    
    Запрос.УстановитьПараметр("ДатаМенюПо", Объект.ДатаПо);
    Запрос.УстановитьПараметр("ДатаМенюС", Объект.ДатаС);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    Выборка = РезультатЗапроса.Выбрать();
    
    Пока Выборка.Следующий() Цикл
        
               Док = Документы.МенюДляОфБух.НайтиПоНомеру(Выборка.Номер);

        
                Если НЕ Док.Пустая() Тогда
                        
                        
                        Для Каждого Строка из Док.Блюда цикл
                            
                            Если Строка.Блюдо = Выборка.Блюдо Тогда
                                
                                  
                                  Продолжить;
                
                              КонецЕсли;
                              
                            
                          КонецЦикла;
                          
                          
            
                           Док = Док.ПолучитьОбъект();
                          
                       Иначе
                          
                            Док = Документы.МенюДляОфБух.СоздатьДокумент();
                            
                       КонецЕсли;

        
         Док.Дата = Выборка.Дата;
         Док.ДатаМеню   =  Выборка.ДатаМеню;
         Док.ГруппаПитания =  Выборка.ГруппаПитания;
         Док.КоличествоПитающихся   = Выборка. КоличествоПитающихся;
         Док.Комментарий  =   Выборка. Комментарий;
         Док.Номер =  Выборка.Номер;
         Док.Ответственный  = Выборка.Ответственный;
         Док.Подразделение = Выборка.Подразделение;
         Док.ПриёмПищи   =   Выборка.ПриёмПищи;
        
        
         ///////////Запись Блюда
         НовСтрока = Док.Блюда.Добавить();
         НовСтрока.Блюдо = Выборка.Блюдо;
         НовСтрока.ИдентификаторБлюда = Выборка.ИдентификаторБлюда;
         НовСтрока.Выход1 = Выборка.Выход1;
         НовСтрока.ЕдиницаВыхода = Выборка.ЕдиницаВыхода;
         НовСтрока.Выход2 = Выборка.Выход2;
         НовСтрока.Выход3 = Выборка.Выход3;
         НовСтрока.КоличествоПорций = Выборка.КоличествоПорций;
         НовСтрока.Меню1 = Выборка.Меню1;
         НовСтрока.Меню2 = Выборка.Меню2;
        
        

    
    ///////////////Запись компонента    
    ПараметрыБлюда = Компонент(Выборка.Номер);
    
    
    Для каждого КомпонентПолученный из ПараметрыБлюда цикл
        
        НовыйКомпонент = Док.КомпонентыБлюд.Добавить();
        
        НовыйКомпонент.ИдентификаторБлюда = КомпонентПолученный.ИдентификаторБлюда;
        НовыйКомпонент.Компонент = КомпонентПолученный.Компонент;
        НовыйКомпонент.ЗакладкаБрутто = КомпонентПолученный.ЗакладкаБрутто;
        НовыйКомпонент.ЕдиницаИзмеренияБрутто = КомпонентПолученный.ЕдиницаИзмеренияБрутто;
        НовыйКомпонент.ЗакладкаНетто = КомпонентПолученный.ЗакладкаНетто;
        НовыйКомпонент.ЕдиницаИзмеренияНетто = КомпонентПолученный.ЕдиницаИзмеренияНетто;
        НовыйКомпонент.Пересчитывать = КомпонентПолученный.Пересчитывать;
        
    
    КонецЦикла;
    

    
                 
         Док.Записать();

        
     КонецЦикла;


  &НаСервере
Функция Компонент(Номер)
      
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    МенюКомпонентыБлюд.ИдентификаторБлюда,
        |    МенюКомпонентыБлюд.Компонент,
        |    МенюКомпонентыБлюд.ЗакладкаБрутто,
        |    МенюКомпонентыБлюд.ЕдиницаИзмеренияБрутто,
        |    МенюКомпонентыБлюд.ЗакладкаНетто,
        |    МенюКомпонентыБлюд.ЕдиницаИзмеренияНетто,
        |    МенюКомпонентыБлюд.Пересчитывать
        |ИЗ
        |    Документ.Меню.КомпонентыБлюд КАК МенюКомпонентыБлюд
        |ГДЕ
        |    МенюКомпонентыБлюд.Ссылка.Номер = &Номер";
    
    Запрос.УстановитьПараметр("Номер", Номер);
    
    РезультатЗапроса = Запрос.Выполнить().Выгрузить();
    
       
    Возврат РезультатЗапроса;


  
    
КонецФункции
Просмотров: 68, оставить комментарий   
Выгрузка номенклатуры с иерархией [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор Semennuch — 22.09.20, 11:26 — 1 комментариев
1С:Підприємство 8.3 (8.3.13.1644) Управління торгівлею для України, редакція 3.1 (3.1.6.1)

Есть такая проблема. Раньше пользовался таким методом, что бы выгрузить Номенклатуру с иерархией (с плюсиками) в экселе:
1. Открывал список Номенклатуры
2. Включал галочку "Фильтр за иерархией"
3. Дальше выбирал меню "Ещё" - "Настроить список"
4. Потом во вкладке "Отбор" добавлял "Группа" - "Равно" - заходил в меню "Значений" и нажимал на "Показать все"
5. С помощью Ctrl выделял корневые папки (у меня это - "Услуги" и "Товары")
6. Дальше выбирал меню "Ещё" - "Вывести список"
7. Выбирал "Выводить в Табличный документ"
8. Ставил галки "Код" и "Наименование"
9. Потом галочка "С подчиненными" и ОК

В результате я получал табличный документ с группировкой (с плюсиками) папок, подпапок и номенклатурой в этих папках, которую выгружаль в эксель и было мне счастье.

После какого-то периода времени и с помощью моих работников, этот метод работает не полностью. Теперь выгружаются только папки без Номенклатуры. Помогите пинком, кто с таким сталкивался или просто знает решение такой проблемы.
Спасибо
Просмотров: 66, последний комментарий от Semennuch   
Как (каким документом) и когда перечислять налоги (НДФЛ, ВЗ) с дохода ФОП при оказании им услуг (покупки у него товаров)? [раздел Бухгалтерия 8, редакция 1 для Украины]
Автор RedCat77 — 22.09.20, 11:18 — 0 комментариев
"Управление торговым предприятием для Украины", редакция 1.2. (1.2.57.1)

Как (каким документом) и когда перечислять налоги (НДФЛ, ВЗ) с дохода ФОП при оказании им услуг (покупки у него товаров)?
Просмотров: 140, оставить комментарий   
Получить признак отказа при проведении документа [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 21.09.20, 13:56 — 2 комментариев
Приветствую, Форумчане!
1с8.3.12, самопис, УФ

Имеется некая процедура "ВыполнитьВсякуюЕрунду", в которой помимо прочего есть процедура создания документа
СоздатьДокументПеремещениеТМЦ();



Бывают случаи, когда при создании этого документа документ хоть и создается (программно), но не проводится и не сохраняется (не выполняются условия по остаткам товара), выходит соответствующее сообщение, что проведение невозможно...

Как можно добится, чтобы если при создании этого документа

       ПеремещениеТМЦ.Заполнить(Объект.Ссылка);
        ПеремещениеТМЦ.Записать(РежимЗаписиДокумента.Проведение);


выясняется, что проведение невозможно, т.е. получен отказ, запретить выполнение дальнейших операций в процедуре
"ВыполнитьВсякуюЕрунду"


Вот выходит такая ошибка при попытке провести:

{Документ.Заказ.Форма.ФормаДокумента.Форма(4567)}: Ошибка при вызове метода контекста (Записать)
        ПеремещениеТМЦ.Записать(РежимЗаписиДокумента.Проведение);
по причине:
Не удалось провести: "Перемещение ТМЦ"!


Именно при такой ситуации и нужно прервать выполнение дальнейших команд
Просмотров: 68, последний комментарий от Vofka   
Как можно при отключённом NumLock вызвать форму которая показала что его надо включить обратно? [раздел Программирование в 1С Предприятие 8.3]
Автор ukr.ray — 18.09.20, 20:53 — 2 комментариев
Добрый день, я заметил что в платформа 1с8 в правом нижнем углу есть значок включен ли сейчас NumLock, у меня очень умные люди работают, надоели звонками что зависла 1с, а когда начинаешь разбираться, выясняется что они не знаю что NumLock отключает цифры на клавиатуре.
Кто ни будь знает как можно при отключённом NumLock вызвать форму которая показала что его надо включить обратно ?
Просмотров: 132, последний комментарий от mut   
1с 8.3 зуп 3.1 внешняя печатная форма с word [раздел Программирование в 1С Предприятие 8.3]
Автор illiona — 18.09.20, 17:29 — 3 комментариев
Пришлось столкнуться с подключаемой внешней печатной формой к документу. Есть документ .doc,как подключить его к печатной форме? Сведенияовнешней нужно в модуле прописывать? Можно кто поделится примером? Заранее спасибо
Просмотров: 124, последний комментарий от MATEVI   
Проблема при обновлении конфигуратора [раздел Программирование в 1С Предприятие 8.3]
Автор ldntester — 18.09.20, 10:00 — 0 комментариев
Платформа 8.3.10.2168

Проблема при обновлении конфигуратора


В процессе обновления информационной базы произошла критическая ошибка
по причине:
Ошибка СУБД:
Microsoft SQL Server Native Client 11.0: Location: e:\b\s3\sources\sql\ntdbms\storeng\include\longrec.inl:1327
Expression: outBufLen >= offsetof (InRowContent, m_varBlobCol) + inBufLen
SPID: 54
Process ID: 2928
HRESULT=80004005, HRESULT=80004005, HRESULT=80004005, SQLSrvr: SQLSTATE=HY000, state=1, Severity=15, native=596, line=0
SQLSrvr: SQLSTATE=HY000, state=1, Severity=14, native=3624, line=1
SQLSrvr: SQLSTATE=01000, state=2, Severity=0, native=3624, line=1

С чем может быть связана данная ошибка?)

MS SQL 2016

Установлены
MS SQL Server 2012 Native Client
MS SQL ODBC Driver 13 for SQL Server
MS SQL ODBC Driver 17 for SQL Server
Просмотров: 76, оставить комментарий   
как ПрочитатьJSON(Чтение) массив объектов (выборку запроса) [раздел Программирование в 1С Предприятие 8.3]
Автор svetas_l — 18.09.20, 8:36 — 10 комментариев
добрый день!
такой код выдаёт ошибку "по причине:
Недопустимое состояние потока записи JSON"

  
    Чтение         =    Новый ЧтениеJSON;
    Чтение.ОткрытьФайл(Этаформа.ПутьЧтения+".json");
    Чтение.УстановитьСтроку("{}");
    Джисон = ПрочитатьJSON(Чтение);
    Чтение.Закрыть();

в чем ошибка?
файл
[
{
"Ссылка": "ТОВ \"ДИРЕКТОРІЯ ЗАТИШКУ\"",
"Код": "000000006",
"Наименование": "ТОВ \"ДИРЕКТОРІЯ ЗАТИШКУ\"",
"Префикс": "ДЗ",
"ИНН": "",
"НомерСвидетельства": "",
"КодПоЕДРПОУ": "40769228",
"ФизическоеЛицо": "",
"НаименованиеПолное": "ТОВАРИСТВО З ОБМЕЖЕНОЮ ВІДПОВІДАЛЬНІСТЮ \"ДИРЕКТОРІЯ ЗАТИШКУ\"",
"СвидетельствоСерияНомер": "",
"СвидетельствоДатаВыдачи": "01.01.0001 0:00:00",
"БанковскийСчетПоУмолчанию": "UA653287040000026009054334936 ТОВ \"ДИРЕКТОРІЯ ЗАТИШКУ\"",
"ЮрФизЛицо": "Юр. лицо",
"ТекущийРуководитель": "БЕЗРАДНА СВІТЛАНА ВІКТОРІВНА",
"ТекущаяДолжностьРуководителя": "Директор",
"ТекущийГлавныйБухгалтер": "",
"ТекущийКассир": "",
"ТекущийПаспортист": "",
"ТипОрганизации": "ТОВ",
"УчетнаяЗаписьЭлектроннойПочты": "",
"НазваниеДляСвернутыхУслуг": "",
"ИнформацияПредупреждениеНовойКвитанции": ""
},
{
"Ссылка": "ОК \" ЖБК Морський 1\"",
"Код": "000000001",
"Наименование": "ОК \" ЖБК Морський 1\"",
"Префикс": "МК",
"ИНН": "",
"НомерСвидетельства": "",
"КодПоЕДРПОУ": "39789906",
"ФизическоеЛицо": "",
"НаименованиеПолное": "   Обслуговуючий  Кооператив   \" ЖБК Морський 1\"",
"СвидетельствоСерияНомер": "",
"СвидетельствоДатаВыдачи": "01.01.0001 0:00:00",
"БанковскийСчетПоУмолчанию": "UA583281680000000026003180694",
"ЮрФизЛицо": "Юр. лицо",
"ТекущийРуководитель": "Хапонен Валерий Сергеевич",
"ТекущаяДолжностьРуководителя": "",
"ТекущийГлавныйБухгалтер": "",
"ТекущийКассир": "",
"ТекущийПаспортист": "",
"ТипОрганизации": "Кооператив",
"УчетнаяЗаписьЭлектроннойПочты": "Морской",
"НазваниеДляСвернутыхУслуг": "",
"ИнформацияПредупреждениеНовойКвитанции": ""
},


запись делаю
  ЗаписатьJSON(ЗаписьJSON, Массив_записи);

где Массив_записи
Запрос = Новый Запрос;
    Запрос.Текст =
                "ВЫБРАТЬ *
                 |ИЗ
                | Справочник.Организации КАК Организации
                |";
          Выборка = Запрос.Выполнить().Выбрать();
         Массив_записи =Новый массив;
                                  
     Пока Выборка.Следующий() Цикл

        ОписаниеОбъекта = Новый Структура("Ссылка, Код, Наименование, Префикс,ИНН,НомерСвидетельства,КодПоЕДРПОУ,
ФизическоеЛицо,НаименованиеПолное,СвидетельствоСерияНомер,СвидетельствоДатаВыдачи,
БанковскийСчетПоУмолчанию,ЮрФизЛицо,ТекущийРуководитель,ТекущаяДолжностьРуководителя,
ТекущийГлавныйБухгалтер,ТекущийКассир,ТекущийПаспортист,ТипОрганизации,
УчетнаяЗаписьЭлектроннойПочты,НазваниеДляСвернутыхУслуг,ИнформацияПредупреждениеНовойКвитанции");
        ОписаниеОбъекта.Ссылка = Строка(Выборка.Ссылка);
        ОписаниеОбъекта.Код=Строка(Выборка.Код);
        ОписаниеОбъекта.Наименование=Строка(Выборка.Наименование);
        ОписаниеОбъекта.Префикс=Строка(Выборка.Префикс);
        ОписаниеОбъекта.ИНН=Строка(Выборка.ИНН);
        ОписаниеОбъекта.НомерСвидетельства=Строка(Выборка.НомерСвидетельства);
        ОписаниеОбъекта.КодПоЕДРПОУ=Строка(Выборка.КодПоЕДРПОУ);
        ОписаниеОбъекта.ФизическоеЛицо=Строка(Выборка.ФизическоеЛицо);
        ОписаниеОбъекта.НаименованиеПолное=Строка(Выборка.НаименованиеПолное);
        ОписаниеОбъекта.СвидетельствоСерияНомер=Строка(Выборка.СвидетельствоСерияНомер);
        ОписаниеОбъекта.СвидетельствоДатаВыдачи=Строка(Выборка.СвидетельствоДатаВыдачи);
        ОписаниеОбъекта.БанковскийСчетПоУмолчанию=Строка(Выборка.БанковскийСчетПоУмолчанию);
        ОписаниеОбъекта.ЮрФизЛицо=Строка(Выборка.ЮрФизЛицо);
        ОписаниеОбъекта.ТекущийРуководитель=Строка(Выборка.ТекущийРуководитель);
        ОписаниеОбъекта.ТекущаяДолжностьРуководителя=Строка(Выборка.ТекущаяДолжностьРуководителя);
        ОписаниеОбъекта.ТекущийГлавныйБухгалтер=Строка(Выборка.ТекущийГлавныйБухгалтер);
        ОписаниеОбъекта.ТекущийКассир=Строка(Выборка.ТекущийКассир);
        ОписаниеОбъекта.ТекущийПаспортист=Строка(Выборка.ТекущийПаспортист);
        ОписаниеОбъекта.ТипОрганизации=Строка(Выборка.ТипОрганизации);
        ОписаниеОбъекта.УчетнаяЗаписьЭлектроннойПочты=Строка(Выборка.УчетнаяЗаписьЭлектроннойПочты);
        ОписаниеОбъекта.НазваниеДляСвернутыхУслуг=Строка(Выборка.НазваниеДляСвернутыхУслуг);
        ОписаниеОбъекта.ИнформацияПредупреждениеНовойКвитанции=Строка(Выборка.ИнформацияПредупреждениеНовойКвитанции);
        Массив_записи.Добавить(ОписаниеОбъекта);
      
  КонецЦикла;
Просмотров: 194, последний комментарий от andr_andrey   
Как лучше хранить тарифы [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор bizisoft — 17.09.20, 21:23 — 6 комментариев
Здравствуйте.

1С Предприятие 1С8.3,

Решил облегчить себе с коммунальными платежами и написать простенькую конфигурацию, чтобы не рассчитывать и заполнять квитанции вручную.
Создал справочники:
- Квартиросъемщик (КодЕРЦ, Адрес, Прописано, ПлощадьЖилая)
- Номенклатура (ВидыРасчетов, Тариф)
- ЕдиницыИзмерений
- Тарифы (флМноготарифный, ЕдИзмерения, Стоимость) + Табличная часть Тарифы (Номер, ОтсчетОт, ОтсчетДо, Стоимость). ТЧ используется для указания многотарифных опций, например для электроэнергии.

Пока только сам заполняю, вроде работает, но чувствуется нет гибкости в настройках тарифов, если добавить еще квартиросъемщика.

Хотел организовать хранение тарифов в регистре сведений, но столкнулся с проблемой, как обыграть случай использования множественных тарифов:
Например в случае с эл.эн. (цифры с потолка)
до 150 кВт - 0,8999
150-800 кВт - 1,6999
> 800 кВт - 2,5999

Посоветуйте, как можно организовать хранение в регистре всех тарифов, как обычных, так и многотарифных, чтобы еще можно было учесть и различие у разных квартиросъемщиков (например если печка газовая, то тариф на эл.эн.

до 150 кВт - 0,8999
150-800 кВт - 1,6999
> 800 кВт - 2,5999

А если печка электрическая, то тариф:

до 250 кВт - 0,6355
250-800 кВт - 0,999
> 800 кВт - 1,800

Думал сделать несколько измерений:
- дата - дата установки тарифа
- плательщик - указывает к какому плательщику привязан этот тариф
- услуга - к какой услуге относится тариф
- номер - номер тарифа для многотарифного (0 - если тариф одинарный)
-
Реквизиты:
- флСчетчик Истина
- ИдИзмерений кВт
- Стоимость 0,8999
- ОтсчетОт 0
- ОтсчетДо 150

Но кажется, что получится избыточность данных, т.к. одинаковый тариф будет дублироваться для каждого плательщика.

Например может быть два разных тарифа, каждый из которых может быть одинаковый для своих потребителей.
Как это правильно организовать.
Просмотров: 132, последний комментарий от bizisoft   
Запись элементов справочника без СериализаторXDTO в формат json под старую платформу 8.3.12 [раздел Программирование в 1С Предприятие 8.3]
Автор svetas_l — 17.09.20, 16:25 — 3 комментариев
есть код работает
но нужно его переделать под старую платформу 8.3.12 т.е. без "СериализаторXDTO."
помогите пожалуйста

Код
&НаСервере
Процедура Команда1НаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст =
                "ВЫБРАТЬ *
                 |ИЗ
                | Справочник.Организации КАК Организации
                |";
          Выборка = Запрос.Выполнить().Выбрать();
         Массив_записи =Новый массив;
                                  
     Пока Выборка.Следующий() Цикл

        ОписаниеОбъекта = Новый Структура("Ссылка, Код, Наименование, Префикс,ИНН,НомерСвидетельства,КодПоЕДРПОУ,ФизическоеЛицо,НаименованиеПолное,СвидетельствоСерияНомер,СвидетельствоДатаВыдачи,БанковскийСчетПоУмолчанию,ЮрФизЛицо,ТекущийРуководитель,ТекущаяДолжностьРук
оводителя,ТекущийГлавныйБухгалтер,ТекущийКассир,ТекущийПаспортист,ТипОрганизации,УчетнаяЗаписьЭлектроннойПочты,НазваниеДляСвернутыхУслуг,ИнформацияПредупреждениеНовойКвитанции");
        ОписаниеОбъекта.Ссылка = Строка(Выборка.Ссылка);
        ОписаниеОбъекта.Код=Строка(Выборка.Код);
        ОписаниеОбъекта.Наименование=Строка(Выборка.Наименование);
        ОписаниеОбъекта.Префикс=Строка(Выборка.Префикс);
        ОписаниеОбъекта.ИНН=Строка(Выборка.ИНН);
        ОписаниеОбъекта.НомерСвидетельства=Строка(Выборка.НомерСвидетельства);
        ОписаниеОбъекта.КодПоЕДРПОУ=Строка(Выборка.КодПоЕДРПОУ);
        ОписаниеОбъекта.ФизическоеЛицо=Строка(Выборка.ФизическоеЛицо);
        ОписаниеОбъекта.НаименованиеПолное=Строка(Выборка.НаименованиеПолное);
        ОписаниеОбъекта.СвидетельствоСерияНомер=Строка(Выборка.СвидетельствоСерияНомер);
        ОписаниеОбъекта.СвидетельствоДатаВыдачи=Строка(Выборка.СвидетельствоДатаВыдачи);
        ОписаниеОбъекта.БанковскийСчетПоУмолчанию=Строка(Выборка.БанковскийСчетПоУмолчанию);
        ОписаниеОбъекта.ЮрФизЛицо=Строка(Выборка.ЮрФизЛицо);
        ОписаниеОбъекта.ТекущийРуководитель=Строка(Выборка.ТекущийРуководитель);
        ОписаниеОбъекта.ТекущаяДолжностьРуководителя=Строка(Выборка.ТекущаяДолжностьРуководителя);
        ОписаниеОбъекта.ТекущийГлавныйБухгалтер=Строка(Выборка.ТекущийГлавныйБухгалтер);
        ОписаниеОбъекта.ТекущийКассир=Строка(Выборка.ТекущийКассир);
        ОписаниеОбъекта.ТекущийПаспортист=Строка(Выборка.ТекущийПаспортист);
        ОписаниеОбъекта.ТипОрганизации=Строка(Выборка.ТипОрганизации);
        ОписаниеОбъекта.УчетнаяЗаписьЭлектроннойПочты=Строка(Выборка.УчетнаяЗаписьЭлектроннойПочты);
        ОписаниеОбъекта.НазваниеДляСвернутыхУслуг=Строка(Выборка.НазваниеДляСвернутыхУслуг);
        ОписаниеОбъекта.ИнформацияПредупреждениеНовойКвитанции=Строка(Выборка.ИнформацияПредупреждениеНовойКвитанции);
        Массив_записи.Добавить(ОписаниеОбъекта);
      
  КонецЦикла;
         Запись_в_JSON(Массив_записи,"test");
  КонецПроцедуры
  
процедура  Запись_в_JSON(Массив_записи,имя_файла)
      ЗаписьJSON= Новый ЗаписьJSON;
     ЗаписьJSON.ПроверятьСтруктуру = Истина;
     НастройкиСериализации = Новый НастройкиСериализацииJSON;
     ПараметрыJSON = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Авто, " ", Истина);
     НастройкиСериализации.ВариантЗаписиДаты = ВариантЗаписиДатыJSON.УниверсальнаяДата;
     НастройкиСериализации.СериализовыватьМассивыКакОбъекты = Истина;    
     ЗаписьJSON.ОткрытьФайл(Этаформа.ПутьЗаписи+имя_файла+".json");       // , , , ПараметрыJSON                        
     ЗаписьJSON.ЗаписатьНачалоОбъекта();
     ЗаписьJSON.ЗаписатьИмяСвойства("Массив_записи");
      СериализаторXDTO.ЗаписатьJSON(ЗаписьJSON,Массив_записи,НазначениеТипаXML.Явное);     //НастройкиСериализации
     ЗаписьJSON.ЗаписатьКонецОбъекта();
     ЗаписьJSON.Закрыть();

   КонецПроцедуры
Просмотров: 89, последний комментарий от kihor   
С полными правами не перепроводит из-за "недостаточно прав на исполнение операции над базой данных" [раздел Программирование в 1С Предприятие 8.3]
Автор ILzuv — 17.09.20, 12:33 — 0 комментариев
Добрый день, нужна помощь. Спасибо.
Отчет производства за смену при перепровидение выдает ошибку "У пользователя недостаточно прав на исполнение операции над базой данных." при попытки выполнить запрос по формированию движений для этого документа. Другие документы на этот запросе не выдают ошибку с правами. RLC на правах не вижу.
Вот сам запрос:

Код
    ВЫБРАТЬ 
             ВложенныйЗапрос.ЗаказНаПроизводство                     КАК ЗаказНаПроизводство,
             ВложенныйЗапрос.Номенклатура                             КАК Номенклатура,
             ВложенныйЗапрос.ХарактеристикаНоменклатуры                 КАК ХарактеристикаНоменклатуры,
             ВложенныйЗапрос.ЕдиницаИзмерения                         КАК ЕдиницаИзмерения,
             ВложенныйЗапрос.Продукция                                 КАК Продукция,
             ВложенныйЗапрос.ХарактеристикаПродукции                 КАК ХарактеристикаПродукции,
             ВложенныйЗапрос.Спецификация                             КАК Спецификация,
             ВложенныйЗапрос.Подразделение                             КАК Подразделение,
             ВложенныйЗапрос.Номенклатура.ВестиУчетПоХарактеристикам КАК НоменклатураВестиУчетПоХарактеристикам,
             ВложенныйЗапрос.Продукция.ВестиУчетПоХарактеристикам    КАК ПродукцияВестиУчетПоХарактеристикам,
             ВложенныйЗапрос.ВидВоспроизводства                         КАК ВидВоспроизводства,
             ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.ЗаказНаПроизводство)      КАК ЗаказНаПроизводствоПред,
             ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.Номенклатура)             КАК НоменклатураПред,
             ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.ХарактеристикаНоменклатуры) КАК ХарактеристикаНоменклатурыПред,
             ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.ЕдиницаИзмерения)         КАК ЕдиницаИзмеренияПред,
             ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.Продукция)                КАК ПродукцияПред,
             ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.ХарактеристикаПродукции)  КАК ХарактеристикаПродукцииПред,
             ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.Спецификация)             КАК СпецификацияПред,
             ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.Подразделение)            КАК ПодразделениеПред,
             ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.ВидВоспроизводства)         КАК ВидВоспроизводстваПред,
             ЕстьNULL(ВложенныйЗапрос.КолДокументЕдиницыДокумента,0)    КАК КолДокументЕдиницыДокумента,
             ЕстьNULL(ВложенныйЗапрос.КолДокумент,0)                    КАК КолДокумент,
             ЕстьNULL(ВложенныйЗапрос.КолПотребностиЕдиницыДокумента,0) КАК КолПотребностиЕдиницыДокумента,
             ЕстьNULL(ВложенныйЗапрос.КолПотребности,0)                 КАК КолПотребности
         ИЗ
         (ВЫБРАТЬ
         //сгруппированное объединение запросов
             ОбъединенныйЗапрос.ЗаказНаПроизводство                             КАК ЗаказНаПроизводство,
             ОбъединенныйЗапрос.Номенклатура                                 КАК Номенклатура,
             ОбъединенныйЗапрос.ХарактеристикаНоменклатуры                     КАК ХарактеристикаНоменклатуры,
             ОбъединенныйЗапрос.ЕдиницаИзмерения                             КАК ЕдиницаИзмерения,
             ОбъединенныйЗапрос.Продукция                                     КАК Продукция,
             ОбъединенныйЗапрос.ХарактеристикаПродукции                         КАК ХарактеристикаПродукции,
             ОбъединенныйЗапрос.Спецификация                                 КАК Спецификация,
             ОбъединенныйЗапрос.Подразделение                                 КАК Подразделение,
             ОбъединенныйЗапрос.ВидВоспроизводства                             КАК ВидВоспроизводства,
             СУММА(ОбъединенныйЗапрос.ДокКоличествоЕдиницыДокумента)            КАК КолДокументЕдиницыДокумента,
             СУММА(ОбъединенныйЗапрос.ДокКоличество)                            КАК КолДокумент,
             СУММА(ОбъединенныйЗапрос.ПотребностьКоличествоЕдиницыДокумента) КАК КолПотребностиЕдиницыДокумента,
             СУММА(ОбъединенныйЗапрос.ПотребностьКоличество)                 КАК КолПотребности
         ИЗ
         (
         //табличная часть документа
         ВЫБРАТЬ
             ЗаказНаПроизводство,
             Номенклатура,
             ХарактеристикаНоменклатуры,
             ЕдиницаИзмерения,
             Продукция,
             ХарактеристикаПродукции,
             Спецификация,
             Подразделение,
             ДокКоличествоЕдиницыДокумента,
             ДокКоличество,
             ПотребностьКоличествоЕдиницыДокумента,
             ПотребностьКоличество,
             ВидВоспроизводства
         ИЗ ВременнаяТаблицаДокумента
         ОБЪЕДИНИТЬ ВСЕ
         //регистр ПотребностиЗаказовНаПроизводство
         ВЫБРАТЬ
             РегПотребности.ЗаказНаПроизводство                    КАК ЗаказНаПроизводство,
             РегПотребности.Номенклатура                         КАК Номенклатура,
             РегПотребности.ХарактеристикаНоменклатуры             КАК ХарактеристикаНоменклатуры,
             РегПотребности.ЕдиницаИзмерения                     КАК ЕдиницаИзмерения,
             РегПотребности.Продукция                             КАК Продукция,
             РегПотребности.ХарактеристикаПродукции                 КАК ХарактеристикаПродукции,
             РегПотребности.Спецификация                         КАК Спецификация,
             РегПотребности.Подразделение                         КАК Подразделение,
             0                                                     КАК ДокКоличествоЕдиницыДокумента,
             0                                                     КАК ДокКоличество,
             ВЫРАЗИТЬ(РегПотребности.КоличествоОстаток * РегПотребности.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент
                 / РегПотребности.ЕдиницаИзмерения.Коэффициент КАК Число(15,3))
                                                                 КАК ПотребностьКоличествоЕдиницыДокумента,
             РегПотребности.КоличествоОстаток                     КАК ПотребностьКоличество,
              РегПотребности.ВидВоспроизводства                     КАК ВидВоспроизводства
         ИЗ
           РегистрНакопления.ПотребностиЗаказовНаПроизводство.Остатки(&КонГраница, ЗаказНаПроизводство В (&МассивЗаказов)) КАК РегПотребности
         ДЛЯ ИЗМЕНЕНИЯ РегистрНакопления.ПотребностиЗаказовНаПроизводство.Остатки
         ) КАК ОбъединенныйЗапрос
         СГРУППИРОВАТЬ ПО
             ОбъединенныйЗапрос.ЗаказНаПроизводство,
             ОбъединенныйЗапрос.Номенклатура,
             ОбъединенныйЗапрос.ХарактеристикаНоменклатуры,
             ОбъединенныйЗапрос.ЕдиницаИзмерения,
             ОбъединенныйЗапрос.Продукция,
             ОбъединенныйЗапрос.ХарактеристикаПродукции,
             ОбъединенныйЗапрос.Спецификация,
             ОбъединенныйЗапрос.Подразделение,
             ОбъединенныйЗапрос.ВидВоспроизводства
         ) КАК ВложенныйЗапрос
         ИТОГИ
             СУММА(КолДокументЕдиницыДокумента),
             СУММА(КолДокумент),
             СУММА(КолПотребностиЕдиницыДокумента),
             СУММА(КолПотребности)
         ПО
             ЗаказНаПроизводство,
             Номенклатура,ХарактеристикаНоменклатуры,
             ЕдиницаИзмерения, Продукция, ХарактеристикаПродукции, Спецификация
Просмотров: 91, оставить комментарий   
чтение массива объектов используя СериализаторXDTO.ПрочитатьJSON [раздел Программирование в 1С Предприятие 8.3]
Автор svetas_l — 17.09.20, 10:53 — 0 комментариев
добрый день!
нужно корректно прочитать файл
Цитата
{
"Массив_записи": {
"#type": "jv8:Array",
"#value": [
{
"#type": "jv8:Structure",
"#value": [
{
"name": {
"#type": "jxs:string",
"#value": "Ссылка"
},
"Value": {
"#type": "jxs:string",
"#value": "ТОВ \"ДИРЕКТОРІЯ ЗАТИШКУ\""
}
},
{
"name": {
"#type": "jxs:string",
"#value": "Код"
},
"Value": {
"#type": "jxs:string",
"#value": "000000006"
}
},
{
"name": {
"#type": "jxs:string",
"#value": "Наименование"
},
"Value": {
"#type": "jxs:string",
"#value": "ТОВ \"ДИРЕКТОРІЯ ЗАТИШКУ\""
}
},
{
"name": {
"#type": "jxs:string",
"#value": "Префикс"
},
"Value": {
"#type": "jxs:string",
"#value": "ДЗ"
}
},
{
"name": {
"#type": "jxs:string",
"#value": "ИНН"

который записывается кодом:
      ЗаписьJSON= Новый ЗаписьJSON;
     ЗаписьJSON.ПроверятьСтруктуру = Истина;
     НастройкиСериализации = Новый НастройкиСериализацииJSON;
     ПараметрыJSON = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Авто, " ", Истина);
     НастройкиСериализации.ВариантЗаписиДаты = ВариантЗаписиДатыJSON.УниверсальнаяДата;
   // НастройкиСериализации.ФорматСериализацииДат = ФорматДатыJSON.ISO;
     НастройкиСериализации.СериализовыватьМассивыКакОбъекты = Истина;    
     ЗаписьJSON.ОткрытьФайл(Этаформа.ПутьЗаписи+имя_файла+".json");       // , , , ПараметрыJSON                        
     ЗаписьJSON.ЗаписатьНачалоОбъекта();
     // ЗаписьJSON.ЗаписатьИмяСвойства("ДатаФормирования");
     //ЗаписьJSON.ЗаписатьЗначение(ЗаписатьДатуJSON(ТекущаяДата(), ФорматДатыJSON.ISO, ВариантЗаписиДатыJSON.УниверсальнаяДата));
     ЗаписьJSON.ЗаписатьИмяСвойства("Массив_записи");
                 
     СериализаторXDTO.ЗаписатьJSON(ЗаписьJSON,Массив_записи,НазначениеТипаXML.Явное);     //НастройкиСериализации
     ЗаписьJSON.ЗаписатьКонецОбъекта();
     ЗаписьJSON.Закрыть();


нужно корректно прочитать массив элементов справочника или выборки запроса из элементов справочника

код
           Массив_записи =Новый массив;
  
      Чтение = Новый ЧтениеJSON;
          Чтение.ОткрытьФайл(Этаформа.ПутьЧтения+".json");
    
      Массив_записи= СериализаторXDTO.ПрочитатьJSON(Чтение, Тип("СправочникОбъект.Организации"));
                
      Чтение.Закрыть();


выдаёт ошибку параметров
- как правильно прочитать
Массив_записи= СериализаторXDTO.ПрочитатьJSON(Чтение, Тип("СправочникОбъект.Организации"))
Просмотров: 88, оставить комментарий   
Отключение объединения номенклатурных позиций [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор KIODAMAGE — 16.09.20, 14:06 — 1 комментариев
Добрый день. В Рознице 2.2 есть возможность в настройках РМК запретить объединение одинаковых номенклатурных позиций в одну строку(когда при добавлении не добавляется новая строка, а только возрастает количество). Подскажите, можно ли это каким-то образом сделать в УТ 3.2.16.3?
Просмотров: 79, последний комментарий от KIODAMAGE   
Запись элементов справочника через СериализаторXDTO в формат json [раздел Программирование в 1С Предприятие 8.3]
Автор svetas_l — 16.09.20, 12:00 — 2 комментариев
Добрый день!
помогите найти ошибку ругается несоответствие типов параметр 3 в строке
" СериализаторXDTO.ЗаписатьJSON(ЗаписьJSON,Массив_записи,НастройкиСериализации); "


Код
    Запрос = Новый Запрос;
    Запрос.Текст =
                "ВЫБРАТЬ *
                 |ИЗ
                | Справочник.Организации КАК Организации
                |";
           
    ЗаписьJSON= Новый ЗаписьJSON;
    ЗаписьJSON.ПроверятьСтруктуру = Истина;
    НастройкиСериализации = Новый НастройкиСериализацииJSON;
    ПараметрыJSON = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Авто, " ", Истина);
    НастройкиСериализации.ВариантЗаписиДаты = ВариантЗаписиДатыJSON.УниверсальнаяДата;
    // НастройкиСериализации.ФорматСериализацииДат = ФорматДатыJSON.ISO;
    НастройкиСериализации.СериализовыватьМассивыКакОбъекты = Истина;    

    Выборка = Запрос.Выполнить().Выбрать();
    ЗаписьJSON.ОткрытьФайл("E:\Odecom\test.json, , , ПараметрыJSON");                                
    ЗаписьJSON.ЗаписатьНачалоОбъекта();
    
    // ЗаписьJSON.ЗаписатьИмяСвойства("ДатаФормирования");
    //ЗаписьJSON.ЗаписатьЗначение(ЗаписатьДатуJSON(ТекущаяДата(), ФорматДатыJSON.ISO, ВариантЗаписиДатыJSON.УниверсальнаяДата));
    
    ЗаписьJSON.ЗаписатьИмяСвойства("Массив_записи");
    Массив_записи =Новый массив;
                                  
    Пока Выборка.Следующий() Цикл
        
        
        ОписаниеОбъекта = Новый Структура("Ссылка, Код, Наименование, Префикс,ИНН,НомерСвидетельства,КодПоЕДРПОУ,ФизическоеЛицо,НаименованиеПолное,СвидетельствоСерияНомер,СвидетельствоДатаВыдачи,БанковскийСчетПоУмолчанию,ЮрФизЛицо,ТекущийРуководитель,ТекущаяДолжностьРук
оводителя,ТекущийГлавныйБухгалтер,ТекущийКассир,ТекущийПаспортист,ТипОрганизации,УчетнаяЗаписьЭлектроннойПочты,НазваниеДляСвернутыхУслуг,ИнформацияПредупреждениеНовойКвитанции");
        ОписаниеОбъекта.Ссылка = Строка(Выборка.Ссылка);
        ОписаниеОбъекта.Код=Строка(Выборка.Код);
        ОписаниеОбъекта.Наименование=Строка(Выборка.Наименование);
        ОписаниеОбъекта.Префикс=Строка(Выборка.Префикс);
        ОписаниеОбъекта.ИНН=Строка(Выборка.ИНН);
        ОписаниеОбъекта.НомерСвидетельства=Строка(Выборка.НомерСвидетельства);
        ОписаниеОбъекта.КодПоЕДРПОУ=Строка(Выборка.КодПоЕДРПОУ);
        ОписаниеОбъекта.ФизическоеЛицо=Строка(Выборка.ФизическоеЛицо);
        ОписаниеОбъекта.НаименованиеПолное=Строка(Выборка.НаименованиеПолное);
        ОписаниеОбъекта.СвидетельствоСерияНомер=Строка(Выборка.СвидетельствоСерияНомер);
        ОписаниеОбъекта.СвидетельствоДатаВыдачи=Строка(Выборка.СвидетельствоДатаВыдачи);
        ОписаниеОбъекта.БанковскийСчетПоУмолчанию=Строка(Выборка.БанковскийСчетПоУмолчанию);
        ОписаниеОбъекта.ЮрФизЛицо=Строка(Выборка.ЮрФизЛицо);
        ОписаниеОбъекта.ТекущийРуководитель=Строка(Выборка.ТекущийРуководитель);
        ОписаниеОбъекта.ТекущаяДолжностьРуководителя=Строка(Выборка.ТекущаяДолжностьРуководителя);
        ОписаниеОбъекта.ТекущийГлавныйБухгалтер=Строка(Выборка.ТекущийГлавныйБухгалтер);
        ОписаниеОбъекта.ТекущийКассир=Строка(Выборка.ТекущийКассир);
        ОписаниеОбъекта.ТекущийПаспортист=Строка(Выборка.ТекущийПаспортист);
        ОписаниеОбъекта.ТипОрганизации=Строка(Выборка.ТипОрганизации);
        ОписаниеОбъекта.УчетнаяЗаписьЭлектроннойПочты=Строка(Выборка.УчетнаяЗаписьЭлектроннойПочты);
        ОписаниеОбъекта.НазваниеДляСвернутыхУслуг=Строка(Выборка.НазваниеДляСвернутыхУслуг);
        ОписаниеОбъекта.ИнформацияПредупреждениеНовойКвитанции=Строка(Выборка.ИнформацияПредупреждениеНовойКвитанции);
             // ОписаниеОбъекта.Контрагент = Строка(Заказ.Контрагент);
        Массив_записи.Добавить(ОписаниеОбъекта);
    КонецЦикла;
      
      
       СериализаторXDTO.ЗаписатьJSON(ЗаписьJSON,Массив_записи,НастройкиСериализации);     //НастройкиСериализации
       ЗаписьJSON.ЗаписатьКонецОбъекта();
Просмотров: 118, последний комментарий от svetas_l   
RSS Текстовая версия Сейчас: 24.09.20, 17:41
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!