Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Пошук точної фрази в списку номенклатури [раздел Вся 1С]
Автор slavikdr — 06.10.22, 12:03 — 1 комментариев
Доброго дня. Задача виникла зі збільшенням кількості товарів, не можу розібратись з функціоналом.
є куча товарів, назва в форматі
товар ВИРОБНИК МОДЕЛЬ НОМЕР. Причому номер часто повторюється в різних товарах. Так само це зустрічається в полі партномерів, які теж виведені в форму списку.
В стандартному пошуку форми списку пробую шукати товари, наприклад МОДЕЛЬ НОМЕР, і видає все що має і МОДЕЛЬ і НОМЕР.
Тобто воно шукає товари по кожному слово окремо. В розширеному пошуку можна зробити відбір по точній фразі, але таке не підходить, бо треба робити пошук по всіх полях зі списку - і в назві, і в партномері.
Питання - як в стандартному пошуку добитись відповідності по точній фразі, щоб шукало тільки обидва входження але по всіх полях довідника?
Ніби проста задача, і воно має бути якось реалізовано на рівні платформи, але я вже пів дня гуглю - все без толку.
Просмотров: 26, последний комментарий от AnryMc   
проблема адаптации обработки [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 05.10.22, 10:18 — 0 комментариев
при открытии сторонней обработки были ошибки в строках, я поправил обрабока открылась, но не работают другие функции, подозреваю что неправильно адаптировал
//ИдентификаторКонфигурации = глИдентификаторКонфигурации(); - было с (), поставил без () и ошибка пропала
ИдентификаторКонфигурации = глРедакцияКонфигурации;
//СуммаЭксп = СокрЛ(Формат(глПересчет(Сумма,Валюта,Гривна,Курс,ДатаДок),"Ч17.2.")); - Курс и ДатаДок пришлось убрать но наверно из-за этого не работает сама обработка
СуммаЭксп = СокрЛ(Формат(глПересчетВалютыПоКурсу(Сумма,Валюта,Гривна),"Ч17.2.")); - тут может быть ошибка
Просмотров: 65, оставить комментарий   
Уменьшение ежегодного отпуска при неявках (НЗ) [раздел 1С Зарплата и Управление Персоналом 8]
Автор Tormal — 03.10.22, 13:58 — 3 комментариев
Зарплата и Управление Персоналом для Украины, редакция 2.1 (2.1.66.1)

В связи с войной, на многих предприятиях, особенно прифронтовой зоны (где много эвакуировавшихся), кадровики табелируют кодом "Невыход по невыясненной причине" (нз).
И это продолжается месяцами.

Но согласно законодательства, НЗ - не дает права на ежегодный отпуск (как прогул, отпуск по уходу до 3 лет и т.д.).
Каждые 15 календарных НЗ дней - это минус 1 день основного отпуска.

Сейчас остро встал вопрос при расчете предоставляемого отпуска и при увольнении (компенсация не отгулянного).

В ЗУПе есть только регистр Положенные ежегодные отпуска, где ставят - 24.

Поделитесь: у кого как решают проблему расчета? (кол-во сотрудников - под 1000)
Просмотров: 94, последний комментарий от One   
Настройка документа "Прием на работу в организацию" - Взносы на фот [раздел Управление торговлей для Украины редакция 2 (Управление торговлей для России редакция 10)]
Автор Нонна — 02.10.22, 10:58 — 2 комментариев
1С:Предприятие 8.3 (8.3.15.1869) "Управление торговым предприятием для Украины", редакция 1.2. (1.2.62.1) (http://1c.ua/v8/RegionalSolutions_UA_UTP.php)
Copyright © Molenari OU, 2017-2021. All rights reserved
Добрый день. Предприятие только начинает работать. Принимаю на работу нового первого сотрудника. Документ Прием на работу в организацию. Во воторой табличке есть только вкладки Начисления и удержания. Вопрос: Как добавить вкладку : взносы на ФОТ? Очевидно нет каких то настроек этой новой фирмы?
Просмотров: 85, последний комментарий от Нонна   
Оновити обробку в "Додаткових звітах та обробках" (програмно [раздел Программирование в 1С Предприятие 8.3]
Автор Inkognito — 29.09.22, 8:57 — 6 комментариев
BAS Бухгалтерія 2.1
Необхідно оновити обробку в переліку "Додаткових звітів та обробок" програмно (додавання реалізовано, але необхідно саме оновленнія, якщо версія поточна вище):

Код

&НаКлиенте
Процедура Тест()
ОбработкаСсылка = ПолучитьСсылкуОбработки();

Если НЕ ОбработкаСсылка.Пустая() Тогда            
         знВерсии= УзнатьВерсиюОбработки(ОбработкаСсылка);
        
         Если знВерсии<АктуальнаяВерсия Тогда
//???
//припустимо, нова обробка тут: КаталогВременыхФайлов() + "ВнешняяОбработка2";
КонецЕсли;
КонецЕсли;


&НаСервере
Функция ПолучитьСсылкуОбработки()
    
    Возврат Справочники.ДополнительныеОтчетыИОбработки.НайтиПоРеквизиту("ИмяФайла", "ВнешняяОбработка1");

КонецФункции

&НаСервере
Функция УзнатьВерсиюОбработки(ОбработкаСсылка)
    
    Возврат ОбработкаСсылка.Версия;
    
КонецФункции
Просмотров: 203, последний комментарий от sava1   
Продам дешево конфигурацию для СТО (полный аналог Альфа-Авто) [раздел 1С:Предприятие 8]
Автор f12 — 29.09.22, 8:35 — 0 комментариев
Есть в наличии для продажи конфигурация для СТО (Автосалон+СТО+Продажа автозапчастей) Конфигурация для Украины. Цена дешевая - 500 грн. Полный аналог конфигурации Альфа-Авто, но без защиты. По функционалу намного круче чем Альфа-Авто
Несколько лет тому назад работал сис.админом в автосалоне, вот и приберег ее себе при увольнении с работы.
Предлагаю cf-файл + рабочая демка с введенными данными. Если кому интересно, то пишите в личку. Готов продемонстрировать удаленно как она выглядит и ее функционал.
Просмотров: 100, оставить комментарий   
Поделитесь BAS СТО [раздел Офф-топик]
Автор barabambler — 25.09.22, 12:47 — 2 комментариев
Будьте добры, поделитесь конфигурацией BAS СТО. Очень нужно! Заранее благодарен!
Просмотров: 165, последний комментарий от barabambler   
не могу передать значение с таблицы [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 23.09.22, 17:00 — 5 комментариев
    КоличествоСтрок = спДанные.Получить("КоличествоСтрок");
    Для ном = 1 По КоличествоСтрок Цикл
        ТекСтрока = "R" + Прав("000" + ном,4);
        rsMain.Fields.Item("TAB1_A1").Value = ном;
        rsMain.Fields.Item("TAB1_NOMENKLATURA_NAME").Value = спДанные.Получить(ТекСтрока + "ТоварНаименование");
        rsMain.Fields.Item("TAB1_OV_NAME").Value = спДанные.Получить(ТекСтрока + "Единица");
        rsMain.Fields.Item("TAB1_A3").Value = спДанные.Получить(ТекСтрока + "Количество");
        rsMain.Fields.Item("TAB1_A5").Value = спДанные.Получить(ТекСтрока + "ЦенаБезНДС");
        rsMain.Fields.Item("TAB1_A6").Value = спДанные.Получить(ТекСтрока + "Сумма");
        rsMain.Post();
        Если ном <> КоличествоСтрок Тогда
            rsMain.Append();
        КонецЕсли;
    КонецЦикла;


ошибка:

rsMain.Fields.Item("TAB1_OV_NAME").Value = спДанные.Получить(ТекСтрока + "Единица");
Неизвестная ошибка


заработало
Просмотров: 300, последний комментарий от 4andriy   
запуск 1с на windows xp и 7 паралельно [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 23.09.22, 14:33 — 1 комментариев
1с 7.7
если запустить на windows xp - работает
если запустить на windows 7 ошибка:
порядок сортировки, установленный для базы данных отличасется от системного
тогда надо менять сортировку и тогда на xp не работает( и опять менять сортировку
Просмотров: 132, последний комментарий от denis84   
Не работает выборка документов [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 23.09.22, 12:41 — 3 комментариев
при выборке документов така ошибка:

Цитата
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: СуммаБезНДС = Документ.РасходнаяНакладная. <<?>> СуммаБезНДС;
Запрос[7] : Неверно заданный путь 'СуммаБезНДС'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: СуммаСНДС = Документ.РасходнаяНакладная. <<?>> СуммаСНДС;
Запрос[8] : Неверно заданный путь 'СуммаСНДС'
СУММАБЕЗНДС<<?>>
Переменная не определена (СУММАБЕЗНДС)
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: Функция СуммаБезНДС_ = Сумма(СуммаБезНДС <<?>> );
Запрос[9] : Ошибка в выражении 'СуммаБезНДС'
СУММАСНДС<<?>>
Переменная не определена (СУММАСНДС)
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: Функция СуммаСНДС_ = Сумма(СуммаСНДС <<?>> );
Запрос[10] : Ошибка в выражении 'СуммаСНДС'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: Условие(Фирма в ВыбФирма <<?>> );
Запрос[14] : Ошибка в условии
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: Условие(Контрагент в список <<?>> );
Запрос[15] : Ошибка в условии
Просмотров: 187, последний комментарий от denis84   
ошибка при открытии обработки [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 22.09.22, 18:31 — 1 комментариев
ИдентификаторКонфигурации = глРедакцияКонфигурации();

Спр = СоздатьОбъект("Справочник.Пользователи");
Если ИдентификаторКонфигурации = "UBUTK" Тогда //Бухгалтерский учет для Украины    
    Если Спр.НайтиПоНаименованию(ИмяПользователя(), 1) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
ИначеЕсли ИдентификаторКонфигурации = "UBUOUSL" Тогда //"Бухгалтерия+Торговля+Склад+Зарплата+Кадры" для Украины
    спВидиДокументів.ВставитьЗначение(5,"Т_РасходнаяНакладная","Видаткова накладна (товари)");
    Если Спр.НайтиПоКоду(ИмяПользователя(), 0) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
ИначеЕсли ИдентификаторКонфигурации = "UManf" Тогда //Производство+Услуги+Бухгалтерия для Украины
    Если Спр.НайтиПоКоду(ИмяПользователя(), 0) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
ИначеЕсли ИдентификаторКонфигурации = "UOUTK" Тогда //Торговля+Склад для Украины
    ОказаниеУслугНом = спВидиДокументів.НайтиЗначение("ОказаниеУслуг");
    Если ОказаниеУслугНом > 0 Тогда
        спВидиДокументів.УдалитьЗначение(ОказаниеУслугНом);
    КонецЕсли;
    Если Спр.НайтиПоКоду(ИмяПользователя(), 0) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
Иначе
    ТекущийПользователь = "";
КонецЕсли;


в глобальном модуле есть:
Перем глРедакцияКонфигурации Экспорт;//это для сравнения редакции конфигурации и константы "РедакцияКонфигурации"


ошибка:
ИдентификаторКонфигурации = глРедакцияКонфигурации<<?>>();
...: Функция не обнаружена (глРедакцияКонфигурации)
Просмотров: 143, последний комментарий от denis84   
При попытке сделать начисление за месяц не тянется ни услуга ни тариф [раздел Остальные конфигурации 1С 8]
Автор kot488 — 21.09.22, 14:19 — 2 комментариев
Может кто то работал с конфигурацией Хвоя ОСББ. Проблема в следующем, создана организация, заполнены справочники, все по их видеоинструкции. Но при попытке сделать начисление за месяц попросту не тянется ни услуга ни тариф.
Может кто то стыкался с этой конфигурацией?
Просмотров: 184, последний комментарий от kot488   
Борг покупця в різних валютах - як вирівняти? [раздел 1С Управление небольшой фирмой для Украины]
Автор slavikdr — 20.09.22, 9:42 — 5 комментариев
Є клієнт з яким працюємо давно. Його договір - в грн.
Валюта обліку в базі - долар.
Якщо сформувати звіт взаєморозрахунків, його борг в грн - ноль. в доларі - 6 дол.
Як ця ситуація виникла - визначити важко, курси постійно мінялись, і кількість документів достатньо велика - видаткові, повернення, касові.
Чи є можливість якось підрівняти борг, списати той борг в доларах без зміни боргу в грн?
Пробував коригування боргу покупця - не виходить.
Просмотров: 234, последний комментарий от Gazulo   
Создание документа Заказ поставщику на основе заказы покупателей [раздел 1С Управление небольшой фирмой для Украины]
Автор vadimgrig — 18.09.22, 0:11 — 0 комментариев
Платфорама 8.3, Конфигурация УНФ 1.6

Приветствую всех.

Нужно понять как настроить возможность создания документа Заказ поставщику, на основе нескольких документов Заказы покупателей.
Можно ли это сделать в настройках, или нужны какие то сложные операции?

Заранее спасибо.

Спасибо всем кто прочитал. Был не внимателен. Решение нашел самостоятельно. Проведенные документы Заказы покупателей, появляются во второй вкладке меню заказ поставщику, где можно сделать групповой выбор и создать один документ.
Просмотров: 139, оставить комментарий   
Вивантаження Акта звірки в xml для завантаження в Медок [раздел Программирование в 1С Предприятие 7.7]
Автор kostya77 — 15.09.22, 11:54 — 4 комментариев
Добрий день. Підкажіть, можливо хто вирішував подібну задачу, як реалізувати?
Просмотров: 234, последний комментарий от mut   
Прорахунок кілометража між точками по координатам [раздел Вся 1С]
Автор wargys1986 — 14.09.22, 15:25 — 3 комментариев
Доброго дня. Поставили задачу, прорахунок кілометража між точками по координатам , та промальовка маршрута. Хто з цим стикався ? Дякую Всім хто відгукнеться
Просмотров: 270, последний комментарий от mut   
FF день [раздел Офф-топик]
Автор sava1 — 13.09.22, 8:45 — 2 комментариев
Всех с днюхой, ПОГРОММисты !!!
Просмотров: 386, последний комментарий от Vofka   
Яким звітом можна подивитись залишок відпусток на дату по працівнику? [раздел 1С Управление Торговым Предприятием 8]
Автор Xmdrug — 07.09.22, 15:02 — 3 комментариев
Конфигурация 1С:Підприємство 8.3 (8.3.9.2309), Управление торговым предприятием для Украины", редакция 1.2. (1.2.41.1). Яким звітом можна подивитись залишок відпусток на дату по працівнику?
Просмотров: 958, последний комментарий от Gazulo   
Підключення з 1с7 до 1с8 для запуску обробки [раздел Программирование в 1С Предприятие 7.7]
Автор kostya77 — 06.09.22, 10:46 — 3 комментариев
Добрий день. Підкажіть, чи можливо з 1с7 підключитися до 1с8 і в 1с8 запустити обробку?
Просмотров: 288, последний комментарий от sava1   
Заміна 1С [раздел Офф-топик]
Автор Vadim67567567 — 05.09.22, 13:02 — 22 комментариев
Добрий день!

Що далі? Яка доля платформи, це все?
Процес розпочато? https://mezha.media/2022/09/01/dubilet-zapuskaie-navkolo/

Які Ваші думки, з цього приводу. Цікаво.

Які прогнози життєздатності?
Просмотров: 758, последний комментарий от caballero   
RSS Текстовая версия Сейчас: 06.10.22, 17:12
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!