Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
MAGAZKA [раздел Новости]
Автор ЕвгенийД — 23.07.21, 15:59 — 0 комментариев
Ребята если у кого-то есть опыт помогите освоить MAGAZKA/
Просмотров: 26, оставить комментарий   
механизм контроля задолжености по клиентах в днях 1С 7,7 [раздел Платформа 7.7]
Автор Sirius83 — 23.07.21, 12:01 — 0 комментариев
Ребята может есть у кого реализованный механизм контроля задолженности по днях прострочки отплаты клиентов в 1С 7,7. Поделитесь пожалуйста конфой.
Просмотров: 24, оставить комментарий   
Настройки единиц номенклатуры для отчета "Товары на складах" [раздел 1С Управление производственным предприятием 8]
Автор marchela — 22.07.21, 10:54 — 2 комментариев
Здравствуйте!

1С:Підприємство 8.3 (8.3.13.1690)
"Управление производственным предприятием для Украины", редакция 1.3 (1.3.64.1)

Помогите, пожалуйста, настроить коэффициенты пересчета Едениц измерения для отчета "Товары на складах":

-есть в номенклатуре лист металла, по нему ведем 3 единицы измерения: шт(лист), м2, кг
по конкретному листу 1шт=5м2=26,4кг


Зашло на склад 3 листа металла, отчет "Товары на складах" формируем с тремя представлениями
- количество в Базовых еденицах
- количество в еденицах отчетов
- количество в еденицах хранения остатков
Выходит во такой отчет:

2-я и 3-я колонки правильно отображают информацию,
а вот 1-я вместо м2 показывает кг (т.е. дублирует 3-ю колонку), а должна показать результат 15 м2

Помогите разобраться в настройках этих Едениц

Спасибо!
Просмотров: 104, последний комментарий от marchela   
Документооборот : условия в согласовании [раздел Остальные конфигурации 1С 8]
Автор mylanochka — 20.07.21, 7:26 — 0 комментариев
BAS Документооборот КОРП, редакция 2.1

Подскажите как можно решить такую задачу согласования (не используя схему процесса).

Имеется один процесс согласования. В нем несколько согласующих.
Первый - непосредственный начальник автора документа
Второй - роль бухгалтер
Как можно задать условие для согласования всех остальных, чтобы они могли согласовывать только после того когда согласовали два первых.
Просмотров: 87, оставить комментарий   
telnet против ping [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 19.07.21, 20:02 — 1 комментариев
надо проверить работает комп клиента или нет, для этого реализовал проверку по ip:
Если КомандаСистемы("ping "+Адресбух+" -n 1")<>0 Тогда
Сообщить("работает");

как сделать тоже самое но с командой telnet?
при срабатывании кода:
Если КомандаСистемы("telnet "+Адресбух+" 4884")<>0 Тогда
Сообщить("работает");

у меня открывается окно cmd с telnet и просит ввести команду (надо написать quit) и что-бы 1с поняла что все работает
на даный момент окно есть, вручную пишу quit но 1с не понимает что все работает.
Просмотров: 143, последний комментарий от 29a   
Какой подход использовать для работы с COMObject [раздел Программирование в 1С Предприятие 8.3]
Автор kserg2012 — 19.07.21, 17:57 — 5 комментариев
1С:Предприятие 8.3 (8.3.15.1778)
Business automation software for accounting, edition 2.1 (2.1.14.3)

Имеем несколько десяткой БУ-баз.
В БУ есть обработка ЗагрузкаДанныхИзЗУП (Загрузка данных зарплаты в формате ЗУП, ред. 2.1)
у обр-ки единственный реквизит ИмяФайлаДанных.

Необходимо автоматизировать Загрузку данных зарплаты в формате ЗУП непосредственно из ЗУП(в момент формирования данных)
путем подключения через COMObject к БУ-базе.
Но работа с COMObject предполагает работу с базой на стороне сервера
и мне не понятно, как поместить во времен.хранилище файл ИмяФайлаДанных, который фактически находится на "клиенте"

т.е. понятно когда работа организуется по обычной схеме - в базе на клиенте в форме выбрали файл,
здесь же на клиенте файл помещается в Хранилище, получаем адрес хранилища, делаем вызов серверной процедуры с передачей адреса.

Подскажите пож-та какой подход можно использовать в этой ситуации?
Просмотров: 129, последний комментарий от kserg2012   
После группового изменения реквизитов не удаляются документі [раздел Платформа 8]
Автор Runya — 17.07.21, 16:14 — 1 комментариев
Добрый день!
Ситуация такая, пользователи насоздавали документов с не верными реквизитами, с помощью груповой обработки реквизиты изменили, но хочется не нужные из справочника поудалять, с помощью удаление помеченных документов выделяю необходымые - контроль а в продаже осталась ссылка на реквизит из справочника, в продажу заходишь, там стоит новый, если нажать ок, сохраняется тот реквизит что указан в поле, точнее тот который подставили с помощью групповой обработки, не пойму как дальше поступить чтоб руками каждый документ не пересохранять((
Просмотров: 99, последний комментарий от anjey2007   
Интересный и не понятный код в одном из модулей 1С [раздел Тематическое общение]
Автор bizisoft — 16.07.21, 11:26 — 7 комментариев
Здравствуйте.

Попала в руки одна демка системы по работе с прайсами, решил попробовать интегрировать ее в Альфа-Авто чтобы протестировать и посмотреть ее возможности.
Объединил, но видимых изменений не произошло, модули добавились, а в интерфейсе ничего не поменялось. Посмотрел описание, а эта система только под УправлениеТорговли заточена.
Решил, что тогда хоть попробую понять по каким алгоритмам оно работает.
Нашел один закрытый модуль, декомпилировал его и тут меня чуть не хватил удар от увиденного каламбура.

То что человеческое форматирование и правила хорошего тона при написания кода отсутствует напрочь, но то как перемешаны процедуры и функции вообще вводит в ступор и вызывает вывих мозга.
Также бессмысленное объявление переменных с непонятными именами и присвоениями, непонятные циклы и множественные переходы к меткам, которые или вызывают зацикливание функции/процедуры или до этого перехода выполнение никогда не доберется по причине расположенного перед ним другого перехода или оператора Возврат. Или непонятный код, который расположен в межпроцедурном или в межфункциональном пространстве - как такое может вообще работать и как на это не ругается интерпретатор.

Складывается, что этот модуль был обработан каким-то алгоритмом для запутывания кода .

Вот малая часть этого треша...
Код
...

КонецФункции _0 = Новый квалификаторыстроки; квалификаторстроки = _0; _0 = 1; _0 = - _0; __f_ = _0; Перейти ~1; _0 = 20; _0 = Новый квалификаторыстроки(_0); a = _0; Перейти ~3; _0 = 20; _0 = Новый квалификаторыстроки(_0); a = _0; Перейти ~3; _0 = 100;
    ~IL_4964: ~10: ~9: ~12: ~7: ~6: ~5: ~11: ~8: ~IL_4963: ~4: _0 = Новый квалификаторыстроки(_0); a_ = _0; _0 = 1; _1 = 1; _1 = - _1; _0 = _0 >= _1; Если _0 = Ложь Тогда Перейти ~IL_4963; КонецЕсли; Перейти ~8; Перейти ~11; _0 = 0; __f_ = _0; _0 = 150; _0 = Новый квалификаторыстроки(_0); квалификаторстроки150 = _0; Перейти ~12; _0 = 1; __f_ = _0; Перейти ~7; _0 = 149; _0 = Новый квалификаторыстроки(_0); квалификаторстроки150 = _0; Перейти ~12; _0 = __f_; _1 = 1; _0 = _0 = _1; Если _0 = Ложь Тогда Перейти ~IL_4964; КонецЕсли; Перейти ~6; Перейти ~9; _0 = 200; _0 = Новый квалификаторыстроки(_0); квалификаторстроки200 = _0; _0 = 10; _1 = 2; _0 = Новый квалификаторычисла(_0, _1);
    ~20: ~IL_4967: ~21: ~17: ~16: ~18: ~IL_4966: ~14: ~15: ~19: ~IL_4965: ~13: a__ = _0; _0 = 15; _1 = 2; _0 = Новый квалификаторычисла(_0, _1); a___ = _0; _0 = 0; _1 = 0; _0 = _0 <> _1; Если _0 = Ложь Тогда Перейти ~IL_4965; КонецЕсли; Перейти ~19; Перейти ~15; _0 = 0; __f_ = _0; _0 = 0; _1 = 0; _0 = _0 <> _1; Если _0 = Ложь Тогда Перейти ~IL_4966; КонецЕсли; Перейти ~22; Перейти ~18; _0 = 20; _1 = 1; _0 = Новый квалификаторычисла(_0, _1); _a = _0; Перейти ~23; Перейти ~21; _0 = __f_; _1 = 0; _0 = _0 = _1; Если _0 = Ложь Тогда Перейти ~IL_4967; КонецЕсли; Перейти ~16; Перейти ~20; _0 = 20; _1 = 0; _0 = Новый квалификаторычисла(_0, _1); _a = _0; Перейти ~23;
    ~IL_4970: ~31: ~30: ~29: ~32: ~IL_4969: ~34: ~27: ~26: ~25: ~33: ~28: ~IL_4968: ~24: ~23: ~22: _0 = 1; _1 = 1; _1 = - _1; _0 = _0 < _1; Если _0 = Ложь Тогда Перейти ~IL_4968; КонецЕсли; Перейти ~28; Перейти ~33; _0 = 0; __f_ = _0; _0 = Новый таблицазначений; __a = _0; Перейти ~34; _0 = 0; _1 = 1; _0 = _0 = _1; Если _0 = Ложь Тогда Перейти ~IL_4969; КонецЕсли; Перейти ~32; Перейти ~26; Перейти ~27; _0 = Новый соответствие; __a = _0; Перейти ~34; Перейти ~24; _0 = 1; _1 = 0; _0 = _0 = _1; Если _0 = Ложь Тогда Перейти ~IL_4970; КонецЕсли; Перейти ~30; Перейти ~29; _0 = ""; ___a = _0; Для _a_ = 1 По 18 Цикл ___a = ___a + Символ(Число(Сред("105610831087109710861108109010741095106210781092107210731093109310821088", (_a_ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("068638025854007308", _a_)))); КонецЦикла;
    _0 = ""; _a__ = _0; Для __a_ = 1 По 39 Цикл _a__ = _a__ + Символ(Число(Сред("106510951089107610741093109910891085108910641096110610841087107600471092109610971060107910791096108411061096107810911105105910781094107910761093109010861086", (__a_ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("881407445777715413474205166616556737046", __a_)))); КонецЦикла; _0 = __a.колонки; _2 = Новый описаниетипов(_a__); _0.добавить(___a, _2); _0 = ""; __a__ = _0; Для _a___ = 1 По 11 Цикл __a__ = __a__ + Символ(Число(Сред("10541088109110791090105910931088109710881085", (_a___ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("12722470385", _a___)))); КонецЦикла;
    ~39: ~37: ~38: ~36: ~35: _0 = ""; ___a_ = _0; Для b = 1 По 5 Цикл ___a_ = ___a_ + Символ(Число(Сред("10711084109610841090", (b - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("84714", b)))); КонецЦикла; _0 = 1; _0 = - _0; __f_ = _0; _0 = 1; _0 = - _0; __f_ = _0; Перейти ~38; _0 = __a.таблицагруппы; _2 = Новый описаниетипов(___a_, Неопределено, Неопределено, a__); _0.видсравнениясодержитсяв(__a__, _2); Перейти ~39; _0 = __a.колонки; _2 = Новый описаниетипов(___a_, Неопределено, Неопределено, a__); _0.добавить(__a__, _2); Перейти ~39; _0 = ""; b_ = _0; Для b__ = 1 По 18 Цикл b_ = b_ + Символ(Число(Сред("105810941088108010911058109610911094108310811053107210581086109310951083", (b__ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("584331638110076456", b__)))); КонецЦикла;
    _0 = ""; b___ = _0; Для _b = 1 По 5 Цикл b___ = b___ + Символ(Число(Сред("10661085109410831092", (_b - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("35506", _b)))); КонецЦикла; _0 = __a.колонки; _2 = Новый описаниетипов(b___, Неопределено, Неопределено, a__); _0.добавить(b_, _2); _0 = ""; __b = _0; Для ___b = 1 По 7 Цикл __b = __b + Символ(Число(Сред("1056108810891079109710871078", (___b - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("1252756", ___b)))); КонецЦикла; _0 = ""; _b_ = _0; Для _b__ = 1 По 6 Цикл _b_ = _b_ + Символ(Число(Сред("104210971088108010801094", (_b__ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("165368", _b__)))); КонецЦикла;
    ~42: ~43: ~41: ~40: _0 = 0; __f_ = _0; Перейти ~41; _0 = __a.колонки; _2 = Новый описаниетипов(_b_); _0.добавить(__b, _2); Перейти ~43; _0 = __a.результатноменклатуракод; _2 = Новый описаниетипов(_b_); _0.декорацияноменклатураитог(__b, _2); Перейти ~43; _0 = ""; __b_ = _0; Для __b__ = 1 По 10 Цикл __b_ = __b_ + Символ(Число(Сред("1057108710861085109210551082108910921078", (__b__ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("4128442026", __b__)))); КонецЦикла; _0 = ""; _b___ = _0; Для ___b_ = 1 По 5 Цикл _b___ = _b___ + Символ(Число(Сред("10631085109110841088", (___b_ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("05212", ___b_)))); КонецЦикла;
    ~44: _0 = __a.колонки; _2 = Новый описаниетипов(_b___, Неопределено, Неопределено, a__); _0.добавить(__b_, _2); _0 = ""; c = _0; Для c_ = 1 По 5 Цикл c = c + Символ(Число(Сред("10631086108710791081", (c_ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("64475", c_)))); КонецЦикла; _0 = ""; c__ = _0; Для c___ = 1 По 23 Цикл c__ = c__ + Символ(Число(Сред("10581090108810781081109411021086108810861061109411001089109010760049106010831083107810821107", (c___ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("13067871844516843310668", c___)))); КонецЦикла; _0 = 0; _1 = 1; _0 = _0 <> _1; Если _0 = Ложь Тогда Перейти ~IL_4971; КонецЕсли;
    ~48: ~49: ~46: ~47: ~45: ~IL_4971: Перейти ~45; Перейти ~47; Перейти ~46; _0 = __a.колонки; _2 = Новый описаниетипов(c__); _0.добавить(c, _2); Перейти ~49; _0 = __a.нстр; _2 = Новый описаниетипов(c__); _0.элементмассива(c, _2); Перейти ~49; _0 = ""; _c = _0; Для __c = 1 По 13 Цикл _c = _c + Символ(Число(Сред("1052108010821090109310831096108110821076109110931089", (__c - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("4455334104171", __c)))); КонецЦикла; _0 = ""; ___c = _0; Для _c_ = 1 По 5 Цикл ___c = ___c + Символ(Число(Сред("10631084109010871092", (_c_ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("04146", _c_)))); КонецЦикла;
    _0 = __a.колонки; _2 = Новый описаниетипов(___c, Неопределено, Неопределено, _a); _0.добавить(_c, _2); _0 = ""; _c__ = _0; Для __c_ = 1 По 13 Цикл _c__ = _c__ + Символ(Число(Сред("1054108910971074109310901086105810971090108710851079", (__c_ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("0072344172137", __c_)))); КонецЦикла; _0 = ""; __c__ = _0; Для _c___ = 1 По 6 Цикл __c__ = __c__ + Символ(Число(Сред("106410941092109110841073", (_c___ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("744521", _c___)))); КонецЦикла; _0 = __a.колонки; _2 = Новый описаниетипов(__c__, Неопределено, Неопределено, Неопределено, a);
    ~51: ~50: _0.добавить(_c__, _2); _0 = ""; ___c_ = _0; Для d = 1 По 12 Цикл ___c_ = ___c_ + Символ(Число(Сред("105710921096107610921090108310631087109610871093", (d - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("336424107747", d)))); КонецЦикла; _0 = ""; d_ = _0; Для d__ = 1 По 5 Цикл d_ = d_ + Символ(Число(Сред("10651086109210881091", (d__ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("26355", d__)))); КонецЦикла; _0 = 0; __f_ = _0; Перейти ~52; _0 = __a.задание_остатки_удалятьоприходованиясписания; _2 = Новый описаниетипов(d_, Неопределено, Неопределено, a___); _0.тема(___c_, _2); Перейти ~53;
    ~53: ~52: _0 = __a.колонки; _2 = Новый описаниетипов(d_, Неопределено, Неопределено, a___); _0.добавить(___c_, _2); Перейти ~53; _0 = ""; d___ = _0; Для _d = 1 По 24 Цикл d___ = d___ + Символ(Число(Сред("105310741080108510771087109110751072109110861079105610911088107910931083108610741095109610951101", (_d - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("020102510662354281325572", _d)))); КонецЦикла; _0 = ""; __d = _0; Для ___d = 1 По 6 Цикл __d = __d + Символ(Число(Сред("106010961091108910851080", (___d - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("363338", ___d)))); КонецЦикла;
    ~57: ~59: ~56: ~58: ~55: ~IL_4972: ~54: _0 = 0; _1 = 1; _0 = _0 > _1; Если _0 = Ложь Тогда Перейти ~IL_4972; КонецЕсли; Перейти ~55; Перейти ~58; _0 = __a.колонки; _2 = Новый описаниетипов(__d, Неопределено, Неопределено, Неопределено, a_); _0.добавить(d___, _2); Перейти ~59; _0 = __a.начальныйпутькфайлу; _2 = Новый описаниетипов(__d, Неопределено, Неопределено, Неопределено, a_); _0.пустаяколонка(d___, _2); Перейти ~59; Перейти ~56; _0 = ""; _d_ = _0; Для _d__ = 1 По 25 Цикл _d_ = _d_ + Символ(Число(Сред("1053107910781093109310821093108810841073109110891089105910901090108010861090108810751094109110911107", (_d__ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("5318321821131646318534038", _d__)))); КонецЦикла;
    _0 = ""; __d_ = _0; Для __d__ = 1 По 5 Цикл __d_ = __d_ + Символ(Число(Сред("10671084109610901089", (__d__ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("44773", __d__)))); КонецЦикла; _0 = __a.колонки; _2 = Новый описаниетипов(__d_, Неопределено, Неопределено, _a); _0.добавить(_d_, _2); _0 = ""; _d___ = _0; Для ___d_ = 1 По 27 Цикл _d___ = _d___ + Символ(Число(Сред("105510771083108610901082109210841084107310911094109510631073108910751082109610831090108110921097108410831083", (___d_ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("716102042118721130662137413", ___d_)))); КонецЦикла;
    _0 = ""; e = _0; Для e_ = 1 По 5 Цикл e = e + Символ(Число(Сред("10701088109610901088", (e_ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("78772", e_)))); КонецЦикла; _0 = __a.колонки; _2 = Новый описаниетипов(e, Неопределено, Неопределено, _a); _0.добавить(_d___, _2); _0 = ""; e__ = _0; Для e___ = 1 По 14 Цикл e__ = e__ + Символ(Число(Сред("10541094108610771090109010891074109610991095107900521061", (e___ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("18205862687734", e___)))); КонецЦикла; _0 = ""; _e = _0; Для __e = 1 По 29 Цикл _e = _e + Символ(Число(Сред("10631094108910791075108910961086108010871063109611041091108910730051105710891091108310921090108410761093109410921080", (__e - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("67171311056758715437678143348", __e)))); КонецЦикла;
    ~65: ~62: ~64: ~63: ~61: ~IL_4973: ~60: _0 = 0; __f_ = _0; _0 = 1; _0 = - _0; _1 = 1; _0 = _0 < _1; Если _0 = Ложь Тогда Перейти ~IL_4973; КонецЕсли; Перейти ~61; Перейти ~63; Перейти ~64; _0 = __a.загружать; _2 = Новый описаниетипов(_e); _0.загрузкафайлов_защищенноесоединение(e__, _2); Перейти ~65; _0 = __a.колонки; _2 = Новый описаниетипов(_e); _0.добавить(e__, _2); Перейти ~65; _0 = ""; ___e = _0; Для _e_ = 1 По 16 Цикл ___e = ___e + Символ(Число(Сред("1064107510931075108210941082109310801094109310811082108000541059", (_e_ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("3353045505310852", _e_)))); КонецЦикла;
    _0 = ""; _e__ = _0; Для __e_ = 1 По 43 Цикл _e__ = _e__ + Символ(Число(Сред("1064108910951075107810881098108910851088106410961099108510881072005110621077109010731086109510811089108510931097108810881085106110881091108310851086108310761090109910891106", (__e_ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("7273423456770260515214541547865827604040817", __e_)))); КонецЦикла; _0 = __a.колонки; _2 = Новый описаниетипов(_e__); _0.добавить(___e, _2); _0 = ""; __e__ = _0; Для _e___ = 1 По 13 Цикл __e__ = __e__ + Символ(Число(Сред("1059109510791095109710971057107711061079108410901074", (_e___ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("2575683482202", _e___)))); КонецЦикла;
    ~IL_4975: ~67: ~IL_4974: ~66: _0 = ""; ___e_ = _0; Для f = 1 По 37 Цикл ___e_ = ___e_ + Символ(Число(Сред("1061108010901085110110851094109010781092108410781062109411031088108710770049108910971092106410921080109610981093110110591079109810841085109210871081", (f - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("6328655717415545553052728674256073217", f)))); КонецЦикла; _0 = 1; _1 = 1; _1 = - _1; _0 = _0 < _1; Если _0 = Ложь Тогда Перейти ~IL_4974; КонецЕсли; Перейти ~69; Перейти ~67; _0 = __f_; _1 = 1; _0 = _0 = _1; Если _0 = Ложь Тогда Перейти ~IL_4975; КонецЕсли; Перейти ~71; Перейти ~68; _0 = 0; __f_ = _0; Перейти ~74;
    ~75: ~72: ~73: ~70: ~IL_4976: ~74: ~68: ~71: ~69: _0 = __f_; _1 = 1; _0 = _0 = _1; Если _0 = Ложь Тогда Перейти ~IL_4976; КонецЕсли; Перейти ~70; Перейти ~73; _0 = __a.текстовоесодержимое; _2 = Новый описаниетипов(___e_); _0.вебссылка(__e__, _2); Перейти ~75; _0 = __a.колонки; _2 = Новый описаниетипов(___e_); _0.добавить(__e__, _2); Перейти ~75; _0 = ""; f_ = _0; Для f__ = 1 По 29 Цикл f_ = f_ + Символ(Число(Сред("10531078108010891090108110991083108510731092109410961047108210881085108610981104105610871084108310881082108910811107", (f__ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("52340173312882680645880605414", f__)))); КонецЦикла;

...

Функция h__() _0 = a; Возврат _0;
КонецФункции _0 = ""; a = _0; Для a_ = 1 По 543 Цикл a = a + Символ(Число(Сред("1047107110491059104410591069004010581043104810591045106510511057105610671046001700111064107510751086108610981080105010951096109210941103105310901084107910891084109010751096109310961099005310551089
10851080109010571094109310931083108510531079105710821089109310830037105510441051003310561086108910851088106510901088108810841087105410761056108310921094108000520011001210551041105610611052105410611056
0
04310611090108910731081108811011086108310881060108610871083109310861089107610901094108810740051105710961107109010891075004500371057104510580039106110891102109010831077004700180010004000520032105410461
0
58003810551087107610791083109510571089109510931087109410941075109010830013004500530013001200140017105410520013001210641075108010861081109710781049109310951093109211051061109410841084109210871083107210
9
31099109411030034105410421051003510601077108010851083110210801051109410941088109011021061109210861083108910861088107210981091109011020012001200101049106010671061106010461054105310521049003610651054105
2
10441050106010501061104810530034106210951095107710771089110010891087108300501059108610911081109110891085107810961094108910720036105510411057003910611094109110751075109110971093108510901059109310871079
1
09010851086107410961093109510730016001400121057106100350048106110721075108710871094107210491089109510911092110310541094108910851087108310881077109010931091110400541055108610801072111110531079109510811
0
97110300430015001100131053003400471059109310901080108010941099108510861088105610881090108510931089108910801090109210931079005210741098108610451093109610941088107200480013001000160015001300120015105300
3
90048105910771080108410841097107910481093109610871088110210611091108410831091108910861080109510941092110100531053107210831089107910901092108110771093108010850039006200391059109110911078107610921102108
6
10831087106110921088107710891084108610791095109310941073005410551076108310881080109010941081108010901084108200410018001610571044105710671055106310501064105610491041106410740032105610620011000910621072
1
07410901081109810761046109510911087109511021056108910891084108910831090107310901091109311000052105510941085108310941063109310921090108910851054107210571083109410901079", (a_ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("5483411823130164301726323648775574040242736280723132045715076203655411305808002271453343813316442243431172613670368464030250787734575874037153813304686720216037376818338343576533637313665465688077
50038642421325723888631338626445080232317783411074480702758082587533547146074672663104517747331528586732533262716532738302470061445418582155023582060867818325245272628684066326887680157658025571074176
3
36578157143755501385066738534270035256758087172436267135864042375261824343587854508601180828271660181040171443700833357417100516281666344751063502", a_)))); КонецЦикла;
Функция h___() ~4: ~5: ~2: ~1: ~3: ~IL_4988: ~0: _0 = 1; _0 = - _0; _1 = 0; _0 = _0 <> _1; Если _0 = Ложь Тогда Перейти ~IL_4988; КонецЕсли; Перейти ~3; Перейти ~1; _0 = a; Возврат _0; Перейти ~5; Перейти ~2; _0 = a; Возврат _0; Перейти ~5;
КонецФункции _0 = ""; a = _0; Для a_ = 1 По 535 Цикл a = a + Символ(Число(Сред("1049107010441062104310581070003810631042105510601045106910511056105510721046001100111060107610811090108410941077104710911094109210951105105910921087108110891083108610721098109210931099005310611089
10891081109510601097109610911090108410611079105110851091109310840035105410421057003210531092108410771095105810931091108810881086105310741058108810941091107700510011001610591045105510571054105910641054
0
04210611091108910751078109211021087108010891055109010851078108610901086107510931093108910750050106210901100108310851072004100351056104110500034105910961107108610841079005200100017004500510037105410441
0
50003510521087108410781082109710611087109010951083109010941077108610830011004500580010001200090010105110490013001310641080107810881087110210781050109210921094108811011056109310841082108810871083107710
9
31099109111040036105810481054003310631079107910871087109610781043109210931089109111071055108810901083109210871083107610901096109111070046001800101057108910961078107710891100108510841089005010581088108
9
10841087108810831076109610911095107900331053104410550036105910891092107710761091110310871083108710541091109010791087108910851072109610991089107400151051105110470009001100140039003500401064107210791084
1
08211021074104910931096109510881106106010861090108210931090108610781096109410881105005010591094107810781109105210741088108810941105001000131051003810571089109210741077108611031087108210871057109310921
0
78109310871089107610961092109110730053107610931094104910961094108810911075001300140016001310550038004210621078107910841080109610781045109610991095109511041059108710871084108810871091107610931091109611
0
00047105310751083108810811092109410751074108810861077003910601059105010601041105610550039003900400036004000430033106410941089107810801086110310861083108910571089108510771089108610901078109610961088107
4
00521058107210841092108010881094107410761089108510780035004400380042004500420044001200171059104810581060105810561052106110551046104110621068003610601055001000131064107510801091108710981080104310901092
1
093109311051058109410921080108810841090108010921095109211010046105710911086108210881063109810911091109010801055107810571082109110971080", (a_ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("7336302672840563251122487405433586663441308150783547378584870523734270060071332660278510717755067522441346720724111833321345110300361022783278088254403428108412532834318813003234685578674171237053
50538354884157647260422482266750405382810286335047452572604607713454224525823515622720681258720247386061282655817706588366306468466521855043602423082254781856461317738683143456476246610262888856137358
4
308110334478123607556603175328017716608137431044766502650483380445131688832725213145141404510463787480216665883327824420452506835802662273", a_)))); КонецЦикла;

...


Функция __h__() _0 = a; Возврат _0;
КонецФункции _0 = ""; a = _0; Для a_ = 1 По 648 Цикл a = a + Символ(Число(Сред("1049107110471063104010591069003910621047105110641047106910501055105810721045001800121065107710771087108610971074105510891088107810911087108910801098109310951078005210571093108410791091106210981094
10901088108810561077105310881096109210800035105710481055003410551088108610831096106310931091109310851082106010721056108210901090108000480017001510561046105010591054105310641059004410641094109610761080
1
09410961093108010901053108810851077108810861091107310901093109010750049106310941105108710831075004200361057104410520036106010961103109110851072004500120014004400520035105610451057003910561090108110781
0
86109310591094109610931088109310941077108410870017001300450056001410501053001100091059107910811084108311011077105810881089107810921083108310801094109510961080003310551042105100361063107610741088108110
9
71078106110891084107910901084108910761094109310881078001700090017104810571067105910641047105910531049105200371060105910531049105610561053106010491048003210621079107710871093109310951062107910791079108
2
10921086108700461067109410901082109810851086108310991058109410871082109110821090107610961097109311060033105610421052003910661093108810881094108910881079110410551094108410801087108410861078109710951091
1
09900170010001400091042106110591059105810511061105310511046003710641055104910441049105410461059105610490034106010891092107510811092110210921083108300491061108610911078108710841087108010901097108910780
0
36105510431053003410641093109210771079109311001091108510891060108810851084109110861086107410941092109610790017001100170012106010560037106410971092108310981082109210821106105510871086108110901086108810
7
81097109810911100004610561094108610801093108910841078109210931090107200370069003510651092109510721081109111031087108810851055108910891078108910881091107610981095109310720047105710961103108310821080001
0
00120009105910560039004210661074107610861083109910751061109210881082108910881087107510951097109210780053105610921075107411081055107410941080109011070034006400341054106210581052105310480016001100110012
1
05600361066109410931087109610901090107611061054108610841084108910841087108010941096109011000049107010961093108110971089108610770035106210571044105910481055105500390041004400360036004700361066107810781
0
88108210971079105910911086108410911089108410741094109710881078005310651096109410871097108310921082003900470040004200380035004600130016001000430057001500380059001610641043105910591060105810481057106010
4
81042106010760039105610540015000910661072107610911085109910771060109210891080109310831083108010901091109110790052105410901087108310891060109710911090108210881058107210561082109510931084", (a_ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("7467011767482552550837544632234165688276647023586468352872337852222686337327052103476460261574778468180802103481022336564131474243748301257336577855144288385832774864261017813755251710844881521454
15136830252644206708648182604753585838713062274375523576603422530705835607466571622723081723528032236743071500801268061571401116842324376773138071224806164533276455756577217643241877283525074350667212
4
54567731038238716222058385707582832351468484501074008030427282333538645464356467361258270172326504086223842457384071007424845213665147013730572177724448655237652767124606716674166748811537166517670305
3
01662287105080385557653810800376143613734085052637", a_)))); КонецЦикла;
Функция _h___() _0 = a; Возврат _0;
КонецФункции _0 = ""; a = _0; Для a_ = 1 По 234 Цикл a = a + Символ(Число(Сред("1046107310441062104610621075003910611042105010641052107110471061106010701051001600151059107810751086108510991078106010901090107810901083109110731092109410951080005310561092108910851092105810911091
10871088108710611078105210821097109110800032105710411050003310581087108610831096105710961092109110891087105610751052108210961093108100470015001610601041105810651053105310591052004610571093109010771074
1
09310961089108110841057108810851078109210891090107810981095109310740053106010911104109110851079004300401055104310580038105810891105108410851077005200120009003800540038105810411050003910511086108010781
0
88109610651089109110971087109410941077108910870012004100560015000900140014105610530018001500380057001800450054001610611047106010671061106310501057105710491045106410690035106110570016001210621075107610
8
91087109910771057109210851083109010851090107710901095109510750053105810901087108210931064109810891090108710801060108010561084109610921083", (a_ - 1) * 4 + 1, 4)) - Число(Символ(КодСимвола("4636647752387728736661623556746151812378736584113167861281307101512680645773312734357818851006062507141242117776845273258372853861061358201568107314167833776837724660548686168826444868213756136363
43367554616537504737543557814507854726", a_)))); КонецЦикла;
Функция ___h_() _0 = a; Возврат _0;

...
Просмотров: 160, последний комментарий от denis84   
Раздел с отзывами о работодателях [раздел http://pro1c.org.ua/]
Автор Vofka — 15.07.21, 8:54 — 3 комментариев
Привет!

Есть ли смысл завести отдельный раздел, где можно было бы оставлять отзывы о работодателях или 1С партнерах, которые оказывают соответствующие услуги?
Просмотров: 128, последний комментарий от Vofka   
Доступ с разделу Имущество не администратору. УНФ [раздел Программирование в 1С Предприятие 8.3]
Автор Anderson — 14.07.21, 12:20 — 2 комментариев
Добрый день. Стоит УНФ 1.6.10.2, платформа 8.3.15.1830.
Нужно пользователю без админских прав дать доступ к справочнику Внеоборотные активы и документам относящимся к ним.
По конфигуратору прошел полные права на справочник, документы и регистры соответствующие дал. В меню все появилось, но при создании похоже что у формы выключена доступность (справочник и докумнты). По коду прошел ничего такого не нашел. Может кто сталкивался? Где искать?
Просмотров: 107, последний комментарий от Anderson   
Где можно скачать типовую конфигурацию 1С ? [раздел Программирование в 1С Предприятие 8.3]
Автор kapitoshka_user — 13.07.21, 9:49 — 1 комментариев
Всем добрый день!
Подскажите, пожалуйста, где можно скачать типовую конфигурацию 1С?
Просмотров: 205, последний комментарий от Vofka   
Не правильное обновление релиза [раздел Программирование в 1С Предприятие 8.3]
Автор kukulkan — 12.07.21, 13:17 — 2 комментариев
1С:Предприятие 8.3 (8.3.17.1496)

Привет!
Подскажите, было обновление релиза но в самом конце видимо забыла нажать на F7 и теперь не могу ни назад откатить ни новый релиз сделать потому что выходит ошибка: Обнаружено логическое завершение исходного текста модуля
Что можно сделать?
Спасибо!
Просмотров: 152, последний комментарий от 29a   
1С 8.3. Не работает карточка счета после того как убрал режим совместимости [раздел Программирование в 1С Предприятие 8.3]
Автор maxst22 — 08.07.21, 10:57 — 2 комментариев
Доброго времени суток форумчане!

Конфигурация: Business automation software for enterprise resource planning (2.1.18.3)
Платформа: 1С:Предприятие 8.3 (8.3.18.1483)
Режим совместимости: Не использовать
База на SQL

После установления соотв. режима совместимости перестал работать отчет "КарточкаСчета". Никакие изменения в отчет не вносились.
Отчет оборотно-сальдовая работает!!!
Может кто сталкивался: как исправить? Заранее спасибо.













Просмотров: 217, последний комментарий от maxst22   
Сброс (или подбор) пароля пользователей файловой базы 1С [раздел Конфигурации]
Автор Santino — 07.07.21, 12:30 — 0 комментариев
Данная конфигурация предназначена для сброса пароля любой учетной записи в файловой базе 1С.
Старый способ с HEX-редактором и прямым редактированием файла сложный и не всегда работал, особенно на базах с новым внутренним форматом 8.3.8+
В этой конфигурации обновлена сама компонента прямого доступа к файловой базе 1С (файл 1Cv8.1CD) до v.1.4.1 , взято с форума http://forum330.com/forum/197.

Также в конфигурацию добавлен функционал другой обработки "Подбор паролей пользователей" автора Ю.А.Пермитина http://devel1c.blogspot.com для выполнения bruteforce атаки на слабые пароли. Только в его обработке использовалась старая утилита shacalculc.exe, версии 2.0 Александра Егорова. Этот sha1 калькулятор был обновлён до версии 5.0 beta, в которой есть поддержка технологии Nvidia CUDA, и к тому же версия 5 просто работает быстрее в 4 раза, чем версия 2 . Калькулятор Егорова можно найти тут: https://github.com/aegoroff/hc.
Этот подбор паролей работает на коротких и простых паролях. Если у пользователя длинный сложный пароль, то за разумное время bruteforce атака пароль не найдёт.

Внимание!
Помните, что перед применением этого инструмента нужно обязательно делать архивную копию подопытной базы!

Сам архив (пароль стандартный, записан в правилах):
Прикрепленный файл  PasswordReset_1.1.part1.rar ( 2 мегабайт ) Кол-во скачиваний: 16

Прикрепленный файл  PasswordReset_1.1.part2.rar ( 2 мегабайт ) Кол-во скачиваний: 16

Прикрепленный файл  PasswordReset_1.1.part3.rar ( 1.92 мегабайт ) Кол-во скачиваний: 17

Просмотров: 154, оставить комментарий   
Расчет себестоимости возврата при расширенной аналитике учета затрат [раздел 1С Управление производственным предприятием 8]
Автор Vladis86 — 06.07.21, 14:59 — 2 комментариев
Добрый день Всем! Конфигурация "Управление производственным предприятием для Украины", редакция 1.3 (1.3.74.1) Очень нужна подсказка.. К огромному сожалению ИТС не предоставил информацию..
Вопрос: При использовании расширенной аналитики учета затрат если в колонке «Документ партии» указана ссылка на документ реализации, то себестоимость возврата будет рассчитана документом «Расчет себестоимости выпуска» исходя из стоимости номенклатуры в месяце возврата. К пиримеру продали в 05 м а вернулив 6 месяце.
Очень нужно понять какая нормативная база этой опирации и почему именно так реализован расчет себестоимости.. читаю ПСБО 16 и 9 и не нахожу.
Нужно понять именно почему так и на какое положение в выводах можно оперется.
Заранее спасибо!
Просмотров: 200, последний комментарий от Vladis86   
Хто підключав екваринговий термінал А930 [раздел Работа с торговым оборудованием]
Автор vbi — 06.07.21, 10:06 — 1 комментариев
Доброго дня! Хто підключав екваринговий термінал А930 до 1С (це такий новий термінал у Приват банка з великим екраном на андроїдв)? поділіться будь-ласка драйверами, обробкою для 1С.
Просмотров: 130, последний комментарий от andreydv87   
8.3 Непонятная проблема с отчетом на СКД [раздел Система компоновки данных]
Автор kserg2012 — 01.07.21, 12:40 — 1 комментариев
Привет!

1С:Предприятие 8.3 (8.3.11.2867)
"Управление торговлей", редакция 10.3 (10.3.12.3)


Есть отчет на СКД (основа запроса 2 регистра накопления ЗаказыПокупателей и ВзаиморасчетыСКонтрагентами)
Есть пользователь с неполными правами, у него в роли в правах доступа имеется права на чтение-промотр-управление итогами в этих регистрах

Имеем ситацию: отчет на СКД не выводит данные (только заголовок отчета), а отчет на том же запросе, но на базе ПостроителяОтчета выводит данные.
Подскажите пож-та, в чем может быть причина проблемы с СКД ?
Просмотров: 178, последний комментарий от kserg2012   
Глюк при запросе движений регистра [раздел Программирование в 1С Предприятие 7.7]
Автор voroneczinna@gmail.com — 30.06.21, 8:31 — 6 комментариев
Не подскажите: Была 1с77 ТИС более 19 лет, начала глючить не правильно показывать данные из регистров приходилось несколько раз обновлять отчеты и сравнивать их, 2 года работали и обрезали остатки на 1 число.
Услановили новую 1с 77 Производство+Услуги+Бухалтерия Украины (7.70.085) база файловая работаем 6 месяцов и эта так же начила глючить выводить пустые движения в отчетах по регистрам не каждый день.
Просмотров: 408, последний комментарий от miha74   
Конфигуратор в разрешении 3840*2160 [раздел Программирование в 1С Предприятие 7.7]
Автор kiveda — 29.06.21, 11:31 — 1 комментариев
можно ли настроить конф 7 для нормальной работы в этом разрешении?шрифт у кода поменял, но меню, печ формы очень мелкие.
Просмотров: 223, последний комментарий от 29a   
Запись регистра сведений [раздел Программирование в 1С Предприятие 8.3]
Автор maci — 29.06.21, 8:24 — 3 комментариев
Всем привет!
Учусь программировать, конфигурация УТ 11, добавил свой регистр сведений периодический, не подчинен регистратору, в обработку проведения описал запись НабораЗаписей в цикле.
Проблема: 1) Все записывается, но все записи удаляются и остаются только данные последнего проведенного документа.
2) Если пользоваться методом Прочитать() тогда записи не удаляются но при перепровдении документа ругается что данные с такими записями уже существуют, как очищать и перезаписывать при перепровдении или как это должно происходить?
Спасибо за помощь!
Просмотров: 366, последний комментарий от maci   
RSS Текстовая версия Сейчас: 24.07.21, 7:40
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!