Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Склад - какую выбрать конфигурацию? [раздел Помогите подобрать конфигурацию]
Автор Zzaaqqaa — 18.06.21, 22:37 — 2 комментариев
Привет!
Помогите выбрать 1с для склада, необходима простая, приход\расход, перемещение между складами, отчеты , типа движение товаров, остатки по складам, маржа (сравнение внесенных закупочных цен и цен продажи в национальной валюте, хотя будут евро и доллары), вот нашел старую 1С, покупал в 17 году, можно ее как-то подпилить? Типа простое оприходование, без всяких заказов поставщикам и т.д., загрузка списком в разные доки, типа перемещение, оприходование и т.д., только не как внешняя обработка, а кнопка внутри программы?
Буду благодарен за совет, может кто помочь?
Просмотров: 32, последний комментарий от Moloko   
поле ввода "падает" вниз [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 17.06.21, 18:24 — 4 комментариев
добавляю в диалог "поле ввода" многострочный - неограниченая длина
ставлю на середине диалога
при открытии формы в 1с поле ввода "падает" вниз, хотя я хотел что-бы оно было именно там, где я его поставил, причем другие поля никуда не прыгают
где поменять что-бы при изменении размера диалога поле не падало вниз
Просмотров: 65, последний комментарий от CobraS   
Ошибка создания источника доступных настроек компоновки данных [раздел Система компоновки данных]
Автор kiveda — 17.06.21, 15:09 — 5 комментариев
замучила эта ошибка.есть внешний отчет на скд на сетевом диске. после правок в конф., сохранения и повторного открытия/запуска предприятии отчет падает вместе с платформой.

симптомы:
1. отваливается отладка - те точки останова не срабатывают

2. отчет не реагирует на изменения кода.

3. после повторного нажатия кнопки сформировать отчет падает с сообщением Ошибка создания источника доступных настроек компоновки данных. Предприятие закрывается аварийно.


помогает сохранить отчет под другим именем или пересоздать заново.
впечатление такое что где внутри платформы кешируется старый вариант. Конечно можно чистить кеш, но делать этот постоянно...
сталкивался ли ктото с таким поведением?

kiveda @ Сегодня, 16:03 * ,
Просмотров: 63, последний комментарий от logist   
Обмен по АПИ с Интертоп и Арбер [раздел Программирование в 1С Предприятие 8.3]
Автор alex1c — 17.06.21, 10:16 — 2 комментариев
Уважаемые коллеги, может кто имеет опыт подключения обмена 1С по АПИ с Интертоп и Арбер.
Имеется УТ 2.3 но меня интересует сам механизм, согласен оплатить за решение.
Просмотров: 63, последний комментарий от alex1c   
Валовая прибыль по поставщику,Не считает USD [раздел Управление торговлей для Украины редакция 2 (Управление торговлей для России редакция 10)]
Автор Gangster1111 — 15.06.21, 7:04 — 1 комментариев
Здравствуйте УТ 10.3 Версия 8.3 столкнулся проблемой, Валовая прибыль по поставщику не считает валюту Доллар из за этого в отчете показывает минуса, Но основную валюты считает и всё нормально, помогите решить проблема пожалуйста. PS> Валовая Прибыль по поставщику сделанна Универсальным отчётам

Это заголовок отчёта


Это прибыль с USD которые показывают минус


Это МодульОбъекта
#Если Клиент Тогда
    
////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ И ФУНКЦИИ НАЧАЛЬНОЙ НАСТРОЙКИ ОТЧЕТА

// Процедура установки начальных настроек отчета с использованием текста запроса
//
Процедура УстановитьНачальныеНастройки(ДополнительныеПараметры = Неопределено) Экспорт
    
    // Настройка общих параметров универсального отчета
    
    // Содержит название отчета, которое будет выводиться в шапке.
    // Тип: Строка.
    // Пример:
    // УниверсальныйОтчет.мНазваниеОтчета = "Название отчета";
    УниверсальныйОтчет.мНазваниеОтчета = СокрЛП(ЭтотОбъект.Метаданные().Синоним);
    
    // Содержит признак необходимости отображения надписи и поля выбора раздела учета в форме настройки.
    // Тип: Булево.
    // Значение по умолчанию: Истина.
    // Пример:
     УниверсальныйОтчет.мВыбиратьИмяРегистра = Ложь;
    
    // Содержит имя регистра, по метаданным которого будет выполняться заполнение настроек отчета.
    // Тип: Строка.
    // Пример:
    // УниверсальныйОтчет.ИмяРегистра = "ТоварыНаСкладах";
    
    // Содержит признак необходимости вывода отрицательных значений показателей красным цветом.
    // Тип: Булево.
    // Значение по умолчанию: Ложь.
    // Пример:
    // УниверсальныйОтчет.ОтрицательноеКрасным = Истина;
    
    // Содержит признак необходимости вывода в отчет общих итогов.
    // Тип: Булево.
    // Значение по умолчанию: Истина.
    // Пример:
    // УниверсальныйОтчет.ВыводитьОбщиеИтоги = Ложь;
    
    // Содержит признак необходимости вывода детальных записей в отчет.
    // Тип: Булево.
    // Значение по умолчанию: Ложь.
    // Пример:
    // УниверсальныйОтчет.ВыводитьДетальныеЗаписи = Истина;
    
    // Содержит признак необходимости отображения флага использования свойств и категорий в форме настройки.
    // Тип: Булево.
    // Значение по умолчанию: Истина.
    // Пример:
     УниверсальныйОтчет.мВыбиратьИспользованиеСвойств = Истина;
    
    // Содержит признак использования свойств и категорий при заполнении настроек отчета.
    // Тип: Булево.
    // Значение по умолчанию: Ложь.
    // Пример:
    // УниверсальныйОтчет.ИспользоватьСвойстваИКатегории = Истина;
    
    // Содержит признак использования простой формы настроек отчета без группировок колонок.
    // Тип: Булево.
    // Значение по умолчанию: Ложь.
    // Пример:
    // УниверсальныйОтчет.мРежимФормыНастройкиБезГруппировокКолонок = Истина;
    
    // Дополнительные параметры, переданные из отчета, вызвавшего расшифровку.
    // Информация, передаваемая в переменной ДополнительныеПараметры, может быть использована
    // для реализации специфичных для данного отчета параметрических настроек.
    
    // Описание исходного текста запроса.
    
    ТекстЗапроса =
    "ВЫБРАТЬ РАЗРЕШЕННЫЕ
    |    ВложенныйЗапрос.Организация КАК Организация,
    |    ВложенныйЗапрос.Проект КАК Проект,
    |    ВложенныйЗапрос.Подразделение КАК Подразделение,
    |    ВложенныйЗапрос.Поставщик КАК Поставщик,
    |    ВложенныйЗапрос.Покупатель КАК Покупатель,
    |    ВложенныйЗапрос.ДоговорПокупателя КАК ДоговорПокупателя,
    |    ВложенныйЗапрос.Номенклатура КАК Номенклатура,
    |    ВложенныйЗапрос.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
    |    ВложенныйЗапрос.СерияНоменклатуры КАК СерияНоменклатуры,
    |    ВложенныйЗапрос.ЗаказПокупателя КАК ЗаказПокупателя,
    |    ВложенныйЗапрос.ДокументОприходования КАК ДокументОприходования,
    |    ВложенныйЗапрос.Регистратор КАК Регистратор,
    |    ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.Организация) КАК ОрганизацияПредставление,
    |    ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.Проект) КАК ПроектПредставление,
    |    ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.Подразделение) КАК ПодразделениеПредставление,
    |    ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.Поставщик) КАК ПоставщикПредставление,
    |    ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.Покупатель) КАК ПокупательПредставление,
    |    ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.ДоговорПокупателя) КАК ДоговорПокупателяПредставление,
    |    ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.Номенклатура) КАК НоменклатураПредставление,
    |    ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.ХарактеристикаНоменклатуры) КАК ХарактеристикаНоменклатурыПредставление,
    |    ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.ЗаказПокупателя) КАК ЗаказПокупателяПредставление,
    |    ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.ДокументОприходования) КАК ДокументОприходованияПредставление,
    |    ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.Регистратор) КАК РегистраторПредставление,
    |    ВложенныйЗапрос.Период КАК Период,
    |    ВложенныйЗапрос.ПериодДень КАК ПериодДень,
    |    ВложенныйЗапрос.ПериодНеделя КАК ПериодНеделя,
    |    ВложенныйЗапрос.ПериодДекада КАК ПериодДекада,
    |    ВложенныйЗапрос.ПериодМесяц КАК ПериодМесяц,
    |    ВложенныйЗапрос.ПериодКвартал КАК ПериодКвартал,
    |    ВложенныйЗапрос.ПериодПолугодие КАК ПериодПолугодие,
    |    ВложенныйЗапрос.ПериодГод КАК ПериодГод,
    |    ВложенныйЗапрос.Количество КАК Количество,
    |    ВложенныйЗапрос.КоличествоЕдиницОтчетов КАК КоличествоЕдиницОтчетов,
    |    ВложенныйЗапрос.КоличествоБазовыхЕдиниц КАК КоличествоБазовыхЕдиниц,
    |    ВложенныйЗапрос.СтоимостьБезНДС КАК СтоимостьБезНДС,
    |    ВложенныйЗапрос.НДС КАК НДС,
    |    ВложенныйЗапрос.Стоимость КАК Стоимость,
    |    ВложенныйЗапрос.Себестоимость КАК Себестоимость,
    |    ВложенныйЗапрос.ВаловаяПрибыль КАК ВаловаяПрибыль,
    |    ВложенныйЗапрос.Эффективность КАК Эффективность,
    |    ВложенныйЗапрос.Рентабельность КАК Рентабельность
    |    //ПОЛЯ_СВОЙСТВА
    |    //ПОЛЯ_КАТЕГОРИИ
    |{ВЫБРАТЬ
    |    Организация.*,
    |    Проект.*,
    |    Подразделение.*,
    |    Поставщик.*,
    |    Покупатель.*,
    |    ДоговорПокупателя.*,
    |    Номенклатура.*,
    |    ХарактеристикаНоменклатуры.*,
    |    СерияНоменклатуры.*,
    |    ЗаказПокупателя.*,
    |    ДокументОприходования.*,
    |    Регистратор.*,
    |    Период,
    |    ПериодДень,
    |    ПериодНеделя,
    |    ПериодДекада,
    |    ПериодМесяц,
    |    ПериодКвартал,
    |    ПериодПолугодие,
    |    ПериодГод,
    |    Количество,
    |    КоличествоЕдиницОтчетов,
    |    КоличествоБазовыхЕдиниц,
    |    СтоимостьБезНДС,
    |    НДС,
    |    Стоимость,
    |    Себестоимость,
    |    ВаловаяПрибыль,
    |    Эффективность,
    |    Рентабельность
    |    //ПСЕВДОНИМЫ_СВОЙСТВА
    |    //ПСЕВДОНИМЫ_КАТЕГОРИИ
    |}
    |ИЗ
    |    (ВЫБРАТЬ
    |        ВложенныйЗапрос.Организация КАК Организация,
    |        ВложенныйЗапрос.Проект КАК Проект,
    |        ВложенныйЗапрос.Подразделение КАК Подразделение,
    |        ВложенныйЗапрос.ДокументОприходования.Контрагент КАК Поставщик,
    |        ВложенныйЗапрос.Покупатель КАК Покупатель,
    |        ВложенныйЗапрос.ДоговорПокупателя КАК ДоговорПокупателя,
    |        ВложенныйЗапрос.Номенклатура КАК Номенклатура,
    |        ВложенныйЗапрос.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
    |        ВложенныйЗапрос.СерияНоменклатуры КАК СерияНоменклатуры,
    |        ВложенныйЗапрос.ЗаказПокупателя КАК ЗаказПокупателя,
    |        ВложенныйЗапрос.ДокументОприходования КАК ДокументОприходования,
    |        ВложенныйЗапрос.Регистратор КАК Регистратор,
    |        ВложенныйЗапрос.Период КАК Период,
    |        НАЧАЛОПЕРИОДА(ВложенныйЗапрос.Период, ДЕНЬ) КАК ПериодДень,
    |        НАЧАЛОПЕРИОДА(ВложенныйЗапрос.Период, НЕДЕЛЯ) КАК ПериодНеделя,
    |        НАЧАЛОПЕРИОДА(ВложенныйЗапрос.Период, ДЕКАДА) КАК ПериодДекада,
    |        НАЧАЛОПЕРИОДА(ВложенныйЗапрос.Период, МЕСЯЦ) КАК ПериодМесяц,
    |        НАЧАЛОПЕРИОДА(ВложенныйЗапрос.Период, КВАРТАЛ) КАК ПериодКвартал,
    |        НАЧАЛОПЕРИОДА(ВложенныйЗапрос.Период, ПОЛУГОДИЕ) КАК ПериодПолугодие,
    |        НАЧАЛОПЕРИОДА(ВложенныйЗапрос.Период, ГОД) КАК ПериодГод,
    |        СУММА(ВложенныйЗапрос.Количество) КАК Количество,
    |        СУММА(ВложенныйЗапрос.КоличествоЕдиницОтчетов) КАК КоличествоЕдиницОтчетов,
    |        СУММА(ВложенныйЗапрос.КоличествоБазовыхЕдиниц) КАК КоличествоБазовыхЕдиниц,
    |        СУММА(ВЫБОР
    |                КОГДА ВложенныйЗапрос.КоличествоПродажи = 0
    |                    ТОГДА ВложенныйЗапрос.СтоимостьБезНДС
    |                ИНАЧЕ ВложенныйЗапрос.СтоимостьБезНДС * ВложенныйЗапрос.Количество / ВложенныйЗапрос.КоличествоПродажи
    |            КОНЕЦ) КАК СтоимостьБезНДС,
    |        СУММА(ВЫБОР
    |                КОГДА ВложенныйЗапрос.КоличествоПродажи = 0
    |                    ТОГДА ВложенныйЗапрос.НДС
    |                ИНАЧЕ ВложенныйЗапрос.НДС * ВложенныйЗапрос.Количество / ВложенныйЗапрос.КоличествоПродажи
    |            КОНЕЦ) КАК НДС,
    |        СУММА(ВЫБОР
    |                КОГДА ВложенныйЗапрос.КоличествоПродажи = 0
    |                    ТОГДА ВложенныйЗапрос.Стоимость
    |                ИНАЧЕ ВложенныйЗапрос.Стоимость * ВложенныйЗапрос.Количество / ВложенныйЗапрос.КоличествоПродажи
    |            КОНЕЦ) КАК Стоимость,
    |        СУММА(ВложенныйЗапрос.Себестоимость) КАК Себестоимость,
    |        ВЫБОР
    |            КОГДА &НеВключатьНДСВСтоимостьПартий
    |                ТОГДА СУММА(ВЫБОР
    |                            КОГДА ВложенныйЗапрос.КоличествоПродажи = 0
    |                                ТОГДА ВложенныйЗапрос.СтоимостьБезНДС
    |                            ИНАЧЕ ВложенныйЗапрос.СтоимостьБезНДС * ВложенныйЗапрос.Количество / ВложенныйЗапрос.КоличествоПродажи
    |                        КОНЕЦ)
    |            ИНАЧЕ СУММА(ВЫБОР
    |                        КОГДА ВложенныйЗапрос.КоличествоПродажи = 0
    |                            ТОГДА ВложенныйЗапрос.Стоимость
    |                        ИНАЧЕ ВложенныйЗапрос.Стоимость * ВложенныйЗапрос.Количество / ВложенныйЗапрос.КоличествоПродажи
    |                    КОНЕЦ)
    |        КОНЕЦ - СУММА(ВложенныйЗапрос.Себестоимость) КАК ВаловаяПрибыль,
    |        100 * ВЫБОР
    |            КОГДА &НеВключатьНДСВСтоимостьПартий
    |                ТОГДА ВЫБОР
    |                        КОГДА СУММА(ВложенныйЗапрос.Себестоимость) > 0
    |                            ТОГДА (СУММА(ВЫБОР
    |                                        КОГДА ВложенныйЗапрос.КоличествоПродажи = 0
    |                                            ТОГДА ВложенныйЗапрос.СтоимостьБезНДС
    |                                        ИНАЧЕ ВложенныйЗапрос.СтоимостьБезНДС * ВложенныйЗапрос.Количество / ВложенныйЗапрос.КоличествоПродажи
    |                                    КОНЕЦ) - СУММА(ВложенныйЗапрос.Себестоимость)) / СУММА(ВложенныйЗапрос.Себестоимость)
    |                        ИНАЧЕ 0
    |                    КОНЕЦ
    |            ИНАЧЕ ВЫБОР
    |                    КОГДА СУММА(ВложенныйЗапрос.Себестоимость) > 0
    |                        ТОГДА (СУММА(ВЫБОР
    |                                    КОГДА ВложенныйЗапрос.КоличествоПродажи = 0
    |                                        ТОГДА ВложенныйЗапрос.Стоимость
    |                                    ИНАЧЕ ВложенныйЗапрос.Стоимость * ВложенныйЗапрос.Количество / ВложенныйЗапрос.КоличествоПродажи
    |                                КОНЕЦ) - СУММА(ВложенныйЗапрос.Себестоимость)) / СУММА(ВложенныйЗапрос.Себестоимость)
    |                    ИНАЧЕ 0
    |                КОНЕЦ
    |        КОНЕЦ КАК Эффективность,
    |        100 * ВЫБОР
    |            КОГДА &НеВключатьНДСВСтоимостьПартий
    |                ТОГДА ВЫБОР
    |                        КОГДА СУММА(ВЫБОР
    |                                    КОГДА ВложенныйЗапрос.КоличествоПродажи = 0
    |                                        ТОГДА ВложенныйЗапрос.СтоимостьБезНДС
    |                                    ИНАЧЕ ВложенныйЗапрос.СтоимостьБезНДС * ВложенныйЗапрос.Количество / ВложенныйЗапрос.КоличествоПродажи
    |                                КОНЕЦ) > 0
    |                            ТОГДА (СУММА(ВЫБОР
    |                                        КОГДА ВложенныйЗапрос.КоличествоПродажи = 0
    |                                            ТОГДА ВложенныйЗапрос.СтоимостьБезНДС
    |                                        ИНАЧЕ ВложенныйЗапрос.СтоимостьБезНДС * ВложенныйЗапрос.Количество / ВложенныйЗапрос.КоличествоПродажи
    |                                    КОНЕЦ) - СУММА(ВложенныйЗапрос.Себестоимость)) / СУММА(ВЫБОР
    |                                        КОГДА ВложенныйЗапрос.КоличествоПродажи = 0
    |                                            ТОГДА ВложенныйЗапрос.СтоимостьБезНДС
    |                                        ИНАЧЕ ВложенныйЗапрос.СтоимостьБезНДС * ВложенныйЗапрос.Количество / ВложенныйЗапрос.КоличествоПродажи
    |                                    КОНЕЦ)
    |                        ИНАЧЕ 0
    |                    КОНЕЦ
    |            ИНАЧЕ ВЫБОР
    |                    КОГДА СУММА(ВЫБОР
    |                                КОГДА ВложенныйЗапрос.КоличествоПродажи = 0
    |                                    ТОГДА ВложенныйЗапрос.Стоимость
    |                                ИНАЧЕ ВложенныйЗапрос.Стоимость * ВложенныйЗапрос.Количество / ВложенныйЗапрос.КоличествоПродажи
    |                            КОНЕЦ) > 0
    |                        ТОГДА (СУММА(ВЫБОР
    |                                    КОГДА ВложенныйЗапрос.КоличествоПродажи = 0
    |                                        ТОГДА ВложенныйЗапрос.Стоимость
    |                                    ИНАЧЕ ВложенныйЗапрос.Стоимость * ВложенныйЗапрос.Количество / ВложенныйЗапрос.КоличествоПродажи
    |                                КОНЕЦ) - СУММА(ВложенныйЗапрос.Себестоимость)) / СУММА(ВЫБОР
    |                                    КОГДА ВложенныйЗапрос.КоличествоПродажи = 0
    |                                        ТОГДА ВложенныйЗапрос.Стоимость
    |                                    ИНАЧЕ ВложенныйЗапрос.Стоимость * ВложенныйЗапрос.Количество / ВложенныйЗапрос.КоличествоПродажи
    |                                КОНЕЦ)
    |                    ИНАЧЕ 0
    |                КОНЕЦ
    |        КОНЕЦ КАК Рентабельность
    |    {ВЫБРАТЬ
    |        Организация,
    |        Проект,
    |        Подразделение,
    |        Поставщик,
    |        Покупатель,
    |        ДоговорПокупателя,
    |        Номенклатура,
    |        ХарактеристикаНоменклатуры,
    |        СерияНоменклатуры,
    |        ЗаказПокупателя,
    |        ДокументОприходования,
    |        Регистратор,
    |        Период,
    |        ПериодДень,
    |        ПериодНеделя,
    |        ПериодДекада,
    |        ПериодМесяц,
    |        ПериодКвартал,
    |        ПериодПолугодие,
    |        ПериодГод}
    |    ИЗ
    |        (ВЫБРАТЬ
    |            ПродажиОбороты.Организация КАК Организация,
    |            ПродажиОбороты.Проект КАК Проект,
    |            ПродажиОбороты.Подразделение КАК Подразделение,
    |            ПродажиОбороты.Контрагент КАК Покупатель,
    |            ПродажиОбороты.ДоговорКонтрагента КАК ДоговорПокупателя,
    |            ПродажиОбороты.Номенклатура КАК Номенклатура,
    |            ПродажиОбороты.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
    |            ПродажиОбороты.СерияНоменклатуры КАК СерияНоменклатуры,
    |            ПродажиОбороты.ЗаказПокупателя КАК ЗаказПокупателя,
    |            ТаблицаРегистраПродажиСебестоимость.ДокументОприходования КАК ДокументОприходования,
    |            ПродажиОбороты.Регистратор КАК Регистратор,
    |            ПродажиОбороты.Период КАК Период,
    |            ПродажиОбороты.КоличествоОборот КАК КоличествоПродажи,
    |            ТаблицаРегистраПродажиСебестоимость.Количество КАК Количество,
    |            ТаблицаРегистраПродажиСебестоимость.Количество * ЕСТЬNULL(ПродажиОбороты.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент, 1) / ЕСТЬNULL(ПродажиОбороты.Номенклатура.ЕдиницаДляОтчетов.Коэффициент, 1) КАК КоличествоЕдиницОтчетов,
    |            ТаблицаРегистраПродажиСебестоимость.Количество * ЕСТЬNULL(ПродажиОбороты.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент, 1) КАК КоличествоБазовыхЕдиниц,
    |            ПродажиОбороты.СтоимостьОборот - ПродажиОбороты.НДСОборот КАК СтоимостьБезНДС,
    |            ПродажиОбороты.НДСОборот КАК НДС,
    |            ПродажиОбороты.СтоимостьОборот КАК Стоимость,
    |            ТаблицаРегистраПродажиСебестоимость.СтоимостьОборот КАК Себестоимость
    |        ИЗ
    |            РегистрНакопления.Продажи.Обороты(&ДатаНач, &ДатаКон, Регистратор, {Организация.* КАК Организация, Проект.* КАК Проект, Подразделение.* КАК Подразделение, Контрагент.* КАК Покупатель, ДоговорКонтрагента.* КАК ДоговорПокупателя, Номенклатура.* КАК Номенклатура, ХарактеристикаНоменклатуры.* КАК ХарактеристикаНоменклатуры, ЗаказПокупателя.* КАК ЗаказПокупателя}) КАК ПродажиОбороты
    |                ВНУТРЕННЕЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
    |                    ПродажиСебестоимость.Номенклатура КАК Номенклатура,
    |                    ПродажиСебестоимость.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
    |                    ПродажиСебестоимость.СерияНоменклатуры КАК СерияНоменклатуры,
    |                    ПродажиСебестоимость.ЗаказПокупателя КАК ЗаказПокупателя,
    |                    ПродажиСебестоимость.ДокументОприходования КАК ДокументОприходования,
    |                    ВЫБОР
    |                        КОГДА ПродажиСебестоимость.ДокументДвижения <> НЕОПРЕДЕЛЕНО
    |                            ТОГДА ПродажиСебестоимость.ДокументДвижения
    |                        ИНАЧЕ ПродажиСебестоимость.Регистратор
    |                    КОНЕЦ КАК Регистратор,
    |                    СУММА(ПродажиСебестоимость.Количество) КАК Количество,
    |                    СУММА(ПродажиСебестоимость.Стоимость) КАК СтоимостьОборот
    |                ИЗ
    |                    РегистрНакопления.ПродажиСебестоимость КАК ПродажиСебестоимость
    |                ГДЕ
    |                    ПродажиСебестоимость.Период МЕЖДУ &ДатаНачала И &ДатаКонца
    |                {ГДЕ
    |                    ПродажиСебестоимость.Проект.* КАК Проект,
    |                    ПродажиСебестоимость.Подразделение.* КАК Подразделение,
    |                    ПродажиСебестоимость.ДокументОприходования.* КАК ДокументОприходования,
    |                    ПродажиСебестоимость.ДокументОприходования.Контрагент.* КАК Поставщик,
    |                    ПродажиСебестоимость.Номенклатура.* КАК Номенклатура,
    |                    ПродажиСебестоимость.ХарактеристикаНоменклатуры.* КАК ХарактеристикаНоменклатуры,
    |                    ПродажиСебестоимость.ЗаказПокупателя.* КАК ЗаказПокупателя}
    |                
    |                СГРУППИРОВАТЬ ПО
    |                    ПродажиСебестоимость.Номенклатура,
    |                    ПродажиСебестоимость.ХарактеристикаНоменклатуры,
    |                    ПродажиСебестоимость.СерияНоменклатуры,
    |                    ПродажиСебестоимость.ЗаказПокупателя,
    |                    ПродажиСебестоимость.ДокументОприходования,
    |                    ВЫБОР
    |                        КОГДА ПродажиСебестоимость.ДокументДвижения <> НЕОПРЕДЕЛЕНО
    |                            ТОГДА ПродажиСебестоимость.ДокументДвижения
    |                        ИНАЧЕ ПродажиСебестоимость.Регистратор
    |                    КОНЕЦ) КАК ТаблицаРегистраПродажиСебестоимость
    |                ПО ТаблицаРегистраПродажиСебестоимость.Номенклатура = ПродажиОбороты.Номенклатура
    |                    И ТаблицаРегистраПродажиСебестоимость.ХарактеристикаНоменклатуры = ПродажиОбороты.ХарактеристикаНоменклатуры
    |                    И ТаблицаРегистраПродажиСебестоимость.СерияНоменклатуры = ПродажиОбороты.СерияНоменклатуры
    |                    И ТаблицаРегистраПродажиСебестоимость.ЗаказПокупателя = ПродажиОбороты.ЗаказПокупателя
    |                    И ТаблицаРегистраПродажиСебестоимость.Регистратор = ПродажиОбороты.Регистратор
    |        
    |        ОБЪЕДИНИТЬ ВСЕ
    |        
    |        ВЫБРАТЬ
    |            ПродажиОбороты.Организация,
    |            ПродажиОбороты.Проект,
    |            ПродажиОбороты.Подразделение,
    |            ПродажиОбороты.Контрагент,
    |            ПродажиОбороты.ДоговорКонтрагента,
    |            ПродажиОбороты.Номенклатура,
    |            ПродажиОбороты.ХарактеристикаНоменклатуры,
    |            ПродажиОбороты.СерияНоменклатуры,
    |            ПродажиОбороты.ЗаказПокупателя,
    |            НЕОПРЕДЕЛЕНО,
    |            ПродажиОбороты.Регистратор,
    |            ПродажиОбороты.Период,
    |            ПродажиОбороты.КоличествоОборот,
    |            ПродажиОбороты.КоличествоОборот - ЕСТЬNULL(ТаблицаРегистраПродажиСебестоимость.Количество, 0),
    |            (ПродажиОбороты.КоличествоОборот - ЕСТЬNULL(ТаблицаРегистраПродажиСебестоимость.Количество, 0)) * ЕСТЬNULL(ПродажиОбороты.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент, 1) / ЕСТЬNULL(ПродажиОбороты.Номенклатура.ЕдиницаДляОтчетов.Коэффициент, 1),
    |            (ПродажиОбороты.КоличествоОборот - ЕСТЬNULL(ТаблицаРегистраПродажиСебестоимость.Количество, 0)) * ЕСТЬNULL(ПродажиОбороты.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент, 1),
    |            ПродажиОбороты.СтоимостьОборот - ПродажиОбороты.НДСОборот,
    |            ПродажиОбороты.НДСОборот,
    |            ПродажиОбороты.СтоимостьОборот,
    |            0
    |        ИЗ
    |            РегистрНакопления.Продажи.Обороты(&ДатаНач, &ДатаКон, Регистратор, {Организация.* КАК Организация, Проект.* КАК Проект, Подразделение.* КАК Подразделение, Контрагент.* КАК Покупатель, ДоговорКонтрагента.* КАК ДоговорПокупателя, Номенклатура.* КАК Номенклатура, ХарактеристикаНоменклатуры.* КАК ХарактеристикаНоменклатуры, ЗаказПокупателя.* КАК ЗаказПокупателя}) КАК ПродажиОбороты
    |                ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
    |                    ПродажиСебестоимость.Номенклатура КАК Номенклатура,
    |                    ПродажиСебестоимость.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
    |                    ПродажиСебестоимость.СерияНоменклатуры КАК СерияНоменклатуры,
    |                    ПродажиСебестоимость.ЗаказПокупателя КАК ЗаказПокупателя,
    |                    ВЫБОР
    |                        КОГДА ПродажиСебестоимость.ДокументДвижения <> НЕОПРЕДЕЛЕНО
    |                            ТОГДА ПродажиСебестоимость.ДокументДвижения
    |                        ИНАЧЕ ПродажиСебестоимость.Регистратор
    |                    КОНЕЦ КАК Регистратор,
    |                    СУММА(ПродажиСебестоимость.Количество) КАК Количество,
    |                    СУММА(ПродажиСебестоимость.Стоимость) КАК СтоимостьОборот
    |                ИЗ
    |                    РегистрНакопления.ПродажиСебестоимость КАК ПродажиСебестоимость
    |                ГДЕ
    |                    ПродажиСебестоимость.Период МЕЖДУ &ДатаНачала И &ДатаКонца
    |                {ГДЕ
    |                    ПродажиСебестоимость.Проект.* КАК Проект,
    |                    ПродажиСебестоимость.Подразделение.* КАК Подразделение,
    |                    ПродажиСебестоимость.ДокументОприходования.* КАК ДокументОприходования,
    |                    ПродажиСебестоимость.ДокументОприходования.Контрагент.* КАК Поставщик,
    |                    ПродажиСебестоимость.Номенклатура.* КАК Номенклатура,
    |                    ПродажиСебестоимость.ХарактеристикаНоменклатуры.* КАК ХарактеристикаНоменклатуры,
    |                    ПродажиСебестоимость.СерияНоменклатуры.* КАК СерияНоменклатуры,
    |                    ПродажиСебестоимость.ЗаказПокупателя.* КАК ЗаказПокупателя}
    |                
    |                СГРУППИРОВАТЬ ПО
    |                    ПродажиСебестоимость.Номенклатура,
    |                    ПродажиСебестоимость.ХарактеристикаНоменклатуры,
    |                    ПродажиСебестоимость.СерияНоменклатуры,
    |                    ПродажиСебестоимость.ЗаказПокупателя,
    |                    ВЫБОР
    |                        КОГДА ПродажиСебестоимость.ДокументДвижения <> НЕОПРЕДЕЛЕНО
    |                            ТОГДА ПродажиСебестоимость.ДокументДвижения
    |                        ИНАЧЕ ПродажиСебестоимость.Регистратор
    |                    КОНЕЦ) КАК ТаблицаРегистраПродажиСебестоимость
    |                ПО ТаблицаРегистраПродажиСебестоимость.Номенклатура = ПродажиОбороты.Номенклатура
    |                    И ТаблицаРегистраПродажиСебестоимость.ХарактеристикаНоменклатуры = ПродажиОбороты.ХарактеристикаНоменклатуры
    |                    И ТаблицаРегистраПродажиСебестоимость.СерияНоменклатуры = ПродажиОбороты.СерияНоменклатуры
    |                    И ТаблицаРегистраПродажиСебестоимость.ЗаказПокупателя = ПродажиОбороты.ЗаказПокупателя
    |                    И ТаблицаРегистраПродажиСебестоимость.Регистратор = ПродажиОбороты.Регистратор) КАК ВложенныйЗапрос
    |    
    |    СГРУППИРОВАТЬ ПО
    |        ВложенныйЗапрос.Организация,
    |        ВложенныйЗапрос.Проект,
    |        ВложенныйЗапрос.Подразделение,
    |        ВложенныйЗапрос.ДокументОприходования.Контрагент,
    |        ВложенныйЗапрос.Покупатель,
    |        ВложенныйЗапрос.ДоговорПокупателя,
    |        ВложенныйЗапрос.Номенклатура,
    |        ВложенныйЗапрос.ХарактеристикаНоменклатуры,
    |        ВложенныйЗапрос.СерияНоменклатуры,
    |        ВложенныйЗапрос.ЗаказПокупателя,
    |        ВложенныйЗапрос.ДокументОприходования,
    |        ВложенныйЗапрос.Регистратор,
    |        ВложенныйЗапрос.Период
    |    
    |    ИМЕЮЩИЕ
    |        (СУММА(ВложенныйЗапрос.Количество) <> 0
    |            ИЛИ СУММА(ВложенныйЗапрос.Себестоимость) <> 0
    |            ИЛИ СУММА(ВЫБОР
    |                    КОГДА ВложенныйЗапрос.КоличествоПродажи = 0
    |                        ТОГДА ВложенныйЗапрос.Стоимость
    |                    ИНАЧЕ ВложенныйЗапрос.Стоимость * ВложенныйЗапрос.Количество / ВложенныйЗапрос.КоличествоПродажи
    |                КОНЕЦ) <> 0)) КАК ВложенныйЗапрос
    |    //СОЕДИНЕНИЯ
    |{ГДЕ
    |    ВложенныйЗапрос.ДокументОприходования.* КАК ДокументОприходования,
    |    ВложенныйЗапрос.Поставщик.* КАК Поставщик,
    |    ВложенныйЗапрос.Регистратор.*,
    |    ВложенныйЗапрос.Период,
    |    ВложенныйЗапрос.ПериодДень,
    |    ВложенныйЗапрос.ПериодНеделя,
    |    ВложенныйЗапрос.ПериодДекада,
    |    ВложенныйЗапрос.ПериодМесяц,
    |    ВложенныйЗапрос.ПериодКвартал,
    |    ВложенныйЗапрос.ПериодПолугодие,
    |    ВложенныйЗапрос.ПериодГод,
    |    ВложенныйЗапрос.Количество,
    |    ВложенныйЗапрос.КоличествоЕдиницОтчетов,
    |    ВложенныйЗапрос.КоличествоБазовыхЕдиниц,
    |    ВложенныйЗапрос.СтоимостьБезНДС,
    |    ВложенныйЗапрос.НДС,
    |    ВложенныйЗапрос.Стоимость,
    |    ВложенныйЗапрос.Себестоимость,
    |    ВложенныйЗапрос.ВаловаяПрибыль,
    |    ВложенныйЗапрос.Эффективность,
    |    ВложенныйЗапрос.Рентабельность
    |    //УСЛОВИЯ_СВОЙСТВА
    |    //УСЛОВИЯ_КАТЕГОРИИ
    |}
    |{УПОРЯДОЧИТЬ ПО
    |    Организация.*,
    |    Проект.*,
    |    Подразделение.*,
    |    Поставщик.*,
    |    Покупатель.*,
    |    ДоговорПокупателя.*,
    |    Номенклатура.*,
    |    ХарактеристикаНоменклатуры.*,
    |    СерияНоменклатуры.*,
    |    ЗаказПокупателя.*,
    |    ДокументОприходования.*,
    |    Регистратор.*,
    |    Период,
    |    ПериодДень,
    |    ПериодНеделя,
    |    ПериодДекада,
    |    ПериодМесяц,
    |    ПериодКвартал,
    |    ПериодПолугодие,
    |    ПериодГод,
    |    Количество,
    |    КоличествоЕдиницОтчетов,
    |    КоличествоБазовыхЕдиниц,
    |    СтоимостьБезНДС,
    |    НДС,
    |    Стоимость,
    |    Себестоимость,
    |    ВаловаяПрибыль,
    |    Эффективность,
    |    Рентабельность
    |    //ПСЕВДОНИМЫ_СВОЙСТВА
    |    //ПСЕВДОНИМЫ_КАТЕГОРИИ
    |}
    |ИТОГИ
    |    СУММА(Количество),
    |    СУММА(КоличествоЕдиницОтчетов),
    |    СУММА(КоличествоБазовыхЕдиниц),
    |    СУММА(СтоимостьБезНДС),
    |    СУММА(НДС),
    |    СУММА(Стоимость),
    |    СУММА(Себестоимость),
    |    ВЫБОР
    |        КОГДА &НеВключатьНДСВСтоимостьПартий
    |            ТОГДА СУММА(СтоимостьБезНДС)
    |        ИНАЧЕ СУММА(Стоимость)
    |    КОНЕЦ - СУММА(Себестоимость) КАК ВаловаяПрибыль,
    |    100 * ВЫБОР
    |        КОГДА &НеВключатьНДСВСтоимостьПартий
    |            ТОГДА ВЫБОР
    |                    КОГДА СУММА(Себестоимость) <> 0
    |                        ТОГДА (СУММА(СтоимостьБезНДС) - СУММА(Себестоимость)) / СУММА(Себестоимость)
    |                    ИНАЧЕ 0
    |                КОНЕЦ
    |        ИНАЧЕ ВЫБОР
    |                КОГДА СУММА(Себестоимость) <> 0
    |                    ТОГДА (СУММА(Стоимость) - СУММА(Себестоимость)) / СУММА(Себестоимость)
    |                ИНАЧЕ 0
    |            КОНЕЦ
    |    КОНЕЦ КАК Эффективность,
    |    100 * ВЫБОР
    |        КОГДА &НеВключатьНДСВСтоимостьПартий
    |            ТОГДА ВЫБОР
    |                    КОГДА СУММА(СтоимостьБезНДС) <> 0
    |                        ТОГДА (СУММА(СтоимостьБезНДС) - СУММА(Себестоимость)) / СУММА(СтоимостьБезНДС)
    |                    ИНАЧЕ 0
    |                КОНЕЦ
    |        ИНАЧЕ ВЫБОР
    |                КОГДА СУММА(Стоимость) <> 0
    |                    ТОГДА (СУММА(Стоимость) - СУММА(Себестоимость)) / СУММА(Стоимость)
    |                ИНАЧЕ 0
    |            КОНЕЦ
    |    КОНЕЦ КАК Рентабельность
    |    //ИТОГИ_СВОЙСТВА
    |    //ИТОГИ_КАТЕГОРИИ
    |ПО
    |    ОБЩИЕ
    |{ИТОГИ ПО
    |    Организация.*,
    |    Проект.*,
    |    Подразделение.*,
    |    Поставщик.*,
    |    Покупатель.*,
    |    ДоговорПокупателя.*,
    |    Номенклатура.*,
    |    ХарактеристикаНоменклатуры.*,
    |    СерияНоменклатуры.*,
    |    ЗаказПокупателя.*,
    |    ДокументОприходования.*,
    |    Регистратор.*,
    |    Период,
    |    ПериодДень,
    |    ПериодНеделя,
    |    ПериодДекада,
    |    ПериодМесяц,
    |    ПериодКвартал,
    |    ПериодПолугодие,
    |    ПериодГод
    |    //ПСЕВДОНИМЫ_СВОЙСТВА
    |    //ПСЕВДОНИМЫ_КАТЕГОРИИ
    |}";
    
    // В универсальном отчете включен флаг использования свойств и категорий.
    Если УниверсальныйОтчет.ИспользоватьСвойстваИКатегории Тогда
        
        // Добавление свойств и категорий поля запроса в таблицу полей.
        // Необходимо вызывать для каждого поля запроса, предоставляющего возможность использования свойств и категорий.
        
        // УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля(<ПсевдонимТаблицы>.<Поле> , <ПсевдонимПоля>, <Представление>, <Назначение>);
        УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ВложенныйЗапрос.Организация", "Организация", "Организация", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Организации);
        УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ВложенныйЗапрос.Поставщик", "Поставщик", "Поставщик", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Контрагенты);
        УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ВложенныйЗапрос.Покупатель", "Покупатель", "Покупатель", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Контрагенты);
        УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ВложенныйЗапрос.ДоговорПокупателя", "ДоговорПокупателя", "Договор покупателя", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_ДоговорыКонтрагентов);
        УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ВложенныйЗапрос.Номенклатура", "Номенклатура", "Номенклатура", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Номенклатура);
        УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ВложенныйЗапрос.ХарактеристикаНоменклатуры", "ХарактеристикаНоменклатуры", "Характеристика номенклатуры", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_ХарактеристикиНоменклатуры);
        УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ВложенныйЗапрос.ЗаказПокупателя", "ЗаказПокупателя", "Заказ покупателя", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Документы);
        УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ВложенныйЗапрос.ЗаказПокупателя", "ЗаказПокупателя", "Заказ покупателя", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Документ_ЗаказПокупателя);
        УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ВложенныйЗапрос.ДокументОприходования", "ДокументОприходования", "Документ оприходования", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Документы);
        
        // Добавление свойств и категорий в исходный текст запроса.
        УниверсальныйОтчет.ДобавитьВТекстЗапросаСвойстваИКатегории(ТекстЗапроса);
        
    КонецЕсли;
        
    // Инициализация текста запроса построителя отчета
    УниверсальныйОтчет.ПостроительОтчета.Текст = ТекстЗапроса;
    
    // Представления полей отчета.
    // Необходимо вызывать для каждого поля запроса.
    // УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить(<ИмяПоля>, <ПредставлениеПоля>);
    
    // Покупатель
    // ДоговорКонтрагента
    
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Организация", "Организация");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Проект", "Проект");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Подразделение", "Подразделение");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Поставщик", "Поставщик");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Покупатель", "Покупатель");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("ДоговорПокупателя", "Договор покупателя");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Номенклатура", "Номенклатура");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("ХарактеристикаНоменклатуры", "Характеристика номенклатуры");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("СерияНоменклатуры", "Серия номенклатуры");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("ЗаказПокупателя", "Заказ покупателя");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("ДокументОприходования", "Документ оприходования");
    
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Количество", "Количество (ед. хранения)");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("КоличествоЕдиницОтчетов", "Количество (ед. отчетов)");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("КоличествоБазовыхЕдиниц", "Количество (базовых ед.)");
    
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("СтоимостьБезНДС", "Стоимость продажи без НДС");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("НДС", "НДС продажи");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Стоимость", "Стоимость продажи с НДС");
    
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Себестоимость", "Себестоимость");
    
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("ВаловаяПрибыль", "Валовая прибыль");
    
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Эффективность", "Эффективность, %");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Рентабельность", "Рентабельность, %");
    
    // Добавление показателей
    // Необходимо вызывать для каждого добавляемого показателя.
    ВалютаУпр = глЗначениеПеременной("ВалютаУправленческогоУчета");
    // УниверсальныйОтчет.ДобавитьПоказатель(<ИмяПоказателя>, <ПредставлениеПоказателя>, <ВключенПоУмолчанию>, <Формат>, <ИмяГруппы>, <ПредставлениеГруппы>);
    УниверсальныйОтчет.ДобавитьПоказатель("Количество", "Ед. хранения", Истина, "ЧЦ=15; ЧДЦ=3", "Количество", "Количество");
    УниверсальныйОтчет.ДобавитьПоказатель("КоличествоБазовыхЕдиниц", "Базовых ед.", Ложь, "ЧЦ=15; ЧДЦ=3", "Количество", "Количество");
    УниверсальныйОтчет.ДобавитьПоказатель("КоличествоЕдиницОтчетов", "Ед. отчетов", Ложь, "ЧЦ=15; ЧДЦ=3", "Количество", "Количество");
    
    УниверсальныйОтчет.ДобавитьПоказатель("СтоимостьБезНДС", "Без НДС", Истина, "ЧЦ=15; ЧДЦ=2", "СтоимостьПродажи", "Стоимость продажи (" + ВалютаУпр + ")");
    УниверсальныйОтчет.ДобавитьПоказатель("НДС", "НДС", Ложь, "ЧЦ=15; ЧДЦ=2", "СтоимостьПродажи");
    УниверсальныйОтчет.ДобавитьПоказатель("Стоимость", "С НДС", Истина, "ЧЦ=15; ЧДЦ=2", "СтоимостьПродажи");
    
    УниверсальныйОтчет.ДобавитьПоказатель("Себестоимость", "Себестоимость  (" + ВалютаУпр + ")", Ложь, "ЧЦ=15; ЧДЦ=2");
    
    УниверсальныйОтчет.ДобавитьПоказатель("ВаловаяПрибыль", "Валовая прибыль (" + ВалютаУпр + ")", Истина, "ЧЦ=15; ЧДЦ=2");
    
    УниверсальныйОтчет.ДобавитьПоказатель("Эффективность", "Эффективность, %", Ложь, "ЧЦ=15; ЧДЦ=2");
    УниверсальныйОтчет.ДобавитьПоказатель("Рентабельность", "Рентабельность, %", Истина, "ЧЦ=15; ЧДЦ=2");
    
    // Добавление предопределенных группировок строк отчета.
    // Необходимо вызывать для каждой добавляемой группировки строки.
    // УниверсальныйОтчет.ДобавитьИзмерениеСтроки(<ПутьКДанным>);
    УниверсальныйОтчет.ДобавитьИзмерениеСтроки("Поставщик");
    УниверсальныйОтчет.ДобавитьИзмерениеСтроки("Номенклатура");
    УниверсальныйОтчет.ДобавитьИзмерениеСтроки("Покупатель");
    
    // Добавление предопределенных группировок колонок отчета.
    // Необходимо вызывать для каждой добавляемой группировки колонки.
    // УниверсальныйОтчет.ДобавитьИзмерениеКолонки(<ПутьКДанным>);
    
    // Добавление предопределенных отборов отчета.
    // Необходимо вызывать для каждого добавляемого отбора.
    // УниверсальныйОтчет.ДобавитьОтбор(<ПутьКДанным>);
    УниверсальныйОтчет.ДобавитьОтбор("Организация");
    УниверсальныйОтчет.ДобавитьОтбор("Подразделение");
    УниверсальныйОтчет.ДобавитьОтбор("Поставщик");
    УниверсальныйОтчет.ДобавитьОтбор("Покупатель");
    УниверсальныйОтчет.ДобавитьОтбор("Номенклатура");
    
    // Добавление предопределенных полей порядка отчета.
    // Необходимо вызывать для каждого добавляемого поля порядка.
    // УниверсальныйОтчет.ДобавитьПорядок(<ПутьКДанным>);
    
    // Установка связи подчиненных и родительских полей
    // УниверсальныйОтчет.УстановитьСвязьПолей(<ПутьКДанным>, <ПутьКДаннымРодитель>);
    
    // Установка связи полей и измерений
    // УниверсальныйОтчет.УстановитьСвязьПоляИИзмерения(<ИмяПоля>, <ИмяИзмерения>);
    
    // Установка представлений полей
    УниверсальныйОтчет.УстановитьПредставленияПолей(УниверсальныйОтчет.мСтруктураПредставлениеПолей, УниверсальныйОтчет.ПостроительОтчета);
    
    // Установка типов значений свойств в отборах отчета
    УниверсальныйОтчет.УстановитьТипыЗначенийСвойствДляОтбора();
    
    // Заполнение начальных настроек универсального отчета
    УниверсальныйОтчет.УстановитьНачальныеНастройки(Ложь);
    
    // Добавление дополнительных полей
    // Необходимо вызывать для каждого добавляемого дополнительного поля.
    // УниверсальныйОтчет.ДобавитьДополнительноеПоле(<ПутьКДанным>, <Размещение>, <Положение>);
    
КонецПроцедуры // УстановитьНачальныеНастройки()

////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ И ФУНКЦИИ ФОРМИРОВАНИЯ ОТЧЕТА
    
// Процедура формирования отчета
//
Процедура СформироватьОтчет(ТабличныйДокумент) Экспорт
    
    // Перед формирование отчета можно установить необходимые параметры универсального отчета.
    Отказ = Ложь;
    УчетнаяПолитика = ОбщегоНазначения.ПолучитьПараметрыУчетнойПолитики(?(Не ЗначениеЗаполнено(УниверсальныйОтчет.ДатаКон), ТекущаяДата(), УниверсальныйОтчет.ДатаКон), Отказ);
    УниверсальныйОтчет.ПостроительОтчета.Параметры.Вставить("НеВключатьНДСВСтоимостьПартий", ?(Отказ, Ложь, УчетнаяПолитика.НеВключатьНДСВСтоимостьПартий));
    
    УниверсальныйОтчет.СформироватьОтчет(ТабличныйДокумент);

КонецПроцедуры // СформироватьОтчет()

////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ И ФУНКЦИИ ОБЩЕГО НАЗНАЧЕНИЯ

// Процедура обработки расшифровки
//
Процедура ОбработкаРасшифровки(Расшифровка, Объект) Экспорт
    
    // Дополнительные параметры в расшифровывающий отчет можно передать
    // посредством инициализации переменной "ДополнительныеПараметры".
    
    ДополнительныеПараметры = Неопределено;
    УниверсальныйОтчет.ОбработкаРасшифровкиУниверсальногоОтчета(Расшифровка, Объект, ДополнительныеПараметры);
    
КонецПроцедуры // ОбработкаРасшифровки()

// Формирует структуру для сохранения настроек отчета
//
Процедура СформироватьСтруктуруДляСохраненияНастроек(СтруктураСНастройками) Экспорт
    
    УниверсальныйОтчет.СформироватьСтруктуруДляСохраненияНастроек(СтруктураСНастройками);
    
КонецПроцедуры // СформироватьСтруктуруДляСохраненияНастроек()

// Заполняет настройки отчета из структуры сохраненных настроек
//
Функция ВосстановитьНастройкиИзСтруктуры(СтруктураСНастройками) Экспорт
    
    Возврат УниверсальныйОтчет.ВосстановитьНастройкиИзСтруктуры(СтруктураСНастройками, ЭтотОбъект);
    
КонецФункции // ВосстановитьНастройкиИзСтруктуры()

// Содержит значение используемого режима ввода периода.
// Тип: Число.
// Возможные значения: 0 - произвольный период, 1 - на дату, 2 - неделя, 3 - декада, 4 - месяц, 5 - квартал, 6 - полугодие, 7 - год
// Значение по умолчанию: 0
// Пример:
// УниверсальныйОтчет.мРежимВводаПериода = 1;

#КонецЕсли



Это МодульФормы
////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ И ФУНКЦИИ ОБЩЕГО НАЗНАЧЕНИЯ

// Обновляет таблицу отчета
//
Процедура ОбновитьОтчет() Экспорт
    
    СформироватьОтчет(ЭлементыФормы.ПолеТабличногоДокументаРезультат);
    
КонецПроцедуры // ОбновитьОтчет()

////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ - ОБРАБОТЧИКИ СОБЫТИЙ ФОРМЫ

// Процедура - обработчик события при открытии формы
//
Процедура ПриОткрытии()
    
    //УниверсальныйОтчет.ФормаПриОткрытии(УниверсальныйОтчет, ЭтотОбъект, ЭтаФорма,,, Новый Действие("ПолеВводаВидСравненияПриИзменении"), Новый Действие("ПолеВводаЗначениеПриИзменении"));
    УниверсальныйОтчет.мДействиеПолеВводаВидСравненияПриИзменении = Новый Действие("ПолеВводаВидСравненияПриИзменении");
    УниверсальныйОтчет.мДействиеПолеВводаЗначениеПриИзменении = Новый Действие("ПолеВводаЗначениеПриИзменении");
    УниверсальныйОтчет.мДействиеКоманднаяПанельФормыПечать = Новый Действие("КоманднаяПанельФормыПечать");
    
    УниверсальныйОтчет.ФормаПриОткрытии(УниверсальныйОтчет, ЭтотОбъект, ЭтаФорма);
    
    
    
КонецПроцедуры // ПриОткрытии()

// Процедура - обработчик события при закрытии формы
//
Процедура ПриЗакрытии()
    
    УниверсальныйОтчет.ФормаПриЗакрытии(УниверсальныйОтчет, ЭтотОбъект, ЭтаФорма);
        
КонецПроцедуры // ПриЗакрытии()

////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ - ОБРАБОТЧИКИ НАЖАТИЯ КНОПОК КОМАНДНОЙ ПАНЕЛИ

// Процедура - обработчик нажатия кнопки "Печать"
//
Процедура КоманднаяПанельФормыПечать(Кнопка)
    
    УниверсальныйОтчет.ФормаПечать(УниверсальныйОтчет, ЭтотОбъект, ЭтаФорма);
    
КонецПроцедуры // КоманднаяПанельФормыПечать()

// Процедура - обработчик нажатия кнопки "Сформировать"
//
Процедура КоманднаяПанельФормыСформировать(Кнопка)
    
    ОбновитьОтчет();
    
КонецПроцедуры // КоманднаяПанельФормыСформировать()

// Процедура - обработчик нажатия кнопки "Настройка"
//
Процедура КоманднаяПанельФормыНастройка(Кнопка)
    
    УниверсальныйОтчет.ФормаНастройка(УниверсальныйОтчет, ЭтотОбъект, ЭтаФорма, ЭлементыФормы.ПолеТабличногоДокументаРезультат);
    
КонецПроцедуры // КоманднаяПанельФормыНастройка()

// Процедура - обработчик нажатия кнопки "НовыйОтчет"
//
Процедура КоманднаяПанельФормыНовыйОтчет(Кнопка)
    
    // Дополнительные параметры в расшифровывающий отчет можно передать
    // посредством инициализации переменной "ДополнительныеПараметры".
    ДополнительныеПараметры = Неопределено;
    
    УниверсальныйОтчет.ФормаНовыйОтчет(УниверсальныйОтчет, ЭтотОбъект, ДополнительныеПараметры);

КонецПроцедуры // КоманднаяПанельФормыНовыйОтчет()

// Процедура - обработчик нажатия кнопки "БыстрыеОтборы"
//
Процедура КоманднаяПанельФормыБыстрыеОтборы(Кнопка)
    
    УниверсальныйОтчет.УправлениеОтображениемЭлементовФормы(УниверсальныйОтчет, ЭтаФорма, Кнопка.Имя);
    УниверсальныйОтчет.УправлениеПанельюБыстрыеОтборы(УниверсальныйОтчет, ЭтаФорма);
    
КонецПроцедуры // КоманднаяПанельФормыБыстрыеОтборы()

// Процедура - обработчик нажатия кнопки "ЗаголовокОтчета"
//
Процедура КоманднаяПанельФормыЗаголовокОтчета(Кнопка)
    
    УниверсальныйОтчет.УправлениеОтображениемЭлементовФормы(УниверсальныйОтчет, ЭтаФорма, Кнопка.Имя);
    УниверсальныйОтчет.УправлениеОтображениемЗаголовка(УниверсальныйОтчет, ЭлементыФормы.ПолеТабличногоДокументаРезультат);
    
КонецПроцедуры // КоманднаяПанельФормыЗаголовокОтчета()

// Процедура - обработчик нажатия кнопки "ВосстановитьНастройку"
//
Процедура КоманднаяПанельФормыВосстановитьНастройку(Кнопка)
    
    УниверсальныйОтчет.ВосстановитьНастройки(УниверсальныйОтчет, ЭтотОбъект, ЭтаФорма);
    
    
КонецПроцедуры // КоманднаяПанельФормыДействиеВосстановитьЗначения()

// Процедура - обработчик нажатия кнопки "СохранитьНастройку"
//
Процедура КоманднаяПанельФормыСохранитьНастройку(Кнопка)
    
    УниверсальныйОтчет.СохранитьНастройки(УниверсальныйОтчет, ЭтотОбъект, ЭтаФорма);
    
КонецПроцедуры // КоманднаяПанельФормыДействиеСохранитьЗначения()

////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ - ОБРАБОТЧИКИ СОБЫТИЙ ЭЛЕМЕНТОВ ФОРМЫ

// Процедура - обработчик нажатия кнопки "КнопкаНастройкаПериода"
//
Процедура КнопкаНастройкаПериодаНажатие(Элемент)
    
    УниверсальныйОтчет.ФормаНастройкаПериода(УниверсальныйОтчет);
    
КонецПроцедуры // КнопкаНастройкаПериодаНажатие()

// Процедура - обработчик нажатия кнопки "КнопкаМинусПериод"
//
Процедура КнопкаМинусПериодНажатие(Элемент)
    
    УниверсальныйОтчет.ФормаМинусПериод(УниверсальныйОтчет);
    
КонецПроцедуры // КнопкаМинусПериодНажатие()

// Процедура - обработчик нажатия кнопки "КнопкаПлюсПериод"
//
Процедура КнопкаПлюсПериодНажатие(Элемент)
    
    УниверсальныйОтчет.ФормаПлюсПериод(УниверсальныйОтчет);
    
КонецПроцедуры // КнопкаПлюсПериодНажатие()

// Процедура - обработчик события "Обработка расшифровки" поля табличного документа "ПолеТабличногоДокументаРезультат"
//
Процедура ПолеТабличногоДокументаРезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    ОбработкаРасшифровки(Расшифровка, ОтчетОбъект);
    
КонецПроцедуры // ПолеТабличногоДокументаРезультатОбработкаРасшифровки()

// Процедура - обработчик события "При изменении" поля ввода "ПолеВводаВидСравнения"
//
Процедура ПолеВводаВидСравненияПриИзменении(Элемент)
    
    УниверсальныйОтчет.ВидСравненияПриИзменении(Элемент, ЭтаФорма);
    
КонецПроцедуры // ПолеВводаВидСравненияПриИзменении()

// Процедура - обработчик события "При изменении" полей ввода "Значение", "ЗначениеС", "ЗначениеПо"
//
Процедура ПолеВводаЗначениеПриИзменении(Элемент)
    
    УниверсальныйОтчет.ЗначениеПриИзменении(Элемент, ЭтаФорма);
    
КонецПроцедуры // ПолеВводаВидСравненияПриИзменении()


Прошу помочь ребята smile.gif
Просмотров: 84, последний комментарий от Vofka   
MES Что такое и с чем едят [раздел Остальные конфигурации 1С 8]
Автор ZenBi — 14.06.21, 14:12 — 0 комментариев
Здравствуйте!
Колом постал вопрос перехода на новую базу. Рассматривал множество конфигураций и как-то случайно наткнулся на эдакого зверя - MES (Оперативное управление производством и другие интересные конфигурации).
Если кто-то встречался/работал/совершал переход на нечто эдакое - Нужно ваше мнение.
1) Стоит ли менять избитое УПП на MES?
2) Какова стоимость перехода на MES? (Почему-то прайс лист в 500 тысяч кажется мне надувательством и реальная цена должна начинаться от 1.5 кк)
3) Что из себя представляет MES?
4) Сложности перехода.
5) Сложности ведения (со стороны программиста)
6) Личное мнение тех кто уже работал с MES.
Ну и прочие вопросы, если есть что сказать.
Просмотров: 84, оставить комментарий   
Открытие формы при старте системы [раздел Программирование в 1С Предприятие 8.3]
Автор BeLuY — 14.06.21, 14:03 — 10 комментариев
Добрый день. В управляемом приложении необходимо сделать автоматическое открытие формы при запуске программы в зависимости от наличия определенной роли. Форму необходимо открыть модально. Знаю, что в обычном приложении это можно сделать в Модуле обычного приложения, в процедуре ПриНачалеРаботыСистемы(), но в управляемом так не работает:

    Если РольДоступна("Роль") Тогда        
        Форма = ПолучитьФорму("Обработка.НоваяОбработка.Форма");        
        Рез = Форма.ОткрытьМодально();        
        
        // Если не удалось
        Если Рез = Ложь Тогда
            // Закрываем программу
            ЗавершитьРаботуСистемы(Ложь);
        КонецЕсли;    
    КонецЕсли;

Это не работает, потому как:
  1. Ругается на глобальный метод РольДоступна(), так как он доступен только на сервере
  2. Модально открыть не получается - выводит ошибку "Использование модальных окон в данном режиме запрещено!"

Опыта работы с управляемыми формами очень мало, но я понимаю, что метод РольДоступна() доступен на сервере, а ПолучитьФорму() на клиенте, и они должны быть, как минимум в разных процедурах (или не всегда? =)), но код я взял из обычного приложения (почти весь) и привел для примера.

Зачем это нужно: Есть мобильное устройство, если заходить в программу с него под пользователем, у которого указана определенная роль, необходимо на весь экран запустить определенную форму с несколькими кнопками, адаптированную под экран мобильного устройства. Так у меня сейчас работает в обычном приложении.

Так вот, как можно решить данный вопрос? Как и где в управляемом приложении описать процедуру проверки доступности роли и модальное открытие окна? Или может мой способ в корне неверный и есть другой, более правильный механизм?

Спасибо)

Конфигурация: BAS Роздрібна торгівля
Просмотров: 191, последний комментарий от BeLuY   
глюк при сохранении файла xls [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 11.06.21, 17:16 — 2 комментариев
1С 7.7
при сохранении документа в формате xls - счет или накладная в одной ячейке сохраняет не более 300 символов, хотя в печатной форме знаков намного больше. в формате htm проблем нет. только в xls. что можно сделать?
Просмотров: 92, последний комментарий от denis84   
Вывод табличного документа на форму [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор stajer — 10.06.21, 16:22 — 2 комментариев
Здравтсвуйте.
1С:Предприятие 8.3 (8.3.13.1513)
"Управление торговым предприятием для Украины", редакция 1.2. (1.2.63.1)

В обработке на основании макета заполняю табличный документ. По команде Показать() в отдельном окне открывается заполненный табличный документ. Добавил реквизит в обработку типа табличный документ и вывел его на форму, как поле табличного документа. Пытаюсь передавать табличный документ таким образом:
ЭлементыФормы.ТабДокФормы.Значение = ТабДок;

Но на форме пустое поле.
Подскажите как можно вывести табличный документ в поле на форму?
Просмотров: 74, последний комментарий от stajer   
ЗИК 67 выгрузка --> ЗУП 8.3 2.1.60.1, В 8.3 пропадают периоды в "Отпуска организаций " [раздел Программирование в 1С Предприятие 7.7]
Автор anatol1c — 10.06.21, 11:24 — 4 комментариев
Добрый день, Всем.
Подскажите, пожалуйста, если сталкивались с такой проблемой.

ЗУП 8.3. Ведется кадровый учет несколько лет. Для расчета ЗП не использовалась.
Хочу загрузить начисления и удержания за месяц 2020 года. Выгружаю обработкой V77Exp.ert из ЗИК данные в файл xml.
После загрузки в ЗУП , в Документах "Отпуска организаций" пропадают "Периоды отпусков". Я так понимаю, что где-то обнуляются данные в регистрах.

Подскажите, пожалуйста.
Документы "Перенос данных" могут обнуляют данные в регистрах?

Или где-то что-то в обработке или правилах "заремить", чтобы в 1с 8.3 в регистры ничего не записывалось?

Сейчас стоит платформа BAF 8.3.16.90. Но этот глюк проявлялся и на 8.3.16.1148, и на 8.3.15. 1595.

С уважением, Анатолий.
Просмотров: 80, последний комментарий от anatol1c   
Ошибка перехода на BAS Agro [раздел Программирование в 1С Предприятие 8.3]
Автор BeLuY — 09.06.21, 9:33 — 13 комментариев
Добрый день. Уже второй день пытаемся выполнить переход с конфигурации "1С:Бухгалтерія сільськогосподарського підприємства для України" на BAS Agro, но безуспешно. Согласно файлу-описанию обновления: "Для перехода на версию 2.1.13 необходимо использовать версию конфигурации "Бухгалтерія сільськогосподарського підприємства" не ниже 2.0.28.1.". Версия, с которой выполняем переход, 2.0.28.1, но при попытке выполнения обновления из конфигуратора получаем сообщение "Файл не содержит доступных обновлений". Комплект поставки взяли с портала ИТС. Из-за чего может такое происходить?

Версия платформы: 8.3.16.1063

Спасибо



Просмотров: 166, последний комментарий от strelok2   
Объединение 3-х запросов [раздел Программирование в 1С Предприятие 8.3]
Автор bizisoft — 09.06.21, 9:14 — 9 комментариев
Здравствуйте.
1С 8.3.14.2095 Альфа-Авто 4.1.23.01

Подскажите пожалуйста возможно-ли объединить 3 запроса в один?

Запрос №1 - Получаю все аналоги для текущего товара
"ВЫБРАТЬ
        |    ГруппыАналогов.Артикул КАК Артикул,
        |    ГруппыАналогов.Производитель КАК Производитель
        |ИЗ
        |    РегистрСведений.ГруппыАналогов КАК ГруппыАналогов
        |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ГруппыАналогов КАК ГруппыАналогов1
        |        ПО ГруппыАналогов.ИдентификаторГруппы = ГруппыАналогов1.ИдентификаторГруппы
        |ГДЕ
        |    ГруппыАналогов1.Артикул = &Артикул
        |";

Результат выгружаю в СписокЗначений

Запрос №2 - Получаю из справочника ПрайсЛистыКонтрагентов список у которых стоит галочка
"ВЫБРАТЬ
        |    ПрайсЛистыКонтрагентов.Ссылка КАК Ссылка
        |ИЗ
        |    Справочник.ПрайсЛистыКонтрагентов КАК ПрайсЛистыКонтрагентов
        |ГДЕ
        |    ПрайсЛистыКонтрагентов.флКонкурент = ИСТИНА";


Результат выгружаю в СписокЗначений


Запрос №3 - Получаю товары из прайслистов контрагентов, согласно двух ранее полученных списков значений.
ВЫБРАТЬ
        |    ПрайсЛистыКонтрагентов.ПрайсЛист КАК ПрайсЛист,
        |    ПрайсЛистыКонтрагентов.Артикул КАК Артикул,
        |    ПрайсЛистыКонтрагентов.Производитель КАК Производитель,
        |    ПрайсЛистыКонтрагентов.Цена КАК Цена,
        |    ПрайсЛистыКонтрагентов.Количество КАК Количество,
        |    ПрайсЛистыКонтрагентов.Контрагент КАК Контрагент,
        |    ПрайсЛистыКонтрагентов1.Валюта КАК Валюта
        |ИЗ
        |    РегистрСведений.ПрайсЛистыКонтрагентов КАК ПрайсЛистыКонтрагентов
        |        ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ПрайсЛистыКонтрагентов КАК ПрайсЛистыКонтрагентов1
        |        ПО ПрайсЛистыКонтрагентов.ПрайсЛист = ПрайсЛистыКонтрагентов1.Ссылка
        |ГДЕ
        |    ПрайсЛистыКонтрагентов.Артикул В(&Артикул)
        |    И ПрайсЛистыКонтрагентов1.Ссылка В(&СпЗнКонкурентныеПрайсы)
        |    И ПрайсЛистыКонтрагентов.Производитель = &Производитель
        |
        |УПОРЯДОЧИТЬ ПО
        |    Цена";

Из результата запроса определяется позиция прайса с минимальной { ТЗ[0].Цена } и максимальной { ТЗ[ТЗ.Количество()-1].Цена } ценой и вычисляется средняя.

Я так и не смог найти, как можно в одном запросе это организовать, чтобы результаты подзапросов (Аналоги) и (Прайсы) передавались в основной запрос как списки значений.
Пробовал Вложенные запросы и временные таблицы, но связать эти три запроса так и не смог.

Можно было и оставить 3 отдельных запроса, но при переборе списка товаров в цикле, для каждого товара необходимо выполнять эти три запроса, а это наверное будет увеличивать общее время обработки списка товаров, а в дальнейшем думал попробовать вообще одним запросом обработать список товаров и вышеописанную кухню (если такое позволяют запросы).
Просмотров: 150, последний комментарий от logist   
Вопрос по архитектуре отчета выгружаемого через ФРЕДО [раздел Программирование в 1С Предприятие 8.3]
Автор kihor — 08.06.21, 17:32 — 2 комментариев
Коллеги, добрый день!

Недавно мы начали использовать ФРЕДО для формирования нового объединенного отчета ЕСВ+1ДФ. Ранее, у нас в отчете 1ДФ были свои небольшие доработки. Сейчас бухгалтера хотят, чтобы эти наработки были перенесены и в новый отчет. Возможно, кто-то знает, можно ли вносить изменения в алгоритм формирования нового объединенного отчета при том, что он передается в ФРЕДО? Я, на данный момент, не совсем четко понимаю архитектуру формирования отчета при помощи ФРЕДО.
Заранее спасибо за ответы.

P.S.
Вопрос касается конфигурации 1С ЗУП, если это имеет значение.
Просмотров: 92, последний комментарий от kihor   
Обучение персонала УПП [раздел 1С Управление производственным предприятием 8]
Автор ZenBi — 07.06.21, 7:29 — 11 комментариев
Здравствуйте!
Появилась неожиданная проблема. Пришёл на работу и.... в общем тут установлена 1С 8.3 УПП. Программа работает, но вот заказчик либо решил сэкономить, либо по своей глупости не прочёл контракт. 44000000.gif
В общем - Программист установил 1С, перевёл туда все данные, и в меру своих возможностей объяснил персоналу как этим пользоваться. В его контракте не было сопровождения, обучения и прочих мелочей, только установка... всё. И вот с этим люди как-то работают уже три года.
Проблема - не обученный персонал.
Может кто-то может посоветовать по личному опыту фирму способную провести аудит, и обучение людей. Ибо неправильно ведётся документооборот.
Просмотров: 204, последний комментарий от ZenBi   
Правила обмена для выгрузки данных из ЗУП в УТП [раздел 1С Управление Торговым Предприятием 8]
Автор One — 03.06.21, 15:26 — 0 комментариев
Прошу правила обмена для выгрузки данных из ЗУП в УТП по аналогии со стандартной выгрузкой из ЗУП в БУ
Просмотров: 104, оставить комментарий   
Как правильно обновить конфигурации на сервере? [раздел Программирование в 1С Предприятие 8.3]
Автор ZenBi — 31.05.21, 9:03 — 3 комментариев
Здравствуйте!

Вот и пришёл тот страшный час, когда мне все же не удалось снова отложить обновление конфигурации, потому я приполз сюда и слёзно прошу помощи.
Не знаю как внести (БЕЗОПАСНО) изменения на сервер 1С.
Изменил несколько встроенных форм и отчёт в своей песочнице (отдельная база выгруженная из сохранения основной, в ней всё та же что и в основной, но с ней никто кроме меня не работает). 1С версии 8.3.10, база - УПП 1.3. НЕ управляемые формы (хотя это думаю понятно), база стоит на сервере и с ней постоянно работает от 40 до 100 сотрудников.
Так вот, в песочнице изменения сделал, проверил - работают. Теперь стоит задача - перенести эти изменения в основную базу или сделать их сразу там (если это возможно, благо, что работа минут на 30), и я не знаю как это сделать. При поиске в интернете находил в основном информацию о том как снять с поддержки базу, или рекомендации по её обновлению, но очень расплывчатые.
На форуме ничего не нашёл, ну или же искал плохо, да и потратил на это не много времени.

И так вопрос - как лучше и безопаснее внести изменения?
Просмотров: 201, последний комментарий от ZenBi   
Формирование документов "Распределение расходов..." [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 29.05.21, 17:37 — 2 комментариев
Приветствую, Форумчане!
1С:ERP Управление предприятием 2 (2.5.6.159)
1С:Предприятие 8.3 (8.3.18.1433)

Помогите разобраться с вопросом: Как формируются документы "Распределение расходов..." при закрытии месяца.
Как описал в свою проблему в https://pro1c.org.ua/index.php?showtopic=66577,
пытаюсь понять как формируются документы "Распределение расходов..." при закрытии месяца, т.е. пытаюсь понять почему формируется та или иная сумма, которая показывается как сумма Кредита по счету в ОСВ.

При открытии интерфейса закрытия месяца выходит дерево со столбцами:
1. Список требуемых операций для закрытия
2. Кнопка-гиперссылка, которая выполняет ту или иную операцию, указанную в первом столбце.

В связи с этим и есть первый вопрос: как и откуда формируется это дерево с указанием кнопки-гиперссылки, которая выполняет операцию?

Далее, если я понял правильно, в списке есть наименование операции "Распределение затрат и расчет себестоимости"
которая и выполняет функционал создания документов "Распределения затрат..."
Где в коде найти эту процедуру, которая и будет формировать эти документы?

Кроме того, хочу понять как в коде происходит это формирование. Т.е. ведь нужно найти необходимые данные, которые нужно распределить, далее как то их проверить, что их нужно взять, далее нужно создать еще и несколько документов распределения по одному документу (наверное).

Подскажите как формируются документы распределения при закрытии месяца, где находится этот код(ы), чтобы можно в последующем как-то проанализировать принцип работы закрытия месяца с постатейными затратами.
Просмотров: 125, последний комментарий от daveal   
92 счет в затратах БУ [раздел 1С Управление производственным предприятием 8]
Автор pablo — 28.05.21, 10:47 — 2 комментариев
Смотрю в отчет "Ведомость затрат(бу)" и вижу, что затраты по 92 счету не закрываются, при этом по бухучету 92 счет закрывается расчетом себестоимости. Проведение этого документа ошибок не дает, способ распределения статей затрат организаций заполнен.

Что нужно донастроить чтобы затраты закрывались.
Нужно ли, чтобы они закрывались?
И для чего вообще нужен этот регистр Затраты БУ? Чтобы смотреть затраты БУ без использования регистра бухгалтерии?
Просмотров: 119, последний комментарий от logist   
API Малый бизнес фотохостинг [раздел Администрирование и настройка 1С]
Автор cotllette — 27.05.21, 11:09 — 2 комментариев
Помогите, плизочки, чайнику разобраться с АПИ . Нашла фотохостинг с АПИ https://insane.su/forum/topic/23092-ipic-api/ фотохостинг
Пытаюсь выгрузить фото и получить в ответ ссылку на него. Танцую с бубном уже 2 дня..

    АдресФайла = КартинкаТовара.ПолныйПуть;
    СтрокаДляОтправки = "<form target=""ipic.su/api/index.php"" action=""loadimg"" method=""post"" enctype=""multipart/form-data"">
    |<a href=""http://ipic.su"">ipic.su/api/index.php</a>
    |<input name=""action"" value=""loadimg"" type=""hidden""/>
    |<input name=""quality"" value=""85"" type=""hidden""/>
    |<input type=""file"" name=""image"" image=" + АдресФайла + "/>
        |</form>";
        
        
    //////Запись = Новый Структура;
    //////Запись.Вставить("quality", "85");
    //////Запись.Вставить("image", КартинкаТовара.ПолныйПуть);
    //////
    //////
    //////ЗаписьJSON = Новый ЗаписьJSON;
    //////ЗаписьJSON.УстановитьСтроку();  
    //////    
    //////ЗаписатьJSON(ЗаписьJSON, Запись);
    //////ДанныеДляТела = ЗаписьJSON.Закрыть();
    
    ЗаписьJSON = Новый ЗаписьJSON;
    ЗаписьJSON.УстановитьСтроку();  
        
    ЗаписатьJSON(ЗаписьJSON, СтрокаДляОтправки);
    ДанныеДляТела = ЗаписьJSON.Закрыть();

    //
        ЗаголовокЗапросАвт = Новый Соответствие();
    ЗаголовокЗапросАвт.Вставить("Content-Type", "text/javascript");
    ЗаголовокЗапросАвт.Вставить("src", "http://ipic.su/javascript/functions.js");
    ЗаголовокЗапросАвт.Вставить("language", "javascript");
    
    //ЗаголовокЗапросАвт.Вставить("enctype", "multipart/form-data");
    //ЗаголовокЗапросАвт.Вставить("target", "http://ipic.su/index.php");
    //ЗаголовокЗапросАвт.Вставить("action", "loadimg");
    //ЗаголовокЗапросАвт.Вставить("method", "post");


    ЗапросАвт = Новый HTTPЗапрос("/api/index.php",ЗаголовокЗапросАвт);
    ЗапросАвт.УстановитьТелоИзСтроки(ДанныеДляТела);

    ОтветHTTP = HTTPСоединение.ВызватьHTTPМетод("POST", ЗапросАвт);


В ответе по идее должно появиться имя файла и код 200, или ошибка.
у меня в ответе код 200 есть, но вместо имя файла : заголовки - соответствие

и в 1м и в закомментированном случае


Я рукожоп или апи не работает?

Просмотров: 185, последний комментарий от logist   
Процедура пошуку номенклатури в БАС Бухгалтерії: проблема в дублювані позицій при загрузці через обробку [раздел Программирование в 1С Предприятие 8.3]
Автор bandrah — 26.05.21, 21:10 — 4 комментариев
Створив обробку для завантаження звітів про роздрібні продажі, перший раз все ок, при повтрній вгрузці дублюється номенклатура, додаю процедуру, що роблю не правильно вже не можу поняти, дякую всім наперед, впевнений, що світ не без добрих людей

Код
&НаСервере
Функция НайтиНоменклатуру(Номенкл, СтавкаПДВ, АртикулП)
    
    Если СокрЛП(СтавкаПДВ)="" Тогда
        СтавкаПДВ = 0;
    КонецЕсли;
    Артикул = СокрЛП(АртикулП);
    
    СтавкаНоменкл = Перечисления.СтавкиНДС.НДС20;
    //Если СтавкаПДВ = 7 Тогда
    //    СтавкаНоменкл = Перечисления.СтавкиНДС.НДС7;
    //ИначеЕсли СтавкаПДВ = 20 Тогда
    //    СтавкаНоменкл = Перечисления.СтавкиНДС.НДС20;
    //Иначе
    //    СтавкаНоменкл = Перечисления.СтавкиНДС.НДС0;
    //КонецЕсли;
    
    Если Артикул <> "" Тогда
        НайдАрт = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул",АртикулП);
        Если СокрЛП(НайдАрт)<> "" Тогда
            Артикул = НайдАрт.Ссылка;
            
        Иначе
            НовДов = Справочники.Номенклатура.СоздатьЭлемент();
            НовДов.БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду("2009"); // шт
            
            НовДов.Наименование = Номенкл;
            НовДов.НаименованиеПолное = Номенкл;
            Если Артикул<>""  Тогда
                НовДов.Артикул = Артикул;
            КонецЕсли;    
            
            НовДов.СтавкаНДС = СтавкаНоменкл;
            
            Запись = НовДов.ЕдиницыИзмерения.Добавить();
            Запись.Коэффициент         = 1;
            Запись.ЕдиницаИзмерения = НовДов.БазоваяЕдиницаИзмерения;
            
            НовДов.Записать();
            
            Возврат НовДов.Ссылка;
        КонецЕсли;
    КонецЕсли;
    
    Запит = Новый Запрос;
    Запит.Текст = "ВЫБРАТЬ
    |    Номенклатура.Ссылка КАК Номенкл,
    |    Номенклатура.Наименование
    |ИЗ
    |    Справочник.Номенклатура КАК Номенклатура
    |ГДЕ
    |    Номенклатура.ПометкаУдаления = ЛОЖЬ
    |    И Номенклатура.Наименование = &Назва
    |    И Номенклатура.Артикул = &Артикул
    |    И Номенклатура.СтавкаНДС = &СтавкаПДВ";
    
    Запит.УстановитьПараметр("Назва", Номенкл);
    Запит.УстановитьПараметр("СтавкаПДВ", СтавкаНоменкл);
    Запит.УстановитьПараметр("Артикул", АртикулП);
    Виб = Запит.Выполнить().Выбрать();
    Если Виб.Следующий() Тогда
        Если Артикул<>"" И СокрЛП(Виб.Номенкл.Артикул)="" Тогда
            Об = Виб.Номенкл.ПолучитьОбъект();
            Об.Артикул = Артикул;
            Об.Записать();
        КонецЕсли;    
        
        Если СтавкаНоменкл <> Виб.Номенкл.СтавкаНДС Тогда
            Об = Виб.Номенкл.ПолучитьОбъект();
            Об.СтавкаНДС = СтавкаНоменкл;
            Об.Записать();
        КонецЕсли;
        
        Возврат Виб.Номенкл;
    КонецЕсли;
    
КонецФункции
Просмотров: 185, последний комментарий от bandrah   
RSS Текстовая версия Сейчас: 20.06.21, 3:43
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!