Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Как текст на форме сделать невидимым? Проблема 1С 7.70.003 торговля склад для Украины? [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 23.10.19, 0:42 — 1 комментариев
Доброй ночи, господа! Или доброе утро! Это снова я.
Мне нужно, чтобы когда клиент оплатит очередной ремонт, я и только я мог делать отметку в документе об оплате.

На форме расходной я добавил атрибут Текст "СПЛАЧЕНО" с идентификатором СПЛАЧЕНО. Возле него поставил флажок с идентификатором Спл. Кроме того, флажок имеет формулу Сплачено(). Еще я добавил атрибут шапки Спл с типом число с одним разрядом. Далее, перед процедурой ПриОткрытии я прописал процедуру флажка Сплачено:


Процедура Сплачено()                   
Если Спл=0 тогда
        Форма.СПЛАЧЕНО.Видимость(0);
    Иначе
        Форма.СПЛАЧЕНО.Видимость(1);
    КонецЕсли;
КонецПроцедуры


Затем в теле процедуры ПриОткрытии прописал следующее:

Если  ПолноеИмяПользователя() <> "Simeon" Тогда
            Форма.Спл.Видимость(0);
            Форма.Спл.Доступность(0);
       Форма.СПЛАЧЕНО.Доступность(0);
    КонецЕсли;
    
    Если Спл=0 тогда  
         Форма.СПЛАЧЕНО.Видимость(0);
         Иначе
        Форма.СПЛАЧЕНО.Видимость(1);
    КонецЕсли;


А проблема в том, что при открытии документа текст СПЛАЧЕНО виден, хотя значение флажка ноль. Если же поставить флажок (единицу), а затем снова его сбросить (ноль), то есть, задействовать процедуру флажка Сплачено(), то текст пропадает. Однако, если закрыть документ с сохранением, а потом его снова открыть, текст СПЛАЧЕНО снова будет снова виден. Хотя, флажок остается в нуле. Почему текст виден, когда флажок по умолчанию в нуле при открытии? Как сделать, чтобы он не появлялся, когда флажок пустой? Спасибо!!!
Кстати, доступность работает по условию. То есть, другим пользователям флажок недоступен. И текст тоже. Но видимый.
Чтобы убедиться, что Спл=0 при открытии , я использовать Сообщить(Спл). Он таки был равен нулю. Но текст был видимым! 64000000.gif
Просмотров: 24, последний комментарий от nysysimara   
Как в документе создать кнопку, доступную только админу? в 1С 7.70.003 торговля склад для Украины? [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 22.10.19, 20:24 — 3 комментариев
Здравствуйте! Возникла необходимость в документе создать процедуру, доступ к которой имел бы только администратор. Я хочу на форме создать соответствующую кнопку. Можно ли сделать ее доступной только администратору? Или определенному пользователю? И как? Спасибо.
Просмотров: 31, последний комментарий от nysysimara   
Выбрать новую конфигурацию или пытаться исправить текущую? [раздел 1С Управление Торговым Предприятием 8]
Автор Fasharama — 22.10.19, 9:25 — 8 комментариев
Доброго времени суток.

Пришел на работу в компанию, которая занимается продажей, ремонтом и обслуживание электронной техники. Здесь есть три учетных системы для каждого направления деятельности. Для бухгалтерии ("Управление торговым предприятием для Украины", редакция 1.2. Разработка конфигурации: "ABBYY Ukraine", 2007-2015 (1.2.27.6), для розницы(1С:Предприятие 8. Магазин бытовой техники и средств связи для Украины, редакция 1.0), для сервиса ("Управление торговым предприятием для Украины", редакция 1.1. Разработка конфигурации: "ABBYY Ukraine", 2007-2011 (1.1.19.1).
Проблема заключается в том, что сервисную базу пилили за последние два года 6-ть разных программистов и каждый со своим стилем. В итоге много элементов лишних, есть вместо записей в справочнике записи прямо в коде, неверно ведется учет складской, отсутствие логики структуры документов и в целом система не гибкая к изменениям. Также взаимодействие с другими базами происходит в ручном режиме, сверки у бухгалтерии также. Задача стоит быстро навести порядок в системе, а внутренних ресурсов для этого нет и нужен внешний подряд.

Возникают вопросы, что лучше, покупать новую конфигурацию и с нуля её выстраивать или доводить до ума имеющуюся? Какой процесс менее затратный? Нужен ли аудит системы и как подобрать партнера?

ПОМОГИТЕ РАЗОБРАТЬСЯ help.gif

Конфигурация:
1С:Предприятие 8.3 (8.3.10.2168)
"Управление торговым предприятием для Украины", редакция 1.1.
Разработка конфигурации: "ABBYY Ukraine", 2007-2011 (1.1.19.1)
Просмотров: 136, последний комментарий от Fasharama   
Добавление субсчета в плане счетов УТП для Украины [раздел 1С Управление Торговым Предприятием 8]
Автор Laureola — 21.10.19, 18:03 — 2 комментариев
Конфигурация "Управление торговым предприятием для Украины", редакция 1.2. (1.2.53.1), Платформа 8.3.10.2252. При создании в плане счетов субсчета к предопределенному счету 39 субсчета (к примеру 391) делает проводку документом "поступление товаров и услуг", дает заполнить Справочник "Расходы будущих периодов", НО не делает проводки при проведение Документа "Закрытие месяца" с флажком "Списание расходов будущих периодов". Т.е. 39 счет не закрывается. Помогите пожалуйста кто сталкивался.
Просмотров: 65, последний комментарий от Laureola   
Пример по получению основных сведений по типу данных любого значения [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 21.10.19, 14:32 — 7 комментариев
Данным примером функции, решил поделиться для гостей сайта и вообще новичков в системе 1С.
Ибо сам в собственной практике сталкивался с кое-какими вопросами указанной темы. И вследствие чего самому приходилось искать по разным страницам в сети, готовое решение вопроса. Но в итоги находил вовсе не готовое решение, а ее отдельные лоскутки. И на удивление даже эти самые «лоскутки», оказывались не из серии кода самого языка 1С, а из языка XML. Что и послужило выводом того, что в самом языке 1С, скорее всего, нет готовой системной функции решающей указанный вопрос данной темы.
Именно по этой причине пришлось из собранных «лоскутков», сесть и написать эту ниже изложенную простую и думаю понятную функцию. По поводу, которой далеко не новички в системе 1С могут сказать, что не так сделал, как было бы корректнее. И будут обвинять меня в том, что то, как сделал это на самом деле «кустарщина» и т.д. Но, я в любом случае уважаю их мнение, даже если оно негативное. Но при это если честно, сам для своих собственных целей все-таки решил пользоваться не данной системной функцией от 1С:
ТипЗнч()

Созданной точно не в «кустарных» условиях, а другой, собственно написанной функцией, хотя пусть даже и в условия полной «кустарщины» smile.gif.
Теперь о самой функции.
Прежде всего, как протестировать...
Новичкам не буду объяснять элементарные азы. Думаю, сами найдут информацию в сети. А скажу только то, что в созданном справочнике или документе, не важно, пусть даже без единого реквизита в модуль формы объекта нужно полностью скопировать и вставить
вот этот весь текст кода с процедурами запуска и функциями:

//##########################################################

&НаКлиенте
Процедура ТипЗнчСведения_Тест(Команда)
//===================================
    стрТип=ТипЗнчСведения(Объект.Ссылка,"Структура");
//===================================
    Сообщить(
    "ФУНКЦИЯ: «ТипЗнчСведения"+Символы.ПС+"(<Значение>,<ПараметрВозврата>)»"+Символы.ПС+
    "---------------------------------------"+Символы.ПС+
    "Результат:"+Символы.ПС+
    "Тип - "+стрТип.Тип+Символы.ПС+
    "Тип группа - "+стрТип.Группа+Символы.ПС+
    "Метаданные группа - "+стрТип.МетаданныеГруппа+Символы.ПС+
    "Метаданные имя - "+стрТип.МетаданныеИмя+Символы.ПС+
    "Метаданные полное имя - "+стрТип.МетаДанныеПолноеИмя+Символы.ПС+
    "---------------------------------------");
//===================================
КонецПроцедуры

//##########################################################


//########### ОПРЕДЕЛЕНИЕ ТИПА ПО ЗНАЧЕНИЮ #################

&НаСервере
Функция ТипЗнчСведения(Значение,ЗначВозврата) Экспорт // ОСНОВНЫЕ СВЕДЕНИЯ по типу данных любого значения
XMLТип=XMLТипЗнч(Значение).ИмяТипа;
Если Найти(XMLТип,".")=0 Тогда
    ТипГруппа=Строка(ТипЗнч(Значение)); //ТипГруппа=ТипЗнч(Значение);        
    Тип=ТипГруппа;
    МетаданныеГруппа=ТипГруппа;
    МетаданныеИмя=ТипГруппа;
    МетаДанныеПолноеИмя=ТипГруппа;
Иначе
    МетаДанныеПолноеИмя=Значение.Метаданные().ПолноеИмя();
    МетаданныеГруппа=Парсер(МетаДанныеПолноеИмя,".",1);
    МетаданныеИмя=Парсер(МетаДанныеПолноеИмя,".",2);
    Если Найти(XMLТип,"RecordSet")>0 Тогда
    ТипГруппа="НаборЗаписей";    
    ИначеЕсли Найти(XMLТип,"Ref")>0 Тогда
    ТипГруппа="Ссылка";    
    Иначе
    ТипГруппа="Объект";    
    КонецЕсли;
    Тип=МетаданныеГруппа+ТипГруппа+"."+МетаданныеИмя;
КонецЕсли;    
//============================
Стр=Новый Структура();
Стр.Вставить("Группа",ТипГруппа);
Стр.Вставить("Тип",Тип);
Стр.Вставить("МетаданныеГруппа",МетаданныеГруппа);
Стр.Вставить("МетаданныеИмя",МетаданныеИмя);
Стр.Вставить("МетаДанныеПолноеИмя",МетаДанныеПолноеИмя);
//============================
    Если ЗначВозврата=Неопределено или ЗначВозврата="Структура" Тогда
    знВозврат=стр;    
    Иначе
    знВозврат=стр[ЗначВозврата];
    КонецЕсли;
//============================
Возврат знВозврат;
//============================
КонецФункции


//################## PARSER  ################################

&НаСервере
Функция Парсер(Текст,Символ,НомерВхода) Экспорт
НомерВхода=НомерВхода-1;
КоличПовтСимвола = СтрЧислоВхождений(Текст, Символ);
НомСимвПовтора = Число((НомерВходаСимвола(Текст, Символ, НомерВхода)));
If КоличПовтСимвола = 0 Then
    strPart = Текст;
ElsIf КоличПовтСимвола = НомерВхода Then
    strPart = Сред(Текст, НомСимвПовтора+1);
ElsIf КоличПовтСимвола > НомерВхода Then
    strТекст = Сред(Текст, НомСимвПовтора+1);
    СимволNext = Найти(strТекст, Символ);
    strPart = Сред(Текст, НомСимвПовтора+1, СимволNext-1);
Else
    НомСимКонечногоПовтора = НомерВходаСимвола(Текст,Символ,КоличПовтСимвола);
    strPart = Сред(Текст, НомСимКонечногоПовтора+1);   //+ 1
EndIf;
Возврат strPart;
КонецФункции

&НаСервере
Функция НомерВходаСимвола(Текст,Символ,НомерВхода) Экспорт
КолРазделителя=СтрЧислоВхождений(Текст, Символ);
ТекстДлина=СтрДлина(Текст);
Count = 0;
CountSymb = 0;
SymbNum = 0;
//---------------------------
For i = 1 to ТекстДлина do
Count = Count + 1;
char = Сред(Текст, i, 1);
    If char = Символ Then
    CountSymb = CountSymb + 1;
    If CountSymb = НомерВхода Then SymbNum = Count EndIf;
    EndIf;
EndDo;
//---------------------------
Возврат SymbNum;
КонецФункции

//##########################################################


Основная, из которых именована «ТипЗнчСведения()». Та, которая имеет отношение к вопросу данной темы. А другие функции созданы в помощь к основной. Так же как и в помощь, многим другим функциям, что довольно часто было необходимо.
И все это опять-таки в помощь тем, которые как я, в свое время, искали готовое решение, что бы сэкономит время, но не нашли его.
Поэтому, вот готовое решение вопроса и тем самым экономия драгоценного времени программиста.
А что касается «кустарщины» то тут, если честно даже не знаю, справедливо ли это в адрес этой простой функции с именем на пример: «ТипЗнчСведения(<Значение>,<ПараметрВозврата>)». Ибо, до ее написания, когда столкнулся с той самой другой выше указанной уже системной функцией, откровенно говоря, уже было, не до таких вопросов. Так как, сама та самая системная функция и отбила охоту вообще об этом даже думать.
Так что не обессудьте.
Ладно!
Удобного юза!
Просмотров: 153, последний комментарий от Gigi   
Обучение по программированию 1С 8.3. Создание внешнего отчета "Отчет по закупкам". [раздел Обучающее видео]
Автор macho210386 — 21.10.19, 12:52 — 0 комментариев


Описание:

Как создать внешний отчет. - создание внешнего отчета "Отчет по закупкам".
Просмотров: 33, оставить комментарий   
Можно ли сделать автоматическое обновление отчета? 1с 7.7 конф 7.7.003 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 19.10.19, 18:29 — 3 комментариев
Здравствуйте! И еще один вопрос. Если у меня открытый отчет на экране и какой-то документ добавился или изменился, есть ли какие-то способы сделать автоматическое обновление отчета, чтобы эти изменения сразу в нем отразились? Спасибо.
Просмотров: 100, последний комментарий от ZUBR   
Сообщение "Недостаточно прав в новом интерфейсе 1с 7.7 конф 7.7.00 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 18.10.19, 19:43 — 3 комментариев
Здравствуйте! Я на финальной стадии доработки. Такой вопрос. Я создал новый интерфейс инженера и отметил ему в конфигураторе права доступа до различных документов, отчетов, справочников и т.д., как считаю нужным. Но если заходить от его имени в программу, выскакивает сообщение "Недостаточно прав". Правда, программа работает. При выходе из программы такое же сообщение. Что это значит, и каких прав недоситаточно? Спасибо.
Просмотров: 68, последний комментарий от ZUBR   
Почему программно не заполняется поле с типом Справочник.Сотрудники 1с 7.7 конф 7.7.003 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 18.10.19, 16:56 — 4 комментариев
Здравствуйте!
Мне нужно, чтобы поле Инженер в моей расходной накладной, имеющий тип Справочник.Сотрудники, заполнялось автоматически. Для этого я написал процедуру "Виконав". Привожу часть кода.

Спр = СоздатьОбъект("Справочник.Сотрудники");               //Автозаполнение поля Инженер
     Спр.ВыбратьЭлементы();
      Пока Спр.ПолучитьЭлемент()=1 Цикл  
          Если Спр.Наименование = СокрЛП(ПолноеИмяПользователя()) Тогда
    Инженер = Спр.Наименование;
    Сообщить(Спр.Наименование);
    КонецЕсли;
    КонецЦикла;


Для выяснения проблемы в тело оператора Если я ввел оператор Сообщить. При выполнении процедуры в поле сообщений появляется наименование сотрудника. Значит, условие выполняется. Но при этом поле Инженер с типом Справочник.Сотрудники остается пустым, хотя оно должно быть заполненным. Я понимаю, что здесь могут быть проблемы потому, что это справочник. Подскажите, что я делаю неправильно. Спасибо!
Просмотров: 82, последний комментарий от ZUBR   
Не инициализируется текст модуля менеджера в конфигураторе [раздел Программирование в 1С Предприятие 8.3]
Автор onsamuy — 18.10.19, 14:33 — 2 комментариев
Собственно в чем дело.

Есть перепуганый заказчик. Все что я кодирую - сначала кодирую в базе тест. Далее заказчик проверяет работу, и самостоятельно выгружает конфу в файлик cf из базы тест, и загружает файлик в базу рабочая. Проблема в том, что я в базе тест, в обработке добавил процедуру ВыгрузкаДБФНовая(). После проверки и манипуляций заказчика с файликами, когда открываю конфигуратор базы рабочая - не вижу этой процедуры, то есть код модуля вижу какбы старый. Хотя алгоритм работает по новому, даже в отладчике курсор бегает по несуществующим строкам модуля smile.gif))))
Проблема известная, лечится или удалением из списка базы добавлением заново, или удалением файлов кеша на локальной машине. НО.. не помогает!!! Как можно все таки вылечить это?
Просмотров: 90, последний комментарий от Vladal   
Системная функция "ТипЗнч()" - не вопрос, а просто мнение [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 18.10.19, 12:07 — 10 комментариев
Всем опять привет!
В данном случае вышел на форум не по поводу вопроса, а по поводу просто мнения.
Не знаю, уместно ли это и есть ли польза какая то от этого.
Хотя думаю все таки есть. По крайней мере думаю гостям данного сайта пригодится.
В особенности новичкам в системе 1С. Тем которые так же как я столкнулись с кое какими вопросами. И пока так и не нашли ответ почему разработчики великого и могучего языка 1С сделали именно так как сделали. А не чуть иначе.
Не буду объяснять детально в чем именно возникает вопрос, а вместо этого скину одну функцию, которую пришлось самому написать в общем модуле.
Думаю понимающему и без слов будет ясно почему и зачем пришлось писать такую функцию, и в чем именно сама функция: "ТипЗнч()" вынудила опять заниматься изобретательством и прочей ерундой.
В особенности если сравнивать две функции. Одна из которой это функция самой системы 1С, т.е. та самая: "ТипЗнч()" и другую, которая, слава богу вообще оказалась, но которая уже не из 1С, а из ХML. Т.е. если сравнить эти две функции и задать вопрос какая лучше. От 1С или от ХML. И лучше в смысле больших возможностей.
Вот код функции:
Функция ПоЗначению(Значение,ЗначВозврата) Экспорт
XMLТип=XMLТипЗнч(Значение).ИмяТипа;
Если Найти(XMLТип,".")=0 Тогда
    ТипГруппа=Строка(ТипЗнч(Значение)); //ТипГруппа=ТипЗнч(Значение);        
    Тип=ТипГруппа;
    МетаданныеГруппа=ТипГруппа;
    МетаданныеИмя=ТипГруппа;
    МетаДанныеПолноеИмя=ТипГруппа;
Иначе
    МетаДанныеПолноеИмя=Значение.Метаданные().ПолноеИмя();
    МетаданныеГруппа=Config_String_серв.Парсер(МетаДанныеПолноеИмя,".",1);
    МетаданныеИмя=Config_String_серв.Парсер(МетаДанныеПолноеИмя,".",2);
    Если Найти(XMLТип,"RecordSet")>0 Тогда
    ТипГруппа="НаборЗаписей";    
    ИначеЕсли Найти(XMLТип,"Ref")>0 Тогда
    ТипГруппа="Ссылка";    
    Иначе
    ТипГруппа="Объект";    
    КонецЕсли;
    Тип=МетаданныеГруппа+ТипГруппа+"."+МетаданныеИмя;
КонецЕсли;    
//============================
Стр=Новый Структура();
Стр.Вставить("Группа",ТипГруппа);
Стр.Вставить("Тип",Тип);
Стр.Вставить("МетаданныеГруппа",МетаданныеГруппа);
Стр.Вставить("МетаданныеИмя",МетаданныеИмя);
Стр.Вставить("МетаДанныеПолноеИмя",МетаДанныеПолноеИмя);
//============================
    Если ЗначВозврата="Структура" Тогда
    знВозврат=стр;    
    Иначе
    знВозврат=стр[ЗначВозврата];
    КонецЕсли;
//============================
Возврат знВозврат;
//============================
         //------- Ref --------- Object
            //"Catalog","Справочник"
            //"Document","Документ"
            //"Enum","Перечисление"
            //"ChartOfCharacteristicTypes","ПланВидовХарактеристик"
            //"ChartOfAccounts","ПланСчетов"
            //"Task","Задача"
         //---- RecordSet ------
            //"InformationRegister","РегистрСведений"
            //"CalculationRegister","РегистрРасчета"
КонецФункции

К этому мне ничего еще добавить. Поэтому воздержусь ... Ибо на счет "возможностей" функции "ТипЗнч()", об этом, думаю сами эти строки кода скажут лучше всяких слов.
Так что, на этот раз решил не задавать вопросы, а просто высказать мнение ...
Ладно ... вот собственно и все.
Просмотров: 308, последний комментарий от Gigi   
Как изменить список печатных форм в документах [раздел 1С Управление небольшой фирмой для Украины]
Автор Laky2006 — 17.10.19, 17:03 — 7 комментариев
Здравствуйте возможно ли в документе скрыть или поместить в низ печатные формы которыми не планируется пользоваться?
Просмотров: 111, последний комментарий от Toka   
Вывод данных из поля табличной части в дополнительное поле формы списка документа [раздел Программирование в 1С Предприятие 8.3]
Автор jojojoba2 — 17.10.19, 12:16 — 6 комментариев
Добрый день!

Есть задача в 1С8.3 в форму списка документа Платежное поручение входящее добавить новое поле ЗаказПокупателя и в него вывести данные с табличной части РасшифровкаПлатежа из поля сделка(в котором отображается заказ покупателя). Помогите пожалуйста разобратся начинающему програмисту :

Код
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
    
     ЭтотОбъект = Документы.ПлатежноеПоручениеИсходящее;
    Запрос = Новый Запрос;
    Запрос.Текст ="ВЫБРАТЬ
                  |    ЗаказПокупателя.Ссылка
                  |ИЗ
                  |    Документ.ЗаказПокупателя КАК ЗаказПокупателя
                  |ГДЕ
                  |    ЗаказПокупателя.Ссылка = &ТекущийДокумент";
    
    Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.СсылкаНаОбъект);
    Результат = Запрос.ВыполнитьПакет();
    ВыборкаЗП = Результат.Выбрать();
    
    ОтборВыборки = Новый Структура("Заказ");
    Для Каждого ТекОформление Из ОформленияСтрок Цикл
        ОтборВыборки.ЗаказПокупателя = ТекОформление.ДанныеСтроки.Ссылка;
        
         ТекОформление.Ячейки.ЗП.Значение(ВыборкаЗП.НайтиСледующий(ОтборВыборки));
        
    КонецЦикла;
КонецПроцедуры


ЗП ---это колонка в форме списка в которую нужно вывести данные


При запуске выдает ошибку:


Документ.Справки_расчеты_роялти.Форма.ФормаСписка.Форма(132)}: Поле объекта не обнаружено (СсылкаНаОбъект)
Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.СсылкаНаОбъект);

----- Как правильно задать параметры колонки ЗП (поле ввода или указать данные реквизита )
----- Правильный запрос вывода значения с табличной части этого документа(я попытался через ссылку на заказ покупателя)
----- Правильный метод вывода значения в колонку формы списка.


Если можно , сбросьте пример.

Заранее всем спасибо.


 ! 

Правила: 9
 
Просмотров: 100, последний комментарий от fly   
Как программно установить значение DPI при сканировании через WIA ? [раздел Тематическое общение]
Автор andrew76 — 17.10.19, 8:22 — 15 комментариев
Добрый день !

Появилась необходимость сканирования фотографий из 1с 8.2 через сервис VIA.
Все работает в принципе,но хотелось бы устанавливать значение DPI программно.
Не могу разобраться с тех.документацией на WIA.
в принципе после вызова следующей строчки кода появляется диалоговое окно WIA.В этом окне и устанавливается значение DPI.
По умолчанию оно 150.А мне нужно 300.Можно ли задать его программно ?

DevManager = Новый COMОбъект("WIA.CommonDialog");
Просмотров: 200, последний комментарий от Vofka   
Декларация по Акцизному налогу [раздел Отчеты / Обработки]
Автор Gorus — 16.10.19, 9:31 — 0 комментариев
В новой декларации по акцизному налогу (действует с сентября 2019г.) появляется ошибка при заполнении: "Поле об`єкту не виявлено D8H01G1S_1" Ошибка проявляется когда по одной налоговой инспекции проходять несколько кодов КОАТУУ.

Исправленная версия обработки: Прикрепленный файл  Reglamentirovannyj_otchet_deklaratsiya_aktsiznogo_naloga.zip ( 655.36 килобайт ) Кол-во скачиваний: 12
Просмотров: 85, оставить комментарий   
Как в доработанную конфигурацию перенести данные?1с 7.7 конф 7.7.00 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 16.10.19, 1:00 — 1 комментариев
Здравствуйте! Я практически закончил доработку стандартной конфигурации под себя. Дальше стоит вопрос, как данные со стандартной конфигурации перенести в новую. Журналы, склад, документы и т.д. Возможно ли это и каким путем. Спасибо.
Просмотров: 91, последний комментарий от volodya1122   
Как получить список всех форм в 1С [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 15.10.19, 11:17 — 12 комментариев
Всем опять привет!
Вообще есть формы системные. Это формы для метаданных. Которые разделены по категориям: ФормаОбъекта, формаСписка и ФормаВыбора.
А есть созданные в конфигурации формы.
Так вот, нужна функция возвращающая значения списка созданных форм. В формате на пример структуры или списка значений ... Не важно.
Для лучшего понимания вопроса вот на пример следующая функция. Написать которую, в чем плюс было не сложно:
//СписокЭлементовМетаданных = ОбщийМодуль_МетаДанные.СписокЭлементовМетаданных(МетаданныеГруппа,"СписокЗначений");
Функция СписокЭлементовМетаданных(МетаданныеГруппа,ФорматВозрата) Экспорт
Перем СписокЭлементовМетаданных, ЭлементМетаданных;
Если ФорматВозрата="СписокЗначений" Тогда
    СписокЭлементовМетаданных = Новый СписокЗначений();
    Для Каждого ЭлементМетаданных Из Метаданные[МетаданныеГруппа] Цикл
    СписокЭлементовМетаданных.Добавить(ЭлементМетаданных.Имя,ЭлементМетаданных.Синоним);
    КонецЦикла;
    Возврат СписокЭлементовМетаданных;
ИначеЕсли ФорматВозрата="Структура" Тогда
    СписокЭлементовМетаданных = Новый Структура();
    Для Каждого ЭлементМетаданных Из Метаданные[МетаданныеГруппа] Цикл
    СписокЭлементовМетаданных.Вставить(ЭлементМетаданных.Имя,ЭлементМетаданных.Синоним);
    КонецЦикла;
    Возврат СписокЭлементовМетаданных;    
Иначе
    Возврат Неопределено;    
КонецЕсли;
КонецФункции

Данная функция выводит список элементов метаданных по указанной в функции группе.
И как понимается тут все легко и просто.
Нужно то же самое, только для форм.
Т.е. таким же маккаром получить его в виде структуры или списка значений.
Если 1С позволяет это то просьба скинуть готовую функцию в примерно подобном стиле. Если конечно не трудно.
Буду признателен!
Просмотров: 485, последний комментарий от Gigi   
Серии в НЗП - при переработке (ошибка расчета себестоимости) [раздел 1С Управление производственным предприятием 8]
Автор VXIIIZ — 15.10.19, 10:51 — 9 комментариев
Подскажите, господа, вдруг кто-то сталкивался.
Платформа: 8.3.13.1809
Конфа: 1.3.64.1

Детализация затрат - детально
Расчет себестоимости - по переделам.

Передел 1:
Из сырья1 делаем полуфабрикат1 (ПФ1)

Передел 2.
Передачей товаров передаем в переработку
поступлением из переработки - распределение материалов фиксируем затраты на выпуск этого ПФ. и собственно регистрируем выпуск ГП1
получением услуг по переработке добавляем услугу и собственно списываем в НЗП с партий переданных в переработку ПФ1

Все просто, себестоимость расчитывается, 231-й закрывается. Ровно до тех пор пока мы не устанавливаем учет по сериям.




При передаче товаров серию можно указать с партий она списывается корректно


Но в партиях переданных серии нет.

Затратах на выпуск продукции серия есть и она заполняется
Но в получении услуг по переработке серии нет


Соответственно в незавершенку это ПФ попадает без серии

И как результат:
Просмотров: 151, последний комментарий от VXIIIZ   
Позволяет ли 1С программно вставить кнопку в панель инструментов [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 15.10.19, 10:10 — 6 комментариев
Всем опять привет!
Искал инфу по указанному вопросу в сети, но че-те не нашел ответ на данный вопрос.
Поэтому никто не может дать точный ответ на вопрос.
Можно ли в 1С программно добавить кнопку не просто в командную панель любой формы, а в саму панель инструментов 1С предприятия.
И по первому вопросу, т.е. по вопросу добавления кнопки в командную панель знаю что можно. Равно как и знаю не только то что в глобальном смысле добавить то можно, а еще и то что, скрыть в том же самом глобальном смысле , что самое смешное, никак нельзя smile.gif. Хоть лопни smile.gif
Поэтому хотел уточнить так ли дело обстоит по вопросу уже панели инструментов или еще хуже?
Ибо судя по тому, что в сети по вопросу не нахожу инфу, догадываюсь что и тут нельзя это сделать. Но хотел уточнить и получить точный ответ на данный вопрос.
Буду признателен!

Gigi @ Сегодня, 9:55 * ,
Вот инфа близкая к заданному вопросу. Но это где то рядом, но все равно не то что надо.
Просмотров: 169, последний комментарий от Gigi   
Как вернуть выбранное значение из формы списка Справочника в вызвавшую форму элемента другого справочника ? [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор andrew76 — 14.10.19, 16:51 — 3 комментариев
Добрый вечер !

Имеется форма элемента справочника.На нажатию кнопки,расположенной на этой форме,запускается форма
списка другого справочника.На это форме по двойному клику или нажатию клавиши Enter обрабатываю событие
Выбор.Мне нужно передать значение реквизита Наименование (выбранный элемент по клику или Enter'у)
в реквизит Наименование вызвавшей формы первого справочника.Как это реализовать ?
Т.е. я должен заменить значение реквизита Наименование выбранным значением из другого справочника.
Просмотров: 150, последний комментарий от getnight   
RSS Текстовая версия Сейчас: 23.10.19, 8:32
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!