Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Расширение у поля тектового документа (Встроенный язык, HTML и пр) [раздел Программирование в 1С Предприятие 8.3]
Автор Slon747 — 01.03.24, 14:09 — 0 комментариев
Можно ли менять Расширение программно?
Просмотров: 23, оставить комментарий   
Печать на принтере без использования Easy Print [раздел Работа с торговым оборудованием]
Автор Slon747 — 27.02.24, 12:45 — 11 комментариев
После отключения Easy Print используется установленный драйвер принтера.
Но теперь нет возможности при печати этикеток выбрать/создать нужный образец (материал для печати).
И возникает проблема при использовании разных размеров этикеток.
Можно ли вернуть использование образцов?
Просмотров: 131, последний комментарий от Slon747   
Поиск подобных товаров по артикулам из перечня артикулов [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Talkman — 26.02.24, 13:47 — 19 комментариев
Добрый день. Нужен совет. Есть документ. В документе в ТЧ список товаров. Каждый товар имеет реквизит артикул типа ххххх/уууууу/сссссс. Тип строка, в значении реквизита несколько разных артикула разделенные слешем. Артикул может быть и один, тогда слеш отсутствует. Задача. При сохранении документа проверять есть ли на остатке товары с пересекающимися артикулами. Например, если в документе есть товар с артикулом 2222/5555 и на остатке в базе есть товар с артикулом 5555/7777, то это нужно сообщить.
Остановился на том, что заполнил массив артикулами из документа. ххххх/уууууу/сссссс = ххххх, уууууу, сссссс , а дальше стопорнулся. Как сделать в запросе, чтобы массив значений проверялся на подобие реквизита артикула?

 Запрос.Текст = 
        "ВЫБРАТЬ
        |   ТоварыНаСкладахОстатки.Номенклатура,
        |   ТоварыНаСкладахОстатки.КоличествоОстаток,
        |   ТоварыНаСкладахОстатки.Номенклатура.Артикул
        |ИЗ
        |   РегистрНакопления.ТоварыНаСкладах.Остатки(&Дата, &мАртикулов ПОДОБНО ""%"" + Номенклатура.Артикул + ""%"") КАК ТоварыНаСкладахОстатки";
    
    Запрос.УстановитьПараметр("Дата", Док.Дата);
    Запрос.УстановитьПараметр("мАртикулов", мАртикулы);


Это же явный бред, да?
Просмотров: 235, последний комментарий от AnryMc   
Посоветуйте. откуда взять данные по неоплаченным реализациям УТ11 [раздел Программирование в 1С Предприятие 8.3]
Автор lolmatrix — 23.02.24, 13:55 — 7 комментариев
Здравствуйте. уважаемые специалисты 1с. посоветуйте, пожалуйста откуда можно взять последние неоплаченные реализации конфигурация Управление торговлей 11. если можно запрос написать, может у кого-то было что-то подобное. но хотя бы откуда взять эти данные. заранее благодарен .

Управляемые формы. Управление торговлей, редакция 11 (11.5.12.73), 1С:Предприятие 8.3 (8.3.22.2411)
Просмотров: 190, последний комментарий от nik389   
Не могу получить макет [раздел Программирование в 1С Предприятие 8.3]
Автор alex_shkut — 23.02.24, 9:21 — 9 комментариев
Уже 15 лет работаю с 1С и тут туплю. Переменная не определена (ЭтотОбъект) Процедура или функция с указанным именем не определена (ПолучитьМакет) ЧЯДНТ.
Макет = ЭтотОбъект.ПолучитьМакет("Наряд"); // ошибка.
Просмотров: 230, последний комментарий от AnryMc   
Соединение строк по группировке в запросе [раздел Программирование в 1С Предприятие 8.3]
Автор AnryMc — 22.02.24, 16:20 — 6 комментариев
Дано: Справочник ААА

его элементы являются ведущим измерением для регистра сведений БББ с измерением ВВВ - тип "строка" неограниченной длины

Нужно ЗАПРОСОМ (не СКД) соединить строки (значение ВВВ) регистра БББ по группировке ААА

Зачем это нужно:
Например - справочник "Продукт"
Регистр "Замечания к продукту" - где элемент справочника "Продукт" ведущее измерение с ресурсом "Замечание" (строка неограниченной длины - может кто "Сагу о Форсайтах" напишет)
В форме списка справочника "Продукты" показывать ВСЕ "Замечания" по данному элементу (в отдельной колонке динамического списка)
Т.е. ТОЛЬКО ЗАПРОС (СКД не подходит)

З.Ы, Это позволит использовать поиск по списку
Просмотров: 197, последний комментарий от AnryMc   
Встановлення картинки в ТЧ програмно [раздел Программирование в 1С Предприятие 8.3]
Автор Inkognito — 22.02.24, 14:58 — 5 комментариев
Бухгалтерія 2.1 на "Керованих формах". Таблична частина, зовнішня обробка.
Необхідно проаналізувати статус документу по коду, і в табличній частині вивести картинку.
Додано реквізит "Картинка", числовий, 1.
На формі "Вид" = "Поле картинки". Пусте, з прив*язкою до реквізиту.
Код відпрацьовує, але картинки для різних статусів не відображуються.

Для Каждого Стр из Объект.ТЧДокументи Цикл
Код = Стр.КодСтатуса;
    Если Код = "1" Тогда
        Стр.Картинка = БиблиотекаКартинок.ОформлениеФлагКрасный;
    ИначеЕсли Код ="2" Тогда
        Стр.Картинка = БиблиотекаКартинок.ОформлениеФлагЗеленый;
    Иначе
        Стр.Картинка = БиблиотекаКартинок.ОформлениеФлагЖелтый;
    КонецЕсли;
КонецЦикла;
Просмотров: 179, последний комментарий от AnryMc   
8.3.24 Web Клиент ошибка при формировании отчета [раздел Программирование в 1С Предприятие 8.3]
Автор burza — 20.02.24, 15:06 — 4 комментариев
или когда отчет или печать вылазит такая ошибка! и еще такая Cannot read properties of undefined (reading 'prefix'). при открытие любого отчета
стояла 8.3.12 всё было ок. Это баги платформы или?
Просмотров: 183, последний комментарий от Vofka   
Настройка панели разделов (верхнее расположение) интерфейс "Такси" [раздел Программирование в 1С Предприятие 8.3]
Автор andrew76 — 20.02.24, 12:20 — 9 комментариев
Доброго дня всем.

Как в конфигураторе настроить панель разделов чтобы она была закреплена в верхнем положении ,
(как на прикрепленных рисунках) , а не в левой области окна ? Конфигурация самописная.


 ! 

Правила: 8
 


[ img ]https://www.koderline.ru/upload/iblock/f8d/6-analiz-prav-dostupa-1s.png [ img ]
Просмотров: 327, последний комментарий от andrew76   
Программно дать право на "Вывод" (сохранение файла) на команду &НаКлиенте [раздел Программирование в 1С Предприятие 8.3]
Автор AnryMc — 16.02.24, 9:09 — 13 комментариев
Пользователь без права "Вывод" (нет права печатать и сохранять в файл).

В одном документе программно формируется файл.

Как дать право на сохранение только этого файла?

Причем: Процедура &НаКлиенте
Просмотров: 336, последний комментарий от AnryMc   
Выполнить действия после закрытия документа [раздел Программирование в 1С Предприятие 8.3]
Автор burza — 15.02.24, 16:48 — 2 комментариев
После закрытия документа нужно делать рассылку по электронной почте программно, сформировать документ расходной в екселе. Написал общий модуль туда все запихнул. Ну а вот дальше беда, на форме после закрытие на срабатывает ибо я делаю печатную форму накладной. работает только когда документ полностью закрыт. Как передать документ уже после всего закрытого на общий модуль?

&НаСервере
Процедура ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи)

mail.ОтправкаПочты(ТекущийОбъект);

Функция ОтправкаПочты(Док)  экспорт   
    
    
        Пар = Новый ТаблицаЗначений;    
        Пар.Колонки.Добавить("Идентификатор");
        Пар.Колонки.Добавить("МенеджерПечати");
        Пар.Колонки.Добавить("УникальныйИдентификатор");
        Пар.Колонки.Добавить("ДополнительныеПараметры");            
        НоваяСтрока = Пар.Добавить();
        НоваяСтрока.Идентификатор = "Накладная";
        НоваяСтрока.МенеджерПечати = "Документ.РасходнаяНакладная";
        НоваяСтрока.УникальныйИдентификатор = "07691C8060031E8CDD5BDFEA5C8E31D8";         
        НоваяСтрока.ДополнительныеПараметры = Новый Структура;
        НоваяСтрока.ДополнительныеПараметры.Вставить("ДополнитьКомплектВнешнимиПечатнымиФормами", ложь);                    
        Для каждого Стр Из Пар Цикл      
        КомандыПечати = Новый Массив();
        КомандыПечати.Добавить(Стр);          
        КонецЦикла;

                    
        СписокОбъектов = Новый Массив();
        СписокОбъектов.Добавить(Док);
                                    
        
        МассивXLS = Новый Массив();
        МассивXLS.Добавить("XLSX");        
        НастройкиСохранения = Новый Структура;
        НастройкиСохранения.Вставить("ФорматыСохранения", МассивXLS);
        НастройкиСохранения.Вставить("ПодписьИПечать", ложь);
        НастройкиСохранения.Вставить("ПереводитьИменаФайловВТранслит", ложь);
        НастройкиСохранения.Вставить("УпаковатьВАрхив", ложь);
    
    СформированныеФайлы = УправлениеПечатью.НапечататьВФайл(КомандыПечати, СписокОбъектов, НастройкиСохранения);
Просмотров: 235, последний комментарий от burza   
Как получить всех родителей элемента справочника? [раздел Программирование в 1С Предприятие 7.7]
Автор kostya77 — 15.02.24, 14:23 — 4 комментариев
Добрый день. Подскажиет как получить всех родетелей елемента справочника
Просмотров: 362, последний комментарий от takefive   
Выгрузка справочника Номенклатуры [раздел Программирование в 1С Предприятие 7.7]
Автор kostya77 — 14.02.24, 13:57 — 3 комментариев
Добрый день. Подскажите, как реализовать выгрузку справочника Номенклатуры с поддежкой иерархии, для последующей загрузки в 1с8 Малый Бизнес
Просмотров: 285, последний комментарий от Vofka   
Нумерация документов в зависимости от вида операции [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор kostya77 — 12.02.24, 18:21 — 3 комментариев
Добрый день. В документме Реализация товаров и услуг эть разные виды операция. Полскажите, как организовать нумерацтю документов в зависимости от вида операции (каждый вид операций - своя нуменрация)
Просмотров: 304, последний комментарий от andrew76   
При нажатии на кнопку программно заполнить реквизит Формы [раздел Прочее 1С 7.7]
Автор url_2l — 12.02.24, 13:14 — 3 комментариев
Доброго дня!!! Потрібна допомога 1С 7.7 в Розхідній Накладній в формі є реквізит Чек (поле вибору з Списку Перечислення Да Ні) при натасканні на кнопку друк перевіряє щоб поле було не пусте. Чи можна зробити щоб при натискані на кнопку це поле заповнювалось автоматично із списку на "Да"?
Приклад перевірки


Если ПустоеЗначение(Чек) = 1 Тогда
            Предупреждение("Виберіть тип Чеку (Да)");        
        Возврат;
        КонецЕсли;
Просмотров: 252, последний комментарий от denis84   
Как выгрузить большой объём данных постранично в json? [раздел Программирование в 1С Предприятие 8.3]
Автор burza — 12.02.24, 12:51 — 12 комментариев
подскажите как выгрузить большой объём данных постранично в json . В каждую страницу по 10 000. как через page передавать типо первая страница 10 000. вторая начиная с 10 001 по 20 000 и т.д

    ПараметрыИзЗапроса = Новый Структура;
    ПараметрыИзЗапроса.Вставить("token", Запрос["ПараметрыURL"].Получить("token"));
    //ПараметрыИзЗапроса.Вставить("page", Запрос["ПараметрыURL"].Получить("page"));


  Если ПараметрыИзЗапроса.token = "fxGXX13iRkE5y0f0NvQAz9mjrAFtF4sRT9QRqZXhifgypLGAF" тогда     
        
    ////Прайс //////////////////////////////////
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    dbo_Table_1.Артикул КАК Артикул,
        |    dbo_Table_1.Производитель КАК Производитель,
        |    dbo_Table_1.Наименование КАК Наименование,
        |    dbo_Table_1.Валюта КАК Валюта,
        |    dbo_Table_1.Поставщик КАК Поставщик,
        |    dbo_Table_1.Цена КАК Цена,
        |    dbo_Table_1.Наличие
        |ИЗ
        |    ВнешнийИсточникДанных.Price.Таблица.dbo_Table_1 КАК dbo_Table_1
        |
        |СГРУППИРОВАТЬ ПО
        |    dbo_Table_1.Артикул,
        |    dbo_Table_1.Цена,
        |    dbo_Table_1.Наименование,
        |    dbo_Table_1.Производитель,
        |    dbo_Table_1.Наличие,
        |    dbo_Table_1.Валюта,
        |    dbo_Table_1.Поставщик";
    

    РезультатЗапроса = Запрос.Выполнить();
    
    Выборка = РезультатЗапроса.Выбрать();
    
       МассивУслуг = Новый Массив;


    Пока Выборка.Следующий() Цикл

            МассивУслуг.Добавить(Новый Структура("Артикул, Производитель, Цена, Наименование, Наличие", Выборка.Артикул, Выборка.Производитель , Выборка.Цена, Выборка.Наименование, Выборка.Наличие));
        
    
        КонецЦикла;    

    
    ЗаписьJSON = Новый ЗаписьJSON;
    ЗаписьJSON.УстановитьСтроку();
    
    ЗаписатьJSON(ЗаписьJSON, МассивУслуг);


    
    СтрокаДляОтвета = ЗаписьJSON.Закрыть();

    
    Ответ = Новый HTTPСервисОтвет(200);    
    Ответ.Заголовки.Вставить("Content-type", "application/json;  charset=utf-8");
    
    Ответ.УстановитьТелоИзСтроки(СтрокаДляОтвета, КодировкаТекста.UTF8, ИспользованиеByteOrderMark.НеИспользовать);
Просмотров: 448, последний комментарий от Vofka   
Отследить удаление записи независимого регистра сведений [раздел Программирование в 1С Предприятие 8.3]
Автор AnryMc — 12.02.24, 11:38 — 1 комментариев
Независимый регистр сведений "Хранилище файлов"
Измерение: ОбъектПривязки - ссылка (множественная) на объекты конфигурации (документы, справочники...). Установленная как "ВЕДУЩЕЕ"

в реквизитах: Путь хранения файла на диске, его имя и расширение (плюс еще всякая информация)

СИТУАЦИЯ: Один из "ОбъектПривязки" помечается на удаление. Монопольно вызывается стандартная обработка "Удаление помеченных объектов"

записи "связанные" с удаляемыми объектами удаляются. НО ОСТАЮТСЯ ФАЙЛЫ НА ДИСКЕ

ПОДРОБНОСТИ: В модуле набора записей "ПередЗаписью" пытаюсь "пререхватить" удаление и "очистить" файлы на диске. Но проблема в том что туда уже приходит:
ЭтотОбъект.Отбор.ОбъектСсылка.Значение = "Объект не найден"

т.е. нельзя понять какой файл следует удалить.

ВОПРОС: Как удалить файлы при удалении записей РС???

AnryMc @ Сегодня, 11:52 * ,

Сделал через подписку на событие "ПередУдалением" для объектов владельцев.

Но буду признателен за идеи как можно решить через модуль РС
Просмотров: 275, последний комментарий от kihor   
Відновлення підтримки конфігурації Бухгалтерия для Украины, редакция 1.2 [раздел Бухгалтерия 8, редакция 1 для Украины]
Автор f12 — 10.02.24, 10:27 — 3 комментариев
Попалась мені в руки досить древня конфігурація Бухгалтерия для Украины, редакция 1.2, - 1,2,25,1. Стоїть питання поновити її до 1,2,51,1 і після цього перевести її на BAS.
Але стикнувся з тим, що дана конфігурація знята з підтримки без можливості поновлення. Поля, де можна виставити інформацію про підтримку - пусті і не редагуються. Як відновити підтримку, щоб можна було ставити поновлення?
Просмотров: 318, последний комментарий от f12   
Как в форму выбора справочника передать параметр? [раздел Программирование в 1С Предприятие 8.1 (8.0)]
Автор kostya77 — 09.02.24, 12:08 — 1 комментариев
Добрый день. Открываю из документа Реализации, из табличной части, характеристику номенклатуты, подскажи как в форму выбора справочника передать параметр?
Просмотров: 272, последний комментарий от denis84   
Непонятное отображение реквизита єлемента справочника [раздел Программирование в 1С Предприятие 8.3]
Автор AnryMc — 08.02.24, 10:58 — 1 комментариев
Справочник имеет реквизит "МойКод" - тип "Строка" (Переменной длины) . Маска: "11.UU". Значение заполнения: "11."

Реквизит может иметь (или не иметь) после "." любые цифры или буквы (верхний регистр)

СИТУАЦИЯ:
Созданы элементы с реквизитами: "11.А", "11.1", "11.33" и много прочих - все нормально.
НО!!! У элемента "11." при открытии формы элемента вместо "11." отображается "11.1"!!!

В отладчике значение реквизита "11."

Куда копать?

P.S. Причем это только в форме элемента, в "списке" отображение нормальное "11."
Просмотров: 270, последний комментарий от AnryMc   
RSS Текстовая версия Сейчас: 02.03.24, 6:46
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!