Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Rongta RP58 не печатает чеков [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор erhon — 24.11.20, 10:30 — 0 комментариев
Здравствуйте! Есть принтер для чеков Rongte rp58e через USB.

В тестовом режиме печатает.

Но когда захожу Касса ККМ Подключение оборудование там его нету (Касса ККМ только видит оборудование ФР и ККТ передачей данных)
[
Есть ли возможность через Фискальный регистратор или ККТ передачей данных запустить этот Rongta RP58e + USB (1c-кие встроенные драйвера использует только COM порт и LAN )
Просмотров: 11, оставить комментарий   
Внешняя обработка и батник [раздел Программирование управляемых форм 1С 8.2]
Автор powerwer — 24.11.20, 9:07 — 2 комментариев
Добрый день ребята.
У меня что то не понятное в 1с.
Есть серверный 1с и обработка где в конце процесса вызывает батник.bat. Сам обработчик включается в определенное время по регламенту задач. Она выгружает данные соpдав при этом txt файл и должен запускать батник где батник отправляет данные на FTP.
Проблема в том что ранее она работала но не давно она перестала работать т.к. данные выгружаются и создается txt файлы но запуска батника не получается.

Для инфо:
Агент 1с имеет уровень админ для работы.
Обработки где хранятся в каталоге имеется полный доступ к пользователю 1с и агенту 1с.

Не подскажите где еще посмотреть, пжлст.
Просмотров: 26, последний комментарий от powerwer   
"Оформить приказ" при добавлении работника выдает ошибку "Неизвестная команда" [раздел Программирование в 1С Предприятие 8.3]
Автор NModern — 23.11.20, 20:24 — 0 комментариев
Здравствуйте, не смог создать тему. Помогите пожалуйста

Используую
1C:Enterprise 8.3 (8.3.17.1549)
Конфигурация: 1С Mühasibat AzStandart konfiqurasiyası (2.1.3.6)

Да это кастомная конфигурация но она основана на Конфигурации Бухгалтерия.

У меня проблема, когда добавляеш работника есть кнопка справа где можно сразу же оформить приказ о приеме его на работу.



Когда нажимаеш на эту кнопку выдает ощибку.
"Неизвестная команда: "


Я включал дебаггинг, и даже дебаггинг фоновых задач но поймать его не смог.

Все отлично работает на версии 8.3.9.2033 и 8.3.10,2561
Но уже на версиях 8.3.15, 8.3.16, 8.3.17 выходит эта ощибка

Как мне устранить это. Возвращятся назад на старые версии не хочу, потому что у них были свои баги.

Где я могу найти код этой кнопки чтоб как то мануально продебаггить и понять в чем дело. Думаю там что то связано с датами, я где то на форумах читал про это. Помогите найти код этой кнопки
Просмотров: 11, оставить комментарий   
Как сделать отдельный интерфейс для каждого пользователя [раздел Программирование в 1С Предприятие 8.3]
Автор kukulkan — 23.11.20, 14:46 — 3 комментариев
Привет! Как сделать, чтобы для пользователя1 при открытии программы отображался только раздел "Банк и касса", для пользователя2 отображался только раздел "Склад", а для пользователя3 отображались все разделы? Спасибо!
Просмотров: 63, последний комментарий от sava1   
1С поле объекта не обнаружено [раздел Программирование в 1С Предприятие 8.3]
Автор kukulkan — 21.11.20, 12:20 — 4 комментариев
помогите понять, что делать. стандартные проверки совершила. очистить кэш, проверить настройки и тд

1С:Предприятие 8.3 (8.3.16.1148)

Поле объекта не обнаружено (ПредставлениеМОЛОтправителя)
{Документ.ПеремещениеМедикаментов.МодульМенеджера(891)}: ОбластьМакетаПодписи.Параметры.ПредставлениеМОЛОтправителя = ОбщегоНазначенияБК.ФамилияИнициалыФизЛица(ВыборкаПоДокументам.МОЛОтправителя);
{Документ.ПеремещениеМедикаментов.МодульМенеджера(577)}: НСтр("ru = 'Накладная на перемещение медикаментов'"),
{ОбщийМодуль.УправлениеПечатью.Модуль(2007)}: МенеджерПечати.Печать(ОбъектыСоответствующиеПечатнойФорме, ПараметрыПечати, ВременнаяКоллекцияДляОднойПечатнойФормы,
{ОбщаяФорма.ПечатьДокументов.Форма(499)}: ПечатныеФормы = УправлениеПечатью.СформироватьПечатныеФормы(Параметры.ИмяМенеджераПечати, ИменаМакетов,
{ОбщаяФорма.ПечатьДокументов.Форма(43)}: КоллекцияПечатныхФорм = СформироватьПечатныеФормы(Параметры.ИменаМакетов, Отказ);
{ОбщийМодуль.УправлениеПечатьюКлиент.Модуль(34)}: ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия, ВладелецФормы, Строка(Новый УникальныйИдентификатор));
{ОбщийМодуль.УправлениеПечатьюБККлиент.Модуль(69)}: УправлениеПечатьюКлиент.ВыполнитьКомандуПечати(ОписаниеКоманды.МенеджерПечати, ОписаниеКоманды.Идентификатор, ОписаниеКоманды.ОбъектыПечати,
{(1)}:УправлениеПечатьюБККлиент.ВыполнитьКомандуПечати(ОписаниеКоманды)
{ОбщийМодуль.УправлениеПечатьюСлужебныйКлиент.Модуль(113)}: Результат = Вычислить(Обработчик);
{ОбщийМодуль.УправлениеПечатьюСлужебныйКлиент.Модуль(26)}: ВыполнитьПодключаемуюКомандуПечатиЗавершение(Истина, ПараметрыВыполнения);
{ОбщийМодуль.ПодключаемыеКомандыКлиент.Модуль(190)}: ВыполнитьОбработкуОповещения(Обработчик, ПараметрКоманды);
{ОбщийМодуль.ПодключаемыеКомандыКлиент.Модуль(34)}: ПродолжитьВыполнениеКоманды(Контекст);
{Документ.ПеремещениеМедикаментов.Форма.ФормаСписка.Форма(56)}: ПодключаемыеКомандыКлиент.НачатьВыполнениеКоманды(ЭтотОбъект, Команда, Элементы.Список);

я понимаю.что проблема в том,что в макете нет МОЛотправителя, но в макете он есть. в старом релизе все работает. а вот в новом при регистрации внешнего отчета выдает ошибку. спасибо за любую помощь!
Просмотров: 98, последний комментарий от kukulkan   
Фактическая себестоимость и себестоимость реализации [раздел 1С Управление Торговым Предприятием 8]
Автор djess — 20.11.20, 13:11 — 3 комментариев
Добрый день)
Уважаемые консультанты, помогите пожалуйста разобраться: есть производство, были выпуски продукции в течение периода; после закрытия периода формируется фактическая себестоимость готовой продукции (на 26 счете). Если ДО закрытия месяца происходит реализация этой партии выпуска (то есть на 26 счете как бы еще нет полной фактической себестоимости)- то на 901 счет и в регистры/журнал операций/ попадает себестоимость реализации - по плановой себестоимости ? И только после закрытия месяца на 901 счете отражается (пересчитывается?) уже фактическая себестоимость реализации? ( ну и затем формируется Фин результат периода ?)

Конфигурация "Управление торговым предприятием для Украины", редакция 1.2. (1.2.48.1).
Просмотров: 81, последний комментарий от sava1   
Отражение внешнего совместителя в отчете по ЕСВ [раздел 1С Зарплата и Управление Персоналом 8]
Автор tdsovwork2019 — 18.11.20, 16:11 — 1 комментариев
Здравствуйте. Подскажите как отразить в отчете сотрудника который принят на две должности( на 0,25 оклада каждая должность)внешним совместителем? Он принят на должности-первая доктор узд, вторая -доктор-акушер-гинеколог. В отчете указываю категория работника -2(без трудовой книжки) пишет, что запись задублированная и что нужно ее обьеденить ????!?!!!
Просмотров: 96, последний комментарий от andr_andrey   
Отбор с условием в отчете на СКД [раздел Система компоновки данных]
Автор Yevhenii_S — 18.11.20, 14:47 — 7 комментариев
платформа: 1С:Підприємство 8.3 (8.3.16.1148)
Конфигурация: 1С:Бухгалтерія сільськогосподарського підприємства для України, редакция 2.0

Добрый день колеги.
Есть задача. имею отчёт сделанный в СКД , данные выбираются запросом, в запросе формируется временная таблица из 8 выборок по регистрам бухгалтерии, которые имеют одинаковые поля и сливаються через "ОБЪЕДИНИТЬ ВСЕ"

ВЫБРАТЬ РАЗРЕШЕННЫЕ
    ХозрасчетныйОстаткиИОбороты.Субконто1 КАК Контрагент,
    ХозрасчетныйОстаткиИОбороты.Субконто2 КАК ДоговорКонтрагента,
    "Початковий залишок" КАК Номенклатура,
    ЕСТЬNULL(ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстатокКт, 0) - ЕСТЬNULL(ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстатокДт, 0) КАК Показатель,
    NULL КАК Документ,
    ХозрасчетныйОстаткиИОбороты.Организация КАК Организация,
    "А" КАК ПорядокКолонок
ПОМЕСТИТЬ вт
ИЗ
    РегистрБухгалтерии.Хозрасчетный.ОстаткиИОбороты(&НачалоПериода, &КонецПериода, , , Счет = &Счет6856, &ПорядокСубконто) КАК ХозрасчетныйОстаткиИОбороты

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
    ХозрасчетныйОбороты.Субконто1,
    ХозрасчетныйОбороты.Субконто2,
    "Нараховано",
    ХозрасчетныйОбороты.СуммаОборотКт,
    ХозрасчетныйОбороты.Регистратор,
    ХозрасчетныйОбороты.Организация,
    "Б"
ИЗ
    РегистрБухгалтерии.Хозрасчетный.Обороты(&НачалоПериода, &КонецПериода, Регистратор, Счет = &Счет6856, &ПорядокСубконто, , , ) КАК ХозрасчетныйОбороты

ОБЪЕДИНИТЬ ВСЕ


пример выборок

в конце выбираем поля для отчёта из временной таблицы

ВЫБРАТЬ
    вт.Организация КАК Организация,
    вт.Контрагент КАК Контрагент,
    вт.ДоговорКонтрагента КАК ДоговорКонтрагента,
    вт.Документ КАК Документ,
    вт.Номенклатура КАК Номенклатура,
    вт.Показатель КАК Показатель,
    вт.ПорядокКолонок КАК ПорядокКолонок
ИЗ
    вт КАК вт

УПОРЯДОЧИТЬ ПО
    ПорядокКолонок


Далее настраиваем ресурсы, параметры, настройки и собственно получаем отчёт
П.С. отчёт не моего авторства, написан разработчиками конфы

Задача: когда пользователь выбирает отбор по контрагенту (1) (а именно группу(отсюда условие)) (2), нужно вывести в отчёт всех контрагентов из этой группы (3)
в отчёт. Сейчас можно вывести или без отбора всех по кому были движения, или контрагента по которому установлен отбор и были движения.

Вопрос: куда копать??? 64000000.gif

до этого в СКД делал довольно простые отчёты, понимаю откуда беруться данные. но не понимаю как связать отбор с запросом и куда соеденить выборку контрагента с выбраным родителем.... help.gif
Просмотров: 151, последний комментарий от sava1   
Программно цена устанавливается, а руками не получается установить [раздел Программирование в 1С Предприятие 8.3]
Автор sinchik — 18.11.20, 13:51 — 2 комментариев
1. Создал Расходную накладную
2.

&НаКлиенте
    Процедура ТоварыНоменклатураПриИзменении(Элемент)
        ТекущиеДанные = Элементы.Товары.ТекущиеДанные;
        ТекущиеДанные.СтавкаНДС =
            ПолучитьСтавкуНДСНоменклатуры(ТекущиеДанные.Номенклатура);
            
        
        ТекущиеДанные.Цена = ПолучитьЦенуТипаЦены (ТекущиеДанные.Номенклатура);
        
          РассчитатьСуммуТабличнойЧасти();
    КонецПроцедуры

&НаСервере  
      Функция ПолучитьЦенуТипаЦены (Номенклатура)  Экспорт
                                                                      
             Отбор = Новый Структура;
        
        Отбор.Вставить("Номенклатура", Номенклатура);
        Отбор.Вставить("ТипЦены", Объект.ТипЦены);  
                Данные = РегистрыСведений.РегистрТипаЦен.ПолучитьПоследнее(
         Объект.Дата, Отбор);
        
       Возврат Данные.Цена;



3.Что тут надо дописать? Чтобы можно было бы изменить цену руками!!! Она подставляется из регистра по ссылке на функцию, а на новую цену не меняется

Спасибо Большое!!!!!


 ! 

Правила: 4, 9
 
Просмотров: 98, последний комментарий от sinchik   
Перенос справочников УТП 1.2.27 в BAS УТ 3.2 [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор Михрутка — 18.11.20, 13:44 — 0 комментариев
Подскажите как перенести справочники из УТП 1.2.27 в BAS УТ 3.2. Пробовал через XML, но почему-то ничего не загружается.
Просмотров: 67, оставить комментарий   
Ошибка при вызове метода контекста (Заблокировать) [раздел Программирование в 1С Предприятие 8.3]
Автор gololol — 18.11.20, 11:23 — 2 комментариев
1С:Предприятие 8.3 (8.3.10.2667)
Толстый Клиент
Обычное приложение


Доброго времени суток.

Есть таблица: ДокументСостояние

В этой таблице одна запись (один документ)

В этом документе есть поля:

Состояние = "1"
ВерсияДанных = "AAAAAABc4OoM"

Есть РегламентноеЗадание: РЗ_ИзменитьСостояние (запускается один раз в период времени)
Это реглмантное задание изменяет значение поля "Состояние"

Ситуация следующая.

РЗ_ИзменитьСостояние - запустилось и изменило значение полей

Состояние = "2"
ВерсияДанных = "AAAAAABc4OoP"

Далее пользователь делает двойной клик на записи
и происходит переход из ФормыСписка в ФормуДокумента

В ФормеДокумента выполняется

Процедура ПриОткрытии()

        ...

    Если Не Ссылка.Пустая() Тогда
         ЭтотОбъект.Заблокировать();
    КонецЕсли;
    

КонецПроцедуры


Проблема в том, что блокируется запись у которой

ВерсияДанных = "AAAAAABc4OoM"

а на самом деле

ВерсияДанных = "AAAAAABc4OoP"

т.е. программа пытается заблокировать запись с несуществующей ВерсиейДанных

ош: Ошибка при вызове метода контекста (Заблокировать)
ЭтотОбъект.Заблокировать();
по причине:
Операция не может быть выполнена из-за несоответствия версии или отсутствия записи базы данных
(возможно, запись была изменена или удалена)!

Всё правильно.

Вопрс: "Как можно решить эту проблему?"
Просмотров: 99, последний комментарий от gololol   
Проблема с перебросом данных через объект ComConnector (1с 8.3.1690) [раздел Программирование в 1С Предприятие 8.3]
Автор andrew76 — 17.11.20, 16:39 — 14 комментариев
Добрый вечер !

Имеется 2-sql базы.Соединение между базами идет через объект ComConnector.
Соединение происходит нормально.Только при попытке записать данные из табличной части
документа Командировочные из одной базы в другую (в аналогичный Документ Командировочные),
выскакивает ошибка.При просмотре отладчиком выясняется следующее: (таблица источникsmile.gif
ТабличнаяЧасть1 - Значение COMObject
Add - метод не найден.
Count - метод не найден и так далее...
Столбцов ТЧ тоже не видно в отладчике.
Реквизиты же шапки документа читаются нормально.

В чем может быть проблема ?
Просмотров: 253, последний комментарий от andrew76   
ЗаказКлиента из курсом Валют [раздел Система компоновки данных]
Автор bodas1995 — 17.11.20, 10:16 — 6 комментариев
Помогите начинающему программисту, в решении данной задачи. Заплутался какие данные нужно выводить.

Прошу готового ничего не давать просто направить. Спасибо заранее

Просто поэтапно расписать что мне нужно сделать. Буду очень благодарен

Разработать отчет для анализа выполненных заказов клиентов в различных валютах.
В отчете реализовать группировки по организации, менеджеру, контрагенту.
Отборы по умолчанию: менеджер, контрагент, заказ.
Отчет должен строиться за период. (edited)
В отчете должны отображаться суммы по заказам клиентов в трех валютах: в грн, долларах, евро с пересчетом на дату каждого заказа.
Выводить итоги по группировкам и общие итоги. (edited)
Выводить заголовок отчета: Данные заказов в валютах системы за период .... по ......

этот отчет делался для конфигурации УТП

но его же и можно сделать для УПП, КУП или ЕРП


Просмотров: 167, последний комментарий от bodas1995   
Екселліо FPU-550ES по TCP [раздел Работа с торговым оборудованием]
Автор Petre — 16.11.20, 17:16 — 0 комментариев
Подключаю Екселліо FPU-550ES по TCP АртСофтовскими драйверами. Со стандартным портом 4545, который предлагают типовые, не подключается. Какой порт для данного ФП используется?
Просмотров: 84, оставить комментарий   
1С 8.3.8 мелкие шрифты [раздел Администрирование и настройка 1С]
Автор Dlmon — 16.11.20, 13:00 — 7 комментариев
Подскажите плз. Есть сервер терминалов 2016, на нем работает сетевая версия 1С, удаленные клиенты. Есть базы в версии 8.3.8. На 1080р мониторе шрифт в 1С очень мелкий получается. Масштабирование текста на основном мониторе не помогает. Как увеличить текст, меню? (на удаленном экране естно менять параметры экрана, шрифтов нельзя, только на основном)
Просмотров: 160, последний комментарий от Dlmon   
Сформировать ЗаказПоставщику из Табличной Части [раздел Программирование в 1С Предприятие 8.3]
Автор DmitriiKr — 16.11.20, 11:00 — 6 комментариев
Доброго времени суток.

Для каждого СтрТЧ Из ТЧ Цикл
        
        ДокументЗаказПоставщику = Документы.ЗаказПоставщику.СоздатьДокумент();
        
        ДокументЗаказПоставщику.Дата = ТекущаяДата();
        ДокументЗаказПоставщику.Контрагент = СтрТЧ.Номенклатура.Поставщик;
        ДокументЗаказПоставщику.Склад = Склад;
        
        НоваяСтрокаТЧДокумента = ДокументЗаказПоставщику.Товары.Добавить();
        НоваяСтрокаТЧДокумента.Номенклатура = СтрТЧ.Номенклатура;
        НоваяСтрокаТЧДокумента.Количество = СтрТЧ.КупитьНужно;
        НоваяСтрокаТЧДокумента.Сумма = СтрТЧ.ЦенаЗакупки;
        
        ДокументЗаказПоставщику.Записать();
        
        ДокументЗаказПоставщику.Записать(РежимЗаписиДокумента.ОтменаПроведения);
        
        Сообщить("Создан документ: заказ поставщику " + СтрТЧ.Номенклатура.Поставщик + " на товар " + СтрТЧ.Номенклатура + " в количестве " + СтрТЧ.КупитьНужно + " шт.");
        
        Элементы.СозданиеЗаказаПотавщику.Доступность = Ложь;
        
        
    КонецЦикла;



Этот код просто берет значения которые указаны в ТЧ на форме (в обработке), данные на форме получаются из документа:ЗаказПокупателя за определенный период.



Так вот застрял на том: В Табличной части есть несколько номенклатурой с одним и темже поставщиком.
Как сделать так чтобы заказПоставщику формировался по дному поставщику с несколькими номенклатурами.
Просмотров: 135, последний комментарий от DmitriiKr   
Автоматичне заповнення ціни та підрахунок суми товару в видатковій накладній [раздел Программирование в 1С Предприятие 8.3]
Автор igorslo — 13.11.20, 14:19 — 10 комментариев
Завдання:

У видатковій накладній потрібно, щоб автоматично заповнювалась ціна із номенклатури та множилась на кількість і давала суму для кожного товару.

&НаКлиенте
Процедура КількістьПриИзменении(Элемент)
    Эл = Элементы.Товари.ТекущиеДанные;
      Эл.Сума = Эл.Ціна * Эл.Кількість;
КонецПроцедуры

&НаКлиенте
Процедура ЦінаПриИзменении(Элемент)
    Эл = Элементы.Товари.ТекущиеДанные;
      Эл.Сума = Эл.Ціна * Эл.Кількість;
КонецПроцедуры


Якщо використовувати цей код, тоді треба вказувати і ціну, і кількість вручну зате сума рахується.
Пробував і підставляти ціну використовуючи "ПутьКДанным", тоді при виборі товару мені автоматично підгружалася ціна, але тепер не множилась ціна на кількість, тому й суму потрібно вводити вручну.


1С:Предприятие 8.3, учебная версия (8.3.8.1933)
Просмотров: 288, последний комментарий от igorslo   
Вернуть структуру с модуля объекта на клиент [раздел Программирование в 1С Предприятие 8.3]
Автор Inkognito — 13.11.20, 12:15 — 6 комментариев
Оптимизирую код обработки, управляемая форма, Бухгалтерия 2.0
Есть табличная часть, по которой проходимся в цикле (по документам). Для каждого документа нужно получить структуру и обработать на клиенте. Сейчас весь код в "МодулеФормы", и хорошо работает. Но вот беда - приходится копировать часть функций с "МодуляФормы" в "МодульОбъекта" (и наоборот). Код становится запутанней, поддерживать все сложнее.
Вопрос: как вызывать функцию получения структуры, если она находится в "МодулеОбъекта", которая должна вернуть структуру?

&НаКлиенте
Процедура Тест()

    Для каждого Строки из Элементы.ТЧДокументы.ВыделенныеСтроки цикл    
        Документ = Элементы.ТЧДокументы.ДанныеСтроки(Строки).Документ;        
                ПолученнаяСтруктура = ПолучитьСтруктуру(Документ); //перенести в "МодульОбъекта" и получить структуру
                //обрабатываем ее

КонецЦикла;

КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьСтруктуру(Документ)
    
    Структура = Новый Структура;
    Структура.Вставить("Номер", Документ.Номер);
       //...............................

    Возврат Структура;
КонецФункции
Просмотров: 164, последний комментарий от Inkognito   
Связка Вин 2008 + SQL + 1C 7.7 [раздел Администрирование и настройка 1С]
Автор Talkman — 13.11.20, 10:58 — 4 комментариев
Добрый день. Ситуация такая.

1. Поставлена тестовая Win 2008 SP 1 (Вируалка 10 ГБ ОЗУ 2 ядра по 2,9 ГЦ ).
2. Поставлен SQL 2008.
3. Заменен BKEND и odbcbcp.dll, sqlsrv32.dll и sqlsrv32.dll.
4. Добавлено представление sksprocesses.
5. Установлена 1С 7.7 027
6. С бекапа восстановлена база.


Запуск связки. База запустилась. Производительность аховая. Переход с одного ТМЦ на следующий в справочнике при нажатой кнопке вниз до одной секунды. Открытие журнала секунд 5-10. Проведение документов раз 5 дольше, чем на связке Win 2003 + SQL 2000.

Меняем условия.
1. Система Вин 2008 SP1. Та же.
2. Поднимаем на виртуалке на этом же сервере параллельно вин 2003 (4 ядра 6ГБ озу)
3. Поставлен SQL 2000.

При коннекте базы с win 2008 до sql 2000 почему то потребовало изменений в sksprocesses. Сделано. База подконнектилась с теми же симптомами. А именно: переход с одного ТМЦ на следующий в справочнике при нажатой кнопке вниз до одной секунды, открытие журнала секунд 5-10. Проведение документов раз 5 дольше, чем на связке Win 2003 + SQL 2000.

Меняем условие.
Коннект к базе из Вин 2003 на виртуалку с SQL 2000. Симптомы похожие.

Работа Вин 2003 с SQL 2000 локально хорошая. PS. Тестовая вируталка с 1 ядром и 4 ГБ Озу с вин 2003 и SQL 2000 имеет приемлемое быстродействие. Вряд ли проблема в выделенных ресурсах под тестовые системы.

Задача. Сделать рабочую с нормальной производительностью связку win 2008 + любой SQL на любой системе на любом компе. Буду рад услышать что не так сделано и как сделать правильно. Спасибо.




Talkman @ Сегодня, 10:55 * ,
Что еще занимательно, ранее до меня на фирме работала связка Вин 2003 + SQL локально для одной базы + SQL по сети на вин 2003 для другой базы. Быстродействие было приемлимым. Сейчас такого воссоздать почему то не получается...
Просмотров: 182, последний комментарий от Anderson   
Создание отчета на СКД програмно [раздел Программирование в 1С Предприятие 8.3]
Автор Sirius83 — 11.11.20, 12:00 — 11 комментариев
Платформа 1С:Підприємство 8.3 (8.3.10.2252)
"Управление производственным предприятием для Украины", редакция 1.3 (1.3.53.1)
Доброго времени! Есть некий отчет по взвешиванию продукции при ручном формировании с заданными параметрами все хорошо формирует

есть задача формировать отчет программно, собственно функция формирования отчета:
Код
Функция СформироватьОтчетПрограммно(Склад)
    Таб = Новый ТабличныйДокумент;    
    
    ТекОтчет = Отчеты.Отчет_РегистрацияВзвешиваний.Создать();
    СКД = ТекОтчет.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
    Настройки = СКД.НастройкиПоУмолчанию;
    НачДата = НачалоДня(ТекущаяДата()) - 1;
    НачДата = Дата(Год(НачДата),Месяц(НачДата),День(НачДата),20,0,0);
    НачальнаяДата = СКД.Параметры.Найти("НачалоПериода");
    Если НачальнаяДата = Неопределено Тогда
        
        ПараметрПериод = СКД.Параметры.Добавить();
        ПараметрПериод.Имя = "НачалоПериода";
        ПараметрПериод.Заголовок = "НачалоПериода";
        ПараметрПериод.ТипЗначения = Новый ОписаниеТипов("Дата");
        ПараметрПериод.ОграничениеИспользования = Ложь;
        ПараметрПериод.Значение = НачДата;
        ПараметрПериод.Использование =ИспользованиеПараметраКомпоновкиданных.Всегда;
        ПараметрПериод.ВключатьВДоступныеПоля = Истина;    
        НачальнаяДата = ПараметрПериод;
    КонецЕсли;
        
    КонечнаяДата = СКД.Параметры.Найти("КонецПериода");
    
    Если КонечнаяДата = Неопределено Тогда
        
        ПараметрПериод = СКД.Параметры.Добавить();
        ПараметрПериод.Имя = "КонецПериода";
        ПараметрПериод.Заголовок = "КонецПериода";
        ПараметрПериод.ТипЗначения = Новый ОписаниеТипов("Дата");
        ПараметрПериод.ОграничениеИспользования = Ложь;
        ПараметрПериод.Значение = НачДата;
        ПараметрПериод.Использование =ИспользованиеПараметраКомпоновкиданных.Всегда;
        ПараметрПериод.ВключатьВДоступныеПоля = Истина;    
        КонечнаяДата = ПараметрПериод;
        
    КонецЕсли;
    
    
    ПараметрКомпоновки = Новый ПараметрКомпоновкиДанных("НачалоПериода");
    ПараметрСКД = ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(ПараметрКомпоновки);
    ПараметрСКД.Значение = НачДата;
    ПараметрСКД.Использование = Истина;    
    
    КонДата = Дата(Год(ТекущаяДата()),Месяц(текущаяДата()),День(ТекущаяДата()),20,0,0);
    
    ПараметрКомпоновки = Новый ПараметрКомпоновкиДанных("КонецПериода");
    ПараметрСКД = ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(ПараметрКомпоновки);
    ПараметрСКД.Значение = КонДата;
    ПараметрСКД.Использование = Истина;        //Помещаем в переменную данные о расшифровке данных
        
    
    ПараметрДанных= ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("НачалоПериода");
    ПараметрДанных.Значение = НачДата;
        
    ПараметрДанных.Использование=Истина;
    
    
    ПараметрДанных= ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("КонецПериода");
    ПараметрДанных.Значение = КонДата;
    
    ПараметрДанных.Использование=Истина;
    
        
    МассивН = Новый Массив;
    МассивН.Добавить(Справочники.Номенклатура.НайтиПоКоду("00000001198"));
    МассивН.Добавить(Справочники.Номенклатура.НайтиПоКоду("00000001197"));
    МассивН.Добавить(Справочники.Номенклатура.НайтиПоКоду("00000001200"));
    СЗ = Новый СписокЗначений;
    СЗ.ЗагрузитьЗначения(МассивН);
    
    тОтчет = ТекОтчет;
    
    //НастройкиКД = ТекОтчет.КомпоновщикНастроек.ПолучитьНастройки();
    НастройкиКД = Настройки;
    ВидВзвешивания = тОтчет.КомпоновщикНастроек.Настройки.Отбор.ДоступныеПоляОтбора.Элементы.Найти("ВидВзвешивания"); //поле отбора присутствует в СКД
    
    НовыйОтбор = НастройкиКД.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    НовыйОтбор.ЛевоеЗначение = ВидВзвешивания.Поле;
    НовыйОтбор.ПравоеЗначение = Перечисления.ИнтекоВидыВзвешивания.Отгрузка;
    НовыйОтбор.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    НовыйОтбор.Использование = Истина;
    
    
    Отправитель = тОтчет.КомпоновщикНастроек.Настройки.Отбор.ДоступныеПоляОтбора.Элементы.Найти("Отправитель"); //поле отбора присутствует в СКД
    
    НовыйОтбор = НастройкиКД.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    НовыйОтбор.ЛевоеЗначение = Отправитель.Поле;
    НовыйОтбор.ПравоеЗначение = Склад;
    НовыйОтбор.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    НовыйОтбор.Использование = Истина;
    
    
    Номенклатура = тОтчет.КомпоновщикНастроек.Настройки.Отбор.ДоступныеПоляОтбора.Элементы.Найти("Номенклатура"); //поле отбора присутствует в СКД
    
    НовыйОтбор = НастройкиКД.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    НовыйОтбор.ЛевоеЗначение = Номенклатура.Поле;
    НовыйОтбор.ВидСравнения = ВидСравненияКомпоновкиДанных.ВСпискеПоИерархии;
    НовыйОтбор.ПравоеЗначение = СЗ;
    НовыйОтбор.Использование = Истина;
    
    тОтчет.КомпоновщикНастроек.ЗагрузитьНастройки(НастройкиКД);
    //
    
    ///////////////////////////////////////////////////////////////////////////////////////////////////
        ПараметрКомпоновки = Новый ПараметрКомпоновкиДанных("НачалоПериода");
    ПараметрСКД = ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(ПараметрКомпоновки);
    ПараметрСКД.Значение = НачДата;
    ПараметрСКД.Использование = Истина;    
    
    КонДата = Дата(Год(ТекущаяДата()),Месяц(текущаяДата()),День(ТекущаяДата()),20,0,0);
    
    ПараметрКомпоновки = Новый ПараметрКомпоновкиДанных("КонецПериода");
    ПараметрСКД = ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(ПараметрКомпоновки);
    ПараметрСКД.Значение = КонДата;
    ПараметрСКД.Использование = Истина;        //Помещаем в переменную данные о расшифровке данных
    
    
    ПараметрДанных= ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("НачалоПериода");
    ПараметрДанных.Значение = НачДата;
    
    ПараметрДанных.Использование=Истина;
    
    ПараметрДанных= ТекОтчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("КонецПериода");
    ПараметрДанных.Значение = КонДата;

    ПараметрДанных.Использование=Истина;
    
    
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
    
    
    Расшифровка = Новый ДанныеРасшифровкиКомпоновкиДанных;    
    //Формируем макет, с помощью компоновщика макета
    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;    
    //Передаем в макет компоновки схему, настройки и данные расшифровки
    МакетКомпоновки = КомпоновщикМакета.Выполнить(СКД, ТекОтчет.КомпоновщикНастроек.ПолучитьНастройки(), Расшифровка);    
    ВнешниеПараметры = Новый Структура;    
    //Выполним компоновку с помощью процессора компоновки
    ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, ВнешниеПараметры, Расшифровка);    
    //Выводим результат в табличный документ
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(Таб);    
    ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных, Истина);  
    
    ТаблицаРезультат = Новый ТаблицаЗначений;
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;

    ПроцессорВывода.УстановитьОбъект(ТаблицаРезультат);
    ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);

    ВОзврат Таб;    
    
КонецФункции

в результате получаем отчет, но без данных табличных частей.

Ткните пожалуйста носом, где недочет.
Просмотров: 259, последний комментарий от sava1   
RSS Текстовая версия Сейчас: 24.11.20, 12:18
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!