Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Программист 1С [раздел Предложения работы]
Автор KarinaO — 05.12.21, 18:58 — 0 комментариев
Требуется программист 1С 8.2
г. Запорожье
заработная плата от 30 тыс грн до 50 тыс грн

Компания «GFS» является ведущим производителем и поставщиком продуктов питания в форматах «Ready meals» и «Food to GO». Обладатели золотых медалей в украинском международном дегустационном конкурсе Favorite Food&Drinks. Одной из важнейших ценностей компании «GFS» являются наши люди. Мы ищем в свою команду профессионала, который сможет реализовать свои профессиональные навыки и приобрести новые. https://gfs.com.ua/

Если ты ищешь компанию с молодой, креативном командой, интересными задачами и возможностями для себя — тогда тебе к нам!

Что будешь делать :

Участие в автоматизации бизнес-процессов компании.
Взаимодействие с внутренним заказчиком, выявление требований и пожеланий.
Написание ТЗ для программистов.
Контроль срока выполнения задач.
Прием готовой задачи от программистов, тестирование, описание ошибок и внедрение доработок.
Обучение, составление инструкций и консультирование пользователей.
Внедрение готового продукта, консультация пользователей.
Что для этого нужно:

Опыт работы консультантом 1С или программистом 1С от 1-х года.
Знание 1С 8.3 УВП или 1с УТП, 1с Бухгалтерия и платформы 1С: Предприятие8
Опыт написания ТЗ для программистов и тестирование готового продукта на ошибки.
Желателен опыт построения бизнес-процессов, знаний бизнес-процессов производства, логистики и торговли.
Работа с большими массивами данных, опыт синхронизации других программ по 1С.
Внимательность к деталям, организованность, аналитический склад ума и хорошие коммуникативные навыки.
Желательно высшее профильное образование (информационные системы и технологии, бухгалтерия, аудит, экономика предприятия).
Знание бизнес-процессов торгово-промышленного предприятия, принципов бухгалтерского, управленческого или финансового учета.
Наличие сертификатов 1С и опыт работы с BAS ERP будет преимуществом.
Условия работы:

конкурентный уровень оплаты труда;
официальное оформление (полный соц. пакет);
комфортное рабочее место,
график работы пн.-пн. с 8.00 до 17.00
резюме направлять k.osokina@gfs.com.ua
Просмотров: 30, оставить комментарий   
Передача між кліентом та сервером [раздел Программирование в 1С Предприятие 8.3]
Автор rogabob — 04.12.21, 21:18 — 1 комментариев
64000000.gif
Конфігурація Розница 2.0, 1с 8.3 (кліент-сервер)
Є клієнт, на якому підключений фіскальний апарат .t400me.
При оплаті потрібна відправка даних на фіскальний апарат (умова= вигрузка в касовий = ИСТИНА, + кількість і штрихкод)
Суть в тому, що код нижче, пряцює при умові якщо кліент і є сервером.. при інакших обставинах там купа помилок.. тобто коли клієнт не є сервером
&НаСервере
Процедура ПечатьФК()
ТекушийПользователь=  ПараметрыСеанса.ТекущийПользователь;
Если ТекушийПользователь.Наименование="Адміністратор" Тогда
    
    ПроверкаКаса=Ложь;
    Для каждого стр из Объект.Товары Цикл
        Если стр.Номенклатура.ВигрузкаКасовий=Истина тогда
            ПроверкаКаса=Истина;
            Прервать;
        КонецЕсли;
    КонецЦикла;    
    Если ПроверкаКаса=Истина Тогда
        Драйвер = Новый COMОбъект("ecrmini.t400");
        Драйвер.t400me("open_port;2;115200;");  
        Драйвер.t400me("cashier_registration;1;0;");  
        Драйвер.t400me("open_receipt;0;");  
    КонецЕсли;

    Для каждого стр из  Объект.Товары Цикл    
        Если стр.Номенклатура.ВигрузкаКасовий=Истина тогда
            ШтрихКод1=ПолучитьШтрихКод(стр.Номенклатура);
            ШтрихКод=СокрЛП(ШтрихКод1);
            КстьТов=Формат(стр.Количество,"ЧДЦ=3; ЧРД=.; ЧГ=0");
            Драйвер.t400me("sale_plu;0;1;0;"+КстьТов+";"+ШтрихКод+";");  
        КонецЕсли;                
    КонецЦикла;    
    
    ОплатаКарткою=Ложь;
    Для каждого стрО из Объект.Оплата Цикл
        Если стрО.ВидОплаты.ТипОплаты=Перечисления.ТипыОплатЧекаККМ.ПлатежнаяКарта Тогда
            ОплатаКарткою=Истина;
        КонецЕсли;
    КонецЦикла;        
            
    Если ПроверкаКаса=Истина Тогда     
        Если  ОплатаКарткою=Истина Тогда    
            Драйвер.t400me("pay;2;0;");    
            Драйвер.t400me("close_port;");  
        Иначе
            Драйвер.t400me("pay;0;0;");  
            Драйвер.t400me("close_port;");  
        КонецЕсли;    
    КонецЕсли;
КонецЕсли;

КонецПроцедуры


На стороні сервера я пробував і тимчасові таблиці, і перемінну форми.. але все заходив в тупік..

Задача проста, потрібно щоб при натиску кнопки оплата і проходило надсилання даних на фіскальний.
Як грамотно це зробити.


Просмотров: 57, последний комментарий от Petre   
Выплаты партнерам - роялти с продажи по дропшиппингу [раздел 1С Управление небольшой фирмой для Украины]
Автор blackfm — 03.12.21, 17:16 — 0 комментариев
Здравствуйте, использую BAF (8.3.16.1690) конфигурацию Business Automation Software for small company. PROF (1.6.16.1)
Знаю, что пишу не совсем в "ту" тему, но именно ветки по BAS Small Business не нашел.

У меня наметились партнеры, которые продают через разные свои каналы товары с моего склада, а по факту, находят мне клиентов. Хотелось бы знать, как правильно провести все операции, и выплатить роялти партнеру?
В данный момент создаю каждый раз нового контрагента, а в качестве источника заказа указываю партнера. Взаиморасчет с партнером выполняю вручную и деньги выдаю как расходы. В реале, прибыль партнера считаю раз в месяц и делаю выплату ему.

Хотелось бы использовать полный взаиморасчет с контрагентом-партнером и при этом сохранить возможность создавать документы на конечного покупателя (расходные накладные, счета для оплаты, приходы денег и возвраты). Была такая мысль, создать документ на покупку услуги от контрагента-партнера на сумму роялти. Но реализация очень сложная для заполнения.

Может есть проще вариант, специально для таких схем работы?
Просмотров: 47, оставить комментарий   
Не отображаются 14% в Декларации по ПДВ [раздел 1С Бухгалтерия 7.7 для Украины]
Автор Shahta27 — 03.12.21, 11:06 — 2 комментариев
1С Бухгалтерия, платформа 7.70.27 релиз 7.70.338. Регламентная 3 кв. 2021 №1
Декларация ПДВ за 11.2021.Ряд. 1.1 - ПДВ -20%, Ряд. 1.3 - ПДВ 14%. Сумы автоматически
заполняются, но в Ряд. 9 не суммируются, только ПДВ по основной ставке - 20%.
Что не так в настройках..?

Просмотров: 103, последний комментарий от Shahta27   
Как получить уникальный идентификатор элемента справочника ? [раздел Программирование в 1С Предприятие 7.7]
Автор andrew76 — 02.12.21, 9:23 — 9 комментариев
Добрый день !

Как получить уникальный идентификатор элемента справочника в 1 с7.7.025 ?
Просмотров: 216, последний комментарий от andrew76   
Как убрать время из даты в запросе ? [раздел Программирование в 1С Предприятие 8.3]
Автор andrew76 — 30.11.21, 13:26 — 4 комментариев
Добрый день !

Имеется Запрос на выборку документов. Реквизит КартаЧитателя у документа имеет тип Дата. Вводится со временем вместе.Как в запросе убрать время из этого реквизита ?
Функции НачалоДня() и КонецДня() тут не помогут.

Запрос = Новый Запрос;
Запрос.Текст =

"ВЫБРАТЬ
|    КартаЧитателя.Ссылка КАК Ссылка,
|    КартаЧитателя.Книга,
|    КартаЧитателя.ДатаВыдачи,
|    КартаЧитателя.ДатаВозврата
|ИЗ
|    Документ.КартаЧитателя.Основной КАК КартаЧитателя
|ГДЕ
|    КартаЧитателя.ДатаВыдачи >=&ДатаНач И КартаЧитателя.ДатаВыдачи <=&ДатаКон";
Просмотров: 132, последний комментарий от andrew76   
Как оптимально выбрать остатки на указанные дни? [раздел Программирование в 1С Предприятие 8.3]
Автор Vofka — 29.11.21, 18:53 — 5 комментариев
Привет!

Есть регистр остатков с измерением Договор, ресурс Сумма.

Есть некоторые данные, допустим, в таблице значений:

Дата - Договор
01.11 - Договор1
02.11 - Договор2
05.11 - Договор3
10.11 - Договор4
29.11 - Договор5

Мне надо к этой таблице значений добавить Сумму из регистра. В таблице значений могут быть любые даты и договора.

Наверное, я мог бы написать 1 запрос, который это сделает. Но я не уверен, что он будет лучше работать, чем если я просто сделаю по одному отдельному запросу для каждой Даты и Договора.

Как бы вы это сделали?
Просмотров: 159, последний комментарий от Batchir   
Документ: точность суммы метода Итог(). Можно ли изменить? Или где определяется [раздел Программирование в 1С Предприятие 7.7]
Автор boser — 29.11.21, 13:06 — 2 комментариев
1с Предприятие 7.70.027

При сравнении сумм по колонке обнаружил, что выражение типа Итог("СуммаБезНДС") возвращает сумму с точностью 1 знак после запятой. Может кто-то подсказать почему именно такая точность?
Просмотров: 128, последний комментарий от boser   
как обойти ошибку при подключении внешней печФормы [раздел Программирование в 1С Предприятие 8.3]
Автор lolmatrix — 29.11.21, 10:33 — 2 комментариев
Здравствуйте, управляемы формы, конфигурация ЗУП 3.1, добавляю внешнюю печатную форму, так же как раньше работало. получаю ошибку:
Невозможно подключить дополнительный отчет из файла.
Возможно, он не подходит для этой версии программы.

Техническая информация:
Метод объекта не обнаружен (СведенияОВнешнейОбработке)
вот код самой функции
Функция СведенияОВнешнейОбработке() Экспорт
    
    ия СведенияОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.2.2.1");
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительныйОтчет();
    ПараметрыРегистрации.Версия = "1.3";
    
    Команда = ПараметрыРегистрации.Команды.Добавить();
    Команда.Представление = НСтр("ru = 'Стажи сотрудников в текущей организации'");
    Команда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
    Команда.Модификатор   = Метаданные.Справочники.ШтатноеРасписание.ПолноеИмя();
    Команда.Идентификатор = "СтажиСотрудников";
    
    Возврат ПараметрыРегистрации
    
КонецФункции

подскажите, пожалуйста, что не так как добавить внешнюю печатную форму в дополнительные отчеты
Просмотров: 135, последний комментарий от lolmatrix   
Не могу удалить документ корректировки долга поставщику [раздел 1С Управление небольшой фирмой для Украины]
Автор Laky2006 — 28.11.21, 22:15 — 3 комментариев
Здравствуйте помогите удалить документ
Унф для украины есть документ коректировка долга поставщику его необходимо удалить, но система не дает пишет
Ошибка:
Нет возможности зафиксировать расчеты с поставщиками
ТОВ, КОМЕЛ ТОВ, Основной договор, Корректировка долга 10 от 16.04.2021, Аванс - возможно, авансов поставщику не было или они уже полностью зачтены в товарных документах.

как найти где произошли зачеты авансов в каком документие, или как насильно удалить этот документ?
Просмотров: 157, последний комментарий от Vofka   
Заполнение РС (независимый, непериодический) [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 27.11.21, 19:46 — 12 комментариев
Приветствую, Форумчане!
УФ, самопис

Приветствую, Форумчане!

Сделал РС, независимый. непериодический
Заполнение этого РС должно происходить в подписке на событии при проведении документа. Это что-то вроде Журнала выполнения операций и запись в РС должна происходить при любом случае (разрешено проведение или нет)
Создал процедуру его заполнения:

Процедура ЗаполнитьРезультатПроверки(Источник, РезультатПроверки, Ошибка, ТипПроверки)
    
    Запись = РегистрыСведений.РезультатыПроверок.СоздатьМенеджерЗаписи();
    Запись.Дата = ТекущаяДата();
    Запись.ОбъектДанных = Источник;
    Запись.ОписаниеОшибки = ?(РезультатПроверки, Ошибка, "");
    Запись.Результат = ?(РезультатПроверки, "Ошибка", "Успешно");
    Запись.ТипПроверки = ТипПроверки;
    Запись.Записать();
    
КонецПроцедуры



Отладчик показывает, что данные все заполняются правильно, но сам регистр оказывается пустым, т.е. не записывается.
Что я не так сделал? Вроде всё как по учебнику, ну и раньше вроде такое делал... Что я забыл?

Обращение к этой процедуре идет так:

 Пока Выборка.Следующий() Цикл
***************    
            ЗаполнитьРезультатПроверки(Источник.Ссылка, РезультатПроверки, Выборка.ОписаниеОшибки, Выборка.ТипПроверки);
        КонецЦикла;


Если Отказ = Ложь, т.е. проведение разрешено, то запись в регистр происходит. Но если проведение запрещено, то запись в регистр не происходит. Я так понял откатываются в небытиё все транзакции. Хотя отладчик показывает правильность заполнения данными в регистр, запись не происходит.

Как можно справится с ситуацией? Т.е. чтобы запись в РС происходила при любом раскладе...
Просмотров: 259, последний комментарий от Batchir   
Поступление дополнительных расходов [раздел 1С Управление Торговым Предприятием 8]
Автор primely — 24.11.21, 19:58 — 0 комментариев
Добрый день, участники форума. Помогите разобраться в таком вопросе.

1С:Предприятие 8.2 (8.2.19.130)
"Управление торговым предприятием для Украины", редакция 1.2.

При попытке провести документ Поступление дополнительных расходов появляется нижеследующая ошибка:

Не заполнено значение реквизита "Счет учета НДС подтвержденный"!

Как исправить?


Вопрос закрыт.
Просмотров: 131, оставить комментарий   
как получить текущую запись из данных формы коллекция [раздел Программирование в 1С Предприятие 8.3]
Автор lolmatrix — 24.11.21, 9:30 — 5 комментариев
1с 8.3 управляемые формы.
Здравствуйте прохожу циклом по строкам получаю строку, а мне нужно передать метаданные в поле для вывода ошибки типа Поле = Объект.ЗначенияПоказателей[0].значение, вот текст
Для Каждого СтрокаТЧ Из Объект.ЗначенияПоказателей Цикл
СтрокаТЧ.Значение = 123456789;
КонецЦикла;

Как передать поле текущей строки СтрокаТЧ.Значение, заранее спасибо
Просмотров: 140, последний комментарий от lolmatrix   
Отсутствие движений по некоторым\всем регистрам накопления в документах [раздел Управление торговлей для Украины редакция 2 (Управление торговлей для России редакция 10)]
Автор denis86823 — 24.11.21, 9:23 — 8 комментариев
Добрый день! Имеется следующая проблема:
1С:Предприятие 8.3 (8.3.9.1850)
"Управление торговлей для Украины", редакция 2.3.
Разработка конфигурации: "ABBYY Ukraine", 2003-2008
(2.3.2.6)

В наличии база данных размером в 29 ГБ, последняя обрезка базы происходила в 2014 году.
В один прекрасный день обнаружили что не сопоставляются остатки склад/база. Начали проверять - есть документы (Реализации, Поступления, Перемещения) в которых отсутствует движение по всем или же некоторым регистрам накопления. Например, было Поступление товаров и услуг в котором не было движения по регистру "Партии товаров на складах (управленческий учёт)". Хоть мы и не пользуемся партионным учётом в базе, но этот регистр влияет на остатки. Конечно это решается перепроведением документа. Но проблема ещё и в том, что неизвестно количество накладных в которых отсутствует движение по регистрам, и не известно с какого периода копать. Повторюсь, что документы в базе с 2014 года. Даже если есть такие документы в 2015-2016 годах, становится страшно их перепроводить, так как насколько мне известно могут всплыть неприятные последствия.
Вопросы следующие:
1. Как отследить ВСЕ документы в которых отсутствуют или ВСЕ движения по регистрам накопления, или в которых нет НУЖНЫХ движений (определённый документ - определённое количество НУЖНЫХ движений по регистрам накопления)?
2. Можно ли использовать перепроведение этих документов, или же имеется какой-то другой метод?
3. Из-за чего вообще мог произойти этот сбой? (По возможности)

P.S. На форуме первый раз, зарегистрировался для того чтобы задать данный вопрос знающим людям. Программистом не являюсь но самые простые принципы работы 1С: Управление знаю. Также понимаю что база объём базы слишком большой, в планах после решения данной проблемы обрезка базы. Заранее извиняюсь если некорректно описал какие-то моменты.
Просмотров: 305, последний комментарий от denis86823   
Как изменить ведение взаиморасчётов в договоре контрагента по умолчанию? [раздел Программирование в 1С Предприятие 8.3]
Автор kolomtaras — 23.11.21, 17:08 — 15 комментариев
Как сделать что бы при создании нового договора, в поле ПО БУХ. ОБЛІКУ (на скрине цифра1), вкладки ОСНОВНІ (2), по умолчанию всегда было ПО РОЗРАХУНКОВИМ ДОКУМЕНТАМ (3), сейчас всегда по умолчанию ЗА ДОГОВОРОМ У ЦІЛОМУ (4). ?

Скрин прикрепляю

Просмотров: 279, последний комментарий от mvo2008   
Проблемы с BAS 2.1.16.1 на платформе 1с 8.3.18.1208 [раздел Администрирование и настройка 1С]
Автор kserg2012 — 23.11.21, 10:54 — 6 комментариев
Добрый день.

В силу обстоятельств вынужден был поставить BAS файловая на такой платформе 8.3.18.1208.
При разработке расширения столкнулся с рядом проблем:
-использую расширение, в расширении для новых полей нет "лупы" для заполнения синонимов на рус/укр языках
-в расширении при попытке добавить в УФ форме условное оформление постоянно падает конфигуратор
-пользователи также жаловались, что при попытке посмотреть в карточке контр-та все документы программа зависает

ТИИ и чек базы ничего не показывает - ошибок нет.

Самое неприятное, что при попытке вернуть на более раннюю платформу 8.3.16 и 8.3.15 база не открывается "Ошибка потока данных"

Подскажите пож-та, что можно еще сделать?
Просмотров: 185, последний комментарий от mokriak   
Таблица созданных программно справочников (документов) без сохранения [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 23.11.21, 8:24 — 1 комментариев
Приветствую, Форумчане!
УФ, познавательный вопрос

Недавно решал вопрос: массовое создание нескольких справочников программно.
Из некой формы галочкой выбирались строки ТЧ и на основании выбранных строк создавались программно справочники (ну и попутно документы).

В итоге, чтобы вновь созданные справочники вывести в некую итоговую таблицу значений (дополнительная форма с ТЗ), пришлось их создать, потом сохранить и вывести в ТЗ, чтобы можно было продолжить с ними работать: оставить или удалить непосредственно как ошибочные или ненужные...

Типа всё работает и все довольны, но вот хотелось бы понять насколько возможно ли следующее:

Создать программно справочники, запомнить их в памяти без сохранения в 1с, вывести то, что есть в памяти в некой ТЗ и эту ТЗ вывести на дополнительную форму для дальнейшей работы???

До этого сделал так: при программном создании выводил на экран вновь созданные справочники. В итоге на экране висело несколько справочников и Пользователь поочереди принимал решение, что делать с этими справочниками, но это не понравилось. Поэтому пришлось создавать, сохранять, выводить их в ТЗ и далее манипулировать (при определенных условиях при закрытии этой формы "ненужные" справочники удалялись программно непосредственно)
Просмотров: 126, последний комментарий от Vofka   
Не записывается периодический реквизит элемента справочника [раздел Программирование в 1С Предприятие 7.7]
Автор Talkman — 22.11.21, 16:39 — 7 комментариев
Добрый день. Впал в ступор, прошу помощи. 1С ПУБ, релиз платформы последний официальный.
Проблема.
Есть Справочник.ТМЦ, у него есть список периодических реквизитов. Один из них АвторДокаУЦ, который ведет учет пользователей, которые меняли учетную цену товара. В процедуре ПриЗаписи() меняется значение реквизита АвторДокаУЦ на нужное значение, проверяю в конфигураторе и с помощью сообщить(АвторДокаУЦ). Высвечивается нужное мне значение. После выполнения процедуры ПриЗаписи() значение в периодический реквизит не записывается. В чем может быть проблема? Перед присвоением значения реквизиту используется метод ИспользоватьДату(). Остальные периодические реквизиты элемента записываюются без проблем...
Просмотров: 206, последний комментарий от Sharzem   
Включить признак налоговый учет на 361 счете [раздел 1С Управление Торговым Предприятием 8]
Автор stark — 22.11.21, 16:01 — 2 комментариев
Нужно будет еще дописать в коде документов отгрузки и платежных документов, проводки.
Может кто сталкивался с подобной задачей?
Какие могут быть подводные камни?
На регламентные отчеты не повлияет?
Задача стоит в контексте ОСВ 361 счет сделать возможность фильтрации
операций Без НДС.
Просмотров: 146, последний комментарий от stark   
Клиент Сервер и Драйвер = Новый COMОбъект("ecrmini.t400"); [раздел Программирование в 1С Предприятие 8.3]
Автор rogabob — 22.11.21, 15:23 — 12 комментариев
Розница для Укр 2.0.6, 1с 8.3.17 Клієнт сервер

Раніше клієнт і сервер був як один, тому відповідно найнятий програміст особо не заморочувався на ком обєктах які створюються на клієнті а які на сервері (якщо це один компютер), але після переносу бази (окремо сервер окремо клієнт) почалися проблеми з фіскальним реєстратором

Код
&НаСервере
Процедура ЗавантаженняТоварівНаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Номенклатура.Ссылка,
        |    Номенклатура.КодПодГрупи,
        |    Номенклатура.КороткаНазва,
        |    Номенклатура.Артикул,
        |    Штрихкоды.Штрихкод,
        |    Номенклатура.Код,
        |    Номенклатура.Відділ
        |ПОМЕСТИТЬ ВТ_Ном
        |ИЗ
        |    Справочник.Номенклатура КАК Номенклатура
        |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.Штрихкоды КАК Штрихкоды
        |        ПО Номенклатура.Ссылка = Штрихкоды.Владелец
        |ГДЕ
        |    Номенклатура.ВигрузкаКасовий = ИСТИНА
        |
        |СГРУППИРОВАТЬ ПО
        |    Номенклатура.Ссылка,
        |    Штрихкоды.Штрихкод,
        |    Номенклатура.КодПодГрупи,
        |    Номенклатура.КороткаНазва,
        |    Номенклатура.Артикул,
        |    Номенклатура.Код
        |;
        |
        |////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
        |    ВТ_Ном.Ссылка,
        |    ВТ_Ном.КодПодГрупи,
        |    ВТ_Ном.КороткаНазва,
        |    ВТ_Ном.Артикул,
        |    ВТ_Ном.Штрихкод,
        |    ВТ_Ном.Код,
        |    ВТ_Ном.Відділ
        |ИЗ
        |    ВТ_Ном КАК ВТ_Ном
        |
        |СГРУППИРОВАТЬ ПО
        |    ВТ_Ном.Ссылка,
        |    ВТ_Ном.Артикул,
        |    ВТ_Ном.КороткаНазва,
        |    ВТ_Ном.Штрихкод,
        |    ВТ_Ном.КодПодГрупи,
        |    ВТ_Ном.Код,
        |    ВТ_Ном.Відділ";
    
    Запрос.УстановитьПараметр("Дата", КонецДня(ТекущаяДата()));
    //Запрос.УстановитьПараметр("ТипЦен", Справочники.ТипыЦенНоменклатуры.НайтиПоКоду("000000002"));
    
    Результат = Запрос.Выполнить().Выбрать();
    Если Результат.Количество()>0 Тогда
        Драйвер = Новый COMОбъект("ecrmini.t400");
        Драйвер.t400me("open_port;2;115200;");
        Драйвер.t400me("del_plu;2;1;");
    //    Драйвер.t400me("close_port;");
        
    //    Драйвер.t400me("open_port;4;115200;");

        //Відділ=1;
        Кількість=0;
        Пока Результат.Следующий() Цикл
                        
            ЗапросЦена = Новый Запрос;
            ЗапросЦена.Текст =
            "ВЫБРАТЬ
            |    ЦеныНоменклатурыСрезПоследних.Цена
            |ИЗ
            |    РегистрСведений.ЦеныНоменклатуры.СрезПоследних(
            |            &Дата,
            |            Номенклатура = &Номенклатура
            |                И ВидЦены = &ВидЦены) КАК ЦеныНоменклатурыСрезПоследних";
            ЗапросЦена.УстановитьПараметр("Номенклатура", Результат.Ссылка);
            ЗапросЦена.УстановитьПараметр("Дата", КонецДня(ТекущаяДата()));
            ЗапросЦена.УстановитьПараметр("ВидЦены", Справочники.ВидыЦен.НайтиПоНаименованию("Роздрібна"));
            РезультатЗапросаЦена = ЗапросЦена.Выполнить().Выбрать();
            Цена=0;
            Если РезультатЗапросаЦена.Количество()>0 Тогда
                Пока РезультатЗапросаЦена.Следующий() Цикл
                     Цена=РезультатЗапросаЦена.Цена;
                КонецЦикла;
            КонецЕсли;    
    
            Если Результат.Ссылка.Весовой=Истина Тогда
                Штучний=1;
            Иначе
                Штучний=0;
            КонецЕсли;
            Артикул=СокрЛП(Результат.Артикул);
            Если Не ЗначениеЗаполнено(Артикул) Тогда
                Артикул=Формат(Прав(Результат.Код,8));
            КонецЕсли;    
        //    сообщить(Артикул);
            КодПодГрупи=Результат.КодПодГрупи;
            Цена=Формат(Цена,"ЧДЦ=2; ЧРД=.; ЧГ=0");
            Кількість=Формат(Кількість,"ЧДЦ=3; ЧРД=.; ЧГ=0");
            Штрихкод=СокрЛП(Результат.Штрихкод);
            Відділ=Результат.Відділ;
            сообщить("Завантажено: "+Результат.Артикул+" "+Результат.КороткаНазва+" "+Штрихкод+" "+Результат.КодПодГрупи+" "+Цена);
            Драйвер.t400me("add_plu;"+СокрЛП(Артикул)+";"+КодПодГрупи+";"+Штучний+";0;0;1;"+Відділ+";"+Цена+";"+СокрЛП(Штрихкод)+";"+СокрЛП(Результат.КороткаНазва)+";"+Кількість+";");
        КонецЦикла;
        Драйвер.t400me("close_port;");
        сообщить("Вигрузку завершено.");

    Иначе
        сообщить("Немає дани для завантаження накасовий апарат !");
    КОнецЕсли;

КонецПроцедуры


&НаКлиенте
Процедура ЗавантаженняТоварів(Команда)
    ЗавантаженняТоварівНаСервере();
КонецПроцедуры


І з літератури ком обєкти сервер не передає.. або щось не правильно зрозумів

Якщо хтось підкаже як це змінити (можна і за оплату),
Потрібно щоб фіскальний отримував ті дані.
Бо все що на &клієнті виконується (тобто без процедур які виконуються на сервері)
Просмотров: 269, последний комментарий от Vofka   
RSS Текстовая версия Сейчас: 06.12.21, 8:27
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!