Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Два запроса в одном отчете СКД [раздел Система компоновки данных]
Автор Constantus — 03.07.20, 16:48 — 1 комментариев
Приветствую, Форумчане!
1с8.3.12, УФ, самопис, БСП

Имеется отчет СКД (рабочий) на базе одного запроса. Результат выводится в формате таблицы.
Требуется в этом же СКД разместить еще один набор данных-запрос, чтобы потом вывести в настройках два результата один под другим.

Т.е. получить в одном отчете два результата разных отчетов.
Подскажите как это сделать? Или ссылку на чтение?

Сейчас полсе создания 1-ой таблицы в настройках, создаю вторую таблицу и при изменении данных во второй таблице, в первой таблице всё меняется...
Просмотров: 43, последний комментарий от sava1   
Клієнтська ліцензія на 10 робочих місць [раздел Администрирование и настройка 1С]
Автор onsamuy — 03.07.20, 10:55 — 5 комментариев
Доброго дня. Якщо ліцензія встановлена на сервері у багатокористувацькому режимі, база 1С УТП файлова, який принцип роботи? ліцензія видається RDP сеансу, чи запущеній програмі 1С? Тобто 1 юзер може запустити скільки завгодно 1С, чи загальна кількість запущених 1С у всіх юзерів (навіть якщо він один активний) не може перевищувати 10?
Просмотров: 71, последний комментарий от Gazulo   
v7: Ресурсы числовой кнопки выбора в 1crcrus.dll [раздел Программирование в 1С Предприятие 7.7]
Автор jahhh — 02.07.20, 17:50 — 10 комментариев
хочу отредактировать числовую кнопку выбора в платформе 7.7
вот эту:



сделать ее больше, чтобы удобно было на планшете тыкать

кто может подсказать как наити ресурсы этой кнопки в 1crcrus.dll или другом *.dll файле

и только не надо про 7.7 и планшет насмехаться smile.gif


 ! 

Правила: 8
 
Просмотров: 106, последний комментарий от Sharzem   
Добавление данных в документ по средством обработки [раздел Программирование в 1С Предприятие 8.3]
Автор DmitryPushkarev — 02.07.20, 12:32 — 5 комментариев
Доброго времени суток. Конфигурация УПП 2 , версия 8.3.

Есть такая задача: необходимо заполнить табличную часть "Товары" документа ПоступленияТоваровУслуг, через обработку ЧтениеЭксель, где в табличной части "Данные" заполнены определенные реквизиты которые могут отличаться от порядка реквизитов в табличной части "Товары".

Вопрос: Как в обработке получить данные о документе, который вызвал обработку, и как заполнить подходящие поля из таблицы "Данные" в таблицу "Товары" документа, при условии что документ может быть еще не проведен или же записан.

Код обработчика, который есть пока что.

&НаКлиенте
Процедура ФайлНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    Объект.Файл = "";
    
    //Диалог выбора файла
    ДиалогВыбора = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    //ДиалогВыбора.Заголовок = “Выберите файл”;
    
    Если ДиалогВыбора.Выбрать() Тогда
        Объект.Файл = ДиалогВыбора.ПолноеИмяФайла;
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура Прочитать(Команда)          
    
    Объект.Данные.Очистить();
    
    //подключаемся к эксель
    Попытка
        Excel = Новый COMОбъект("Excel.Application");
        Excel.WorkBooks.Open(Объект.Файл);
        Состояние("Обработка файла Microsoft Excel...");
    Исключение
        Сообщить("Ошибка при открытии файла с помощью Excel! Загрузка не будет произведена!");
        Сообщить(ОписаниеОшибки());
        Возврат;
    КонецПопытки;    
    
    //Открываем необходимый лист
    Попытка
        Excel.Sheets(1).Select(); // лист 1, по умолчанию
    Исключение
        //Закрываем Excel
        Excel.ActiveWorkbook.Close();
        Excel = 0;
        Сообщить("Файл "+Строка(Объект.Файл)+" не соответствует необходимому формату! Первый лист не найден!");
        Excel.ОтменитьТранзакцию();
        Возврат;
    КонецПопытки;
    
    НС = 2;
    Пока НС <= Объект.КоличествоСтрок Цикл    
        Состояние("Файл "+Строка(Объект.Файл)+": Обрабатывается первый лист "+Строка(Формат(?(Объект.КоличествоСтрок=0,0,((100*НС)/Объект.КоличествоСтрок)),"ЧЦ=3; ЧДЦ=0"))+" %");
        НоваяСтрока = Объект.Данные.Добавить();
        //заполнение списока значениями            
        НоваяСтрока.Наименование = Excel.Cells(НС, 1).Text;
        НоваяСтрока.Цена = Excel.Cells(НС, 2).Text;
        НоваяСтрока.Валюта = Excel.Cells(НС, 3).Text;
        НоваяСтрока.Код = Excel.Cells(НС, 4).Text;    
        НоваяСтрока.НаименованиеДляПечати = Excel.Cells(НС, 5).Text;
        НоваяСтрока.Артикул = Excel.Cells(НС, 6).Text;    
        НоваяСтрока.Количество = Excel.Cells(НС, 7).Text;
        
        НС = НС +1;    
    КонецЦикла;                  
    
    
    //Объект.Файл.Вставить(0,ИмяФайла,ИмяФайла);
    //Закрытие Эксель после выполнения процедуры
    Excel.DisplayAlerts = 0;
    Excel.Quit();
    Excel.DisplayAlerts = 1;
    
КонецПроцедуры

// Здесь начинается вопрос темы.
&НаКлиенте
Процедура ЗаполнитьДокумент(Команда)
    
    ЗаполнитьДокументНаСервере();
    
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьДокументНаСервере()
    
    //

КонецПроцедуры


Код для открытия формы обработчика в документе ПриобретениеТоваровУслуг
&НаКлиенте
Процедура ЗаполнитьИзФайла(Команда)
    ПолучитьФорму("Обработка.ЧтениеЭксель.Форма.Форма").Открыть();
    
КонецПроцедуры


Как я понял при помощи кода ниже, можно получить открытый документ, но на него нельзя воздействовать на прямую.
  Форма=Документы.ПриобретениеТоваровУслуг.ПолучитьФорму();

P.s: Изучаю 1С - пожалуйста сильно не бейте.
Просмотров: 107, последний комментарий от denis84   
Ошибка с WinHttp.WinHttpRequest [раздел Программирование в 1С Предприятие 8.3]
Автор dobrotank — 02.07.20, 11:53 — 4 комментариев
Добрый день, коллеги!

Платформа 8.3.15.1830, конфигурация "1С:Учет в управляющих компаниях ЖКХ, ТСЖ и ЖСК, редакция 3.0 (3.0.77.5)". Столкнулся с интересной ситуацией:
Есть внешняя обработка, подключенная через БСП внешние отчёты и обработки. Она должна отрабатывать в качестве регламентного задания по расписанию. И в одной базе нормально отрабатывает. А в другой, с точно такой же конфигурацией, вываливается с ошибкой "Ошибка при вызове метода контекста (Open): Произошла исключительная ситуация (WinHttp.WinHttpRequest): URL-адрес не использует поддерживаемый протокол". Эта же ошибка воспроизводится и в файловой копии базы. При том, если запускать в фоновом задании через Консоль Заданий, то всё отрабатывает нормально. В чём же может быть дело?
Просмотров: 101, последний комментарий от dobrotank   
Период в отчете на СКД в учетом времени [раздел Система компоновки данных]
Автор Sirius83 — 01.07.20, 14:27 — 3 комментариев
Доброго времени всем!
Подскажыте пожалуйста как в отчете на СКД в поле отбора НачалоПериода КонецПериода которие имеют тип Стандартный период отобразить не только дату но и время (нужно для отбора).



1С:Підприємство 8.3 (8.3.10.2252)
"Управление производственным предприятием для Украины", редакция 1.3 (1.3.53.1)


 ! 

Правила: 8
 
Просмотров: 100, последний комментарий от Sirius83   
Программное добавление отбора в форме списка документов. [раздел Программирование в 1С Предприятие 8.1 (8.0)]
Автор Alex78 — 01.07.20, 12:58 — 1 комментариев
Доброго времени суток.
Есть документ "СчетНаОплатуПокупателю".
У него есть реквизит "ДоговорКонтрагента".
У договоров контрагента, в свою очередь, есть реквизит "ВидВзаиморасчетов".
Можно ли в форме списка документов "СчетНаОплатуПокупателю" добавить отбор по реквизиту "ДоговорКонтрагента.ВидВзаиморасчетов" и, если можно, как это сделать.
Платформа - 8.1.15.14.
Конфигурация - управление торговым предприятием для Украины 1.1.14.1.
Спасибо.
Просмотров: 65, последний комментарий от sava1   
Вывод нулевых остатков в отчёт [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор fenrishawke — 01.07.20, 9:53 — 13 комментариев
Добрый день. Есть отчёт для показа остатков на складе. Только эта icon_cuss.gif не выводит нулевые остатки. Помогите тупенькому пожалуйста 64000000.gif

Код запроса:
ВЫБРАТЬ
    СвободныеОстаткиОстатки.Номенклатура КАК Номенклатура,
    СвободныеОстаткиОстатки.КоличествоОстаток КАК КоличествоОстаток,
        ВЫБОР
        КОГДА КоличествоОстаток = 0 ТОГДА "0"
                    КОГДА НЕ СвободныеОстаткиОстатки.Номенклатура.Родитель.Родитель = НЕОПРЕДЕЛЕНО
            ТОГДА СвободныеОстаткиОстатки.Номенклатура.Родитель.Родитель
            ИНАЧЕ СвободныеОстаткиОстатки.Номенклатура.Родитель
    КОНЕЦ КАК Категория
ИЗ
    РегистрНакопления.СвободныеОстатки.Остатки(&Период, ) КАК СвободныеОстаткиОстатки

Просмотров: 176, последний комментарий от sava1   
Формирование прайс-листа.Как после вывода цен добавить еще колонки? [раздел 1С Управление небольшой фирмой для Украины]
Автор ElkaK — 29.06.20, 19:46 — 3 комментариев
УНФ. При выводе прайс-листа нужно, чтобы колонки с ценами были в средине таблицы, а после них шли еще заданные реквизиты номенклатуры. Цены всегда выводятся конечными колонками таблицы. Как это побороть?
Просмотров: 249, последний комментарий от denis84   
Как определить в двух строковых типах большее число [раздел Программирование в 1С Предприятие 8.3]
Автор webaristan — 29.06.20, 14:32 — 3 комментариев
Как определить в двух строковых типах большее число
Подскажите пожалуйста, заранее благодарен.
В двух строковых полях разные числа типа IP адреса: 245.120.243.567 и к примеру 299.125.40.69. Как определить в другом текстовом поле большее число.

Данное решение нужно для управляемых форм.

Подскажите где посмотреть пример или код, ну или описание этого метода обработки кода.
Благословений всем.
Просмотров: 126, последний комментарий от volodya1122   
Обработка Консоль запросов не размещается в подсистемах. [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 28.06.20, 15:13 — 3 комментариев
Приветствую, Форумчане!
1с8.3.12, БСП, УФ, самопис

Имеется классическая обработка: "ИнструментыРазработчикаКонсольЗапросов"
Имеется подсистема "Администрирование"
В подсистеме указываю эту обработку в "Составе", но в Командном интерефейсе" эту обработку не видно.
У меня крамольные мысли, что эту обработку как-то запретили размещать её в подсистемах.
Остальные обработки размещаются без проблем и усилий.

Что не так происходит, что я недоделываю?
Обработка работает через "Все функции"
Просмотров: 160, последний комментарий от Constantus   
Выбор минимальной даты в ТаблицеЗначений 1С 7.70.003 торговля склад для Украины? [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 25.06.20, 13:14 — 5 комментариев
Здравствуйте. Есть таблица значений, в которой есть колонка ДатаПриема. Нужно из этой колонки выбрать минимальную дату.

Расх=СоздатьОбъект("Документ.РасходнаяНакладная");
ТЗ=СоздатьОбъект("ТаблицаЗначений");
ТЗ.НоваяКолонка("ДатаПриема");
...................................................................
..................................................................
Расх.ВыбратьДокументы(НачДата, КонДата);
Пока Расх.ПолучитьДокумент()=1 цикл
ТЗ.ДатаПриема=Расх.ДатаПриема;
................................................
....................................................
КонецЦикла;

МинДата=???????????


Как определить из таблицы значений минимальную дату из всех значений ДатаПриема?
Спасибо!
Просмотров: 206, последний комментарий от ZUBR   
Ускорить работу запроса-объект по поиску данных [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 24.06.20, 11:44 — 4 комментариев
Приветствую, Форумчане!
1с8.3.12, УФ, самопис

Имеется некий запрос объект, в модуле которого прописывается код поиска остатка позиций по Регистру накопления.
    РезультатСЗ = Запрос.Выполнить().Выгрузить();
    
    РезультатСЗ.Колонки.Добавить("ОстатокСклада", ОбщегоНазначения.ОписаниеТипаЧисло(15,2));    
    РезультатСЗ.Колонки.Добавить("Проблема",       ОбщегоНазначения.ОписаниеТипаСтрока(100));
                                    
    Для Каждого СТР Из РезультатСЗ Цикл
        
        Если СТР.Параметр = "СТЛ" Тогда
            СТР.ОстатокСклада = ОстатокСтел(СТР.Номенклатура, СТР.Модель, СТР.РазмерИзделия, СТР.ПолировкаИзделия, СТР.Склад, СТР.Период);
        ИначеЕсли СТР.Параметр = "ОСН" Тогда
            СТР.ОстатокСклада = ОстатокНоменклатуры(СТР.Номенклатура, СТР.РазмерИзделия, СТР.ПолировкаИзделия, СТР.Склад, СТР.Период);
        ИначеЕсли СТР.Параметр = "ДОП" Тогда    
            СТР.ОстатокСклада = ОстатокДопов(СТР.Номенклатура, СТР.Склад, СТР.Период);
        КонецЕсли;    
            
    КонецЦикла;




Где функции "ОстатокСтел/Номенклатуры/Допов" имеет одинаковый смысл поиска из регистра накопления, только с разными параметрами поиска:Таких запросов аж 3-и штуки

Функция ОстатокСтел(Номенклатура, Модель, Размер, Полировка, Склад, Период)
    
    Результат = 0;
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ДвижениеТМЦОстатки.КоличествоОстаток КАК Остаток
        |ИЗ
        |    РегистрНакопления.ДвижениеТМЦ.Остатки(
        |            &Дата,
        |            Номенклатура = &Номенклатура
        |                И Модель = &Модель
        |                И Размеры = &Размеры
        |                И Полировка = &Полировка
        |                И Склад = &Склад) КАК ДвижениеТМЦОстатки
        |ГДЕ
        |    ДвижениеТМЦОстатки.КоличествоОстаток > 0";
    
    Запрос.УстановитьПараметр("Дата", Период);
    Запрос.УстановитьПараметр("Модель", Модель);
    Запрос.УстановитьПараметр("Номенклатура", Номенклатура);
    Запрос.УстановитьПараметр("Полировка", Полировка);
    Запрос.УстановитьПараметр("Размеры", Размер);
    Запрос.УстановитьПараметр("Склад", Склад);
.....................
    
КонецФункции



Запрос работает правильно, но очень медлено, т.к. каждая строка имеет свой параметр поиска "Период" и "Склад"
Можно ли как-то ускорить работу запроса по поиску остатков по каждой строке с разными параметрами поиска?
Просмотров: 179, последний комментарий от Bernet   
Помощь при выборе конфигурации 1С [раздел Помогите подобрать конфигурацию]
Автор premiumMagnolia — 24.06.20, 11:00 — 6 комментариев
Первый раз сталкиваюсь с 1С, так что, прошу, сильно не бить.
У нас есть на авторынке 1 склад и 2 магазина. Есть около 15 позиций товара, но самой единицы товара насчитывается до 10.000. Нам надоело считать товар вручную, который имеется в наличии. Поэтому решили подключить 1С, но здесь мы зашли уже в тупик. Нам нужно просто вести учет товар, не его продажа. Продажа будет осуществляться за наличку, либо переводом денег на карту.
Начальник говорит
Цитата
Хочу вести учет товар, не больше. Просто приход и уход товара. Отслеживать товар, будем с помощью сканера.

Какая версия 1С подойдет лучше всего?
Просмотров: 215, последний комментарий от denis84   
Как создать таблицу с данными, которая отдельно может храниться 1с 7.7 конф 7.7.003 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 22.06.20, 23:35 — 7 комментариев
Здравствуйте. У меня в офисе постоянно есть небольшое количество ремонтируемой техники. Есть отчет, который перебирает все документы и выделяет только те, которые имеют статус Времонте. Я хочу создать отдельную таблицу, в которой бы хранились ссылки на все документы ремонтируемых в данный момент аппаратов. Чтобы каждый раз не перебирать все документы. Далее программно можно осуществить удаление из таблицы ссылки на документ ремонтируемого аппарата в момент его выдачи. И также добавление новой ссылки при поступлении нового аппарата. Какой вид ресурсов программы для этого взять? Справочник? Регистр? А, может, можно как-то сохранять в виде документа список значений? Или таблицу значений? В виде реального объекта, а не виртуального. Чтобы он не создавался каждый раз, а реально присутствовал в памяти. Подскажите, пожалуйста, что лучше использовать и как? Мне нужен только сохраняемый список ссылок.
Спасибо!
Просмотров: 222, последний комментарий от rlinks   
Можно ли записать изменения в документе из модуля документа? 7.7.003 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 19.06.20, 19:37 — 3 комментариев
Здравствуйте!
В модуле документа (не модуле формы!) привыполнении некоторого условия есть такая строка:
Адрес=Мистер.ПочтовыйАдрес;

Мистер - это Справочник.Контрагенты, предварительно созданный через СоздатьОбъект.
Как в модуле документа записать изменение в документе? Потому что значение Адрес просто не переписывается.
Строка
Записать()
в модуле документа не действует. Выскакивает ошибка, что не выбран документ. А мне нужно, чтобы этот документ перезаписался, в модуле которого находится данная строка кода.
Как это сделать? Спасибо!
Просмотров: 124, последний комментарий от ZUBR   
При работе с фаловой базой данных подтормаживает 1С 7.7 [раздел Платформа 7.7]
Автор F.U.T.U. — 19.06.20, 10:37 — 10 комментариев
Доброго Вам утра! Возник интересный вопрос по сути в Названии темы.
1С:Предприятие 7.7 (7.70.027) "Бухгалтерский учёт" для Украины (7.70.328)
Немного о сути проблеммы. Раньше пользователей 1С было 3 человека, сейчас добавилось еще несколько пользователей всего где-то 10 одновременных пользователей. Недавно пользователи начали халоваться на подтормаживание работы 1С. Все пользователи работают через удаленный рабочий стол (RDP), подключаются к серверу через локальную сеть. Как ускорить работу 1С с файловой базой данных?
Просмотров: 250, последний комментарий от nik389   
Яка краща версія платформи з 8.3? [раздел Платформа 8]
Автор o.broshko — 19.06.20, 10:33 — 3 комментариев
Шановні консультанти 1С, яку Ви б порадили платформу з останніх (8.3. ?) з найменшою кількістю багів?
Просмотров: 148, последний комментарий от Petre   
Сортировка строк в печатной форме документов [раздел Платформа 8]
Автор onsamuy — 18.06.20, 15:29 — 2 комментариев
Доброго всем дня.
Уже не один год преследует меня следующая проблема. В запросе, если явно не указано сортировать по полю, выбирает данные "как попало".
Конкретнее: в конфигурации Бухгалтерия БАС, печать налоговой. В модуле есть процедура ПодготовитьТаблицы(). Эта процедура формирует запрос по табличным частям документа, но в запросе нет СОРТИРОВАТЬ ПО.
Все было ОК, пока мы не перешли на новый сервер. Теперь строки товара выводятся на печать как попало. Конечно, можно лезть в типовой функционал, прописывать принудительную сортировку по номеру строки, но это не выход. Принудительной сортировки в типовой конфе нет практически во всех документах.

Что может влиять на сортировку? Повторяюсь, такое произошло когда перешли на LINUX/ Postgre
Просмотров: 157, последний комментарий от Petre   
Управляемая форма списка для Поступления товаров и услуг [раздел Программирование в 1С Предприятие 8.3]
Автор vbi — 18.06.20, 11:22 — 2 комментариев
1С:Предприятие 8.3 (8.3.11.3133)
"Управление торговым предприятием для Украины", (1.2.24.3)

Сделали управляемую форму списка для документа поступление товаров и услуг. Вывели функционал сохранения и восстановления настроек формы:

Настройка формы работает. Сохранение настройки работает. Но вот если попробовать восстановить настройку - получаем ошибку:

Цитата
Параметры Отбора, Сортировки, Группировки или список отображаемых полей заданы неверно. по причине Невозможно применить фиксированные настройки.
Совпадают значения параметра при восстановлении настроек в управляемой форме


И список документов остается пустой. После этого ту же ошибку получаем и при всех остальных операциях (настройка, сохранение, очистка).
Если форму списка закрыть и открыть заново - настройки снова работают, но при восстановлении - то же самое. Как победить?
Просмотров: 140, последний комментарий от vbi   
RSS Текстовая версия Сейчас: 04.07.20, 12:30
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!