Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Настройка сканера штрихкодов Datalogic Quick Scan QW2100.....Помогите пожалуйста [раздел Работа с торговым оборудованием]
Автор IvantsivAnd — 20.01.17, 0:16 — 0 комментариев
Помогите пожалуйста настроить сканер в 1С.....уже второй день не могу подключить
1с 8.3.9.2033
УТП для Украины 1.2.39.1
сканера штрихкодов Datalogic Quick Scan QW2100
1. Установил драйвер на сканер и перевел его с клавиатуры в СОМ (сейчас СОМ3 в диспетчере устройств - Порты СОМ та LPT)....на клавиатуре сканер в блокнот записивает штрихкод!!
2. Установил 1С:Сканер штрихкода (COM) 8.1.6.1
3. Подключил его в 1с как торговое оборудование там также выбрал СОМ3 (все нашло .... все подключилось без вопросов)
4. Делаю "Тест устройства" в параметрах там выбивает "СОМ3: Ок и Keyboard: Ok".....также сканирую штрих и получаю отчет с своим штрхкодом и сканер выдает одинарной звук!!
5. В модуле обычного приложения в процедуре ПриНачалеРаботыСистемы добавляю подключение компоненти (ScanOPOS.dll)....все ок подключаеться
Но не срабатывает процедура ВнешнееСобытие в модуле форми обработки и когда сканирую при включенной обработке то сканер выдает какой-то тройной звук!

Помогити пожайлуста!!
Спасибо!!
Просмотров: 34, оставить комментарий   
Доступ к базе УТ 3.1 со смартфона [раздел Мобильная платформа 1С]
Автор anna_v — 19.01.17, 21:38 — 3 комментариев
На сервере расположена база УТ 3.1, настроен IIS, база опубликована. Какими средствами лучше воспользоваться для работы с ней торговым представителям для ввода заказов? Возможен ли доступ к веб-странице через смартфон? или есть более удобные варианты?
Просмотров: 49, последний комментарий от Flexy   
1С 8.2 УТ 10.3 Как сделать синхронный вывод двух реквизитов из одного справочника? [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Vzonder — 19.01.17, 14:49 — 1 комментариев

1С 8.2 УТ 10.3
На примере справочника станций метро Москвы.
Имеется справочник Метро.
В нем 2 реквизита: Станция и Ветка.

Если на форму документа (например, Заказ покупателя) выводить поле с одним реквизитом, то проблем не возникает.
А как вывести два реквизита справочника из одной записи.
Т.е. на форму документа выводится два поля, в одном отражается Станция, во втором Ветка (именно та, что была присвоена Станции в справочнике Метро) ?

Просмотров: 59, последний комментарий от Petre   
Как изменить значения реквизита "Код УКТВЭД" в табличной части Товары документа Налоговой Накладной [раздел Программирование в 1С Предприятие 8.3]
Автор Yana.P — 19.01.17, 13:01 — 5 комментариев
Создаю внешнюю обработку, в которой нужно создать автозаполние КодУКТВЭД



    Для каждого Стр из Таблица Цикл
        Если Стр.Пометка Тогда
            НайтиНоменклатуру = Справочники.Номенклатура.НайтиПоНаименованию(Стр.Номенклатура);

        

                КонецЕсли;
    КонецЦикла;


Подскажите пожалуйста, как дальше реализовать это? Чтоб найти этот КодУКТВЭД и соответственно записать в табличную часть Товары в выбранные документы
Просмотров: 92, последний комментарий от Petre   
Платформа 7.7 + Нова пошта. [раздел Программирование в 1С Предприятие 7.7]
Автор XBrut — 19.01.17, 12:50 — 3 комментариев
Товариші. Хто бачив-чув. Бо людям цікаво...
Просмотров: 101, последний комментарий от Flexy   
Работает ли СообщениеПользователю в управляемой форме обычного приложения? [раздел Программирование управляемых форм 1С 8.2]
Автор Yevhenii — 19.01.17, 11:23 — 9 комментариев
1С Предприятие 8.2 обычное приложение.
Конфигурация "Управление торговым предприятием для Украины", редакция 1.2.

Здравствуйте уважаемые.

Пытаюсь прикрутить вывод сообщения к полю ввода реквизита. Работаю в режиме обычного приложения, но форма управляемая.
Сообщение как бы выводит но только в нижней части, т.е. в некрасивой области сообщений. А хотелось бы выводить облачко именно на незаполненом поле.
Пробую вот так:
&НаКлиенте
Процедура ПродажаПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)
    
    Если Элементы.ПолеКурс.ТекстРедактирования="0,00" Тогда
    
        Отказ=Истина;
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = "Сначала введите курс!";
                Сообщение.Поле  = "Курс";
            Сообщение.ПутьКДанным = "Объект";
            Сообщение.Сообщить();
    КонецЕсли;

КонецПроцедуры



и так:
&НаСервере
Процедура Сообщить4НаСервере()
    Сообщение4 = новый СообщениеПользователю;
    Сообщение4.УстановитьДанные(РеквизитФормыВЗначение("Объект"));
    Сообщение4.Текст = "Сначала введите курс!";
    Сообщение4.Поле = "Курс";
    Сообщение4.Сообщить();
КонецПроцедуры


&НаКлиенте
Процедура ПродажаПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)
    
    Если Элементы.ПолеКурс.ТекстРедактирования="0,00" Тогда
    
        Отказ=Истина;
            Сообщить4НаСервере();

    КонецЕсли;
КонецПроцедуры
Просмотров: 116, последний комментарий от Petre   
Отчеты Торговля + Склад [раздел 1С Торговля и Склад 7.7 для Украины]
Автор Анатолий_73 — 18.01.17, 18:35 — 2 комментариев
Программа 1С Торговля +Склад 7.7 была установлена на Windows Server 2008 , после перехода на более мощный сервер с Windows Server 2012 программа 1С Торговля +Склад 7.7 стала работать некорректно в плане отчетов. При каждом запуске одного и того же отчета , результаты отчетов были разные.
Просмотров: 89, последний комментарий от mister-x   
Взаиморасчеты с Поставщиками в Рознице 1.0 [раздел Система компоновки данных]
Автор Constantus — 18.01.17, 14:44 — 2 комментариев
Приветствую, Форумчане!
Розница 1.0, обычное, 1с8.3

В рознице как известно нет отчета "Взаиморасчеты с Поставщиком" тем более в разрезе Контрагент и Регистратор.
Для документов "ПоступлениеТоваров", "ВозвратТоваров" и РКО создал регистр накопления "ВзаиморасчетыСПоставщиками" (Контрагент, ресурс: Сумма)
Проводки осуществояются корректно.

Создал отчет на СКД на базе виртуальной таблицы: ВзаиморасчетыСПоставщикамиОстаткиИОбороты с Периодичностью по Регистратору.
Вывел все необходимые полями

ВЫБРАТЬ
    ВзаиморасчетыСПоставщикамиОстаткиИОбороты.Контрагент.ТипКонтрагента,
    ВзаиморасчетыСПоставщикамиОстаткиИОбороты.Контрагент,
    ВзаиморасчетыСПоставщикамиОстаткиИОбороты.СуммаНачальныйОстаток КАК НачальныйОстаток,
    ВзаиморасчетыСПоставщикамиОстаткиИОбороты.СуммаКонечныйОстаток КАК КонечныйОстаток,
    ВзаиморасчетыСПоставщикамиОстаткиИОбороты.СуммаПриход КАК Приход,
    ВзаиморасчетыСПоставщикамиОстаткиИОбороты.СуммаРасход КАК Расход,
    ВзаиморасчетыСПоставщикамиОстаткиИОбороты.Регистратор
ИЗ
    РегистрНакопления.ВзаиморасчетыСПоставщиками.ОстаткиИОбороты(, , Регистратор, , ) КАК ВзаиморасчетыСПоставщикамиОстаткиИОбороты


Отчет СКД в Настройках: Группировка по Контрагентам и с подгруппировкой по Регистратору
В результате получаю явно некорректный результат по итогам (сорр, не знаю как разместить таблицу)

Контрагент Начальны__Приход____Расход___Конечный
Основание
Поставщик___331,800__439,800___108,000___663,600
Поступление____2,800____2,800______________5,600
Поступление__245,000__245,000____________490,000
Поступление__192,000__192,000____________384,000
РасходныйКО_-100,000___________100,000__-200,000
Возврат________-8,000_____________8,000___-16,000

Понимаю, что что-то делаю не так с размещением итогов и работой с ресурсами. Помогите разобраться как правильно отработать с ресурсами и итогами в отчете СКД
Просмотров: 100, последний комментарий от Constantus   
Не работает двусторонняя печать в 1с [раздел Платформа 8]
Автор marcus_666 — 18.01.17, 13:32 — 4 комментариев
09000000.gif Хелп о всемогучие 1с-ники. После обновления 1С с 8.2 на 8.3 на принтере HP M425dw не работает двухсторонняя печать. В настройках принтера установлен параметр двухстороней печати. В остальних програмах Word, Exel даже блокнот все работает на ура 19000000.gif. Раньше в 8.2 все хорошо работало. why.gif
Просмотров: 132, последний комментарий от podcast   
УНФ или Бухгалтерия ред.2? [раздел Прочее 1С 8]
Автор f12 — 18.01.17, 13:27 — 4 комментариев
Прошу совета. Произошла 100% потеря данных по 1С базе 8.2 Бух. "Подцепили" вирус шифровальщик, криптанул все данные на компе (сохранились только бекапы с МЕДКА и Сонаты - делались изначально на флешку) Вот собираюсь восстанавливать все данные (работы в принципе не очень много). Остановил свой выбор на УНФ для Украины или Бухгалтерии ред.2 Фирма на ед.налоге + ПДВ. Прошу вашего мнения или советов по поводу выбора конфигурации.
Просмотров: 168, последний комментарий от Trintintin   
Приказ о приеме на работу в 1С8 [раздел 1С Управление Торговым Предприятием 8]
Автор ЯраЯровая — 18.01.17, 12:11 — 7 комментариев
Добрый день! Подскажите ,как быть с неправильно оформленным приемом на работу? Был принят сотрудник, в приказе о приеме указали взносы на ФОТ, а во вкладке "Взносы" - пусто. ЗП данному работнику уже была начислена. Т.е. взносы по нему не начислялись?
Просмотров: 161, последний комментарий от Нонна   
Как сохранить в реквизите цвет? [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Vzonder — 18.01.17, 12:06 — 0 комментариев
Хочется сделать справочник, с перечислением Станций и Веток Московского Метрополитена.
Реализовано по аналогии справочника КонтактныеЛицаКонтрагентов

В форме справочника два поля (с выпадающим списком) с реквизитами (Станция и Ветка) и представление в котором эти реквизиты записываются через пробел.

Все замечательно, вот только длиннннновато получается:
Нахимовский проспект Серпуховско-Тимирязевская
)))))

Подскажите, как можно (наиболее просто) реализовать запись Линии (ветки) другим способом?
Например:
Цвет текста ветки (вместо название ветки вносится символ “-” с соответствующим цветом)
Цветом текста в названии станции
Картинка – в поле ветка выбирается маленькая картинка (квадратик нужного цвета, соответствующего ветке), который в свою очередь отражается в представлении через пробел рядом со станцией.
Цвет поля представления.
Иное

Любой способ передачи цвета, который можно записать в реквизит представления, который в свою очередь можно будет использовать для отражения на формах, формах списка и табличных полях.
Просмотров: 88, оставить комментарий   
Загрузка списка номенклатуры из эксель файла в 1с [раздел Управление торговлей для Украины редакция 2 (Управление торговлей для России редакция 10)]
Автор hitman0000007 — 18.01.17, 11:28 — 6 комментариев
Добрый день! Подскажите пожалуйста, как загрузить список номенклатуры из эксель файла в 1с? Для этого есть стандартная возможность или нужно что-то ещё???
Просмотров: 116, последний комментарий от Егор Динин   
Как открыть программно открыть форму контрагента? 1C 8.2 УТ 10.3 [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Vzonder — 17.01.17, 18:47 — 1 комментариев
1C 8.2 УТ 10.3


ОткрытьФорму("Справочник.Контрагенты.Форма.ФормаЭлементаТтн");


При выполнении процедуры из Формы Заказа Покупателя – открывается форма нового элемента….(

Научите, пожалуйста, как открыть форму с текущем Контрагентом.
Просмотров: 107, последний комментарий от Flexy   
Как сделать зведену податкову накладну [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Andrey102 — 17.01.17, 13:48 — 1 комментариев
Здравствуйте, подскажите пожалуйста как дописать код чтобы сделать зведену податкову накладну и зведену выдаткову накладну
Просмотров: 92, последний комментарий от Petre   
Как в табличное поле добавить строку из справочника? [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Vzonder — 17.01.17, 4:39 — 2 комментариев

1С 8.2 УТ 10.3

Создал в форме Справочника Контрагента табличное поле, по абсолютной аналогии с ВидыДеятельности, с соответствующем набором реквизитов, Табличной частью и реквизитами.

Поэтому, чтобы не городить огород, на примере ВидыДеятельности и задам вопрос:

На форме создал поле ввода: ПолеОсновнойВидДеятельности, подключил реквизит ОсновнойВидДеятельности, и включил кнопку выбора.

Теперь в ПолеОсновнойВидДеятельности можно выбирать элементы из СправочникСсылка.ВидыДеятельностиКонтрагентов.

При этом в Табличном поле ВидыДеятельности в имеющихся строках выбирается основной вид деятельности (подсвечивая шрифт жирным) в уже добавленных.

Возникла необходимость добавлять элементы (подобно действию кнопки добавить), путем выбора значения в ПолеОсновнойВидДеятельности.
Т.е. при отсутствии элемента, он автоматически добавляется в табличное поле ВидыДеятельности.

Понимаю, что в процедуре Процедура ПолеОсновнойВидДеятельности ПриИзменении(Элемент) необходимо задать запрос, который сравнит содержимое и если в списке строк не найдет элемент, то его добавит.

И тут у меня полный тупняк.
Вот какая…. Получается:


Процедура ПолеОсновнойВидДеятельностиПриИзменении(Элемент)
      
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    КонтрагентыВидыДеятельности.ВидДеятельности
        |ИЗ
        |    Справочник.Контрагенты.ВидыДеятельности КАК КонтрагентыВидыДеятельности
        |ГДЕ
        |    КонтрагентыВидыДеятельности.ВидДеятельности = &ВидДеятельности";
    
    Запрос.УстановитьПараметр("ВидДеятельности",  ОсновнойВидДеятельности);
    
    РезультатЗапроса = Запрос.Выполнить();
        
            Если РезультатЗапроса.Пустой() Тогда
            Предупреждение(" не найден!!!!");
      
        Иначе  Предупреждение("ОК!");
        
        ЭлементыФормы.ВидыДеятельности.ДобавитьСтроку(); // Сломал голову, как добавить в строчку элемент
                   
        КонецЕсли;
                    КонецПроцедуры


Пожалуйста, подскажите как правильно написать запрос, чтобы при отсутствии указанного в ПолеОсновнойВидДеятельности автоматическое добавление элемента?

И объясните, пожалуйста, как правильно написать, чтобы добавлялась не только новая строка, но и автоматически вставлялся элемент из справочника ВидыДеятельностиКонтрагентов?

Просмотров: 397, последний комментарий от Flexy   
Выбор сервера для 1с терминальный сервер [раздел Администрирование и настройка компьютера, железо]
Автор Веталь — 16.01.17, 15:16 — 21 комментариев
Раньше стоял обычный комп 4х ядерный амд на 2003 сервере 1с 8.2 9 пользователей в рознице и 1 в управление торговлей.
Нужно сменить само железо и виндовс. Нужна помощь с выбором и что б не дорого.
Также пару вопросов:
1) могут перенести лицензии на новое железо? если да то я так понял надо уже звонить и заказывать новые пинкоды.
2) по поводу выбора виндовса, 8.2 дружит с 2012 и 2016?
3) если брать уже готовое железо, то стоит ли брать с установленным виндовс сервером?(насколько я знаю то что ОЕМ виндовс поставляется уже сборщиком железа)
4) у нас работают 9 розниц через RDP, я так понял что кроме винды надо еще 10 CALи 9 RDP? Если брать все сразу то будет дешевле?
Просмотров: 446, последний комментарий от Flexy   
Синхронизация Бинотела и 1С [раздел Программирование в 1С Предприятие 8.3]
Автор dimplast — 16.01.17, 14:48 — 1 комментариев
Хотим синхронизировать Бинотел и 1С предприятие 8.3. Как происходит сам процесс? У нас несколько телефонов что делать и как? Обьясните плиз. Программа:

1С:Предприятие 8.3 (8.3.5.1383)

Управление небольшой фирмой для Украины, редакция 1.5
Локализация для Украины: ООО "ХВОЯ Интегра" (1.5.3.11) (http://v8.1c.ru/regional/RegionalSolutions_UA_UNF.htm)
Copyright © ООО "1C", 2015. Все права защищены
(http://www.1c.ru)
Просмотров: 128, последний комментарий от sava1   
Расчет цен [раздел 1С Управление Торговым Предприятием 8]
Автор DimaKCM — 15.01.17, 19:37 — 3 комментариев
Здравствуйте. 1С:Предприятие 8.3 (8.3.8.1964)"Управление торговым предприятием для Украины", редакция 1.2. Вопрос -можно ли реализовать алгоритм ценообразования по формуле = наценка на базовый тип в процентах плюс сумма ко всему документу. Привожу пример- Закупочная цена товара А -100грн, товарБ- 200гр, товарВ 150грн, нужно что бы к каждой цене прибавилось допустим 15% и после этого к сумме документа прибавилось 100грн (как разбить сумму по суммам)?
Просмотров: 178, последний комментарий от DimaKCM   
Доначисление до минимальной зарплаты [раздел 1С Управление Торговым Предприятием 8]
Автор iat — 15.01.17, 18:38 — 13 комментариев
1С:Предприятие 8.3 (8.3.7.1917)
"Управление торговым предприятием для Украины", редакция 1.2.
Разработка конфигурации: "ABBYY Ukraine", 2007-2016 (1.2.38.1)

Добрый день.
Скажите, пожалуйста, кто знает: реализована ли в УТП возможность автоматического доначисления до минзарплаты? Поясню: предприятие не может (не имеет материальной возможности) повысить оклады до 3200 грн. Предприятие оставляет существующие оклады желает воспользоваться доначислением до законодательного минимума.
Регистры по минимальной з\п и прожиточными минимумам заполнены. Где нужно указать, что начисленную зарплату следует увеличить до 3200? и есть ли такая возможность?
Благодарю.
Просмотров: 290, последний комментарий от Petre   
RSS Текстовая версия Сейчас: 20.01.17, 7:44
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне