Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Переход с УТ версии 3.1 на 3.2 (BAS) [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор python — 20.05.19, 16:57 — 0 комментариев
Доброго дня!

Предпринята попытка обновить конфигурацию УТ версии 3.1.5 до 3.2.
База тестовая. Размер не малый, клиент-сервер, БД MS SQL Server 2017. База на SSD диске, памяти достаточно.
Активно используется документ регистрации цен поставщиков.

Обновление проходит нормально (практически).

Проблема присутствует при выполнении обработчиков отложенного обновления.
В частности, процедура "Документы.РегистрацияЦенНоменклатурыПоставщика.ЗаполнитьВидЦеныПоставщикаВТабличнойЧастиТовары".
Выполняется сутками!

Текст процедуры, которая выполняется.
// Обработчик обновления BAS УТ 3.2.1
// Заполняет "ВидЦеныПоставщика" в табличных частях документа и обновляет движения по регистру сведений ЦеныНоменклатурыПоставщиков
Процедура ЗаполнитьВидЦеныПоставщикаВТабличнойЧастиТовары(Параметры) Экспорт
    
    ПолноеИмяОбъекта = "Документ.РегистрацияЦенНоменклатурыПоставщика";
    
    МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
    
    Результат = ОбновлениеИнформационнойБазы.СоздатьВременнуюТаблицуСсылокДляОбработки(
        Параметры.Очередь,
        ПолноеИмяОбъекта,
        МенеджерВременныхТаблиц
    );
    
    Если НЕ Результат.ЕстьДанныеДляОбработки Тогда
        Параметры.ОбработкаЗавершена = Истина;
        Возврат;
    КонецЕсли;
    
    Если НЕ Результат.ЕстьЗаписиВоВременнойТаблице Тогда
        Параметры.ОбработкаЗавершена = Ложь;
        Возврат;
    КонецЕсли;
    
    ЗапросПоДокументам = Новый Запрос;
    ЗапросПоДокументам.МенеджерВременныхТаблиц = МенеджерВременныхТаблиц;
    ЗапросПоДокументам.Текст = "
    |ВЫБРАТЬ
    |    Т.Ссылка                                     КАК Ссылка,
    |    Т.Ссылка.Партнер                             КАК Партнер,
    |    Т.Ссылка.УдалитьСоглашение                   КАК Соглашение,
    |    Т.Ссылка.УдалитьСоглашение.ВидЦеныПоставщика КАК ВидЦеныПоставщика
    |ИЗ
    |    Документ.РегистрацияЦенНоменклатурыПоставщика.Товары КАК Т
    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ ВТДляОбработки КАК ДокументыКОбработке
    |            ПО Т.Ссылка = ДокументыКОбработке.Ссылка
    |ГДЕ
    |    Т.Ссылка.Проведен
    |    И (Т.ВидЦеныПоставщика = ЗНАЧЕНИЕ(Справочник.ВидыЦенПоставщиков.ПустаяСсылка)
    |        И ЕСТЬNULL(Т.Ссылка.УдалитьСоглашение, ЗНАЧЕНИЕ(Справочник.СоглашенияСПоставщиками.ПустаяСсылка)) <> ЗНАЧЕНИЕ(Справочник.СоглашенияСПоставщиками.ПустаяСсылка))
    |";
    
    ЗапросПоДокументам.Текст = СтрЗаменить(ЗапросПоДокументам.Текст, "ВТДляОбработки", Результат.ИмяВременнойТаблицы);
    
    Выборка = ЗапросПоДокументам.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        
        НачатьТранзакцию();
        
        Попытка    
            
            Блокировка = Новый БлокировкаДанных;
            ЭлементБлокировки = Блокировка.Добавить(ПолноеИмяОбъекта);
            ЭлементБлокировки.УстановитьЗначение("Ссылка", Выборка.Ссылка);
            ЭлементБлокировки = Блокировка.Добавить("РегистрСведений.ЦеныНоменклатурыПоставщиков.НаборЗаписей");
            ЭлементБлокировки.УстановитьЗначение("Регистратор", Выборка.Ссылка);
            Блокировка.Заблокировать();
            
            ДокументОбъект = Выборка.Ссылка.ПолучитьОбъект();
            
            // Если объект ранее был удален или обработан другими сеансами, пропускаем его
            Если ДокументОбъект = Неопределено Тогда
                ОтменитьТранзакцию();
                ОбновлениеИнформационнойБазы.ОтметитьВыполнениеОбработки(Выборка.Ссылка);
                Продолжить;
            КонецЕсли;
            
            Для Каждого СтрокаТовары Из ДокументОбъект.Товары Цикл
                Если Не ЗначениеЗаполнено(СтрокаТовары.ВидЦеныПоставщика) Тогда
                    СтрокаТовары.ВидЦеныПоставщика = Выборка.ВидЦеныПоставщика;
                КонецЕсли;
            КонецЦикла;
            
            ДокументОбъект.УдалитьСоглашение = Неопределено;
            
            ОбновлениеИнформационнойБазы.ЗаписатьДанные(ДокументОбъект);
            
            НаборЗаписей = РегистрыСведений.ЦеныНоменклатурыПоставщиков.СоздатьНаборЗаписей();
            НаборЗаписей.Отбор.Регистратор.Значение = ДокументОбъект.Ссылка;
            НаборЗаписей.Отбор.Регистратор.Использование = Истина;
            НаборЗаписей.Прочитать();
            Если НаборЗаписей.Выбран() Тогда
                
                Для Каждого СтрокаНабора Из НаборЗаписей Цикл
                    
                    Если НЕ ЗначениеЗаполнено(СтрокаНабора.ВидЦеныПоставщика) Тогда
                        СтрокаНабора.ВидЦеныПоставщика = Выборка.ВидЦеныПоставщика;
                    КонецЕсли;
                    
                    СтрокаНабора.Соглашение = Неопределено;
                    СтрокаНабора.Партнер = Выборка.Партнер;
                    
                КонецЦикла;
                
                ОбновлениеИнформационнойБазы.ЗаписатьДанные(НаборЗаписей);
                
            КонецЕсли;
            
            ЗафиксироватьТранзакцию();
            
        Исключение
            
            ОтменитьТранзакцию();
            ОбновлениеИнформационнойБазыУТ.СообщитьОНеудачнойОбработке(Выборка.Ссылка);
                                        
        КонецПопытки;
        
    КонецЦикла;
    
    Параметры.ОбработкаЗавершена = ОбновлениеИнформационнойБазы.ОбработкаДанныхЗавершена(
        Параметры.Очередь,
        ПолноеИмяОбъекта
    );
    
КонецПроцедуры


Что-то мне подсказывает, что долго. По всей видимости - причина в количестве строк в документах, запись данных большими порциями.
Исправить можно только через разбиение на более мелкие документы? Или есть еще варианты оптимизации?

Пытался ли кто управлять последовательностью выполнения обработчиков отложенного обновления?
Хотелось бы посмотреть на эту разработку, но не бесплатная она: [необходимо зарегистрироваться для просмотра ссылки]

На этом проблемы с обновлением не заканчиваются, к сожалению.
Так как не все обработки отложенного обновления выполнены - при открытии документа (к примеру, заказа покупателя) выдается ошибка "Недостаточно фактических параметров".
Ошибка возникает при вызове необходимых обработчиков при открытии формы, но вылетает. Как бороться? Перепроверять все доки, все процедуры?
{(1)}: Недостаточно фактических параметров
Документы.РасходныйОрдерНаТовары.РасходныеОрдераОбновленыНаНовуюВерсию(Параметры)


Есть подозрение, что разработчики не тестировали обновление на больших базах.
Кто-то уже переходил на УТ BAS? Как успехи, какие впечатления?

О себе:
1С:Предприятие 8.3 (8.3.13.1809)
BAS Управление торговлей, редакция 3.2 (3.2.8.1)
Просмотров: 13, оставить комментарий   
В полях объекта не заполняются данные из запроса [раздел Программирование в 1С Предприятие 8.3]
Автор burza — 20.05.19, 11:16 — 5 комментариев
Где-то туплю но не могу понять где, подскажите. в полях объекта не заполняються данные из запроса, если через цикл влазят но мне не нужно переберать ДОЛ не одно, не правильно показывает.
Запрос = Новый Запрос;
   Запрос.Текст =
                "ВЫБРАТЬ
                |    СопровождениеКлиента.РуководительГруппы,
                |    ЗаказКлиентаГруппаОтдыхающих.Ссылка.Партнер,
                |    ЗаказКлиентаГруппаОтдыхающих.Ссылка.Санаторий,
                |    ЗаказКлиентаГруппаОтдыхающих.Ссылка.Номер
                |ИЗ
                |    Документ.ЗаказКлиента.ГруппаОтдыхающих КАК ЗаказКлиентаГруппаОтдыхающих
                |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.СопровождениеКлиента КАК СопровождениеКлиента
                |        ПО ЗаказКлиентаГруппаОтдыхающих.Ссылка.РуководительГруппы = СопровождениеКлиента.РуководительГруппы
                |ГДЕ
                |    ЗаказКлиентаГруппаОтдыхающих.Ссылка.Дата МЕЖДУ &ДатаС И &ДатаПо
                |    И СопровождениеКлиента.ПометкаУдаления = &ПометкаУдаления
                |    И ЗаказКлиентаГруппаОтдыхающих.Ссылка.ПометкаУдаления = &ПометкаУдаления
                |    И СопровождениеКлиента.Ссылка = &Ссылка

                |СГРУППИРОВАТЬ ПО
                |    ЗаказКлиентаГруппаОтдыхающих.Ссылка.Санаторий,
                |    СопровождениеКлиента.РуководительГруппы,
                |    ЗаказКлиентаГруппаОтдыхающих.Ссылка.Партнер,
                |    ЗаказКлиентаГруппаОтдыхающих.Ссылка.Номер";
  
   Запрос.УстановитьПараметр("ДатаС", ДАТА(2019, 1, 1));
   Запрос.УстановитьПараметр("ДатаПо", ДАТА(2020, 1, 1) );
   Запрос.УстановитьПараметр("ПометкаУдаления", ЛОЖЬ );
    Запрос.УстановитьПараметр("Ссылка", Объект.Ссылка );

  
    
РезультатЗапроса = Запрос.Выполнить();
    
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

//Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

Объект.ДОЛ = ВыборкаДетальныеЗаписи.Санаторий;
Объект.НомерЗаявки = ВыборкаДетальныеЗаписи.Номер;

//КонецЦикла;



 ! 

Правила: 4
 
Просмотров: 79, последний комментарий от sava1   
"1С:Предприятие 8. Управляющий" отзывы [раздел Остальные конфигурации 1С 8]
Автор nysysimara — 20.05.19, 10:40 — 0 комментариев
"1С:Предприятие 8. Управляющий" (решение для автоматизации управленческого учета).
Нужен ответ на вопрос: стоит ли устанавливать?
Интересно мнение тех, кто эксплуатирует данную конфигурацию,
получили ли руководители желаемое: УПРАВЛЕНЧЕСКИЙ учет?

и еще: Бухгалтерский учет сейчас ведётся в 7.7.
Есть ли функционал перегрузки данных из 7.7. в эту конфигурацию?

Просмотров: 38, оставить комментарий   
Перенос справочника Контагенты из Бухгалтерия 1.2 в УПП [раздел Бухгалтерия 8, редакция 1 для Украины]
Автор VarMkn — 20.05.19, 9:40 — 4 комментариев
Кто поможет с данной проблемой ?
Перенести надо в УПП 8.3

Исходная версия Бухгалтерия для Украины, редакция 1.2. (1.2.51.1
1С:Предприятие 8.3 (8.3.9.2233)

Спасибо
Просмотров: 84, последний комментарий от VarMkn   
Особова картка П-2 в 1С 8.3 [раздел Прочее 1С 8]
Автор pepelniy — 18.05.19, 19:09 — 2 комментариев
уважаемые форумчане.
подскажите пожалуйста, где найти личную карточку П-2 в 1С 8.3 (8.3.13.1644)
пс у меня Базовая 2.0, но думаю не принципиально
Просмотров: 52, последний комментарий от Petre   
Интеграция 1С УТП с Битрикс24 [раздел Программирование в 1С Предприятие 8.3]
Автор TailorMade — 18.05.19, 9:49 — 0 комментариев
Здравствуйте. хотел бы написать обработку для получения задач с Битрикс24 в 1С УТП через API. Может есть какой-то пример как это реализовать?А то с API не работал ни разу
Заранее спасибо
Просмотров: 46, оставить комментарий   
Заболансові рахунки для передачи товару від комітента комісіонеру [раздел 1С Управление производственным предприятием 8]
Автор Oceanoftastes — 17.05.19, 15:47 — 1 комментариев
В мене УПП 8.13 При формуванні документа "Реалізація товарів та послуг" по договору комісії формуються провадки
Д6431 К6432 ПДВ забов'язання Сума напр. 20 грн
Д 283 К 26 Передача товарів на комісію Сума напр. 90 грн =сумі собівартості продукції на рах26

в документі "Реалізація товарів та послуг" проставлені забалансові рахунки 0242 та 0241

але проводку Д0242 К- на суму відгрузки товару разом з пдв (у прикладі вона буде 120грн) программа робити не хоче.

А мені потрібна така проводка, бо не хочу ускладнювати облік веденням торгових націнок. Тобто я хочу, щоб формувалися проводки:

Д6431 К6432 ПДВ забов'язання 20 грн
Д 283 К 26 Передача товарів на комісію 90 грн =сумі собівартості продукції на рах26
Д0242 К- сума відгрузки товару 120грн

Як це реалізувати?
Просмотров: 70, последний комментарий от fly   
Вакансия Программист 1С8 в г.Харьков [раздел Предложения работы]
Автор Мила1 — 17.05.19, 14:32 — 0 комментариев
Мы многопрофильная корпорация, развиваемся в таких направлениях: медицинский центр, сеть аптек, сеть лабораторий. В поиске специалиста программиста 1С8, для успешного перехода корпорации с 7 версии ( да, еще остались компании работающие в 7 версии)).Есть действующий отдел в котором успешно работают 3 специалиста.
Предлагаем:
-заработную плату 30 000грн.
-работу в графике 5/2 с 9-18
-комфортный офис на ст.м.Холодная гора
-корпоративные скидки на обслуживание в размере 50% и 30%
-обеды в офис за счет компании

Задачи:
Написание программных модулей в программе 1С: 8 согласно поставленных задач, поддержка пользователей различных конфигураций 1С: 8, в том числе и не типовых.

Для нас важно:

-знания и навыки в приложении 1С 8; СКД
-знание типовых конфигураций (БП, ЗУП)
-приветствуется знание программирования в 1С 7.7 (для анализа алгоритмов старых обработок)
-умение разбираться в чужом программном коде
-способность, как к системной самостоятельной работе, так и умение эффективно работать в команде
Узнать больше о компании можно на сайтах:https://www.rmc.kh.ua/, [необходимо зарегистрироваться для просмотра ссылки], sapteka.com.ua
Если подходят наши условия, звоните по телефонам: 099 035 36 96, 067 395 54 98, Мила
Резюме можно отправить на почту astarta.apteki@gmail.com
Просмотров: 55, оставить комментарий   
Отбор при выборе справочника из данных запроса [раздел Программирование в 1С Предприятие 8.3]
Автор burza — 17.05.19, 13:33 — 3 комментариев
Есть запрос выводит какие руководители актуальны в этом году, есть документ в котором реквизит смотрит на руководителей. нужно чтобы при нажатие на выбор руководителя были только те которые актуальны.
Сделал так но выводит пустоту.помогите.
&НаСервере
Функция СписокКонтрагентов()
    
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
            |    ЗаказКлиентаГруппаОтдыхающих.Ссылка.Партнер,
            |    ЗаказКлиентаГруппаОтдыхающих.Ссылка.Санаторий,
            |    ЗаказКлиентаГруппаОтдыхающих.Ссылка.РуководительГруппы КАК РуководительГруппы,
            |    ЗаказКлиентаГруппаОтдыхающих.ДатаВыезда КАК ДатаВыезда
            |ИЗ
            |    Документ.ЗаказКлиента.ГруппаОтдыхающих КАК ЗаказКлиентаГруппаОтдыхающих
            |ГДЕ
            |    ЗаказКлиентаГруппаОтдыхающих.ДатаВыезда МЕЖДУ &ДатаВыездаС И &ДатаВыездаПо

            |СГРУППИРОВАТЬ ПО
            |    ЗаказКлиентаГруппаОтдыхающих.Ссылка.Партнер,
            |    ЗаказКлиентаГруппаОтдыхающих.Ссылка.РуководительГруппы,
            |    ЗаказКлиентаГруппаОтдыхающих.Ссылка.Санаторий,
            |    ЗаказКлиентаГруппаОтдыхающих.ДатаВыезда

            |УПОРЯДОЧИТЬ ПО
            |    ДатаВыезда";
  
   Запрос.УстановитьПараметр("ДатаВыездаС", 20190101);
   Запрос.УстановитьПараметр("ДатаВыездаПо", 20200101 );
  
   Возврат Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку("РуководительГруппы");
    
КонецФункции

&НаКлиенте
Процедура РуководительГруппыНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    НовыйПараметр = Новый ПараметрВыбора("Отбор.Ссылка", СписокКонтрагентов());
    НовыйМассив = Новый Массив();
    НовыйМассив.Добавить(НовыйПараметр);
    НовыеПараметры = Новый ФиксированныйМассив(НовыйМассив);
    Элементы.РуководительГруппы.ПараметрыВыбора = НовыеПараметры;
    
КонецПроцедуры

вот что дает запрос






 ! 

Правила: 8
 
Просмотров: 103, последний комментарий от Vofka   
БСП. Не отображается универсальный отчет у пользователя [раздел Остальные конфигурации 1С 8]
Автор Vladal — 17.05.19, 10:39 — 0 комментариев
Есть самописка на БСП 3.0.2.

Дал пользователю права на запуск универсального отчета.
В профиле группы с пользователем добавил соответствующую роль, "Использование универсального отчета".

На копии базы у меня получилось - в разделе учета у пользователя появился раздел "Отчеты" и "Универсальный отчет".

А в рабочей базе не могу воспроизвести.
Делал то же, что и на копии, проверил роли пользователя в конфигураторе - у пользователя роль использования универсального отчета есть.
В профиле группы - роль есть.
Пользователь в группе состоит.

Что делать?
Просмотров: 49, оставить комментарий   
Как отобразить остатки в форме выбора документа? [раздел Программирование в 1С Предприятие 8.3]
Автор Lexveritas — 16.05.19, 13:11 — 1 комментариев
Всем доброго дня!
1С 8,3,13 УПП обычные формы.

Дописка.

Суть такова:
Есть документ "задание" в котором есть реквизит "Номенклатур"а и "Количество". Движение в регистр "Задание" Приход.
Есть документ "Выпуск" у которого такие же реквизиты и движение Расход.

Вот каков вопрос: В документе "Выпуск" есть поле ссылающееся на документ "формаВыбора" в которой отражаются остатки регистра "Задание" на ТекущаяДата(), и возможно из этого списка выбрать значение в строку...

Как это сделать?
Пробовал мутаборить в форме выбора запросом, но ничего из этого не вышло...

Буду рад хоть каким то примерам и подсказкам!


 ! 

Правила: 4
 
Просмотров: 61, последний комментарий от Vofka   
Заполнение поля из свойства другого объекта [раздел Программирование в 1С Предприятие 8.3]
Автор jojojoba2 — 16.05.19, 12:44 — 11 комментариев
Добрый день!

Помогите начинающему разработчику 1С. Есть документ Перемещение ОС. В нем нужно добавить поле с вожможностью вода данных ,на ком или какому складе(МОЛ) принадлежит ОС(Тоесть чтобы было поле "Тот кто здал" и "Тот кто принял". При создании нового документа Перемещение ОС, при добавлении Основного средства необходимо чтобы данные на ком(на каком складе) оно числится добавлялись в созданное поле автоматически.

Подскажите метод или пример кода автоматического заполнения. Я Пытаюсь через обработку формы при изменении документа "Перемещение ОС"
подставить в новое поле (созданное мною "на ком числиться") данные из документа "Основные Средства" вкладка "бух учет" из поля "МОЛБУ",но это не реквизит , а переменная в Процедура ЗаполнитьОписания() формы элемента. Как сделать ссылку на конкретный элемент формы другого документа.

Процедура ОСОсновноеСредствоПриИзменении(Элемент)
    
СтрокаТабличнойЧасти = ЭлементыФормы.ос.ТекущиеДанные;
СтрокаТабличнойЧасти.м =Справочники.ОсновныеСредства.ФормаЭлемента. ???????????

КонецПроцедуры


Направте на путь истинный.

Спасибо.


 ! 

Правила: 4, 9
 
Просмотров: 174, последний комментарий от Vofka   
Нужен внешний отчет обороты счета для 1С 8.3 на СКД или похожий отчет [раздел Программирование в 1С Предприятие 8.3]
Автор fricker12 — 16.05.19, 9:44 — 3 комментариев
У кого-нибудь есть внешний отчет обороты счета для 1С 8.3 на СКД или похожий отчет. Скиньте пример пожалуйста.


 ! 

Правила: 4
 
Просмотров: 81, последний комментарий от sava1   
7.7 Запрет копирования данных из печатной формы в буфер обмена [раздел Программирование в 1С Предприятие 7.7]
Автор Lunatik_55 — 16.05.19, 8:45 — 4 комментариев
Добрый день. Нужно запретить копировать данные из печатной формы в буфер обмена, при этом функции меню "Файл" - "Сохранить" и "Сохранить как" должны быть доступны.
Если использовать стандартный метод таблицы "Защита(1)", то блокируется не только копирование в буфер, но и функции сохранения в файл. Пробовал вернуть доступность этим функциям меню через использование "FormEx", не срабатывает. Может у кого-то есть идеи как это реализовать?

Делается все это для защиты данных. Сохранение в файл я могу перехватить, сделать копию и потом проанализировать кто и что копировал. С тем что копируют через буфер, у меня проанализировать не получается. Проще запретить копировать в буфер, но как это сделать не знаю.
Просмотров: 91, последний комментарий от sava1   
Загрузка курсов валют НБУ XML для 1с 7.7 [раздел Отчеты / Обработки]
Автор Acid — 15.05.19, 14:56 — 1 комментариев
сабж.

**какое же оно все кривое, блеать....
Прикрепленные файлы
Прикрепленный файл  ZagruzkaKursov77_XML.zip ( 17.82 килобайт ) Кол-во скачиваний: 10
 
Просмотров: 52, последний комментарий от Vofka   
Загрузка данных из Excel начала тормозить и иногда вообще обрывается [раздел Администрирование и настройка 1С]
Автор george_smith — 15.05.19, 9:06 — 0 комментариев
Здравствуйте!
Пользователь работает в терминальной сессии, в документе "Реализация товаров и услуг", загружает номенклатурные позиции из файла Excel. Раньше быстро работало, а сейчас начало тормозить, иногда загрузка обрывается. Особенное если номенклатурных позиций больше 100. Даже при 50 отрабатывает не совсем хорошо. Подскажите как решить данную проблему или хотя бы в какую сторону копать.


 ! 

Правила: 4
 
Просмотров: 75, оставить комментарий   
Будет ли отличаться работа 1С на Exppress от работы на полной SQL? [раздел Программирование в 1С Предприятие 7.7]
Автор NAGor4ik — 15.05.19, 8:58 — 12 комментариев
Будет ли отличаться работа 1С на Exppress от работы на полной SQL
Просмотров: 214, последний комментарий от Bernet   
У пользователя нет доступа к отбору отчета СКД [раздел Система компоновки данных]
Автор Constantus — 14.05.19, 15:18 — 1 комментариев
Приветствую, Форумчане!
Делал много раз различные отчеты СКД, для доступа к отчету активировал роль "базовые права" (эта роль есть у всех пользователей).
Всегда работало на ура...

Создал довольно простой отчет СКД с отбором по одному полю и вывожу его в заголовок отчета...
Пользователь открывает отчет и у него нет доступа на редактирование, проведение отбора. при открытии отбора вообще отсутствуют какие-либо доступные поля для отбора, в структуре отчета также пусто... В роли стоят все галки для этого отчета. У других пользователей с аналогичными правами такая же ситуация.
С полными правами нормально...

Что могло произойти? Как вернуть функционал?

Создал с нуля новый такой же отчет. Всё руками, ничего не копировал... Также... нет доступа к отборам и т.д.


У кого есть полные права - нормально...


У регистра сведений, откуда брались данные не было прав для пользователя...
Просмотров: 88, последний комментарий от pablo   
Группировка разных документов с общим реквизитом по максимальной дате [раздел Система компоновки данных]
Автор Constantus — 13.05.19, 14:15 — 3 комментариев
Приветствую, Форумчане!

Имеется некий документ с реквизитом Дата и ДокОснование

Получается так:

Док01__от__02.05____ДО01
Док02__от__07.05____ДО01
Док03__от__06.05____ДО01
Док04__от__04.05____ДО01

Док05__от__09.05____ДО02
Док06__от__13.05____ДО02
Док07__от__06.05____ДО02
Док08__от__10.05____ДО02

Нужно сгруппировать этот список документов, чтобы сгруппировано было по ДО01/02, максимальной датой

Результат (выделенные строки

Док02__от__07.05____ДО01
Док06__от__13.05____ДО02

Т.е. единственное, что связывает эти документы это ДОХХ. Никак не могу сообразить как объединить их по общему реквизиту ДО, максимальной датой документа?
Просмотров: 85, последний комментарий от Vladal   
СКД Выбрасывает null группировки [раздел Программирование в 1С Предприятие 8.3]
Автор Said — 13.05.19, 11:08 — 3 комментариев
Добрый день.

Вопрос по СКД. (8.3.9.1818)
Пишу отчет "Дт задолженность по периодам"
Суть отчета, показать задолженность в разных периодах. И такую которая тянется с более ранних периодов и сгруппировать по периодам задолженности.

Текст запроса
ВЫБРАТЬ
    ХозрасчетныйОстатки.Субконто3 КАК ДокументРасчетов,
    ХозрасчетныйОстатки.СуммаОстатокДт КАК СуммаЗадолженности,
    "0" КАК ПорядокЗадолженности
ПОМЕСТИТЬ ВТ_Остатки
ИЗ
    РегистрБухгалтерии.Хозрасчетный.Остатки(&Период {(&Период)}, Счет = &Счет, , {(Субконто1).* КАК Контрагент, (Субконто2).* КАК ДоговорКонтрагента, (Субконто3).* КАК ДокументРасчетов}) КАК ХозрасчетныйОстатки
{ГДЕ
    (">0") КАК ПорядокЗадолженности}
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    ХозрасчетныйОстатки.Субконто3 КАК ДокументРасчетов,
    ХозрасчетныйОстатки.СуммаОстатокДт КАК СуммаЗадолженности,
    ">30" КАК ПорядокЗадолженности
ПОМЕСТИТЬ ВТ_Остатки30
ИЗ
    РегистрБухгалтерии.Хозрасчетный.Остатки(ДОБАВИТЬКДАТЕ(&Период, ДЕНЬ, -30) {(&Период)}, Счет = &Счет, , {(Субконто1).* КАК Контрагент, (Субконто2).* КАК ДоговорКонтрагента, (Субконто3).* КАК ДокументРасчетов}) КАК ХозрасчетныйОстатки
{ГДЕ
    (">30") КАК ПорядокЗадолженности}
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    ВТ_Остатки.ДокументРасчетов КАК ДокументРасчетов,
    ЕСТЬNULL(ВТ_Остатки30.ПорядокЗадолженности, ">0") КАК ПорядокЗадолженности,
    ЕСТЬNULL(ВТ_Остатки30.СуммаЗадолженности, ВТ_Остатки.СуммаЗадолженности) КАК СуммаЗадолженности
{ВЫБРАТЬ
    ДокументРасчетов.*,
    ПорядокЗадолженности,
    СуммаЗадолженности}
ИЗ
    ВТ_Остатки КАК ВТ_Остатки
        ЛЕВОЕ СОЕДИНЕНИЕ ВТ_Остатки30 КАК ВТ_Остатки30
        ПО ВТ_Остатки.ДокументРасчетов = ВТ_Остатки30.ДокументРасчетов


Проблема в том что в консоли запросов запрос показывает все корректно. Колонки "ПорядокЗадолженности" и "СуммаЗадолженности" заполнены.
А вот когда в отчете пытаюсь сгруппировать по "ПорядокЗадолженности" у меня выводится только группировка ">30". Хотя в консоли есть ">0" и ">30"

Пытался указать для поля "ПорядокЗадолженности" в ролях "Обязательное", но ничего не помогло. "Автозаполнение" - снял

Прошу помощи, что я делаю не так?
Заранее спасибо.
Просмотров: 142, последний комментарий от sava1   
RSS Текстовая версия Сейчас: 21.05.19, 6:56
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне