Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Задать ширину растянуть форму [раздел Программирование управляемых форм 1С 8.2]
Автор Gigi — 21.11.17, 13:26 — 2 комментариев
Всем опять привет!
Опять проблема блиин! Как надоело...
Вечно кляузы, проблемы .. дебилизм
Вообщем форме задать нужные пределы и растянуть ее в нужной величине это оказывается опять очередной раз целая проблема ...
Так пытался .. сяк старался ... ни в какую ...
Ну какие только варианты не пробуешь а делает ну просто БЕЗОБРАЗНО
Короче не буду долго демагогить, а лучше предложу посмотреть это "великолепие"

Вот как безобразно делает.
Опять вынужден возиться с ерундой, тогда как куча дел поважнее.
Нужно группу общей формы "Рубли" РАСТЯНУТЬ и сделать по ширине так как группу: "кВт/ч"
А не в таком приплюснутом безобразном виде как получается.
Как не старался никак не получается.
Увеличиваю ширину группы "Руб", а ее ширина уходит влево (т.е. уменьшая группу:"кВт/ч") , тогда как нужно что бы ширина увеличивалась не влево, а в право.
Жесть ... как все через одно место построено... достало ...
Опять проблема сделать пустячное дело .... ладно пардон!
Вообщем буду признателен если кто подскажет, как сделать.... Первое ... второе и т.д.
Просмотров: 55, последний комментарий от Gigi   
Как сделать недоступными некоторые значения переключателя? [раздел Программирование в 1С Предприятие 8.3]
Автор Alex78 — 21.11.17, 13:05 — 3 комментариев
Доброго времени суток.
Платформа 8.3.10.2252. Конфигурация - УТ 3.1.5.1 для Украины (на УФ).
Есть документ, у него есть реквизит ПроцентСкидки. Соответствующий элемент формы - поле переключателя. Задача следующая - исходя из некоторых условий некоторые значения переключателя сделать недоступными.
Попытка № 1:

&НаКлиенте
Процедура qwerty()
МассивДостЗнач=Новый Массив;
// заполнение массива
// .............................
//заполнение массива
ЭтаФорма.Элементы.ПроцентСкидки.СписокВыбора.ДоступныеЗначения.ЗагрузитьЗначения(СпДоступныеЗначения);
КонецПроцедуры


Выдается сообщение "Значение не является значением объектного типа (ЗагрузитьЗначения)".

Попытка № 2:

&НаСервереБезКонтекста
Процедура qwertyServ(СпВыбора)
МассивДостЗнач=Новый Массив;
// заполнение массива
// .............................
//заполнение массива
СпВыбора.ДоступныеЗначения.ЗагрузитьЗначения(СпДоступныеЗначения);
КонецПроцедуры

&НаКлиенте
Процедура qwerty()
qwertyServ(ЭтаФорма.Элементы.ПроцентСкидки.СписокВыбора);
КонецПроцедуры


Результат - тот же.


Пардон за оформление, что-то намутил.

 ! 

Правила: 3,4,9
 
Просмотров: 62, последний комментарий от Alex78   
Табличный документ - окрасить строку в цвет по условию цикла [раздел Программирование управляемых форм 1С 8.2]
Автор Gigi — 21.11.17, 9:12 — 11 комментариев
Всем привет!
Опять вынужден выходить на форум и опять по ерунде.
Вот фрагмент процедуры запроса на создание отчета с использованием макета:
........
знОплачен=Строка(ЗапросОбъект.СчетОплачен);
Если ОтчетныйПериод=знОтчетныйМесяц Тогда
номСтр=номСтр+1;
ОблТаблица.Параметры.Заполнить(Запрос);
    Если знОплачен="Нет" Тогда
    Сообщить(знОплачен+" -- "+номСтр);
    ТекОбласть=ТабДок.Область("R"+номСтр+"C1:R"+номСтр+"C12");
    ТекОбласть.ЦветФона=WebЦвета.Желтый;
    КонецЕсли;
ТабДок.Вывести(ОблТаблица);
КонецЕсли;
..........

Опять процедура никак не может попасть в значение "Нет" переменной "знОплачен" и окрасить строку в желтый цвет.
Т.е. окрасить те строки где реквизит: "СчетОплачен" имеет значение "Нет"
Почему?
Опять, что ли нужно строки загонять в массив или ТЗ , а уже после окрашивать .... и заставлять машину делать двойную работу. Опять что ли это делать необходимо ради какой то ерунды .
А нельзя ли одним циклом решить этот пустяк.
Короче буду опять признателен!
Суть в том, что код окрашивает не только значение "Нет", но местами прихватывает и значение "Да".
Т.е. попасть никак не может .. дурачек ...smile.gifsmile.gif ... Ладно Шутка!
Вообщем буду признателен!
Просмотров: 85, последний комментарий от Gigi   
Почему не удается в параметры построителя отчетов поместить границу регистра накопления [раздел Программирование в 1С Предприятие 8.3]
Автор redking — 19.11.17, 21:48 — 7 комментариев
Добрый день, создана простая обработка конструктором (Построитель отчетов) на регистре денежные ср-ва (УПП)
ВЫБРАТЬ
    ДенежныеСредстваОбороты.СуммаОборот,
    ДенежныеСредстваОбороты.Период
ИЗ
    РегистрНакопления.ДенежныеСредства.Обороты(&НачДата, &КонДата, День, ) КАК ДенежныеСредстваОбороты

Обработка работает.Далее
в Процедура ОтчетВывести() добавлено:
    НачДата = '20171011';
    КонДата = Новый граница(Документы.ПлатежноеПоручениеВходящее.НайтиПоНомеру("00006",РабочаяДата),ВидГраницы.Включая);
    
        ПостроительОтчетаОтчет.Параметры.Вставить("КонДата", КонДата);
    ПостроительОтчетаОтчет.Параметры.Вставить("НачДата", НачДата);

при выполнении отчета ошибка
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Отчет.Форма(57)}: Ошибка при вызове метода контекста (Вывести)
ПостроительОтчетаОтчет.Вывести(ЭлементыФормы.ПолеТабличногоДокумента);
по причине:
{(5, 2)}: Ошибка обработки представления "РегистрНакопления.ДенежныеСредства.Обороты:Несоответствие типов (Параметр номер ""2"")"
<<?>>РегистрНакопления.ДенежныеСредства.Обороты(&НачДата, &КонДата, День, ) КАК ДенежныеСредстваОбороты

Почему не удалось прописать Границу в параметры? или где может указывать тип параметров?


 ! 

Правила: 4,5,9
 
Просмотров: 198, последний комментарий от redking   
Сохранение данных в обработке [раздел Программирование в 1С Предприятие 8.3]
Автор A.Frost89 — 17.11.17, 14:42 — 12 комментариев
Добрый день, Уважаемые товарищи. На основе некой обработки, взятой с просторов интернета, переделав её под себя ,столкнулся с тем, что.. Простите, не с того начал. Обработка для Бухгалтерия предприятия КОРП, редакция 3.0 (3.0.52.36), предназначена для печати транспортной накладной, с возможностью забивки нужных данных,вида, водитель, адрес погрузки, данные о грузе и прочее. Подошли к главному Столкнулся с тем, что внесенные данные, одним пользователем, не отображаются у других пользователей, использующих данную обработку. Т.е. если Иванов, ввел данные,беря инфу из справочников физ.лиц и контрагентов, сохранил, записал, напечатал и закрыл окно, у него при открытии, информация сохранится, а вот если Петров откроет на данном документе ту же обработку, то внесенной информации не будет. Посоветуйте как быть. Как сделать так, чтобы другие пользователи видели внесенные первоначальные данные, и чтобы не было путаницы, и повторного внесения информации(правильной аль нет).
Хоть заранее и не благодарят, но все равно Благодарю Вас всех!


 ! 

Правила: 4,5
 
Просмотров: 197, последний комментарий от Petre   
Удалить указанные стоки табличной части [раздел Программирование управляемых форм 1С 8.2]
Автор Gigi — 16.11.17, 15:27 — 7 комментариев
Привет всем!
У меня опять вопрос ерундовый. У которого наверно опять решение это .... целая проблема.
Опять как обычно.. сделать ерунду сложно, а не наоборот.
Вопрос в чем... нужно удалить строки табличной части в которых булевый "реквизит2" имеет значение ЛОЖЬ.
Ну никак это не удаеться блин.. эта опять ерунда.
Потому, что наверно команда: Объект.ТабличнаяЧасть1.Удалить(ТекСтрокаИдент); удаляет по номеру строки, а не по идентификатору.
Поэтому в цикл удаляет не все поля имеющие на пример значение реквизита: "Реквизит2": ложь.... кое что оставляет и не удаляет.
Как быть? Блиин! Опять вынужден выходить на форум из ерундового вопроса.
Думал можно в цикле удалять так:
Сторка.Удалить();

Но где такое счастье, что бы можно было такой легкой командой удалить. И не париться с номером строки.. идентификатором и т.д.
&НаКлиенте
Процедура ТЧ_УдалитьУказанныеСтроки()
Для Каждого Сторка из Объект.ТабличнаяЧасть1 цикл
ТекСтрокаНомер=Сторка.НомерСтроки;
ТекСтрокаИдент=Сторка.ПолучитьИдентификатор();
Сообщить(""+ТекСтрокаНомер+" -- "+ТекСтрокаИдент);
//------------------------------------------------
Если  Сторка.Реквизит2=ложь Тогда
//Сторка.Удалить();    // ну такой команды конечно нет ... естественно
Объект.ТабличнаяЧасть1.Удалить(ТекСтрокаИдент); // не все удаляет .. пропускает не удалив
КонецЕсли;
//------------------------------------------------
КонецЦикла;    
КонецПроцедуры

Как быть?
Может в таком случае нужно удалять по идентификатору?
И как это сделать?
Буду признателен!
Просмотров: 155, последний комментарий от Petre   
Иерархический список [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор ranis — 16.11.17, 8:39 — 4 комментариев
Нужно изменить справочник банковские счета, чтобы был иерархический список. Только есть там владельцы справочника(Справочники "Организации" и "Контрагнеты"). Как это можно реализовать?
Просмотров: 100, последний комментарий от Bernet   
Вывод уникального идентификатора документа [раздел Программирование в 1С Предприятие 7.7]
Автор Lion-Box2 — 15.11.17, 15:41 — 1 комментариев
Добрый день.
Платформа 1С:Предприятие 7.7 для SQL (7.70.027)
Конфигурация "Торговля+Склад для Украины" (7.70.007)
Была поставлена задача организовать автоматическую выгрузку данных для поставщика.
По требованию поставщика в выгрузку должен быть включён уникальный идентификатор документа. На платформе 8.хх это реализовано.
На семёрке - не нашёл. В принципе поставщика устроит значение поля IdDOC одной из таблиц скуля, но не знаю как это сделать без скул-запроса, а со скул-запросом - ТОЖЕ НЕ ЗНАЮ.
Подскажите, реально ли, получить этот идентификатор?
Вообще-то механизмы получения ун.идентификатора в конфе есть, но они привязаны не ко всем документам, которые надо выгружать, а насыщать базу инфой, которая нам самим не нужна - не хочется.
Просмотров: 86, последний комментарий от Vofka   
Разные цены для разных единиц измерения одного товара [раздел Программирование в 1С Предприятие 8.3]
Автор Михрутка — 15.11.17, 15:31 — 5 комментариев
1С 8.3. УТП 1.2.27.6

Тема уже избита, но решения мною не найдено. Как сделать, чтобы у одного товара на разные единицы измерения можно было бы установить разные цены. Через механизм скидок не вариант, т.к. во-первых создать для 15к тываров такие скидки задача не из простых, а во-вторых, при изменении цены на базу измениться цена на вторую упаковку, что не должно быть.
Как можно реализовать такой вариант, 2 цены на один товар, с мимимальными передалками?
Просмотров: 123, последний комментарий от logist   
Добавить кнопки на общую форму "ПечатьДокументов" [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 15.11.17, 9:33 — 12 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

На общей форме "Печать документов" имеются кнопки: "Отправить по электронной почте" и "Сохранить как..."

Как можно добавить на эту форму кнопки "Печать", "Параметры страницы" и "Предварительный просмотр"?
Просмотров: 1075, последний комментарий от Constantus   
Печать документа на общей форме "ПечатьДокументов" ориентация страницы [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 15.11.17, 9:29 — 0 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Сделал печать документа на основе общей формы "ПечатьДокументов".

Но печать вышла с книжной ориентацией, а требуется печать по-умолчанию в альбомной ориентации. Как такое сделать?

Процедура НапечататьДокумент1(ПечДокумент, КоличествоЭкземпляров = 1, НаПринтер = Ложь, Заголовок = "") Экспорт
Если ПечДокумент = Неопределено тогда
    Возврат;
КонецЕсли;
// Получить необходимое количество копий
Если КоличествоЭкземпляров < 1 Тогда
    ПечДокумент.КоличествоЭкземпляров = 1;
Иначе
     ПечДокумент.КоличествоЭкземпляров = КоличествоЭкземпляров;
КонецЕсли;
Если НаПринтер Тогда
     ПечДокумент.Напечатать();
Иначе
// Отобразить печатный документ на экране
    ФормаПечати = ПолучитьОбщуюФорму("ПечатьДокументов",, ПечДокумент);
    ФормаПечати.ПечатныйДокумент = ПечДокумент;
    ФормаПечати.Заголовок = Заголовок;
    ФормаПечати.Открыть();
КонецЕсли;
КонецПроцедуры // НапечататьДокумент()


В функции формирования табличного документа стоит ориентация

    Если ШК Тогда
    ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
    Иначе
    ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
    КонецЕсли;
    

    Возврат ТабДок;




Извините, поспешил...

В модуле общей формы при открытии добавил код

ЭлементыФормы.ПолеТабличногоДокумента.ОриентацияСтраницы=ПечатныйДокумент.ОриентацияСтраницы;


Вроде сработало
Просмотров: 62, оставить комментарий   
Нужен код списания товаров по методу FIFO [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор cao0603 — 13.11.17, 18:29 — 3 комментариев
кто может поделиться готовым кодом на списание по FIFO?заранее спасибо


 ! 

Правила: 4,5
 
Просмотров: 134, последний комментарий от Vofka   
Объединение колонок итогов в ТЧ. Возможно ли? [раздел Программирование в 1С Предприятие 8.3]
Автор Inkognito — 13.11.17, 15:22 — 4 комментариев
Есть табличная часть, отображена на форме. В ней указано "Отображать подвал" (да).
Реально ли объединить несколько подвалов в один, чтобы там написать свой текст, который бы помещался, скажем, в одном длинном подвале (допустим, на три колонки)?
Обычные формы, Бухгалтерия для Украины.
Просмотров: 143, последний комментарий от Vofka   
Посоветуйте решение для юридической компании [раздел Помогите подобрать конфигурацию]
Автор olatim — 13.11.17, 13:28 — 4 комментариев
Посоветуйте решение для юридической компании. Хотят учет времени по сотрудникам и проектам.
Просмотров: 148, последний комментарий от kihor   
НЕ могу создать внешнюю обработку с запросом из справочника. [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Bassar — 12.11.17, 20:19 — 4 комментариев
НЕ могу создать внешнюю обработку с запросом из справочника. (Просто отобразить). В обычной форме отчёта через компоновку данных могу делать, через форму документа например тоже могу запросом и макетом. А как с внешней формой быть? Нужна фнеш форма с отображением имён Контрагентов.


 ! 

Правила: 4,5
 
Просмотров: 157, последний комментарий от Vofka   
Проблема с вводом по строке. [раздел Программирование в 1С Предприятие 8.3]
Автор Alex78 — 12.11.17, 13:05 — 2 комментариев
Доброго времени суток. В справочнике "Партнеры" на вкладке "Поле ввода" в поле "Ввод по строке" указываю реквизит "НомерКарточки". Однако поиск происходит по наименованию, а не по номеру карточки. Не могу понять, в чем причина. Буду благодарен за информацию. Платформа - 8.3.8.2322, конфигурация - Управление торговлей для Украины 3.1.5.1 (на управляемых формах), немного доработанная.
Просмотров: 108, последний комментарий от Alex78   
Автозаполнение табличного документа [раздел Программирование в 1С Предприятие 8.3]
Автор burza — 10.11.17, 13:00 — 5 комментариев
Есть форма с табличной частью при добавлении новой строки нужно чтобы в поле выбора статуса он заполнялся автоматически(какой укажу) сейчас есть вот это. Понимаю что справочник нужно проводить через сервер но не могу понять как потом вставить переменную сюда.
&НаКлиенте
Процедура ПланПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    Если НоваяСтрока И Не Копирование тогда
        Элемент.ТекущиеДанные.Дата = ТекущаяДата();
        Элемент.ТекущиеДанные.СтатусВыполнения = Справочники.СтатусВыполнения.НайтиПоНаименованию("В работе");
    КонецЕсли;

КонецПроцедуры

Просмотров: 166, последний комментарий от logist   
УТ Запрос при выборе клиента из справочника [раздел Программирование в 1С Предприятие 8.3]
Автор burza — 10.11.17, 11:40 — 2 комментариев
Подскажите как сделать запрос перед выбором справочника. То есть есть справочник партнеров есть документ продажи где ссылка на партнеров идет само собой. Есть третий документ где нужно при выборе партнера чтобы было видны только те которые купили товар.(документ в табличной форме)
Просмотров: 101, последний комментарий от burza   
Убрать пустые строки в ФормеСписка справочника [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор illiona — 09.11.17, 6:28 — 6 комментариев

Есть справочник партии. Как мне из него либо удалить, либо скрыть отбором строки, где остаток = 0 ? Пустые строки ненужны, лучше бы их удалить
Просмотров: 166, последний комментарий от Flexy   
Свертка БД (SQL) - удаление за период! [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор mut_mut — 08.11.17, 21:25 — 1 комментариев
И меня это постигло.

У кого есть обработинка по удалению/чистки объектов? У меня есть вот такая 122546_Ochistka_bazy_sredstvami_SQL.epf из info....ru.... вот только у нее РН и РС удалить можно полностью, а мне нужно "с" "по")))).... Новый вариант этой обработки, как раз позволяет это сделать... только я ее не могу заполучить.

может есть кого-то... ПЛЗ!


 ! 

Правила: 4,5
 
Просмотров: 109, последний комментарий от logist   
RSS Текстовая версия Сейчас: 22.11.17, 4:01
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне