Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Настройка сканера штрихкодов Datalogic Quick Scan QW2100.....Помогите пожалуйста [раздел Работа с торговым оборудованием]
Автор IvantsivAnd — 20.01.17, 0:16 — 0 комментариев
Помогите пожалуйста настроить сканер в 1С.....уже второй день не могу подключить
1с 8.3.9.2033
УТП для Украины 1.2.39.1
сканера штрихкодов Datalogic Quick Scan QW2100
1. Установил драйвер на сканер и перевел его с клавиатуры в СОМ (сейчас СОМ3 в диспетчере устройств - Порты СОМ та LPT)....на клавиатуре сканер в блокнот записивает штрихкод!!
2. Установил 1С:Сканер штрихкода (COM) 8.1.6.1
3. Подключил его в 1с как торговое оборудование там также выбрал СОМ3 (все нашло .... все подключилось без вопросов)
4. Делаю "Тест устройства" в параметрах там выбивает "СОМ3: Ок и Keyboard: Ok".....также сканирую штрих и получаю отчет с своим штрхкодом и сканер выдает одинарной звук!!
5. В модуле обычного приложения в процедуре ПриНачалеРаботыСистемы добавляю подключение компоненти (ScanOPOS.dll)....все ок подключаеться
Но не срабатывает процедура ВнешнееСобытие в модуле форми обработки и когда сканирую при включенной обработке то сканер выдает какой-то тройной звук!

Помогити пожайлуста!!
Спасибо!!
Просмотров: 34, оставить комментарий   
Доступ к базе УТ 3.1 со смартфона [раздел Мобильная платформа 1С]
Автор anna_v — 19.01.17, 21:38 — 3 комментариев
На сервере расположена база УТ 3.1, настроен IIS, база опубликована. Какими средствами лучше воспользоваться для работы с ней торговым представителям для ввода заказов? Возможен ли доступ к веб-странице через смартфон? или есть более удобные варианты?
Просмотров: 49, последний комментарий от Flexy   
1С 8.2 УТ 10.3 Как сделать синхронный вывод двух реквизитов из одного справочника? [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Vzonder — 19.01.17, 14:49 — 1 комментариев

1С 8.2 УТ 10.3
На примере справочника станций метро Москвы.
Имеется справочник Метро.
В нем 2 реквизита: Станция и Ветка.

Если на форму документа (например, Заказ покупателя) выводить поле с одним реквизитом, то проблем не возникает.
А как вывести два реквизита справочника из одной записи.
Т.е. на форму документа выводится два поля, в одном отражается Станция, во втором Ветка (именно та, что была присвоена Станции в справочнике Метро) ?

Просмотров: 59, последний комментарий от Petre   
Как изменить значения реквизита "Код УКТВЭД" в табличной части Товары документа Налоговой Накладной [раздел Программирование в 1С Предприятие 8.3]
Автор Yana.P — 19.01.17, 13:01 — 5 комментариев
Создаю внешнюю обработку, в которой нужно создать автозаполние КодУКТВЭД



    Для каждого Стр из Таблица Цикл
        Если Стр.Пометка Тогда
            НайтиНоменклатуру = Справочники.Номенклатура.НайтиПоНаименованию(Стр.Номенклатура);

        

                КонецЕсли;
    КонецЦикла;


Подскажите пожалуйста, как дальше реализовать это? Чтоб найти этот КодУКТВЭД и соответственно записать в табличную часть Товары в выбранные документы
Просмотров: 92, последний комментарий от Petre   
Платформа 7.7 + Нова пошта. [раздел Программирование в 1С Предприятие 7.7]
Автор XBrut — 19.01.17, 12:50 — 3 комментариев
Товариші. Хто бачив-чув. Бо людям цікаво...
Просмотров: 101, последний комментарий от Flexy   
Работает ли СообщениеПользователю в управляемой форме обычного приложения? [раздел Программирование управляемых форм 1С 8.2]
Автор Yevhenii — 19.01.17, 11:23 — 9 комментариев
1С Предприятие 8.2 обычное приложение.
Конфигурация "Управление торговым предприятием для Украины", редакция 1.2.

Здравствуйте уважаемые.

Пытаюсь прикрутить вывод сообщения к полю ввода реквизита. Работаю в режиме обычного приложения, но форма управляемая.
Сообщение как бы выводит но только в нижней части, т.е. в некрасивой области сообщений. А хотелось бы выводить облачко именно на незаполненом поле.
Пробую вот так:
&НаКлиенте
Процедура ПродажаПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)
    
    Если Элементы.ПолеКурс.ТекстРедактирования="0,00" Тогда
    
        Отказ=Истина;
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = "Сначала введите курс!";
                Сообщение.Поле  = "Курс";
            Сообщение.ПутьКДанным = "Объект";
            Сообщение.Сообщить();
    КонецЕсли;

КонецПроцедуры



и так:
&НаСервере
Процедура Сообщить4НаСервере()
    Сообщение4 = новый СообщениеПользователю;
    Сообщение4.УстановитьДанные(РеквизитФормыВЗначение("Объект"));
    Сообщение4.Текст = "Сначала введите курс!";
    Сообщение4.Поле = "Курс";
    Сообщение4.Сообщить();
КонецПроцедуры


&НаКлиенте
Процедура ПродажаПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)
    
    Если Элементы.ПолеКурс.ТекстРедактирования="0,00" Тогда
    
        Отказ=Истина;
            Сообщить4НаСервере();

    КонецЕсли;
КонецПроцедуры
Просмотров: 116, последний комментарий от Petre   
Взаиморасчеты с Поставщиками в Рознице 1.0 [раздел Система компоновки данных]
Автор Constantus — 18.01.17, 14:44 — 2 комментариев
Приветствую, Форумчане!
Розница 1.0, обычное, 1с8.3

В рознице как известно нет отчета "Взаиморасчеты с Поставщиком" тем более в разрезе Контрагент и Регистратор.
Для документов "ПоступлениеТоваров", "ВозвратТоваров" и РКО создал регистр накопления "ВзаиморасчетыСПоставщиками" (Контрагент, ресурс: Сумма)
Проводки осуществояются корректно.

Создал отчет на СКД на базе виртуальной таблицы: ВзаиморасчетыСПоставщикамиОстаткиИОбороты с Периодичностью по Регистратору.
Вывел все необходимые полями

ВЫБРАТЬ
    ВзаиморасчетыСПоставщикамиОстаткиИОбороты.Контрагент.ТипКонтрагента,
    ВзаиморасчетыСПоставщикамиОстаткиИОбороты.Контрагент,
    ВзаиморасчетыСПоставщикамиОстаткиИОбороты.СуммаНачальныйОстаток КАК НачальныйОстаток,
    ВзаиморасчетыСПоставщикамиОстаткиИОбороты.СуммаКонечныйОстаток КАК КонечныйОстаток,
    ВзаиморасчетыСПоставщикамиОстаткиИОбороты.СуммаПриход КАК Приход,
    ВзаиморасчетыСПоставщикамиОстаткиИОбороты.СуммаРасход КАК Расход,
    ВзаиморасчетыСПоставщикамиОстаткиИОбороты.Регистратор
ИЗ
    РегистрНакопления.ВзаиморасчетыСПоставщиками.ОстаткиИОбороты(, , Регистратор, , ) КАК ВзаиморасчетыСПоставщикамиОстаткиИОбороты


Отчет СКД в Настройках: Группировка по Контрагентам и с подгруппировкой по Регистратору
В результате получаю явно некорректный результат по итогам (сорр, не знаю как разместить таблицу)

Контрагент Начальны__Приход____Расход___Конечный
Основание
Поставщик___331,800__439,800___108,000___663,600
Поступление____2,800____2,800______________5,600
Поступление__245,000__245,000____________490,000
Поступление__192,000__192,000____________384,000
РасходныйКО_-100,000___________100,000__-200,000
Возврат________-8,000_____________8,000___-16,000

Понимаю, что что-то делаю не так с размещением итогов и работой с ресурсами. Помогите разобраться как правильно отработать с ресурсами и итогами в отчете СКД
Просмотров: 100, последний комментарий от Constantus   
Как сохранить в реквизите цвет? [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Vzonder — 18.01.17, 12:06 — 0 комментариев
Хочется сделать справочник, с перечислением Станций и Веток Московского Метрополитена.
Реализовано по аналогии справочника КонтактныеЛицаКонтрагентов

В форме справочника два поля (с выпадающим списком) с реквизитами (Станция и Ветка) и представление в котором эти реквизиты записываются через пробел.

Все замечательно, вот только длиннннновато получается:
Нахимовский проспект Серпуховско-Тимирязевская
)))))

Подскажите, как можно (наиболее просто) реализовать запись Линии (ветки) другим способом?
Например:
Цвет текста ветки (вместо название ветки вносится символ “-” с соответствующим цветом)
Цветом текста в названии станции
Картинка – в поле ветка выбирается маленькая картинка (квадратик нужного цвета, соответствующего ветке), который в свою очередь отражается в представлении через пробел рядом со станцией.
Цвет поля представления.
Иное

Любой способ передачи цвета, который можно записать в реквизит представления, который в свою очередь можно будет использовать для отражения на формах, формах списка и табличных полях.
Просмотров: 88, оставить комментарий   
Как открыть программно открыть форму контрагента? 1C 8.2 УТ 10.3 [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Vzonder — 17.01.17, 18:47 — 1 комментариев
1C 8.2 УТ 10.3


ОткрытьФорму("Справочник.Контрагенты.Форма.ФормаЭлементаТтн");


При выполнении процедуры из Формы Заказа Покупателя – открывается форма нового элемента….(

Научите, пожалуйста, как открыть форму с текущем Контрагентом.
Просмотров: 107, последний комментарий от Flexy   
Как сделать зведену податкову накладну [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Andrey102 — 17.01.17, 13:48 — 1 комментариев
Здравствуйте, подскажите пожалуйста как дописать код чтобы сделать зведену податкову накладну и зведену выдаткову накладну
Просмотров: 92, последний комментарий от Petre   
Как в табличное поле добавить строку из справочника? [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Vzonder — 17.01.17, 4:39 — 2 комментариев

1С 8.2 УТ 10.3

Создал в форме Справочника Контрагента табличное поле, по абсолютной аналогии с ВидыДеятельности, с соответствующем набором реквизитов, Табличной частью и реквизитами.

Поэтому, чтобы не городить огород, на примере ВидыДеятельности и задам вопрос:

На форме создал поле ввода: ПолеОсновнойВидДеятельности, подключил реквизит ОсновнойВидДеятельности, и включил кнопку выбора.

Теперь в ПолеОсновнойВидДеятельности можно выбирать элементы из СправочникСсылка.ВидыДеятельностиКонтрагентов.

При этом в Табличном поле ВидыДеятельности в имеющихся строках выбирается основной вид деятельности (подсвечивая шрифт жирным) в уже добавленных.

Возникла необходимость добавлять элементы (подобно действию кнопки добавить), путем выбора значения в ПолеОсновнойВидДеятельности.
Т.е. при отсутствии элемента, он автоматически добавляется в табличное поле ВидыДеятельности.

Понимаю, что в процедуре Процедура ПолеОсновнойВидДеятельности ПриИзменении(Элемент) необходимо задать запрос, который сравнит содержимое и если в списке строк не найдет элемент, то его добавит.

И тут у меня полный тупняк.
Вот какая…. Получается:


Процедура ПолеОсновнойВидДеятельностиПриИзменении(Элемент)
      
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    КонтрагентыВидыДеятельности.ВидДеятельности
        |ИЗ
        |    Справочник.Контрагенты.ВидыДеятельности КАК КонтрагентыВидыДеятельности
        |ГДЕ
        |    КонтрагентыВидыДеятельности.ВидДеятельности = &ВидДеятельности";
    
    Запрос.УстановитьПараметр("ВидДеятельности",  ОсновнойВидДеятельности);
    
    РезультатЗапроса = Запрос.Выполнить();
        
            Если РезультатЗапроса.Пустой() Тогда
            Предупреждение(" не найден!!!!");
      
        Иначе  Предупреждение("ОК!");
        
        ЭлементыФормы.ВидыДеятельности.ДобавитьСтроку(); // Сломал голову, как добавить в строчку элемент
                   
        КонецЕсли;
                    КонецПроцедуры


Пожалуйста, подскажите как правильно написать запрос, чтобы при отсутствии указанного в ПолеОсновнойВидДеятельности автоматическое добавление элемента?

И объясните, пожалуйста, как правильно написать, чтобы добавлялась не только новая строка, но и автоматически вставлялся элемент из справочника ВидыДеятельностиКонтрагентов?

Просмотров: 397, последний комментарий от Flexy   
Синхронизация Бинотела и 1С [раздел Программирование в 1С Предприятие 8.3]
Автор dimplast — 16.01.17, 14:48 — 1 комментариев
Хотим синхронизировать Бинотел и 1С предприятие 8.3. Как происходит сам процесс? У нас несколько телефонов что делать и как? Обьясните плиз. Программа:

1С:Предприятие 8.3 (8.3.5.1383)

Управление небольшой фирмой для Украины, редакция 1.5
Локализация для Украины: ООО "ХВОЯ Интегра" (1.5.3.11) (http://v8.1c.ru/regional/RegionalSolutions_UA_UNF.htm)
Copyright © ООО "1C", 2015. Все права защищены
(http://www.1c.ru)
Просмотров: 128, последний комментарий от sava1   
Обновление FormEx. Версия 2.5.0.115 [раздел Программирование в 1С Предприятие 7.7]
Автор sava1 — 13.01.17, 13:27 — 0 комментариев
От Альфа:

Постарался привести в порядок als-файл.

Объект "Сервис". Новые методы:
КопироватьОбъект() - открывает форму нового документа, создаваемого путем копирования указанного;
НарисоватьШтрихкод() - рисует штрих-код заданного типа на объекте "Картинка" с помощью библиотеки zint;
РежимКонфигуратораУСообщений() - переключение вывода в сообщений в режим, когда по двойному клику на любом сообщении осуществляется переход в конфигуратор, как при ошибке исполнения;
ПолучитьСтекВызова() - возвращается таблица значений с текущим стеком вызова.

Объект "АтрибутФормы". Новое свойство:
СтильРамкиКартинки - чтение\запись стиля картинки на форме.

Новый объект "ОкноСообщений" для создания собственных окон сообщений и управления ими.

Скачать можно, как обычно, по адресу: [необходимо зарегистрироваться для просмотра ссылки]
Просмотров: 151, оставить комментарий   
Звуковое и визуальное оповещение группы пользователей при изменении реквизита. [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Vzonder — 12.01.17, 22:00 — 3 комментариев
1С 8.2 УТ 10.3

Возможно создать следующее?

Если значение реквизита в документе (ФормаСписка и (или) Документа) становится равным “Упаковка”, то у сотрудника из группы Упаковка (права, Роль – все создам…) на компьютере срабатывал звуковой сигнал (желательно по противней))) и на экране выскакивала Форма – нарисую самую яркую))) или заставка оповещения.
Очень часто я слышу от упаковщиков, что не усмотрели…
Отсюда и вопрос.
Извините за эмоциональность – наболело))))

Это возможно?
Просмотров: 148, последний комментарий от Vlad 1C   
Как распечатать содержимое ФормыСписка с отбором? [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Vzonder — 12.01.17, 21:38 — 5 комментариев
1С 8.2 УП 10.3

Создал форму списка документа с отбором:

В Процедуре ПриОткрытии()
ДокументСписок.Отбор.Сбросить();
ДокументСписок.Отбор.ЭтапыПродажи.ВидСравнения=ВидСравнения.Равно;
ДокументСписок.Отбор.ЭтапыПродажи.Значение="Отгружать ТК";
ДокументСписок.Отбор.ЭтапыПродажи.Установить();


Открывается форма со списком документов, в котором перечислены документы у которых в реквизите ЭтапыПродажи значение Равно Отгружать ТК.

Если создать кнопку с присвоенной процедурой из конструктора печати, то на печать выводится весь список без отбора….

Процедура ПечатьСписка(Элемент)

ТабДок = Новый ТабличныйДокумент;
Макет = Документы.ЗаказПокупателя.ПолучитьМакет("ПечатьСписка");
        
        
Выборка = Документы.ЗаказПокупателя.Выбрать();
Реквизиты = Макет.ПолучитьОбласть("Реквизиты");
Пока Выборка.Следующий() Цикл
Реквизиты.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Реквизиты);
КонецЦикла;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.Показать();
    
КонецПроцедуры

На всякий случай уточню, печать не документов из списка, а именно список (перечень) документов.

Конечно можно использовать штатную кнопку Вывести список выбрать реквизиты и распечатать.
Только при этом нет возможности влиять на макет…

Вопрос:
Как в процедуру ПечатьСписка внести отбор документов по содержанию реквизита?
Просмотров: 157, последний комментарий от Vofka   
Как размещать Файлы не в базе, а в отдельных, в том числе сетевых папках? [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Vzonder — 12.01.17, 20:43 — 5 комментариев
1С 8.2 УТ 10.3

Хотелось бы в документах или справочниках размещать файлы, которые располагаются в папке на компьютере сервера 1С или в сетевой папке.
Например:
Создаю справочник Транспортных компаний, услугами которых пользуется наша компания.
В справочник будут заноситься адресные данные, график работа и прочая информация, в том числе схемы проезда.
Предполагается, что схемы будут в файлах картинок jpg, png и т.д.
При необходимости, эти данные будут распечатываться.
Вопрос:

Как разместить в форме элемента картинку размещенную в папке на сервере 1С или в сетевой папке?
Просмотров: 156, последний комментарий от Flexy   
функция ПодключитьОбработчикОжидания обновляет объект [раздел Программирование в 1С Предприятие 8.3]
Автор Brutok — 12.01.17, 20:05 — 3 комментариев
Версия 8.3.7.1917
база самописная

Ниже пример кода секундомера.

При открытии вызываю функцию
ПодключитьОбработчикОжидания("Отсчет",1);


а вот и сама процедура "отсчет".
&НаКлиенте
Процедура Отсчет()
    ВремяОтсчета='20170112100000';
    пустаядата='00010101010101';
    время=формат(пустаядата+(ТекущаяДата()-ВремяОтсчета), "ДФ=ЧЧ:мм:сс");
    Элементы.Секундомер.Заголовок=время;
КонецПроцедуры

Элементы.Секундомер это поле надписи

Проблема в том что постоянно считывается объект с сервера и обновляется вся форма и невозможно внести изменения, они исчезают
Просмотров: 133, последний комментарий от Brutok   
Как посмотреть, содержание заполнения базы? [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Vzonder — 12.01.17, 20:03 — 3 комментариев
1C 8.2 УТ 10.3

За два года работы база раздулась до 10 Гб.
Около 15000 заказов покупателей и несколько тысяч номенклатуры.
Ну, и соответственно, реализация товаров и услуг с заказами поставщиков.
Картинок и прочих доп файлов в базу не грузили…
Сжатие SQL базы не помогает.


Вопрос:
Как посмотреть содержимое по темам, чтобы понять как и что чистить и наладить?
Просмотров: 130, последний комментарий от Trintintin   
Веб-интерфейс или мобильное приложение? [раздел Тематическое общение]
Автор andreykyiv@bigmir.net — 12.01.17, 3:22 — 12 комментариев
Есть самописная база по мотивам ранней УТ2, обычные формы.
База сейчас работает под платформой 8.2, но готов перевести ее на 8.3 ради данной задачи.
На копии такой переход уже обкатал.
База распределенная. В офисе стоит центральная база, а в магазинах - дочерняя.
Обмен выполняется через план обмена с помощью фтп.
Товар - обувь, остатки ведутся в разрезе размеров, а также продается галантерея и сопутка.

В период распродаж одного рабочего места в магазине не хватает. Есть желание консультантам организовать рабочее место на планшете под Андроид.
В этом рабочем месте консультант должен иметь возможность определить наличие товара на складе.
В перспективе - делать продажу, точнее, заполнить корзину, как на сайте. И на основании уже этой корзины на кассе будет произведена продажа.
Не могу принять решение - это должно быть мобильное приложение, которое каким-то образом будет обмениваться данными с базой магазина,
или предлагают создать доработку под веб-интерфес. Вайфай в магазине имеется.

Прошу консультации знающих людей. Какие плюсы/минусы у каждого из вариантов.
И готов оформить заказ на разработку. Нанять разработчика.

П.С. админов прошу помочь разместить пост в нужном, если считаете, что я не прав, размещая тему здесь
Просмотров: 264, последний комментарий от andreykyiv@bigmir.net   
как на 1с 7.7 добавить базу 1с 8.3 чтобы работала ? [раздел Программирование в 1С Предприятие 7.7]
Автор 000202 — 11.01.17, 20:20 — 9 комментариев
как на 1с 7.7 добавить базу 1с 8.3 чтобы работала ???
Просмотров: 564, последний комментарий от mister-x   
RSS Текстовая версия Сейчас: 20.01.17, 7:44
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне