Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Добавление субконто - чем чревато? [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор mut_mut — 26.07.17, 10:25 — 2 комментариев
1С:Підприємство 8.2 (8.2.19.130)

Бухгалтерия для Украины, редакция 1.2.
Разработка конфигурации: "ABBYY Ukraine", 2005-2017 (1.2.41.2)



Хотят видеть движения в разрезе складов.

Если добавлю склад 3-м субконто - чем чревато?... могут быть какие-то траблы.

Спрашиваю бо не знаю!!!!)

Дякую.
Просмотров: 47, последний комментарий от mut_mut   
Работа с списком выбора [раздел Программирование в 1С Предприятие 8.3]
Автор rodrigezrobert — 25.07.17, 14:37 — 4 комментариев
1С 8.3 (8.3.6.2237) управляемое приложение, интерфейс "Такси".
Здравствуйте!
При открытии формы создаю список
&НаКлиенте
    Процедура ПриОткрытии(Отказ)        
        М = ПолучитьСписокСправочников ();        
        Элементы.Справочник_.СписокВыбора.ЗагрузитьЗначения(М);        
    КонецПроцедуры

Значения появились в поле ввода при нажатии кнопки выпадающего списка, но выбрать одно я не могу.
Выбранное значение не фиксируется в поле ввода.
Подскажите в чем причина? Спасибо.
Просмотров: 70, последний комментарий от rodrigezrobert   
Виснет 1с при добавлении номенклатуры в документ "Чек" [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор mut_mut — 25.07.17, 12:12 — 4 комментариев
1С:Підприємство 8.2 (8.2.19.130)

"Управление торговлей для Украины", редакция 2.3.
Разработка конфигурации: "ABBYY Ukraine", 2003-2015
(2.3.24.3)

Центральная БД SQL, а переферийки файловые.

После исправления становится все нормально но после очередного обмена все возвращается взад.

Виснет на переферийке на 40 сек. Документ чек... без разницы в сам док или через РМК!

Как решить такой прикол и как понять, на чем глючит... документ или запись в регистре?

Спасибо.
Просмотров: 70, последний комментарий от mut_mut   
Макет печатной формы документа [раздел Программирование в 1С Предприятие 8.3]
Автор Pavlik1c — 24.07.17, 15:55 — 4 комментариев
Добрый день!

1С:Предприятие 8.3 (8.3.8.1675)

"Управление торговым предприятием для Украины", редакция 1.2.
Разработка конфигурации: "ABBYY Ukraine", 2007-2017 (1.2.42.2) (http://1c.ua/v8/RegionalSolutions_UA_UTP.php)
Copyright © ДП "Еврософтпром", 2007-2017. Все права защищены
(http://www.1c.ua)


Делаю внешнюю печатную форму документа "Перемещение ОС". С выводом одинарных реквизитов проблем нет, но столкнулся с проблемой вывода табличной части. Помогите сделать вывод таблицы с колонками :1) номер строки, 2) инвентарный номер, 3) основное средство.
Просмотров: 103, последний комментарий от Bernet   
Просроченные долги по расчетным документам: отбор по договорам [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 24.07.17, 11:20 — 3 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Нашел и скачал вот такой интересный отчет: [необходимо зарегистрироваться для просмотра ссылки] (бесплатно)
Просроченные долги по срокам и документам для 1С УТ10

Отчет интересный получился и вроде правильный.

Код
    ТекстЗапроса =
    "ВЫБРАТЬ
    |    Календарь.ДатаКалендаря КАК ДатаКалендаря,
    |    КОЛИЧЕСТВО(*) КАК Ранг
    |ПОМЕСТИТЬ Календарь
    |ИЗ
    |    РегистрСведений.РегламентированныйПроизводственныйКалендарь КАК Календарь
    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.РегламентированныйПроизводственныйКалендарь КАК КалендарьКопия
    |        ПО Календарь.ДатаКалендаря >= КалендарьКопия.ДатаКалендаря
    |ГДЕ
    |    Календарь.ДатаКалендаря >= &МинимальнаяДата
    |    И (Календарь.ВидДня = ЗНАЧЕНИЕ(Перечисление.ВидыДнейПроизводственногоКалендаря.Рабочий)
    |            ИЛИ Календарь.ВидДня = ЗНАЧЕНИЕ(Перечисление.ВидыДнейПроизводственногоКалендаря.Предпраздничный))
    |    И КалендарьКопия.ДатаКалендаря >= &МинимальнаяДата
    |    И (КалендарьКопия.ВидДня = ЗНАЧЕНИЕ(Перечисление.ВидыДнейПроизводственногоКалендаря.Рабочий)
    |            ИЛИ КалендарьКопия.ВидДня = ЗНАЧЕНИЕ(Перечисление.ВидыДнейПроизводственногоКалендаря.Предпраздничный))
    |
    |СГРУППИРОВАТЬ ПО
    |    Календарь.ДатаКалендаря
    |
    |ИНДЕКСИРОВАТЬ ПО
    |    ДатаКалендаря
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ РАЗРЕШЕННЫЕ
    |    КалендарьРанг.ДокументРасчетовСКонтрагентом КАК ДокументРасчетовСКонтрагентом,
    |    Календарь.ДатаКалендаря КАК ДатаКалендаря
    |ПОМЕСТИТЬ РабочаяДатаВзаиморасчетыОстаткиИОбороты
    |ИЗ
    |    Календарь КАК Календарь
    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
    |            ВзаиморасчетыОстаткиИОбороты.ДокументРасчетовСКонтрагентом КАК ДокументРасчетовСКонтрагентом,
    |            МИНИМУМ(Календарь.Ранг) + МИНИМУМ(ВзаиморасчетыОстаткиИОбороты.ДопустимоеЧислоДнейЗадолженности) КАК РангСоединения,
    |            МИНИМУМ(Календарь.Ранг) КАК Ранг
    |        ИЗ
    |            (ВЫБРАТЬ
    |                ВзаиморасчетыОстаткиИОбороты.ДокументРасчетовСКонтрагентом КАК ДокументРасчетовСКонтрагентом,
    |                МИНИМУМ(ВзаиморасчетыОстаткиИОбороты.ДоговорКонтрагента.ДопустимоеЧислоДнейЗадолженности) КАК ДопустимоеЧислоДнейЗадолженности,
    |                НАЧАЛОПЕРИОДА(МИНИМУМ(ВзаиморасчетыОстаткиИОбороты.ДокументРасчетовСКонтрагентом.Дата), ДЕНЬ) КАК Дата
    |            ИЗ
    |                РегистрНакопления.ВзаиморасчетыСКонтрагентамиПоДокументамРасчетов.ОстаткиИОбороты(
    |                        &ДатаНач,
    |                        &ДатаКон,
    |                        Регистратор {(&Периодичность)},
    |                        ,
    |                        ДоговорКонтрагента.ВидДоговора В (&МассивВидовДоговоров)
    |                            И ДоговорКонтрагента.ДопустимоеЧислоДнейЗадолженности > 0
    |                            И ДоговорКонтрагента.ВестиПоДокументамРасчетовСКонтрагентом = ИСТИНА) КАК ВзаиморасчетыОстаткиИОбороты
    |            ГДЕ
    |                ВзаиморасчетыОстаткиИОбороты.УпрУчет
    |            
    |            СГРУППИРОВАТЬ ПО
    |                ВзаиморасчетыОстаткиИОбороты.ДокументРасчетовСКонтрагентом) КАК ВзаиморасчетыОстаткиИОбороты
    |                ВНУТРЕННЕЕ СОЕДИНЕНИЕ Календарь КАК Календарь
    |                ПО ВзаиморасчетыОстаткиИОбороты.Дата <= Календарь.ДатаКалендаря
    |        
    |        СГРУППИРОВАТЬ ПО
    |            ВзаиморасчетыОстаткиИОбороты.ДокументРасчетовСКонтрагентом) КАК КалендарьРанг
    |        ПО (КалендарьРанг.РангСоединения = Календарь.Ранг)
    |
    |ИНДЕКСИРОВАТЬ ПО
    |    ДокументРасчетовСКонтрагентом
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ
    |    ИтогиВзаиморасчетов.Организация КАК Организация,
    |    ИтогиВзаиморасчетов.Контрагент КАК Контрагент,
    |    ИтогиВзаиморасчетов.ДоговорКонтрагента КАК ДоговорКонтрагента,
    |    ИтогиВзаиморасчетов.ВалютаВзаиморасчетов КАК ВалютаВзаиморасчетов,
    |    ИтогиВзаиморасчетов.ДокументРасчетовСКонтрагентом КАК ДокументРасчетовСКонтрагентом,
    |    ИтогиВзаиморасчетов.ДокументРасчетовСКонтрагентом.Дата КАК ДатаДокумента,
    |    ИтогиВзаиморасчетов.КоличествоДнейОтсрочки КАК КоличествоДнейОтсрочки,
    |    ВЫБОР
    |        КОГДА РАЗНОСТЬДАТ(&ПолучитьНаДату, ИтогиВзаиморасчетов.Срок, ДЕНЬ) > 0
    |            ТОГДА 0
    |        ИНАЧЕ РАЗНОСТЬДАТ(&ПолучитьНаДату, ИтогиВзаиморасчетов.Срок, ДЕНЬ)
    |    КОНЕЦ КАК ПросроченоДней,
    |    ИтогиВзаиморасчетов.СуммаОбщегоДолга КАК СуммаОбщегоДолга,
    |    ИтогиВзаиморасчетов.Срок КАК Срок,
    |    ВЫБОР
    |        КОГДА ИтогиВзаиморасчетов.СуммаОбщегоДолга < 0
    |            ТОГДА ИтогиВзаиморасчетов.СуммаОбщегоДолга
    |        ИНАЧЕ 0
    |    КОНЕЦ КАК СуммаАвансов,
    |    ВЫБОР
    |        КОГДА ИтогиВзаиморасчетов.СуммаОбщегоДолга > 0
    |                И ИтогиВзаиморасчетов.Срок <= &ПолучитьНаДату
    |            ТОГДА ИтогиВзаиморасчетов.СуммаОбщегоДолга
    |        ИНАЧЕ 0
    |    КОНЕЦ КАК СуммаПросроченныйДолг,
    |    ВЫБОР
    |        КОГДА ИтогиВзаиморасчетов.СуммаОбщегоДолга > 0
    |                И НЕ ИтогиВзаиморасчетов.Срок <= &ПолучитьНаДату
    |            ТОГДА ИтогиВзаиморасчетов.СуммаОбщегоДолга
    |        ИНАЧЕ 0
    |    КОНЕЦ КАК СуммаНепросроченныйДолг,
    |    ИтогиВзаиморасчетов.ДокументРасчетовСКонтрагентом.СуммаДокумента КАК СуммаДокумента
    |{ВЫБРАТЬ
    |    ВалютаВзаиморасчетов.*,
    |    Контрагент.*,
    |    Организация.*,
    |    ДоговорКонтрагента.*,
    |    ДокументРасчетовСКонтрагентом.*,
    |    ДатаДокумента,
    |    СуммаДокумента,
    |    КоличествоДнейОтсрочки,
    |    Срок,
    |    ПросроченоДней,
    |    СуммаОбщегоДолга,
    |    СуммаАвансов,
    |    СуммаПросроченныйДолг,
    |    СуммаНепросроченныйДолг}
    |ИЗ
    |    (ВЫБРАТЬ
    |        ОстаткиПоПериодам.Организация КАК Организация,
    |        ОстаткиПоПериодам.Контрагент КАК Контрагент,
    |        ОстаткиПоПериодам.ДоговорКонтрагента КАК ДоговорКонтрагента,
    |        ОстаткиПоПериодам.ДоговорКонтрагента.ВалютаВзаиморасчетов КАК ВалютаВзаиморасчетов,
    |        ОстаткиПоПериодам.ДокументРасчетовСКонтрагентом КАК ДокументРасчетовСКонтрагентом,
    |        ОстаткиПоПериодам.ДоговорКонтрагента.ДопустимоеЧислоДнейЗадолженности КАК КоличествоДнейОтсрочки,
    |        ОстаткиПоПериодам.СуммаВзаиморасчетовОстаток КАК СуммаОбщегоДолга,
    |        ВЫБОР
    |            КОГДА &СпособКонтроляДнейЗадолженности = ЗНАЧЕНИЕ(Перечисление.СпособыКонтроляДнейЗадолженности.ПоРабочимДням)
    |                ТОГДА ЕСТЬNULL(РабочаяДатаВзаиморасчетыОстаткиИОбороты.ДатаКалендаря, ОстаткиПоПериодам.ДокументРасчетовСКонтрагентом.Дата)
    |            ИНАЧЕ ДОБАВИТЬКДАТЕ(ОстаткиПоПериодам.ДокументРасчетовСКонтрагентом.Дата, ДЕНЬ, ОстаткиПоПериодам.ДоговорКонтрагента.ДопустимоеЧислоДнейЗадолженности)
    |        КОНЕЦ КАК Срок
    |    ИЗ
    |        РегистрНакопления.ВзаиморасчетыСКонтрагентамиПоДокументамРасчетов.Остатки(&ПолучитьНаДату, ДоговорКонтрагента.ВидДоговора В (&МассивВидовДоговоров) {(Организация).*, (Контрагент).*, (ДоговорКонтрагента).*}) КАК ОстаткиПоПериодам
    |            ЛЕВОЕ СОЕДИНЕНИЕ РабочаяДатаВзаиморасчетыОстаткиИОбороты КАК РабочаяДатаВзаиморасчетыОстаткиИОбороты
    |            ПО (РабочаяДатаВзаиморасчетыОстаткиИОбороты.ДокументРасчетовСКонтрагентом = ОстаткиПоПериодам.ДокументРасчетовСКонтрагентом)) КАК ИтогиВзаиморасчетов
    |{ГДЕ
    |    ИтогиВзаиморасчетов.Контрагент.*,
    |    ИтогиВзаиморасчетов.Организация.*,
    |    (РАЗНОСТЬДАТ(&ПолучитьНаДату, ИтогиВзаиморасчетов.Срок, ДЕНЬ)) КАК ПросроченоДней,
    |    ИтогиВзаиморасчетов.ДокументРасчетовСКонтрагентом.Агент.* КАК Агент}
    |{УПОРЯДОЧИТЬ ПО
    |    Контрагент.*,
    |    ДокументРасчетовСКонтрагентом.*,
    |    ПросроченоДней}
    |ИТОГИ
    |    МАКСИМУМ(ДатаДокумента),
    |    МАКСИМУМ(КоличествоДнейОтсрочки),
    |    МИНИМУМ(ПросроченоДней),
    |    СУММА(СуммаОбщегоДолга),
    |    МИНИМУМ(Срок),
    |    СУММА(СуммаАвансов),
    |    СУММА(СуммаПросроченныйДолг),
    |    СУММА(СуммаНепросроченныйДолг),
    |    СУММА(СуммаДокумента)
    |ПО
    |    ОБЩИЕ
    |{ИТОГИ ПО
    |    ВалютаВзаиморасчетов.*,
    |    Контрагент.*,
    |    Организация.*,
    |    ДоговорКонтрагента.*,
    |    ДокументРасчетовСКонтрагентом.*}";
    
    Если УниверсальныйОтчет.ИспользоватьСвойстваИКатегории Тогда        
        УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ОстаткиПоПериодам.Контрагент", "Контрагент", "Контрагент", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Контрагенты);
        УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ОстаткиПоПериодам.Организация", "Организация", "Организация", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Организации);
        
        УниверсальныйОтчет.ДобавитьВТекстЗапросаСвойстваИКатегории(ТекстЗапроса);        
    КонецЕсли;
    
    УниверсальныйОтчет.ПостроительОтчета.Текст = ТекстЗапроса;
    
    ПараметрыПостроителя = УниверсальныйОтчет.ПостроительОтчета.Параметры;



Воот... Теперь встал вопрос. Как можно провести отбор по Договорам контрагентов. Дело в том, что мы для удобства стандартизировали названия договоров. У всех Контрагентов имеются договора "Основной", "Перечисление", "Кредит", "Аванс"...

Как можно в этом отчете (обработку могу выслать, или скачайте с указанного сайта) провести отбор по "Наименованию" договоров?

Я вставил туда отбор по Договору, но он при начале отбора требует выбрать конкретного Контрагента, а уж потом Договор, в результате получается отбор по Договору конкретного Контрагента, а нужно отобрать только по Наименованию (возможно что-то типа содержит, но с возможностью выбора текста Наименования), чтобы , например, при выборе "Кредит" вышли все Контрагенты с этим договором.
Просмотров: 161, последний комментарий от pablo   
Как получить выбор чисел в 1С 8.2 [раздел Программирование управляемых форм 1С 8.2]
Автор Gigi — 23.07.17, 14:04 — 2 комментариев
Привет всем!
Опять столкнулся с проблемой.
Есть реквизит ну на пример; "ЭлектросетьСнабжения"
Это реквизит ссылка.
Мне нужно, что бы в этом реквизите ссылки выходил список чисел. Просто чисел.
Всего пять цифр: 220;110;10;6;0,4.
НИКАК НЕ ПОЛУЧАЕТСЯ ЭТО СДЕЛАТЬ! Опять проблема.
Если создать справочник с именем "ЭлектросетьСнабжения", то в таком случае мне нужно, что бы тип значения реквизита "Наименование" было числом.
А это ЦЕЛАЯ ПРОБЛЕМА И НЕВОЗМОЖНАЯ задача .И наверно более сложная чем ракета на орбиту.
Если создать элемент перечисления с тем же именем:"ЭлектросетьСнабжения" и эти пять несчастных цифр вписать в значения перечисления, то там тоже числовые значения писать нельзя!
А КАК БЫТЬ ТОГДА? smile.gifsmile.gif
И куда впихнуть эти пять несчастных цифр? smile.gifsmile.gif
Буду признателен если кто подскажет как решить проблему!


 ! 

Правила: 3
 
Просмотров: 138, последний комментарий от logist   
Функция СУММАЕСЛИ в 1С 8.2 [раздел Программирование управляемых форм 1С 8.2]
Автор Gigi — 21.07.17, 16:53 — 0 комментариев
Привет всем!
Написал функцию в 1С для гибкого учета данных.
Эту функцию заимствовал из эксель. Потому, что она очень простая и удобная.
Поэтому решил подобное написать и в 1С. для общего модуле.
Вроде все получилось, только одна проблема.... хочу ее сделать симпатичнее чем так грубо и коряво как и получилось. smile.gifsmile.gif
Ибо вообще на этом форуме примечали, что код написанный мной грубоват. И думаю на самом деле. smile.gifsmile.gif
Поэтому прошу помощи. Помочь в доработке.
Что нужно?
Функция имеет три базовых параметров: Столбец суммирования, искомое значение для поиска и и столбец поиска.
Все это решил адаптировать для 1С. Т.е. уже в 1С реквизит суммирования и текст(Объект) поиска и реквизит поиска.
Просто последние два аргумента нужно в не ограниченном количестве.
А я это не знаю как сделать. Потому, что с массивами слабо дружу.
Поэтому данная функция ограничивается только тремя аргументами объекта поиска и реквизита поиска.
А нужно, что бы можно было любое количество указывать, как в Экселе.
Вот сама функция нуждающаяся в доработке:
//Общий модуль с именем на пример: "Fx_Арифм"
Функция СУММАЕСЛИ_Простой(Конфигурат,КонфигуратЭлемент, РеквизитСУММЫ, значение1, Рекывизит1, значение2, Рекывизит2, значение3, Рекывизит3) Экспорт
//=================================================================
Попытка
Запрос = Новый Запрос();
Запрос.Текст = "ВЫБРАТЬ
|"+КонфигуратЭлемент+".Ссылка
|ИЗ
|"+Конфигурат+"."+КонфигуратЭлемент+" КАК "+КонфигуратЭлемент+";";
Исключение    
Возврат "Не корректное указание объекта конфирурации!";    
КонецПопытки;    
//=================================================================    
Выборка = Запрос.Выполнить().Выбрать();    
//=================================================================
знСУММАЕСЛИ=0;
Пока Выборка.Следующий() Цикл
//----------------------------------------------    
знРеквизитаСУММЫ=Выборка.Ссылка[РеквизитСУММЫ];
знРеквизита1=""+Выборка.Ссылка[Рекывизит1];
//----------------------------------------------
Если значение2=Неопределено и Рекывизит2=Неопределено тогда
УсловиеСУММЫ=(знРеквизита1=значение1)
Иначе
знРеквизита2=""+Выборка.Ссылка[Рекывизит2];
УсловиеСУММЫ=(знРеквизита1=значение1 и знРеквизита2=значение2);
КонецЕсли;
Если значение3=Неопределено и Рекывизит3=Неопределено тогда
УсловиеСУММЫ=(знРеквизита1=значение1 и знРеквизита2=значение2)
Иначе
знРеквизита3=""+Выборка.Ссылка[Рекывизит3];
УсловиеСУММЫ=(знРеквизита1=значение1 и знРеквизита2=значение2 и знРеквизита3=значение3);
КонецЕсли;
//----------------------------------------------
Если УсловиеСУММЫ тогда
знСУММАЕСЛИ=знСУММАЕСЛИ+(знРеквизитаСУММЫ*1);
КонецЕсли;
//----------------------------------------------
КонецЦикла;     
//=================================================================    
Возврат знСУММАЕСЛИ;    
КонецФункции

//А это вызов функции с клиента:

&НаКлиенте
Процедура Кнопка_СуммаПоСчетам(Команда)
НачисленоРуб_Итого=Fx_Арифм.СУММАЕСЛИ_Простой("Документ","Счета", "СуммаНачисленоРуб", Объект.Ссылка, "ОбъектСчета", ,, ,);
Предупреждение(НачисленоРуб_Итого);
КонецПроцедуры


Уважаемые СПЕЦИАЛИСТЫ!!!! ТУТ УЖ ТОЧНО НУЖНА ВАША ПОМОЧЬ! smile.gifsmile.gif
Буду признателен!
Просмотров: 133, оставить комментарий   
Задать два формата в шаблоне макета [раздел Программирование управляемых форм 1С 8.2]
Автор Gigi — 21.07.17, 15:20 — 8 комментариев
Всем привет!
Никто не подскажет как решить следующую проблему.
Допустим одна ячейка макета с параметром заполнения шаблон... ну допустим вот эта:
<Счет № [НомерСчета] от [Дата]>

или на пример не шаблон, а просто ячейка с заполнением параметр:
<Дата>

Во втором случае формат даты легко указать по своему усмотрению.
в свойствах выбрать "Формат" и выбрать любой нужный формат.
Но это при заполнении Параметр.
А как поставить нужный формат при заполнении шаблон?
Просто в экселе это не проблема сделать.
Хотелось бы так и в Макете формы.
Т.е. как установить нужный формат в шаблоне. В данном случае для параметра "Дата"
Буду признателен!
Просмотров: 184, последний комментарий от pablo   
Выборка данных [раздел Программирование в 1С Предприятие 8.3]
Автор Direx53 — 20.07.17, 10:41 — 2 комментариев
Добрый день,уважаемые форумчане. Необходимо сделать отбор по колонке "тип"((см. скрин)Динамический Список).Данный отбор например, сделать из поля(например,ТипТест(см. скрин)).Учитывая, что колонка "тип" создается программно(т.е. при помощи запроса(см. скрин.)), при этом "РеестрДокументов.Ссылка" состоит из сылок на документы(см.скрин).


Просмотров: 126, последний комментарий от Direx53   
Анализ использования бумаги для печати первичных документов [раздел Программирование в 1С Предприятие 8.3]
Автор Murano — 20.07.17, 9:03 — 3 комментариев
Доброго времени суток. Я первый раз на форуме и прошу не судить строго. В 1С всего неделю, но хочу побыстрее и главное - качественно разобраться во всём этом. Есть у меня задание: "Отчет должен базироваться на данных документов системы 1С по количеству экземпляров для печати:
- Заказ покупателя - 1 экземпляр;
- Реализация товаров и услуг - 2 экземпляра;
- Перемещение товаров - 2 экземпляра;
- приходный ордер на товары - 1 экземпляр;
- Расходные ордер на товары - 1 экземпляр. "
Я не умею создавать отчеты. Можете мне помочь? Или посоветовать какой-то видео-курс по созданию именно отчетов. Ибо я ничего похожего не нашел. Заранее спасибо!


 ! 

Правила: 4,5
 
Просмотров: 164, последний комментарий от Vofka   
Прочитать данные Хранилища из регистра "СохраненныеНастройки" [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 20.07.17, 6:48 — 12 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

В Моби-С в настройках Агента используется регистр "СохраненныеНастройки", в частности хранятся данные по Контрагентам.

Пользователь - Агент. Наименование настройки : Отбор.Контрагенты, где данные хранятся в ХранилищеЗначений (список Контрагентов)

При открытии формы настроек Агента, вкладка Контрагенты заполняется кодом:

    ТаблСОтбором = ПрочитатьОтбор(Агент,"Контрагенты");
    ЗаполнитьОтборПостроителя(ТаблСОтбором,ПостроительОтчетаКонтрагенты,БланкПостроителяОтчетаКонтрагенты);


Т.е. зная Пользователя (владельца), волшебным образом счтываются данные по Контрагентам и заполняются данные.

У меня стоит задача обратная.

Имеется Контрагент, который хранится в ХранилищеЗначений регистра СохраненныеНастройки. Зная этого Контрагента мне нужно получить Пользователя из этого регистра.

Имеется документ ПКО, в нем есть реквизит "Агент". В документе прописан "Контрагент", зная его нужно заполнить реквизит "Агент" полем выбора, т.к. Контрагенту могут соответствовать несколько Пользователей (владельцев, Агентов) в регистре Сохраненные настройки.

Как можно обратится к ХранилищуЗначений, получить от туда Контрагента и сопоставить его с данными СохраненнойНастройки, как Пользователя (Владельца) и вставить значение Агента в реквизит документа ПКО?


Просмотров: 227, последний комментарий от Bernet   
Как настроить создание пользователя в режиме загрузки в 1С 8.2 [раздел Программирование управляемых форм 1С 8.2]
Автор Gigi — 18.07.17, 19:55 — 6 комментариев
Всем привет!
Уважаемые форумчане. Не подскажите как настроить создание пользователя в режиме пользователя.
Что бы создать нового пользователя смог сам пользователь. Без необходимости влезать в конфигуратор, где он не ничего не смыслит.
Возможно ли это вообще?
Если да то как.
Поподробнее пожалуйста.
Буду признателен!

Gigi @ Сегодня, 20:25 * ,
Да .... еще забыл добавить.
Ролей всего два: "Администратор" и "Обычныйпользователь".
Нужно что бы пользователь сам мог создать нового пользователя под роль: "Обычныйпользователь"
Просмотров: 174, последний комментарий от Gigi   
Работа с Сом объектом [раздел Программирование управляемых форм 1С 8.2]
Автор Filosof — 18.07.17, 10:06 — 9 комментариев
К машине подключены весы через Ком порт. В файловом варианте использую КомОбъект внешней компоненты Mscomm32 данные прекрасно считываются с весопроцессора. Но в клиент серверном варианте проблема. Создана на форме клиентская процедура с таким кодом:
&НаКлиенте
Процедура Брутто(Команда)
Попытка
        Весы = Новый COMОбъект("MSCOMMLib.MSComm");
    Исключение
        Сообщить("Ошибка создания объекта компоненты MSCommLib (Mscomm32.ocx)", СтатусСообщения.Внимание);
        Сообщить(ОписаниеОшибки(), СтатусСообщения.Внимание);
        //Возврат;
    КонецПопытки;
    
    Весы.CommPort = 7;
    Весы.Settings = "9600,N,8,1";
    Весы.InputLen = 0;
    Попытка
        Весы.PortOpen = 1;
    Исключение
        Сообщить("Порт занят другим устройством, отключите его и повторите попытку");
    КонецПопытки;
    
    тЗапросНаВзвешивание = Символ(2) + "AB03" + Символ(3);
    
    Для Н = 1 по 5 Цикл        // попытки если вес не стабилен
        
        
        Весы.Output = тЗапросНаВзвешивание;
        
        Пока Весы.InBufferCount < 12 Цикл
            #Если Клиент Тогда
                ОбработкаПрерыванияПользователя();
            #КонецЕсли
        КонецЦикла;
        
        См = Весы.Input;
        
        Если ПустаяСтрока(См) Тогда
            
            Продолжить;
            
        Иначе
            //Сообщить(См);
            
            См = Сред(СтрЗаменить(См, Лев(тЗапросНаВзвешивание,3), ""), 2);
            См = СтрЗаменить(См, Символ(3), "");
            См = Лев(См, СтрДлина(См)-2);    // последние 2 символа служебные
                        
            ЗнСВесов = Число(См);
            
            Прервать;
            
        КонецЕсли;    
        
    КонецЦикла;
    
    Весы.PortOpen = 0;
    
//Возврат ЗнСВесов;            
    
    
    Объект.Брутто=ЗнСВесов;    
Объект.РучнойВводБрутто=Ложь;
Объект.ДатаПолученияБрутто=ТекущаяДата();
КонецПроцедуры


Но почему то выдает ошибки:
Ошибка создания объекта компоненты MSCommLib (Mscomm32.ocx)
и
{Документ.ПриемкаПродукцииСПолейКФК.Форма.ФормаДокумента.Форма(5)}: Ошибка при вызове конструктора (COMОбъект): -2147221230(0x80040112): Класс не лицензирован для использования


 ! 

Правила: 9
 
Просмотров: 182, последний комментарий от Flexy   
Код обозначения текущего объекта в модуле объекта [раздел Программирование управляемых форм 1С 8.2]
Автор Gigi — 17.07.17, 13:32 — 4 комментариев
Всем привет!
С этим вопросом может и не было бы необходимости выходить на форум, если пошарил бы в учебнике или пошастал бы по статьям в интернете на эту тему.
Что делал но че то не найду. Так что, вынужден опять открыть тему, потому, что думаю так будет быстрее, чем искать искать и целый день тратить на какую то мелочь.
Так что нужна помощь.
Речь о модуле объекта. С которым совсем не знаком. Потому, что все процедуры в основном писал в модуле формы объекта и в общем модуле.
Вопрос:
Как обозначить текущий объект в модуле объекта

В событии в модуле формы объекта ведь все так выглядит
Процедура ПриОткрытии(Отказ)
Сообщить(""+Объект.Ссылка+" -- "+Объект.код);
КонецПроцедуры


А вот событие уже в модуле объекта.
Процедура ПередУдалением(Отказ)
Сообщить(""+Объект.Ссылка+" -- "+Объект.код); //НЕ РАБОТАЕТ! Естественно
КонецПроцедуры

Как получить то, что указано для модуля формы объекта уже в модуле объекта
Нужно код подкорректировать!
Буду признателен!
Просмотров: 167, последний комментарий от Petre   
Анализ движения денежных средств: группировка строк по дополнительному реквизиту при б/н расчету [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 17.07.17, 7:44 — 0 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Практически во всех значимых документах установлен дополнительный реквизит "Агент" (ПКО, РКО, ВПП, ИПП)

При выводе отчета "Анализ движения денежных средств" при группировке строк могу выбрать параметр "ДокументДвижения.Агент"
Кроме того в группировке колонок устанавливаю режим: "Вид денежных средств (наличный, безналичный).

При таком раскладе, в случае с наличными средствами, группировка строк отчет срабатывает четко, т.е. показывает движение по наличному расчету правильно, но

отчет по безналичному расчету не группирует по реквизиту "Агент", т.е. все сводит в одну строку.

Понимаю, что предыдущий оратор-программист сделал всё для группировки по наличному расчету, но я никак не могу сообразить, в какой регистр загнать "Агент", чтобы в ДокументеДвижения при отборе строк срабатывала группировка строк при безналичномм расчете по реквизиту "Агент"?


Вопрос снят.

Предыдущий оратор-программист почему-то "Агента" сделал реквизитом формы... Исправил. Всё заработало
Просмотров: 91, оставить комментарий   
Получить текущий объект метаданных [раздел Программирование управляемых форм 1С 8.2]
Автор Gigi — 14.07.17, 13:11 — 10 комментариев
Привет всем!
Никто не подскажет как получить текущий элемент метаданных.
Рыл везде ... все что нашел .... нечто подобное ...
//Сообщить(Метаданные.Справочники[1]);
Для Каждого Справочник из Метаданные.Справочники Цикл
Сообщить (Справочник.Имя);
КонецЦикла;

А мне нужно не это, а нужно получить текущий элемент метаданных. Не по индексу не по указанию имени, а в зависимости от события.
Например при событии формы списка: СписокПередУдалением()
Тут в самом начале нужна линия кода, которая выдавала бы имя метаданных, к которому относиться текущий список.
Или на пример ФормаЭлемента и реквизиты. Где нужно получить имя объекта метаданных этой ФормаЭлемента.
Вот такой вот вопрос.
Буду признателен!
Просмотров: 259, последний комментарий от vasya_nepupkin   
Дополнительные реквизиты для кпк Моби-С [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 14.07.17, 8:54 — 0 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Если верить сайту, то для Моби-С можно добавить дополнительные реквизиты для обмена данными с центральной базой.
[необходимо зарегистрироваться для просмотра ссылки]
Но я ничего не понял, как правильно сделать этот дополнительный реквизит.

Задача: в документе "Заказ покупателя" в УТ я создаю новый реквизит "СрокКредита" (список значений, "7", "14", "30" дней)
Т.е. при договоре с наименованием "Кредит" пациент должен выбрать срок кредита в днях в выпадающем списке.

Аналогично нужно сделать и на планшете в Моби-С.

На сайте вроде всё понятно, но сбивает с толку пункт: Обработка при создании документа

Так значит что-то нужно делать и в самой УТ?

Кто-нить сталкивался с дополнительными реквизитами для кпк Моби-С? Посоветуйте, а лучше дайте списать :-)
Просмотров: 115, оставить комментарий   
Глюк Formex [раздел Программирование в 1С Предприятие 7.7]
Автор XBrut — 13.07.17, 12:20 — 1 комментариев
Платформа 27.
Формекс 2.0.5.124
В текстових полях діалогу виникає набажане виділення вмісту.
Тобто...: багаторядкове поле, починаєш писати текст...через кілька секунд все виділяється... і з натисканням наступрої клавіші - зникає.
Мені чомусь здається, що таку проблему бачив не тільки я.
Шукав в інтернетах. Проблема існує , але відповіді толковї не знайшов.

Тобто. Якщо хтось знає, допоможіть будь ласка, хто скільки зможе smile.gif
Просмотров: 188, последний комментарий от Sharzem   
Проверка оплаты реализации (договор в целом; без "вести по документам расчетов с контрагентами") [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 13.07.17, 10:31 — 11 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Имеется Договор (по договору в целом, и без "вести по документам расчетов с контрагентами")
Проводится 2-реализации
1. Реал 01 - 500 денег
2. Реал 02 - 500 денег

ПКО по оплате по этому договору - 750 денег. Задолженность по договору - 250 денег

Имеется ли возможность получить некий отчет, который бы позволил увидеть оплаты по данному договору и реализациям, т.е.

1. Реал 01 - 500 денег; оплачено 500; долг 0
2. Реал 02 - 500 денег; оплачено 250; долг 250

Слышал звон, что 1с при данных условиях списывает оплату по реализациям по ФИФО.

Возможно ли получить такой отчет, с учетом, что договор не ведется по документам расчетов?
Просмотров: 205, последний комментарий от Constantus   
загрузка свойств номенклатуры из xls [раздел Программирование в 1С Предприятие 7.7]
Автор Korotkiy — 12.07.17, 21:44 — 3 комментариев
Добрый вечер!
1с7.7 платформа 7.70.027
Типовая конфигурация "Торговля+Склад" редакция 9,2
Оптово-розничная конфигурация 7.70.935

Подскажите что у меня неправильно. Никак непойму чтото , выкидывает ошибку
Цитата
<<?>>Процедура ПоКнопкеЗагрузить() Далее
{H:\загрузка свойств.ert(56)}: Определения процедур и функций должны размещаться перед операторами основной программы

Ну и в целом правильно ли я написал ?
Вообщем нужно в номенклатуре присвоить ряд свойств. в ручную не вариант т.к. номенклатуры 50к позиций
решил сдалать обработку которая загрузит из экселя, в голове понимаю что должно быть , а вот с реализацией не очень ...
Перем НомерСтроки;   
Перем Ид;
Перем Эксель;
Перем Книга;
Перем Лист;
Перем ИмяФайлаЗагрузки;


Запрос = СоздатьОбъект("Запрос");
СпрСвойств = СоздатьОбъект("Справочник.ВидыСвойств");        
СпрЗначСвойств = СоздатьОбъект("Справочник.ЗначенияСвойств");
СпрСвойствНом = СоздатьОбъект("Справочник.СвойстваНоменклатуры");  


//******************************************************************************
// ПоКнопкеЗагрузить()
//
//
// Вызывается из формул элементов диалога:
//  Кнопка "Загрузить".
//
// Описание:  
//    Вызывается при нажатии кнопки "Загрузить". заполняются значения из таблицы эксель
//

Процедура  ПоКнопкеЗагрузить() Далее


//откроем эксель
    
        Попытка
        Эксель = СоздатьОбъект("Excel.Application");
        Исключение
        Сообщить (ОписаниеОшибки() + " Программа Exсel не установлена на данном компьютере!");
        Возврат;
        КонецПопытки;

//откроем наш файл и установим параметры

        Если ПустоеЗначение(ИмяФайлаЗагрузки)=1 Тогда  
            Сообщить ("Не выбран файл для загрузки!");
            Возврат;
        Иначе
            Книга = Эксель.WorkBooks.Open(ИмяФайлаЗагрузки);
            Эксель.Visible=0;
               Эксель.DisplayAlerts=0;
               Эксель.ScreenUpdating = 0;
               Эксель.EnableEvents = 0;  
               Лист = Книга.WorkSheets(1);
           КонецЕсли;

//зациклим чтобы прочитать каждую строку
//получим значение ID из нашей таблицы
        НомерСтроки=1;
        
        Пока ПустоеЗначение (Лист.Cells(НомерСтроки, 1).Value)=0 Цикл    
            НомерСтроки=НомерСтроки+1;
            Ид=  Лист.Cells(НомерСтроки, 1).Value;
//найдем элемент номенклатуры по коду
            СпрСвойствНом.ИспользоватьВладельца(Запрос.Номенклатура);
            СпрСвойствНом.НайтиПоКоду(Ид);
                Если СпрСвойствНом.выбран()=1 Тогда
                СпрСвойствНом = СпрСвойствНом.ТекущийЭлемент();
//проверим совпадают ли артикулы
                    Если Запрос.Номенклатура.Артикул = Лист.Cells(НомерСтроки, 2).Value Тогда
//найдем значение производителя
                          СпрСвойств.НайтиПоКоду("20030");
//проверим заполнено ли оно
                        Если СпрСвойствНом.НайтиПоРеквизиту("ВидСвойства",СпрСвойств.ТекущийЭлемент(),0) = 0 Тогда
//присвоим значение полученое из таблицы
          
                        СпрСвойств.Новый();
                        СпрСвойств.ЗначениеСвойства = Лист.Cells(НомерСтроки, 3).Value;
                        СпрСвойств.ВидСвойства      = СпрСвойств.НайтиПоКоду("20030");
                            СпрСвойств.Записать();
                        КонецЕсли;
//найдем значение модель
                          СпрСвойств.НайтиПоКоду("20034");
//проверим заполнено ли оно
                        Если СпрСвойствНом.НайтиПоРеквизиту("ВидСвойства",СпрСвойств.ТекущийЭлемент(),0) = 0 Тогда
//присвоим значение полученое из таблицы

                        СпрСвойств.Новый();
                        СпрСвойств.ЗначениеСвойства = Лист.Cells(НомерСтроки, 5).Value;
                        СпрСвойств.ВидСвойства      = СпрСвойств.НайтиПоКоду("20034");
                            СпрСвойств.Записать();
                        КонецЕсли;
        
                    КонецЕсли;
                КонецЕсли;
        КонецЦикла;
        Эксель.Quit();  
КонецПроцедуры
Просмотров: 211, последний комментарий от 1Cv77   
RSS Текстовая версия Сейчас: 26.07.17, 16:30
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне