Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Вывести сверху в шапке строчку под каждым месяцем [раздел Система компоновки данных]
Автор dsfdsfsdf — 17.09.18, 15:34 — 1 комментариев
Сделал отчет на скд, отбором вывел суммы за каждый месяц. Как мне вывести сверху в шапке строчку под каждым месяцем Слово "План" ?




 ! 

Правила: 4
 
Просмотров: 68, последний комментарий от _tray_   
Программно открыть или скрыть подсистему [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 17.09.18, 11:59 — 11 комментариев
Всем привет!
Никто не подскажет возможно ли это и как это сделать?
Буду признателен!

Gigi @ Сегодня, 12:44 * ,
Вот код из модуля управляемого приложения:
Перем АктивнаяПодсистема;
Процедура ПриНачалеРаботыСистемы()
АктивнаяПодсистема="desktop";
//АктивнаяПодсистема="СТАТИСТИКА";
ПодключитьОбработчикОжидания("СканТекущейПодсистемы",0.1,Истина);
КонецПроцедуры

Процедура СканТекущейПодсистемы() Экспорт
ТекНавигСсылка=АктивноеОкно().ПолучитьНавигационнуюСсылку();
//-------------------------
Сообщить("Навигационная ссылка: «" + ТекНавигСсылка+"»");
Подсистема=СтрЗаменить(ТекНавигСсылка,"e1cib/navigationpoint/","");
Знак=Найти(Подсистема,"/");
Если Знак>0 Тогда
    Подсистема=Лев(Подсистема,Знак-1);
КонецЕсли;
//-------------------------
Если АктивнаяПодсистема<>Подсистема Тогда
Сообщение=Новый СообщениеПользователю;
Сообщение.Текст="Вы в подсистеме: «" + Подсистема+"»";
Сообщение.Сообщить();
АктивнаяПодсистема=Подсистема
КонецЕсли;
//ПодключитьОбработчикОжидания("СканТекущейПодсистемы",0.1,Истина);
КонецПроцедуры

Дело в том, что все это просто сообщает текущую подсистему.
А нужно программно открыть или скрыть любую указанную подсистему.
Как это сделать?
Буду весьма признателен!
Просмотров: 131, последний комментарий от Gigi   
Как восстановить конфигурацию имея 1cd базу и 1cema.xml [раздел Мобильная платформа 1С]
Автор zadevil — 15.09.18, 17:06 — 6 комментариев
КАк восстановить конфигурацию имея 1cd базу с соболиного и 1cema.xml. Случайно затер конфигурацию.
Просмотров: 197, последний комментарий от zadevil   
Универсальный отчет задваивает группировки [раздел Программирование в 1С Предприятие 8.3]
Автор twilight_dream — 15.09.18, 8:58 — 2 комментариев
1С:Предприятие 8.3 (8.3.9.1818)
"Управление торговым предприятием для Украины", редакция 1.2. (1.2.43.1)

Здравствуйте!
Пытаюсь впервые сотворить отчет на универсальном отчете. Взял простейший пример, просто выборка из одного регистра. Но в дальнейшем это будет ещё соединение с регистром "цены номенклатуры".
Многое закоментировал, чтобы уж совершенно просто было.
В результате получаю в группировках склад и номенклатура повторяется по два раза. А если делаю ещё и левое соединение, то и суммы странные - и не задваивает, и не затраивает, а что то вообще произвольное. Иногда больше, иногда меньше. Иногда оборотов нет, а конечный остаток отличается от начального smile.gif Но это уже следующий этап. Сейчас хотя бы задвоение побороть. Код настройки и скрин задвоения прилагается.

Код
    тз="ВЫБРАТЬ
       |    ТоварыВНТТОстаткиИОбороты.Склад КАК Склад,
       |    ПРЕДСТАВЛЕНИЕ(ТоварыВНТТОстаткиИОбороты.Склад),
       |    ТоварыВНТТОстаткиИОбороты.Номенклатура КАК Номенклатура,
       |    ПРЕДСТАВЛЕНИЕ(ТоварыВНТТОстаткиИОбороты.Номенклатура),
       |    ТоварыВНТТОстаткиИОбороты.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
       |    ТоварыВНТТОстаткиИОбороты.СерияНоменклатуры КАК СерияНоменклатуры,
       |    ТоварыВНТТОстаткиИОбороты.ЦенаВРознице КАК ЦенаВРознице,
       |    ТоварыВНТТОстаткиИОбороты.КоличествоНачальныйОстаток КАК КоличествоНачальныйОстаток
       |{ВЫБРАТЬ
       |    Склад.*,
       |    Номенклатура.*,
       |    ХарактеристикаНоменклатуры.*,
       |    СерияНоменклатуры.*,
       |    ЦенаВРознице,
       |    КоличествоНачальныйОстаток}
       |ИЗ
       |    РегистрНакопления.ТоварыВНТТ.ОстаткиИОбороты(&ДатаНачала, &ДатаКонца, Регистратор, , ) КАК ТоварыВНТТОстаткиИОбороты
       |{ГДЕ
       |    ТоварыВНТТОстаткиИОбороты.Склад.*,
       |    ТоварыВНТТОстаткиИОбороты.Номенклатура.*,
       |    ТоварыВНТТОстаткиИОбороты.ХарактеристикаНоменклатуры.*,
       |    ТоварыВНТТОстаткиИОбороты.СерияНоменклатуры.*}
       |ИТОГИ
       |    СУММА(КоличествоНачальныйОстаток)
       |ПО
       |    ОБЩИЕ,
       |    Склад,
       |    Номенклатура
       |{ИТОГИ ПО
       |    Склад.*,
       |    Номенклатура.*}";
УниверсальныйОтчет.мВыбиратьИмяРегистра=ложь;
УниверсальныйОтчет.ИмяРегистра="";
       УниверсальныйОтчет.ПостроительОтчета.Текст=тз;
       Пока УниверсальныйОтчет.ПостроительОтчета.ИзмеренияСтроки.Количество() > 0 Цикл
          
           УниверсальныйОтчет.ПостроительОтчета.ИзмеренияСтроки.Удалить(УниверсальныйОтчет.ПостроительОтчета.ИзмеренияСтроки[0]);
          
       КонецЦикла;

       УниверсальныйОтчет.ПостроительОтчета.Параметры.Вставить("ТипЦенБазовыйСНДС",Справочники.ТипыЦенНоменклатуры.НайтиПоКоду("000000003"));
       УниверсальныйОтчет.мНазваниеОтчета = СокрЛП(ЭтотОбъект.Метаданные().Синоним);
       УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Склад","Склад 1");
       УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Номенклатура","Номенклатура");
       УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("ХарактеристикаНоменклатуры","ХарактеристикаНоменклатуры");
       УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("СерияНоменклатуры","СерияНоменклатуры");
       УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("ЦенаВРознице","ЦенаВРознице");
       УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("КоличествоНачальныйОстаток","КоличествоНачальныйОстаток");
      //
      // УниверсальныйОтчет.ДобавитьПоказатель("ЦенаВРознице","Цена в рознице",истина,"ЧЦ=15; ЧДЦ=2","ЦенаВРознице","Цена в рознице");
      //// УниверсальныйОтчет.ДобавитьПолеРесурс("СуммаВРозницеНачальныйОстаток",     "ВЫРАЗИТЬ(КоличествоНачальныйОстаток * ЦенаВРознице КАК ЧИСЛО(15, 2))", "Стоимость в рознице с НДС (нач. ост.)");
      // УниверсальныйОтчет.ДобавитьПоказатель("ЦенаБазоваяСНДС","Цена базовая с НДС",истина,"ЧЦ=15; ЧДЦ=2","ЦенаБазоваяСНДС","Цена базовая с НДС");
      //
      // УниверсальныйОтчет.ДобавитьПоказатель("СуммаБазоваяСНДСНачОст","Сумма баз. с НДС нач.ост",истина,"ЧЦ=15; ЧДЦ=2","СуммаБазоваяСНДС","Сумма базовая с НДС");
      // УниверсальныйОтчет.ДобавитьПоказатель("СуммаБазоваяСНДСКонОст","Сумма баз. с НДС кон.ост",истина,"ЧЦ=15; ЧДЦ=2","СуммаБазоваяСНДС","Сумма базовая с НДС");
      // УниверсальныйОтчет.ДобавитьПоказатель("СуммаБазоваяСНДСПриход","Сумма баз. с НДС приход",истина,"ЧЦ=15; ЧДЦ=2","СуммаБазоваяСНДС","Сумма базовая с НДС");
      // УниверсальныйОтчет.ДобавитьПоказатель("СуммаБазоваяСНДСРасход","Сумма баз. с НДС расход",истина,"ЧЦ=15; ЧДЦ=2","СуммаБазоваяСНДС","Сумма базовая с НДС");
      // УниверсальныйОтчет.ДобавитьПоказатель("СуммаБазоваяСНДСОборот","Сумма баз. с НДС оборот",истина,"ЧЦ=15; ЧДЦ=2","СуммаБазоваяСНДС","Сумма базовая с НДС");
      //
       УниверсальныйОтчет.ДобавитьПоказатель("КоличествоНачальныйОстаток","КоличествоНачальныйОстаток",истина,"ЧЦ=15; ЧДЦ=2","Количество","Количество");
      // УниверсальныйОтчет.ДобавитьПоказатель("КоличествоКонечныйОстаток","КоличествоКонечныйОстаток",истина,"ЧЦ=15; ЧДЦ=2","Количество","Количество");
      // УниверсальныйОтчет.ДобавитьПоказатель("КоличествоОборот","КоличествоОборот",истина,"ЧЦ=15; ЧДЦ=2","Количество","Количество");
      // УниверсальныйОтчет.ДобавитьПоказатель("КоличествоПриход","КоличествоПриход",истина,"ЧЦ=15; ЧДЦ=2","Количество","Количество");
      // УниверсальныйОтчет.ДобавитьПоказатель("ЦенаБазоваяСНДС","ЦенаБазоваяСНДС",истина,"ЧЦ=15; ЧДЦ=2","Количество","Количество");
       УниверсальныйОтчет.ДобавитьИзмерениеСтроки("Склад");
       УниверсальныйОтчет.ДобавитьИзмерениеСтроки("Номенклатура");




Просмотров: 85, последний комментарий от Vidocq05   
Видає помилку при створенні нових документів [раздел Программирование в 1С Предприятие 8.3]
Автор berest.andriy — 14.09.18, 17:13 — 7 комментариев
Інколи при створенні нових документів реалізаціі чи приходу вискакує помилка
Просмотров: 139, последний комментарий от Vofka   
Програмная установка стандартного периода СКД [раздел Система компоновки данных]
Автор twilight_dream — 13.09.18, 16:18 — 2 комментариев
1С:Предприятие 8.3 (8.3.9.1818)
"Управление торговым предприятием для Украины", редакция 1.2. (1.2.43.1)

Здравствуйте.
Отчет СКД открывается и формируется из формы документа. И всё бы хорошо, но вот стандартный период как не устанавливаю, всё равно его поля пустые.
Использую такой код :
отчетР = отчеты.ВедомостьПоР.Создать();

    отчетР .СхемаКомпоновкиДанных.Параметры.Период.Значение.ДатаНачала = НачалоДня(НачалоМесяца(дата));
    отчетР .СхемаКомпоновкиДанных.Параметры.Период.Значение.ДатаОкончания = КонецДня(КонецМесяца(дата));

Форма открывается. Поля периода пусты.
Для верности изменил этот код и ставил прямо в форму отчета при открытии
СхемаКомпоновкиДанных.Параметры.Период.Значение.ДатаНачала = НачалоДня(НачалоМесяца(дата));
.СхемаКомпоновкиДанных.Параметры.Период.Значение.ДатаОкончания = КонецДня(КонецМесяца(дата));


и снова пусто


 ! 

Правила: 3
 
Просмотров: 105, последний комментарий от twilight_dream   
Проблема со штрихкодом (Ocvita Barcode). Печать по ширине компоненты [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор bizisoft — 11.09.18, 21:48 — 9 комментариев
Здравствуйте.
1С:Предприятие 8.2 (8.2.19.130)
"Альфа-Авто: Автосервис+Автозапчасти, украинская версия 4.1" (4.1.14.01)
обычные формы.

Пытаюсь задействовать компоненту от ocvita barcode, т.к. штатная не удовлетворяет требованиям (не может печатать QR или CODE128 ).

Для вывода использую штатную обработку Альфы, немного модифицированную, чтобы выводила доп.реквизиты.
Вот так выглядит макет в конфигураторе:


А так выглядит на экране печатная форма:


А это фото распечатанных этикеток:


Проблема заключается в том, что никак не могу растянуть штрих код на ширину элемента штрихкода (в данном случае почти на всю ширину этикетки).
Было замечено, что штрихкод меняет свою ширину при уменьшении/увеличении количество символов передаваемой строки (артикула), но он не заполняется равномерно по установленной при проектировании ширине.
Например на оригинальных этикетках штрихкод всегда (по крайней мере визуально) имеет одинаковую ширину в не зависимости от зашифрованного в нем артикула



Перепробовал много вариантов.
Менял в свойствах параметр height, но он отвечает только за высоту штрихов, к сожалению параметра weight не оказалось.
Изменял до минимально возможного размер самого элемента штрихкод, чтобы на выходи происходило заполнение по ширине - не действует, т.к. при достижении определенных размеров штрихкод превращался в прямоугольник с перечеркнутыми диагоналями.
Также напрягает тот факт, что есть несоответствие видимого на экране и полученного при печати (видно из скриншота выше и фото).

Это скрин настроек компоненты.

Из всех доступных параметров визульно влияют только barcode (выводится в ШК если не передан текст), symbology (вид ШК), height (высота штрихов).
Остальные параметры по моему опыту не дали каких-либо визуальных изменений, конечно если еще знать, какие в эти параметры нужно вводить значенияsmile.gif.

Помогите советом, каким образом, если конечно возможно, растягивать штрихкод по ширине или пните ссылкой, где можно почитать.

Благодарю.
Просмотров: 175, последний комментарий от bizisoft   
Обмен 1С и Woocommerce [раздел Программирование в 1С Предприятие 8.3]
Автор kosalex — 11.09.18, 19:46 — 1 комментариев
Доброго времени суток! Настраиваю обмен между УНФ 1.6.6.1 и woocommerce последней версии.
Плагин для обмена использую 1С:Предприятие Data Exchange
Номенклатура нормально выгрузилась на сайт, а вот заказы с сайта никак не хотят поступать в 1С

Вот какую выдаёт ошибку
PHP Unknown Error: Функция status вызвана неправильно. Order properties should not be accessed directly. Backtrace: require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), do_action('template_redirect'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, wc1c_template_redirect, wc1c_exchange, wc1c_mode_query, include('/plugins/woocommerce-and-1centerprise-data-exchange/exchange/query.php'), WC_Abstract_Legacy_Order->__get, wc_doing_it_wrong Дополнительную информацию можно найти на странице <a href="https://codex.wordpress.org/Debugging_in_WordPress">&laquo;Отладка в WordPress&raquo;</a>. (Это сообщение было добавлено в версии 3.0.) in /home/vtrendes/domains/vtrendeshop.com/public_html/wp-includes/functions.php on line 4161.

#0 wc1c_error(Функция status вызвана <strong>неправильно</strong>. Order properties should not be accessed directly. Backtrace: require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), do_action('template_redirect'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, wc1c_template_redirect, wc1c_exchange, wc1c_mode_query, include('/plugins/woocommerce-and-1centerprise-data-exchange/exchange/query.php'), WC_Abstract_Legacy_Order->__get, wc_doing_it_wrong Дополнительную информацию можно найти на странице <a href="https://codex.wordpress.org/Debugging_in_WordPress">&laquo;Отладка в WordPress&raquo;</a>. (Это сообщение было добавлено в версии 3.0.) in /home/vtrendes/domains/vtrendeshop.com/public_html/wp-includes/functions.php on line 4161, PHP Unknown Error) called at [/home/vtrendes/domains/vtrendeshop.com/public_html/wp-content/plugins/woocommerce-and-1centerprise-data-exchange/exchange.php:142]
#1 wc1c_strict_error_handler(1024, Функция status вызвана <strong>неправильно</strong>. Order properties should not be accessed directly. Backtrace: require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), do_action('template_redirect'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, wc1c_template_redirect, wc1c_exchange, wc1c_mode_query, include('/plugins/woocommerce-and-1centerprise-data-exchange/exchange/query.php'), WC_Abstract_Legacy_Order->__get, wc_doing_it_wrong Дополнительную информацию можно найти на странице <a href="https://codex.wordpress.org/Debugging_in_WordPress">&laquo;Отладка в WordPress&raquo;</a>. (Это сообщение было добавлено в версии 3.0.), /home/vtrendes/domains/vtrendeshop.com/public_html/wp-includes/functions.php, 4161, Array ([function] => status,[message] => Order properties should not be accessed directly. Backtrace: require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), do_action('template_redirect'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, wc1c_template_redirect, wc1c_exchange, wc1c_mode_query, include('/plugins/woocommerce-and-1centerprise-data-exchange/exchange/query.php'), WC_Abstract_Legacy_Order->__get, wc_doing_it_wrong Дополнительную информацию можно найти на странице <a href="https://codex.wordpress.org/Debugging_in_WordPress">&laquo;Отладка в WordPress&raquo;</a>.,[version] => (Это сообщение было добавлено в версии 3.0.)))
#2 trigger_error(Функция status вызвана <strong>неправильно</strong>. Order properties should not be accessed directly. Backtrace: require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), do_action('template_redirect'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, wc1c_template_redirect, wc1c_exchange, wc1c_mode_query, include('/plugins/woocommerce-and-1centerprise-data-exchange/exchange/query.php'), WC_Abstract_Legacy_Order->__get, wc_doing_it_wrong Дополнительную информацию можно найти на странице <a href="https://codex.wordpress.org/Debugging_in_WordPress">&laquo;Отладка в WordPress&raquo;</a>. (Это сообщение было добавлено в версии 3.0.)) called at [/home/vtrendes/domains/vtrendeshop.com/public_html/wp-includes/functions.php:4161]
#3 _doing_it_wrong(status, Order properties should not be accessed directly. Backtrace: require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), do_action('template_redirect'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, wc1c_template_redirect, wc1c_exchange, wc1c_mode_query, include('/plugins/woocommerce-and-1centerprise-data-exchange/exchange/query.php'), WC_Abstract_Legacy_Order->__get, wc_doing_it_wrong, 3.0) called at [/home/vtrendes/domains/vtrendeshop.com/public_html/wp-content/plugins/woocommerce/includes/wc-deprecated-functions.php:116]
#4 wc_doing_it_wrong(status, Order properties should not be accessed directly., 3.0) called at [/home/vtrendes/domains/vtrendeshop.com/public_html/wp-content/plugins/woocommerce/includes/legacy/abstract-wc-legacy-order.php:407]
#5 WC_Abstract_Legacy_Order->__get(status) called at [/home/vtrendes/domains/vtrendeshop.com/public_html/wp-content/plugins/woocommerce-and-1centerprise-data-exchange/exchange/query.php:141]
#6 include(/home/vtrendes/domains/vtrendeshop.com/public_html/wp-content/plugins/woocommerce-and-1centerprise-data-exchange/exchange/query.php) called at [/home/vtrendes/domains/vtrendeshop.com/public_html/wp-content/plugins/woocommerce-and-1centerprise-data-exchange/exchange.php:474]
#7 wc1c_mode_query(sale) called at [/home/vtrendes/domains/vtrendeshop.com/public_html/wp-content/plugins/woocommerce-and-1centerprise-data-exchange/exchange.php:511]
#8 wc1c_exchange() called at [/home/vtrendes/domains/vtrendeshop.com/public_html/wp-content/plugins/woocommerce-and-1centerprise-data-exchange/exchange.php:533]
#9 wc1c_template_redirect()
#10 call_user_func_array(wc1c_template_redirect, Array ([0] => )) called at [/home/vtrendes/domains/vtrendeshop.com/public_html/wp-includes/class-wp-hook.php:286]
#11 WP_Hook->apply_filters(, Array ([0] => )) called at [/home/vtrendes/domains/vtrendeshop.com/public_html/wp-includes/class-wp-hook.php:310]
#12 WP_Hook->do_action(Array ([0] => )) called at [/home/vtrendes/domains/vtrendeshop.com/public_html/wp-includes/plugin.php:453]
#13 do_action(template_redirect) called at [/home/vtrendes/domains/vtrendeshop.com/public_html/wp-includes/template-loader.php:12]
#14 require_once(/home/vtrendes/domains/vtrendeshop.com/public_html/wp-includes/template-loader.php) called at [/home/vtrendes/domains/vtrendeshop.com/public_html/wp-blog-header.php:19]
#15 require(/home/vtrendes/domains/vtrendeshop.com/public_html/wp-blog-header.php) called at [/home/vtrendes/domains/vtrendeshop.com/public_html/index.php:17]

Request URI: [необходимо зарегистрироваться для просмотра ссылки]
Server API: litespeed
Memory limit: 256M
Maximum POST size: 8M
PHP version: 5.6.37
WordPress version: 4.9.8
Plugin version: 0.7r1466555
Просмотров: 91, последний комментарий от kosalex   
Отчет ПродажиПоПериодах [раздел Программирование в 1С Предприятие 8.3]
Автор dsfdsfsdf — 11.09.18, 20:38 — 2 комментариев
Мне надо было подсчитать себестоимость и реализацию за период, в запросе я все подсчитал и все хороо выводит. Проблема следущая. Этот отчет сделан с помощью Построителя отчета, мне надо добавить 4 новые колонки и вывести туда данные, но никак не получается, данные не отображаются, хотя запрос все хорошо считает и в построителе(в запросе) выбрал нужные поля.
Когда я пишу
ПостроительОтчета.ЗаполнитьНастройки()
, данные в колонки выводит, но выводит и ненужные колонки, которые не должны быть.
Кто сталкивался например можете выбрать в запросе елинички или двойки и просто вывести их в отдельные колонки а я туда допилю то что подсчитывал, отчет прикреплю сейчас.

[необходимо зарегистрироваться для просмотра ссылки]

Я подсчитал все, мне надо просто вывести в колонки покажите как вывести я парился целых 2 дня уже, никак не могу. Процедура заполнения замедляет отчет и выводит ненужные колонки
Просмотров: 179, последний комментарий от twilight_dream   
Публикация веб сервиса на внешнем хостинге [раздел Программирование в 1С Предприятие 8.3]
Автор kosalex — 11.09.18, 16:08 — 0 комментариев
Всем привет!

Подскажите пожалуйста, можно ли опубликовать веб сервис на хостинге где лежит сайт?
Что нужно тогда написать в конфигураторе, в строке настройки публикации "Каталог"? Вписывал туда название домена и каталог, в ответ "Нужен полный путь"...

Вообще реально опубликовать веб сервис на внешнем хостинге? Публиковал кто нибудь?
Просмотров: 89, оставить комментарий   
Знание архитектуры какой либо конфигурации [раздел Тематическое общение]
Автор Victor031 — 09.09.18, 16:38 — 1 комментариев
Доброго времени суток, уважаемые форумчане! icon_beer17.gif
Во многих вакансиях, пишут одно из требований: знание архитектуры ЕРП, знание архитектуры ЗУП, БП и т.д, подскажите, что конкретно означает требование "Знание архитектуры"? Например человек работает с ут, дорабатывает ее под нужды фирмы и т.д, но ведь это не означает знание архитектуры этого прикладного решения? Как собственно эту архитектуру изучать? есть ли какие то книги? Заранее спасибо за ответы! 32000000.gif
Просмотров: 130, последний комментарий от Егор Динин   
Закрытие обработки [раздел Программирование в 1С Предприятие 8.3]
Автор Inkognito — 07.09.18, 15:53 — 2 комментариев
Управляемые формы, Бухгалтерия 2.0
Есть одна непонятная ошибка в обработке, когда открываем ее дважды. И закрываем поочередно открытые обработки.
Код
Ошибка при вызове метода контекста (ПередЗакрытиемНаСервере)
ПередЗакрытиемНаСервере();
по причине:
Неизвестный идентификатор формы

После этого 1С вообще не закрывается, только через "Диспетчер задач".

Я так понимаю, повторного открытия вообще не должно быть, нужно как-то позиционироваться на уже открытой обработке?
Просмотров: 123, последний комментарий от Inkognito   
Обычная и управляемая форма в одной обработке [раздел Программирование в 1С Предприятие 8.3]
Автор Inkognito — 07.09.18, 14:21 — 3 комментариев
Необходимо создать обработку с двумя формами: обычной и управляемой.
Если обработка открывается в конфигурации обычных форм (например, "Бухгалтерии 1.2"), то открывать обычную форму, а если в управляемых (например, "Бухгалтерии 2.0") - управляемую. Элементы управления будут базовые (текст, кнопки, табличная часть), чтобы обработка работала одинаково в разных конфигурациях.
Вопрос: как написать проверку (или в настройках обработки что-то поменять?) Или придется делать две обработки?
Прошу не кидать тапками, управляемые формы... они такие управляемые...
Просмотров: 123, последний комментарий от Inkognito   
Как отобразить при наличии 2х регистраторов второй. [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор eror2008 — 07.09.18, 10:55 — 22 комментариев
Простите сразу за тупые вопросы, только учусь. Конфигурация не типовая. Но задача такая:
Нужно сделать отчет в котором выводятся договора и договора с Доп. соглашением по заданному периоду. (Это сделал вроде работает) Но проблема в том что отображаются 2ве записи: договор и договора с доп. соглашениями.
Как сделать правильно условие: если есть второй регистратор то не отображать первый.? Заранее спасибо!


код отчета:
ВЫБРАТЬ
    Договора.Объект КАК Объект,
    МАКСИМУМ(Договора.Период) КАК Период,
    МАКСИМУМ(Договора.Договор.Дата) КАК ДоговорДата,
    Договора.СуммаПолнаяUSD
ПОМЕСТИТЬ Договорчики
ИЗ
    РегистрСведений.Договора КАК Договора
ГДЕ
    Договора.Активность = ИСТИНА
    И Договора.Регистратор ССЫЛКА Документ.Договор
            

СГРУППИРОВАТЬ ПО
    Договора.Объект,
    Договора.СуммаПолнаяUSD
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    Договора.Объект КАК Объект,
    Договора.Объект.ПлощадьОбщая КАК ОбъектПлощадьОбщая,
    СУММА(Договора.СуммаПолнаяUSD) КАК СтоимостьОбъекта,
    Договора.Объект.Комплекс КАК Комплекс,
    Договора.Объект.Секция КАК Секция,
    Договора.Объект.Этаж КАК Этаж,
    СУММА(Договора.Договор.СуммаПервогоВзноса) КАК СуммаПервогоВзноса,
    Договора.Договор.Контрагенты КАК Контрагент
ИЗ
    РегистрСведений.Договора КАК Договора
        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Договорчики КАК Договорчики
        ПО Договора.Период = Договорчики.Период
            И Договора.Объект = Договорчики.Объект
ГДЕ
    Договора.Договор.Дата >= &НачалоПериода
    И Договора.Договор.Дата <= &КонецПериода
    И ВЫБОР
            КОГДА Договора.Регистратор ССЫЛКА Документ.Договор
                ТОГДА ИСТИНА
            КОГДА Договора.Регистратор ССЫЛКА Документ.ДополнительноеСоглашение
                ТОГДА ИСТИНА
            ИНАЧЕ ЛОЖЬ
        КОНЕЦ

СГРУППИРОВАТЬ ПО
    Договора.Объект,
    Договора.Объект.Комплекс,
    Договора.Объект.Секция,
    Договора.Объект.Этаж,
    Договора.Договор.Контрагенты,
    Договора.Объект.ПлощадьОбщая
Просмотров: 435, последний комментарий от eror2008   
Как сделать отчет периодами за каждый день [раздел Программирование в 1С Предприятие 8.3]
Автор burza — 05.09.18, 15:18 — 17 комментариев
Нужно чтобы отчет показывал информацию за год в пределах дня какое количество работающих
ибо выбирать каждый день в период года это не реально.сейчас работает на дату.
ВЫБРАТЬ
    ШтатноеРасписаниеСрезПоследних.Подразделение,
    ШтатноеРасписаниеСрезПоследних.Должность,
    РаботающиеСотрудникиНаДату.КоличествоРаботников КАК КоличествоРаботников
ИЗ
    РегистрСведений.ШтатноеРасписание.СрезПоследних(, ) КАК ШтатноеРасписаниеСрезПоследних
        ПОЛНОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
            РегистрСотрудниковСрезПоследних.Подразделение КАК Подразделение,
            КОЛИЧЕСТВО(РегистрСотрудниковСрезПоследних.Работник) КАК КоличествоРаботников,
            РегистрСотрудниковСрезПоследних.Должность КАК Должность
        ИЗ
            РегистрСведений.РегистрСотрудников.СрезПоследних(, ) КАК РегистрСотрудниковСрезПоследних
                ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                    КадровыйДокументСотрудникиПринимаемые.Ссылка КАК Ссылка,
                    КадровыйДокументСотрудникиПринимаемые.Сотрудник КАК Сотрудник,
                    КадровыйДокументСотрудникиПринимаемые.Ссылка.Подразделение КАК Подразделение,
                    КадровыйДокументСотрудникиПринимаемые.ДатаПриема КАК ДатаПриема,
                    КадровыйДокументСотрудникиПринимаемые.Должность КАК Должность,
                    КадровыйДокументСотрудникиПринимаемые.Примечание КАК Примечание
                ИЗ
                    Документ.КадровыйДокумент.СотрудникиПринимаемые КАК КадровыйДокументСотрудникиПринимаемые
                ГДЕ
                    КадровыйДокументСотрудникиПринимаемые.Ссылка.ПометкаУдаления = ЛОЖЬ
                
                ОБЪЕДИНИТЬ ВСЕ
                
                ВЫБРАТЬ
                    КадровыйДокументСотрудникиУвольняемые.Ссылка,
                    КадровыйДокументСотрудникиУвольняемые.Сотрудник,
                    КадровыйДокументСотрудникиУвольняемые.Ссылка.Подразделение,
                    КадровыйДокументСотрудникиУвольняемые.ДатаПриема,
                    КадровыйДокументСотрудникиУвольняемые.Должность,
                    КадровыйДокументСотрудникиУвольняемые.Примечание
                ИЗ
                    Документ.КадровыйДокумент.СотрудникиУвольняемые КАК КадровыйДокументСотрудникиУвольняемые
                ГДЕ
                    КадровыйДокументСотрудникиУвольняемые.Ссылка.ПометкаУдаления = ЛОЖЬ) КАК КадровыеДанные
                ПО РегистрСотрудниковСрезПоследних.Подразделение = КадровыеДанные.Подразделение
                    И РегистрСотрудниковСрезПоследних.Работник = КадровыеДанные.Сотрудник
                    И РегистрСотрудниковСрезПоследних.ДатаПриема = КадровыеДанные.ДатаПриема
                    И РегистрСотрудниковСрезПоследних.Должность = КадровыеДанные.Должность
                    И РегистрСотрудниковСрезПоследних.Регистратор = КадровыеДанные.Ссылка
        ГДЕ
            РегистрСотрудниковСрезПоследних.Статус = &параметрСтатусРаботает
        
        СГРУППИРОВАТЬ ПО
            РегистрСотрудниковСрезПоследних.Подразделение,
            РегистрСотрудниковСрезПоследних.Должность) КАК РаботающиеСотрудникиНаДату
        ПО ШтатноеРасписаниеСрезПоследних.Подразделение = РаботающиеСотрудникиНаДату.Подразделение
            И ШтатноеРасписаниеСрезПоследних.Должность = РаботающиеСотрудникиНаДату.Должность



вот пример на сегодня.



а так понемаю нужно сделать что-то вроде этого
ВЫБРАТЬ
    Номенклатура,
    Период,
    ВНаличииКонечныйОстаток КАК Было
ПОМЕСТИТЬ Шаг0
ИЗ
    РегистрНакопления.ТоварыНаСкладах.ОстаткиИОбороты(&НачалоПериода, &КонецПериода, День, , )

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
    Номенклатура,
    &НачалоПериода,
    0
ИЗ
    РегистрНакопления.ТоварыНаСкладах.ОстаткиИОбороты(&НачалоПериода, &КонецПериода, ДЕНЬ, , )
;

////////Повторяется Х раз////////
ВЫБРАТЬ
    Номенклатура,
    Период,
    ЕСТЬNULL(МАКСИМУМ(Было), МАКСИМУМ(Стало)) КАК Было
ПОМЕСТИТЬ Шаг1
ИЗ
    (ВЫБРАТЬ
        Номенклатура КАК Номенклатура,
        Период КАК Период,
        Было КАК Было,
        NULL КАК Стало
    ИЗ      
        Шаг0 //таблица, полученная на предыдущем шаге
    
    ОБЪЕДИНИТЬ ВСЕ
    
    ВЫБРАТЬ
        Номенклатура,
        ДОБАВИТЬКДАТЕ(Период, ДЕНЬ, 1),//каждый раз вдвое больше дней: 1, 2, 4 и так далее
        NULL,
        Было
    ИЗ      
        Шаг0
    ГДЕ
        ДОБАВИТЬКДАТЕ(Период, ДЕНЬ, 1) <= &КонецПериода) КАК Куча

СГРУППИРОВАТЬ ПО
    Номенклатура,
    Период
;
////////конец повторов////////

ВЫБРАТЬ
    Номенклатура,
    Период,
    Было
ИЗ
    ШагХ

УПОРЯДОЧИТЬ ПО
    Номенклатура,
    Период


помогите адаптировать к моему коду.
Просмотров: 407, последний комментарий от burza   
Виникає помилка при вигрузці товарів на сайт [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор zhezabel — 05.09.18, 10:31 — 2 комментариев
При вигрузці залишків товарів на сайт виникає помилка
{Обработка.ОбменСЛичнымКабинетом.МодульОбъекта(5364)}: Поле объекта не обнаружено (КодГруппы)
Результат = Ссылка.КодГруппы;

Подивилась в конфігураторі

Функция КодГруппы(Ссылка, РезультатСтрокой=Ложь) Экспорт
    
    Результат = Неопределено;
    
    Если ЗначениеЗаполнено(Ссылка) Тогда
        Результат = Ссылка.КодГруппы;
    КонецЕсли;    
    
    Возврат ?(РезультатСтрокой, XMLСтрока(Результат), Результат);
    
КонецФункции


В 1с недавно працюю. Підкажіть, будь ласка, що поміняти щоб нормально вигружалось.


 ! 

Правила: 3, 9
 
Просмотров: 127, последний комментарий от zhezabel   
Цены на медикаменты [раздел Тематическое общение]
Автор 161162nvk — 05.09.18, 9:48 — 0 комментариев
Занимаемся оптовой реализацией медикаментов. Существует реестр оптовых цен на медикаменты,утвержденный МОЗ, выше которых продавать некоторые наименования мы не имеем права. Эта цена должна быть также указана в расходной накладной (наряду с нашей ценой реализации). Есть ли у кого-то опыт реализации: закачка реестра с сайта МОЗ (он периодически обновляется), добавление второй цены в расходную накладную. Работаем в Управление производственным предприятием для Украины, редакция 1.3 (1.3.55.1)
Просмотров: 89, оставить комментарий   
Влияние расширения конфигурации на скорость загрузки конфигурации [раздел Программирование в 1С Предприятие 8.3]
Автор ABurkovskiy — 04.09.18, 22:47 — 0 комментариев
Платформа 1С:Предприятие 8.3 (8.3.11.2867)
Конфигурация УправлениеТорговымПредприятиемДляУкраины, версия 1.2.45.2
ОС Windows Server 2008 R2 Standard, терминальный режим, по памяти и процессору загрузка до 60-70%.
Добавил расширение. В него подтянул из конфигурации 15 документов, 10 справочников, 5 регистров накопления, 1 регистр сведений, 3 общих модуля, 30 ролей. Конфигурация с расширением грузиться дольше чем без расширения, в пределах 1 минуты, без расширения 30-40с.
Подтянул из конфигурации еще 15 документов (без реквизитов, форм и т.д.), только для того чтобы ограничить доступ через роли.
В результате загрузка конфигурации увеличилась до 6 минут. Это уже слишком долго. Такое ощущение, что есть прямая зависимость времени загрузки от количества заимствованных объектов и ограничения доступа к ним через роли.
Подскажите, что нужно подкрутить в платформе, конфигурации, расширении или в голове, чтобы уменьшить время загрузки?
Просмотров: 114, оставить комментарий   
Автоматизация Интернет магазина [раздел Помогите подобрать конфигурацию]
Автор Nysha1210 — 03.09.18, 15:56 — 10 комментариев
Всем привет. Очень нужен совет.
Решили автоматизировать работу Интернет-магазина. Выбрали 1С 8.3.
Теперь стал вопрос на базе какой конфы стоит его делать, так как есть свои вопросы по учёту.
Так же нужна будет интеграция с 3 сайтами.
Выбираем между: УТ, УТП и УНФ, разработка ABBY.
Всем спасибо. Буду благодарна за ответ.
Просмотров: 319, последний комментарий от Acid   
Как можно оптимизировать обработку табличной части документа [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор bizisoft — 02.09.18, 20:44 — 6 комментариев
Здравствуйте.
1С:Предприятие 8.2 (8.2.19.130)
"Альфа-Авто: Автосервис+Автозапчасти, украинская версия 4.1" (4.1.17.01)

Есть такой документ как Изменение цен компании, в котором устанавливаются цены для товаров в разрезе выбранного типа цен.
Например: у поставщика куплен товар, проведена приходная накладная. В Изменение цен компании выбирается эта приходная как документ основание и заполняется ТЧ по документу основания.
В ТЧ отображаются старая цена (которая была установлена ранее), базовая цена (цена из приходной), себестоимость (судя по значениям это итоговая себестоимость товара), а также % наценки, сумма наценки и Новая цена.

Добавил поле ПредыдущаяСебестоимость, в которую вывожу себестоимость товара, но без учета товара из приходной, т.е. делаю выборку по партиям до даты приходной накладной.
Все это действие выполняю в процедуре ПриПолученииДанных - все вроде работает, но тормоза при этом неописуемые.
При любом чихе (изменение данных, простая смена строки) происходит проход по ТЧ и выполнение запроса для каждой строки, что не по феншую.

...
        Если РасчетЦенОт=1 Тогда            
            Если НЕ ДокументОснование.Пустая() Тогда    
                ДокОсн = ДокументОснование.Ссылка;
                //Сообщить(ДокОсн.Номер);
                //Сообщить(ДокОсн.Дата);
                //Сообщить(ДокОсн.Номер);
                ЗапросПартии = Новый Запрос;                      
                ЗапросПартии.Текст =
                    "ВЫБРАТЬ
                    |    ПартииТоваровКомпанииОстатки.Номенклатура,
                    |    ПартииТоваровКомпанииОстатки.СуммаУпрОстаток / ПартииТоваровКомпанииОстатки.КоличествоОстаток КАК Себест
                    |ИЗ
                    |    РегистрНакопления.ПартииТоваровКомпании.Остатки КАК ПартииТоваровКомпанииОстатки
                    |ГДЕ
                    |    ПартииТоваровКомпанииОстатки.Номенклатура = &Номенклатура
                    |    И ПартииТоваровКомпанииОстатки.Партия.Дата < &Дата";                 
                ЗапросПартии.УстановитьПараметр("Номенклатура",ДанныеСтроки.Номенклатура);         
                ЗапросПартии.УстановитьПараметр("Дата",ДокОсн.Дата);         
                Результат = ЗапросПартии.Выполнить();
                ТЗ = Результат.Выгрузить();
                //ТЗ.Свернуть("Номенклатура","Себест");
                Сумма = 0;
                КолВо = 0;
                Для Каждого Стр Из ТЗ Цикл
                //Выб = Результат.Выбрать();
                //ПредыдущаяСебестоимость = 0;
                //Пока Выб.Следующий() Цикл
                    //Сообщить(Выб.Номенклатура);
                    //Сообщить(Выб.Себест);
                    Сумма = Сумма+Стр.Себест;
                    КолВо = КолВо+1;
                    Сообщить(Сумма);
                    Сообщить(КолВо);
                    //ПредыдущаяСебестоимость = Выб.Себест; //ЗапросПартии.Выполнить().Выгрузить()[0][1];//.Себест;
                    //Сообщить(ПредыдущаяСебестоимость);
                КонецЦикла;
                Попытка
                    ПредыдущаяСебестоимость = Сумма/КолВо;
                Исключение
                    ПредыдущаяСебестоимость = 0;
                КонецПопытки;
                ОформлениеСтроки.Ячейки.ПредыдущаяСебестоимость.ОтображатьТекст=Истина;
                ОформлениеСтроки.Ячейки.ПредыдущаяСебестоимость.Текст=Формат(ПредыдущаяСебестоимость,"ЧЦ=15; ЧДЦ=2");
            КонецЕсли;            
        КонецЕсли;            
...


Подскажите пожалуйста как можно оптимизировать этот процесс?
Просмотров: 191, последний комментарий от andr_andrey   
RSS Текстовая версия Сейчас: 19.09.18, 15:26
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне