Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Соединить в строку ссылку и текст [раздел Программирование управляемых форм 1С 8.2]
Автор kot488 — 28.04.17, 15:35 — 4 комментариев
Подскажите пожалуйста, есть процедура. Она заполняет извещение на основании документа.
Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
    //{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
    // Даний фрагмент побудований конструктором.
    // При повторному використанні конструктора, внесені вручну зміни будуть втрачені!!!
    Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ДекларацияПочта") Тогда
        // Заповнення шапки
        Тема = ДанныеЗаполнения.НомерДекларации;
        Копии = ДанныеЗаполнения.ОтправительEMail;
        Получатели = ДанныеЗаполнения.ПолучательEmail;
        ИмяОтправителя = ДанныеЗаполнения.СетьКурьерскихСлужб;
        АдресОтправителя = Справочники.ПочтовыеЯщики.НайтиПоКоду("000000001");
        ПочтовыйЯщик = Справочники.ПочтовыеЯщики.НайтиПоКоду("000000001");
    КонецЕсли;
    //}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
КонецПроцедуры


Подскажите пожалуйста, как можно задать статический текст с переменной, что бы Тема = ДанныеЗаполнения.НомерДекларации; при выводе было Документ и номер декларации. Как их склеить?

 ! 

Правила: 4
 
Просмотров: 95, последний комментарий от logist   
Запрос к бухгалтерским итогам [раздел Программирование в 1С Предприятие 7.7]
Автор SergXP — 28.04.17, 11:49 — 1 комментариев
Платформа 7.70.027
Конфигурация "Бухгалтерия+Торговля+Склад+Зарплата+Кадры для Украины" 7.70.018, очень сильно уже пере/дописанная.
Вопрос.
Инвентаризация ОС.
Счет учета ОС - 10
Субконто1 - МестоХранения
Субконто2 - ОС

Счет учета износа ОС - 13
Субконто1 - ОС

Как можно более оптимально построить запрос объекта "БухгалтерскиеИтоги", чтобы получить балансовую стоимость и накопленный износ по ОС для Места хранения?

Размышления...
ИспользоватьСубконто(ВидыСубконто.МестаХранения, МестоХранения,2);
ИспользоватьСубконто(ВидыСубконто.НеоборотныеАктивы);
ВключатьСубсчета(-1);
ВыполнитьЗапрос(ДатаОстатков,,"10;13",,,,,"СК");

В результате выполнения запроса в выборку не попадает счет "13". Мне кажется из-за того, что в 13-м счете не определен Субконто типа МестаХранения. А мне без МестХранения никак нельзя...
Просмотров: 70, последний комментарий от nysysimara   
Управление торговлей для Украины, редакция 3.1 не работает обмен с банком [раздел Программирование в 1С Предприятие 8.3]
Автор AlexeyMalko — 27.04.17, 14:57 — 4 комментариев
Есть файл выписки с российского банка при попытке загрузить выдаёт ошибку Неверный реквизит заголовка. для украинского банка вообще нету возможности загрузить так как есть всего две галочки txt и xml формата. Что можно сделать дял того чтобы загружать выписку?
Просмотров: 87, последний комментарий от logist   
Префиксы нового номера у самописных документов [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 26.04.17, 15:43 — 17 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Имеется самописный документ "СамДок"

Прописал его на подписку на событие при установке нового номера документа. Однако номер не сохраняется и прежде всего не проставляется префикс Организации.

Отладчиком обнаружил, что в
Процедура ДобавитьПрефиксОрганизации(ДокументОбъект, Префикс) Экспорт


ЗначениеЗаполнено(ДокументОбъект.Организация.Префикс)

значение не заполнено.

Хотя на форме документа присутствует реквизит Оргнизация

Понимаю, что нарушил какую-то последовательность действий. Подскажите как правильно прописать номер...

Кроме того, почему при создании нового Документа сразу прописывается номер 0000004...?
Просмотров: 198, последний комментарий от Constantus   
Руководство разработчика для MEDOC [раздел Тематическое общение]
Автор Bernet — 26.04.17, 11:25 — 9 комментариев
Всем привет.
Нужна документация с описанием структуры БД Медка.
Есть задача на допиливание функционала 1С и получении данных из Медка, а именно: нужно сверять коды УКТЗЕД поставщиков (которые ведутся у нас в базе) и те, которые приходят в входящих налоговых накладных в Медке.
Из примера медовой стыковки COM-объект с реестром входящих налоговых получил, теперь хочу пройтись по таб. части товаров каждого документа, там есть колонка "Код УКТЗЕД" - вот не знаю как её вытянуть, не хотелось бы пальцем в небо тыкать, а знать наверняка. Может кто находил нормальную документацию?

Дошел до следующего места:
        // получаем данные с МЕДКА
    App = Неопределено;
    Попытка
        App = Новый COMОбъект("Medoc.ZApplication")
    Исключение
        Возврат;
    КонецПопытки;                
    
    // Описание входящих параметров Медка:
    // ТипДокумента - "10100" - Налоговая накладная
    // ТипДокумента - "10101" - Приложение 2
    // ТипДокумента - "10100" - Входящий налоговый документ
    
    // Направление - 1 - исходящие
    // Направление - 2 - входящие
        
    prim = App.GetPrimaryDocs();
    Reestr = prim.GetPrimaryReestr("10100", 2, НачалоДня(НачалоПериода), КонецДня(КонецПериода));
    Reestr.First();
    Счетчик = Reestr.RecordCount;
    Пока Счетчик <> 0 Цикл
        
        НомерДокМед     = Reestr.Fields.Item("DOC_NUM").Value;
        ДатаДокМед      = Reestr.Fields.Item("DOC_DATE").Value;
        СуммаДокМед     = Reestr.Fields.Item("DOCSUM").Value;      
        
                // КАК ТУТ ОРГАНИЗОВАТЬ ПЕРЕБОР СТРОК ТАБ. ЧАСТИ И ВЫТЯНУТЬ КОД УКТЗЕД  С КАЖДОЙ СТРОКИ ?

        Счетчик = Счетчик-1;
          Reestr.Next();
    КонецЦикла;


P.S. [необходимо зарегистрироваться для просмотра ссылки] я не нашел того что хотел
Просмотров: 196, последний комментарий от Vofka   
Настройки отчета: ограничить снятие галочки параметра Склад [раздел Система компоновки данных]
Автор Constantus — 26.04.17, 11:23 — 0 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Отчет на СКД, форма отчета - управляемая

Основной параметр - Склад.

При открытии формы отчета в верхней части отчета появляется строка с выбором Склада и впереди галочка.

Можно ли как-то запретить снятие с параметра этой галочки, чтобы она всегда была активна и пользователь не мог ее снять?

Извините, поспешил... в параметрах СКД на этот параметр установил Использование : всегда
Просмотров: 74, оставить комментарий   
Налоговая накладная (проблема округления) [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Vidocq05 — 25.04.17, 14:58 — 3 комментариев
УТП 1.2.41.1 Платформа 8.2

Похожая тема уже подымалась но решения вроде как нет.

Привожу пример:
Выгружаю налоговую накладную в XML, в ней есть строка
Номенклатура - ТоварТакойто
Количество - 546 шт.
Сумма - 3261,23
Цена - 5,97 (Сумма/Количество = 5,972948717948718 округленное до 2-го знака после запятой)

Отправляем в налоговую.
Возвращается ошибка (дословно не помню), типа после проверки 5,97*546=3259,62, а переданная сумма 3261,23. Превышает допустимое отклонение в 1 грн.

Кто как решил?
Размышляю над разбиением строк при выгрузке в XML.
Просмотров: 120, последний комментарий от Petre   
Кнопка командной панели [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор EritikWoW — 25.04.17, 14:25 — 9 комментариев
1С:Предприятие 8.3 (8.3.6.2449)
"Управление торговлей для Украины" (2.3.25.1)

Сопсно задача создать 1 универсальную кнопку для всех документов которая изменяла бы данные общего реквезита тип булево на истину или ложъ
Создал свой общий модуль и вызываю процедуры в нем из общего модуля к которому обращаются все документы....
Теперь сама суть... если кнопке задать ту же процедуру то вылетает ошибка о том что данное имя не уникально.... я не хочу сильно грубить други модуля... хотел обойтись только вставкой одной строки на обращение к моей процедуре...

Что я хотел уточнить.... ну 1. Привести в порядок код (глазом человека который в этом шарит) что 2. Можно ли как кнопке КП передать процедуру не из формы а из моего модуля или хотя бы просто "Выгружать = Истина\ложъ" ?




Процедура ПриОткрытии (объект) Экспорт 
    
    НазваниеДокумента = Метаданные.НайтиПоТипу(ТипЗнч(объект)).Имя;
    ИндДок = Метаданные.Документы.Найти(НазваниеДокумента);
    ИмяФормы = ИндДок.Формы.ФормаДокумента.Имя;
    НД = ВРег(НазваниеДокумента);
    КолвоСим = СтрДлина(НазваниеДокумента);
    Форма = объект.ПолучитьФорму(ИмяФормы);
    КоличествоЭлементов = Форма.ЭлементыФормы.Количество();
    
    Для Каждого Док из Документы Цикл
    НазвДок = Прав(Док,КолвоСим);
    НазвДок = ВРег(НазвДок);
        Если НазвДок = НД ТОгда
            Форма1 = Док.ПолучитьФорму(ИмяФормы);
            КолЭлем = Форма1.ЭлементыФормы.Количество();
        КонецЕсли;        
    КонецЦикла;    
    
    
    
    Если Форма.ЭлементыФормы.ДействияФормы.Кнопки.Найти("Выгружать") = Неопределено Тогда
    КП = Форма.ЭлементыФормы.ДействияФормы.Кнопки;    
    инд = КП.Количество();
    ПодМенюВыгружать = КП.Вставить(инд,"Выгружать", ТипКнопкиКоманднойПанели.Подменю, "Выгружать");
    ПодМенюВыгружать.Отображение = ОтображениеКнопкиКоманднойПанели.НадписьКартинка;
        
    ДействиеКнопкиДа = Новый Действие ("ПриОткрытии");
    ДействиеКнопкиНет = Новый Действие ("УстановитьКнопкиПодменюЗаполненияТЧ");


    индкн = ПодМенюВыгружать.Кнопки.Количество();
    ПодМенюВыгружать.Кнопки.Вставить(индкн,"Да", ТипКнопкиКоманднойПанели.Действие,"Да",ДействиеКнопкиДа);
    ПодМенюВыгружать.Кнопки.Да.Картинка = БиблиотекаКартинок.Галочка;
    ПодМенюВыгружать.Кнопки.Да.Отображение = ОтображениеКнопкиКоманднойПанели.НадписьКартинка;
        
    ПодМенюВыгружать.Кнопки.Вставить(индкн+1,"Нет", ТипКнопкиКоманднойПанели.Действие,"Нет",ДействиеКнопкиНет);
    ПодМенюВыгружать.Кнопки.Нет.Картинка = БиблиотекаКартинок.Крест;
    ПодМенюВыгружать.Кнопки.Нет.Отображение = ОтображениеКнопкиКоманднойПанели.НадписьКартинка;
    КонецЕсли;
    
КонецПроцедуры    

Процедура Выгружать(Форма)Экспорт
    
    НазваниеДокумента = Метаданные.НайтиПоТипу(ТипЗнч(Форма)).Имя;
    ИндДок = Метаданные.Документы.Найти(НазваниеДокумента);
    ИмяФормы = ИндДок.Формы.ФормаДокумента.Имя;
    Форма1 = Форма.ПолучитьФорму(ИмяФормы);                                                  
    
    Форма1.Выгрузка = Истина;
    КП = Форма1.ЭлементыФормы.ДействияФормы.Кнопки;
    КП.Выгружать.Картинка = БиблиотекаКартинок.Галочка;
    
КонецПроцедуры

Процедура НеВыгружать(Форма)Экспорт
    НазваниеДокумента = Метаданные.НайтиПоТипу(ТипЗнч(Форма.ДокументОбъект.Ссылка)).Имя;
    ИндДок = Метаданные.Документы.Найти(НазваниеДокумента);
    ИмяФормы = ИндДок.Формы.ФормаДокумента.Имя;
    Форма1 = Форма.ПолучитьФорму(ИмяФормы);
    Форма1.Выгрузка = Ложь;
    
    КП = Форма1.ЭлементыФормы.ДействияФормы.Кнопки;
    КП.Выгружать.Картинка = БиблиотекаКартинок.Крест;
    
    //Shell = Новый COMОбъект("WScript.Shell");
    //НажатиеМышки = shell.run("rundll32.exe user32.dll, mouse_event 1", 1, "true");

КонецПроцедуры
Просмотров: 192, последний комментарий от EritikWoW   
рассылка документов из 1С по контрагентам [раздел Программирование в 1С Предприятие 8.3]
Автор A.Frost89 — 25.04.17, 13:56 — 4 комментариев
Добрый день. Бухгалтерия предприятия КОРП 3.0.49.23 . Есть обработка, которая отправляет документы - акт об оказании услуг, счета-фактуры, счета на оплату покупателей, контрагентам - списку либо единичным. Документы сохраняются в формате pdf, учетная запись используется 1С-ная настроенная. Все бы ничего, но при отправке документов контрагентам, сколько документов было выбрано для отправки, столько писем на почтовый адрес и приходит. Что не есть хорошо. Как сделать так, чтобы одному контрагенту, приходило одно письмо с вложенными документами, сколько бы их там не было выбрано?
p.s. Прикладываю [необходимо зарегистрироваться для просмотра ссылки].честно, она не моя. счета кое-как подправил под себя. их цепляет и отправляет. а при выборе акта, наблюдаются проблемы. видимо из-за изменения конфы. но надеюсь что подправлю со временем.
p.p.s. в программировании начинающий,так что учусь, просьба не ругаться если буду тупить. Буду рад любой помощи/подсказке/совету.
Просмотров: 174, последний комментарий от Bernet   
Залипла дата в документах [раздел Программирование управляемых форм 1С 8.2]
Автор kot488 — 25.04.17, 12:54 — 10 комментариев
Есть в самописной базе документ. В нем есть кнопка заполнить с помощью которой в него заполняются все определенные документы указанного типа. На скрине документ правильный, с правильными датами. Но дата в заголовке почему то 03.04.2017


Это под моей учетной записью.
А у некоторых пользователей, в этом документе отображается дата что документы созданы 03.04


Хотя если зайти в сам документ то в нем правильная дата, 23.04. И даже документы от 31.03 пользователю показывает как 03.04

Что за глюк? Кеш почистил


и все новые документы тоже создаются с датой 03.04
Просмотров: 162, последний комментарий от kot488   
Закрытие заказов покупателей: снятие с резерва [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 25.04.17, 11:30 — 7 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

На сколько я понял, автоматически снятие с резерва товаров не предусмотрено.
В связи с этим, можно ли с документом "Закрытие заказов покупателей" сделать буквально следующее:

Т.к. планируется выполнять только определенный алгоритм действий, то можно ли при открытии этого документа, если он новый,
программно настроить все опции.

Т.е. Операция: снятие с резервов.
И автоматически заполнить все заказы, требующие снятия с резервов без захода на посадку в меню "Заполнить" с выбором определенных опций.

Ну или другой вариант программирования снятия резервов со склада?
Просмотров: 135, последний комментарий от Petre   
Условное оформление формы динамического списка [раздел Программирование управляемых форм 1С 8.2]
Автор RomarioMen — 24.04.17, 11:18 — 6 комментариев
1С 8.2 УНФ для Украины. Редакция 1,3.
Всем привет! Установил условное оформление дин. списка в конфигураторе, но оно работает только в пользователей с полными правами.
В ост. все красит одним цветом. Подскажите, плиз, куда смотреть?
Просмотров: 180, последний комментарий от logist   
Как определить, что база запущена на андроиде? [раздел Мобильная платформа 1С]
Автор Gavrila — 21.04.17, 23:36 — 8 комментариев
Есть самописная небольшая база. Работает на веб-клиенте.
Хочу ее адаптировать под планшет. Подскажите, как определить при запуске, программа запущена на андроиде или на веб-клиенте?
В идеале хотелось бы режим запуска сохранить в параметрах сеанса
Просмотров: 224, последний комментарий от logist   
Стоимость часа 1С-ника [раздел Тематическое общение]
Автор rotting — 21.04.17, 17:08 — 25 комментариев
Задумался не мало ли я беру денег за работу. Сам беру 450 грн/час (~$15). Хотел бы устроить небольшой опрос. Сколько вы берете за час работы (Киев)?
Просмотров: 634, последний комментарий от XBrut   
Форма выбора для формы Отбора и Сортировки [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 21.04.17, 15:39 — 4 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Для справочников, возможно создать несколько форм выбора и наложить на них какие-либо условия при открытии, например для фильтрации вывода на экран с ограничениями...

Для склада сделал 2-е формы отбора: Основная (с фильтрацией) и "ФормаВыбораВсе" (без каких либо ограничений)

Просматриваю список документов "Перемещение товаров". Там имеется склад Отправитель и склад Получатель.
На склад Отправитель поставлена форма выбора Основная (с фильтрацией), на склад Получатель - форма выбора "ФормаВыбораВсе", т.е. без ограничений с возможностью выбрать любой склад...

Это все нормально, но вот столкнулся с такой проблемой...

В списке документов Перемещений требуется открыть форму "Отбор и Сортировка" и проводить там фильтрацию по обоим типам складов.

При открытии в "Отборе и Сортировки" склада Отправитель отрабатывает основная форма выбора склада с ограничением - это так и правильно...
При открытии склада "Получатель" тоже открывается основная форма выбора, что по условиям задачи - не правильно: нужно открытие формы "ФормаВыбораВсе"...

В реквизитах и на всех формах документа Перемещения на склад Получатель поставил в свойство форма выбора - "ФормаВыбораВсе", но открывает все равно основную...

Каким образом в форме "Отбор и Сортировка" можно прописать при отборе нужную форму отбора справочников??? Я так понял, что используется основная форма отбора справочника...
Просмотров: 197, последний комментарий от Constantus   
Отчет Валовая прибыль в СКД [раздел Система компоновки данных]
Автор AlexeyMalko — 21.04.17, 13:40 — 5 комментариев
1С:Предприятие 8.3 (8.3.7.1949)
"Управление торговым предприятием для Украины", редакция 1.2.
Разработка конфигурации: "ABBYY Ukraine", 2007-2017 (1.2.41.1)
Хочу добавить поля для расчёта себестоимости - ещё два ресурса с Регистров накопления (добавить колонки по расчёту затрат на Перевозку и бонусы менеджеров) , но не получается. Хочу сделать в СКД но выдаёт ошибку при попытке сохранить Запрос, ругается на поле "Итоги". Код не привожу потому что он типовой, кто нибудь пробовал , в чём ошибка и как исправить?


 ! 

Правила: 3
 
Просмотров: 199, последний комментарий от Bernet   
Передать значение адреса объекта с клиента на сервер [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 20.04.17, 17:22 — 7 комментариев
Всем привет уважаемые форумчане и специалисты!

Гуууу! Сколько уже вожусь и никак не получается...перерыл везде, где мог и ничего не нашел, как сделать следующее:Допустим есть справочник: "ОБЪЕКТ". И нужно, что бы из формы этого справочника по указанному адресу был найден указанный код реквизита на сервере, но в другом справочнике, на пример в списке справочника "ТОЧКА". Для чего есть команда: "НайтиПоКоду". И вроде бы с этим все получилось по вот такой схеме:

 
&НаКлиенте
Процедура Тест_Пойск(Команда)
    ТекстКода="000000001";
    текзначение=ПолучитьКод("СпрТочки", ТекстКода);
    сообщить(текзначение);
КонецПроцедуры

&НаСервере
Функция ПолучитьКод(Путь, ТекстПойска)
    Если Путь="СпрТочки" Тогда
        ПутьСпр = Справочники.ТОЧКА;  
        Возврат ПутьСпр.НайтиПоКоду(ТекстПойска);
    Иначе
        Возврат неопределено;
    конецесли;
КонецФункции


Но дело в том, что этот путь не удовлетворяет цель. которая в следующем:
Создать функцию для сервера с параметром адреса указанного на Клиенте.
Ибо функция для того и нужна, что бы для каждого случая не писать ее отдельно.
Т.е. суть вопроса в том, что бы код функции оставался неизменным. И что в ней было прописано то, что она должна сделать.
А все .... необходимые параметры, что бы можно было задавать на клиенте.
К сожалению указанный вариант годиться для индивидуального случая. Т.е. когда адрес поиска: Справочники.ТОЧКА.
А если другой адрес? Тогда его опять нужно указывать на сервере.
Вообще, нельзя ли сделать так, что бы на клиенте можно было указать любой адрес поиска.
И это для параметра одной и той же общей функции на сервере. Просто передать ЛЮБОЙ адрес. Который может меняться.

Вот в чем вопрос!

Буду очень признателен за ответ и за помощь!
Если кто то подкорректирует ....

 ! 

Правила: Правда так лучше код выглядит? тема переехала в раздел 8.3
 
Просмотров: 271, последний комментарий от Gigi   
Начальный И Конечный остаток в отчете на СКД [раздел Система компоновки данных]
Автор Gazulo — 20.04.17, 15:15 — 6 комментариев
Конфигурация УТП 1.2.41.1. Делаю отчет на СКД по регистру ВзаиморасчетыСКонтрагентамиПоДокументамРасчетов.
Группировки Контрагент, Документ расчетов и Регистратор, надо чтобы по регистратору выводило только обороты

Сделал так:
ВЫБОР
КОГДА ВзаиморасчетыПоДокументам.ПериодСекунда = &НачалоПериода
ТОГДА ВзаиморасчетыПоДокументам.СуммаВзаиморасчетовНачальныйОстаток
ИНАЧЕ 0
КОНЕЦ

Но если документ регистратор проведен началом периода тогда
начальный остаток выводится и остаток по верхним группировкам не правильный .
Просмотров: 225, последний комментарий от Gazulo   
Фильтр формы списка документов [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 20.04.17, 14:04 — 6 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Для ограничения просмотра некоторых документов, например, Реализация, на код при открытии повесил следующее:

    ЭтаФорма.Отбор.Склад.Использование=Истина;
    ЭлементыФормы.Список.Значение.Отбор.Склад.ВидСравнения = ВидСравнения.ВСписке;
    ЭлементыФормы.Список.НастройкаОтбора.Склад.Доступность = Ложь;
............................
    ЭтаФорма.Отбор.Склад.Значение = СписокДокументов;


Где "СписокДокументов", т.е. доступных для просмотра складов...

Код работает исправно. Список открывается с нужными фильтрами, и изменить список доступных складов в форме Отбора и сортировки - невозможно...

Но вот столкнулся с такой ситуацией...
Предположим имеется 10 складов, из них только 3-м складам имеется допуск... В результате я вижу только те Реализации, где присутствуют те 3-и элитных склада.

Но вот теперь пользователю хочется отфильтровать Реализации по одному из этих складов, а доступ к редактированию списка доступных складов закрыт.
Если снять доступность, т.е. сделать её редактируемой, то легким движением руки список превращается в желтую прессу доступной по всем складам.

Можно ли сделать так, чтобы на форме "Отбор и сортировка" поле значения складов осталось редактируемым, несмотря на то, что доступность = ложь?

Просмотров: 216, последний комментарий от Constantus   
Избирательный план обмена [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 19.04.17, 16:49 — 2 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Сделал обмен на базе "Полного обмена". Обмен работает.

Как можно сделать так, чтобы из Центральной базы не перегонялись, например, продажи, но с филиала в Центральную поступали все данные по их продажам?...

Т.е. сделать избирательный обмен, а то сейчас в филиальную часть гонятся все данные Центра, что филиалу вообще не нужно...

На филиал передаются данные по новым номенклатурам, перемещениям товаров на филиальные склады, а обратно передаются данные только по продажам филиала... Одним словом, чтобы Центр мог видеть отчетность по филиалу...

Просмотров: 167, последний комментарий от Constantus   
RSS Текстовая версия Сейчас: 30.04.17, 13:09
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне