Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
УПП 1.3 Документ Электронные Письма [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор alexandr_f — 15.07.19, 11:09 — 2 комментариев
Нужно послать письмо через документ Электронные Письма.
Все есть - только не могу понять формат заполнения Строки Копия (нужно послать в несколько адресов). что-то сохраняется только последний адрес
Просмотров: 38, последний комментарий от alexandr_f   
Отбор в запросе по уникальному индентификатору [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 15.07.19, 10:45 — 3 комментариев
Приветствую, Форумчане!
1с8.3.12, самопис, БСП, УФ

Создаю массив уникальных индентификаторво "КлючСтроки" из ТЧ

    Для Каждого Ключа Из Объект.Окантовано Цикл
        МассивКлючей = Новый Массив;
        МассивКлючей.Добавить(Ключа.КлючСтроки);
    КонецЦикла;



Имеется некий запрос, где пытаюсь исключить из записей все данные, где есть такиеже КлючиСвязи (УИД)

"ВЫБРАТЬ
    |    ЗаказМодельИКомплектация.Ссылка КАК Заказ,
    |    ЗаказМодельИКомплектация.Номенклатура,
    |    ЗаказМодельИКомплектация.Модель КАК Модель,
    |    ЗаказМодельИКомплектация.РазмерИзделия КАК Размер,
    |    ЗаказМодельИКомплектация.ПолировкаИзделия КАК Полировка,
    |    ЗаказМодельИКомплектация.КлючСтроки
    |ИЗ
    |    Документ.Заказ.МодельИКомплектация КАК ЗаказМодельИКомплектация
    |ГДЕ
    |    ЗаказМодельИКомплектация.Ссылка = &ТТН
    |    И НЕ ЗаказМодельИКомплектация.КлючСтроки В (&ПараметрКлючей)

    Запрос.УстановитьПараметр("ТТН", Объект.ВыбранныйЗаказ);
    Запрос.УстановитьПараметр("ПараметрКлючей", МассивКлючей);


Выдает ошибку, что нельзя сравнивать неограниченную длину и несовместимые типы.

Везде "КлючСтроки" тип одинаковый "УникальныйИдентификатор"

Как правильно провести операцию исключения из запроса с

И НЕ ЗаказМодельИКомплектация.КлючСтроки В (&ПараметрКлючей)


Просмотров: 51, последний комментарий от fly   
Не могу найти работу с опытом [раздел Тематическое общение]
Автор TabletPSC — 14.07.19, 19:40 — 10 комментариев
Добрый день.

Надеюсь не ошибся с разделом.

1. Опишу вкратце мой опыт.
2. Проблемы с которыми столкнулся при поиске нового места работы.


1. Собственно мне 26 лет, попал в 1С через курсы в франч (живу в мегаполисе Украинском), ставка была на около 175 грн за час. Работал на сопровождении. Сдал профа через несколько месяцев после устройства во франач, готовился на специалиста, из-за серьёзной загрузки бросил эту затею. Проработал во франче около 2-ух лет. От меня требовали : взять заявку, прийти, анализ, тз, сделать, оплата от клиента. Иногда привлекал аналитиков или консультантов на проект. В основном пачками задачи по сопровождению конфигураций БП, УТ, УТП, УПП, Розница, ЗУП, КА и их аналоги на упр формах примерно 50% обычные 50% упр. Из внедрений которые доверили это было отраслевая БП с большими различиями(доработки) по З,П., Розница в местный ресторан. УТ + интеграции с разными web сервисами типа Битрикс в местный магазин.

Ушел с франча, в связи с тем, что вектор задач был не в 1 области, очень обширный + "От меня требовали : взять заявку, прийти, анализ, тз, сделать, оплата от клиента.", а в этой цепочке могли случится трудности (на последнем этапе) и денег я своих и не видел по несколько месяцев.

Устроился в контору которая занималась EDI по России.
Было несколько решений на основе 1С и их интеграций в клиентские конфы. Моя задача состояла (и других ребят) разработка нового функционала, поддержка текущий решений внедренных и внедрение новых. Так после 7 месяцев, удалось поработать ведущим программистом, т.к. резко упал круг областей знаний по сравнению с франчом, удлось очень быстро освоится.

Помимо знакомства с большинством упр/обыч формы российскими конфами, ежедневно работал с xml/json/web сервисами/sql.
Из знакового: делал серьёзный рефракторинг решений, углублялся в быстроедествие того или иного участков кода. Так же удалось поруководить, придумать архитектуру, и в том числе и разрабатывать вместе командой(около 5 человек + 3 консультанта) решения работе с (Меркурием)

Ушел на втором году работы, сменилось начальство и был ад.

Дальше попал в производственную контору.

УНф+производственный модуль отраслевой + УПП + БП + ЗУП. Сопровождал в месте с еще 1 человеком + 1 аналитик + 1 аутсорс.

Из знакового : был хаос на складах, разработал систему под ячеечное хранение. Успешно внедрил, пользуются. Интеграции с telegram, трекинг заказов. Почтовые сервисы(украина/россия/казахстан) тоже интеграции. Интеграции с google docs.

Попросил меня уйти через время(причина была рандномная)

Собственно опыта у меня набралось около 4-5 лет.

2. Вышел на рынок, разместил резюме, полились звонки.

Я в принципе не привередлив, уживаюсь нормально с коллективом. К разного рода переработкам отношусь спокойно. Не опаздываю. Т.е. меня устраивают в большинстве случаев почти все предложения в вакансиях кроме з.п.

Примерно как проходит собеседование с очередным откликом ( моим или их):
Тестовое по их желанию делаю, вопросов возникало в 2% случаев и то на месте решались.
Опыт работодателя обычно устраивает, часто упоминают об этом в процессе разговора.
В конце(или начале) обычно говорим о з.п., процентов 95 это вопросы их по типу "Сколько вы бы хотели?". Я отвечал все подряд, все перепробовал. В основном я ссылаюсь на ставки во франчах(знакомые) и аутсорс(есть опыт периодеческий) и множу их на 160 или 120 рабочих часов. Ставки разные, мало ребят знаю с опытом которые работают ниже 300, да и сам брал периодически от старых клиентов от 300 до 500 за час в зависимости, что там за работа.

За последние 4 месяца, я видел около 2-3 откликов которые хоть как-то коррелируються с моими мыслями. В основном это в 2 даже в 3 раза ниже того, на, что я примерно думал (выше).

Хотелось бы ваших советов.
Что так все плачевно на фирмах?
Может я перегибаю и цифры действительно ниже в 2-3 раза?
Может есть какие-то мысли или какой был у вас опыт с устройством на работу и ожидаемые/реальные доходы.

p.s. +- на том же аутсорсе мне на жизнь хватает. Я просто ищу параллельно, что-то своё.
Просмотров: 175, последний комментарий от awp   
Выгрузить категорию на сайт [раздел Программирование в 1С Предприятие 8.3]
Автор burza — 12.07.19, 13:42 — 1 комментариев
нужно выгрузить на сайт категории с родителями, только не стоковые а я сделал сам где по иерархии будет лежать товар на сайте. нужно выгрузить свои категории на сайт а не те которые есть в объекта номенклатуры.
То есть в 1С своя иерархия а на сайте другая.


где тут это подправить?

Процедура ПутьКатегории(ТекОбъект, ВерхнийКод)
    ТекУровень = ТекОбъект.Уровень();
    Если ТекУровень > УровеньКорневойКатегории Тогда
        ПутьКатегории(ТекОбъект.Родитель, ВерхнийКод);
    КонецЕсли;
    CategoryPath(ВерхнийКод, СокрЛП(ЗаменитьПрефиксы(ТекОбъект.Код)), Строка(ТекУровень - УровеньКорневойКатегории));
КонецПроцедуры

//******************************************************************************
// Рекурсивная процедура заполнения описания категорий
Процедура КатегорииТовара(ТекОбъект, ВерхнийКод, ВерхнийУровень)
    
    ТекУровень = ТекОбъект.Уровень();
    Если ТекУровень > УровеньКорневойКатегории Тогда      
        КатегорииТовара(ТекОбъект.Родитель, ВерхнийКод, ВерхнийУровень);
        КодРодителя = СокрЛП(ЗаменитьПрефиксы(ТекОбъект.Родитель.Код));
        Топ = "0";
    Иначе
        КодРодителя = "0";
        Топ = "1";
    КонецЕсли;     
    Если ТекУровень < ВерхнийУровень Тогда
        ТекКод    = СокрЛП(ЗаменитьПрефиксы(ТекОбъект.Код));
        ТекИмя    = СокрЛП(ТекОбъект.Наименование);
        Описание  = СокрЛП(ТекОбъект.Описание);
        ИмяЧПУ = СокрЛП(?(Транслитерация, Транслит(ТекИмя), ТекИмя));
        ИмяЧПУ = СтрЗаменить(СтрЗаменить(СтрЗаменить(ИмяЧПУ, " ", "-"), "+", "_"), "&", "_");
        ЧислоСтолбцов = 1;
        meta_title = "";
        meta_description = "";
        meta_keyword = "";
        seo_title =  "";
        seo_h1 =  "";    
        Category(ТекКод,
                    КодРодителя,
                    ТекИмя,
                    ИмяЧПУ,
                    СокрЛП(Описание),
                    Топ,
                    Строка(ТекущаяДата()),
                    ФорматДВ,
                    ЧислоСтолбцов,
                    meta_title,
                    meta_description,
                    meta_keyword,
                    seo_title,
                    seo_h1,
                    ?(Перезаписывать, "0", "1")
                    );                    
        Product2Category(ВерхнийКод, ТекКод, Топ);
        ПутьКатегории(ТекОбъект, ТекКод);
    КонецЕсли;    
КонецПроцедуры
Просмотров: 91, последний комментарий от burza   
Событие отмены в списке значений [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 12.07.19, 10:11 — 6 комментариев
Всем привет!
Гууу ... Не на что уже нет настроения... Просто нет ... все ПУСТО ВОКРУГ.
Ладно пардон ... не обращайте внимание ...
Вот код простого типа:
спЗначений = Новый СписокЗначений();
спЗначений.Добавить("Значение1","Представление1");
спЗначений.Добавить("Значение2","Представление2");
ВыбранныйЭлементСписка = спЗначений .ВыбратьЭлемент();
Если ВыбранныйЭлементСписка = Неопределено Тогда  Возврат; КонецЕсли;

Но это когда без флажков. Т.е. когда нужно сделать один единственный выбор.
Теперь код для множественного выбора в списке.
//==========================    
    ствПеречень=Новый Соответствие();
    ствПеречень.Вставить("Значение1","Представление1");
    ствПеречень.Вставить("Значение2","Представление2");
    ствПеречень.Вставить("Значение3","Представление3");
    ствПеречень.Вставить("Значение4","Представление4");
//-----------------------------------------------    
    ствВыбрНеВыбрЗначения=Новый Соответствие();
    спЗначений = Новый СписокЗначений();
    Для Каждого Эл Из ствПеречень Цикл
        спЗначений.Добавить(Эл.Ключ,Эл.Значение);
    КонецЦикла;
    спЗначений.ЗаполнитьПометки(Истина);  
//-----------------------------------------------
    Если спЗначений.ОтметитьЭлементы("Выводить") Тогда
        Для Каждого знВыбор Из спЗначений Цикл
            Если знВыбор.Пометка Тогда
                ствВыбрНеВыбрЗначения.Вставить(знВыбор.Значение,Истина);
            Иначе
                ствВыбрНеВыбрЗначения.Вставить(знВыбор.Значение,Ложь);
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;
//==========================    
Если Вопрос("Создать отчет данных энергосистемы в формате Excel?",РежимДиалогаВопрос.ДаНет,,,"Отчет в формате Эксель")=КодВозвратаДиалога.Нет Тогда Возврат; КонецЕсли;

Короче что надо ... опять очередная ерунда. .. с которой уже сижу час и опять ищу методом тыка.
Во втором варианте кода нужно зафиксировать событие когда пользователь нажал на кнопку отменить.
В первом простом варианте это как указано делается таким путем:
Если ВыбранныйЭлементСписка = Неопределено Тогда  Возврат; КонецЕсли;

Нужно то же самое только для второго варианта ... т.е. для списка значений с множественным выбором.
Ибо согласно выше указанного кода диалог вопроса:
Если Вопрос("Создать отчет данных энергосистемы в формате Excel?",РежимДиалогаВопрос.ДаНет,,,"Отчет в формате Эксель")=КодВозвратаДиалога.Нет Тогда Возврат; КонецЕсли;

в любом случае всплывает. Даже в случае если пользователь в окне списка значений нажал на кнопку отменить.
А нужно что бы действие переходило на следующую линию кода только тогда когда нажали на кнопку "Ок". А когда нажали на "Отменить" нужно что бы действие останавливалось.
Вот что нужно...
И вот эта вот ерунда. С которой уже сижу час.
Так что если можно строчу кода в помощь.
Буду признателен!

Gigi @ Сегодня, 10:31 * ,
Вы куда все подевались уважаемые? ))
Гууу... я вроде просил строчку кода. Всего одну строчку ..
Не думаю что больше нужно будет. Хотя от этой системы всего можно ожидать. Потому что в ней наверно "сложное всегда просто", как и все гениальное )).. а не наоборот.
Короче вопрос открыт..
Жду вашего отклика!
И буду признателен!

Просмотров: 146, последний комментарий от Gigi   
Где можно прочитать о написании драйверов для торгового оборудования? [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор mak — 12.07.19, 9:23 — 1 комментариев
Подскажите где можно прочитать о написании драйверов для торгового оборудования? Спасибо
Просмотров: 54, последний комментарий от Petre   
Не реагирует на текущий элемент со свойством только просмотр [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 11.07.19, 16:33 — 1 комментариев
Приветствую, Форумчане!
1с 8.3.12, БСП, самопис, УФ

После перехода с 8.3.6 на *.12 возник странный эффект. Есть Код:

&НаКлиенте
Процедура РаботыПередНачаломИзменения(Элемент, Отказ)
    // Вставить содержимое обработчика.
    ТекущиеДанные = Элементы.Работы.ТекущиеДанные;
    
    Если НЕ Отказ
        И Элемент.ТекущийЭлемент = Элементы.РаботыЦенаДляЗаказчика Тогда //107174
        Отказ = НЕ ТекущиеДанные.РазрешеноРедактированиеЦен;
    КонецЕсли;

КонецПроцедуры


Поле табличной части "Работы" - ЦеныДляЗаказчика в конфигураторе стоит как "ТолькоПросмотр"

На предыдущей версии данный код срабатывал и давал возможность вносить изменения в это поле, т.е. если в текущей записи есть галка разрешить, то "Отказ = Истина" и изменяй на здоровье.

Т.е. даже если поле не доступно (только чтение), то 1с знал, что текущий элемент такой-то...

На новой версии код перестал работать и поле остается недоступным. Отладчик даже не прерывается, если тыкаешь в него и Элемент.ТекущийЭлемент не считывается для проверки условия...

Что такого катастрофического произошло? Как это побороть?
Просмотров: 72, последний комментарий от Petre   
Не дает ввести в поле ввода значение (1с 8.2.19.106) [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор andrew76 — 11.07.19, 4:08 — 3 комментариев
Доброе утро !

Имеется подчиненный справочник "Ученые степени".Способ редактирования - в Диалоге.
Не вводится значение в поле ввода ,пока не нажмешь клавишу unsert,.хотя редактирую суўествуюўую запись.Реквизит справочника - строковый , длина 50.Допустимая длинағпеременная.
Установлен многострочный режим для реквизита.В чем может быть проблема ?
Просмотров: 118, последний комментарий от andrew76   
Поиск и подбор номенклатуры [раздел Программирование в 1С Предприятие 8.3]
Автор Dantist — 10.07.19, 10:22 — 3 комментариев
Всем привет. Есть вопрос: каким образом можно реализовать подобную вещь?



1С:Предприятие 8.3 (8.3.13.1690), версия конфигурации 3.2.8.1
Просмотров: 107, последний комментарий от Vofka   
7.7 Управление положением колонок в табличной части документа [раздел Программирование в 1С Предприятие 7.7]
Автор Lunatik_55 — 10.07.19, 9:03 — 1 комментариев
Добрый день. Есть табличная часть документа, где каждая колонка состоит из двух строк (каждая вторая колонка имеет положение "на следующей строке"). Задача скрыть от некоторых пользователей нижнюю часть колонок. Но методом видимость не получается скрыть нижнюю часть колонки, только всю колонку состоящую из двух строк.
Была идея перед тем как скрывать, программно менять положение колонок с "на следующей строке" на "новая колонка", но не нашел как сделать это программно.
Пробовал сделать через 1с++ табличное поле (я в этом не силен), но там другая проблема, не получается сделать автоматический переход к следующей колонке после ввода значения. Автопереход или не работает или я не нашел как его сделать.

Может кто нибудь подскажет как можно реализовать поставленную задачу?
Просмотров: 89, последний комментарий от mut   
Как создать таблицу значений. Пример. 1с 7.7 конф 7.7.003 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 10.07.19, 1:29 — 6 комментариев
Здравствуйте!
Мне нужно создать таблицу значений, в которой будут отражаться различньіе данньіе с различньіх документов и справочников и с которой я буду работать ежедневно. Перелопатил весь интернет - нет ни одного конкретного примера по именно созданию такой таблицьі. Мне не понятно, код таблицьі пишется в модуле формьі, или в модуле документа? Ответа не нашел. Много информации, как работать с уже созданной таблицей, и почти нет информации, как она создается.
Господа, опять же, не прошу мне ничего разжевьівать. Кратко скажите, где писать ее код. Или дайте ссьілку конкретного примера. Или где почитать. Спасибо.
Просмотров: 139, последний комментарий от mut   
Работа с QR Code при помощи типовой КомпонентаПечатиQRКода [раздел Программирование в 1С Предприятие 8.3]
Автор kosalex — 09.07.19, 13:01 — 5 комментариев
Доброго времени суток!
Подскажите какие методы есть у типовой КомпонентаПечатиQRКода ? В интернете нигде не могу найти примера. Везде с использованием сторонних библиотек.
Задача у меня следующая, сгенерировать QR-Code и сохранить его в картинку.
В самой конфигурации нет примера работы с этой компонентой.
Просмотров: 153, последний комментарий от kosalex   
Общая форма не раскрывается во весь экран [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 09.07.19, 10:46 — 3 комментариев
Приветствую, Форумчане!
1с.8.3.13, БСП, самопис, УФ

Прямого отношения к программированию не имеет, приношу извинения, но более правильной ветки не нашел

Ранее на 8.3.6 работали и перешли на 8.3.12

В документе Заказ на панели навигации есть ссылка на "Присоединенные файлы" . Это общая форма, где отображаются графические файлы к этому документу.

После перехода на 8.3.12 эта общая форма не раскрывается по вертикали и горизонтали на весь экран.

Где хранятся эти настройки, чтобы при активации раскрывалась эта форма во весь экран? Уже всё, где нашел поставил расширять по вертикали и горизонтели, но как стоит скромно с полосами прокрутки, так и стоит

Подскажите...

_________________________________________________________________

Такая же ерунда и с другим документом, точнее с выводом формы списка по команде:

Код
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    ПараметрыФормы = Новый Структура("Отбор", Новый Структура("Заказ", ПараметрКоманды));
    ОткрытьФорму("Документ.Ретушь.ФормаСписка", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка);
КонецПроцедуры


Документ.Ретушь.ФормаСписка тоже не раскрывается во весь экран, а скромно выходит маленькой с полосами прокруток

//------------------------------------------------

Если вызывать эти документы через правую клавишу в отдельном окне, то форма раскрывается по полной программе
Просмотров: 169, последний комментарий от python   
Где находится форма расходной накладной в 1С 7.70.003 торговля склад для Украины? [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 05.07.19, 13:48 — 6 комментариев
Здравствуйте. Мне нужно доработать 1С под себя. Начинаю изучать. Надо добавить дополнительные несколько справочников и дополнительные поля в расходную накладную. Но столкнулся с проблемой. Не могу найти форму расходной накладной. Формы остальных документов есть, где им положено быть, а вот формы расходной накладной нет. Есть реквизиты, модуль, а там, где должна быть форма расходной накладной, есть только форма ее вкладки. Где доверенность, и кто отпустил. Я ее долго искал в других документах, но так и не нашел. Помогите, пож начинающему. Я не прошу научить программировать, у меня есть учебник онлайн, скажите, где находится форма, а то я не могу начать)))
Спасибо.
Для информации. Хочу доработать программу для нужд сервисного центра. Хочу добавить справочники моделей и производителей аппаратуры, добавить в расходную поля серийного номера, заявленной неисправности, модели, производителя, добавить акт приема в ремонт, и т.д. Попытаюсь сделать сам. Вопрос времени. Если не смогу, тогда буду искать спец программиста.
Спасибо!
Просмотров: 177, последний комментарий от ZUBR   
вывести 2 отчета на 1лист [раздел Система компоновки данных]
Автор MrIgor — 04.07.19, 15:56 — 4 комментариев
Приветствую, уважаемые форумчане.
Задали тут задачку из разряда "Нарисовать 5 красных литий 3 из которых зеленые"...

Заказчик желает видеть 2 отчета на 1 листе. Есть отчеты дебиторка и остатки по складу нужно их расположить на 1м листе.
То есть открываем форму отчета задаем период. Нажимаем кнопку сформировать Отчеты формируются и на выходе получаем типа такого



Это вообще реально?
Просмотров: 151, последний комментарий от MrIgor   
Пользователь не может переопределить отбор [раздел Система компоновки данных]
Автор fitzfootbet — 01.07.19, 16:40 — 4 комментариев
Обычное приложение CRM 2.0

Подскажите пожалуйста как можно переопределить отбор в режиме 1С Предприятие пользователем и сохранить настройки отличные от тех что в конфигураторе
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    
Параметры = КомпоновщикНастроек.Настройки.ПараметрыДанных;
Пользователь = ПараметрыСеанса.ТекущийПользователь;
Сотрудник = Справочники.Пользователи.НайтиПоНаименованию(Пользователь.Наименование);
Параметры.УстановитьЗначениеПараметра("Сотрудник", Сотрудник);
    
КонецПроцедуры


Отбор устанавливался в Модуле объекта , в параметрах самой схемы СКД указывается Сотрудник , ну и в запросе сам отбор.
Может что то лишнее указываю? проблема в том что пользователь не может переопределить отбор , он не сохраняется и не отбирается по новым настройкам.
Просмотров: 161, последний комментарий от Vofka   
Отбор по максимальному значению в результате запроса [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 27.06.19, 16:49 — 8 комментариев
Приветствую, Форумчане!
1с.8.3.6, самопис, БСП, УФ

Имеется результат некоего запроса:

Вася_3
Вася_2
Вася_1

Петя_4
Галя_3
Олег_4
Олег_1

Саша_2
Гоша_3
Гоша_2


Как видно, есть имена с одной позицией, а есть имена с несколькими позициями с разными цифрами

Требуется оставить тех, кто имеет одно значение, а те, кто имеет несколько значений, оставить с максимальной цифрой, т.е.:


Вася_3
Петя_4
Галя_3
Олег_4
Саша_2
Гоша_3

Никак не могу составить запрос на базе этого результата. Подскажите.
Просмотров: 250, последний комментарий от sava1   
Ссылка на Документ основание [раздел Программирование в 1С Предприятие 8.3]
Автор jojojoba2 — 26.06.19, 16:00 — 4 комментариев
Добрый день!

В 8.3 УПП в документе РеализацияТоваровИУслуг необходимо скопировать данные из табличной части ТОВАРЫ документа основания Заказ Покупателя. Написал запрос но не знаю как в запросе сослатся на данные каторые есть в документе основании (на товары каторые есть в табличной части Заказ Покупателя).

Процедура СкопироватьТовары2(ТабличнаяЧасть,ДокументОснование) 
    
        Если ТабличнаяЧасть = Товары   Тогда
    
    
        ДатаОстатков = ОбщегоНазначения.ПолучитьДатуОстатков(ЭтотОбъект);
              
        Запрос = Новый Запрос;
        
            Запрос.УстановитьПараметр("ДокументОснование", ДокументОснование);
        Запрос.УстановитьПараметр("ПустойСклад", Справочники.Склады.ПустаяСсылка());
        Запрос.УстановитьПараметр("ДатаОстатков", ДатаОстатков);
        
        Запрос.Текст ="ВЫБРАТЬ
                      |    Товары.НомерСтроки,
                      |    Товары.Номенклатура,
                      |    Товары.Количество,
                      |    Товары.ЕдиницаИзмерения,
                      |    Товары.Коэффициент,
                      |    Товары.Цена,
                      |    Товары.ПроцентСкидкиНаценки,
                      |    Товары.Сумма
                      |ИЗ
                      |    Документ.РеализацияТоваровУслуг.Товары КАК Товары   ";
                
        
        РезультатЗапроса = Запрос.Выполнить();
        
        Если РезультатЗапроса.Пустой() Тогда
            Возврат;
        КонецЕсли;
        
        ДобавленКомплект = Ложь;
        Выборка          = РезультатЗапроса.Выбрать();
        
        Пока Выборка.Следующий() Цикл
                        
                        
            НоваяСтрока = Товары.Добавить();
            НоваяСтрока.Номенклатура                        = Выборка.НомерСтроки;
            НоваяСтрока.Номенклатура                        = Выборка.Номенклатура;
            НоваяСтрока.Количество                          = Выборка.Количество;        
            НоваяСтрока.ЕдиницаИзмерения                    = Выборка.ЕдиницаИзмерения;
            НоваяСтрока.Коэффициент                         = Выборка.Коэффициент;
            НоваяСтрока.Цена                       = Выборка.Цена;
            НоваяСтрока.ПроцентСкидкиНаценки                = Выборка.ПроцентСкидкиНаценки;            
            НоваяСтрока.Сумма =      Выборка.Сумма;
                        
                                    
                        
                                
            
            НоваяСтрока.ЗаказПокупателя              = Сделка;

            ДобавленКомплект                         = Истина;
        КонецЦикла;
КонецЕсли;


КонецПроцедуры



 ! 

Правила: 9
 
Просмотров: 170, последний комментарий от jojojoba2   
Панель навигации формы "Перейти": отразить регистр накопления [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 24.06.19, 10:52 — 5 комментариев
Приветствую, Форумчане!
1с8.3.6, самопис, БСП, УФ

Имеется регистр накопления "ВзаиморасчетыПоЗаказам"

Как в форме "Заказы" в командном интерфейсе на панели навигации в "Перейти" отразить этот регистр накопления по конкретному заказу, из формы которого вызывается эта "Перейти"? Т.е. перейти и увидеть все движения по этому документу "Заказы"?
Просмотров: 213, последний комментарий от pablo   
Очистка не выбранных строк в таблице [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Lolita — 23.06.19, 8:24 — 3 комментариев
Добрый день!

Этот код написал:

Если НЕ ЗначениеЗаполнено(КатегорияПоложениеРаботника[0].ОД) Тогда
ТаблицаЗначений.Удалить(0);;
Отказ = Истина;
Если Отказ Тогда
Возврат;
КонецЕсли;
КонецЕсли;


Что здесь не так.

В этом коде хочу, если я выбрал строку (поставил флажок напротив строки). А которые не выбрал исчезали (или вся строка исчезала).




 ! 

Правила: 9
 
Просмотров: 168, последний комментарий от Prospero   
RSS Текстовая версия Сейчас: 16.07.19, 0:41
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!