Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Підготовка податкових накладних в xml - формі [раздел Программирование в 1С Предприятие 7.7]
Автор FOZOT — 27.03.17, 16:09 — 4 комментариев
Чергові зміни у формі податкових накладних - введений код послуг згідно ДКПП. В результаті без "ручного" коригування неможливо відправити через АртЗвіт сформовану ПН. В результаті досліджень виявив, що це відбувається через "застарілість" обробки xmlexp.ert, яка не підтримує новий формат "DKPPColumn".
Підкажіть, будь-ласка, де можна "взяти" нову версію xmlexp.ert, яка вже підтримує новий формат "DKPPColumn"?
Просмотров: 63, последний комментарий от FOZOT   
ПКО обновить данные табличной части [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 27.03.17, 12:41 — 5 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Что-то совсем туплю или запутался.
В ТЧ ПКО имеется ДокументРасчетаСКонтрагентами. Обычно это "РеализацияТоваров"
В РеализацииТоваров имеется ссылка на документ основание - "ЗаказПокупателя (реквизит "Сделка")

Также в ТЧ имеется реквизит "Сделка" (обычно "Заказ покупателя")
ПКО раскрывается в режиме по нескольким сделкам.

Сделал кнопку "Заполнить заказы (сделки)", прописал код:

ДокОбъект = Ссылка.ПолучитьОбъект(); //здесь Док - ссылка на объект

Для Каждого Стр из ДокОбъект.РасшифровкаПлатежа Цикл

Стр.Сделка = Стр.ДокументРасчетовСКонтрагентом.Сделка.Ссылка;

Сообщить(Стр.ДокументРасчетовСКонтрагентом.Сделка);

КонецЦикла;


Сообщить выдает правильный результат, но данные Стр.Сделка не заполняются в ТЧ... Ошибок никаких не выдает...

Посоветуйте как правильно сделать обновление табличной части?
Просмотров: 82, последний комментарий от Constantus   
Помогите розобратся с запросом и его данными [раздел Программирование в 1С Предприятие 7.7]
Автор leo10k10 — 27.03.17, 12:31 — 5 комментариев
Подскажите что не так пишу или делаю.
Есть запрос

Запрос_1 = СоздатьОбъект("Запрос");
    ТекстЗапроса_1 =
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Обрабатывать НеПомеченныеНаУдаление;
    |ПриходнаяНакладная = Документ.ПриходнаяНакладная.ТекущийДокумент;
    |ТМЦ = Документ.ПриходнаяНакладная.ТМЦ;
    |ПлотностьНа15Град = Документ.ПриходнаяНакладная.ПлотностьНа15Град;
    |ЛитрОтПлотности = Документ.ПриходнаяНакладная.ЛитрОтПлотности;
    |Группировка День;
    |Группировка ПриходнаяНакладная;
    |Группировка ТМЦ;
    |Группировка ПлотностьНа15Град;
    |Группировка ЛитрОтПлотности;
    |"//}}ЗАПРОС


создаю таблицу значений для заполнения ее данными запроса

Список_Прих = СоздатьОбъект("ТаблицаЗначений");
    Список_Прих.НоваяКолонка("День", "Дата");
    Список_Прих.НоваяКолонка("НомПрихНакл", "Строка");
    Список_Прих.НоваяКолонка("ИмяПрихТовара", "Строка");
    Список_Прих.НоваяКолонка("ПлотнПрихТовара", "Число");
    Список_Прих.НоваяКолонка("ПрихАкцизЛитр", "Число");


и заполняю ее на цикле последеней групировки

Пока Запрос_1.Группировка(5) = 1 Цикл
                    Сообщить (Запрос_1.ЛитрОтПлотности);
                    НомПрих = НомПрих + 1;
                    Список_Прих.НоваяСтрока(НомПрих);
                    Список_Прих.День = Запрос_1.День;
                                    Список_Прих.НомПрихНакл = Запрос_1.ПриходнаяНакладная;
                                    Список_Прих.ИмяПрихТовара = Запрос_1.ТМЦ;
                                    Список_Прих.ПлотнПрихТовара = Запрос_1.ПлотностьНа15Град;
                                    Список_Прих.ПрихАкцизЛитр = Запрос_1.ЛитрОтПлотности;
                КонецЦикла;


в результате неверная информация в полях таблици Список_Прих что не так не пойму
Просмотров: 77, последний комментарий от leo10k10   
Макет: вертикальная полоса прокрутки по всей высоте результата [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 27.03.17, 7:35 — 8 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Сделал обработку, макет к ней. Получил результат, но заметил такой неудобный момент:
Результат по строкам около 100 строк. Первые строки выдает в пределах размера открывшегося макета. Естественно визуально выводятся только первые строки.
Вертикальная полоса прокрутки стоит по высоте выведенного результата.
Если хочу просмотреть результат полностью, то приходится нажимать прокрутку вниз, а это почему-то достаточно медленно...
Кроме того, если захочу вернуться вначало, а потом опять вниз, то имеется таки дискомфорт по прокрутке.

Можно ли как-нить настроить полосу прокрутки, чтобы было более быстро, как в Экселе, который как-то рассчитывает количество строк и выдает вертикальную прокрутку с возможностью быстрого перехода вниз/вверх?
Просмотров: 89, последний комментарий от Bernet   
Область не найдена:Ошибка при вызове метода контекста (ПолучитьОбласть) [раздел Программирование в 1С Предприятие 8.3]
Автор repreplo — 26.03.17, 18:33 — 6 комментариев
Добры день уважаемые форумчаны!!!
Столкнулся с на первый взшляд банальной ошибкой, но как исправить и где еще копать не пойму, помогите ПЛИЗ.
Использую платформу: 8.3 (8.3.9.2170)
Конфигурация на управляемых формах: Бухгалтерия для Украины (2.0.4.3).
В типовом документе Счет на оплату от покупателя, редактирую (единственный) макет, добавил одну область "Автомобиль", в Модуле менеджера добавил пару строк: получаю область, заполняю параметры и вывожу эту область. Но программа не видит мою область, отладчиком в процедуру попадаю, имя макета то которое в данном докумене, а именно "ПФ_MXL_СчетЗаказ", Макет.Области - мою область не содержит, и естественно как только дохожу до своего кода , получаю ошибку:
{Документ.СчетНаОплатуПокупателю.МодульМенеджера(314)}: Ошибка при вызове метода контекста (ПолучитьОбласть)
ОбластьМакета = Макет.ПолучитьОбласть("ОбластьАвто");
через:
Область не найдена: ОбластьАвто
Не нашел как прикрепит фото, поэтуму выложил в Облако Маил.ру:

 ! 

Правила: 5,8
 


Направьте пожалуйста в нужное русло!

repreplo @ Сегодня, 19:30 * ,
По форумам походил, советы попробовал, но без результатов. Пробовал:
- удалять имя, и заново назначать
- сверил тот ли макет вызывается Функцией формирования макета
- ...
Просмотров: 99, последний комментарий от repreplo   
Выбор ПКО из Структуры подчиненности [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 25.03.17, 12:50 — 9 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Делаю обработку, которая покажет некий отчет по работе с ЗаказамиПокупателей.
Система работает: ЗаказПокупателя - Реализация - ПКО (по цепочке на основании)

Для вывода подчиненных документов использую код:

    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ РАЗРЕШЕННЫЕ
        |    СтруктураПодчиненности.Ссылка
        |ИЗ
        |    КритерийОтбора.СвязанныеДокументы(&ЗначениеКритерияОтбора) КАК СтруктураПодчиненности";
        
    Запрос.УстановитьПараметр("ЗначениеКритерияОтбора", Выборка.Ссылка);

Где Выборка.Ссылка - ссылка на ЗаказПокупателей (в цикле по дате)

Для вывода в макет соответствующих ПКО использую код:

            Если ТипЗнч(ВыборкаДетальныеЗаписи.Ссылка) = Тип("ДокументСсылка.ПриходныйКассовыйОрдер") Тогда
                Область.Параметры.ПКО = ВыборкаДетальныеЗаписи.Ссылка;
                Область.Параметры.ПКОСсылка = ВыборкаДетальныеЗаписи.Ссылка;
            КонецЕсли;


Все в принципе работает правильно за исключением редких случаев, когда ПКО оформляется списком, т.е. ПКО делается на основании 2-х и более реализаций.

В этом случае, значения ПКО в макете выводится пустой строкой. Хотя, если открываю ЗаказПокупателя и смотрю на подчиненность, там высвечиваются данные по ПКО...

Как мне достучаться до значений ПКО в СтруктуреПодчиненности, в случае, если ПКО оформляется списком???
Просмотров: 116, последний комментарий от Flexy   
Работа с пречислениями (платформа 8.2.19.106) [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор andrew76 — 24.03.17, 18:03 — 15 комментариев
Добрый всем вечер !

Имеется следующее перечисление- "Родственники".Задействовано в ТЧ справочника Сотрудники.
Почему то при переборе записей ТЧ значение реквизита Родственник(тип перечисление) можно прочитать
следующим образом:

Значение_реквизита=Строка(Родственник); //псевдокод

Если не использовать функцию Строка(),то на выходе пусто.В отладчике -тип Перечисление.

Кто с таким сталкивался ?
Просмотров: 200, последний комментарий от andrew76   
Подстановка даты конца периода равного началу периода [раздел Система компоновки данных]
Автор Constantus — 24.03.17, 14:34 — 3 комментариев
Приветствую, форумчане!

"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

В отчете СКД устанавливаю параметры "НачалоПериода" и "КонецПериода"

В настройках вывожу на экран эти два параметра.

Ввожу дату начала периода...

Как автоматически подставить дату "КонецПериода" равной дате "НачалаПериода" или

Подставить в дату "КонецПериода" дату отличную от даты начала на, скажем, + 2дня
Просмотров: 114, последний комментарий от sava1   
Создание нового документа и проверка на наличие уже созданого. Подскажите пожалуйста что не так я делаю. [раздел Программирование в 1С Предприятие 7.7]
Автор inna.innainna84 — 24.03.17, 10:29 — 7 комментариев
Код
Процедура СоздаемПЛ() 
    
    тз.выбратьстроки();
    Пока ТЗ.ПолучитьСтроку()=1 Цикл                     
        //================создаем новый!=====================          
        ДокМ=СоздатьОбъект("Документ.ПутевойЛистГрузовой");                 
        ДокМ.Новый();          
        глЗаполнитьШапку(ДокМ);
        ДокМ.ДатаДок = ТЗ.ДатаДок;  
        ДокМ.Автомобиль = ТЗ.Автомобиль.ТекущийЭлемент();         
        Докм.ПоказанияСпидометраНаНачало=ТЗ.КоличествоНачПокСпид;
        Докм.ПоказанияСпидометраНаКонец=ТЗ.КоличествоКонПокСпид;
        Докм.ПробегGPS=ТЗ.GPS;
        Докм.ПробегНорма=ТЗ.Км;
        Докм.СуммаЗаправки=ТЗ.ПоступилоСумма;
        Докм.ПоступилоГСМ=ТЗ.ПоступилоЛитр;
        Докм.Автор=глПользователь;
        //================создаем новый!=====================             
        
        //=========================проверям на наличие уже созданного пл=======================    
        ДокПЛ=СоздатьОбъект("Документ.ПутевойЛистГрузовой");    
        ДокПЛ.ВыбратьДокументы(Дата1,Дата2);
        Пока ДокПл.ПолучитьДокумент()=1 Цикл
                       Если ДокПЛ.ПометкаУдаления() = 0 Тогда // проверяем все кроме помеченных!!
                
                //================находим документ и редактируем его!=====================           
                Если (ДокПЛ.Автомобиль=ДокМ.Автомобиль) и (ДокПЛ.ДатаДок=ДокМ.ДатаДок) Тогда                  
                    Если Вопрос("ПЛ № "+ДокПЛ+" уже записан (№ "+ДокПЛ.Номердок+"). РЕДАКТИРОВАТЬ?", "Да+Нет") =  "Да" Тогда  
                        
                        ДокМ=ДокПЛ;
                        
                        Если ДокМ.Проведен()=1 Тогда                            
                            ДокМ.СделатьНеПроведенным();                             
                        КонецЕсли;
                    КонецЕсли;
                    Докм.Автор=глПользователь;
                    ДокМ.ПоказанияСпидометраНаНачало=ТЗ.КоличествоНачПокСпид;
                    ДокМ.ПоказанияСпидометраНаКонец=ТЗ.КоличествоКонПокСпид;
                    ДокМ.ПробегGPS=ТЗ.GPS;
                    ДокМ.ПробегНорма=ТЗ.Км;
                    ДокМ.СуммаЗаправки=ТЗ.ПоступилоСумма;
                    ДокМ.ПоступилоГСМ=ТЗ.ПоступилоЛитр;
                    ДокМ.Записать();        
                    Сообщить("Редактирован! "+ДокМ.ТекущийДокумент());                     
                КонецЕсли;                   
                //================находим документ и редактируем его!=====================         
            КонецЕсли;             
        КонецЦикла;  
        
        //===========================================================
    КонецЦикла;                                        
    
    Попытка
        ДокМ.Записать();
        Сообщить("№2 "+ ДокМ);    
    Исключение
    КонецПопытки;
    
    сообщить("Ок.");    
КонецПроцедуры
Просмотров: 193, последний комментарий от inna.innainna84   
ПКО и реализация в одном отчете [раздел Система компоновки данных]
Автор Constantus — 24.03.17, 9:43 — 3 комментариев
Приветствую, форумчане!

"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Сложная вещчЪ... Попробую объяснить.

Проводится реализация. Документы реализации оформляются сегодня (для примера 20.03)
ПКО оформляются на следующий день, т.е. от 21.03
В ПКО имеется ссылка на документ Реализации, т.к. все ПКО делаются на основании этих документов.
Возможны и другие ПКО

При оформлении Реализации возможны ситуации с перечислением или в кредит, т.е. оплаты по данным реализациям не будут осуществлены 21.03
Кроме того, будут ситуации, когда ПКО будет оформлен на основании Реализации старыми датами (клиенты таки решились оплатить по старым долгам)

В итоге, состояние кассы за 21.03 не будет равняться сумма по всем Реализациям за 20.03

Требуется получить отчет за день, где сначала будут указаны все ПКО за 21.03, а далее указаны все реализации за 20.03 в соответствующие ПКО.
Причем должны быть показаны также неоплаченные реализации и показаны ПКО оплаченныз за Реализацию других периодов, т.е. будут пустые строки:

ПКО_01 21.03 $300 РТС_01 20.03 $300
ПКО_02 21.03 $310 РТС_02 20.03 $310
ПКО_03 21.03 $330 РТС_03 20.03 $330
ПКО_01 21.03 $300 ________________ РТС_04 01.03 $300
_________________ РТС_05 20.03 $330 (перечисление)
_________________ РТС_06 20.03 $330 (кредит)

В итоге должно получиться:
1 Колонка - все ПКО за день с итогом по сумме, включая пустые строки в случае наличия Реализации (последние строки таблицы)
2 Колонка - все Реализации за предыдущий день по отчету по ПКО
3 колонка - все оплаченные Реализации за другие предыдущие периоды

Даже не знаю с чего начать, подскажите или дайте списать smile.gif



Просмотров: 123, последний комментарий от sava1   
Запись элементов табличной части справочника в поле ввода на форме [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор andrew76 — 24.03.17, 6:23 — 6 комментариев
Доброго всем утра !

Прошу извинения за название темы-должно было быть "Запись элементов ТЧ справочника в поле ввода на форме ?"

Имеется справочник областей страны ,в табличной части этого справочника определены районы входящие в состав области.
Можно ли имея на форме 2 поля ввода,при выборе области в первом поле,автоматически заполнять значениями районов из ТЧ (объектного типа) второе поле?
Или не заморачиваться - определить в конфигураторе подчиненный справочник районов страны - и дело с концом ?
Просмотров: 133, последний комментарий от andrew76   
Сформировать отчет из двух баз 1С 8.1 и 8.2 [раздел Программирование управляемых форм 1С 8.2]
Автор Kulonbekov — 24.03.17, 5:09 — 1 комментариев
На 1С 8.1 есть данные по продажам, на 1С 8.2 есть данные по возвратам, надо создать общий отчет из двух баз.
Надо написать обработку либо альтернативный вариант.
Помогите???
Просмотров: 84, последний комментарий от Vofka   
Отбор документов по контрагенту [раздел Программирование в 1С Предприятие 8.3]
Автор kot488 — 23.03.17, 17:18 — 15 комментариев
Имеется самописная конфигурация. В конфигурации есть документы с формой списка


Для всех пользователей отображается поле отбора test1, а для пользователей с ролью test отображается только поле отбора test. Это поле имеет ссылку на справочник контрагентов.

В документе есть поле Кто платит. Пользователи с ролью test всегда будут выбирать только одного плательщика Компания.
Теперь сама проблема, нужно что бы когда пользователь переходит на список документов у него автоматически подставлялся в поле отбора test контрагент Компания.


Как это можно очень просто реализовать, я далек от 1С
Просмотров: 274, последний комментарий от kot488   
1C и термопринтер TSC ttp-244 pro [раздел Работа с торговым оборудованием]
Автор Yevhenii — 23.03.17, 16:14 — 3 комментариев
1С Предприятие 8.2 обычное приложение, обычная форма
Конфигурация "Управление торговым предприятием для Украины", редакция 1.2.

Ребятушки, может кто сталкивался с подобным чудо-девайсом и разобрался что с ним делать!?

в общем дело такое: есть термопринтер TSC ttp-244 pro. Драйвера: Seagul TSC TSPL Driver Версия:7.4.3 так же пробовал работать на "родном" драйвере с диска который был с девайсом (TSC TSPL Driver Версия: 7.3.4 M-5)

поставил драйвер, поставил утилиту BarTender UltraLite.
немножко поигрался с настройками и добился того что с утилиты печатает отлично, теперь нужно печатать этикетки непосредственно с 1С
и вот тут то началось неведомое.
Пробую печатать обработкой "Печать Этикеток" в итоге если выбрать размеры этикетки по реальному размеру материала то он печатает на трёх-четырёх штуках, т.е. разносит сам рисунок по нескольким этикеткам. Если сделать этикетку в 1С в соотношении где то на 50% меньше чем реальный размер материала, то вродь как печатает, но соответственно очень маленькое изображение, если выставить размеры страницы раза в два больше чем сам рисунок и чем размеры самого материала то примерно можно методом тыка добиться того что изображение будет занимать почти всю полезную область на материале, как бы и должно быть, но только период печати получается этикетки в три. т.е три пустые-одна напечатаная-три или три с половиной пустые. Но это есть совсем не хорошо с точки полезности использования материала. Получается что я искусственно увеличил реальную область печати, но принтер "думает" что он печатает 150х100 мм. вместо 50х30мм по реальному размеру материала ну и начало печати естественно каждый раз смещается, вообщем это не печать, а сплошная болячка.

Может кто сталкивался с данной моделью и особенностью его печати из 1С. Буду весьма благодарен за любую помощь.
Просмотров: 125, последний комментарий от Gazulo   
ЗУП логотип в печатной форме документа [раздел Программирование в 1С Предприятие 8.3]
Автор Altem — 23.03.17, 10:40 — 12 комментариев
Доброго дня!
Есть несколько организаций.
В печатной форме необходимо вывести логотип определенной организации.
Картинка находится в хранилище дополнительной информации.



Прикреплять картинку в макет документа присваивая область не подходит.
Просмотров: 195, последний комментарий от logist   
Отчет по складу в 3-х единицах измерения [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 23.03.17, 7:17 — 4 комментариев
Приветствую, форумчане!

"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Очередная хотелка руководства.

Все товары имеют 3 (три) единицы измерения, например:

Товар "Банка чего-та"
шт. - коэф.=1
коробка - коэфф= 30 (шт в коробке)
поддон - коэфф. = 300 (шт в поддоне, 10 коробок на поддоне)

Хотят видеть в отчете "Ведомость товаров на складе" во всех единицах измерения. Сейчас могу поставить в "Ед. измерения для отчетов" либо коробку, либо поддон и соответсвенно в самом отчете сделать настройку... Но отчет покажет остатки в базовой и (коробка или поддон)

Можно ли с минимальными потерями изменить типовой отчет, или лучше всего собственное изобретение внедрять?
Просмотров: 125, последний комментарий от candrey   
как програмно организовать автоматическое заполнение поля многострочной части определенного докумнта [раздел Программирование в 1С Предприятие 7.7]
Автор leo10k10 — 22.03.17, 15:30 — 2 комментариев
Подскажите пожалуйста как в 1С 7.7 правильно организовать следующее действие, к примеру есть Документ «Расходная накладная» в его форме имеется таблица в виде «Многострочной части» которая состоит из 9 полей среди которых есть такие поля как «Температура» «Плотность» «Приведенная Плотность» нужно чтобы поле «Приведенная Плотность» по определённой формуле заполнялось автоматически после заполнения полей «Температура» и «Плотность». Заранее благодарен за конструктивные ответы.
Просмотров: 106, последний комментарий от leo10k10   
УПП 1.3 Ссылку на форму из которой выбран элемент [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор alexandr_f — 22.03.17, 12:16 — 7 комментариев
Выбираю элемент справочника , Соответвенно владелец Формы Табличное поле. А как получить ссылку на Форму Владельца. Дело в том что там есть еще одно ТП , которе мне нужно
Просмотров: 135, последний комментарий от alexandr_f   
Места хранения склада: учет времени хранения [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 22.03.17, 10:44 — 2 комментариев
Приветствую, форумчане!

"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Задали такую задачку. Понимаю, что в УТ данного функционала нет. Поэтому поделитесь своим мнением и направлением решения.

Имеется некий склад "Главный". Пусть имеется структура мест хранения 1-ого уровня по палетам. П01, П02, П03.....

С другого склада (или поступление) оформляем документ "Перемещение" на склад "Главный".
Вот тут нужно разместить товар по местам хранения П01, П02, П03... (первая проблема)

Теперь приходит время и товар забирается со склада перемещением. Необходимо забрать с определенных П01, П02 и т.д. необходимый товар.

И такая карусель в течение месяца... В конце месяца необходимо вывести отчет о том, сколько времени (по дням) была загружена каждая палета...

Как правильно пойти?


 ! 

Правила: 3
 
Просмотров: 101, последний комментарий от DrLivsi   
СтандартнаяОбработка на булево дополнительного реквизита [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 22.03.17, 8:49 — 5 комментариев
Приветствую, форумчане!

"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

В документе "ЗаказПоставщику" есть дополнительный реквизит "Утверждаю"

Имеется проверка на право разрешения утвердить.
Использую код на изменение

Процедура УтверждаюПриИзменении(Элемент, СтандартнаяОбработка)
....
    Иначе
        СтандартнаяОбработка = Ложь;
        Сообщить("Ваш статус: " + УправлениеДопПравамиПользователей.РазрешитьУтверждение() +
        ". Вы не имеете прав на утверждение как Руководитель");
        
    КонецЕсли;    
КонецПроцедуры


Однако при выполнении на запрет, галочка всё-равно изменяется. Попробовал добавить в параметры Процедуры "СтандартнаяОбработка" и применить ее в режиме "Ложь" - не помогло.

Как в случае запрета на утверждение, не позволять изменять значение реквизита "Утверждаю"?


Просмотров: 148, последний комментарий от candrey   
RSS Текстовая версия Сейчас: 27.03.17, 20:28
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне