Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
У звіті "Продажі" відображать і суми у валюті USD [раздел 1С Управление производственным предприятием 8]
Автор marchela — 19.04.24, 9:42 — 4 комментариев
Доброго дня!

1С:Підприємство 8.3 (8.3.13.1690)
"Управление производственным предприятием для Украины", редакция 1.3 (1.3.64.1)

Деякий товар продається в доларах

Документ Реалізації проведено в доларах

Звіт "Продажі" відображає суму проданого товару тільки у гривні в перерахунку по поточному курсу

Чи можливо якось налаштувати звіт, щоб відображалась сума продаж у доларах і сума продаж у гривні?
Просмотров: 51, последний комментарий от marchela   
Розрахунок собівартості [раздел 1С Управление производственным предприятием 8]
Автор chernomoretc_cn — 18.04.24, 15:51 — 1 комментариев
1С:Предприятие 8.3 (8.3.18.1334)
"Управление производственным предприятием для Украины", редакция 1.3
Разработка конфигурации: "ABBYY Ukraine", 2005-2017 (1.3.56.2) (http://1c.ua/v8/RegionalSolutions_UA_UPP.php)
Copyright © «ДП "Еврософтпром"», 2005-2017. Все права защищены
(http://www.1c.ua)

Після розрахунку собівартості, ОСВ 281 рахунку
Святковий з начинкою "Вишня" зефір БУ 13526,50 9448693,80 -9 435 167,30
Кол. 240,500 240,500
240,5 - це 65 ящ по 3,7 кг (Одиниця 3,7 коєф. 3,7)
Картка рахунку
"Поступление от 04.03.2024 17:46:20
Оприходованы ТМЦ 25шт 281 5 202,50 631 Д 5 202,50
"Поступление от 19.03.2024 15:53:52
Оприходованы ТМЦ 15шт 281 3 121,50 631 Д 8 324,00
"Поступление от 25.03.2024 16:59:05
Оприходованы ТМЦ 25шт 281 5 202,50 631 Д 13 526,50
"Расчет себестоимости от 31.03.2024 23:58:58
Реализация"
"Себестоимость реализованных покупных запасов" 902 281 9 448 693,80 Д -9 435 167,30

При проведенні документу "Расчет себестоимости" визначається кількість і вартість: 3,7 і 145364,52 (39287 за одиницю)


Функция СформироватьВременнуюТаблицуУзлыКорректировкиСтоимостиСписания(
Запрос,
РегистрУчета,
ВидОтраженияВУчете,
СтруктураПараметров,
ОперацияРасчетаСебестоимостиВыпуска)
Модуль КорректировкаСтоимостиУчетаЗатрат

Може хто підкаже як визначається ціна? З запиту я не можу зрозуміти звідки вона береться.
Просмотров: 62, последний комментарий от Moloko   
УФ после выбора из списка задать вопрос - не работает [раздел Программирование в 1С Предприятие 8.3]
Автор AnryMc — 11.04.24, 11:50 — 16 комментариев
Точно не мой день...

Задача: Пользователь должен выбрать из списка значение, после чего ему задается вопрос...

КОД: (МойСписок, ВыбранноеПредставление и ВыбранноеЗначение - реквизиты формы)
Начало выполнения - КомандаВыполнить()
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    ЗаполнитьМойСписок();
    
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьМойСписок()
    
    Для н = 1 По 10 Цикл
        
        нр = МойСписок.Добавить();
        
        нр.Значение = "Значение_" + СокрЛП(н);
        
        нр.Представление = "Наименование " + СокрЛП(н);
        
    КонецЦикла;
    
КонецПроцедуры

&НаКлиенте
Процедура КомандаВыполнить(Команда)
    
    Оповещение = Новый ОписаниеОповещения("ПослеВыбораИзСписка", ЭтотОбъект);
    МойСписок.ПоказатьВыборЭлемента(Оповещение, "Виберіть, що додається...");

КонецПроцедуры

&НаКлиенте
Процедура ПослеВыбораИзСписка(ВыбранныйЭлемент, СписокПараметров) Экспорт
    
    Если ВыбранныйЭлемент = Неопределено Тогда
        
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "Не обрано!";
        Сообщение.УстановитьДанные(ЭтотОбъект);
        Сообщение.Сообщить();
        
    Иначе
        
        ВыбраноеЗначение = ВыбранныйЭлемент.Значение;
        ВыбранноеПредставление = ВыбранныйЭлемент.Представление;
        
        ПродолжимВыполнение();
        
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура ПродолжимВыполнение()
    
    ОписаниеОповещения = Новый ОписаниеОповещения("ПослеОтветаНаВопрос", ЭтотОбъект);
    ПоказатьВопрос(ОписаниеОповещения, "Дайте відповідь що небудь!", РежимДиалогаВопрос.ДаНет, 60);

КонецПроцедуры

&НаКлиенте
Процедура ПослеОтветаНаВопрос(РезультатВопроса, ДополнительныеПараметры) Экспорт
    
    Если РезультатВопроса = КодВозвратаДиалога.Да Тогда
        
        ПередадимДействиеДальше();
        
    Иначе
        
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "- - - - -";
        Сообщение.УстановитьДанные(ЭтотОбъект);
        Сообщение.Сообщить();
        
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура ПередадимДействиеДальше()
        
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "! ! ! ! ! ! ! !";
        Сообщение.УстановитьДанные(ЭтотОбъект);
        Сообщение.Сообщить();
        
КонецПроцедуры


После выбора значения из списка вызывается ПродолжимВыполнение() но отображение вопроса не происходит
В ПослеОтветаНаВопрос() всегда РезультатВопроса = НЕТ

Как это реализовать???
Просмотров: 1010, последний комментарий от AnryMc   
Возврат параметра при закрытии формы [раздел Программирование в 1С Предприятие 8.3]
Автор AnryMc — 11.04.24, 10:07 — 4 комментариев
Капитально туплю сегодня - помогите!!!

Форма Обработки 1
Программно открывается Обработка 2
&НаКлиенте
    
    ПараметрыФормы = Новый Структура("", "");
    
    ОписаниеОповещения = Новый ОписаниеОповещения("ЗакрытаФормаОбработки2", ЭтотОбъект, ПараметрыФормы);
    
    ОткрытьФорму("Обработка.Обработка2.Форма", ПараметрыФормы,,,,,ОписаниеОповещения);


В Обработке 2 устанавливается НужныйРеквизит

Форма Обработки 2 - закрывается

В Обработке 1 выполняется Оповещение
&НаКлиенте
Процедура ЗакрытаФормаОбработки2(Результат, ДополнительныеПараметры) Экспорт
    
    ...
//Как здесь узнать установленный в Обработке 2 НужныйРеквизит
    
КонецПроцедуры


КАК???


Просмотров: 433, последний комментарий от AnryMc   
Вплив SQL server на SSD [раздел Тематическое общение]
Автор Toster — 10.04.24, 11:37 — 11 комментариев
Доброго дня . Не впевнений чи правильно вибрав розділ публікації, тому на перед вибачаюся) Суть питання , збираю домашній ПК в основному для роботи 32000000.gif , в ньому буде жити 2 ссд . 1 м2 КС3000 і 1 SATA 3 SSD . Хочу розгорнути MSSQL server і там буде тестове середовище з 3 базами даних . від 80 до 60 гіг кожна . Питання , на скільки SQL при активному використанні "вбиває ССД", бо як би , трішки жаба душить вбивати кс3000 , а з іншої сторони різниця в швидкостях між сата і м2 дуже суттєва. Буду вдячний за пораду, куда ставити SQL і бази данних)
Просмотров: 797, последний комментарий от Toster   
Как можно управлять панелями разделов программно [раздел Программирование в 1С Предприятие 8.3]
Автор mikkia — 04.04.24, 14:05 — 1 комментариев
Пытаюсь сделать это через настройки
НастройкиИнтерфейса = ХранилищеСистемныхНастроек.Загрузить("Общее/ПанельРазделов/НастройкиКомандногоИнтерфейса");

но не знаю какие там методы есть. Через НастройкиИнтерфейса может только скрыть панели, а мне нужно конкретно одну панель скрыть от пользователей.
Просмотров: 283, последний комментарий от AnryMc   
Подключение внешней обработки к документу [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор kostya77 — 04.04.24, 9:31 — 5 комментариев
Добрый день. Есть внешняя обработка по выгрузке данных по ЗП на банк. Как сделать вызов этой обработки из документа Зарплата к выплате
Просмотров: 377, последний комментарий от takefive   
Работа с объектом ДанныеФормыКоллекция 1С 8.3 (УФ) [раздел Программирование в 1С Предприятие 8.3]
Автор andrew76 — 02.04.24, 11:48 — 11 комментариев
Добрый день всем.

Не получается передать Таблицу Значений с сервера на клиент.
На управляемой форме имеется реквизит РеквизитТЗ с типом ТаблицаЗначений.
Мне нужно передать ТЗ с сервера на клиент.


&НаСервере

Результат=Запрос.Выполнить().Выгрузить();

//заполняю реквизит формы РеквизитТЗ результатом запроса данных
ЭтотОбъект.РеквизитТЗ.Загрузить(Запрос.Выполнить().Выгрузить());



А как этот объект (ДанныеФормыКоллекция) прочитать на клиенте ?

Или я неправильно его заполнил в процедуре на сервере ?
Просмотров: 3745, последний комментарий от andrew76   
Проблема при открытии периода - искажаются остатки товара [раздел 1С Торговля и Склад 7.7 для Украины]
Автор foks — 01.04.24, 14:51 — 2 комментариев
Здравствуйте!
очень нужна помощь:

В субботу 30/03 закончили работать как обычно, сделали резервную копию.
Сегодня вошли в программу, выполнили открытие периода, предложенное системой, как обычно.
Поработав 1 час, поняли, что остатки отображаются не корректные - меньше товара на складе.
В отчете Остатки товаров на складе и также при подборе - при создании счета-фактуры.

Вернули из резервной копии на 30/03 - все нормально - но как только делаем открытие периода - остатки сбиваются.
По нескольким товарам.

При этом сделав отчет по движению по одному из таких товаров - видим что в итоговых остатках отчета - остатки товара не верные - а в построчечной детализации - верные.

Еще в средине марта возникала проблема - по одному товару - в отчете остатки товаров - остаток корректный, а при подборе - набирая его в счет-фактуру - показывает оперативный остаток не корректный (меньше).
Заметили такое только по одному товару.
Просмотров: 266, последний комментарий от Vofka   
раскраска строки FormEX [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 01.04.24, 8:05 — 6 комментариев
для 1с 7.7
для раскраски использую FormEx
надо раскрасить текущую строку
выделеная ячейка сейчас синяя, а надо что-бы ячейка была одним цветом, а строка другим

если пишу такой код тогда красит всю таблицу:
Если ПустоеЗначение(ТекущийЭлемент().Наименование)=0 Тогда Возврат "BRUSH[" + ПолучитьЦвет(200,200,100) + "]"; КонецЕсли;
Просмотров: 552, последний комментарий от piterkzl   
Запрос в СКД с параметрами из самого запроса [раздел Система компоновки данных]
Автор Pacific — 30.03.24, 7:52 — 1 комментариев
Доброго времени суток.
Подскажите как сделать такой запрос:
- выбрать документы и получить время проведения; (Док1, ДатаДокТекущий)
- выбрать информацию из другого документа, используя в качестве периода значения из верхнего запроса (Док2)
Док2.Дата МЕЖДУ &ДатаДокПредыдущий И &ДатаДокТекущий

Возможно ли так? Через отдельные запросы написал и посчитал в ТЗ. Но, нужны итоги, группировки и там уже сложно для меня.
Просмотров: 237, последний комментарий от fly   
Вывести в отчёт данные из внутренней таблицы регистра [раздел Система компоновки данных]
Автор Shiwchik — 29.03.24, 14:29 — 4 комментариев
Добрый день. Очень нужна помощь по СКД.
На данный момент у меня в отчет выводится номенклатура (скрин 1),


но необходимо выводить "Найменування торгових мереж" (скрин 2).


Номенклатура по иерархии находится тут (скрин 3).

Ниже (рядом) расположил "ОтгрузкаПродукцииТовары" из верхнего регистра ПродажиИОбороты
где находится внутренняя таблица "Товари"
с "Найменування торгових мереж" (скрин 4), выделено красным.
Желтым выделено, то что потом буду подвязывать к наименованию торговых сетей.


Пытался как-то их связать (скрин 5).


Крутил вертел по разному, но ничего не выходит.
В общем: мне нужно вывести 1 - наименование торговых сетей, 2 - кол-во, 3 - цена, 4 - сумма документа отгрузка.
Но видимо из-за этой отдельной таблицы я не могу вывести в отчет, да и не смогу сгруппировать по наименованию товар.

Если где-то непонятно описал, скажите предоставлю больше информации.
Просмотров: 3460, последний комментарий от Shiwchik   
Реализация ОСВ на регистрах [раздел Программирование в 1С Предприятие 7.7]
Автор kostya77 — 29.03.24, 13:58 — 4 комментариев
Добрый день. Подскажите. возможно ли сделати на регистрах что -то похожее на ОСВ, что бы было Сально начальное дебет и Кредит, обороты и Сальдо конечное Дебет и Кредит. Если это возмно, то подскажите как реализовать?
Просмотров: 2847, последний комментарий от fly   
Не выводить итоги в детальных записях СКД [раздел Система компоновки данных]
Автор kostya77 — 28.03.24, 10:28 — 1 комментариев
Добрый день. Подскажите, есть отчет на СКД в нем три группировки - Контрагент, заказ, номенклатура. Выводятся итоги по сумма Заказа по группировкам и Общий итог. Как сделать так, чтобы в строку группировки Номенклатры не выводильсь суммы по Заказу?
Просмотров: 364, последний комментарий от AnryMc   
список элементов без каталогов [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 27.03.24, 17:45 — 1 комментариев
1с 7.7 Предприятие
при использовании в коде:
СписокЭлементов.ДобавитьЗначение(Сотрудники.ТекущийЭлемент());


почему-то в списке сотрудников показывает еще группы, например:
кадри
офис
грузчики
Иванов И.И
Петров И.И
Сидоров И.И

от чего зависит что-бы не показывало группы, а только сотрудников?
Просмотров: 479, последний комментарий от denis84   
Как скрыть некоторые значения перечисления из списка выбора в реквизите формы (Управляемы формы) [раздел Программирование в 1С Предприятие 8.3]
Автор AnryMc — 27.03.24, 14:57 — 3 комментариев
ДАНО:
Есть Перечисление АААААА со значениями:
- Значение 1
- Значение 2
- Значение 3
- Значение 4
- Значение 5

На форме есть реквизит (поле выбора) с данными - Перечисление ААААА

ЗАДАЧА: Показать пользователю в списке выбора только значения:
- Значение 1
- Значение 3
- Значение 5

ВОПРОС: Как это можно реализовать?

P.S.
Код:
НужныйСписок = НОВЫЙ СписокЗначений;
НужныйСписок.Добавить(Перечисления.ААААА.Значение1);
НужныйСписок.Добавить(Перечисления.ААААА.Значение3);
НужныйСписок.Добавить(Перечисления.ААААА.Значение5);

//ВЫРИАНТ 1
//Остается "первоначальный" список и добавляется "новый"
//Получается такой:
//- Значение 1
//- Значение 2
//- Значение 3
//- Значение 4
//- Значение 5
//- Значение 1
//- Значение 3
//- Значение 5

Элементы.МойРеквизит.СписокВыбора.Очистить();
Элементы.МойРеквизит.СписокВыбора.Добавить(НужныйСписок );

//ИЛИ
//ВАРИАНТ 2
//РАБОТАЕТ ТОЛЬКО НА ТОЛСТОМ КЛИЕНТЕ

Элементы.МойРеквизит.СписокВыбора.ДоступныеЗначения(НужныйСписок );
Просмотров: 332, последний комментарий от alexxbely   
Умова ИЛИ у швидкому відборі універсального звіту [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор zay — 27.03.24, 9:59 — 3 комментариев
Доброго дня
Звичайні форми 8.3.10.2375, самописна конфігурація

У клієнта є звіт на базі універсального звіту (универсальный отчет). У звіті є поля Контрагент1, Контрагент2 і ці поля додані у швидкій відбір. При використанні звіту виявилося що клієнту зручно було б робити відбір вказуючи просто одного контрагента, байдуже хто він буде Контрагент1 чи Контрагент2

Чи можливо це зробити в універсальному звіті через відбори?
Чи треба прибирати швидкі відбори і робити як у звичайному звіті
|    И (Таб.Контрагент1 = &Контрагент ИЛИ Таб.Контрагент2 = &Контрагент)

?
Просмотров: 482, последний комментарий от AnryMc   
Как вывести на печать штрих код? [раздел Программирование в 1С Предприятие 8.3]
Автор kostya77 — 25.03.24, 13:57 — 2 комментариев
Добрый день. Подскажити ка вывести на печать Штрих код? Делаю так - на ПФ помещаю Таблица - Рисунки - Картина.в свойствах картинки выбираю Картинка - Штрих код. Присваиваю картинке имя ШтрихКод Пишу код

ПараметрыШтрихкода=Новый Структура("Ширина,Высота,ТипКода,ОтображатьТекст,Штрихкод",200,80,4,Истина,"12345678");
КартинкаШтрихКода=МенеджерОборудованияВызовСервера.ПолучитьКартинкуШтрихкода(ПараметрыШтрихкода);
ОбластьМакета.Рисунки.Штрихкод.Картинка=КартинкаШтрихКода;
ТабличныйДокумент.Вывести(ОбластьМакета);


Вылетает с ошибкой - Поле об`єкту не виявлено (Штрихкод)
Просмотров: 329, последний комментарий от Slon747   
Загрузка EXEL c сервера через COM [раздел Программирование в 1С Предприятие 8.3]
Автор burza — 21.03.24, 10:43 — 12 комментариев
На клиенте данные загружает, когда процедуру переношу на сервер, ругается на МассивКолонок = arr.Выгрузить(); именно Выгрузить, что нужно сделать?)

я знаю что есть код для сервера другой я и сам им удачно пользуюсь, но нужен именно этот по причинам.

        
Попытка    
        Excel = Новый COMОбъект("Excel.Application");
        WB   =  Excel.Workbooks.Open(файл);
        WS = WB.Worksheets(1);
        arr = WS.UsedRange.Value;
        WB.Close(0);
        
        Исключение    
        КонецПопытки;
        
        МассивКолонок = arr.Выгрузить();
        ВсегоСтрок = (МассивКолонок.Получить(0).Количество()) - 1;
Просмотров: 691, последний комментарий от xlmel   
Интеграция с CheckBox: как добавлять налоги и акцизы (вместе или по одному) [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор alexandr_f — 19.03.24, 16:56 — 0 комментариев
При создании чека, как добавлять налоги и акцизі. У меня есть только А и Є, З и Б. Смотрю с сайта только один налог. но в АРИ там массив.
Просмотров: 325, оставить комментарий   
RSS Текстовая версия Сейчас: 20.04.24, 8:39
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!