Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Переход с УТ версии 3.1 на 3.2 (BAS) [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор python — 20.05.19, 16:57 — 0 комментариев
Доброго дня!

Предпринята попытка обновить конфигурацию УТ версии 3.1.5 до 3.2.
База тестовая. Размер не малый, клиент-сервер, БД MS SQL Server 2017. База на SSD диске, памяти достаточно.
Активно используется документ регистрации цен поставщиков.

Обновление проходит нормально (практически).

Проблема присутствует при выполнении обработчиков отложенного обновления.
В частности, процедура "Документы.РегистрацияЦенНоменклатурыПоставщика.ЗаполнитьВидЦеныПоставщикаВТабличнойЧастиТовары".
Выполняется сутками!

Текст процедуры, которая выполняется.
// Обработчик обновления BAS УТ 3.2.1
// Заполняет "ВидЦеныПоставщика" в табличных частях документа и обновляет движения по регистру сведений ЦеныНоменклатурыПоставщиков
Процедура ЗаполнитьВидЦеныПоставщикаВТабличнойЧастиТовары(Параметры) Экспорт
    
    ПолноеИмяОбъекта = "Документ.РегистрацияЦенНоменклатурыПоставщика";
    
    МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
    
    Результат = ОбновлениеИнформационнойБазы.СоздатьВременнуюТаблицуСсылокДляОбработки(
        Параметры.Очередь,
        ПолноеИмяОбъекта,
        МенеджерВременныхТаблиц
    );
    
    Если НЕ Результат.ЕстьДанныеДляОбработки Тогда
        Параметры.ОбработкаЗавершена = Истина;
        Возврат;
    КонецЕсли;
    
    Если НЕ Результат.ЕстьЗаписиВоВременнойТаблице Тогда
        Параметры.ОбработкаЗавершена = Ложь;
        Возврат;
    КонецЕсли;
    
    ЗапросПоДокументам = Новый Запрос;
    ЗапросПоДокументам.МенеджерВременныхТаблиц = МенеджерВременныхТаблиц;
    ЗапросПоДокументам.Текст = "
    |ВЫБРАТЬ
    |    Т.Ссылка                                     КАК Ссылка,
    |    Т.Ссылка.Партнер                             КАК Партнер,
    |    Т.Ссылка.УдалитьСоглашение                   КАК Соглашение,
    |    Т.Ссылка.УдалитьСоглашение.ВидЦеныПоставщика КАК ВидЦеныПоставщика
    |ИЗ
    |    Документ.РегистрацияЦенНоменклатурыПоставщика.Товары КАК Т
    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ ВТДляОбработки КАК ДокументыКОбработке
    |            ПО Т.Ссылка = ДокументыКОбработке.Ссылка
    |ГДЕ
    |    Т.Ссылка.Проведен
    |    И (Т.ВидЦеныПоставщика = ЗНАЧЕНИЕ(Справочник.ВидыЦенПоставщиков.ПустаяСсылка)
    |        И ЕСТЬNULL(Т.Ссылка.УдалитьСоглашение, ЗНАЧЕНИЕ(Справочник.СоглашенияСПоставщиками.ПустаяСсылка)) <> ЗНАЧЕНИЕ(Справочник.СоглашенияСПоставщиками.ПустаяСсылка))
    |";
    
    ЗапросПоДокументам.Текст = СтрЗаменить(ЗапросПоДокументам.Текст, "ВТДляОбработки", Результат.ИмяВременнойТаблицы);
    
    Выборка = ЗапросПоДокументам.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        
        НачатьТранзакцию();
        
        Попытка    
            
            Блокировка = Новый БлокировкаДанных;
            ЭлементБлокировки = Блокировка.Добавить(ПолноеИмяОбъекта);
            ЭлементБлокировки.УстановитьЗначение("Ссылка", Выборка.Ссылка);
            ЭлементБлокировки = Блокировка.Добавить("РегистрСведений.ЦеныНоменклатурыПоставщиков.НаборЗаписей");
            ЭлементБлокировки.УстановитьЗначение("Регистратор", Выборка.Ссылка);
            Блокировка.Заблокировать();
            
            ДокументОбъект = Выборка.Ссылка.ПолучитьОбъект();
            
            // Если объект ранее был удален или обработан другими сеансами, пропускаем его
            Если ДокументОбъект = Неопределено Тогда
                ОтменитьТранзакцию();
                ОбновлениеИнформационнойБазы.ОтметитьВыполнениеОбработки(Выборка.Ссылка);
                Продолжить;
            КонецЕсли;
            
            Для Каждого СтрокаТовары Из ДокументОбъект.Товары Цикл
                Если Не ЗначениеЗаполнено(СтрокаТовары.ВидЦеныПоставщика) Тогда
                    СтрокаТовары.ВидЦеныПоставщика = Выборка.ВидЦеныПоставщика;
                КонецЕсли;
            КонецЦикла;
            
            ДокументОбъект.УдалитьСоглашение = Неопределено;
            
            ОбновлениеИнформационнойБазы.ЗаписатьДанные(ДокументОбъект);
            
            НаборЗаписей = РегистрыСведений.ЦеныНоменклатурыПоставщиков.СоздатьНаборЗаписей();
            НаборЗаписей.Отбор.Регистратор.Значение = ДокументОбъект.Ссылка;
            НаборЗаписей.Отбор.Регистратор.Использование = Истина;
            НаборЗаписей.Прочитать();
            Если НаборЗаписей.Выбран() Тогда
                
                Для Каждого СтрокаНабора Из НаборЗаписей Цикл
                    
                    Если НЕ ЗначениеЗаполнено(СтрокаНабора.ВидЦеныПоставщика) Тогда
                        СтрокаНабора.ВидЦеныПоставщика = Выборка.ВидЦеныПоставщика;
                    КонецЕсли;
                    
                    СтрокаНабора.Соглашение = Неопределено;
                    СтрокаНабора.Партнер = Выборка.Партнер;
                    
                КонецЦикла;
                
                ОбновлениеИнформационнойБазы.ЗаписатьДанные(НаборЗаписей);
                
            КонецЕсли;
            
            ЗафиксироватьТранзакцию();
            
        Исключение
            
            ОтменитьТранзакцию();
            ОбновлениеИнформационнойБазыУТ.СообщитьОНеудачнойОбработке(Выборка.Ссылка);
                                        
        КонецПопытки;
        
    КонецЦикла;
    
    Параметры.ОбработкаЗавершена = ОбновлениеИнформационнойБазы.ОбработкаДанныхЗавершена(
        Параметры.Очередь,
        ПолноеИмяОбъекта
    );
    
КонецПроцедуры


Что-то мне подсказывает, что долго. По всей видимости - причина в количестве строк в документах, запись данных большими порциями.
Исправить можно только через разбиение на более мелкие документы? Или есть еще варианты оптимизации?

Пытался ли кто управлять последовательностью выполнения обработчиков отложенного обновления?
Хотелось бы посмотреть на эту разработку, но не бесплатная она: [необходимо зарегистрироваться для просмотра ссылки]

На этом проблемы с обновлением не заканчиваются, к сожалению.
Так как не все обработки отложенного обновления выполнены - при открытии документа (к примеру, заказа покупателя) выдается ошибка "Недостаточно фактических параметров".
Ошибка возникает при вызове необходимых обработчиков при открытии формы, но вылетает. Как бороться? Перепроверять все доки, все процедуры?
{(1)}: Недостаточно фактических параметров
Документы.РасходныйОрдерНаТовары.РасходныеОрдераОбновленыНаНовуюВерсию(Параметры)


Есть подозрение, что разработчики не тестировали обновление на больших базах.
Кто-то уже переходил на УТ BAS? Как успехи, какие впечатления?

О себе:
1С:Предприятие 8.3 (8.3.13.1809)
BAS Управление торговлей, редакция 3.2 (3.2.8.1)
Просмотров: 13, оставить комментарий   
"1С:Предприятие 8. Управляющий" отзывы [раздел Остальные конфигурации 1С 8]
Автор nysysimara — 20.05.19, 10:40 — 0 комментариев
"1С:Предприятие 8. Управляющий" (решение для автоматизации управленческого учета).
Нужен ответ на вопрос: стоит ли устанавливать?
Интересно мнение тех, кто эксплуатирует данную конфигурацию,
получили ли руководители желаемое: УПРАВЛЕНЧЕСКИЙ учет?

и еще: Бухгалтерский учет сейчас ведётся в 7.7.
Есть ли функционал перегрузки данных из 7.7. в эту конфигурацию?

Просмотров: 38, оставить комментарий   
Перенос справочника Контагенты из Бухгалтерия 1.2 в УПП [раздел Бухгалтерия 8, редакция 1 для Украины]
Автор VarMkn — 20.05.19, 9:40 — 4 комментариев
Кто поможет с данной проблемой ?
Перенести надо в УПП 8.3

Исходная версия Бухгалтерия для Украины, редакция 1.2. (1.2.51.1
1С:Предприятие 8.3 (8.3.9.2233)

Спасибо
Просмотров: 84, последний комментарий от VarMkn   
Особова картка П-2 в 1С 8.3 [раздел Прочее 1С 8]
Автор pepelniy — 18.05.19, 19:09 — 2 комментариев
уважаемые форумчане.
подскажите пожалуйста, где найти личную карточку П-2 в 1С 8.3 (8.3.13.1644)
пс у меня Базовая 2.0, но думаю не принципиально
Просмотров: 52, последний комментарий от Petre   
Заболансові рахунки для передачи товару від комітента комісіонеру [раздел 1С Управление производственным предприятием 8]
Автор Oceanoftastes — 17.05.19, 15:47 — 1 комментариев
В мене УПП 8.13 При формуванні документа "Реалізація товарів та послуг" по договору комісії формуються провадки
Д6431 К6432 ПДВ забов'язання Сума напр. 20 грн
Д 283 К 26 Передача товарів на комісію Сума напр. 90 грн =сумі собівартості продукції на рах26

в документі "Реалізація товарів та послуг" проставлені забалансові рахунки 0242 та 0241

але проводку Д0242 К- на суму відгрузки товару разом з пдв (у прикладі вона буде 120грн) программа робити не хоче.

А мені потрібна така проводка, бо не хочу ускладнювати облік веденням торгових націнок. Тобто я хочу, щоб формувалися проводки:

Д6431 К6432 ПДВ забов'язання 20 грн
Д 283 К 26 Передача товарів на комісію 90 грн =сумі собівартості продукції на рах26
Д0242 К- сума відгрузки товару 120грн

Як це реалізувати?
Просмотров: 70, последний комментарий от fly   
БСП. Не отображается универсальный отчет у пользователя [раздел Остальные конфигурации 1С 8]
Автор Vladal — 17.05.19, 10:39 — 0 комментариев
Есть самописка на БСП 3.0.2.

Дал пользователю права на запуск универсального отчета.
В профиле группы с пользователем добавил соответствующую роль, "Использование универсального отчета".

На копии базы у меня получилось - в разделе учета у пользователя появился раздел "Отчеты" и "Универсальный отчет".

А в рабочей базе не могу воспроизвести.
Делал то же, что и на копии, проверил роли пользователя в конфигураторе - у пользователя роль использования универсального отчета есть.
В профиле группы - роль есть.
Пользователь в группе состоит.

Что делать?
Просмотров: 49, оставить комментарий   
Изменение счета ЕСВ [раздел 1С Управление Торговым Предприятием 8]
Автор aik2001 — 13.05.19, 10:39 — 4 комментариев
Проводки по ЕСВ Формируются на счет 651. Что нужно изменить, чтобы формировать проводки на 6511 и 6512.
Вид расчета "ЕСВ ФОТ" один и для инвалидов и для работников поэтому если поменять в нем "способ отражения в бух учете", счет изменится у тех и у других.
И какой смысл в справочнике "СпособыОтраженияЗарплатыВРеглУчете" если проводки по ЕСВ оттуда не тянутся?

Управление торговым предприятием для Украины", редакция 1.2. (1.2.50.1)
Просмотров: 145, последний комментарий от aik2001   
Очистка кеша користувача [раздел Бухгалтерия 8, редакция 1 для Украины]
Автор Юля — 08.05.19, 13:05 — 2 комментариев
Привіт, не знала в який розділ віднетсти це запитання, тому прохання адміна, перенести куди потрібно, якщо я помилилась.
Питання наступне: в клієнтів бухгалтерія для України 1.2, при друку рахунка на оплату підтягує прінтер, який був видалений давно і не використовується, активний принтер, стоїть по замвчуваню, проблем немає. Цікаво те, що в інших документах такої проблеми не має, друк іде через активний прінтер, в інших користувачів також все добре. Я так розумію, що проблема в користувачові. Як можна вирішити проблему, але щоб інші налаштування по програмі не злетіли. Дякую.
Просмотров: 92, последний комментарий от Юля   
Как автоматически убирать галочку "Сотрудник актуален"? [раздел 1С Зарплата и Управление Персоналом 8]
Автор asu — 02.05.19, 16:18 — 2 комментариев
Добрый день! 1С 8.3(8.3.8.1861) "Зарплата и Управление Персоналом для Украины", редакция 2.1.Разработка конфигурации: "ABBYY Ukraine", 2008-2017 (2.1.45.3).
Как при увольнении сотрудника сделать так, чтобы автоматически убиралась галочка "Сотрудник актуален" в данных сотрудника организации? До определенного момента времени так всегда и было, но потом что то пошло не так и теперь после приказа об увольнении необходимо специально лишний раз заходить в "Сотрудники организации" и вручную эту галку убирать(
Просмотров: 120, последний комментарий от fly   
Списание стоимости в рознице при продаже комплектующей в другой ед.измерения [раздел 1С Управление Торговым Предприятием 8]
Автор Inna1C_UTP — 02.05.19, 14:07 — 0 комментариев
"Управление торговым предприятием для Украины", редакция 1.2. (1.2.49.1). Знаю что релиз не последний но на последнем такая же ситуация.

1. Создаю номенклатуру "Тест номенклатура" с типом Товар, которая имеет две ед. измерения:
1шт.=1кг.=1коэф. - основная ед.измерения.
1порц.=0,100кг.=0,1коэф. - дополнительная ед.измерения которая закладываю в набор комплект.

2. Создаю номенклатуру с типом Набор-комплект "Тест комплект" в шт., на вкладке "Комплектующие" выбираю номенклатуру "Тест номенклатура" в ед.измерения порц.=1

3. Создаю Установку цен номенклатуры, Переоценку товаров в рознице- цена в рознице "Тест номенклатуры" =10грн. (за 1шт.), так как установить цену в доп.ед. невозможно, не дает перевыбрать программа в этих документах.
Для номенклатуры "Тест комплект" цена в рознице =25грн. за шт.

4. Покупаю товар "Тест номенклатура" - 1шт. на склад АТТ по цене закупки = 5грн.

5.
По регистру накопления "Товары в рознице" есть запись (приход ПТУ - 1шт.=10грн. (по цене продажи)
По регистру бухгалтерского учета на счете Дт2821 числится 1 шт. =10грн. (по цене продажи)

6. Продаю (сразу в документе ОРП) номенклатуру "Тест комплект" -1 шт. в которую заложена в комплектующих "Тест номенклатура"=1порц.

7.
По регистру "Товары в рознице" - делается запись расход "Тест номенклатуры" 1шт. стоимость 12,5грн. Откуда и почему такая стоимость? Должен быть пересчет при продаже согласно коэф. доп.ед.измерения?
По регистру бухгалтерского учета в Дт 2821 стает цена становится 22грн. а по Кт 2821 -0,100шт. - 12,50грн. Количество списывает правильно а цену берет не понятно какую. Каждый раз при продаже порции этой номенклатуры увеличивается Дт2821 хотя же должно отображаться по цене продажи Дт 2821 и никак иначе?

8. Пыталась и долю стоимости выставлять и менять ее но все равно не корректно учет по цене продажи ведется по Дт счета 2821 и по регистру Товары в рознице. Если продаю все порции в составе комплекта то по регистру Товары в рознице и по регистру бухгалтерии все закрывается в ноль при этом.

Подскажите каков алгоритм работы товаров в рознице если номенклатура входит в состав комплектующей в другой ед.измерения (например купили майонез в пачках(шт.) а продаю порциями в составе хот дога)?



Просмотров: 91, оставить комментарий   
Учет и производство краски [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор AlexanderFree — 28.04.19, 9:30 — 2 комментариев
Добрый день!
Необходимо ввести на предприятии систему учета лако-красочных материалов.
Есть следующая проблема:
При производстве цвета краски используется пропорция (формула) для материалов, например: база:70% г, компонент1: 20% г, компонент2: 10% г.
На складе продукция находится как в кг так и в литрах.

Вопрос: как перевести в 1С кг в литры и обратно (при необходимости) используя плотность материалов и успешно списать со склада?

Вариант поставить на учет все в кг есть, но есть позиции которые отпускаются только в литрах.

Заранее благодарен за наводку

Конфигурация:
УТП для Украины, 1.2.50.1
Просмотров: 162, последний комментарий от Petre   
Сотрудник-совместитель для нескольких организаций [раздел Управление торговлей для Украины редакция 2 (Управление торговлей для России редакция 10)]
Автор vegas — 22.04.19, 14:59 — 2 комментариев
Доброе время суток!
Есть сотрудник который работает по совместительству в нескольких организациях, ни на одной из организаций он не работает на основном месте. Как правильно создать сотрудников в 1с?
Просмотров: 180, последний комментарий от vegas   
Не закрывается 231 счет [раздел 1С Управление производственным предприятием 8]
Автор greatdndz — 16.04.19, 9:29 — 4 комментариев
Добрый день!

Конфигурация УПП 1.3.61, ведется РАУЗ. После расчета себестоимости не закрывается 231 счет по дебету по определенной номенклатурной группе. Подскажите пожалуйста какими отчетами либо другими способами найти ошибку?

Просмотров: 168, последний комментарий от Егор Динин   
Связи Физ лиц с контрагентами [раздел 1С Управление производственным предприятием 8]
Автор jojojoba2 — 12.04.19, 15:01 — 2 комментариев
Добрый день!

Может кто нибудь знает какими справочниками,документами или вообще объектами , а также реквизитами связываются контрагенты и физ лица?
Просмотров: 212, последний комментарий от Vofka   
Объединение клиентов по соглашениям [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор Володька — 12.04.19, 7:06 — 0 комментариев
Уважаемые форумчане! Ищу совета, думаю с таким многие сталкивались:

В базе существуют порядка 3000 клиентов в таком формате:
Клиент 1
Копия Клиент 1
Клиент 2
Копия Клиент 2
....

У каждого из них есть соглашение (индивидуальное)

Нужно из объединить в Клиент 1 (Соглашение 1 и Соглашение 2) ...

По всем ним есть движения (Заказы, Реализации, ПКО)

Пробовал Соглашение Копии Клиента 1 перенести Клиенту 1 пометить на удаление Копию Клиент 1 и через замену изменить Копию Клиент 1 на Клиент 1 во всех местах использования. Ругается на КлючиАналитикиПартнера.

Скажите, как такое можно провернуть?

Просмотров: 130, оставить комментарий   
RSS Текстовая версия Сейчас: 21.05.19, 6:51
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне