Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Передача реквизитов между формами [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 31.03.20, 10:54 — 5 комментариев
1C 7.7 Предприятие
Форма номер 1 - есть данные контрагента ТекущийЭлемент
Форма 2 - журнал документов
Форма 3 - сам документ с полем ввода Контрагент

В форме номер 3 нужно заполнить поле Ввода Контрагент из выбраного в форме 1.
Просмотров: 104, последний комментарий от 4andriy   
Не работает приложение на конкретном устройстве [раздел Мобильная платформа 1С]
Автор vbi — 30.03.20, 17:52 — 5 комментариев
Платформа сборщика приложений: 1С:Предприятие 8.3 (8.3.10.2699)
Сборщик: (2.0.7.48)
JDK: 1.8.0_181
Ant: 1.10.5
android-studio-ide-173.4907809
Мобільна платформа: 8.3.12.67

Собранный APK файл запускается на всех ранее тестированных планшетах и телефонах (Samsung, Xiaomi, Huawei? другие Lenovo), а вот на Lenovo TAB-M8 (TB-8505X) не запускается. Устанавливается, но при запуске - приложение завершилось с ошибкой и все. Ничего не помогает ни переустановка, ни чистка кеша и данных, та же самая проблема и на втором точно таком же планшете. В чем может біть проблема?
Просмотров: 56, последний комментарий от Petre   
Открытие файла web-клиент [раздел Программирование в 1С Предприятие 8.3]
Автор twilight_dream — 29.03.20, 1:46 — 1 комментариев

1С:Предприятие 8.3 (8.3.16.1148)
Конфигурация - любая

Как нонче в последней платформе можно сделать открытие файлов в веб-клиенте, ежели модальные окна запретили от слова совсем, а при выполнении команды "УстановитьРасширениеРаботыСФайлами();" 1С пытается открыть модальное окно, которое сама же и запрещает открывать...

Предвосхищая очень радостный оптимизм:
Просмотров: 76, последний комментарий от Bernet   
Какой знак нужно поставить чтобы реквизиты печатались каждый с новой строки? [раздел Программирование в 1С Предприятие 8.3]
Автор alla35 — 26.03.20, 16:12 — 3 комментариев
Доброго дня! Подскажите пожалуйста, Как добиться чтобы реквизиты печатались каждый с новой строки?
ОбластьМакета.Параметры.ПредставлениеПоставщика = УправлениеНебольшойФирмойСервер.ОписаниеОрганизации(СведенияОбОрганизации, "ПолноеНаименование,КодПоЕДРПОУ,ИНН,НомерСчета,Банк,МФО,ЮридическийАдрес,Телефоны,,Факс,");
Просмотров: 111, последний комментарий от Bernet   
Как в СКД при сохранении отчета чтобы имя файла уже было заполненным? [раздел Программирование в 1С Предприятие 8.3]
Автор twilight_dream — 26.03.20, 15:29 — 4 комментариев
Платформа: 1С:Предприятие 8.3 (8.3.16.1224)
Конфигурация: любая

САБЖ.

Просмотров: 102, последний комментарий от Vladal   
Как создать документ из справочника контрагентов? [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 25.03.20, 16:24 — 9 комментариев
1С 7.7 7.70.027 Предприятие

Есть журнал документов куда нужно зайти и создать документ, тогда выбрать контрагента из справочника и выписать документ.

Как бы реализовать процес наоборот? Зайти в справочник контрагентов и тогда создать для него документ.


 ! 

Правила: 4
 
Просмотров: 306, последний комментарий от 4andriy   
Увеличение количества знаков после запятой при печати НН [раздел Программирование в 1С Предприятие 8.3]
Автор Pashaboston — 25.03.20, 11:40 — 0 комментариев
Конфигурация BAS Бухгалтерія, редакція 2.1 (2.1.5.4) , платформа 1С:Предприятие 8.3 (8.3.15.1489). Как уваличить число знаков при печати налоговой накладной после запятой в цене(нужно 5), количество в макете и документе я сделал. Но на печать выводит всегда 2 знака. В отдалчике при заполнении праметров области макета показивает 5 знаков. В свойствах ячейки цени в режиме предприятия показивает формат ЧЦ=15; ЧДЦ=2; ЧН=-, а в конфигкраторе стоит ЧЦ=15; ЧДЦ=5; ЧН=-.
Просмотров: 60, оставить комментарий   
Ограничения по Рабочему столу [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 20.03.20, 15:32 — 0 комментариев
Приветствую, Форумчане!
1с8.3.12, УФ, самопис, БСП

В командном интерфейсе основного раздела прописан документ "Заказы" (их там много, чисто для примера)

Как известно, "Рабочий стол" всегда на глазах и там отображаются все метаданные, прописанные в интерфейсе основного раздела

Для одного пользователя была сделана специально одна подсистема, куда нагромодили ему нужные метаданные...

Для того, чтобы документы не отражались у этого пользователя на рабочем столе (рабочий стол вообще должен быть пуст), в роли этого пользователя у всех документах убрал право "Просмотр"
Действительно, все с рабочего стола исчезло, но...

При работе этого пользователя ему нужно выбрать документ из "Заказы". При выборе выходит сообщение "Не достаточно прав для просмотра"
Это и понятно, т.к. я убрал из роли это право.

Если верну право, то "Заказы" отображаются на рабочем столе...

Подскажите, каким образом можно добится, если конечно можно, чтобы в моей ситуации было право просмотра (выбора), но и на рабочем столе это не отражалось?
(если есть вариант как вырубить рабочий стол, то можно и это рассмотреть, вдруг кто-нить таки придумал такое чудо)
Просмотров: 91, оставить комментарий   
Мария 301 МТМ «Невозможно открыть COM порт» [раздел Работа с торговым оборудованием]
Автор Володька — 20.03.20, 10:31 — 4 комментариев
Добрый день!
Имеется Мария 301 МТМ (фискализированная) и ломаный драйвер (доступен в интернете с открытым исходным кодом).

Пользователи подключаются по RDP

Для файловой базы написал Общий модуль - работает без нареканий.

А вот на SQL-версии при попытке вызвать Драйвер.ОткрытьПорт(Порт, Скорость) постоянно выдает ошибку «Невозможно открыть COM порт».

Наличие проброшенного порта проверял, всё есть.
Консоль Марии на удаленном столе запускал (по нужно порту) всё отлично.

Дайте совет, как найти и решить проблему, я опускаю руки(
Просмотров: 193, последний комментарий от Володька   
Сгруппировать и сравнить в ТЧ записи по определенному отбору [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 19.03.20, 11:51 — 1 комментариев
Приветствую, Форумчане!
1с8.3.12, УФ, самопис

В ТЧ есть два реквизита "ТипДанных" и "Оформитель" (все перечисления)

Покрытие - Офис
Покрытие - Офис
Покрытие - Производство
Покрытие - Производство
Ерунда1 - Игнор
Ерунда1 - Игнор

Требуется проанализировать только по парам "Покрытие - Офис" и "Покрытие - Производство"
Т.е. проверить наличие этих пар в ТЧ, причем главным условием должно быть наличие только одной из этих пар: если есть обе, то это очень плохо и больно...

Проверка идет перед записью в модуле объекта.

Перепробовал несколько мыслей:

СтруктураДляПоиска.Вставить("ТипДанных, Оформитель", Перечисления.ТипыДанныхОформления.Покрытие, Перечисления.СпособыИзготовления.Производство);
МассивСтрокНаПроизводстве = Оформление.НайтиСтроки(структураДляПоиска);

там нужно использовать только один параметр для поиска

ПроверкаПокрытия.Свернуть("ТипДанных", "Оформитель");

требует число в суммируемом поле

Использовать запрос не удобно, т.к. проверка может идти для нового документа

Посоветуйте как правильно свернуть, сгруппировать или есчё что-нить, чтобы получить мечту жизни?

Просмотров: 102, последний комментарий от TohaMonster   
Заполнить данные в выбранном элементе справочнике при выборе в поле ввода [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 18.03.20, 23:49 — 3 комментариев
1С 7.70.027
2 справочника: Склады и сотрудники.
В форме "Склады" в форму добавил "Поле ввода" в котором из справочника Сотрудников выбираю ответственного.
Процедурой надо прописать данные склада в справочник с сотрудниками.

Процедура НазначОтв()
Сообщить(Отв.Должность);
Элемент=СоздатьОбъект("Справочник.Сотрудники");
Элемент.найтиЭлемент(ТекущийЭлемент());
//вариант 1
Элемент.Отв.Должность="склад 1";
//вариант 2
Элемент.Сотрудники.Должность="склад 1";
//вариант 3
Элемент.Должность="склад 1";
Элемент.Записать();
КонецПроцедуры


в трех вариантах не работает.
Просмотров: 166, последний комментарий от 4andriy   
Получить ссылочную ячейку расшифровки отчета на БСП в отдельной форме [раздел Система компоновки данных]
Автор Constantus — 16.03.20, 12:37 — 6 комментариев
Приветствую, Форумчане!
1с8.3.12, самопис, УФ

Имеется отчет СКД "Отчет по кассовым сменам" (достался в наследство и до этого подобных отчетов никогда не использовал в практике, даже не знал об таком)


Двойной клик на "Закрыто" вызывает расшифровку по стандартам БСП


Эта расшифровка открывается формой в отчете СКД "ФормаРасшифровкиОтчета" средствами БСП

Расшифровка работает, но требуется, чтобы на расшифровке поля "Ссылка", где отображены документы при двойном клике открывался документ.

Перечитал всякого. Понял, что это добивается Макетом в "ОсновнаяСхемаКомпоновкиДанных"
Макет выглядит так:


Сама расшифровка берется из второго макета СКД "СхмаРасшифровкиОтчета" со своим отчетом, где и берутся все поля в расшифровке.
На форме расшифровке стоит "Результат" с типом ТабличныйДокумент, куда и загоняются все данные.

Читал доки, но никак не смог сообразить как это наследство доработать. Подскажите на простом языке, как мне добится открытие документа по ссылке в расшифровке отчета?
Просмотров: 161, последний комментарий от Constantus   
Не срабатывает подсчет количества в запросе [раздел Программирование в 1С Предприятие 8.3]
Автор svetas_l — 15.03.20, 20:13 — 7 комментариев
ЕСТЬ ФУНКЦИЯ -которая должна возвращать существующую характеристику или создавать новую, если текущая не найдена,
причем сам запрос в консоли запросов отрабатывает, но в функции не хочет. В результате функция создаёт к одной номенклатуре 16 характеристик одинаковых, а должна только одну.
В чем ошибка?

Код
  
Функция СоздатьХарактеристику(Номенклатура,Цвет)
// ХарактеристикиНоменклатуры
перем  kol;
kol=0;
    Запрос = Новый Запрос;
    Запрос.Текст = "
    |ВЫБРАТЬ
    |    количество(ХарактеристикиНоменклатуры.Ссылка) КАК Количество_Характеристик
    |ИЗ
    |    Справочник.ХарактеристикиНоменклатуры.ДополнительныеРеквизиты КАК ХарактеристикиНоменклатуры
    |ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Номенклатура КАК Номенклатура
    |    ПО ХарактеристикиНоменклатуры.Ссылка.Владелец = Номенклатура.Ссылка
    |ЛЕВОЕ СОЕДИНЕНИЕ ПланВидовХарактеристик.ДополнительныеРеквизитыИСведения КАК ДополнительныеРеквизитыИСведения
    |    ПО ХарактеристикиНоменклатуры.Свойство = ДополнительныеРеквизитыИСведения.Ссылка
    |ГДЕ
    |    Номенклатура.Наименование = &Номенклатура_    
    |    И ДополнительныеРеквизитыИСведения.Наименование = ""Цвет (Мотоциклы (Для характеристик))""
    |    И ХарактеристикиНоменклатуры.Значение = &Цвет_
    |";

Запрос.УстановитьПараметр("Номенклатура_", СокрЛП(Строка(Номенклатура)));
Запрос.УстановитьПараметр("Цвет_", СокрЛП(Строка(Цвет)));

    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДокументов = РезультатЗапроса.Выбрать();

    Пока ВыборкаДокументов.Следующий() Цикл
       kol=kol+ (ВыборкаДокументов.Количество_Характеристик);
    КонецЦикла;




Если kol=0 Тогда
     Цвет = Справочники.ЗначенияСвойствОбъектов.НайтиПоНаименованию(СокрЛП(Строка(Цвет)));
    СоздадимХарактеристику = Справочники.ХарактеристикиНоменклатуры.СоздатьЭлемент();
СоздадимХарактеристику.УстановитьНовыйКод();
СоздадимХарактеристику.Владелец =Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(Строка(Номенклатура)));
СоздадимХарактеристику.УстановитьСсылкуНового(Справочники.ХарактеристикиНоменклатуры.ПолучитьСсылку(Новый УникальныйИдентификатор));
  СоздадимХарактеристику.Наименование =  Цвет;
СоздадимХарактеристику.НаименованиеПолное=  Цвет;

    НовоеСвойство3=СоздадимХарактеристику.ДополнительныеРеквизиты.Добавить();
    НовоеСвойство3.Свойство=ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию(Строка("Цвет (Мотоциклы (Для характеристик))"));
    НовоеСвойство3.Значение= СокрЛП(Строка(Цвет));
НовоеСвойство3.ТекстоваяСтрока= СокрЛП(Строка(Цвет));

Попытка
      СоздадимХарактеристику.Записать();
Возврат СоздадимХарактеристику.Ссылка;
Исключение
      Сообщить("Не удалось записать элемент справочника. " + ОписаниеОшибки());
  Возврат неопределено;
    КонецПопытки;  

    
ИначеЕсли kol>0 тогда
Запрос.УстановитьПараметр("Номенклатура_", СокрЛП(Строка(Номенклатура)));
Запрос.УстановитьПараметр("Цвет_", СокрЛП(Строка(Цвет)));


    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДокументов = РезультатЗапроса.Выбрать();

    Пока ВыборкаДокументов.Следующий() Цикл
       Характеристика = ВыборкаДокументов.Характеристика;
    КонецЦикла;


kol=0;
Возврат  Характеристика;

КонецЕсли;

КонецФункции
Просмотров: 206, последний комментарий от svetas_l   
Есть ли весомые причины использовать расширения в системе, к которой есть полный доступ? [раздел Программирование в 1С Предприятие 8.3]
Автор Vofka — 13.03.20, 15:51 — 6 комментариев
Вопрос к этому сообщению.

Petre, какой смысл использовать расширения, если есть полный доступ к системе? Обновляться автоматически? А сопутствующих проблем в итоге не больше получается? Вопрос без подвоха.
Просмотров: 193, последний комментарий от Petre   
Открыть форму и дождаться ее закрытия для выполнения следующих кодов [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 11.03.20, 18:38 — 3 комментариев
Приветствую, Форумчане!
1с8.3.12, самопис, УФ

Имеется некий большой код в модуле формы. В код вставляется открытие формы:

    Оповещение = Новый ОписаниеОповещения("ОткрытьПараметрыЗавершение", ЭтотОбъект);
    
    ПараметрыОткрытия = Новый Структура;
    ПараметрыОткрытия.Вставить("Подразделение", Объект.ТекущееПодразделение);
    ПараметрыОткрытия.Вставить("АдресТаблицыИзделий", АдресТаблицыИзделий());
    
    ОткрытьФорму("Документ.Заказ.Форма.ФормаПроверкиСкладовВыставки", ПараметрыОткрытия, ЭтотОбъект,,,,Оповещение,РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);

    //55782 -->
    РезультатПроверки = ПереводВСтатусРазрешен(ПредопределенноеЗначение("Перечисление.СтатусыЗаказов.Открыт"));
    Если РезультатПроверки.ЕстьОшибки Тогда
        
        ПоказатьПредупреждение(, РезультатПроверки.ОписаниеОшибки, 5, "Изменение статуса заказа");
        Возврат;
    
    КонецЕсли;


Открытие срабатывает и даже срабатывает то, что нужно сделать в этой открытой форме.
Но программа не дожидается закрытия этой формы и продолжает выполнение всех остальных кодов, что следуют за открытием, т.е. в данном случае, форма открывается, но код

РезультатПроверки = ПереводВСтатусРазрешен(ПредопределенноеЗначение("Перечисление.СтатусыЗаказов.Открыт"));
    Если РезультатПроверки.ЕстьОшибки Тогда


Срабатывает, недожидаясь завершения работы открытой формы "ФормаПроверкиСкладовВыставки"

Никак не могу добится этого эффекта модальности, чтобы всё замерло до закрытия открытой формы...
Посоветуйте
Просмотров: 170, последний комментарий от Petre   
Допоможіть витягнути залишки товарів з цінами [раздел Программирование в 1С Предприятие 7.7]
Автор kasatik — 10.03.20, 22:24 — 3 комментариев
Доброго дня.
Допоможіть в ситуації. В одному продуктовому магазині поставили програму обліку на базі 1с7,7. Програміст сам її написав, понаставляв захистів, привязав до одного компа. При спробі перенести на інший комп - конфігурація не запускається. Якщо витягнути вінчестер і вставити в інше залізо - запускається , але нема залишків товару.
З'явилась потреба перейти на якусь серйознішу конфігурацію.
Сам автор візмовляється переносити дані в іншу конфігурацію. За гроші може допиляти під клієнта, а хочете перейти на іншу - колупайтесь самі...
Просмотров: 239, последний комментарий от kasatik   
Как создать поиск клиента по номеру телефона [раздел Программирование в 1С Предприятие 7.7]
Автор Danaza — 09.03.20, 13:56 — 2 комментариев
Здравствуйте. В накладной есть 3 ячейки: Клиент, номер телефона и дисконтная карта. Если ввести номер дисконтной карты - автоматически выбивает Клиента и номер телефона. Если клиента вводить через каталог - автоматически выбивает дисконтную карту и номер телефона. А вот ячейка номер телефона таким способом не работает. Она имеет тип Строка. Прописав модуль она начинает работать, если изменить тип на Число, но при этом в программе происходит утеря данных уже существующих клиентов (существующие номера теряют цифры), да и при в вводе номера (0...........) 0-не вбивает.
Просмотров: 192, последний комментарий от Sharzem   
Создать обновление цен в накладной при копировании старой [раздел Программирование в 1С Предприятие 7.7]
Автор Danaza — 09.03.20, 13:42 — 5 комментариев
Здравствуйте. Подскажите, пожалуйста, способы обновления цен в старой накладной на новые. Т.е. если нужно сделать дубль накладной прошлого, допустим, года, а в ней стоят старые цены и поменять можно только вручную. Есть вариант, сделать автоматически или кнопку добавить?
Просмотров: 226, последний комментарий от denis84   
программное заполнение ссылки на вновь созданную характеристику номенклатуры ERP управляемые формы 8.3 [раздел Программирование в 1С Предприятие 8.3]
Автор svetas_l — 09.03.20, 12:46 — 40 комментариев
Добрый день!
создаю новую характеристику номенклатуры ERP управляемые формы 8.3
&НаСервере

Функция СоздатьХарактеристику(Номенклатура,Цвет)
    // ХарактеристикиНоменклатуры
  Запрос = Новый Запрос;
  Запрос.Текст = "
|ВЫБРАТЬ
|    ХарактеристикиНоменклатуры.Ссылка КАК Характеристика,
|    ХарактеристикиНоменклатуры.НомерСтроки,
|    ХарактеристикиНоменклатуры.Свойство,
|    ХарактеристикиНоменклатуры.Значение,
|    ХарактеристикиНоменклатуры.ТекстоваяСтрока,
|    ХарактеристикиНоменклатуры.Ссылка КАК Ссылка1,
|    ХарактеристикиНоменклатуры.Ссылка.Владелец,
|    ХарактеристикиНоменклатуры.Ссылка.Принципал,
|    ХарактеристикиНоменклатуры.Ссылка.Контрагент,
|    ХарактеристикиНоменклатуры.Ссылка.Предопределенный,
|    ХарактеристикиНоменклатуры.Ссылка.ИмяПредопределенныхДанных,
|    ХарактеристикиНоменклатуры.Ссылка.ИмяПредопределенныхДанных КАК ИмяПредопределенныхДанных1,
|    ХарактеристикиНоменклатуры.Свойство.ТипЗначения,
|    Номенклатура.Ссылка КАК Ссылка2,
|    Номенклатура.Наименование
|    ИЗ
|    Справочник.ХарактеристикиНоменклатуры.ДополнительныеРеквизиты КАК ХарактеристикиНоменклатуры
|        ПОЛНОЕ СОЕДИНЕНИЕ Справочник.Номенклатура КАК Номенклатура
|        ПО ХарактеристикиНоменклатуры.Ссылка.Владелец = Номенклатура.Ссылка
|        ЛЕВОЕ СОЕДИНЕНИЕ ПланВидовХарактеристик.ДополнительныеРеквизитыИСведения КАК ДополнительныеРеквизитыИСведения
|        ПО ХарактеристикиНоменклатуры.Свойство = ДополнительныеРеквизитыИСведения.Ссылка
|ГДЕ
|      Номенклатура.Наименование = &Номенклатура_

|    И ДополнительныеРеквизитыИСведения.Наименование = ""Цвет (Мотоциклы (Для характеристик))""
|    И ХарактеристикиНоменклатуры.Значение ПОДОБНО &Цвет_
|";

Запрос.УстановитьПараметр("Номенклатура_",    Номенклатура);
Запрос.УстановитьПараметр("Цвет_",    Цвет);
РезультатЗапроса = Запрос.Выполнить().Выбрать();

Если РезультатЗапроса.Количество()=0   Тогда
    
     GUID=Новый УникальныйИдентификатор();
     СоздадимХарактеристикуСсылка=  Справочники.ХарактеристикиНоменклатуры.ПолучитьСсылку(GUID);
     СоздадимХарактеристику = Справочники.ХарактеристикиНоменклатуры.СоздатьЭлемент();
     СоздадимХарактеристику.УстановитьНовыйКод();
     СоздадимХарактеристику.Владелец =Справочники.Номенклатура.НайтиПоНаименованию(Номенклатура);
            
     НовоеСвойство3 =СоздадимХарактеристику.ДополнительныеРеквизиты.Добавить();  
      НовоеСвойство3.Свойство = "Цвет (Мотоциклы (Для характеристик))";
     НовоеСвойство3.Значение = СокрЛП(Строка(Цвет));
     НовоеСвойство3.ТекстоваяСтрока = СокрЛП(Строка(Цвет));
    
     СоздадимХарактеристику.НаименованиеПолное  =Строка(НовоеСвойство3.Значение);
     СоздадимХарактеристику.Наименование =  Строка(НовоеСвойство3.Значение);
      СсылкаНового=Справочники[СоздадимХарактеристику.ЭтотОбъект.Метаданные().Имя].ПолучитьСсылку();
     СоздадимХарактеристику.УстановитьСсылкуНового(СоздадимХарактеристикуСсылка);    

    Попытка
     СоздадимХарактеристику.Записать();
     Исключение
     Сообщить("Не удалось записать элемент справочника. " + ОписаниеОшибки());
    КонецПопытки;  
    
      Возврат СоздадимХарактеристику;
Иначе
    
    Пока РезультатЗапроса.Следующий() Цикл
      Характеристика = РезультатЗапроса.Характеристика;
    КонецЦикла;
  Возврат  Характеристика;
КонецЕсли;

КонецФункции



но ссылка не заполняется


а нужно на выходе из функции передать именно ссылку.
Помогите, пожалуйста.
Просмотров: 841, последний комментарий от Vofka   
Подключение к источнику данных (прерывание выполнения обработки) [раздел Программирование в 1С Предприятие 8.3]
Автор Malus — 07.03.20, 23:35 — 0 комментариев
Добрый день!
Конфигурация: Управление небольшой фирмой для Украины, редакция 1.6 (1.6.10.1)

Использую подключение к внешним источникам данных. Столкнулся с проблемой постоянного появления этой формы, при выполнении обработки (само выполнение прерывается).


В коде нашел, что эта форма запускается от сюда:
СписокФорм.Добавить("ВнешняяОбработка.StandardExternalDataSourceManagement.Форма.Form"

Думал мб подправить на автопереподключение, но не понимаю где это "ВнешняяОбработка".

Так же заметил, что эта проблема появилась после перехода на MSSql, в файловой базе таких прерываний не было.

Подскажите как сделать так чтобы обработка завершалась без прерывания, происходило автоматическое переподключение к внешним источниками.

Спасибо.
Просмотров: 126, оставить комментарий   
RSS Текстовая версия Сейчас: 01.04.20, 0:45
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!