Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Пошук точної фрази в списку номенклатури [раздел Вся 1С]
Автор slavikdr — 06.10.22, 12:03 — 1 комментариев
Доброго дня. Задача виникла зі збільшенням кількості товарів, не можу розібратись з функціоналом.
є куча товарів, назва в форматі
товар ВИРОБНИК МОДЕЛЬ НОМЕР. Причому номер часто повторюється в різних товарах. Так само це зустрічається в полі партномерів, які теж виведені в форму списку.
В стандартному пошуку форми списку пробую шукати товари, наприклад МОДЕЛЬ НОМЕР, і видає все що має і МОДЕЛЬ і НОМЕР.
Тобто воно шукає товари по кожному слово окремо. В розширеному пошуку можна зробити відбір по точній фразі, але таке не підходить, бо треба робити пошук по всіх полях зі списку - і в назві, і в партномері.
Питання - як в стандартному пошуку добитись відповідності по точній фразі, щоб шукало тільки обидва входження але по всіх полях довідника?
Ніби проста задача, і воно має бути якось реалізовано на рівні платформи, але я вже пів дня гуглю - все без толку.
Просмотров: 23, последний комментарий от AnryMc   
проблема адаптации обработки [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 05.10.22, 10:18 — 0 комментариев
при открытии сторонней обработки были ошибки в строках, я поправил обрабока открылась, но не работают другие функции, подозреваю что неправильно адаптировал
//ИдентификаторКонфигурации = глИдентификаторКонфигурации(); - было с (), поставил без () и ошибка пропала
ИдентификаторКонфигурации = глРедакцияКонфигурации;
//СуммаЭксп = СокрЛ(Формат(глПересчет(Сумма,Валюта,Гривна,Курс,ДатаДок),"Ч17.2.")); - Курс и ДатаДок пришлось убрать но наверно из-за этого не работает сама обработка
СуммаЭксп = СокрЛ(Формат(глПересчетВалютыПоКурсу(Сумма,Валюта,Гривна),"Ч17.2.")); - тут может быть ошибка
Просмотров: 65, оставить комментарий   
Оновити обробку в "Додаткових звітах та обробках" (програмно [раздел Программирование в 1С Предприятие 8.3]
Автор Inkognito — 29.09.22, 8:57 — 6 комментариев
BAS Бухгалтерія 2.1
Необхідно оновити обробку в переліку "Додаткових звітів та обробок" програмно (додавання реалізовано, але необхідно саме оновленнія, якщо версія поточна вище):

Код

&НаКлиенте
Процедура Тест()
ОбработкаСсылка = ПолучитьСсылкуОбработки();

Если НЕ ОбработкаСсылка.Пустая() Тогда            
         знВерсии= УзнатьВерсиюОбработки(ОбработкаСсылка);
        
         Если знВерсии<АктуальнаяВерсия Тогда
//???
//припустимо, нова обробка тут: КаталогВременыхФайлов() + "ВнешняяОбработка2";
КонецЕсли;
КонецЕсли;


&НаСервере
Функция ПолучитьСсылкуОбработки()
    
    Возврат Справочники.ДополнительныеОтчетыИОбработки.НайтиПоРеквизиту("ИмяФайла", "ВнешняяОбработка1");

КонецФункции

&НаСервере
Функция УзнатьВерсиюОбработки(ОбработкаСсылка)
    
    Возврат ОбработкаСсылка.Версия;
    
КонецФункции
Просмотров: 203, последний комментарий от sava1   
не могу передать значение с таблицы [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 23.09.22, 17:00 — 5 комментариев
    КоличествоСтрок = спДанные.Получить("КоличествоСтрок");
    Для ном = 1 По КоличествоСтрок Цикл
        ТекСтрока = "R" + Прав("000" + ном,4);
        rsMain.Fields.Item("TAB1_A1").Value = ном;
        rsMain.Fields.Item("TAB1_NOMENKLATURA_NAME").Value = спДанные.Получить(ТекСтрока + "ТоварНаименование");
        rsMain.Fields.Item("TAB1_OV_NAME").Value = спДанные.Получить(ТекСтрока + "Единица");
        rsMain.Fields.Item("TAB1_A3").Value = спДанные.Получить(ТекСтрока + "Количество");
        rsMain.Fields.Item("TAB1_A5").Value = спДанные.Получить(ТекСтрока + "ЦенаБезНДС");
        rsMain.Fields.Item("TAB1_A6").Value = спДанные.Получить(ТекСтрока + "Сумма");
        rsMain.Post();
        Если ном <> КоличествоСтрок Тогда
            rsMain.Append();
        КонецЕсли;
    КонецЦикла;


ошибка:

rsMain.Fields.Item("TAB1_OV_NAME").Value = спДанные.Получить(ТекСтрока + "Единица");
Неизвестная ошибка


заработало
Просмотров: 300, последний комментарий от 4andriy   
запуск 1с на windows xp и 7 паралельно [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 23.09.22, 14:33 — 1 комментариев
1с 7.7
если запустить на windows xp - работает
если запустить на windows 7 ошибка:
порядок сортировки, установленный для базы данных отличасется от системного
тогда надо менять сортировку и тогда на xp не работает( и опять менять сортировку
Просмотров: 132, последний комментарий от denis84   
Не работает выборка документов [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 23.09.22, 12:41 — 3 комментариев
при выборке документов така ошибка:

Цитата
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: СуммаБезНДС = Документ.РасходнаяНакладная. <<?>> СуммаБезНДС;
Запрос[7] : Неверно заданный путь 'СуммаБезНДС'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: СуммаСНДС = Документ.РасходнаяНакладная. <<?>> СуммаСНДС;
Запрос[8] : Неверно заданный путь 'СуммаСНДС'
СУММАБЕЗНДС<<?>>
Переменная не определена (СУММАБЕЗНДС)
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: Функция СуммаБезНДС_ = Сумма(СуммаБезНДС <<?>> );
Запрос[9] : Ошибка в выражении 'СуммаБезНДС'
СУММАСНДС<<?>>
Переменная не определена (СУММАСНДС)
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: Функция СуммаСНДС_ = Сумма(СуммаСНДС <<?>> );
Запрос[10] : Ошибка в выражении 'СуммаСНДС'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: Условие(Фирма в ВыбФирма <<?>> );
Запрос[14] : Ошибка в условии
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: Условие(Контрагент в список <<?>> );
Запрос[15] : Ошибка в условии
Просмотров: 187, последний комментарий от denis84   
ошибка при открытии обработки [раздел Программирование в 1С Предприятие 7.7]
Автор 4andriy — 22.09.22, 18:31 — 1 комментариев
ИдентификаторКонфигурации = глРедакцияКонфигурации();

Спр = СоздатьОбъект("Справочник.Пользователи");
Если ИдентификаторКонфигурации = "UBUTK" Тогда //Бухгалтерский учет для Украины    
    Если Спр.НайтиПоНаименованию(ИмяПользователя(), 1) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
ИначеЕсли ИдентификаторКонфигурации = "UBUOUSL" Тогда //"Бухгалтерия+Торговля+Склад+Зарплата+Кадры" для Украины
    спВидиДокументів.ВставитьЗначение(5,"Т_РасходнаяНакладная","Видаткова накладна (товари)");
    Если Спр.НайтиПоКоду(ИмяПользователя(), 0) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
ИначеЕсли ИдентификаторКонфигурации = "UManf" Тогда //Производство+Услуги+Бухгалтерия для Украины
    Если Спр.НайтиПоКоду(ИмяПользователя(), 0) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
ИначеЕсли ИдентификаторКонфигурации = "UOUTK" Тогда //Торговля+Склад для Украины
    ОказаниеУслугНом = спВидиДокументів.НайтиЗначение("ОказаниеУслуг");
    Если ОказаниеУслугНом > 0 Тогда
        спВидиДокументів.УдалитьЗначение(ОказаниеУслугНом);
    КонецЕсли;
    Если Спр.НайтиПоКоду(ИмяПользователя(), 0) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
Иначе
    ТекущийПользователь = "";
КонецЕсли;


в глобальном модуле есть:
Перем глРедакцияКонфигурации Экспорт;//это для сравнения редакции конфигурации и константы "РедакцияКонфигурации"


ошибка:
ИдентификаторКонфигурации = глРедакцияКонфигурации<<?>>();
...: Функция не обнаружена (глРедакцияКонфигурации)
Просмотров: 143, последний комментарий от denis84   
Вивантаження Акта звірки в xml для завантаження в Медок [раздел Программирование в 1С Предприятие 7.7]
Автор kostya77 — 15.09.22, 11:54 — 4 комментариев
Добрий день. Підкажіть, можливо хто вирішував подібну задачу, як реалізувати?
Просмотров: 234, последний комментарий от mut   
Прорахунок кілометража між точками по координатам [раздел Вся 1С]
Автор wargys1986 — 14.09.22, 15:25 — 3 комментариев
Доброго дня. Поставили задачу, прорахунок кілометража між точками по координатам , та промальовка маршрута. Хто з цим стикався ? Дякую Всім хто відгукнеться
Просмотров: 270, последний комментарий от mut   
Підключення з 1с7 до 1с8 для запуску обробки [раздел Программирование в 1С Предприятие 7.7]
Автор kostya77 — 06.09.22, 10:46 — 3 комментариев
Добрий день. Підкажіть, чи можливо з 1с7 підключитися до 1с8 і в 1с8 запустити обробку?
Просмотров: 288, последний комментарий от sava1   
Нетиповой отбор в форме списка документа [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор kserg2012 — 02.09.22, 12:22 — 3 комментариев
Платформа 8.3.18
Управление торговлей для Украины", редакция 2.3.30.1 (обычные формы)

Есть форма списка документа ЗаказПокупателя.
На форме была добавлена новая колонка "Процент оплаты по заказу", которая заполняется по отдельному запросу в Процедура СписокПриПолученииДанных

Возникла необходимость сделать полноценный отбор по данной колонке, и как то не получается придумать что-то "дельное"...

Подскажите какие возможны варианты реализации такого отбора?
(с учётом того, что пользователь может задавать и другие условия через типовой механизм отборов формы)

Спасибо
Просмотров: 351, последний комментарий от alex1c   
Отправка почты с UKR.NET [раздел Программирование в 1С Предприятие 8.3]
Автор One — 02.09.22, 10:33 — 3 комментариев
1С:Предприятие 8.3 (8.3.8.1861)

UKR.net сейчас поддерживает только IMAP

у кого-нибудь получилось настроить отправку из 1С?
Просмотров: 402, последний комментарий от Anderson   
Передача изображения на сервер MyDrop [раздел Программирование в 1С Предприятие 8.3]
Автор Multilobster — 01.09.22, 12:15 — 2 комментариев
Привет.

Бьюсь на задачей передачи изображения. Перепробовал разные методы, но сервер все все упирается: {"message":"The browser (or proxy) sent a request that this server could not understand."} Подозреваю, что проблема в том, что в теле запроса помимо двоичных данных не указан ключ "file". Подскажите, кто знает, как это сделать?

Вот рекоммендации техподдержки сайта:



Цитата
POST-запрос на https://backend.mydrop.com.ua/vendor/products/upload
тело запроса на скриншоте. т.е. ключ в форме называется file, а в значение передаётся бинарное значение фотки


разделитель = "test";
    ФайлОтвета = КаталогВременныхФайлов()+ "\answer.txt";
    
    потоквпамяти = новый потоквпамяти();
    записьданных = новый записьданных(потоквпамяти);
    
    ДвоичныеДанные = Новый ДвоичныеДанные("C:\pics\797-BILA-779-B.jpg");
    
    записьданных.Записатьстроку("--"+разделитель);
    записьданных.Записать("file: ");
    записьданных.Записать(ДвоичныеДанные);
    записьданных.Записатьстроку("");
    
    записьданных.Записатьстроку("--"+разделитель+"--");
    записьданных.Закрыть();
    
    телозапроса = потоквпамяти.ЗакрытьИПолучитьДвоичныеДанные();
    
    Соединение = Новый HTTPСоединение("backend.mydrop.com.ua",,,,,,Новый ЗащищенноеСоединениеOpenSSL());
    
    Запрос = Новый HTTPЗапрос("/vendor/products/upload");

    Запрос.Заголовки.Вставить("X-API-KEY", "ххх");
    Запрос.Заголовки.Вставить("Content-Type", "multipart/form-data; boundary=" + разделитель);
    
    запрос.УстановитьТелоИзДвоичныхДанных(телозапроса);
    
    Ответ = Соединение.ОтправитьДляОбработки(Запрос, ФайлОтвета);
Просмотров: 327, последний комментарий от mut   
Динамический список и странное поведение [раздел Программирование в 1С Предприятие 8.3]
Автор Andry.Boris — 31.08.22, 17:05 — 11 комментариев
День добрый!

Прошу помощи у сообщества.

Решил модифицировать список номенклатуры для удобства работы,
чтобы можно было видеть аналоги номенклатуры и картинки
прикрепленные к номенклатуре, на одной общей форме.
Для начала, перенес список номенклатуры в расширение.
Добавил на форму ниже "Списка" номенклатуры вывод "Аналогов" номенклатуры (как дин. список).
Связал по ключевому полю через УстановитьЗначениеПараметра дин. списка.
Пока все работает нормально, при выборе в "Списке" номенклатуры ниже в "Аналогах" отображаются аналоги.
Решил добавить еще на форму вывод картинок слева на форме.
Добавил страницу и создал там поле ввода с видом "Поле картинки".
Количество картинок генерируется автоматически по наличию вложенных картинок текущего элемента списка.
и вот тут начитается полная чехарда, после заполнения картинок, пропадает содержимое основного дин. списка "Список". Заметил по отладчику, при заполнении картинок постоянно обновляется основной дин. списка "Список". В общем не могу понять почему постоянно при заполнение картинок срабатывает событие "СписокПриАктивизацииСтрокиПосле". Может кто сталкивался с таким поведением? Почему так происходит или как правильно выводить картинки? И к тому же постоянно теряется фокус текущей строки в дин. списке "Список".

Просмотров: 1053, последний комментарий от Vofka   
Період в журналі відбору [раздел Программирование в 1С Предприятие 7.7]
Автор kostya77 — 31.08.22, 14:41 — 2 комментариев
Добрий день. Підкажіть, будь ласка. як передати період в журла відбору?
Просмотров: 309, последний комментарий от denis84   
позиционирование после стандартного поиска [раздел Программирование в 1С Предприятие 8.3]
Автор iksteram — 30.08.22, 14:40 — 7 комментариев
Управляевые формы. Можно ли сделать в динамическом списке (справочник Номенклатура) что бы после стандартного поиска происходило позиционирование на список (первую строку списка)? Как вариант после нажатия клавиши Enter.? Спасибо.
Просмотров: 338, последний комментарий от AnryMc   
отправка массива POST запросом [раздел Программирование в 1С Предприятие 8.3]
Автор Multilobster — 29.08.22, 13:40 — 3 комментариев
привет.

пытаюсь обновить инфу о товаре на mydrop.com.ua. ответ сервера: {"message":"The method is not allowed for the requested URL."} схожий запрос отправляю для создания заказа - все ок. помогите найти проблему, плиз.

мануал к api: https://api.mydrop.com.ua/#88c45a7ee1

тело запроса:
Цитата
[
{
"sku": "897-1790",
"assembly_price": 999
}
]


    
        ЗаписьJSON         = Новый ЗаписьJSON;
    ЗаписьJSON.УстановитьСтроку(Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Авто, " ", Истина));
    
    массив = Новый массив;
    
    тДанные = Новый Структура;
    тДанные.Вставить("sku",     тов.Артикул);
    тДанные.Вставить("assembly_price", 999);
    
    массив.Добавить(тДанные);
    
    ЗаписатьJSON(ЗаписьJSON, массив);
    
    СтрокаJS = ЗаписьJSON.Закрыть();
    
    ФайлОтвета = КаталогВременныхФайлов()+ "\answer2.txt";
    
    Соединение  = Новый HTTPСоединение("backend.mydrop.com.ua",,,,,,Новый ЗащищенноеСоединениеOpenSSL());
    Запрос         = Новый HTTPЗапрос("/vendor/api/products");
    
    Запрос.Заголовки.Вставить("X-API-KEY", "хххххххххх");
    Запрос.Заголовки.Вставить("Content-Type", "application/json");

    запрос.УстановитьТелоИзСтроки(СтрокаJS);
    
    Ответ = Соединение.ОтправитьДляОбработки(Запрос, ФайлОтвета); //POST
Просмотров: 499, последний комментарий от Multilobster   
RSS Текстовая версия Сейчас: 06.10.22, 16:13
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!