Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Чек-лист в 1с [раздел Программирование управляемых форм 1С 8.2]
Автор Constantus — 19.04.19, 8:40 — 1 комментариев
Приветствую, Форумчане!
1с8.3.6, самописная, БСП, УФ

Имеется задание сформировать чек-лист проверок, имеются куча вопросов, сгруппированных по смыслу.

Как оптимально создать такой чек-лист?

Создам справочник иерархический с этими вопросами.
Создам документ.

Как создать документ с табличной частью в виде дерева, где основными узлами будут папки иерархии (родители) этого справочника?
Просмотров: 69, последний комментарий от Petre   
Ошибка преобразования данных XDTO [раздел Программирование в 1С Предприятие 8.3]
Автор sanytch — 18.04.19, 16:15 — 4 комментариев
Доброго времени суток. Столкнулся с проблемой, которая пока-что за гранью моей области знаний, а именно XML.
История вкратце такова: Есть 3 информационных базы с идентичными конфигурациями (Бухгалтерия для Украины, редакция 2.0. (2.0.16.1)). на платформе 8.3.11.3034
В 2-х из них ведется учет по "Организации_1" и "Организации_2" соответственно, а в третьей по "Организации_3". В неё нужно выгружать данные из этих двух, но подменять "Организацию_1" и "Организацию_2" на "Организацию_3". Зачем - не спрашивайте, такова задумка начальства в сговоре с бухгалтерами и мне она не понятна, да и понимать не хочу.
Показалось что задача выполнима: нашел обычную внешнюю обработку обмена данными через XML и допилил её в разделе "Загрузка" проверкой получаемых данных:
    Пока Сериализатор.ВозможностьЧтенияXML(ЧтениеXML) Цикл
        
        Попытка
            
            ЗаписанноеЗначение = Сериализатор.ПрочитатьXML(ЧтениеXML);

            #Область Обработка_входящих_данных
            
            // Нашли Справочник Организации и поместим в него вместо прочитанной нашу организацию по умолчанию
            Если ТипЗнч(ЗаписанноеЗначение) = Тип("СправочникОбъект.Организации")  Тогда
                ЗаписанноеЗначение = Справочники.Организации.НайтиПоКоду("00-000001").ПолучитьОбъект();
            КонецЕсли;
            // Справочник ПодразделенияОрганизаций иерархически подчинен справочнику Организации, поэтому у него замещаем значение реквизита Владелец
            Если ТипЗнч(ЗаписанноеЗначение) = Тип("СправочникОбъект.ПодразделенияОрганизаций") Тогда
                ЗаписанноеЗначение.Владелец = Справочники.Организации.НайтиПоКоду("00-000001")
            КонецЕсли;
            // Если Объект имеет реквизит Организация то заменим этот реквизит на организацию по умолчанию    
            Если ЗаписанноеЗначение.Метаданные().Реквизиты.Найти("Организация") <> Неопределено Тогда
                ЗаписанноеЗначение.Организация = Справочники.Организации.НайтиПоКоду("00-000001")
            КонецЕсли;
            // У справочника Сотрудники принадлежность сотрудника к организации в реквизите ГоловнаяОрганизация
            Если ЗаписанноеЗначение.Метаданные().Реквизиты.Найти("ГоловнаяОрганизация") <> Неопределено Тогда
                ЗаписанноеЗначение.ГоловнаяОрганизация = Справочники.Организации.НайтиПоКоду("00-000001")
            КонецЕсли;
            ...

Топорно, но работало...
А теперь суть проблемы: Выгрузил данные с обоих баз. Затянул. Все нормально было. Но с недавних пор возникла ошибка при выгрузке одной из баз. Одна по прежнему без проблем выгружается и загружается, а одна выгружается но при загрузке выдает ошибку. Используется как для выгрузки, так и для загрузки одна и та же обработка. Из обоих баз выгружаются один и тот же перечень документов, конфигурации повторю идентичны... А ошибка такая

По кнопке "Подробнее" вот такой текст:

Цитата
{ВнешняяОбработка.ВыгрузкаЗагрузкаДанныхXML.МодульОбъекта(212)}: Ошибка при вызове метода контекста (ПрочитатьXML)
ЗаписанноеЗначение = Сериализатор.ПрочитатьXML(ЧтениеXML);
по причине:
Ошибка преобразования данных XDTO:
НачалоСвойства: {http://v8.1c.ru/8.1/data/enterprise/current-config}DocumentObject.ПоступлениеНаРасчетныйСчет Форма: Элемент Тип: {http://v8.1c.ru/8.1/data/enterprise/current-config}DocumentObject.ПоступлениеНаРасчетныйСчет
по причине:
Ошибка преобразования данных XDTO:
НачалоСвойства: РасшифровкаПлатежа Форма: Элемент Тип: {http://v8.1c.ru/8.1/data/enterprise/current-config}DocumentTabularSectionRow.ПоступлениеНаРасчетныйСчет.РасшифровкаПлатежа


Ругается только на документ "ПоступлениеНаРасчетныйСчет" и, насколько я понимаю на его ТабЧасть "РасшифровкаПлатежа". Нашел в обоих XML-файлах эту часть и сравнил чуть ли не по-символьно - никаких различий в структуре, в данных понятно, они разные, но ругается ведь на какую то ошибку при приобразовании... Подскажите в чем может быть причина?
Просмотров: 92, последний комментарий от sanytch   
Пучить полный адрес файла внешней обработки при ее открытии [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 17.04.19, 11:03 — 9 комментариев
Всем привет!
&НаКлиенте
Процедура ПриОткрытии(Отказ)
ПолныйАдресФайла="???????";
Сообщить(ПолныйАдресФайла);
КонецПроцедуры

Шарил в поисковике ... потом надоело... и кроме того времени нет на это...
И если пойск занимает более 5-ти минут то лучше уже здесь... по способу решение задачи в фоновом режиме.... Не отвлекаясь от работы.
Так что, кто нибудь поможет сэкнмить время..
И скинуть готовый код....Вернее вписать строки в эту процедуру как это сделать.
Так что нужен только код по быстрому и безо всяких комментариев.
Буду признателен!
Просмотров: 260, последний комментарий от Gigi   
Работа с синонимом реквизита шапки документа [раздел Программирование в 1С Предприятие 7.7]
Автор leonid_gun — 17.04.19, 9:24 — 10 комментариев
Здравствуйте.
Есть необходимость получить синоним реквизита документа для его последующего отображения в заголовке окна редактирования значения этого реквизита

Процедура ВводПоля(РеквизитДокумента)   // РеквизитДокумента передается в процедуру
    Перем Инф;
    
    //Синоним = РеквизитДокумента.Синоним; // вот здесь не знаю как обратиться к нужному реквизиту, а точнее к его синониму
    
    Инф= РеквизитДокумента;
    Если ВвестиСтроку(Инф, "Введите значение " + Синоним, 999, 1,) = 1 Тогда
        РеквизитДокумента = Инф;
    Иначе
        Возврат;
    КонецЕсли;
КонецПроцедуры


Подскажите как правильно обращаться к Синониму или к Комментарий реквизита шапки, ведь для чего-то они присутствуют в базе. Пробовал через метаданные, но понял только как получить Синоним идентификатора документа, а мне нужен синоним реквизита шапки.
Просмотров: 172, последний комментарий от Batchir   
Аналитик-консультант 1с [раздел Офф-топик]
Автор Kateryna6789 — 16.04.19, 20:46 — 5 комментариев
Добрый день. Подскажите, пожайлуста, сколько получает аналитик-консультант 1с?
Просмотров: 133, последний комментарий от Kateryna6789   
Реализовать автоматическое выполнение задач для данного исполнителя [раздел Программирование в 1С Предприятие 8.3]
Автор Vladal — 16.04.19, 12:55 — 2 комментариев
Конфгурация на БСП 3.0.2, платформа 8.3.13.

Есть бизнес-процесс с "линейной" картой.



По "пожеланиям телезрителей" нужно автоматически закрывать задачу, если этот пользователь (адресат исполнения) в данном бизнес-процессе уже закрывал задачу положительно.
В моем случае "локальный директор", "финансовый" и "исполнительный" - одно и то же лицо и нужно упростить, автоматизировать закрытие последующих задач.

Что есть: при интерактивном закрытии задачи формируется следующая, в которую нужно зайти и нажать кнопку Согласовать, и так три раза (на карте три последние точки маршрута).
Что я дописал:

В отладчике я вижу, что точки бизнес-процесса продвигаются, задача меняется, выполняется, но в конце маршрута вываливается с ошибкой
Цитата
Операция не может быть выполнена из-за несоответствия версии или отсутствия записи базы данных (возможно, запись была изменена или удалена)!

Естественно, ссылка одна и та же, да и открыта интерактивно.

Делал это программно. Получил ссылку на текущую задачу, вызвал метод ВыполнитьЗадачу(), в отладчике прослеживаю все этапы и на последнем шаге получаю ошибку о невозможности закрыть задачу, так как она уже была выполнена.

Как это сделать правильно?

В обработчике точки маршрута ВыполнитьПриСозданииЗадач пишу свой код:
////////////////////////////////////////////////////////////////////////////////
// Обработчики событий элементов карты маршрута.

Процедура ВыполнитьПриСозданииЗадач(ТочкаМаршрутаБизнесПроцесса, ФормируемыеЗадачи, Отказ)
    
    НомерИтерации = НомерИтерации + 1;
    Записать();
    
    // Устанавливаем реквизиты адресации и доп. реквизиты для каждой задачи.
    Для каждого Задача Из ФормируемыеЗадачи Цикл
        
        Если ТочкаМаршрутаБизнесПроцесса.Имя = "СогласованиеФинансовыйКонтролер" Тогда
            Задача.РольИсполнителя = Справочники.РолиИсполнителей.ФинансовыйКонтролер;
...

        // Определить. был ли этот исполнитель в предыдущих точках маршрута
        Запрос = Новый Запрос;
        Запрос.Текст =
        "ВЫБРАТЬ РАЗРЕШЕННЫЕ
        |    ЗадачаИсполнителя.Ссылка КАК Ссылка,
        |    ЗадачаИсполнителя.БизнесПроцесс КАК БизнесПроцесс,
        |    ЗадачаИсполнителя.Выполнена КАК Выполнена,
        |    ЗадачаИсполнителя.ГруппаИсполнителейЗадач КАК ГруппаИсполнителейЗадач,
        
...

Запрос.УстановитьПараметр("ОсновнойОбъектАдресации", Задача.ОсновнойОбъектАдресации);
        
        Результат = Запрос.Выполнить();
        Если Не Результат.Пустой() Тогда
            Выборка = Результат.Выбрать();
            Выборка.Следующий();
            Задача.ГруппаИсполнителейЗадач = Выборка.ГруппаИсполнителейЗадач;
            Задача.Исполнитель = Выборка.Исполнитель;
            Задача.ДополнительныйОбъектАдресации = Выборка.ДополнительныйОбъектАдресации;
            
            //-- сделал и так, но все равно последняя задача рубится с ошибкой, что она выполнена и вся транзакция откатывается назад
            Если Не Задача.Выполнена Тогда
                Задача.ВыполнитьЗадачу();
            КонецЕсли;
            
            //-- вызывал и типовой модуль, но он тоже валится...
            //БизнесПроцессыИЗадачиВызовСервера.ВыполнитьЗадачу(Задача.Ссылка, Истина);
        КонецЕсли;
Просмотров: 121, последний комментарий от Vladal   
Индесация базы 1Сv8 под MS SQL - server 2014 [раздел Администрирование и настройка серверов баз данных]
Автор george_smith — 16.04.19, 11:13 — 4 комментариев
Здравствуйте!
Хочу увеличить производительность системы "Управление торговым предприятием для Украины", редакция 1.2. (1.2.48.1)
База 1Сv8.3 под MS SQL (mdf - файл весить около 15 gb., log урезанный до 1 gb.).
До перестройки индексов запрос sys.dm_db_index_physical_stats показал для многих объектов id avg_fragmentation_in_percent больше 30%.
После Rebuild Indexes ситуация не изменилась. Запрос sys.dm_db_index_physical_stats показал тоже самое.
Подскажите как победить высокий процент не фрагментированых индексов? Может через Reorganize Indexes? Чем эти два способа отличаются.


Просмотров: 143, последний комментарий от Vladal   
Находится ли конфигурация на поддержке? [раздел Программирование в 1С Предприятие 8.3]
Автор Inkognito — 16.04.19, 11:47 — 2 комментариев
Необходимо программно узнать, находится ли конфигурация на поддержке (или снята с поддержки, и можно вносить изменения?) - конфигурациия и платформа может быть самая разнообразная.
Использоваться планируется так: если заказчик/потенциальный заказчик хочет всяко-разного, но не может ответить на простые вопросы. Соберу всю нужную информацию программно.
//---------
Пробовал: СистемнаяИнформация(), Метаданные() - ничего похожего.

Наиболее лучше узнать "Правило поддержки" конфигурации. Но как это сделать программно? upset.gif
Картинка
Просмотров: 104, последний комментарий от Inkognito   
Стандартом присутствия продукции в торговых точках [раздел Программирование в 1С Предприятие 8.3]
Автор i369 — 16.04.19, 10:06 — 4 комментариев
Конфигурация нетиповая самописная. Платформа 8.3.12.1440
Добрый день.
Подскажите пожалуйста кто-нибудь сталкивался при анализе продаж со «Стандартом присутствия продукции в торговых точках» он же Минимальный обязательный ассортимент (Minimum Must List, MML)?
В зависимости от Категории торговой точки устанавливается минимальный набор Продукции, которая должна быть в торговых точках, устанавливается план в зависимости от КатегорииТТ и в отчете высчитывается Факт и %Выполнения Плана.
Может кто-то сталкивался или делал подобное?

Пример...

Просмотров: 95, последний комментарий от podcast   
Не закрывается 231 счет [раздел 1С Управление производственным предприятием 8]
Автор greatdndz — 16.04.19, 9:29 — 4 комментариев
Добрый день!

Конфигурация УПП 1.3.61, ведется РАУЗ. После расчета себестоимости не закрывается 231 счет по дебету по определенной номенклатурной группе. Подскажите пожалуйста какими отчетами либо другими способами найти ошибку?

Просмотров: 102, последний комментарий от Егор Динин   
Можно ли зайти в базу на сервере из другой конфигурации. [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 14.04.19, 15:41 — 12 комментариев
Всем привет!
Гууу… даже в выходные дни вынужден работать… и даже в такое время нет покоя.. Это потому что охота отмучиться и забыть… И просто поскорее избавиться
Так вот, проблема такая. И попытаюсь коротко изложить. Если получиться ....что чаще не получается … согласен ))))) И если и на этот раз опять не получилось коротко то опять и тут БОЛЬШИЕ ИЗВИНЕНИЯ ЗА ТАКОЙ ОПЯТЬ ГИГАНТСКИЙ РАЗМЕР. Но это что бы удобнее было знать в деталях суть вопроса.
Представите, что есть две базы. Одна серверная … т.е. рабочая … а другая файловая на ПК.
Обе базы содержат одни и те же данные. Но при этом одна из них первая урезанная, а вторая полная.
Имею ввиду то, что конфигурация у серверной рабочей базы сильно урезана. Почти все возможности есть только по юр лицам. А во всем остальном это просто сухие данные справочников и документов без каких либо созданных форм, отчетов, очень удобных для загрузки данных и прочих целей обработок и т.д. Т.е. только сухие данные. Не отчетов не удобных для работы форм … ничего вообще. Короче в этом полная бездарщина. Хотя в том, как база в корне выстроена тут полная противоположность бездарщине. Потому что копия той же базы с теми же данными но уже в файловом варианте …загруженная уже из другой конфигурации … навороченной ….. с гибкими алгоритмами расчета, те же данные считает по нулям.
Но это фаилово-серверная ситуация. А вопрос в том, как я сам буду с этим работать с той рабочей базой, конфигурация которой урезана. Ибо работаю ведь не только программистом, но начальником технической статистики.
И тут вопрос решил следующим образом ...
Понаписал кучу строк кода для получения всех данных из базы серверной в базу файловую. И вопрос был решен. Т.е. в итоги я сам пользуюсь не рабочим вариантом базы правильно выстроенной, но очень не удобной и практически не возможной работать с ней, которая на сервере, а файловым, навороченным и удобным )) естественно ))
И как получать данные из урезанной базы на сервере в файловую с этим нормально. Файловая база с каждым месяцем пополняется новыми данными от рабочей серверной.
Но я просто хочу сделать еще удобнее.
А именно войти в базу, которая на сервере через другую конфигурацию. Т.е. не через ту с которой синтезируется база на сервере с урезанной конфигурацией, а войти через не урезанный и полный вариант конфигурации.
Вот как хотел.
И для этой цели я понасодавал кучу внешних обработок … т.е. множество фишек из полного варианта конфигурации сохранил виде внешних обработок. И открывал эти внешние обработки из тонкого клиента серверной базы. И они все абсолютно нормально работают и не где не ошибаются. Ибо ведь данные базы одни и те же. Но все дело в том, что этих разных внешних обработок стало куча. И открывать каждую отдельно для своей части работы стало очень не удобно. Поэтому нужно просто всю ту навороченную конфигурацию в целом создать как внешнюю обработку и зайти в базу на сервере через нее. И так что бы данные базы так же отобразить из другой конфигурации.
И не важно как зайти.. через файл/открыть обработку или иным способом.
Поэтому вопрос в том МОЖНО ЛИ ТАК СДЕЛАТЬ?
Только если опять и тут нельзя то не рубите сразу… ))))) …и не будьте жестоки )))
Потому, что буду сильно расстроен если так. )))))
И тогда напрасно столько в деталях описал… относительно того что нужно.
Тогда как может задуманное не реализуемо ибо такой возможности опять и тут просто нет.
И поэтому буду признателен …и это без иронии. Если кто подскажет варианты решения вопроса.
Просмотров: 323, последний комментарий от Gigi   
Связи Физ лиц с контрагентами [раздел 1С Управление производственным предприятием 8]
Автор jojojoba2 — 12.04.19, 15:01 — 2 комментариев
Добрый день!

Может кто нибудь знает какими справочниками,документами или вообще объектами , а также реквизитами связываются контрагенты и физ лица?
Просмотров: 138, последний комментарий от Vofka   
Проверка точки маршрута перестала работать в другой локали [раздел Программирование в 1С Предприятие 8.3]
Автор Vladal — 12.04.19, 9:53 — 1 комментариев
Привет!

Конфигурация Документооборот (DMS 2.1.8.53). Платформа 8.3.10

В форме задачи есть проверка на точку маршрута:

&НаКлиенте
Процедура ЗадачаИсполнено(Команда)
    
    Если ТочкаМаршрутаТекущейЗадачи <>
        ПредопределенноеЗначение("БизнесПроцесс.Исполнение.ТочкаМаршрута.Исполнить") Тогда
        
        Возврат;
    КонецЕсли;
    
...

КонецПроцедуры


Все работало ровно до того момента, когда добавили второй язык в конфигурацию и перевели тексты интерфейсов.
Теперь для англоязычного пользователя ТочкамаршрутаТекущейЗадачи возвращает "To execute", и рушится эта проверка.
Хотел проверить на сервере по метаданным - то же самое.

Или на карте БП для точек маршрута продублировать названия из старой локали в новую локаль и забыть?

Можно дописать проверку на сервере для получения не выполненных задач по этому БП и узнать точку маршрута, но это надо снимать с поддержки.

Может какие другие есть идеи, давайте обсудим.

По поиску ПредопределенноеЗначение("БизнесПроцесс. находится 38 мест. Увы, перевод был сделан и наверно для каждого из них такая же проблема.

Где еще может "выстрелить" метод ПредопределенноеЗначение, чтобы обратить сейчас на это внимание? Кто сталкивался?
Просмотров: 104, последний комментарий от Vladal   
Объединение клиентов по соглашениям [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор Володька — 12.04.19, 7:06 — 0 комментариев
Уважаемые форумчане! Ищу совета, думаю с таким многие сталкивались:

В базе существуют порядка 3000 клиентов в таком формате:
Клиент 1
Копия Клиент 1
Клиент 2
Копия Клиент 2
....

У каждого из них есть соглашение (индивидуальное)

Нужно из объединить в Клиент 1 (Соглашение 1 и Соглашение 2) ...

По всем ним есть движения (Заказы, Реализации, ПКО)

Пробовал Соглашение Копии Клиента 1 перенести Клиенту 1 пометить на удаление Копию Клиент 1 и через замену изменить Копию Клиент 1 на Клиент 1 во всех местах использования. Ругается на КлючиАналитикиПартнера.

Скажите, как такое можно провернуть?

Просмотров: 85, оставить комментарий   
RLS глюки по физ лицам в при проведении документа "Отражение взаиморасчетов с контрагентами в 1-ДФ" [раздел Программирование в 1С Предприятие 8.3]
Автор jojojoba2 — 11.04.19, 15:40 — 6 комментариев
Всем Привет!

Возникла проблема с использованием RLS. Типичная УПП для Украины 1С:Предприятие 8.3 (8.3.13.1513). Организовали доступ на уровне записей по ОРГАНИЗАЦИИ, ПОДРАЗДЕЛЕНИЯ, СКЛАДЫ, ФИЗ ЛИЦА, НОМЕНКЛАТУРА, СПЕЦИФИКАЦИИ.

При попытке проведения документа "Отражение взаиморасчетов с контрагентами в 1-ДФ" выдает ошибку : Ошибка при выполнении обработчика - 'ОбработкаПроведения'
по причине:
{Документ.ОтражениеВзаиморасчетовСКонтрагентамиВ1ДФ.МодульОбъекта(449)}: Ошибка при вызове метода контекста (Записать)

по причине:
У пользователя недостаточно прав на исполнение операции над базой данных.


У пользователя все необходимые роли назначены.
Если поставить полные права или убрать с регистра накопления "ВзаиморасчетыПоНДФЛ" проверку RLS то проводится без проблем.
Также если убрать в настройках RLS разграничение по физ лицам,тоже все прекрасно работает и проводится.

Заметил что с документа "Отражение взаиморасчетов с контрагентами в 1-ДФ" в регистр записываются Контрагенты. Может в этом проблема.

Сталкивался кто-нибудь с такой проблемой?

Просмотров: 180, последний комментарий от jojojoba2   
Не печатает один отредактированный(печатная форма) документ [раздел Программирование в 1С Предприятие 8.3]
Автор yoj — 10.04.19, 14:47 — 0 комментариев
Не печатает один отредактированный(печатная форма) документ.
Выводим на Печать документ ТТН (товаро-транспортная накладная), выбираем Таблица-Вид-Редактировать. Вписываем строку и нажимаем печатать. Печатает исходный вид документа.
В счетах, накладных печатает именно отредактированный документ.
Где можно убрать этот запрет?

1С Предприятие 8,3 (8.3.11.2867)
Конфигурация: Управление производственным предприятием, редакция 1.3 БИТ.ФИНАНС 3.0
Просмотров: 77, оставить комментарий   
Ошибка при получении УникальныйИдентификатор [раздел Программирование в 1С Предприятие 8.3]
Автор Михрутка — 09.04.19, 18:16 — 2 комментариев
1с 8.3
УТП 1.2.21
Обработка "обмненССайтом" стандартная без доработок. Вот фрагмент функции:

Функция ВыполнитьПоискНоменклатурыХарактеристикиПоСсылкам(СтрокаТовара, Номенклатура, ХарактеристикаНоменклатуры)
    
    Если НЕ ЗначениеЗаполнено(СтрокаТовара.ТоварУслугаИд) Тогда
        Возврат Ложь;
    КонецЕсли;
            
    //Попытка
        
        ИдНоменклатуры = ПолучитьИдНоменклатуры(СтрокаТовара.ТоварУслугаИд);
        Номенклатура = Справочники.Номенклатура.ПолучитьСсылку(Новый УникальныйИдентификатор(ИдНоменклатуры));
        Если Номенклатура = Справочники.Номенклатура.ПустаяСсылка() Тогда            
            Возврат Ложь;
        КонецЕсли;


Возникает ошибка:

{Обработка.ОбменССайтом.МодульОбъекта(4103)}: Ошибка при вызове конструктора (УникальныйИдентификатор)
Номенклатура = Справочники.Номенклатура.ПолучитьСсылку(Новый УникальныйИдентификатор(ИдНоменклатуры));
по причине:
Недопустимое значение параметра (параметр номер '1')

Все вроде верно и ничего не менялось. В чем может быть проблема?
Просмотров: 130, последний комментарий от Михрутка   
Получить IP машины от Веб Сервиса [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 09.04.19, 14:15 — 3 комментариев
Привет всем!
Вопрос такой...
Дело в том, что то о чем тема это можно сделать разными путями.
Вот несколько способов которую вызывает тестовая функция:
 Функция Получить_IP() Экспорт
// ========= Способ 1
            //Возврат winmgmts_Получить_IP();
// ========== Способ 2
            Возврат IP_Получить_MACAddress();
// ========== Способ 3 == Определение ip через веб сервис
            //Возврат IP_ПолучитьОтВебСервиса();
КонецФункции

Способы 1/2: Хотя они почти одни и те же.
&НаКлиенте
Функция winmgmts_Получить_IP() Экспорт
//Определение ip адреса через "winmgmts"
COMОбъект = ПолучитьCOMОбъект("winmgmts:\\.\root\CIMV2");    
Результат = COMОбъект.ExecQuery("SELECT * FROM
                                |Win32_NetworkAdapterConfiguration
                                |WHERE IPEnabled = TRUE");                
Для каждого Строка Из Результат Цикл
Для каждого ПодСтрока Из Строка.IPAddress  Цикл
Возврат ПодСтрока;
КонецЦикла;    
КонецЦикла;
КонецФункции

&НаКлиенте
Функция IP_Получить_MACAddress() Экспорт
ServicesSet = GetComObject("winmgmts:{impersonationLevel=impersonate}!\\" + СокрЛП(".") + "\root\cimv2");
Items = ServicesSet.ExecQuery("SELECT MACAddress FROM Win32_NetworkAdapter WHERE NetConnectionStatus=2");
Для каждого Item Из Items Цикл
    Если СокрЛП(Item["MACAddress"]) <> "" Тогда
        Mac = СокрЛП(Item["MACAddress"]);
        Прервать;
    КонецЕсли;
КонецЦикла;    
Items = ServicesSet.ExecQuery("SELECT * FROM Win32_NetworkAdapterConfiguration WHERE MACAddress='" + Mac + "'");
Для Каждого objItem Из Items Цикл
    Если ТипЗнч(objItem.IPAddress) = Тип("COMSafeArray") Тогда
        Для Каждого Элем Из objItem.IPAddress Цикл
            IP = Элем;
            Прервать;
        КонецЦикла;
    КонецЕсли;
КонецЦикла;
Возврат IP;
КонецФункции

Ну таким маккаром можно, но одна проблема. Дело в том, что все это работает если 1С предприятие в режиме тонкий клиент.
Но если Веб клиент то выдает ошибку... говорит что терпеть не может COMОбъект.
А раз так то тогда вот третий способ:
&НаСервере
Функция IP_ПолучитьОтВебСервиса() Экспорт
Описание= Новый  WSОпределения("http://develplatform.ru/SynIP.asmx?wsdl");
Прокси = Новый WSПрокси(Описание, "http://www.develplatform.com/", "SynIP", "SynIPSoap");
Тип = Прокси.ФабрикаXDTO.Пакеты.Получить("http://www.develplatform.com/").Получить("GetClientIP");
ФабрикаВебСервис = Прокси.ФабрикаXDTO.Создать(Тип);
Возврат     Прокси.GetClientIP(ФабрикаВебСервис).GetClientIPResult;
КонецФункции

Который че то не срабатывает. и это на первой же линии. Пишет что не может найти сервис.
Я просто не сильно дружу с разными веб сервисными штучками ... не приходилось сталкиваться.
Поэтому кто нибудь не может побыстрому дать инфу почему нет соединения?
Может адрес сервиса не тот ... или в коде ошибка..
Буду признателен!
Просмотров: 209, последний комментарий от Gigi   
Вывести внешнюю обработку печатной формы без проведения [раздел Программирование в 1С Предприятие 8.3]
Автор XacTLa — 09.04.19, 13:04 — 5 комментариев
Есть внешняя обработка печатной формы, я понимаю что она обращается по ссылке к оригинальному документу, я хочу что бы документ без проведения печатался, не могу понять какой параметр вставить может кто что знает?


1С:ERP Управление предприятием 2.0 (2.0.9.66)
1С:Предприятие 8.3 (8.3.9.2309)
Просмотров: 184, последний комментарий от nik389   
копирование документов в 1С Предприятие 8.3. [раздел 1С Управление производственным предприятием 8]
Автор AN70AN — 09.04.19, 12:54 — 15 комментариев
Здравствуйте.
Я пользователь 1С 8.3.
Админ нашей фирмы запретил копирование документов в 1С Предприятие 8.3.
Озвучена причина - в конфигурации 1С с несколькими организациямипри копировании документов автоматически подтягивались

ссылки на регистры документа родителя и это приводило к множеству ошибок в базе 1С с последующим их длительным выявлением и

исправлением.

Прошу Вашей помощи, так как без копирования тратится куча времени на набор документов с нуля.
Прав ли админ? Есть ли возможность доработки 1С, чтобы разрешить пользователям копирование доков?

Заранее благодарен за ответ.
Просмотров: 272, последний комментарий от Vofka   
RSS Текстовая версия Сейчас: 20.04.19, 17:18
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне