Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Регистрация )




Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Всех с наступающим воскресением Христовым и майскими праздниками!, Офф-топик
Автор Vofka — 29.04.16, 15:18 — 0 комментариев
Всем хорошо отдохнуть! mamba.gif

Просмотров: 20, оставить комментарий | Просмотр полной темы | Просмотр раздела "Офф-топик"   
Эквайринг: ИНПАС Эквайринговые терминалы UNIPOS (применение), Управление торговлей для Украины редакция 3 (11.х для России)
Автор Constantus — 29.04.16, 13:12 — 1 комментариев
Приветствую, Форумчане!

Имеется эквайринговый терминал VeriFone VX675 ECR. Если верить некоторым сайтам, то он является INPAS VeriFone VX675, да к тому же UNIPOS.

Сейчас работаю с УТ 11.1

Там, в подключаемом оборудовании среди драйверов Эквайринга обнаружился встроенный драйвер: ИНПАС: Эквайринговые терминалы UNIPOS

Могу ли я использовать данный драйвер для моего VeriFone VX675 ECR?
Или как можно проверить какие устройства можно подключить с помощью данного встроенного драйвера?
Просмотров: 41, последний комментарий от logist | Просмотр полной темы | Просмотр раздела "Управление торговлей для Украины редакция 3 (11.х для России)"   
В заказ клиента добавляю контрагента, но не могу видеть список всех контрагентов, Управление торговлей для Украины редакция 3 (11.х для России)
Автор Юля — 29.04.16, 9:56 — 2 комментариев
Привет! Только начинаю знакомство с УТ 3.1)) столкнулась с такой проблемой: в заказ клиента добавляю контрагента ,но не могу видеть список всех контрагентов, показывает только менеджера((( Почему я не могу искать по всем котрагентам????


 ! 

[необходимо зарегистрироваться для просмотра ссылки]: 4
 
Просмотров: 60, последний комментарий от Юля | Просмотр полной темы | Просмотр раздела "Управление торговлей для Украины редакция 3 (11.х для России)"   
Не проводится документ "Закрытие месяца", 1С Бухгалтерия 8.*
Автор yulia_i30 — 28.04.16, 15:29 — 7 комментариев
Помогите, пожалуйста!

После проведения документа "Прийняття до обліку НМА" в марте 2016, не проводится закрытие месяца за апрель.

Помилка при виконанні обробника - 'ОбработкаПроведения'
через:
{ОбщийМодуль.УправлениеНеоборотнымиАктивами.Модуль(3543)}: Поле об`єкту не виявлено (ЕстьНалогНаПрибыльДо2015)



Убираем галочки "Нарахування амортизації НМА" - всё ок. Что не так? В чём может быть проблема?
Просмотров: 123, последний комментарий от Gazulo | Просмотр полной темы | Просмотр раздела "1С Бухгалтерия 8.*"   
Помогите разобраться в структуре данных Номенклатуры., 1С:Предприятие 8.3
Автор oleg_dyakov — 28.04.16, 10:37 — 7 комментариев
Дорогие форумчане, будьте добры, подскажите пожалуйста: позволяет ли 1С сделать следующую нумерацию в пределах групп и подгрупп.
Например,
Дано:
Общая Группа --> РАЗЪЁМЫ
!
.............................. подгруппа --> Разъёмы питания
.............................. !
............................. подгруппа --> Разъёмы сигнальные
............................. ! !
............................. ... USB-разъёмы
............................ ... !
............................. ... RS-232 разъёмы
Необходимо:
Чтобы абсолютно все номенклатурные единицы носили бы НОМЕР ОСНОВНОЙ ГРУППЫ (пусть это будет в данном случае 017-) что, как я понимаю, записывается в артикуле.
Проблема в том, что на сколько я понял, 1С вполне логично даёт создаваемым подгруппам внутри основных групп свои уникальные номера артикулов.
Как сделать всё же так, как я описал в вопросе - чтобы номер основной группы и всех подгрупп в неё входящих начинался с одного и того же числа?
Нумерация номенклатуры в пределах одной ГРУППЫ (основной) может быть сплошной.
Помогите пожалуйста.

Возможно так будет понятнее о чём идёт речь.
Просмотров: 103, последний комментарий от oleg_dyakov | Просмотр полной темы | Просмотр раздела "1С:Предприятие 8.3"   
Помогите вернуть номенклатуру в отдельные папки, 1С Торговля и Склад 7.7 для Украины
Автор Елеанка — 27.04.16, 15:37 — 6 комментариев
1с 7.7 7.70.027 Бухгалтер каким то образом переместила номенклатуру из 4 папок в одну общую кучу. Подскажите пожалуйста возможно ли как то вернуть всё обратно в эти папки, на вопрос как она это сделала, ответ один это не я, ни чего не знаю.
Просмотров: 137, последний комментарий от Acid | Просмотр полной темы | Просмотр раздела "1С Торговля и Склад 7.7 для Украины"   
Как ускорить управляемую форму?, 1С 8.2 Управляемый интерфейс
Автор pablo — 27.04.16, 14:43 — 0 комментариев
Есть у меня документ, в котором есть одна основная табличная часть и 12 вспомогательных. В форме документа есть страницы для основной ТЧ и несколько страниц для дополнительных, т.е. на одной странице могут располагаться несколько ТЧ. И есть у меня некоторая проблема быстродействия при переключении закладок, а именно: если в основной ТЧ порядка 200 строк, то переключение на страницу с другими ТЧ код процедуры ПриСменеСтраниц выполняется 4-5 секунд.
При этом экспериментально я выяснил, что основная часть потраченного времени тратится на следующий код:
    Отбор1=новый Структура;
    Если НомерИзделия=0 тогда        
        Если Объект.Изделия.Количество()=0 тогда
            Возврат;
        КонецЕсли;    
        Отбор1.Вставить("НомерИзделия",Объект.Изделия[0].НомерИзделия);
    иначе    
        Отбор1.Вставить("НомерИзделия",Объект.Изделия[НомерИзделия-1].НомерИзделия);
    КонецЕсли;    
    ОтборПараметров=новый ФиксированнаяСтруктура(Отбор1);
    Если ТекущаяСтраница=Элементы.Группа4.ПодчиненныеЭлементы.Обработка тогда
        Элементы.Обработки.ОтборСтрок=ОтборПараметров;
    ИначеЕсли ТекущаяСтраница=Элементы.Группа4.ПодчиненныеЭлементы.Структура тогда          
        Элементы.Материалы.ОтборСтрок=ОтборПараметров;
    КонецЕсли;

Т.е. именно ОтборСтрок по Табличной части тормозит вывод данных.

Как можно ускорить отбор строк?
P.S. Я пробовал создать отдельный реквизит формы типа ТаблицаЗначений и заполнять ее вручную, но результат в лучшем случае не улучшался.



P.P.S. Управляемая форма используется в толстом клиенте.
Просмотров: 59, оставить комментарий | Просмотр полной темы | Просмотр раздела "1С 8.2 Управляемый интерфейс"   
Странные ошибки при проведении на сервере., 1С Предприятие 7.7
Автор gilaa70 — 27.04.16, 12:43 — 4 комментариев
Подскажите, где копать?
Стандартная конфигурация "1С 7.7 Производство+Услуги+Бухгалтерия".
При проведении документа производствf ("Фактические калькуляции") на сервере возникает ошибка:
== В подразделении ********** не выпускалась продукция с уровнем передела 0! ==
Движения по регистрам есть, все в порядке.

Если базу выгрузить в ДБФ вариант на локальный компютер, документ без проблем проводится.
Менял collation, делал новую базу и загружал данные из ДБФ архива, ничего не помогает.
SQL Сервер 2005.

Может кто нибудь подсказать, хоть в каком направлении копать дальше?
Кстати, на SQL сервере, развернутом на локальной машине ситуация аналогичная. Документ не проводится.
Просмотров: 140, последний комментарий от gilaa70 | Просмотр полной темы | Просмотр раздела "1С Предприятие 7.7"   
Подключение Datecs FP-3530T RT к УТ, Работа с торговым оборудованием
Автор Pashaboston — 27.04.16, 11:26 — 0 комментариев
Подключение касового апарата к 1с производится через обработку SystemGroup_ATLAS_v2. При оплате карточкой чек не пробивается на ФР пишет "ЧЕК АНУЛЬОВАНО".

Вот функция которая закрываэт чек. Параметры проверил, код вида оплаты в тоже.
Функция ЗакрытьЧек(Объект, СуммаНал, СуммаБезнал) Экспорт

    Результат  = мНетОшибки;

    Если Объект.Драйвер.PrinterState = 9 Тогда
        Объект.Драйвер.EndNonFiscal();
    Если Объект.Драйвер.ResultCode <> 0 Тогда         
                Объект.ОписаниеОшибки = НСтр("ru='Кассовый аппарат ';uk='Касовий апарат '") + НСтр("ru=' ошибка оплаты ';uk=' помилка оплати '") + ОписаниеОшибки() + ".";
                Результат = мОшибкаНеизвестно;
                Возврат Результат;             КонецЕсли;     КонецЕсли;

        
    Если    СуммаБезнал  <>  0  Тогда        
    Объект.Драйвер.PrintRecTotal(СуммаБезнал, СуммаБезнал, "1");
    
    Если Объект.Драйвер.ResultCode <> 0 Тогда         
                Объект.ОписаниеОшибки = НСтр("ru='Кассовый аппарат ';uk='Касовий апарат '") + НСтр("ru=' ошибка оплаты ';uk=' помилка оплати '") + ОписаниеОшибки() + ".";
                Результат = мОшибкаНеизвестно;
                Возврат Результат;             КонецЕсли;     КонецЕсли;
        
        
        
    Если    СуммаНал  <>  0  Или  (СуммаНал  =  0 И СуммаБезнал  =  0)Тогда
    Объект.Драйвер.PrintRecTotal(СуммаНал, СуммаНал, "0");
    
    Если Объект.Драйвер.ResultCode <> 0 Тогда         
                Объект.ОписаниеОшибки = НСтр("ru='Кассовый аппарат ';uk='Касовий апарат '") + НСтр("ru=' ошибка оплаты ';uk=' помилка оплати '") + ОписаниеОшибки() + ".";
                Результат = мОшибкаНеизвестно;
                Возврат Результат;             КонецЕсли;     КонецЕсли;
            
        

            
    Объект.Драйвер.EndFiscalReceipt(True);
    
    Если Объект.Драйвер.ResultCode <> 0 Тогда         
                Объект.ОписаниеОшибки = НСтр("ru='Кассовый аппарат ';uk='Касовий апарат '") + НСтр("ru=' ошибка оплаты ';uk=' помилка оплати '") + ОписаниеОшибки() + ".";
                Результат = мОшибкаНеизвестно;
                Возврат Результат;             КонецЕсли;
        
        
    // Закрытие чека

    Возврат Результат;

КонецФункции // ЗакрытьЧек()
Просмотров: 102, оставить комментарий | Просмотр полной темы | Просмотр раздела "Работа с торговым оборудованием"   
Немного поменялось оформление Портала (главной страницы), Новости
Автор Vofka — 27.04.16, 8:46 — 0 комментариев
[необходимо зарегистрироваться для просмотра ссылки] - не забываем Ctrl+F5 сделать smile.gif
Просмотров: 100, оставить комментарий | Просмотр полной темы | Просмотр раздела "Новости"   
Расчет Количества клиентов в маршрутном листе, 1С Предприятие 7.7
Автор inna.innainna84 — 26.04.16, 22:36 — 6 комментариев
В маршрутном листе есть список клиентов, есть такие что повторяються, но есть у клиента реквизит -Неиспользуется, то клиента нужно отнять, меня смущает ;Тз.СдвинутьСтроку(-1); "
вася-стоит реквизит неиспользовать
вася-стоит реквизит неиспользовать
петя
КолвоКлиентов-2, а нужно 1
или
вася-стоит реквизит неиспользовать
вася-стоит реквизит неиспользовать
петя
юра-стоит реквизит неиспользовать
юра-стоит реквизит неиспользовать
КолвоКлиентов-2, а нужно 1

Процедура РасчитатьКолвоКлиентов()       
    Тз = СоздатьОбъект("ТаблицаЗначений");
    ВыгрузитьТабличнуюЧасть(ТЗ,"Клиент");  
    Тз.ВыбратьСтроки();
    Пока Тз.ПолучитьСтроку()=1 Цикл
        Если Тз.Клиент.Неиспользуется = 1 Тогда
            Тз.УдалитьСтроку(Тз.НомерСтроки);
            Если Тз.НомерСтроки > Тз.Количествострок()  Тогда
                Тз.СдвинутьСтроку(-1);    
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
    ТЗ.Свернуть("Клиент","");
    КолвоКлиент = Тз.КоличествоСтрок();
    
КонецПроцедуры    // РасчитатьКолвоКлиентов
Просмотров: 163, последний комментарий от Sharzem | Просмотр полной темы | Просмотр раздела "1С Предприятие 7.7"   
Как получить объект по представлению?, 1С Предприятие 7.7
Автор twilight_dream — 26.04.16, 18:01 — 5 комментариев
Имеется строка вида "Начисление бонусов FKG-020516 (29.02.16)", как найти этот документ, зная эту строку?
Просмотров: 135, последний комментарий от Acid | Просмотр полной темы | Просмотр раздела "1С Предприятие 7.7"   
Управленческий учет (С.8.24) S, 1С:Предприятие 8.3
Автор lazur_shevtsov — 26.04.16, 12:27 — 3 комментариев
Пока ДокМаршрут.Следующий() Цикл
        Для Каждого Стр Из ДокМаршрут.Маршрут Цикл
            Если ДокВидПлатежа = Стр.ВидПлатежа или НЕ Стр.Документ.Ф2 или НЕ Стр.Документ.Проведен Тогда
                Продолжить;
            Иначе    
                Индикатор = Индикатор+1;
                ОбластьВодитель = Макет.ПолучитьОбласть("Водитель");
                ОбластьВодитель.Параметры.Сч = Индикатор;
                ОбластьВодитель.Параметры.ВодительЭкспедитор = Стр.Экспедитор;
                ОбластьВодитель.Параметры.РНакладная = Стр.Документ;
                ОбластьВодитель.Параметры.Контрагент = Стр.Контрагент;
                ОбластьВодитель.Параметры.АдресТТ = Стр.Адрес;
                ОбластьВодитель.Параметры.Сумма = Стр.Сумма;
                Пока Выборка.Следующий() Цикл
                    Если Выборка.ТТ = Стр.ТорговаяТочка Тогда
                        ОбластьВодитель.Параметры.Возврат = Выборка.Возврат;
                    КонецЕсли;
                КонецЦикла;    
                ТабДок.Вывести(ОбластьВодитель);
            КонецЕсли;    
        КонецЦикла;
    КонецЦикла;

//Помогите пожалуйста.
//Не могу сделать так, что если перебирать документы, то при выборе Выборки по возвратам подвязать возврат к торговой точке
//т.к. выбирает первую торговую точку сравнивает с ней все возвраты и на второй торговой точке возвраты уже не сверяет.
//а надо чтобы с каждой торговой точкой сравнить все возвраты.
Просмотров: 76, последний комментарий от lazur_shevtsov | Просмотр полной темы | Просмотр раздела "1С:Предприятие 8.3"   
Как создать таблицу на Гугле и заполнить её используя API google, 1С:Предприятие 8.3
Автор -Сергій- — 26.04.16, 11:30 — 8 комментариев
Проблема следующая. Нужно информацию с табличной части выгрузить в Гугл. Пока мне удалось получить список файлов на Гугл диске. Кто подскажет как создать таблицу на Гугле и заполнить её. Буду благодарен.


 ! 

[необходимо зарегистрироваться для просмотра ссылки]: 3,4
 
Просмотров: 201, последний комментарий от -Сергій- | Просмотр полной темы | Просмотр раздела "1С:Предприятие 8.3"   
Как можно получить бухитог по двум фирмам вкуче?, 1С Предприятие 7.7
Автор twilight_dream — 25.04.16, 20:01 — 3 комментариев
Здравствуйте.
Сейчас в бухитоге используется такая конструкция, когда нужно отобрать по одной фирме
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьРазделительУчета(Фирма);
Ну и в результате в кучу вываливает по этой фирме итоги.
А вот нужно то же самое, тоже в одну кучу, но по двум фирмам.
Прошу подсказать знающих, как это сделать можно.

Просмотров: 126, последний комментарий от Sharzem | Просмотр полной темы | Просмотр раздела "1С Предприятие 7.7"   
Аренда сервера для УНФ для небольшого интернет-магазина, Тематическое общение
Автор Amicus — 25.04.16, 19:46 — 17 комментариев
Здравствуйте!
Посоветуйте, пожалуйста, сценарии и компании, предоставляющие аренду 1С.
Сервер не обязательно должен находиться в Украине, можно в Европе.
Также важен веб-доступ и возможность установки своих модификаций для интеграции с интернет-магазином.
Просмотров: 166, последний комментарий от Amicus | Просмотр полной темы | Просмотр раздела "Тематическое общение"   
СредстаГеопозиционирования в мобильной платформе, 1С:Предприятие 8.3
Автор Elena_1288 — 25.04.16, 16:13 — 2 комментариев
Доброго времени суток!
Занимаюсь разработкой мобильного приложения. Возникла потребность работать с гео. данными. Использую средства геопозиционирования, которые доступны на мобильном клиенте. С помощью них могу получать местонахождение планшетов. НО! Проблема в том, что пользователь может перед стартом системы не включить геоданные или же, что еще хуже, выключить их во время работы. Дело в том, что система находит или не находит провайдеров, если пользователь выключил или включил геопозиционирование, но при этом не перезашел в систему. Т.е.:
Провайдеры = СредстваГеопозиционирования.ПолучитьПровайдеров();
1. Возвращает НЕОПРЕДЕЛЕНО, если в систему зашли, потом включили геолокацию и НЕ перезашли повторно, а продолжили работу.
2. Возвращает список провайдеров, даже если выключили геолокацию, но не перезайшли в систему.

Кто может сталкивался с таким, можно ли как-то отловить момент вкл./выкл. геоданных?
Просмотров: 87, последний комментарий от Elena_1288 | Просмотр полной темы | Просмотр раздела "1С:Предприятие 8.3"   
Язык текста ячейки макета, 1С 8.2 Обычный интерфейс
Автор robot1 — 25.04.16, 15:46 — 9 комментариев
Имеется внешний отчет, в котором текст всех ячеек внесен в поле для русского языка. Соответственно, в 1С текст не отображается. Подскажите, пжлст, можно ли быстро содержимое ячеек продублировать в поля для украинского языка.
Спасибо.
Просмотров: 112, последний комментарий от Petre | Просмотр полной темы | Просмотр раздела "1С 8.2 Обычный интерфейс"   
Добавление записи в регистр накоплений, 1С 8.2 Обычный интерфейс
Автор Ayrym — 25.04.16, 15:33 — 3 комментариев
Добрый день! подскажите как в регистр накоплений добавить запись, которая соответствует группе контрагента. В документе контрагент конечно же присутствует, но нужно еще записать его родителя, который не присутсвует на форме. Такое вообще можно сделать?
Просмотров: 78, последний комментарий от Petre | Просмотр полной темы | Просмотр раздела "1С 8.2 Обычный интерфейс"   
Не знаю как сделать отчет: Склад/ Номенклатура / Остаток / Себестоимость, Система компоновки данных
Автор nomac — 24.04.16, 13:31 — 5 комментариев
прошу пощения у ТС за то что пишу в эту же тему
но имеется похожий вопрос, начинаю осваивать 1с 8,3. Есть задание сделать отчет в УНФ ред. 1.5..
Отчет должен быть такого типа(как указано ниже), вид не важен, не могу понять с чего начать и что нужно делать.

Задание такое.
Отчет должен показать примерно такой результат.

Номенклатура Остаток (по всем складам) Себестоимость за 1 шт.
Склад №1 15 216,5
Брюки 10 275
Рубашка 5 158
Склад №2 12 675
Футболка 7 350
Ботинки 5 1000
Итого 27 445,75

Заранее благодарю за ответы.
Просмотров: 92, последний комментарий от nomac | Просмотр полной темы | Просмотр раздела "Система компоновки данных"   
RSS Текстовая версия Сейчас: 30.04.16, 1:34
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне