Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
РКО не закрывает взаиморасчет с контрагентом [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор bezmenov — 27.09.16, 23:32 — 0 комментариев
Доброе время суток.

1С:Предприятие 8.3 (8.3.8.1652) Управление торговлей для Украины, редакция 3.1

Для регистрации неторговых расходов использую документ "Поступление услуг и прочих активов" (например услуги внешнего брокера). Оплату провожу документом РКО с операцией "Оплата поставщику" выбираю объект расчетов, все в порядке дает выбрать "Поступление услуг и прочих активов". Но при формировании отчета "Управленческий баланс" возникает контроль нарушения баланса и отчет "Контроль управленческого баланса" показывает что РКО деньги снимает а взаимозачет с контрагентом не проводит, хотя движения в регистрах "Расчеты с поставщиками по документам" и Регистр накопления "Расчеты с поставщиками" есть. Если закрывать через документ "Списание безналичных ДС" все правильно закрывается.

Заранее благодарен за помощь.
Просмотров: 9, оставить комментарий   
Не відображається матеріальна допомога [раздел 1С Бухгалтерия 8]
Автор usser — 27.09.16, 23:05 — 0 комментариев
1С:Підприємство 8.3 Бухгалтерия для Украины, редакция 1.2.

Така ситуація, нарахували зарплату і матеріальну допомогу, всі проводки сформувались, але в Розрахунково-платіжній відомості ця допомога не відображається ... В чому може бути причина ?
Просмотров: 28, оставить комментарий   
Увольнение сотрудника [раздел 1С Управление Торговым Предприятием 8]
Автор kot488 — 27.09.16, 12:39 — 3 комментариев
Столкнулся с такой проблемой. Сотрудника приняли на роботу с помощью документа Кадровые перемещения организации. Теперь его нужно уволить создал документ на увольнение а мне при проведении: работник и приказ о приеме не соответствуют друг другу. В кадровом перемещении нет никакой строки с договором. Помогите разобраться как его теперь уволить
Просмотров: 69, последний комментарий от logist   
нужна обработка Установка цен на наборы номенклатуры [раздел Помогите найти/скачать обработку, отчет, макет...]
Автор Ariesod — 27.09.16, 11:17 — 0 комментариев
Добрый день. Буду очень благодарна, если кто поделиться обработкой по установке цен на наборы-комплекты для 1С:Предприятие 8.2 (8.2.19.83) конфигурация "Управление производственным предприятием для Украины", редакция 1.3

Похожая обработка есть на Инфостаре, но она для УТ [необходимо зарегистрироваться для просмотра ссылки]

Буду благодарна за любые ответы и советы.
Я тут новичек, уж простите, если что не так.
Заранее всем неравнодушным спасибо.
Просмотров: 35, оставить комментарий   
Не перенаправляются некоторые свойства принтера на сервер [раздел Администрирование и настройка компьютера, железо]
Автор vbi — 26.09.16, 19:36 — 7 комментариев
Есть локальный компьютер с Windows 7. На нем установлен принтер этикеток ZDesigner LP 2824. В свойствах принтера есть шаблоны (образцы) настроек печати:


Через RDP заходим на сервер Windows Server 2012. Принтер пробрасывается и печатает, но не пробрасываются настроенные образцы. Более того на стороне сервера нельзя изменить эти образцы у перенаправленного принтера. Нет прав. Хотя в настройках безопасности на локальном компьютере стоят все права для "Все":


Как пробросить образцы или хотя бы получить доступ к изменению образцов на сервере?
Просмотров: 118, последний комментарий от nmf   
Значение показателей схем мотивации [раздел 1С Управление Торговым Предприятием 8]
Автор podcast — 26.09.16, 9:53 — 0 комментариев
Здравствуйте подскажите пожалуйста как работают "Значение показателей схем мотивации ", есть предопределенный элемент "Оклад(Тариф) назначения (за час)" если его подставлять в формулу то он при расчете у кого то сам проставляется(очень редко), а кому то нужно прописывать, какой то закономерности я не заметил, при каких условиях он считается?
И ещё вопросы сделал свой показатель "Цена" выбрал назначение для "Организации" и тут такая же ситуация у кого берёт у кого то нет. Как они вообще работают?
Просмотров: 60, оставить комментарий   
Не удаляются документы в базе. В одном 4500 строк, в другом - 8500 стр [раздел Программирование в 1С Предприятие 7.7]
Автор whtblck — 25.09.16, 17:39 — 7 комментариев
Есть база 77, ТиС, редакция 9.2.
Объем 5,5Гб, файловая, с 2010 года.
Пытаюсь свернуть.
Нужно удалить документы до даты свертки.
Есть документы ввода начальных остатков, в одном 4500 строк, в другом - 8500 строк.
Не могу удалить (отменить проведение) этих документов.
За 8 часов документ в 4500 строк не пометился на удаление.
Боюсь подумать про документ в 8500 строк.
Есть предложения - как их отменить/удалить?
Спасибо.


 ! 

Правила: 4,5
 
Просмотров: 146, последний комментарий от whtblck   
Не могу получить из запроса значение [раздел Программирование в 1С Предприятие 8.3]
Автор sanytch — 24.09.16, 12:22 — 14 комментариев
Доброго времени всем. Буду признателен за любую помощь и подсказку.
Проблема собственно в следующем. В СКД запрос работает и выдаёт все необходимые данные, но если этот же запрос выполнять в модуле то выдаёт ошибку "Поле объекта не обнаружено (Сумма). Стр.Зарплаты = Результат.ПараметрыОплаты.Сумма;"
Думается мне что это от того что Сумма находится в ПараметрыОплаты

и если СКД воспринимает это нормально, выдавая результат

то модуль ругается.
Перепробовал варианты как и в тексте запроса:
- ЗарплатаКВыплатеОрганизаций.ПараметрыОплаты.(Сумма КАК СуммаЗП)
- ЗарплатаКВыплатеОрганизаций.ПараметрыОплаты.(Сумма) КАК СуммаЗП
так и в модуле:
- Стр.Сумма = Результат.ПараметрыОплаты.СуммаЗП;
- Стр.Сумма = Результат.ПараметрыОплаты.(СуммаЗП);
и кучу других, но...
Пробовал и способом вот таким:
    Выборка = Документы.ЗарплатаКВыплатеОрганизаций.Выбрать(НачалоПериода,КонецПериода);
    Пока Выборка.Следующий() Цикл
        Стр.Дата = Выборка.Дата;
        Стр.Документ = Выборка.Номер;
        Стр.Зарплаты = Выборка.ПараметрыОплаты.Сумма;
    КонецЦикла;

но когда дело доходит до Суммы то и Суммы то нет...


Ниже привожу отрывок кода из модуля:
(Стр - строка табличного поля Таб , в которое выводятся результаты)
        Запрос.Текст =
        "ВЫБРАТЬ
    |    ЗарплатаКВыплатеОрганизаций.Организация,
    |    НАЧАЛОПЕРИОДА(ЗарплатаКВыплатеОрганизаций.Дата, ДЕНЬ) КАК Дата,
    |    ЗарплатаКВыплатеОрганизаций.Номер,
    |    ЗарплатаКВыплатеОрганизаций.Проведен,
    |    ЗарплатаКВыплатеОрганизаций.ПараметрыОплаты.(Сумма)
    |ИЗ
    |    Документ.ЗарплатаКВыплатеОрганизаций КАК ЗарплатаКВыплатеОрганизаций
    |ГДЕ
    |    ЗарплатаКВыплатеОрганизаций.Проведен = ИСТИНА
    |    И ЗарплатаКВыплатеОрганизаций.Дата МЕЖДУ &НачПериода И &КонПериода    
    |
    |УПОРЯДОЧИТЬ ПО
    |    Дата";
    
    Результат = Запрос.Выполнить().Выбрать();

    Пока Результат.Следующий() Цикл
        Стр = Таб.Добавить();
        Стр.Дата = Результат.Дата;
        Стр.Документ = Результат.Номер;
        Стр.Сумма = Результат.ПараметрыОплаты.Сумма;
        Сообщить("Док №: "+Стр.Документ+" от "+Стр.Дата+" на сумму "+Стр.Зарплаты);
    КонецЦикла;

Подскажите как правильно обратится к Сумме из запроса?


 ! 

Правила: 3
 
Просмотров: 152, последний комментарий от sanytch   
Предопределенные данные (контакт. информ.): добавить новый элемент [раздел Программирование обычных форм 1С 8.2]
Автор Constantus — 24.09.16, 9:55 — 2 комментариев
Приветствую, форумчане!
УТ 10.3, 1с8.2, обычный

Пытаюсь в справочник "ВидыКонтактнойИнформации" добавить новый предопределенный элемент:
"АдресОрганизацииНаНациональномЯзыке", тип: Адрес, вид объекта: "Справочник "Организация""

Однако, когда создаю в Конфигураторе новый предопределенный элемент, в справочнике "ВидыКонтактной Информации" он хоть и проявляется, но без типа и вида объекта. Что делает его бесполезным элементом.

Как прописать в Конфигураторе все реквизиты для нового предопределенного элемента?
Просмотров: 69, последний комментарий от logist   
Сохранение отбора ТЧ на форме обработки [раздел Программирование обычных форм 1С 8.2]
Автор djmn_alexander — 23.09.16, 14:47 — 2 комментариев
Есть табличная часть обработки конфигурации. 1с 8.2 обычное приложение. Как мне сохранять отборы пользователя в данной форме обработки. При нажатии закрыть все отборы для табличной части (табличного поля) слетают.
Просмотров: 66, последний комментарий от vbi   
Ошибка при добавлении контрагента - "запись запрещена настройками" [раздел 1С Управление Торговым Предприятием 8]
Автор kindly — 23.09.16, 14:39 — 9 комментариев
1С:Предприятие 8.2 (8.2.18.104) Управление торговым предприятием для Украины", редакция 1.1.

Здравствуйте, уважаемые форумчани у меня вопрос, а точнее проблема. У менеджера возникла проблема с добавлением контрагента, хотя раньше все работало права не изменялись, роли настроены на добавление редактирование.

Не подскажите где можно посмотреть и как решить ошибку? "запись запрещена настройками"




 ! 

Правила: 3,4,5
 
Просмотров: 169, последний комментарий от logist   
Помогите настроить "Расходы будущих периодов" [раздел 1С Управление производственным предприятием 8]
Автор Наталья_К — 23.09.16, 12:12 — 3 комментариев
Здравствуйте , я новичок.
С программой 1С 8.3 - не работала. Сейчас вот учусь. Помогите пожалуйста.
Вопрос вот в чем. Мы строительная организация. И у меня много материалов, которые списываются по мере выполнения работ. Могу списать через 2-3 месяца, при подписании ф.2. Как мне относить материалы на расходы будущих периодов?
Тут я видела тему ка относить на 39 подписку. Но у меня другой вариант.
Если есть такая тема, то прошу прощения, что засоряю. Прошу тогда дать ссылку и мою удалить.
Просмотров: 110, последний комментарий от logist   
Оце мені цікаво, чому... [раздел Офф-топик]
Автор XBrut — 22.09.16, 16:32 — 10 комментариев
В Україні Рахунок-Фактура - це маловажливий папірець, за яким можна щось оплатити, а можна і ні,
а в московщині, Польщі (і я здагадуюсь в інших країнах) Рахунок-Фактура це документ, що підтверджує факт продажу і подію для нарахування ПДВ?
В який момент і чому саме так сталося?

У всіх воно називається щось типу Sales Order , а от у нас - "Рахунок-фактура".
Напевно, тут якась страшна тайна.
Просмотров: 202, последний комментарий от Petre   
Интерфейс Мобильного приложения. [раздел Мобильная платформа 1С]
Автор VOVIAL — 21.09.16, 15:30 — 7 комментариев
Доброго времени суток господа!

Есть вопрос, кто нибудь пытался изменить интерфейс мобильного приложения?
Если да то что получилось и как?
Например изменить основной цвет рамки с желтой на какой нибудь другой цвет или в меню добавить не только названия справочников и др. но и пиктограмки?
Изменить фон форм?
Просмотров: 149, последний комментарий от Acid   
Javascript и 1С. Кросс-платформенное взаимодействие [раздел 1С:Предприятие 8.3]
Автор Vofka — 21.09.16, 12:06 — 0 комментариев
Что делать, если необходим богатый интерфейс, а управляемые формы нам его не могут обеспечить? Использовать HTML и JavaScript. В статье рассмотрено взаимодействие кода 1С и JavaScript, работающее на любой платформе: толстый, тонкий и веб-клиент, под Windows и Linux.

На текущий момент штатные средства 1С в управляемых формах не могут в полной мере удовлетворить потребность в богатом и отзывчивом интерфейсе. Ведь, по словам разработчиков платформы, управляемые формы призваны обеспечить быструю и эффективную разработку бизнес-логики приложения, с некоторым ущербом интерфейсу. Для абсолютного большинства ситуаций это верный подход, но есть случаи, когда необходимо и то, и другое.
Решением является использование HTML и JavaScript.

Прелагается решение, которое работает как в тонком, так и в веб-клиенте. Под Windows и Linux.

Примечание: при упоминании работоспособности в тонком клиенте, также подразумевается работоспособность и в толстом клиенте (управляемое приложение).

Вызов методов языка JavaScript из кода 1С.

Методы JavaScript могут быть вызваны из 1C так:

<Окно документа>.funcName(funcArgs);


Глобальные переменные доступны следующим образом:

<Окно документа>.varName;


Для браузера Internet Explorer окно документа доступно через

Элементы.ПолеHTMLДокумента.Документ.parentWindow


Для остальных браузеров через

Элементы.ПолеHTMLДокумента.Документ.defaultView


Подготовка переменных модуля для взаимодействия с JavaScript и вызов функции:

&НаКлиенте
Перем ДокументПервогоБраузера;

&НаКлиенте
Перем ОкноПервогоБраузера;

&НаКлиенте
Процедура ПервыйБраузерДокументСформирован(Элемент)
        
    // Сохранение элементов document и window в переменные модуля формы,
    // для последующего быстрого доступа к элементам и функциям.
    ДокументПервогоБраузера = Элемент.Документ;
    ОкноПервогоБраузера     = ДокументПервогоБраузера.parentWindow; // IE
    Если ОкноПервогоБраузера = Неопределено Тогда
        ОкноПервогоБраузера = ДокументПервогоБраузера.defaultView; // Прочие браузеры
    КонецЕсли;

    ОкноПервогоБраузера.createButtons(МассивКнопокПервогоБраузера);

КонецПроцедуры


Подробнее остановимся на передаваемых агрументах.

В тонком клиенте под Windows, помимо примитивных типов Строка, Число, Булево.., в функцию JavaScript можно передавать и нативные объекты 1С, такие как Структура, Массив, Соответствие, УправляемаяФорма, и др. Затем, в теле javascript функции доступны свойства и методы этих объектов.

Пример:

&НаКлиенте
Процедура СоздатьКнопки(Команда)
    
    МассивКнопок = Новый Массив;    
    ...
    Для Сч = 1 По КоличествоКнопок Цикл
        ...
        СтруктураКнопки = Новый Структура;
        СтруктураКнопки.Вставить("Заголовок",         ЗаголовокКнопки);
        СтруктураКнопки.Вставить("ИмяКоманды",         ИмяКоманды);
        СтруктураКнопки.Вставить("РазмерТекста",     РазмерТекста);
        СтруктураКнопки.Вставить("ЦветТекста",         ЦветТекста);
                
        МассивКнопок.Добавить(СтруктураКнопки);
    КонецЦикла;        
    
    ОкноПервогоБраузера.createButtons(МассивКнопок);
    
КонецПроцедуры

function createButtons(buttonsArray)
{
    var buttonsCount = buttonsArray.Количество(); // Доступны методы и свойства массива 1С
    for(var i = 0; i < buttonsCount; i++)
    {
        ПараметрыКнопки = buttonsArray.Получить(i);

        var btn = document.createElement('div');
        btn.id             = ПараметрыКнопки.ИмяКоманды;
        btn.innerText         = ПараметрыКнопки.Заголовок;    
        btn.style.fontSize     = ПараметрыКнопки.РазмерТекста;            
        btn.style.color     = ПараметрыКнопки.ЦветТекста;    
                        
        container.appendChild(btn);                        
    }  
}


Данный метод очень удобен, и он подходит, если хватает возможности работы в тонком клиенте в ОС Windows.

В тонком клиенте под Linux, а также в веб-клиенте метод не работает. При передаче структур, массивов, соответствий в аргумент функции, в её теле эти агрументы равны undefined. Работает передача строк, чисел, булев.

Решением возникшей проблемы является использование формата обмена данными JSON. Что это такое - см. [необходимо зарегистрироваться для просмотра ссылки]

Массивы, Структуры и Соответствия преобразуются в их строковое представление, и передаются в функцию. Затем, в теле функции они преобразовываются в объекты языка javascript, такие как Array и Object.

Функции сериализации и десериализации в/из JSON:

&НаКлиенте
Функция СериализоватьВJSON(СериализуемыйОбъект)
    
    #Если ВебКлиент Тогда    
        СтрокаJSON = СериализоватьВJSONНаСервере(СериализуемыйОбъект);
    #Иначе
        ЗаписьJSON = Новый ЗаписьJSON;
        ЗаписьJSON.УстановитьСтроку();
        НастройкиСериализации = Новый НастройкиСериализацииJSON();
        НастройкиСериализации.СериализовыватьМассивыКакОбъекты = Ложь;
        ЗаписатьJSON(ЗаписьJSON, СериализуемыйОбъект, НастройкиСериализации, "ПреобразованиеВJSON", ЭтотОбъект);
        СтрокаJSON = ЗаписьJSON.Закрыть();
    #КонецЕсли
    
    Возврат СтрокаJSON;

КонецФункции

&НаСервереБезКонтекста
Функция СериализоватьВJSONНаСервере(СериализуемыйОбъект)
    
    ЗаписьJSON = Новый ЗаписьJSON;
    ЗаписьJSON.УстановитьСтроку();
    НастройкиСериализации = Новый НастройкиСериализацииJSON();
    НастройкиСериализации.СериализовыватьМассивыКакОбъекты = Ложь;
    ЗаписатьJSON(ЗаписьJSON, СериализуемыйОбъект);
    // ЗаписатьJSON(ЗаписьJSON, СериализуемыйОбъект, НастройкиСериализации, "ПреобразованиеВJSON", ЭтотОбъект);
    //
    // ЭтотОбъект недоступнен в безконтекстном вызове, поэтому нужно либо поместтить эту функцию в общий модуль,
    // либо изменить директиву компиляции в &НаСервере
    СтрокаJSON = ЗаписьJSON.Закрыть();
        
    Возврат СтрокаJSON;

КонецФункции

&НаКлиентеНаСервереБезКонтекста
Функция ПреобразованиеВJSON(Свойство, Значение, ДополнительныеПараметры, Отказ) Экспорт
    
    // Данная функция вызывается для всех свойств, тип которых не поддерживает преобразование в формат JSON напрямую.
    // Они нам не нужны, поэтому всегда отказ от их записи.
    Отказ = Истина;    
    
    // Можно сделать преобразование в строку.
    // Значение = Строка(Значение);
    // Возврат Значение;
    
КонецФункции

&НаКлиенте
Функция ДесериализоватьИзJSON(СтрокаJSON)
    
    #Если ВебКлиент Тогда
        ДесериализованныйОбъект = ДесериализоватьИзJSONНаСервере(СтрокаJSON);
    #Иначе
        ЧтениеJSON = Новый ЧтениеJSON();
        ЧтениеJSON.УстановитьСтроку(СтрокаJSON);
        ДесериализованныйОбъект = ПрочитатьJSON(ЧтениеJSON);
        ЧтениеJSON.Закрыть();
    #КонецЕсли    
    
    Возврат ДесериализованныйОбъект;
    
КонецФункции

&НаСервереБезКонтекста
Функция ДесериализоватьИзJSONНаСервере(СтрокаJSON)
    
    ЧтениеJSON = Новый ЧтениеJSON();
    ЧтениеJSON.УстановитьСтроку(СтрокаJSON);
    ДесериализованныйОбъект = ПрочитатьJSON(ЧтениеJSON);
    ЧтениеJSON.Закрыть();
    
    Возврат ДесериализованныйОбъект;
    
КонецФункции


Используются механизмы работы с JSON, реализованные в платформе 8.3.6.1977.

Для платформы 8.3.5 и ранее, можно использовать разработку господина Александра Переверзева, доступную по адресу http://pro1c.org.ua/index.php?showtopic=15065

Теперь, прежде чем передавать структуру в функцию JavaScript, преобразуем её в строку:

JSONМассивКнопокПервогоБраузера = СериализоватьВJSON(МассивКнопокПервогоБраузера);
ОкноПервогоБраузера.createButtons(JSONМассивКнопокПервогоБраузера);


Изменится и код функции Javascript, так как строку нужно преобразовать обратно в объект, пусть и не 1С-овский, но удобный для обработки:

function createButtonsWithJSON(buttonsData)
{
    buttonsData = JSON.parse(buttonsData);
    
    for(var i in buttonsData)
    {
        ПараметрыКнопки = buttonsData[i];

        var btn = document.createElement('li');
        btn.id = ПараметрыКнопки.ИмяКоманды;
        ...                                    
    }
}


Глобальный объект JSON, используемый для сериализации и парсинга (десериализации) в javascript, доступен начиная с Internet Explorer 8.

HTML документ в тонком клиенте, по умолчанию, даже при наличии установленного IE11, отображается в режиме совместимости с IE 5 (Quirks mode), поэтому необходимо его перевести в Standarts mode установной тега <meta http-equiv="X-UA-Compatible" content="IE=EDGE" /> в теле тега head.

Если на компьютере установлен IE7 (когда переход в режим IE8 невозможен), то нужно использовать следующий скрипт: [необходимо зарегистрироваться для просмотра ссылки]

который реализует функционал работы с JSON в IE < 8 (по аналогии с работой с JSON в платформе начиная с версии 8.3.6.1977, и до неё).

В функции javascript можно создавать массивы или объекты javascript, заполнять их, и возвращать в 1C.

&НаКлиенте
Процедура ПолучитьОбъектИзJavaScript(Команда)
    
    JSONСтруктураОтвета = ОкноПервогоБраузера.getDataFromJavaScript("");
    // Нужно передать любой параметр, например пустую строку, иначе функция не выполняется,
    // а переменной принимающей результат присваивается ссылка на эту функцию (COMОбъект).    
    СтруктураОтвета = ДесериализоватьИзJSON(JSONСтруктураОтвета);
    
    Для Каждого КлючИЗначение Из СтруктураОтвета Цикл
        Сообщить("Ключ: " + КлючИЗначение.Ключ + " Значение: " + КлючИЗначение.Значение);    
    КонецЦикла;
    
КонецПроцедуры

function getDataFromJavaScript()
{
    var arr = []; // Массив
    arr.push(555);
    arr.push("Строка в массиве");
    
     var obj = {}; // Объект (структура)
     obj["Ключ1"] = "Пробная строка";
     obj["Ключ2"] = 7777;
     obj["Ключ3"] = true;
     obj["Ключ4"] = arr;
    
     return JSON.stringify(obj);
}


Вызов методов 1С из JavaScript

В тонком клиенте под Windows доступен очень удобный метод:

В HTML документе создается глобальная переменная, например externalForm. При загрузке документа, переменной externalForm присваивается ссылка на текущую упрваляемую форму, доступную через ЭтотОбъект или ЭтаФорма.

Затем, в коде JavaScript становятся доступны любые клиентские экспортные методы и переменные модуля данной управляемой формы.

Пример:

// В документе html, в теге script объявляем глобальную переменную.
var externalForm = null;
var timer = null;
var counter = 0;

function startTimer()
{        
    alert(externalForm.ПеременнаяМодуля);
            
    timer = setInterval(function()
    {
        externalForm.МетодВызываемыйИзJavaScript("Значение переменной conunter: " + counter++);
    }, 1000);
}

function stopTimer()
{
    clearInterval(timer);
}
&НаКлиенте
Перем ПеременнаяМодуля Экспорт;

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    ...
    ПеременнаяМодуля = "Значение переменной модуля";
    
КонецПроцедуры

&НаКлиенте
Процедура ПервыйБраузерДокументСформирован(Элемент)
    
    ...        
    ОкноПервогоБраузера.externalForm = ЭтаФорма;
    
КонецПроцедуры

&НаКлиенте
Процедура ЗапуститьТаймер(Команда)
    
    ОкноПервогоБраузера.startTimer();
    
КонецПроцедуры

&НаКлиенте
Процедура ОстановитьТаймер(Команда)
    
    ОкноПервогоБраузера.stopTimer();
    
КонецПроцедуры

&НаКлиенте
Процедура МетодВызываемыйИзJavaScript(Данные) Экспорт
    
    Сообщить(Данные);
    
КонецПроцедуры


В тонком клиенте на Linux и в веб-клиенте методы и свойства переменной externalForm не доступны в javascript, их значение - undefined, поэтому используется следующая методика:

Объявляем глобальную переменную javascript, в которую будет помещать передаваемое значение.

var interactionVariable = null;


В документ добавляем невидимую кнопку

<button id="interactionButton" style="display: none">Кнопка взаимодействия</button>


Присваиваем передаваемое значение, например имя необходимой функции или любое другое значение, переменной interactionVariable и вызываем нажатие невидимой кнопки.

interactionVariable = "МетодВызываемыйИзJavaScript через interactionButton. Значение переменной conunter: " + counter;
interactionButton.click();


И обрабатываем событие ПриНажатии у поля HTML документа.

&НаКлиенте
Процедура ПервыйБраузерПриНажатии(Элемент, ДанныеСобытия, СтандартнаяОбработка)
    
    НажатыйЭлемент = ДанныеСобытия.Element;
    Если НажатыйЭлемент.id = "interactionButton" Тогда
        МетодВызываемыйИзJavaScript(ОкноПервогоБраузера.interactionVariable);
        
        // Или Заглушка = Вычислить(ОкноПервогоБраузера.interactionVariable + "()");
        // Поле для фантазии большое    
    КонецЕсли;
    
КонецПроцедуры


Благодарю за внимание, не претендую на уникальность и надеюсь, что и данная информация будет полезна многим.

[необходимо зарегистрироваться для просмотра ссылки]
Просмотров: 113, оставить комментарий   
Вывести название номенклаутрной позиции, текущие остатки по номенклатуре и минимальный остаток [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор SimplyUser1C — 21.09.16, 9:13 — 3 комментариев
Добрый день всем!

Столкнулась с такой возможно простой, но приводящей меня в тупик проблемой.

Необходимо вывести в таблицу название номенклаутрной позиции, текущие остатки по номенклатуре и минимальный остаток. В самой 1С ничего подобного не нашла. Все данные введены в БД.
Есть ли вообще такой отчет? Если нет то как его создать?

Версия программы:
1С:Предприятие 8.3 (8.3.7.1917)
Управление торговлей для Украины, редакция 3.1

Буду благодарна за помощь!


 ! 

Правила: 4,5
 
Просмотров: 139, последний комментарий от logist   
Как сделать переключатель горизонтальным [раздел Программирование в 1С Предприятие 8.3]
Автор info230a02 — 20.09.16, 15:27 — 2 комментариев
на форме документа поставил переключатель, он получился горизонтальным - "то шо доктор прописал".
Аналогично хочу вставить в форме элемента справочника - вертикальный получается. А хочу горизонтальный. как это сделать? где искать? Помогите пожалуйста
Просмотров: 145, последний комментарий от zetovich   
Добавление в отчет, всех единиц измерения товара [раздел 1С Управление Торговым Предприятием 8]
Автор Михрутка — 19.09.16, 11:29 — 4 комментариев
1с 8.2. УТП 1.2.27.6

Товар имеет единицу измерения -базову, единицу хранения остатков и единицу для отчетов - грамм. Также он имеет несколько других единиц измерения, одна из которых - штуки, которые добавлены в элементе номенклатуры, на вкладке "Единицы измерения". Можно ли настроить отчеты(например остатки), по единицам измерения, отличным от базовых?
Просмотров: 165, последний комментарий от Михрутка   
Редактирование и удаление 2-х документов, сделанных на основании (УТ 10.3.29.1) [раздел Программирование обычных форм 1С 8.2]
Автор Constantus — 17.09.16, 15:14 — 3 комментариев
Приветствую, форумчане!

УТ 10.3, 1с8.2, обычное.

Создал самописный документ "РегулированиеПоступлений" (точнее полная копия документа "Реализация товаров и услуг")
На основании данного документа создаются 2-а новых документа:
1. Реализация Товаров и Услуг
2. Поступление Товаров и Услуг

Иными словами, это формирование пакета документов для передачи товаров Основной организации в её филиалы (передача товаром между собственными организациями). Первый документ формирует задолженность перед Основной Организацией, Второй документ осуществляет Поступление товаров на склад Филиала.

Т.е. одним документом (самописным) я фотографирую двух зайцев.

В перспективе планирую создать кнопку, которая будет формировать эти 2-а документа программно. Это я сделать смогу...

Но вот возникает вопрос: возможна ситуация, что потребуется редактирование основного документа "РегулированиеПоступлений"!!! В этом случае мне потребуется редактирование и этих 2-х сопутствующих документов (сделанных на основании), точнее их табличных частей с последующим проведением.

Аналогично, если данный основной документ подлежит удалению (пометке), т.е. нужно также программно сделать отметку об удалении на эти 2-а документа.

Каким образом можно будет программно отредактировать ТЧ сопутствующих документов, сделанных на основании основного?
Как можно сделать программно отметку об удалении документов, сделанных на основании основного документа???


 ! 

Правила: 3
 
Просмотров: 173, последний комментарий от sava1   
Не получается прочитать запись Набора записей бухрегистра [раздел Программирование в 1С Предприятие 8.3]
Автор ms84 — 16.09.16, 19:42 — 3 комментариев
Здравствуйте, Конфигурация БГУ, добавлен долнительный субконто в счет,
затем хочу вытащить этот субконто из проводки, не получается

Движения=РегистрыБухгалтерии.ЕПСБУ.СоздатьНаборЗаписей();
Движения.Отбор.Регистратор.Значение=Документ;
Движения.Прочитать();
Для каждого запись из Движения цикл
запись.СубконтоДт - не получается раскрыть?


 ! 

Правила: 3,4,9
 
Просмотров: 180, последний комментарий от Vofka   
RSS Текстовая версия Сейчас: 28.09.16, 5:21
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне