Новые сообщения

Пользователю 7.7

Бухучет и налоги

Отзывы и предложения

Стол заказов

Обновления 1С

Пользователю 8.х

База знаний

ХРАНИЛИЩЕ

Здравствуйте, гость ( Вход | Регистрация )

Loading

Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 


> Навигация сайта
 

>  Стол заказов


Нужно доработать 1С? Обратитесь к нам в стол заказов!

С описанием работы системы можете ознакомиться по этой ссылке
 

> Посетители
Сейчас на сайте человек: 904
(пользователей: 35, гостей: 869)
Яндекс шпион
Гугл шпион
logist
Мейл.ру шпион
Yahoo шпион
mr_AntA
Shevon
steptostep
chessdude
Рамблер шпион
avaava
andr_andrey
Transgen
ivan-ik
pablo
Домовик
artemka_86
micmanm
dimentor
papasha95
Dimakur
V..I..P
webstudioglobal
konfed
msokolan
alrez
asd_13
nvru
vashchas
evgeniuss07
IgorSh2010
stark
sava1
vvdluua
maddokz
nysysimara
Petre
Zaval
mailrum
Lapka
 

> Последние бух. новости
Арсений Яценюк @ 26.04.15, 23:50
Просмотров: 26   Комментариев: 0

Арсений Яценюк @ 26.04.15, 23:50
Просмотров: 12   Комментариев: 0

Арсений Яценюк @ 26.04.15, 23:50
Просмотров: 14   Комментариев: 0

Арсений Яценюк @ 26.04.15, 23:50
Просмотров: 14   Комментариев: 0

Арсений Яценюк @ 26.04.15, 23:50
Просмотров: 15   Комментариев: 0

Арсений Яценюк @ 26.04.15, 23:50
Просмотров: 18   Комментариев: 0

Арсений Яценюк @ 26.04.15, 23:50
Просмотров: 13   Комментариев: 0

Арсений Яценюк @ 26.04.15, 23:50
Просмотров: 14   Комментариев: 0

Арсений Яценюк @ 26.04.15, 23:50
Просмотров: 16   Комментариев: 0

Арсений Яценюк @ 26.04.15, 23:50
Просмотров: 15   Комментариев: 0

Арсений Яценюк @ 26.04.15, 0:00
Просмотров: 54   Комментариев: 0

Арсений Яценюк @ 25.04.15, 23:50
Просмотров: 48   Комментариев: 0

Арсений Яценюк @ 25.04.15, 23:50
Просмотров: 46   Комментариев: 0

Арсений Яценюк @ 25.04.15, 23:50
Просмотров: 46   Комментариев: 0

Арсений Яценюк @ 25.04.15, 23:50
Просмотров: 45   Комментариев: 0

 

> Апрель 2015 Перейти к месяцу
  ВПВСЧПС
»
»
7
»
»
23
25
»
 
> 1С:Предприятие 8.3 :: Роли 1С 8.3 УПП
Автор alrez — 27.04.15, 14:46 — 1 комментариев
Добрый день.

Для настройки прав доступа была создана тестовая база. Копия продакшена. Был создан новый пользователь в тестовой базе.

Для этого пользователя выдаются права такие же как и работающего опльзователя в продакшене.

Но доступ к документам для тестового пользователя запрещен.

Чем это иожет быть вызвано? Спасибо.
Просмотров: 16, последний комментарий от logist | Просмотр полной темы | Просмотр раздела "1С:Предприятие 8.3"   
 

> 1С Управление производственным предприятием 8.* :: увеличение реквизита на определенное значение
Автор DatteBayo — 27.04.15, 12:33 — 4 комментариев
Приветствую, Уважаемые форумчане!
Мудрейшие форума сего, дозвольте впитать частичку вашей гениальности, посредством очередного вопроса
Есть ли возможность пакетно изменить цены в номенклатуре на, к примеру, 15%? Групповая обработка изменяет сам реквизит. Есть ли возможность исхитриться?
Просмотров: 52, последний комментарий от sava1 | Просмотр полной темы | Просмотр раздела "1С Управление производственным предприятием 8.*"   
 

> 1С 8.2 Управляемый интерфейс :: Ошибка отображения типов:
Автор ktu78 — 27.04.15, 12:16 — 5 комментариев
Добрый день, коллеги. Версия 1с 8.3
Проблема: в документе у меня 2 реквизита:
КонтрагентВалюты и НомерПаспорта
КонтрагентВалюты - ссылочный тип на Справочник "КонтрагентыВалюты"
НомерПаспорта - строка 10 знаков.
В справочнике "КонтрагентыВалюты" также есть реквизит НомерПаспорта, строка 10 симв.
Я хочу, чтобы в форме документа после того, как выберу контрагента, в поле документа "НомерПаспорта" автоматически появился номер паспорта, взятый со справочника "КонтрагентыВалюты" для конкретного человека
В модуле формы таков код:

&НаКлиенте
Процедура ПродавецВалютыПриИзменении(Элемент)
    НомерПаспорта=ПолучиНомерПаспорта(Элементы.ПродавецВалюты);
КонецПроцедуры

&НаСервере
Функция ПолучиНомерПаспорта(СсылкаНаПродавцаВалюты)
    ПродавецВалютыКакОбъект=СсылкаНаПродавцаВалюты.ПолучитьОбъект();
    
    Возврат ПродавецВалютыКакОбъект.НомерПаспорта;
КонецФункции

При запуске 1с в пользовательском режиме когда я вставляю Контрагента
выдается сообщение:
Ошибка отображения типа. Отсутствует отображение для типа "Поле формы"
Когда я подробней просмотрел ошибку, то выдано следующее:
{Документ.ПокупкаВалюты.Форма.ФормаДокумента.Форма(34)}: Ошибка при вызове метода контекста (ПолучиНомерПаспорта)
НомерПаспорта=ПолучиНомерПаспорта(Элементы.ПродавецВалюты);
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'param':
форма: Элемент
имя: {http://v8.1c.ru/8.2/managed-application/modules}param
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'ПолеФормы'

Подскажите пожалуйста, помогите. Заранее благодарен. Удачного дня!


 ! 

Правила, п.5,12
 
Просмотров: 33, последний комментарий от Petre | Просмотр полной темы | Просмотр раздела "1С 8.2 Управляемый интерфейс"   
 

> 1С 8.2 Обычный интерфейс :: УТП, изменение режима совместимости
Автор onsamuy — 24.04.15, 15:53 — 2 комментариев
Доброго всем дня. Хочу использовать общие реквизиты, но в УТП стоит режим совместимости "версия 8.2.13". Когда то читал инфу что в конфигурациях АББИ (УТП, Бухгалтерия) режим совместимости лучше не трогать, поскольку могут быть проблемы с проведением по бух. регистрам (ошибки в субконто). Что подскажете, может кто менял совместимость? Каков результат такого действия в УТП?
Просмотров: 110, последний комментарий от logist | Просмотр полной темы | Просмотр раздела "1С 8.2 Обычный интерфейс"   
 

> 1С Управление производственным предприятием 8.* :: Факт уплаты налогов
Автор DatteBayo — 24.04.15, 14:03 — 3 комментариев
Приветствую, уважаемые форумчане!
Вопрос нубский, но он меня уже победил и теперь все мои надежды на коллективный разум.
Как ПРАВИЛЬНО отразить факт уплаты налогов, вчастности НДФЛ.
На данный момент этот факт фиксируется плтаженым поручением(на общуу сумму с указанием назначение платежа "уплата налогов"), но оно никакой привязки к сотрудникам либо к зарплатным документам не имеет. Так и выходит что налог сотрудникам посчитали, а уплаты как бы и не было. В регистрах накопления приход по налогу есть, а расхода нет и в 1ДФ соответственно колонка уплаченого налога пустая


 ! 

Правила, пункт 5!
 
Просмотров: 161, последний комментарий от logist | Просмотр полной темы | Просмотр раздела "1С Управление производственным предприятием 8.*"   
 

> 1С Бухгалтерия 8.* :: Зарплата в спецификации
Автор BARBARA — 23.04.15, 20:36 — 7 комментариев
1С:Предприятие 8.2 (8.2.19.83)
Доброе времени суток!
Производство гипсовых фигур. Создаю спецификацию на каждую фигуру и указываю количество материалов. Хочу указать расценку на изготовление такой фигурки в спецификации. Как это сделать? 64000000.gif
Просмотров: 222, последний комментарий от BARBARA | Просмотр полной темы | Просмотр раздела "1С Бухгалтерия 8.*"   
 

> 1С Бухгалтерия 8.* :: Красные суммы счетов 26 и 23
Автор Мирослава — 23.04.15, 17:51 — 8 комментариев
Здравствуйте! Я новичок по пользованию 1 С8.2 -) У меня следующая проблема: после проведения Закрития месяца по Дт 26 Кт 23 получились красные суммы по некоторым видам продукции. З чем это связано? Раньше такого не было. Очень нуждаюсь в ответе. Заранее спасибо.
Просмотров: 226, последний комментарий от Мирослава | Просмотр полной темы | Просмотр раздела "1С Бухгалтерия 8.*"   
 

> 1С 8.2 Обычный интерфейс :: Получение данных из регистра бухгалтерии
Автор DrLivsi — 23.04.15, 16:02 — 3 комментариев
Всем привет.

Есть регистр бухгалтерии с корреспонденцией счетов.
Есть простой отчет который строится из этого регистра (виртуальная таблица ОстаткиИОбороты)
В регистре есть такая запись:



361 счет - валютный, соответственно сумма в валюте пишется.
701 счет - не валютный, суммы вал. нет.

В отборах отчета стоит счет 701.

Вопрос, можно ли вывести сумму вал. для 701 счета (которая в данной записи = 2250)?

Конфигурация и отчет самописные, версия 1с 8.2
Просмотров: 146, последний комментарий от Petre | Просмотр полной темы | Просмотр раздела "1С 8.2 Обычный интерфейс"   
 

> 1С 8.2 Управляемый интерфейс :: Открытие из ячейки одного справочника формы элемента другого справочника
Автор inetmarko — 23.04.15, 14:51 — 1 комментариев
Подскажите, плз, можно ли при двойном клике на записи в поле Контрагенты списка справочника "Заказы" (например Антарес, ЧФ (выделено красным)) открыть форму элемента с соответствующим Наименованием ("Антарес, ЧФ") из справочника Контрагенты, а не форму элемента текущего справочника "Заказы"?
Если да, то можно ли это сделать без написания кода?
Если нет, то я предполагаю, что нужно описать процедуру при обработке события "при нажатии" элемента формы "Контрагент" списка справочника "Заказы". Я на правильном пути или нет?
Что посоветуете?

Просмотров: 112, последний комментарий от Petre | Просмотр полной темы | Просмотр раздела "1С 8.2 Управляемый интерфейс"   
 

> 1С Предприятие 7.7 :: Общая файловая ошибка при доступе файл Картинка
Автор gls65 — 23.04.15, 14:46 — 0 комментариев
Скинули мне для друга- стоматолога простую конфу. Я ее поставил на XP - все работает. У друга Windows 7 x64.
Проблема работы с картинками.
Есть основной Справочник пациентов и у него есть подчиненный Справочник Галерея - картинки.jpg . В форме списка последнего вставлен текст, у которого в дополнительно, формула - с помощью функции картинка рисуется в форме.

Функция ЗагрузитьКартинку();
    Если ПустоеЗначение(ПутьКФайлуФото)=0 Тогда            
        Форма.Картинка.Видимость(1);
        Картинка.РежимРисования(3);
        Картинка.Загрузить(СокрЛП(ПутьКФайлуФото));    
        Картинка.РежимРисования(3);
        Картинка.Загрузить(СокрЛП(ПутьКФайлуФото));    
    Иначе
        Форма.Картинка.Видимость(0);
    КонецЕсли;
КонецФункции


Если открыть именно Справочник пациентов в виде списка и оттуда вызвать подчиненный справочник, то все работает.
если открыть Справочник пациентов и Элемент справочника, то там есть Кнопка с формулой:

ОткрытьФорму("Справочник.Галерея",ТекущийЭлемент(),1);

пишет ошибку : общая файловая ошибка при доступе и далее путь к файлу с картинкой

????? плз


 ! 

Правила, 12
 
Просмотров: 152, оставить комментарий | Просмотр полной темы | Просмотр раздела "1С Предприятие 7.7"   
 

> Вся 1С :: Полезные функции для работы со строками
Автор Vofka — 23.04.15, 10:23 — 5 комментариев
Для себя писал несколько функций, которыми периодически пользуюсь. Ничего сверхъестественного, просто полезно иметь что-то такое под рукой. Если у вас есть что-то подобное - можно так же тут выкладывать.

// Возвращает массив цифр в виде стоковых символов
//
Функция ПолучитьМассивЦифровыхСимволов() Экспорт
    
    МассивЦифр = Новый Массив();
    
    МассивЦифр.Добавить("0");
    МассивЦифр.Добавить("1");
    МассивЦифр.Добавить("2");
    МассивЦифр.Добавить("3");
    МассивЦифр.Добавить("4");
    МассивЦифр.Добавить("5");
    МассивЦифр.Добавить("6");
    МассивЦифр.Добавить("7");
    МассивЦифр.Добавить("8");
    МассивЦифр.Добавить("9");
    
    Возврат МассивЦифр;
    
КонецФункции

// Возвращает Истину, если в передаваемой строке есть что-то кроме цифр
//
Функция ЕстьНеЦифры(Строка) Экспорт
    
    МассивЦифр = ПолучитьМассивЦифровыхСимволов();
    
    ЕстьНеЦифры = Ложь;
    Для ъ = 1 По СтрДлина(Строка) Цикл
        Символ = Сред(Строка, ъ, 1);
        Если МассивЦифр.Найти(Символ) = Неопределено Тогда
            ЕстьНеЦифры = Истина;
            Прервать;
        КонецЕсли;
    КонецЦикла;
    
    Возврат ЕстьНеЦифры;
    
КонецФункции

// Возвращает строку, в которой убирает любые символы, кроме цифр
//
Функция ПолучитьТолькоЦифры(Строка) Экспорт
    
    МассивЦифр = ПолучитьМассивЦифровыхСимволов();
    
    Для ъ = 1 По СтрДлина(Строка) Цикл
        Символ = Сред(Строка, ъ, 1);
        Если МассивЦифр.Найти(Символ) = Неопределено Тогда
            Строка = СтрЗаменить(Строка, Символ, " ");
        КонецЕсли;
    КонецЦикла;
    Строка = СтрЗаменить(Строка, " ", "");
    
КонецФункции

// Возвращает Истину, если в передаваемой строке есть буквы
//
Функция ЕстьБуква(Строка) Экспорт
    
    МассивБукв = ПолучитьМассивБукв();
    ЕстьБуква = Ложь;
    Для ъ=1 По СтрДлина(Строка) Цикл
        Буква = ВРег(Сред(Строка, ъ, 1));
        Если МассивБукв.Найти(Буква) <> Неопределено Тогда
            ЕстьБуква = Истина;
            Прервать;
        КонецЕсли;
    КонецЦикла;
    Возврат ЕстьБуква;
    
КонецФункции

// Просто возвращает массив наших и латинских букв
//
Функция ПолучитьМассивБукв() Экспорт
    
    МассивБукв = Новый Массив;
    
    МассивБукв.Добавить("А");
    МассивБукв.Добавить("Б");
    МассивБукв.Добавить("В");
    МассивБукв.Добавить("Г");
    МассивБукв.Добавить("Д");
    МассивБукв.Добавить("Е");
    МассивБукв.Добавить("Ё");
    МассивБукв.Добавить("Ж");
    МассивБукв.Добавить("З");
    МассивБукв.Добавить("И");
    МассивБукв.Добавить("Й");
    МассивБукв.Добавить("К");
    МассивБукв.Добавить("Л");
    МассивБукв.Добавить("М");
    МассивБукв.Добавить("Н");
    МассивБукв.Добавить("О");
    МассивБукв.Добавить("П");
    МассивБукв.Добавить("Р");
    МассивБукв.Добавить("С");
    МассивБукв.Добавить("Т");
    МассивБукв.Добавить("У");
    МассивБукв.Добавить("Ф");
    МассивБукв.Добавить("Х");
    МассивБукв.Добавить("Ц");
    МассивБукв.Добавить("Ч");
    МассивБукв.Добавить("Ш");
    МассивБукв.Добавить("Щ");
    МассивБукв.Добавить("Ъ");
    МассивБукв.Добавить("Ы");
    МассивБукв.Добавить("Ь");
    МассивБукв.Добавить("Э");
    МассивБукв.Добавить("Ю");
    МассивБукв.Добавить("Я");
    МассивБукв.Добавить("І");
    МассивБукв.Добавить("Ї");
    МассивБукв.Добавить("Є");
    МассивБукв.Добавить("Ґ");
    
    МассивБукв.Добавить("A");
    МассивБукв.Добавить("B");
    МассивБукв.Добавить("C");
    МассивБукв.Добавить("D");
    МассивБукв.Добавить("E");
    МассивБукв.Добавить("F");
    МассивБукв.Добавить("G");
    МассивБукв.Добавить("H");
    МассивБукв.Добавить("I");
    МассивБукв.Добавить("J");
    МассивБукв.Добавить("K");
    МассивБукв.Добавить("L");
    МассивБукв.Добавить("M");
    МассивБукв.Добавить("N");
    МассивБукв.Добавить("O");
    МассивБукв.Добавить("P");
    МассивБукв.Добавить("Q");
    МассивБукв.Добавить("R");
    МассивБукв.Добавить("S");
    МассивБукв.Добавить("T");
    МассивБукв.Добавить("U");
    МассивБукв.Добавить("V");
    МассивБукв.Добавить("W");
    МассивБукв.Добавить("X");
    МассивБукв.Добавить("Y");
    МассивБукв.Добавить("Z");
    
    Возврат МассивБукв;
    
КонецФункции

// Из передаваемой строки убираются любые не буквенные символы
//
Функция ПолучитьТолькоБуквы(Строка) Экспорт
    
    ВозвращаемаяСтрока = "";
    МассивБукв = ПолучитьМассивБукв();
    
    Для ъ = 1 По СтрДлина(Строка) Цикл
        Буква = ВРег(Сред(Строка, ъ, 1));
        
        Если МассивБукв.Найти(Буква) = Неопределено Тогда
            Продолжить;
        КонецЕсли;
        
        ВозвращаемаяСтрока = ВозвращаемаяСтрока + Сред(Строка, ъ, 1);
    КонецЦикла;
    
    Возврат ВозвращаемаяСтрока;
    
КонецФункции
Просмотров: 195, последний комментарий от Petre | Просмотр полной темы | Просмотр раздела "Вся 1С"   
 

> Работа с торговым оборудованием :: Использование фискального регистратора мини фп54.01
Автор geniusbsd — 23.04.15, 8:33 — 0 комментариев
Доброго дня!
В связи с изменением законодательства Украины требуется на всех наших торговых точках требуется установить
фискальные регистраторы.
В данный момент используется для печати чеков обычные чековые принтера
Хотел проконсультироваться по использованию фискального регистратора мини фп54.01
Прочитав документацию понял так что бы что продать через регистратор требуется сначала этот товар записать в регистратор
Память регистратора на 16000 товаров у нас на мальних магазинах больше 20000, а на больших ассортимент больше 40000 наименований
Можно ли перед отправкой на регистратор делать проверку на наличие товара в памяти регистратора если его нет добавлять и так проходить весь чек
А при закрытии смены очищать записанные товары
Или такая схема будет занимать много времени?
Второй вопрос продажа акционых товаров.
К примеру у нас с 8:00-9:00 и с 19:00-20:00 и при сумме 150грн оптовые цены
В чеке процедура проверяет время и сумму и пересчитывает цены
Также используются акции 1+1=3 и Второй в чеке 50%
В OLE сервере фискальника есть функция скидок/наценок.

Можно ли заведя в регистратор товар с открытой ценой при продаже указывать ему требуемую цену через 1С
Или это не правильно со стороны фискальной службы


 i 

Правила, п.3,4,5
 
Просмотров: 144, оставить комментарий | Просмотр полной темы | Просмотр раздела "Работа с торговым оборудованием"   
 

> 1С Управление производственным предприятием 8.* :: Не учитывать ежегодный отпуск при декрете
Автор ozstriker — 23.04.15, 8:29 — 0 комментариев
Доброго времени суток!)

Столкнулся с проблемой, которую не могу решить.

Человек находится в декретном отпуске. В регистрах сведений "Учетна политика по персоналу" и "положенные отпуска" выставлено, что сотрудник имеет 24 календарных дня отпуска(плановых, ежегодных, начиная с 2010 года), и для этого сотрудника выставлено, что начиная с 2012 года, она имеет 365 дней в году ДЕКТРЕТНОГО отпуска.

Открываю "Отчет по использованию отпусков", а в нем вижу то, что у человека оказывается 389 дней отпуска в году)))))

Так вот вопрос обстоит в том, как ПРАВИЛЬНО заполнить регистры(или что-либо еще), чтобы во время декретного отпуска НЕ УЧИТЫВАЛСЯ плановый ежегодный, и, соответственно, чтобы в отчете получали более или менее адекватные цифры по срокам отпусков.

Заранее всем спасибо за помощь!)

З.Ы. Конфигурация УПП 1.3.14
Просмотров: 126, оставить комментарий | Просмотр полной темы | Просмотр раздела "1С Управление производственным предприятием 8.*"   
 

> 1С 8.2 Управляемый интерфейс :: Помогите сделать код для подсчета общей суми
Автор Tweakerok — 22.04.15, 21:52 — 3 комментариев
Есть документ рахунок-фактура. Вводиться например количество 2, а цена 10 000. Нужно чтобы автоматически подсчитывало значение в поле СУМА, т.е. устанавливало 20 000.

Как это сделать с помощью кода? Модуль объекта пустой....




 ! 

Правила, пункт 3
 
Просмотров: 135, последний комментарий от logist | Просмотр полной темы | Просмотр раздела "1С 8.2 Управляемый интерфейс"   
 

> Администрирование и настройка серверов баз данных :: работа в сети с 1С без RDP?
Автор satelite-2015 — 22.04.15, 15:34 — 16 комментариев
Смысл в следуюющем - есть сервер 1С 8,2 удаленка, замысел отказатся от подключения удаленных рабочих столов. Какие варианты могут быть?
1. Можно ли при подключении через ВПН вынести ярлыки на рабочие столы пользователям? Будет ли с этих ярлыков запускатся 1С или нужно дорабатывать?
2. Решение административными средствами груповых политик и скриптов для запуска 1С без РДП
3. Альтернативы?

Рад буду любым решениям и помощи.
Просмотров: 299, последний комментарий от satelite-2015 | Просмотр полной темы | Просмотр раздела "Администрирование и настройка серверов баз данных"   
 

> 1С Предприятие 8.1 (8.0) :: Перенос слов в другую строку макета.
Автор olichka — 22.04.15, 15:19 — 4 комментариев
здравствуйте, подскажите пожалуйста как перенести слова в другую строку макета. в свойствах не подходит. На рисунке видно проблему. мне нужно чтоб слово "систем" перенеслось на другую строку
Просмотров: 158, последний комментарий от Petre | Просмотр полной темы | Просмотр раздела "1С Предприятие 8.1 (8.0)"   
 

> 1С:Предприятие 8.3 :: Печать нужных колонок макета
Автор kosalex — 22.04.15, 14:26 — 1 комментариев
Добрый день! Есть макет:


Имя колонки "счет" = КолонкаСчет;
Имя колонки "Цена" = КолонкаЦена;
Имя колонки "Сумма" = КолонкаСумма;

В зависимости от настроек, нужно выводить/прятать "счет", выводить/прятать "Цена", "Сумма". Как то можно так делать?
Просмотров: 100, последний комментарий от Petre | Просмотр полной темы | Просмотр раздела "1С:Предприятие 8.3"   
 

> 1С:Предприятие 8.3 :: Помогите с передачей параметров во внешнюю обработку
Автор kosalex — 22.04.15, 14:16 — 8 комментариев
Доброго времени суток! Есть внешняя обработка, и конфа БП КОРП (РФ), УФ. Обработку подключил, по кнопке "Печать" в документе "ТребованияНакладная" моя кнопка появляется.

Мне нужно по нажатию на добавленной кнопке открыть форму настроек, форма в самой обработке. У нее есть реквизиты "Объект" и т.п. Мне нужно чтобы в Объект попала ссылка на документ с которого была нажата кнопка. Как это сделать, что то ума не приложу.

Нужно при открытии формы "Настройки" передавать эту ссылку или как и где? ПОДСКАЖИТЕ !

Вок какой код у меня есть в модуле объекта обработки, как я понимаю этот код нужен чтобы прописать мою внешнюю печатную форму в базе.
Функция СведенияОВнешнейОбработке() Экспорт

    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Документ.ТребованиеНакладная");
    МассивНазначений.Добавить("Документ.ПоступлениеИзПереработки");

    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "Отчет о списании материалов ""ТребованияНакладной"" и ""ПоступлениеИзПереработки""");
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
    ПараметрыРегистрации.Вставить("Информация","by kos");
    
    ТаблицаКоманд = ПолучитьТаблицуКоманд();

    ДобавитьКоманду(ТаблицаКоманд,
        "Отчет о списании материалов",
        "0",
        "ОткрытиеФормы",
        Истина
    );

    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

    Возврат ПараметрыРегистрации;
КонецФункции

Функция ПолучитьТаблицуКоманд()
  Команды = Новый ТаблицаЗначений;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление;
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;
КонецПроцедуры

Просмотров: 206, последний комментарий от kosalex | Просмотр полной темы | Просмотр раздела "1С:Предприятие 8.3"   
 

> 1С:Предприятие 8.3 :: Внешняя компанента zxing.dll
Автор vbnm — 22.04.15, 13:30 — 10 комментариев
УстановитьВнешнююКомпоненту(Путь);

Выдает ошибку "Возможно, отсутствует компонента для используемого клиентского приложения"

При регистрации пишет не найдена точка входа.

Штатная - 1CBarcodeRecognitionAddIn17.dll работает, но только с одним кодом.

Кто то прикручивал zxing.dll ?
Просмотров: 254, последний комментарий от Vofka | Просмотр полной темы | Просмотр раздела "1С:Предприятие 8.3"   
 

> 1С Предприятие 7.7 :: Не правильно формирует отчет
Автор sasha_bako — 21.04.15, 23:24 — 4 комментариев
//*******************************************
// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
    
    Перем Запрос, ТекстЗапроса, Таб;
    Если ВыбМастер.Выбран()=0 Тогда
         Предупреждение("Не выбран мастер");
         Возврат;
    КонецЕсли;
    Если ВыбВидРемонта.Выбран()=0 Тогда
         Предупреждение("Не выбран вид ремонта");
         Возврат;
КонецЕсли;    

    НачОтчета=Дата("01.01.00");
    КонОтчет=КонГода(ВыбКонПериода);
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =  
    
    
    "//{{ЗАПРОС(Сформировать)
    |Период с НачОтчета по КонОтчет;
    |Мастер = Документ.РК.МастерРемонта;
    |ТекущийДокумент = Документ.РК.ТекущийДокумент;
    |ТМЦ = Документ.РК.Агрегат;
    |ВидРемонта = Документ.РК.ВидРемонта;
    |Группировка Мастер;
    |Группировка ТекущийДокумент;
    |Группировка ВидРемонта;
    |Группировка ТМЦ;
    |Условие(Мастер = ВыбМастер);
    |Условие(ВидРемонта = ВыбВидРемонта);
    |"//}}ЗАПРОС
;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;

    // Подготовка к заполнению выходных форм данными запроса
    //Таб = СоздатьОбъект("Таблица");
    //Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Ном=0;
    Пока Запрос.Группировка(1) = 1 Цикл
        // Заполнение полей Мастер
        //Таб.ВывестиСекцию("Мастер");
        Пока Запрос.Группировка(2) = 1 Цикл
            // Заполнение полей ТекущийДокумент
            //Таб.ВывестиСекцию("ТекущийДокумент");  
            
            Пока Запрос.Группировка(3) = 1 Цикл
                // Заполнение полей ТМЦ
                
                Пока Запрос.Группировка(4) = 1 Цикл
                    // Заполнение полей ВидРемонта
                    Если Запрос.ТМЦ.ЭтоГруппа()=1 тогда
                        Продолжить;
                    КонецЕсли;
                    
                    //Если (ВыбНачПериода>=Запрос.ТекущийДокумент.ДатаРемонта) И (ВыбКонПериода<=Запрос.ТекущийДокумент.ДатаРемонта)  Тогда
                    Если (НачМесяца(ВыбНачПериода)=НачМесяца(Запрос.ТекущийДокумент.ДатаРемонта)) ИЛИ (КонМесяца(ВыбКонПериода)=КонМесяца(Запрос.ТекущийДокумент.ДатаРемонта))  Тогда
                        Ном=Ном+1;
                    Таб.ВывестиСекцию("товар");
                    КонецЕсли;    
                КонецЦикла;
            КонецЦикла;
        КонецЦикла;
    КонецЦикла;
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры



 ! 

Правила: 3, 12
 
Просмотров: 256, последний комментарий от miha74 | Просмотр полной темы | Просмотр раздела "1С Предприятие 7.7"   
 

RSS Текстовая версия Сейчас: 27.04.15, 15:36
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне