Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Налоговая накладная по рознице [раздел 1С Управление Торговым Предприятием 8]
Автор avel1976 — 23.03.17, 0:37 — 0 комментариев
Здравствуйте. С 22.03.2017 налоговая ввела новые требования по заполнению итоговой налоговой накладной по рознице за день. Требуют, чтобы товары группировались по коду УКТ ЗЕД и ДКПП, колонки 4,5,6,7 были пустыми, а была только сумма. Но 1С так не формирует налоговую накладную. При обращении на линию поддержки 1С, оператор сказал, что обновления не предвидится, так как нет нормативных документов. Подскажите, кто и как выходил из данного положения. Заполнять ручками - не реально, около 500 строк наименований. Спасибо.
Просмотров: 22, оставить комментарий   
Поступление товаров и услуг не попадает в регистр "Партии товаров на складах" [раздел 1С Управление Торговым Предприятием 8]
Автор bestnamebest — 22.03.17, 17:28 — 3 комментариев
1С:Предприятие 8.3 (8.3.9.2033)
"Управление торговым предприятием для Украины", редакция 1.2.
Разработка конфигурации: "ABBYY Ukraine", 2007-2016 (1.2.39.1) (http://1c.ua/v8/RegionalSolutions_UA_UTP.php)
Copyright © ДП "Еврософтпром", 2007-2016. Все права защищены
(http://www.1c.ua)


Здравствуйте. Есть документ "Поступление товаров и услуг". Галочка стоит только по упр учету. При проведении документа за любой день до 11.01.17, он ПОПАДАЕТ в регистр "Партии товаров на складах по упр. учету".
При проведении его после 11.01.17 он НЕ ПОПАДАЕТ в регистр/не делает записи. Почему? Кто подскажет?
В учетной политике все ок. По ФИФО, вести партионный учет по складам. Период 01.01.1980
Просмотров: 71, последний комментарий от logist   
Как убрать должность главного бухгалтера в документах [раздел 1С Зарплата и Управление Персоналом 8]
Автор Лелуш Ламперуж — 22.03.17, 16:31 — 10 комментариев
О программе:
1. 1С:Предприятие 8.3 (8.3.9.2170)
2.Конфигурация: "Зарплата и Управление Персоналом для Украины", редакция 2.1.
Разработка конфигурации: "ABBYY Ukraine", 2008-2017 (2.1.45.3)

У меня маленькое предприятие и должности главный бухгалтер и руководитель кадровой службой просто нет, но есть должность бухгалтер. Можно ли как-то убрать эти подписи и вместо них оставить подпись бухгалтера. Заранее спасибо за ответ.
Просмотров: 86, последний комментарий от Лелуш Ламперуж   
Программист 1С, Харьков, от 8-16 тыс. грн. (полный день) [раздел Предложения работы]
Автор drdroid — 22.03.17, 15:39 — 4 комментариев
1. Требуется программист 1С 8.х, обычные формы.
2. Зарплата по собеседованию от 8000 до 16000 т. грн;

О компании:
- г. Харьков, Франковская 14;
- ГК "Аптека-95";
- основная деятельность: поставки фармацевтического сырья, расходных материалов и оборудования;

Требования и необходимые навыки:
1. Высшее образование (техническое, экономическое)
2. Знание платформы 1С Предприятие 8.х.
3. Опыт работы программистом 1С 8.х не менее 2 лет.
4. Практический опыт участия в проектах доработки конфигураций на платформе 1С Предприятие 8.х.
5. Опыт групповой разработки (работа с хранилищем конфигурации, версионирование).
6. Желательно опыт разработки нетиповых конфигураций 1С.
7. Желательно опыт администрирования 1С:Предприятие 8.х (обновление версии платформы, работа с базами MSSQL).
8. Желательно знание одной из типовых конфигураций (1С:Упраление торговлей / 1С:Управление торговым предприятием).

Необходимые качества:
- ответственность;
- аккуратность;
- системность мышления;

Обязанности:
1. Модификация используемой конфигурации 1С под актуальные задачи компании, поддержка имеющейся конфигурации.
2. Создание новых документов, отчетов, обработок.
3. Тестирование функциональности системы.
4. Администрирование и поддержка 1С.
5. Количество пользователей 1с ~50;

8. Условия работы:
- оформление по трудовой книжке;
- зарплата: на руки - от 8000 до 16000 т. грн. На испытательный з/п зарплата может быть меньше. Зарплата выдаётся без задержек после 10-го числа, авансов нет. Бывают премии;
- расписание работы с 9.00 до 18.00, перерыв на обед 1 час
- испытательный срок - месяц;
- работа в основном в офисе;

9. Условия собеседования:
- собеседование ведут кадровый работник и ИТ-специалист. Понадобится прислать ваше резюме, заполнить анкету. После одобрения кандидатуры второе собеседование с руководителем.

10. Контактные данные для связи:
Email: personal1995@gmail.com
Контактный телефон: (057) 787−10−11 (Лупакова Алла Николаевна)

Отправляете ваши резюме на адрес: personal1995@gmail.com
Просмотров: 61, последний комментарий от drdroid   
как програмно организовать автоматическое заполнение поля многострочной части определенного докумнта [раздел Программирование в 1С Предприятие 7.7]
Автор leo10k10 — 22.03.17, 15:30 — 2 комментариев
Подскажите пожалуйста как в 1С 7.7 правильно организовать следующее действие, к примеру есть Документ «Расходная накладная» в его форме имеется таблица в виде «Многострочной части» которая состоит из 9 полей среди которых есть такие поля как «Температура» «Плотность» «Приведенная Плотность» нужно чтобы поле «Приведенная Плотность» по определённой формуле заполнялось автоматически после заполнения полей «Температура» и «Плотность». Заранее благодарен за конструктивные ответы.
Просмотров: 47, последний комментарий от leo10k10   
Универсальная консоль запросов/отчетов 1С7.7 [раздел 1С:Предприятие 7.7]
Автор nikolay100x — 22.03.17, 14:58 — 0 комментариев
Целью создания данной обработки было дать возможность пользователю самостоятельно получать нужную информацию и при необходимости создавать нужные отчеты, которые не требуют вмешательства программиста (под вмешательством подразумеваю отчеты, которые не нужно писать кодом).
 
Консоль запросов/отчетов.
Консоль, представляет собой простой и наглядный инструмент для получения нужной информации из базы данных 1С7.7 в режиме «пользователя» с последующей ее обработки то ли в виде отчета, то ли в виде анализа в КУБе (типа OLAP). Другими словами, пользователь сам может строить себе необходимые отчеты.
Данный инструмент универсален и работает в любой конфигурации 1С версии 7.7. Но для его полноценной работы необходимы дополнительные библиотеки (FormEX, Йоксель, ReportEX.dll). Данные библиотеки необходимо скопировать в каталог информационной базы.

Что умеет данная консоль:
- Наглядно, с помощью конструктора без проблем строить запросы (функции, условия, группировки, режим вывода результата).
- Возможность изменять написанный запрос/отчет в конструкторе.
- Реализована возможность указывать и передавать любые параметры в запросы.
- Реализована возможность передавать параметром в запрос результат выполнения другого запроса.
- Возможность вывести результат выполнения запроса, как в таблицу значений, так и в «красивую печатную форму» с расшифровкой по всем реквизитам (т.е. из отчета можно открыть любое значение из базы данных, которое фигурировало в запросе, элемент справочника, документ, движения документа по регистрам и т.д.).
- Возможность из результата сформировать отчет с любым количеством группировок и в последующем сворачивать/разворачивать группировки в отчете.
- Реализована возможность вывести результат запроса для последующего анализа в КУБ.
- При выводе результата в КУБ есть возможность в виде конструктора создавать расчетные реквизиты для КУБа, т.е. писать произвольные формулы, по которым будут дополнительно рассчитываться значения в КУБе. Данный механизм реализован с рекурсивным вычислением формул, так что можно использовать формулу в формуле.
- Вывод результатов, отчетов и КУБа в Excel.
- Возможность сохранения всех настроек данной консоли для каждого пользователя.

Работа с консолью.
Главное окно консоли выглядит следующим образом:


Для того чтобы создать запрос необходимо нажать на кнопку «Добавить» и в появившемся окне ввести имя запроса (отчета), после чего нажать на кнопку «Конструктор».


Конструктор выглядит примерно, так же как и в самой платформе 1С7.7 если его вызывать в режиме конфигуратора, но есть небольшие отличия.
На первой «странице» конструктора необходимо указать такие параметры как «Период» (его можно будет указывать самостоятельно, либо выбрать существующие уже варианты), а также указать параметры обработки данных (Проведенные, Не проведенные, Помеченные на удаление и др.) и нажать кнопку «Выбрать метаданные>>».


«Страница» выбора метаданных имеет три поля. Первое отображает в виде дерева все метаданные конфигурации. При двойном щелчке левой кнопкой мыши на нужном нам элементе данный вид метаданного (справочник, документ, регистр) попадает во второе поле «Таблицы». Таким образом, можно выбрать сразу только те виды метаданных, с которыми будем работать, а не искать их постоянно во всем дереве.
В поле «Таблицы» выбранные нами значения так же отображаются в виде дерева и из него тем же двойным щелчком на нужном нам уже реквизите, реквизит попадает в последнее поле «Поля». Если же нужно добавить связь, т.е. один реквизит из одного объекта нужно связать с реквизитом из другого объекта, то нужно нажать на кнопку «Добавить связь». В этом же поле «Поля» можно указать синонимы наших выбранных реквизитов, т.е. поле «Сумма» можно обозвать другим именем, например «СуммаРасход».
После того как с метаданными определились, нажимаем кнопку «Добавить функции».



В появившемся окне, пользователю предоставляется возможность добавить функции, группировки и условия. Функции в зависимости от выбранного объекта отличаются, например, для числовых реквизитов (не из регистров) можно указывать такие предопределенные функции как, Сумма, Среднее, Максимум, Минимум и т.д., для регистров Начальный остаток и т.д. Функции могут быть с условиями, например можно указать, что считать из регистра сумму только тогда когда выполниться определенное условие.
В группировках можно указать, как группировать наши данные, а также можно указать сортировку, т.е. упорядочивание.
В условиях можно добавлять как простые условия типа равно, не равно, больше меньше и т.д., так и писать сложные.

После того как все указали, нажимаем кнопку «Готово», после чего открывается главная страница консоли с сформированным запросом. Далее, если в запросе указаны были параметры (условия) нажимаем кнопку «Получить параметры». Заполняется таблица с параметрами, которые нужно указать для нашего запроса. Данная таблица содержит три колонки: Параметр (отображает имя параметра), Тип (пользователю необходимо указать какой у параметра будет тип, т.е. откуда будет выбираться значение) и Значение (здесь указывается значение для параметра, документ, элемент справочника, перечисление, другой ранее созданный запрос).
После того как все параметры заполнены нажимаем «Сформировать» - выполняется запрос. Если запрос написан неправильно, то система выдаст предупреждение. На форме так же есть информация о времени выполнения запроса/отчета, количестве полученных записей.


Хотелось бы отдельно выделить возможность передавать в запрос параметром – результат выполнения другого запроса. Видно на рисунке выше. В запрос2 в параметр мСпк передан результат выполнения запроса1.
Полученный результат запроса можно вывести как таблицу значений на весь экран, так и в виде простого отчета:




Есть так же возможность вывести результат с группировками, указанными в запросе (любое количество):


Все эти отчеты можно сохранить в Excel.
Для более детального анализа результат можно выгрузить в КУБ. Для этого необходимо нажать на соответствующую кнопку «Вывод результата в КУБ». После чего будет задан вопрос, «Указать дополнительные формулы для КУБа». Если ответ – нет, то выгружается в КУБ просто результат запроса. Если ответить – да, тогда откроется форма «Конструктор формул для КУБа», в котором предоставлена возможность самостоятельно добавить новое поле в КУБ по своей формуле.



В данном конструкторе формул реализован механизм рекурсии, т.е. можно в формуле использовать помимо ресурсов из запроса еще и созданные ранее формулы, другими словами может быть формула в формуле.
При выгрузке результата в КУБ с формулами, так же выполняется проверка на корректность написанных формул, а так же проверяются все формулы на несуществующие ресурсы.



Все настройки, т.е. запросы, формулы для куба по каждому запросу – сохраняются для каждого пользователя отдельно. Для этого необходимо указать каталог для хранения файла с настройками, что дает возможность при следующем запуске обработки продолжить работу со своими ранее написанными запросами/отчетами.


Таким образом, данная консоль может заменить пользователю ряд штатных отчетов, помочь в получении нужной информации, оперативно выявить ошибки в базе данных и т.д.

Цена данной обработки: 1500 грн.
По желанию заказчика могу доработать те или иные моменты.

Обращаться можно в ЛС или писать на nikolay100x@gmail.com
Просмотров: 41, оставить комментарий   
УПП 1.3 Ссылку на форму из которой выбран элемент [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор alexandr_f — 22.03.17, 12:16 — 6 комментариев
Выбираю элемент справочника , Соответвенно владелец Формы Табличное поле. А как получить ссылку на Форму Владельца. Дело в том что там есть еще одно ТП , которе мне нужно
Просмотров: 51, последний комментарий от sava1   
Места хранения склада: учет времени хранения [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 22.03.17, 10:44 — 2 комментариев
Приветствую, форумчане!

"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Задали такую задачку. Понимаю, что в УТ данного функционала нет. Поэтому поделитесь своим мнением и направлением решения.

Имеется некий склад "Главный". Пусть имеется структура мест хранения 1-ого уровня по палетам. П01, П02, П03.....

С другого склада (или поступление) оформляем документ "Перемещение" на склад "Главный".
Вот тут нужно разместить товар по местам хранения П01, П02, П03... (первая проблема)

Теперь приходит время и товар забирается со склада перемещением. Необходимо забрать с определенных П01, П02 и т.д. необходимый товар.

И такая карусель в течение месяца... В конце месяца необходимо вывести отчет о том, сколько времени (по дням) была загружена каждая палета...

Как правильно пойти?


 ! 

Правила: 3
 
Просмотров: 62, последний комментарий от DrLivsi   
СтандартнаяОбработка на булево дополнительного реквизита [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 22.03.17, 8:49 — 5 комментариев
Приветствую, форумчане!

"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

В документе "ЗаказПоставщику" есть дополнительный реквизит "Утверждаю"

Имеется проверка на право разрешения утвердить.
Использую код на изменение

Процедура УтверждаюПриИзменении(Элемент, СтандартнаяОбработка)
....
    Иначе
        СтандартнаяОбработка = Ложь;
        Сообщить("Ваш статус: " + УправлениеДопПравамиПользователей.РазрешитьУтверждение() +
        ". Вы не имеете прав на утверждение как Руководитель");
        
    КонецЕсли;    
КонецПроцедуры


Однако при выполнении на запрет, галочка всё-равно изменяется. Попробовал добавить в параметры Процедуры "СтандартнаяОбработка" и применить ее в режиме "Ложь" - не помогло.

Как в случае запрета на утверждение, не позволять изменять значение реквизита "Утверждаю"?


Просмотров: 88, последний комментарий от candrey   
Программное нажатие на кнопку из командного интерфейса "перейти" [раздел Программирование в 1С Предприятие 8.3]
Автор vlad_ — 21.03.17, 18:01 — 2 комментариев
помогите пожалуйста!! нужно программно нажать на одну из кнопок командного интерфейса "перейти" упр.формы.
к примеру: мы находимся в документе реализация. там есть наша кнопка и нам нужно по нажатию на эту кнопку вызвать событие которое откроет (к примеру мы передаем туда номенклатуру) штрихкод номенклатуры. или же..(см.скрин)

как вообще можно обратиться к стандартным командам закладки "перейти"?

есть приблизительное направление поиска:
НавСсылка = "e1cib/command/ОбщаяКоманда.мояКоманда";
ПерейтиПоНавигационнойСсылке(НавСсылка);

но всё время навссылка не верна..
как именно искать не знаю

Просмотров: 68, последний комментарий от Vofka   
Различие в Заказе покупателя и в чеке [раздел Управление торговлей для Украины редакция 2 (Управление торговлей для России редакция 10)]
Автор s2dentishe — 21.03.17, 17:20 — 3 комментариев
Добрый день!

Подскажите, может ли быть такая ситуация, что Чек продажи (подвязанный к Заказу покупателя)содержит другой товар и другой вид оплаты нежели в Заказе покупателя?
Просмотров: 76, последний комментарий от Petre   
Лампочки к заказам о готовности заказа [раздел Программирование в 1С Предприятие 8.3]
Автор XacTLa — 21.03.17, 10:36 — 6 комментариев
1С:ERP Управление предприятием 2.0 (2.0.9.66) 1С:Предприятие 8.3 (8.3.6.2237).
Добрый день,в заказах клиентов. Вот допустим готов заказ к отгрузке все позиции можно отгрузить со склада, и рядом с заказом загорается лампочка зеленым цветом, или когда не готов заказ он горит красным. Состояние обеспечения не совсем подходит, так как не очень удобная форма. Спасибо за внимание.
Просмотров: 126, последний комментарий от Vofka   
Вывод колонки УКТВЭД на форму счета [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор kot488 — 21.03.17, 10:46 — 4 комментариев
Имеется УТП 1.2.41. На форму списка номенклатуры выводится код УКТВЭД в своей колонке. Такая же колонка добавлена на форму счета фактуры, при добавлении в счет позиции с кодом, код подставлялся в свою колонку. Это все работало на 40 версии. Вчера обновился до 41 и при добавлении номенклатуры в счет показывает:
Цитата
{Документ.СчетНаОплатуПокупателю.МодульОбъекта(1531)}: Поле об`єкту не виявлено (ОтечественныйНеподакцизныйТовар)
Если СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры.ОтечественныйНеподакцизныйТовар = Истина Тогда


Вот этой процедурой добавлялся код на форму счета:

Процедура ЗаполнитьУКТВЭДВСтрокеТоваров(СтрокаТабличнойЧасти) Экспорт
    НоменклатураГТДХарактеристики = СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры.НоменклатураГТД;
    
    Если СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры.ОтечественныйНеподакцизныйТовар = Истина Тогда
        
        СтрокаТабличнойЧасти.КодУКТВЭД = Неопределено;
        СтрокаТабличнойЧасти.НомерГТД = Неопределено;
    ИначеЕсли ЗначениеЗаполнено(НоменклатураГТДХарактеристики) Тогда
        СтрокаТабличнойЧасти.КодУКТВЭД = НоменклатураГТДХарактеристики.КодУКТВЭД;
        СтрокаТабличнойЧасти.НомерГТД  = НоменклатураГТДХарактеристики.НомерГТД;
    Иначе
        СтрокаТабличнойЧасти.КодУКТВЭД = СтрокаТабличнойЧасти.Номенклатура.НоменклатураГТД.КодУКТВЭД;
        СтрокаТабличнойЧасти.НомерГТД  = СтрокаТабличнойЧасти.Номенклатура.НоменклатураГТД.НомерГТД;
    КонецЕсли;
КонецПроцедуры


Вывод кода писал по аналогу с интернета, помогите пожалуйста разобраться что нужно подправить что бы все опять работало


 ! 

Правила: 9
 


Вроде разобрался
Просмотров: 134, последний комментарий от andr_andrey   
Сгруппировать таблицу значений [раздел Программирование в 1С Предприятие 8.3]
Автор Pavlik1c — 21.03.17, 9:36 — 5 комментариев
Здравствуйте!!!
"Управление торговым предприятием для Украины", редакция 1.2.
Разработка конфигурации: "ABBYY Ukraine", 2007-2017 (1.2.41.1) (http://1c.ua/v8/RegionalSolutions_UA_UTP.php)
Copyright © ДП "Еврософтпром", 2007-2017. Все права защищены
(http://www.1c.ua)

Делаю обработку для загрузки Экселя в 1С. В таблицу значений загружаю содержимое файла. Помогите преобразовать ТЗ к желаемому виду как на скриншоте. Группировка идет по "Услуге" и по "Цене"


 ! 

Правила: 8
 
Просмотров: 96, последний комментарий от Petre   
цикл в печатной форме [раздел Программирование в 1С Предприятие 8.3]
Автор dadka — 21.03.17, 7:57 — 2 комментариев
доброго времени суток. имеется конфигурация Общепит
пишу внешнюю печ.форму для документа Выпуск продукции ОП6
и тут затык - не могу понять, что сделал не так в цикле,

Код
Ном = 0;
    
    Шапка = ВыборкаПеремещение.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    
    Пока Шапка.Следующий() Цикл
                                                
        Ном = Ном + 1;                                                    
        ОбластьСтрока.Параметры.Ном = Ном;
        ОбластьСтрока.Параметры.Номенклатура = ВыборкаДетальныеЗаписи.Товар;
        ОбластьСтрока.Параметры.Код = ТоварКод;
        ОбластьСтрока.Параметры.Единица = ТоварЕдИзм;
        ОбластьСтрока.Параметры.КодЕдиницы = ТоварЕдИзмКод;
        ОбластьСтрока.Параметры.ИтогоОтпущено = Количество;
        ОбластьСтрока.Параметры.ЦенаУчетная = Цена;
        ОбластьСтрока.Параметры.СуммаУчетная = Сумма;
        ТабличныйДокумент.Вывести(ОбластьСтрока);
    КонецЦикла;


где Шапка.Следующий() всегда = ЛОЖЬ

подскажите, что делаю не так?

Вот весь код
ВалютаПечати = Константы.ВалютаРегламентированногоУчета.Получить();
    
    
    Макет = РеквизитФормыВЗначение("Объект").ПолучитьМакет("ОП6");
    
    ТабличныйДокумент = Новый ТабличныйДокумент;
    ТабличныйДокумент.АвтоМасштаб            = Истина;
    ТабличныйДокумент.ПолеСверху            = 0;
    ТабличныйДокумент.ПолеСлева                = 0;
    ТабличныйДокумент.ПолеСнизу                = 0;
    ТабличныйДокумент.ПолеСправа            = 0;
    ТабличныйДокумент.ОриентацияСтраницы    = ОриентацияСтраницы.Ландшафт;
    ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ОП6";                            
    
    СисИнфо = Новый СистемнаяИнформация;
    Если ПустаяСтрока(СисИнфо.ИнформацияПрограммыПросмотра) Тогда
        ТабличныйДокумент.ПолеСлева          = 0;
    Иначе
        ТабличныйДокумент.ПолеСлева          = 10;
    КонецЕсли;

          
//    Запрос.УстановитьПараметр("МассивОбъектов", СсылкаНаОбъект);
//    Запрос.УстановитьПараметр("ДатаДок", СсылкаНаОбъект.Дата);
//    Запрос.УстановитьПараметр("ДополнительнаяКолонкаПечатныхФормДокументов", Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить());
    
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ОбщепитВыпускПродукции.Ссылка КАК ВыпускПродукции,
        |    ПеремещениеТоваров.Ссылка КАК Перемещение,
        |    ПеремещениеТоваров.СкладОтправитель,
        |    ПеремещениеТоваров.СкладПолучатель
        |ПОМЕСТИТЬ втДокументы
        |ИЗ
        |    Документ.ОбщепитВыпускПродукции КАК ОбщепитВыпускПродукции
        |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПеремещениеТоваров КАК ПеремещениеТоваров
        |        ПО ОбщепитВыпускПродукции.Ссылка = ПеремещениеТоваров.ДокументОснование
        |ГДЕ
        |    ОбщепитВыпускПродукции.Ссылка В(&МассивОбъектов)
        |    И ОбщепитВыпускПродукции.ВидОперации = ЗНАЧЕНИЕ(Перечисление.ОбщепитВидыОперацийВыпускПродукции.ВыпускПродукции)
        |
        |ОБЪЕДИНИТЬ ВСЕ
        |
        |ВЫБРАТЬ
        |    ОбщепитВыпускПродукции.Ссылка,
        |    ОбщепитВыпускПродукции.Ссылка,
        |    ОбщепитВыпускПродукции.Склад,
        |    ОбщепитВыпускПродукции.СкладПолучатель
        |ИЗ
        |    Документ.ОбщепитВыпускПродукции КАК ОбщепитВыпускПродукции
        |ГДЕ
        |    ОбщепитВыпускПродукции.Ссылка В(&МассивОбъектов)
        |    И ОбщепитВыпускПродукции.ВидОперации = ЗНАЧЕНИЕ(Перечисление.ОбщепитВидыОперацийВыпускПродукции.ВыпускПродукцииСперемещением)
        |;
        |
        |////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
        |    втДокументы.ВыпускПродукции,
        |    втДокументы.Перемещение,
        |    втДокументы.СкладПолучатель,
        |    втДокументы.СкладОтправитель,
        |    ХозрасчетныйОбороты.Субконто1.Код КАК ТоварКод,
        |    ХозрасчетныйОбороты.Субконто1 КАК Товар,
        |    ХозрасчетныйОбороты.Субконто1.ЕдиницаИзмерения КАК ТоварЕдИзм,
        |    ХозрасчетныйОбороты.Субконто1.ЕдиницаИзмерения.Код КАК ТоварЕдИзмКод,
        |    ХозрасчетныйОбороты.СуммаОборотДт КАК Сумма,
        |    ХозрасчетныйОбороты.КоличествоОборотДт КАК Количество
        |ПОМЕСТИТЬ втРезультат
        |ИЗ
        |    втДокументы КАК втДокументы
        |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрБухгалтерии.Хозрасчетный.Обороты(
        |                &ДатаДок,
        |                ,
        |                Запись,
        |                Счет В ИЕРАРХИИ (ЗНАЧЕНИЕ(ПланСчетов.Хозрасчетный.ГотоваяПродукция))
        |                    ИЛИ Счет В ИЕРАРХИИ (ЗНАЧЕНИЕ(ПланСчетов.Хозрасчетный.Товары)),
        |                ,
        |                ,
        |                ,
        |                ) КАК ХозрасчетныйОбороты
        |        ПО втДокументы.СкладПолучатель = ХозрасчетныйОбороты.Субконто2
        |            И втДокументы.Перемещение = ХозрасчетныйОбороты.Регистратор
        |ГДЕ
        |    ХозрасчетныйОбороты.Регистратор В
        |            (ВЫБРАТЬ
        |                втДокументы.Перемещение
        |            ИЗ
        |                втДокументы КАК втДокументы)
        |;
        |
        |////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
        |    втРезультат.Перемещение КАК Перемещение,
        |    втРезультат.СкладПолучатель,
        |    втРезультат.СкладОтправитель,
        |    втРезультат.ТоварЕдИзм,
        |    втРезультат.Товар,
        |    втРезультат.ТоварЕдИзмКод,
        |    втРезультат.ТоварКод,
        |    втРезультат.Сумма,
        |    втРезультат.Количество,
        |    втРезультат.Сумма / втРезультат.Количество КАК Цена
        |ИЗ
        |    втРезультат КАК втРезультат
        |ИТОГИ ПО
        |    Перемещение";
    
        
    Запрос.УстановитьПараметр("МассивОбъектов", СсылкаНаОбъект);
    Запрос.УстановитьПараметр("ДатаДок", СсылкаНаОбъект.Дата);
        
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаПеремещение = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    
    Пока ВыборкаПеремещение.Следующий() Цикл
        
        Перемещение = ВыборкаПеремещение.Перемещение;
    
        ВыборкаДетальныеЗаписи = ВыборкаПеремещение.Выбрать();
    
        Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            
            СкладПолучатель = ВыборкаДетальныеЗаписи.СкладПолучатель;
            СкладОтправитель = ВыборкаДетальныеЗаписи.СкладОтправитель;
            ТоварЕдИзм = ВыборкаДетальныеЗаписи.ТоварЕдИзм;
            Товар = ВыборкаДетальныеЗаписи.Товар;
            ТоварЕдИзмКод = ВыборкаДетальныеЗаписи.ТоварЕдИзмКод;
            ТоварКод = ВыборкаДетальныеЗаписи.ТоварКод;
            Сумма = ВыборкаДетальныеЗаписи.Сумма;
            Количество = ВыборкаДетальныеЗаписи.Количество;
            Цена = ВыборкаДетальныеЗаписи.Цена;
            
        КонецЦикла;
    КонецЦикла;
    
        
    
    ОбластьЗаголовокТаблицы = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
    СведенияОбОрганизации = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(СсылкаНаОбъект.Организация, СсылкаНаОбъект.Дата);
    ОбластьЗаголовокТаблицы.Параметры.ПредставлениеОрганизации = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОбОрганизации);
    ОбластьЗаголовокТаблицы.Параметры.СкладОтправитель = СкладОтправитель;
    ОбластьЗаголовокТаблицы.Параметры.СкладПолучатель = СкладПолучатель;
    ОбластьЗаголовокТаблицы.Параметры.КодПоОКПО = СведенияОбОрганизации.КодПоОКПО;
    ОбластьЗаголовокТаблицы.Параметры.НомерДок = СсылкаНаОбъект.Номер;
    ОбластьЗаголовокТаблицы.Параметры.ДатаДок = Формат(СсылкаНаОбъект.Дата, "ДФ=dd.MM.yyyy");
    ОбластьЗаголовокТаблицы.Параметры.Должность = "Руководитель службы питания";
    ОбластьЗаголовокТаблицы.Параметры.Руководитель = "Мостовой Ю.А.";
    ОбластьЗаголовокТаблицы.Параметры.Бухгалтер = "Шайда Л.А.";
    ТабличныйДокумент.Вывести(ОбластьЗаголовокТаблицы);
    
    ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
    ТабличныйДокумент.Вывести(ОбластьШапкаТаблицы);
    
    ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
    
    Ном = 0;
    
    Шапка = ВыборкаПеремещение.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    
    Пока Шапка.Следующий() Цикл
                                                
        Ном = Ном + 1;                                                    
        ОбластьСтрока.Параметры.Ном = Ном;
        ОбластьСтрока.Параметры.Номенклатура = ВыборкаДетальныеЗаписи.Товар;
        ОбластьСтрока.Параметры.Код = ТоварКод;
        ОбластьСтрока.Параметры.Единица = ТоварЕдИзм;
        ОбластьСтрока.Параметры.КодЕдиницы = ТоварЕдИзмКод;
        ОбластьСтрока.Параметры.ИтогоОтпущено = Количество;
        ОбластьСтрока.Параметры.ЦенаУчетная = Цена;
        ОбластьСтрока.Параметры.СуммаУчетная = Сумма;
        ТабличныйДокумент.Вывести(ОбластьСтрока);
    КонецЦикла;
    
    Возврат ТабличныйДокумент;



 ! 

Правила: №9. Есть специальный тег для публикации кода.
 
Просмотров: 96, последний комментарий от Vofka   
Отчет по отработанным часам/начисленной ЗП [раздел 1С Зарплата и Управление Персоналом 8]
Автор Натали Шелл — 20.03.17, 18:47 — 2 комментариев
Добрый день всем участникам форума.
5 лет работала в 1С 7, теперь перешла на 1С 8 ЗуП "Зарплата и Управление Персоналом для Украины", редакция 2.1.
Зарплату я начислила и выплатила.

Но финдир требует такой отчет:

Сотрудник-Отработанные часы-Выплаченная зарплата

ФИО ЧАСЫ ЗП
Иванов 180 5000

Не могу понять как мне его сделать, уже всевозможные варианты подбора пробовала-не получается.И с расчетной ведомостью игралась, и со сводом начисленной зп...
Очень прошу помощи в этом вопросе!
Заранее спасибо!


 ! 

Правила: 4,5
 
Просмотров: 101, последний комментарий от Натали Шелл   
Импортный товар или нет (для загрузки в Медок)? [раздел 1С Управление Торговым Предприятием 8]
Автор vbi — 20.03.17, 17:49 — 1 комментариев
УТП для Украины версия 1.2.41.1 от 14.03.2107. Вроде для моей задачи актуальная.
Вот пытаюсь разобратся с выгрузкой налоговой в XML для последующей загрузки в Медок. Все хорошо работает и загружается, НО! Для налоговой важно какой товар импортный а какой нет. У меня в выгрузке идет весь товар как НЕ импортный, но на самом деле часть импортная а часть нет.
Так вот, нигде не могу найти признак "импортности" товара. Вряд ли это должна быть птичка в номенклатуре, так как один и тот же товар может быть импортирован а может и нет. Наверное все углубляется в партии, но где в партиях этот признак? Проверял птичку "Не резидент" у контрагента-поставщика, так эта птичка не фигурирует в регламентированной отчетности 2017 года.

Может кто подскажет как один товар сделать импортным для ГНАУ а другой нет? Или подскажет куда копать...
Просмотров: 126, последний комментарий от logist   
Отображение остатка по товару в чеке ККМ "на лету" [раздел Программирование в 1С Предприятие 8.3]
Автор bobr_dobr — 20.03.17, 15:46 — 7 комментариев
Доброго дня, вопрос по платформе 8.3.5.1443 управляемые формы, конфигурация Управление небольшой фирмой для Украины, редакция 1.4.
Возникла необходимость сделать так, чтобы кассир видел остатки по номенклатуре на форме чека ККМ во время ее добавления (т.е. вместе с единицей измерения и ценой, которые заполняются из события ПриИзменении), потому что его не устраивает, когда он наполняет чек несколькими наименованиями, а потом чек не проводится, если есть нехватка на складе.
Контроль отрицательных остатков отключать не хотят.
В модуль формы документа событие ПриИзменении добавил

СтрокаТабличнойЧасти.Остаток =ОбщегоНазначения.РассчитатьОстаток(Объект.Организация,СтрокаТабличнойЧасти.Номенклатура,Объект.Дата);


в ОбщегоНазначенияКлиентСервер

&НаСервере

Функция РассчитатьОстаток(Организация,Номенклатура,Дата) Экспорт
    Запрос = Новый Запрос(
    "ВЫБРАТЬ
    |    ЗапасыОстатки.Организация,
    |    ЗапасыОстатки.Номенклатура,
    |    ЗапасыОстатки.КоличествоОстаток КАК Остаток
    |ИЗ
    |    РегистрНакопления.Запасы.Остатки(&МоментВремени, ) КАК ЗапасыОстатки
    |ГДЕ
    |    ЗапасыОстатки.Номенклатура = &Номенклатура
    |    И ЗапасыОстатки.Организация = &Организация"
    );
    Запрос.УстановитьПараметр("МоментВремени", Дата);
     Запрос.УстановитьПараметр("Номенклатура", Номенклатура);
     Запрос.УстановитьПараметр("Организация", Организация);
    Результат = Запрос.Выполнить();
    а = Результат.Выгрузить();  
  
   КонецФункции


Отладку запускаю в толстом клиенте, но в результате запроса в табло не цифры, а то, что на скрине.

В консоли запросов все нормально, получаю остаток и остальные данные запроса.
Просьба подсказать, что не так сделал, ибо давно уже не ковырял конфигурации, тем более управляемые формы. А может вообще эта реализация кривая и есть более гуманные способы upset.gif
Просмотров: 132, последний комментарий от bobr_dobr   
Сбилась нумерация НН [раздел Бухгалтерия 8, редакция 1 для Украины]
Автор bagrin_1958 — 20.03.17, 14:32 — 2 комментариев
Здравствуйте! Установлено - 1С:Предприятие 8.3 (8.3.9.1850), Бухгалтерия для Украины, редакция 1.2. (1.2.40.2)
В октябре 2016 нумерация НН шла Ок000000000000008 с начала месяца - до 28-го числа. 28-го откуда прилепилось 0Ок00000000000001. И вот этот 0 впереди префикса путешествует до сегодняшнего дня. То есть выглядит так : 0Но00000000000001, 0Дк00000000000001 ну и дальше соответственно! Помогите пожалуйста!
Просмотров: 105, последний комментарий от bagrin_1958   
Лицензия 1С: сколько денег орстается в Украине, а сколько уходит в Россию? [раздел Офф-топик]
Автор Мичман Харитонов — 20.03.17, 12:21 — 5 комментариев
Доброго дня!
Всерьез задумался вот над чем: 1С у нас вроде как продукт оккупанта, геть и долой. Ну, это понятно.
Но вот реально - сколько денег с купленной лицензии остается в Украине, а сколько - уходит за границу?
В гривнях, в процентах, неважно.
Чисто финансово для нас - больше вреда или пользы?
Если кто-нибудь из форумчан в курсе, буду благодарен за ликбез по сабжу.
Просмотров: 173, последний комментарий от XBrut   
RSS Текстовая версия Сейчас: 23.03.17, 4:05
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне