Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Переход с средневзвешеной на FIFO, 1С Управление Торговым Предприятием 8.*
Автор audit7buh — 25.07.16, 10:50 — 6 комментариев
Уважаемые ГУРУ!
Подскажите, как коректно перейти с 01.01.2016г. со средневзвешеной на ФИФО,
2-й клас только товары задействованы
Просмотров: 109, последний комментарий от audit7buh | Просмотр полной темы | Просмотр раздела "1С Управление Торговым Предприятием 8.*"   
Видео-уроки Обучение по программе 1С Управление торговым предприятием, Обучающее видео
Автор psi-x — 23.07.16, 17:40 — 0 комментариев
[необходимо зарегистрироваться для просмотра ссылки]
Просмотров: 68, оставить комментарий | Просмотр полной темы | Просмотр раздела "Обучающее видео"   
Список корректных проводок, Бухгалтерский учет, налоги, последние изменения законодательства
Автор RedCat77 — 22.07.16, 15:32 — 0 комментариев
Всем добрый день.
Ищу список корректных корреспонденций счетов (корректных проводок) для настройки в бух учете.
Стандартное заполнение заливает все и вся в регистр (конфа Бух для Украины)
Заранее СПС

 ! 

Правила: 3,5
 
Просмотров: 121, оставить комментарий | Просмотр полной темы | Просмотр раздела "Бухгалтерский учет, налоги, последние изменения законодательства"   
Считыванте шк в накладных, 1С Управление небольшой фирмой для Украины
Автор BrainIsDead — 22.07.16, 15:19 — 2 комментариев
Здравствуйте, собственно вопрос звучит точно так же как и описание темы. Как сделать так что бы шк считывался в документе только 1 раз и при повторном сканировании 1с выдавалО соответствующую ошибку
Просмотров: 153, последний комментарий от BrainIsDead | Просмотр полной темы | Просмотр раздела "1С Управление небольшой фирмой для Украины"   
Найти договор из содержания платежа (импорт банк.выписок), 1С Предприятие 7.7
Автор Redneck — 22.07.16, 10:59 — 2 комментариев
Добрый день!

Я тут немного занялся автоматизацией импорта банковских выписок в 1С (1С:Предприятие 7.70.027, конфа - БухУч для Украины 7.70.318).
В общем, обработку-переходничок для своего банка дописал (немного нестандартный формат данных был).
Немного повозился с ClientBank.ert и всё заработало.
Контрагенты подтягиваются, а если нет в базе, создаются. Проводки в 97% случаев верные получаются на выходе.

И, вроде бы, все отлично, но я слишком ленив, чтобы к каждой строчке выписки в графе "Заказ" выбирать нужный договор из списка. 64000000.gif

Так что начал парсер внутри ClientBank.ert...
Большинство договоров имеют номер документа типа ***/СД, от этого и оттолкнулся для начала.
Вот код (первый вариант):

            //ОТБОР ЗАКАЗОВ - ПАРСЕР    
            ВхСтр = тВыписка.Содержание;                
            // проверяем, не вписал ли бухгалтер английскую буковку "С";-)
            Если Найти(Врег(ВхСтр),Врег("/СД"))>0 Тогда              
                СодержНачСимвДог=Найти(Врег(ВхСтр),Врег("/СД"))
            Иначе
                СодержНачСимвДог=Найти(Врег(ВхСтр),Врег("/CД"))
            КонецЕсли;    
            
            Сообщить("");                  
            Сообщить(ВхСтр);
               Если СодержНачСимвДог = 0 Тогда
                   СодержДог= "";
                   Сообщить("Увы, договор в содержании платежа не найден. Хотя, может, его там и нет просто");
               Иначе
                   СодержДог = СокрЛП(СтрЗаменить(Сред(ВхСтр,СодержНачСимвДог-3,6),"№",""));    
                   Сообщить("ЕСТЬ! Найден договор: "+СодержДог);
               КонецЕсли;                                      
               
               ВхСтр=СтрЗаменить(ВхСтр," ",РазделительСтрок);
                Для пц=1 По СтрКоличествоСтрок(ВхСтр) Цикл
                    ТекСтр=СтрПолучитьСтроку(ВхСтр,пц);
                    ТекДата=Дата(ТекСтр);
                    Если (ПустоеЗначение(ТекДата)<>1) Тогда
                        Сообщить("Нашли дату: "+ТекДата);  
                            
                        СодержДатаДог=ТекДата;
                        ДокЗкз = СоздатьОбъект("Документ.Договор");
                            Если (ДокЗкз.НайтиПоНомеру(СодержДог,СодержДатаДог) = 1)  Тогда      
                                Сообщить(ДокЗкз.ПолучитьАтрибут("Контрагент"));
                                Сообщить(тВыписка.Контрагент);
                                    Если  СокрЛП(ДокЗкз.ПолучитьАтрибут("Контрагент")) = СокрЛП(тВыписка.Контрагент) Тогда
                                        Док.Заказ = ДокЗкз.ТекущийДокумент();      
                                        сообщить(Док.Заказ);
                                    КонецЕсли;
                            КонецЕсли;
                    
                    КонецЕсли;
                КонецЦикла;  
            //ОТБОР ЗАКАЗОВ - ПАРСЕР


В целом, работает, но количество успешных подхватов едва превышает 60% (тестил на базе выписок за полгода).
Хочется довести до 90% хотя бы...

Но мешают мне следующие проблемы:
1) бухгалтера-"слэшеры", которые любят вводить даты странными способами:
"22/12/2015", "22122015", "22,12,15" и т.п. // тут еще ладно (можно прописать проверку на наличие двух вхождений слэша(запяты) и замянять их на точки перед функцией Дата().
2) бухгалтера-"пробельщики", которые суют свои пробелы куда не попадя:
в в даты "01 .10. 2015", и в номера договоров... //как с этими бороться, ума не приложу - мой парсер основан весь на процедуре с разбивкой строки по пробелам и дальнейшему анализу подстрок. Так каша получается полная
3) бухгалтера-"копипастеры", которые вписывают в назначение платежа старые договора
//тут скорее уже проблема не в процедуре импорта, пожалуй, но все равно раздражает
4) все-таки, хоть большинство договоров и имеют типовой формат, но хотелось бы универсальности.

В общем, я хочу как-то доработать алгоритм, чтобы не тыкать никуда мышкой лишний раз 64000000.gif
Но познаний синтаксиса 1С, особенно для работы со строками у меня явно не хватает. Нужна Ваша помощь.

Сегодня с утра появилась идея, но не могу пока оценить, выполнимо ли это в принципе.
Что будет, если завернуть алгоритм в обратную сторону:

Пример назначения платежа:
Сплата за газовий конденсат згiдно дог.№2 22/СД вiд 15.1 1.15р. ПДВ 134166,67 грн.
1) Убираем все пробелы:
Сплатазагазовийконденсатзгiднодог.№222/СДвiд15.11.15р.ПДВ134166,67грн.
2) Формируем список всех договоров по Контрагенту (он уже известен на этом этапе)
3) Циклом проверяем наличии НомерДог и ДатаДог в беспробельном назначении платежа для каждого договора.
4) Если оба нашлись, то устанавливаем заказ, иначе: Сообщить("Облом... ;(");

Вопросы:
1) Так может получиться?
2) Как правильно реализовать перебор договоров по отдельному контрагенту циклом, чтобы минимально нагружать систему?
3) Может, я велосипед изобретаю? Ни у кого нет подходящих кусков кода?

Буду крайне благодарен за любой совет, кусок кода или хоть намек!
Просмотров: 128, последний комментарий от andrey.v.m | Просмотр полной темы | Просмотр раздела "1С Предприятие 7.7"   
Отчет по труду 1-ПВ, 1С Управление Торговым Предприятием 8.*
Автор bodic — 22.07.16, 9:21 — 4 комментариев
Здравствуйте ! Вопрос по 1с 8.3 УТП 1.2.37.1. Кнопка "Заполнить" в поле "Фонд оплати праці усіх працівників..." за месяц проставляет сумму которая не совпадает (меньше) с суммой оборотов по кредиту счета 661. Никто на знает какие суммы автозаполнение не включает в фонд оплаты труда или почему может быть расхождение?
Просмотров: 142, последний комментарий от Oxana747 | Просмотр полной темы | Просмотр раздела "1С Управление Торговым Предприятием 8.*"   
Ошибка Поле объекта не обнаружено, 1С 8.2 Обычный интерфейс
Автор MOTOPARTNER — 21.07.16, 22:48 — 6 комментариев
{Обработка.РМ.Форма.ФормаРМ.Форма(2523)}: Поле объекта не обнаружено (НоваяПочта)
    Если (ДанныеСтроки.СпособДоставки = Справочники.КлассификаторСпособовДоставки.НоваяПочта


Вот код в конфигурации что не так? и что доделать нужно?

Процедура РегистрПосылокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
    Если НЕ ЗначениеЗаполнено(ДанныеСтроки.Мест) Тогда
        ОформлениеСтроки.Ячейки.Мест.ЦветФона = WEBЦвета.Розовый;
    КонецЕсли;
    
    Если (ДанныеСтроки.СпособДоставки = Справочники.КлассификаторСпособовДоставки.НоваяПочта
           ИЛИ ДанныеСтроки.СпособДоставки = Справочники.КлассификаторСпособовДоставки.Автолюкс) И НЕ ЗначениеЗаполнено(ДанныеСтроки.Вес) Тогда
        ОформлениеСтроки.Ячейки.Вес.ЦветФона = WEBЦвета.Розовый;
    КонецЕсли;
    
    Попытка
        Если НЕ ЗначениеЗаполнено(ДанныеСтроки.Контроль) Тогда
            ОформлениеСтроки.Ячейки.Контроль.ЦветФона = WEBЦвета.Розовый;        
        КонецЕсли;
    Исключение
    КонецПопытки;    
    
    Если ДанныеСтроки.Отгрузка = Перечисления.WMS_СтатусыПосылок.Ожидание Тогда      //Нельзя отправлять
        ОформлениеСтроки.Ячейки.Отгрузка.Картинка = БиблиотекаКартинок.УтвердитьНеПолностью;
        ОформлениеСтроки.Ячейки.Отгрузка.ОтображатьКартинку = Истина;
        ОформлениеСтроки.Ячейки.Отгрузка.Выравнивание = ГоризонтальноеПоложение.Центр;
        ОформлениеСтроки.Ячейки.Отгрузка.ОтображатьТекст = Ложь;
    ИначеЕсли ДанныеСтроки.Отгрузка = Перечисления.WMS_СтатусыПосылок.Разрешено Тогда //Можно отправлять
        ОформлениеСтроки.Ячейки.Отгрузка.Картинка = БиблиотекаКартинок.Утвердить;
        ОформлениеСтроки.Ячейки.Отгрузка.ОтображатьКартинку = Истина;
        ОформлениеСтроки.Ячейки.Отгрузка.Выравнивание = ГоризонтальноеПоложение.Центр;
        ОформлениеСтроки.Ячейки.Отгрузка.ОтображатьТекст = Ложь;
    ИначеЕсли ДанныеСтроки.Отгрузка = Перечисления.WMS_СтатусыПосылок.Пауза Тогда //Pause    
        ОформлениеСтроки.Ячейки.Отгрузка.Картинка = БиблиотекаКартинок.Отклонить;
        ОформлениеСтроки.Ячейки.Отгрузка.ОтображатьКартинку = Истина;
        ОформлениеСтроки.Ячейки.Отгрузка.Выравнивание = ГоризонтальноеПоложение.Центр;
        ОформлениеСтроки.Ячейки.Отгрузка.ОтображатьТекст = Ложь;
    ИначеЕсли ДанныеСтроки.Отгрузка = Перечисления.WMS_СтатусыПосылок.Отменено Тогда
        ОформлениеСтроки.Ячейки.Отгрузка.Картинка = БиблиотекаКартинок.offline;
        ОформлениеСтроки.Ячейки.Отгрузка.ОтображатьКартинку = Истина;
        ОформлениеСтроки.Ячейки.Отгрузка.Выравнивание = ГоризонтальноеПоложение.Центр;
        ОформлениеСтроки.Ячейки.Отгрузка.ОтображатьТекст = Ложь;
    ИначеЕсли ДанныеСтроки.Отгрузка = Перечисления.WMS_СтатусыПосылок.Отправлено Тогда //Отправили     
        ОформлениеСтроки.Ячейки.Отгрузка.Картинка = БиблиотекаКартинок.Logistic;
        ОформлениеСтроки.Ячейки.Отгрузка.ОтображатьКартинку = Истина;
        ОформлениеСтроки.Ячейки.Отгрузка.Выравнивание = ГоризонтальноеПоложение.Центр;
        ОформлениеСтроки.Ячейки.Отгрузка.ОтображатьТекст = Ложь;
    ИначеЕсли ДанныеСтроки.Отгрузка = Перечисления.WMS_СтатусыПосылок.Доставлено Тогда //Доставлено     
        ОформлениеСтроки.Ячейки.Отгрузка.Картинка = БиблиотекаКартинок.online;
        ОформлениеСтроки.Ячейки.Отгрузка.ОтображатьКартинку = Истина;
        ОформлениеСтроки.Ячейки.Отгрузка.Выравнивание = ГоризонтальноеПоложение.Центр;
        ОформлениеСтроки.Ячейки.Отгрузка.ОтображатьТекст = Ложь;
    ИначеЕсли ДанныеСтроки.Отгрузка = Перечисления.WMS_СтатусыПосылок.Консолидация Тогда //Консолидация     
        ОформлениеСтроки.Ячейки.Отгрузка.Картинка = БиблиотекаКартинок.ВходящееСобытие;
        ОформлениеСтроки.Ячейки.Отгрузка.ОтображатьКартинку = Истина;
        ОформлениеСтроки.Ячейки.Отгрузка.Выравнивание = ГоризонтальноеПоложение.Центр;
        ОформлениеСтроки.Ячейки.Отгрузка.ОтображатьТекст = Ложь;
    КонецЕсли;
    
КонецПроцедуры


 ! 

Правила: 3,4
 
Просмотров: 162, последний комментарий от logist | Просмотр полной темы | Просмотр раздела "1С 8.2 Обычный интерфейс"   
Изменение количества знаков в документе., 1С:Предприятие 8.3
Автор pqvv — 21.07.16, 13:22 — 2 комментариев
Здравствуйте ! Вопрос касается 1с УПП 8.3. На предприятии в количестве - 4 знака после запятой. В документе "Перемещение товаров" - выставлено 4 знака после запятой, в регистре "Партии товаров на складах" (БП и УПП) - выставлено 4 знака после запятой. Всё равно при проведении документа по регистру - есть округление. В частности, 0,0198 округляется до 0,0200. В отчете "Ведомость по партиям товаров на складах" тоже округленная цифра. По остальным регистрам - правильно. Подскажите, пожалуйста, куда копать ?
Просмотров: 116, последний комментарий от pqvv | Просмотр полной темы | Просмотр раздела "1С:Предприятие 8.3"   
ФОП, какая конфигурация?, Помогите подобрать конфигурацию
Автор senia — 21.07.16, 12:53 — 11 комментариев

У меня стоит 1с 8.2 бухгалтерия для Украины, теперь у меня появился ФОП и я хочу поставить конфигурацию "управление небольшой фирмой" Теперь вопрос: как это сделать, т.е. это устанавливается все отдельно или как? и стоит ли? или поставить что-то другое? Подскажите пожалуйста
Просмотров: 181, последний комментарий от senia | Просмотр полной темы | Просмотр раздела "Помогите подобрать конфигурацию"   
Подбор документов в табличную часть обработки, 1С:Предприятие 8.3
Автор Sergowa — 21.07.16, 9:23 — 2 комментариев
Добрый день все. Суть задачи вот в чем.
Есть обработка с табличной частью, куда добавляются документы реализации.
Нужно сделать кнопочку подбор, чтобы можно было выбрать сразу несколько документов и поместить их в табличную часть обработки.
Кнопку я создал, открываю форму списка реализации, а как переместить не знаю.
Может кто нибудь сталкивался с таким?? Заранее спасибо!
Просмотров: 88, последний комментарий от Sergowa | Просмотр полной темы | Просмотр раздела "1С:Предприятие 8.3"   
Обмен данными УТ 10.3 - БП 2.0: настройка обмена, Управление торговлей для Украины редакция 2 (10.х для России)
Автор Constantus — 20.07.16, 13:28 — 0 комментариев
Приветствую, Форумчане!

УТ 10.3, 1с8.2, обычный
БП 2.0, 1с8.2, обычный

БП 2.0 сделана под стандарты Туркменистана, свой план счетов. БП полностью настроена и работоспособная под законодательство Туркменистана.

Сейчас пытаюсь настроить обмен данными между УТ и БП. Перечитал многое. Вроде догадался как сделать. Можно и встроенными инструментами, можно создать свои правила обмена в КД...

Но возникает следующие опасения. Предположим, я внес поступление товара, назначил новые цены и произвел продажу в УТ. если я эти операции произвожу в БП, то благодаря настройкам все операции каким-то образом регистрируются в БП и разносятся по правильным бухгалтерским счетам.

Так вот, если я сделаю все эти операции в УТ и перенесу эти данные в БП через ПланыОбмена и ПравиламОбмена. после переноса все операции разнесутся по счетам БУ с учетом настроек работоспособной БП для Туркменистана или мне нужно будет как-то самому что-то делать, чтобы все эти операции в УТ после переноса легли правильно по настроенным счетам???

Насколько я понимаю, УТ не использует никакие планы счетов БУ, а ведет только управленческий учет. Правильно ли моё "умозаключение", что в случае соответствия всех реквизитов, соответствия номенклатур, справочников и т.д. в обеих конфигурациях, то после переноса (обмена) данных из УТ, БП сама проведет новые документы и все разбросает по своим счтеам БУ?

Или таки нужно будет в Планах Обмена и Правилах что-то допиливать по расброске счетов БУ???

Посоветуйте, кто имел опыт? Я не бухгалтер, даже пока проверить не могу...
Просмотров: 157, оставить комментарий | Просмотр полной темы | Просмотр раздела "Управление торговлей для Украины редакция 2 (10.х для России)"   
Продажники 1С, Специалисты техподдержки, программисты, Предложения работы
Автор anatol_ua — 20.07.16, 12:10 — 1 комментариев
1. Менеджер по продажам 1С, Киев
6000-12000 грн

возраст от 25 до 40 лет;
пол любой;

высшее образование,
опыт работы в продажах,
знание основ бухгалтерского учета и программы 1С: Предприятие 8 на уровне пользователя,
коммуникабельность,
грамотная речь,
хорошая память.

2. Технический специалист по 1С (консультант), Киев
5000-8000 грн
консультирование клиентов по использованию типовых конфигураций 1С в офисе или на территории заказчика
простые обновления
написание несложных настроек

возраст от 25 до 40 лет;
пол любой;

высшее образование,
начальное знание языка 1С (обязательно),
хорошо развитое логическое мышление, желание учиться и брать участие в интересных проектах разного масштаба и разной сложности
опыт подобной работы - приветствуется.

3. Программист 1С, Киев
6000-12000 грн
консультирование клиентов по использованию 1С в офисе или на территории заказчика
обновления
написание настроек
разработка новых конфигураций

возраст от 25 до 40 лет;
пол любой;

высшее образование,
знание языка 1С на уровне эксперта (обязателен сертификат),
хорошо развитое логическое мышление, желание учиться и брать участие в интересных проектах разного масштаба и разной сложности

Остальные подробности - на собеседовании, которое проводят менеджер по персоналу и коммерческий директор.

ООО "Центр Информационных Технологий"
Киев, пер. Лабораторный, 1,
основная деятельность: продажа и сопровождение продуктов 1С и собственных разработок.
[необходимо зарегистрироваться для просмотра ссылки]

Резюме отправлять на адрес vakans_centerit@ukr.net
Просмотров: 169, последний комментарий от Zaval | Просмотр полной темы | Просмотр раздела "Предложения работы"   
Анализ счета по субконто в валюте при сложных проводках, 1С Предприятие 7.7
Автор hornet — 20.07.16, 11:23 — 0 комментариев
Добрый день коллеги.Может кто-то уже сталкивался с подобной проблемой.

Есть ситуация. Учет импорта ведется с помощью сложных проводок(ПУБ). Пример

Дт - Кт 632 сумма 25 000 сумма вал.1000
Дт 201 Кт - сумма 12 500
Дт 201 Кт- сумма 12 500

При формировании анализа счета по субконто журнала-ордера по субконто по 632 счету
в валюте 201 счет вообще не попадает .т.е общие обороты 1000 видны, а расшифровки по счетам нет.
если делаешь тот же отчет в гривне виден 201 счет с оборотом 25 000.

Есть ли способ не уходя от сложных проводок решить данную проблему .

п.с. я понимаю, что может быть сложная проводка с разными счетами, т.е. 1 проводка 201 , вторая 207 т.д.
и тогда возникает вопрос как корректно разбить валютную сумму.

Заранее благодарен за ваши ответы.
Просмотров: 104, оставить комментарий | Просмотр полной темы | Просмотр раздела "1С Предприятие 7.7"   
Отчет Анкетирования, 1С:Предприятие 8.3
Автор burza — 20.07.16, 9:56 — 0 комментариев
Нуждаюсь в вашей помощи! Есть у меня отчет по анкетированию он считает количество ответов на вопрос каждого пользователя а потом делает среднее число и так с 10 вопросами. Мне надо еще дописать чтобы он считал среднее число с общих средних чисел. скрин для наглядности.

третье число после / это среднее. надо сделать третью колонку с общей средней. Вот сам [необходимо зарегистрироваться для просмотра ссылки]
Просмотров: 80, оставить комментарий | Просмотр полной темы | Просмотр раздела "1С:Предприятие 8.3"   
Получить нужный отбор, Система компоновки данных
Автор SerikanP — 19.07.16, 17:16 — 2 комментариев
Понимаю, что писано неправильно 09000000.gif , но суть задачи такова:
Надо выбрать Документы ПеремещенияТовара по которым нет проведенных ПриходныхОрдеров (Ордера могут быть помечены на удаление или непроведенные).
Делается для того что бы автоматически создать Ордера по выбранным Перемещениям.



Выбрать
    
    ВложенныйЗапрос.ДокументПеремещенияСсылка,
    ВложенныйЗапрос.Ссылка1

Из
    (ВЫБРАТЬ
    ПеремещениеТоваров.Ссылка КАК ДокументПеремещенияСсылка,
    NULL КАК Ссылка1
ИЗ
    Документ.ПеремещениеТоваров КАК ПеремещениеТоваров
ГДЕ
    ПеремещениеТоваров.Проведен
    И ПеремещениеТоваров.ВнутреннийЗаказ.Дата МЕЖДУ &ДатаНачала И &ДатаКонца
    
ОБЪЕДИНИТЬ все

ВЫБРАТЬ
    ПриходныйОрдерНаТовары.ДокументПеремещения.Ссылка,
    ПриходныйОрдерНаТовары.Ссылка
ИЗ
    Документ.ПриходныйОрдерНаТовары КАК ПриходныйОрдерНаТовары
ГДЕ
    Не ПриходныйОрдерНаТовары.ПометкаУдаления
    //И Не ПриходныйОрдерНаТовары.ДокументПеремещения.Ссылка ЕСТЬ NULL
    И НЕ ПриходныйОрдерНаТовары.Проведен) КАК ВложенныйЗапрос

Сгруппировать по
    ВложенныйЗапрос.ДокументПеремещенияСсылка,
    ВложенныйЗапрос.Ссылка1


Цитата(SerikanP @ 19.07.16, 17:52) *
Понимаю, что писано неправильно , но суть задачи такова:
Надо выбрать Документы ПеремещенияТовара по которым нет проведенных ПриходныхОрдеров (Ордера могут быть помечены на удаление или непроведенные).
Делается для того что бы автоматически создать Ордера по выбранным Перемещениям.


Ну и конечно Ордеров может не быть вообще пока upset.gif
Просмотров: 152, последний комментарий от SerikanP | Просмотр полной темы | Просмотр раздела "Система компоновки данных"   
При OLE запросе ошибка - Плохой тип переменной, 1С Предприятие 7.7
Автор shkoda — 19.07.16, 16:16 — 4 комментариев
Всем приветы!

Делаю отчёт, и пытаюсь при помощи ОЛЕ в него добавить данные из другой базы. Обе базы самописные но на основе ЗиКа.
Я хочу взять данные по Начислениям ЗП и вот как это выглядит:

БазаОле=СоздатьОбъект("V77S.Application");
...
    ЖурналЗП = БазаОле.CreateObject("ЖурналРасчетов.Зарплата");
    СпрСот = БазаОле.CreateObject("Справочник.Сотрудники");
...
Если СпрСот.НайтиПоКоду(СокрЛП(Сред(ЗначениеГр2.КОД,3))) = 1 Тогда
Сотр = СпрСот.ТекущийЭлемент();
Сообщить(Сотр.Наименование);
ЖурналЗП.ВыбратьЗаписиПоОбъекту(Сотр,НачДата,КонДата);
    Пока ЖурналЗП.ПолучитьЗапись() = 1 Цикл
        Если ЖурналЗП.ВидРасч.ВходитВГруппу(ГруппаРасчетов.ВсеНачисления)=1 Тогда
            ВсегоНачислено = ВсегоНачислено + ЖурналЗП.Результат;
        КонецЕсли;
        Сообщить(ЖурналЗП.Результат);
    КонецЦикла;
КонецЕсли;

ЗПФ1 = ВсегоНачислено;



При выполнении этого "кода"
получается вот такая ошибка

Если ЖурналЗП.ВидРасч.ВходитВГруппу(ГруппаРасчетов.ВсеНачисления)=1 Тогда
....ERT(195)}: Плохой тип переменной

уже по всякому пробовал, и так и эдак, уже неделю парюсь не могу сделать, но начальство уже очень живо интересуется почему отчет всё ещё не готов(((

очень подозреваю, что проблема кроется в
ГруппаРасчетов.ВсеНачисления
судя по всему Оле не видит что там написано, либо не может с этим работать

может кто сталкивался с подобным? как обойти эту проблему или решить другим способом

и ещё - думаю попробовать сделать прямым запросом SQL'ным


п.с. если сделать
ЖурналЗП.ВыбратьЗаписиПоОбъекту(Сотр,НачДата,КонДата);
    Пока ЖурналЗП.ПолучитьЗапись() = 1 Цикл
        Сообщить(ЖурналЗП.Результат);
    КонецЦикла;


то данные за нужный период выводятся, но там помимо начислений есть и другие записи, как их отфильтровать?


Всем спасибо!
Просмотров: 183, последний комментарий от shkoda | Просмотр полной темы | Просмотр раздела "1С Предприятие 7.7"   
Вкладка "Агентские услуги" в документе "Реализация товаров и услуг", Остальные конфигурации 1С 8.*
Автор AlesZ — 19.07.16, 15:20 — 0 комментариев
Подскажите, в какой конфигурации есть вкладка "Агентские услуги" ? копаюсь в 1С Бухгалтерия Проф 8,2 , последнее обновление, нет такого. Здесь нашел что мне надо, пытаюсь сделать подобное [необходимо зарегистрироваться для просмотра ссылки]


 ! 

Правила: 3,5,7
 
Просмотров: 102, оставить комментарий | Просмотр полной темы | Просмотр раздела "Остальные конфигурации 1С 8.*"   
КД: УТ 8.1 - 8.2, Конфигурация "1С:Конвертация данных"
Автор Constantus — 19.07.16, 12:47 — 5 комментариев
Приветствую, Форумчане!

Есть необходимость перегнать данные и вести обмен между УТ 8.1 и 8.2 (10.3, обычное)

С помощью КД 2.1 создали конвертацию и правила обмена. Однако, было замеченао, что КД не учитывает регистры Накоплений, в частности крайне необходим регистр "Товары на складах"... Но КД предуматривает только перенос данных регистров сведений.

Как быть?

Дело в том, что в соответствующх конфигурациях создали планы обмена, в настройках которого указываем правила обмена, созданного в КД 2.1. данные переносятся, но без "Товары на складах"...
Просмотров: 149, последний комментарий от Constantus | Просмотр полной темы | Просмотр раздела "Конфигурация "1С:Конвертация данных""   
Verifone 520: подклчение и настройка, Работа с торговым оборудованием
Автор Constantus — 19.07.16, 12:39 — 0 комментариев
Приветствую, Форумчане!

УТ 10.3, обычное, 1с 8.2

Имеется карточный терминал Verifone 520.

Опыта подключения данного устройства как банковского терминала не имею. Подскажите как настроить данный аппарат к 1с, где получить обработку, что нужно для всего этого.

Может есть ресурс, где можно подробно с картинками подключить его к 1с УТ 10.3?
Просмотров: 116, оставить комментарий | Просмотр полной темы | Просмотр раздела "Работа с торговым оборудованием"   
Арифметическое выражение в запросе, 1С Предприятие 7.7
Автор twilight_dream — 18.07.16, 16:01 — 13 комментариев
Здравствуйте.
Прошу подсказать, что я не так делаю и как написать правильно? Нужно приход поделить на 1.2 в запросе...

...
|Сумма = Регистр.Бонусы.Сумма;
|Функция СуммаПриход = Приход(Сумма);
|Функция БонусДляБП =  Сумма(СуммаПриход/1.2) Когда (Док.ПериодБонусирования=ПериодБонусирования);


В результате имею:
Цитата
Функция БонусДляБП = Сумма(СуммаПриход <<?>> /1.2) Когда (Док.ПериодБонусирования=ПериодБонусирования);
Запрос[19] : Ошибка в выражении 'СуммаПриход'


не могу понять как правильно написать арифметическое выражение...
Просмотров: 336, последний комментарий от Sharzem | Просмотр полной темы | Просмотр раздела "1С Предприятие 7.7"   
RSS Текстовая версия Сейчас: 26.07.16, 8:21
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне