Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Функция СУММАЕСЛИ в 1С 8.2 [раздел Программирование управляемых форм 1С 8.2]
Автор Gigi — 21.07.17, 16:53 — 0 комментариев
Привет всем!
Написал функцию в 1С для гибкого учета данных.
Эту функцию заимствовал из эксель. Потому, что она очень простая и удобная.
Поэтому решил подобное написать и в 1С. для общего модуле.
Вроде все получилось, только одна проблема.... хочу ее сделать симпатичнее чем так грубо и коряво как и получилось. smile.gifsmile.gif
Ибо вообще на этом форуме примечали, что код написанный мной грубоват. И думаю на самом деле. smile.gifsmile.gif
Поэтому прошу помощи. Помочь в доработке.
Что нужно?
Функция имеет три базовых параметров: Столбец суммирования, искомое значение для поиска и и столбец поиска.
Все это решил адаптировать для 1С. Т.е. уже в 1С реквизит суммирования и текст(Объект) поиска и реквизит поиска.
Просто последние два аргумента нужно в не ограниченном количестве.
А я это не знаю как сделать. Потому, что с массивами слабо дружу.
Поэтому данная функция ограничивается только тремя аргументами объекта поиска и реквизита поиска.
А нужно, что бы можно было любое количество указывать, как в Экселе.
Вот сама функция нуждающаяся в доработке:
//Общий модуль с именем на пример: "Fx_Арифм"
Функция СУММАЕСЛИ_Простой(Конфигурат,КонфигуратЭлемент, РеквизитСУММЫ, значение1, Рекывизит1, значение2, Рекывизит2, значение3, Рекывизит3) Экспорт
//=================================================================
Попытка
Запрос = Новый Запрос();
Запрос.Текст = "ВЫБРАТЬ
|"+КонфигуратЭлемент+".Ссылка
|ИЗ
|"+Конфигурат+"."+КонфигуратЭлемент+" КАК "+КонфигуратЭлемент+";";
Исключение    
Возврат "Не корректное указание объекта конфирурации!";    
КонецПопытки;    
//=================================================================    
Выборка = Запрос.Выполнить().Выбрать();    
//=================================================================
знСУММАЕСЛИ=0;
Пока Выборка.Следующий() Цикл
//----------------------------------------------    
знРеквизитаСУММЫ=Выборка.Ссылка[РеквизитСУММЫ];
знРеквизита1=""+Выборка.Ссылка[Рекывизит1];
//----------------------------------------------
Если значение2=Неопределено и Рекывизит2=Неопределено тогда
УсловиеСУММЫ=(знРеквизита1=значение1)
Иначе
знРеквизита2=""+Выборка.Ссылка[Рекывизит2];
УсловиеСУММЫ=(знРеквизита1=значение1 и знРеквизита2=значение2);
КонецЕсли;
Если значение3=Неопределено и Рекывизит3=Неопределено тогда
УсловиеСУММЫ=(знРеквизита1=значение1 и знРеквизита2=значение2)
Иначе
знРеквизита3=""+Выборка.Ссылка[Рекывизит3];
УсловиеСУММЫ=(знРеквизита1=значение1 и знРеквизита2=значение2 и знРеквизита3=значение3);
КонецЕсли;
//----------------------------------------------
Если УсловиеСУММЫ тогда
знСУММАЕСЛИ=знСУММАЕСЛИ+(знРеквизитаСУММЫ*1);
КонецЕсли;
//----------------------------------------------
КонецЦикла;     
//=================================================================    
Возврат знСУММАЕСЛИ;    
КонецФункции

//А это вызов функции с клиента:

&НаКлиенте
Процедура Кнопка_СуммаПоСчетам(Команда)
НачисленоРуб_Итого=Fx_Арифм.СУММАЕСЛИ_Простой("Документ","Счета", "СуммаНачисленоРуб", Объект.Ссылка, "ОбъектСчета", ,, ,);
Предупреждение(НачисленоРуб_Итого);
КонецПроцедуры


Уважаемые СПЕЦИАЛИСТЫ!!!! ТУТ УЖ ТОЧНО НУЖНА ВАША ПОМОЧЬ! smile.gifsmile.gif
Буду признателен!
Просмотров: 54, оставить комментарий   
Задать два формата в шаблоне макета [раздел Программирование управляемых форм 1С 8.2]
Автор Gigi — 21.07.17, 15:20 — 8 комментариев
Всем привет!
Никто не подскажет как решить следующую проблему.
Допустим одна ячейка макета с параметром заполнения шаблон... ну допустим вот эта:
<Счет № [НомерСчета] от [Дата]>

или на пример не шаблон, а просто ячейка с заполнением параметр:
<Дата>

Во втором случае формат даты легко указать по своему усмотрению.
в свойствах выбрать "Формат" и выбрать любой нужный формат.
Но это при заполнении Параметр.
А как поставить нужный формат при заполнении шаблон?
Просто в экселе это не проблема сделать.
Хотелось бы так и в Макете формы.
Т.е. как установить нужный формат в шаблоне. В данном случае для параметра "Дата"
Буду признателен!
Просмотров: 105, последний комментарий от Gigi   
Скидка в Расходной накладной [раздел 1С Управление небольшой фирмой для Украины]
Автор lion-6v — 21.07.17, 14:11 — 1 комментариев
Всем привет! Управление небольшой фирмой для Украины, редакция 1.6 (1.6.1.64)
При создании Расходной накладной в вид цены проставляется скидка автоматически.
Как ее убрать? Подскажите где смотреть.
Приходится удалять каждый раз при создании новой расходной.
Саму скидку удалять не нужно она используется при розничных продажах продавцами. Есть Склад который отгружает товар, и там скидка не нужна.
Просмотров: 47, последний комментарий от Bernet   
Скидка в Расходной накладной [раздел 1С Управление небольшой фирмой для Украины]
Автор lion-6v — 21.07.17, 14:09 — 0 комментариев
Всем привет!
При создании Расходной накладной в вид цены проставляется скидка автоматически.
Как ее убрать? Подскажите где смотреть.
Приходится удалять каждый раз при создании новой расходной.
Саму скидку удалять не нужно она используется при розничных продажах продавцами. Есть Склад который отгружает товар, и там скидка не нужна.
Просмотров: 27, оставить комментарий   
Документ Зарплата к выплате не редактируется (1.2.41.2) [раздел Бухгалтерия 8, редакция 1 для Украины]
Автор Domiurg — 20.07.17, 11:35 — 6 комментариев
Документ открывается как бы в режиме только-просмотр. Ничего нельзя поменять и даже кнопки Ок и Записать недоступны
Бух утверждает, что так стало после обновления на последний релиз
Никто не в курсе?
Просмотров: 120, последний комментарий от Vofka   
Выборка данных [раздел Программирование в 1С Предприятие 8.3]
Автор Direx53 — 20.07.17, 10:41 — 2 комментариев
Добрый день,уважаемые форумчане. Необходимо сделать отбор по колонке "тип"((см. скрин)Динамический Список).Данный отбор например, сделать из поля(например,ТипТест(см. скрин)).Учитывая, что колонка "тип" создается программно(т.е. при помощи запроса(см. скрин.)), при этом "РеестрДокументов.Ссылка" состоит из сылок на документы(см.скрин).


Просмотров: 88, последний комментарий от Direx53   
Проблемы с вводом РКО и счет-фактуры [раздел Управление торговлей для Украины редакция 2 (Управление торговлей для России редакция 10)]
Автор bsv_belovo — 20.07.17, 9:35 — 0 комментариев
1С:Предприятие 8.3 (8.3.10.2466)
"Управление торговлей", редакция 10.3 (10.3.43.1)
Здравствуйте!
В 1С новичок, да еще и недавно перешли с 7.7 на 8.3, пока возникают сложности.
В связи с этим пока два вопроса:
1) Почему при создании РКО по умолчанию создается "Оплата поставщику" и не меняется на "Возврат ден.средств покупателю"? Т.е. в статье движения ден. средств я могу выбрать возврат покупателю, но это ничего не меняет. Я в этом документе не могу выбрать договор контрагента, который по умолчанию записан, как покупатель (руководитель организации). В 7.7 с этим сложностей не возникало. Это всё нужно для того, чтобы руководитель мог забирать свои деньги, некогда вложенные в кассу магазина.
2) Из "Реализация товаров и услуг" не могу создать счет-фактуру, пишет "Счет-фактуру нельзя вводить на основании документа, не отражаемого в бух.учете". В реализации место для галочки БУ не активно, т.е. галочку я поставить не могу.
Просмотров: 87, оставить комментарий   
Анализ использования бумаги для печати первичных документов [раздел Программирование в 1С Предприятие 8.3]
Автор Murano — 20.07.17, 9:03 — 3 комментариев
Доброго времени суток. Я первый раз на форуме и прошу не судить строго. В 1С всего неделю, но хочу побыстрее и главное - качественно разобраться во всём этом. Есть у меня задание: "Отчет должен базироваться на данных документов системы 1С по количеству экземпляров для печати:
- Заказ покупателя - 1 экземпляр;
- Реализация товаров и услуг - 2 экземпляра;
- Перемещение товаров - 2 экземпляра;
- приходный ордер на товары - 1 экземпляр;
- Расходные ордер на товары - 1 экземпляр. "
Я не умею создавать отчеты. Можете мне помочь? Или посоветовать какой-то видео-курс по созданию именно отчетов. Ибо я ничего похожего не нашел. Заранее спасибо!


 ! 

Правила: 4,5
 
Просмотров: 130, последний комментарий от Vofka   
Прочитать данные Хранилища из регистра "СохраненныеНастройки" [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 20.07.17, 6:48 — 12 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

В Моби-С в настройках Агента используется регистр "СохраненныеНастройки", в частности хранятся данные по Контрагентам.

Пользователь - Агент. Наименование настройки : Отбор.Контрагенты, где данные хранятся в ХранилищеЗначений (список Контрагентов)

При открытии формы настроек Агента, вкладка Контрагенты заполняется кодом:

    ТаблСОтбором = ПрочитатьОтбор(Агент,"Контрагенты");
    ЗаполнитьОтборПостроителя(ТаблСОтбором,ПостроительОтчетаКонтрагенты,БланкПостроителяОтчетаКонтрагенты);


Т.е. зная Пользователя (владельца), волшебным образом счтываются данные по Контрагентам и заполняются данные.

У меня стоит задача обратная.

Имеется Контрагент, который хранится в ХранилищеЗначений регистра СохраненныеНастройки. Зная этого Контрагента мне нужно получить Пользователя из этого регистра.

Имеется документ ПКО, в нем есть реквизит "Агент". В документе прописан "Контрагент", зная его нужно заполнить реквизит "Агент" полем выбора, т.к. Контрагенту могут соответствовать несколько Пользователей (владельцев, Агентов) в регистре Сохраненные настройки.

Как можно обратится к ХранилищуЗначений, получить от туда Контрагента и сопоставить его с данными СохраненнойНастройки, как Пользователя (Владельца) и вставить значение Агента в реквизит документа ПКО?


Просмотров: 186, последний комментарий от Bernet   
Отрицательный остаток в Незавершенном производстве [раздел 1С Управление Торговым Предприятием 8]
Автор Bernet — 19.07.17, 10:44 — 2 комментариев
Добрый день.

Вопрос следующего характера: Имеется небольшое производство, пользователи делают документы "Отчеты производства за смену". В Конце месяца документом "Требование-накладная" списываем материалы и документом "Прочие затраты" разносим косвенные затраты на производство. После чего проводим документ "Закрытие месяца" с галочкой корректировки фактической себестоимости. Все было нормально но заметили в прошлом месяце возник минусовый остаток по Незавершенному производству, этот же остаток показывается в Калькуляционной карте. Как возник отрицательный остаток в незавершенном производстве и как его исправить?

Пробовал перепровести последовательно документы:
1) Отчеты производства за смену (каждый день)
2) Требование-накладная (в конце месяца)
3) Прочие затраты (в конце месяца)
4) Закрытие месяца (в конце месяца)

но все равно не помогло, отрицательная сумма так и висит. Подскажите кто знает, как исправить, спасибо smile.gif
Просмотров: 123, последний комментарий от Bernet   
Как настроить создание пользователя в режиме загрузки в 1С 8.2 [раздел Программирование управляемых форм 1С 8.2]
Автор Gigi — 18.07.17, 19:55 — 6 комментариев
Всем привет!
Уважаемые форумчане. Не подскажите как настроить создание пользователя в режиме пользователя.
Что бы создать нового пользователя смог сам пользователь. Без необходимости влезать в конфигуратор, где он не ничего не смыслит.
Возможно ли это вообще?
Если да то как.
Поподробнее пожалуйста.
Буду признателен!

Gigi @ Сегодня, 20:25 * ,
Да .... еще забыл добавить.
Ролей всего два: "Администратор" и "Обычныйпользователь".
Нужно что бы пользователь сам мог создать нового пользователя под роль: "Обычныйпользователь"
Просмотров: 142, последний комментарий от Gigi   
Отчет ЕСВ для ЗиК 77 с выгрузкой в дбф [раздел Отчеты / Обработки]
Автор igmig65 — 18.07.17, 18:27 — 1 комментариев
В архиве 2 файла, собственно сам отчет + прайс для отчетов, чтобы этот отчет появился как новый, не заменяя старый в списке регл.отчетов. в самой базе ЗиК
Нужно распаковать архив в папку с регл.отчетами, типа ExtForms\Rp17q1.grp, что в каталоге базы.
Прикрепленные файлы
Прикрепленный файл  esvd4_r1.zip ( 95,15 килобайт ) Кол-во скачиваний: 3
 
Просмотров: 67, последний комментарий от Vofka   
Работа с Сом объектом [раздел Программирование управляемых форм 1С 8.2]
Автор Filosof — 18.07.17, 10:06 — 9 комментариев
К машине подключены весы через Ком порт. В файловом варианте использую КомОбъект внешней компоненты Mscomm32 данные прекрасно считываются с весопроцессора. Но в клиент серверном варианте проблема. Создана на форме клиентская процедура с таким кодом:
&НаКлиенте
Процедура Брутто(Команда)
Попытка
        Весы = Новый COMОбъект("MSCOMMLib.MSComm");
    Исключение
        Сообщить("Ошибка создания объекта компоненты MSCommLib (Mscomm32.ocx)", СтатусСообщения.Внимание);
        Сообщить(ОписаниеОшибки(), СтатусСообщения.Внимание);
        //Возврат;
    КонецПопытки;
    
    Весы.CommPort = 7;
    Весы.Settings = "9600,N,8,1";
    Весы.InputLen = 0;
    Попытка
        Весы.PortOpen = 1;
    Исключение
        Сообщить("Порт занят другим устройством, отключите его и повторите попытку");
    КонецПопытки;
    
    тЗапросНаВзвешивание = Символ(2) + "AB03" + Символ(3);
    
    Для Н = 1 по 5 Цикл        // попытки если вес не стабилен
        
        
        Весы.Output = тЗапросНаВзвешивание;
        
        Пока Весы.InBufferCount < 12 Цикл
            #Если Клиент Тогда
                ОбработкаПрерыванияПользователя();
            #КонецЕсли
        КонецЦикла;
        
        См = Весы.Input;
        
        Если ПустаяСтрока(См) Тогда
            
            Продолжить;
            
        Иначе
            //Сообщить(См);
            
            См = Сред(СтрЗаменить(См, Лев(тЗапросНаВзвешивание,3), ""), 2);
            См = СтрЗаменить(См, Символ(3), "");
            См = Лев(См, СтрДлина(См)-2);    // последние 2 символа служебные
                        
            ЗнСВесов = Число(См);
            
            Прервать;
            
        КонецЕсли;    
        
    КонецЦикла;
    
    Весы.PortOpen = 0;
    
//Возврат ЗнСВесов;            
    
    
    Объект.Брутто=ЗнСВесов;    
Объект.РучнойВводБрутто=Ложь;
Объект.ДатаПолученияБрутто=ТекущаяДата();
КонецПроцедуры


Но почему то выдает ошибки:
Ошибка создания объекта компоненты MSCommLib (Mscomm32.ocx)
и
{Документ.ПриемкаПродукцииСПолейКФК.Форма.ФормаДокумента.Форма(5)}: Ошибка при вызове конструктора (COMОбъект): -2147221230(0x80040112): Класс не лицензирован для использования


 ! 

Правила: 9
 
Просмотров: 151, последний комментарий от Flexy   
Оборотно-сальдовая ведмость по счету 703 [раздел Бухгалтерия 8, редакция 1 для Украины]
Автор dobruan — 18.07.17, 9:20 — 14 комментариев
Переходит фирма с Бух. 7.7 на 8.3 Бух 1.2.
В 7-ке бухгалтера делали оборотно-сальдовою ведомость по счету 703 для сверки предоставленых услуг.
В 8-ке 703 счет имеет не те субконто. Можна ли штатными очетами получить инфорацию аналогичную ОСВ в 7-ке или нужно писать внешний отчет?
Просмотров: 192, последний комментарий от dobruan   
Код обозначения текущего объекта в модуле объекта [раздел Программирование управляемых форм 1С 8.2]
Автор Gigi — 17.07.17, 13:32 — 4 комментариев
Всем привет!
С этим вопросом может и не было бы необходимости выходить на форум, если пошарил бы в учебнике или пошастал бы по статьям в интернете на эту тему.
Что делал но че то не найду. Так что, вынужден опять открыть тему, потому, что думаю так будет быстрее, чем искать искать и целый день тратить на какую то мелочь.
Так что нужна помощь.
Речь о модуле объекта. С которым совсем не знаком. Потому, что все процедуры в основном писал в модуле формы объекта и в общем модуле.
Вопрос:
Как обозначить текущий объект в модуле объекта

В событии в модуле формы объекта ведь все так выглядит
Процедура ПриОткрытии(Отказ)
Сообщить(""+Объект.Ссылка+" -- "+Объект.код);
КонецПроцедуры


А вот событие уже в модуле объекта.
Процедура ПередУдалением(Отказ)
Сообщить(""+Объект.Ссылка+" -- "+Объект.код); //НЕ РАБОТАЕТ! Естественно
КонецПроцедуры

Как получить то, что указано для модуля формы объекта уже в модуле объекта
Нужно код подкорректировать!
Буду признателен!
Просмотров: 146, последний комментарий от Petre   
Анализ движения денежных средств: группировка строк по дополнительному реквизиту при б/н расчету [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 17.07.17, 7:44 — 0 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Практически во всех значимых документах установлен дополнительный реквизит "Агент" (ПКО, РКО, ВПП, ИПП)

При выводе отчета "Анализ движения денежных средств" при группировке строк могу выбрать параметр "ДокументДвижения.Агент"
Кроме того в группировке колонок устанавливаю режим: "Вид денежных средств (наличный, безналичный).

При таком раскладе, в случае с наличными средствами, группировка строк отчет срабатывает четко, т.е. показывает движение по наличному расчету правильно, но

отчет по безналичному расчету не группирует по реквизиту "Агент", т.е. все сводит в одну строку.

Понимаю, что предыдущий оратор-программист сделал всё для группировки по наличному расчету, но я никак не могу сообразить, в какой регистр загнать "Агент", чтобы в ДокументеДвижения при отборе строк срабатывала группировка строк при безналичномм расчете по реквизиту "Агент"?


Вопрос снят.

Предыдущий оратор-программист почему-то "Агента" сделал реквизитом формы... Исправил. Всё заработало
Просмотров: 71, оставить комментарий   
Получить текущий объект метаданных [раздел Программирование управляемых форм 1С 8.2]
Автор Gigi — 14.07.17, 13:11 — 10 комментариев
Привет всем!
Никто не подскажет как получить текущий элемент метаданных.
Рыл везде ... все что нашел .... нечто подобное ...
//Сообщить(Метаданные.Справочники[1]);
Для Каждого Справочник из Метаданные.Справочники Цикл
Сообщить (Справочник.Имя);
КонецЦикла;

А мне нужно не это, а нужно получить текущий элемент метаданных. Не по индексу не по указанию имени, а в зависимости от события.
Например при событии формы списка: СписокПередУдалением()
Тут в самом начале нужна линия кода, которая выдавала бы имя метаданных, к которому относиться текущий список.
Или на пример ФормаЭлемента и реквизиты. Где нужно получить имя объекта метаданных этой ФормаЭлемента.
Вот такой вот вопрос.
Буду признателен!
Просмотров: 236, последний комментарий от vasya_nepupkin   
Дополнительные реквизиты для кпк Моби-С [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 14.07.17, 8:54 — 0 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Если верить сайту, то для Моби-С можно добавить дополнительные реквизиты для обмена данными с центральной базой.
[необходимо зарегистрироваться для просмотра ссылки]
Но я ничего не понял, как правильно сделать этот дополнительный реквизит.

Задача: в документе "Заказ покупателя" в УТ я создаю новый реквизит "СрокКредита" (список значений, "7", "14", "30" дней)
Т.е. при договоре с наименованием "Кредит" пациент должен выбрать срок кредита в днях в выпадающем списке.

Аналогично нужно сделать и на планшете в Моби-С.

На сайте вроде всё понятно, но сбивает с толку пункт: Обработка при создании документа

Так значит что-то нужно делать и в самой УТ?

Кто-нить сталкивался с дополнительными реквизитами для кпк Моби-С? Посоветуйте, а лучше дайте списать :-)
Просмотров: 101, оставить комментарий   
Автоматически освобождать память [раздел Администрирование и настройка 1С]
Автор Brutok — 13.07.17, 19:02 — 2 комментариев
Как автоматически освобождать память rphost sqlsever Windows NT64. На данный момент проблема решается перезапуском соответствующих служб.
Просмотров: 159, последний комментарий от Brutok   
Глюк Formex [раздел Программирование в 1С Предприятие 7.7]
Автор XBrut — 13.07.17, 12:20 — 1 комментариев
Платформа 27.
Формекс 2.0.5.124
В текстових полях діалогу виникає набажане виділення вмісту.
Тобто...: багаторядкове поле, починаєш писати текст...через кілька секунд все виділяється... і з натисканням наступрої клавіші - зникає.
Мені чомусь здається, що таку проблему бачив не тільки я.
Шукав в інтернетах. Проблема існує , але відповіді толковї не знайшов.

Тобто. Якщо хтось знає, допоможіть будь ласка, хто скільки зможе smile.gif
Просмотров: 173, последний комментарий от Sharzem   
RSS Текстовая версия Сейчас: 22.07.17, 12:56
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне