Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
как удалить все записи регистра [раздел Программирование в 1С Предприятие 8.3]
Автор lolmatrix — 18.06.19, 11:26 — 3 комментариев
Здравствуйте подскажите пожалуйста как удалить записи регистра все или по условию
Просмотров: 14, последний комментарий от sava1   
Управление торговым предприятием 8.3 для Украины [раздел Обучающее видео]
Автор zuzuzu557 — 18.06.19, 11:24 — 0 комментариев
Добрый день помогите найти в просторе инттернета безоплатный источник с видео-уроками по Управление торговым предприятием 8.3 для Украины. Благодарю
Просмотров: 5, оставить комментарий   
Программное Нажатие Кнопки [раздел Программирование в 1С Предприятие 8.3]
Автор ukr.ray — 17.06.19, 10:43 — 2 комментариев
Добрый день, мне поставили задачу сделать автоматическое закрытие смены. Розница 1.0.
В определено время запускается форма.[необходимо зарегистрироваться для просмотра ссылки]
Форме есть кнопка, как можно программно её нажать средствами 1с?

я пробовал такой вариант, присваивал кнопки "СочитаниеКлавишы" (Например кнопка F1)
Процедура ПриОткрытии()
Shell= Новый COMОбъект("Wscript.Shell");
Shell.SendKeys("{F1}");
КонецПроцедуры

Работает некорректно с 200 точек срабатывает примерно на 150.

У кого есть идеи как можно её нажать средствами 1с. ?

Объясняю почему надо именно нажать кнопку а не выполнить процедур которая прописана в кнопке.

Если просто запустить обработку закрытие смены (без физического нажатие кнопки), в момент закрытия смены, продавцы не читают что написано на экране и просто нажимают мышкой по открытой форме, появляется сообщение windows 1сv8 не отвечает Закрыть программу или Ожидание отклика от программы, ну конечно они нажимают Закрыть программу. и все смена не закрыта.

Просмотров: 71, последний комментарий от pablo   
Импорт-экспорт между двумя базами [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 17.06.19, 10:38 — 1 комментариев
Всем привет!
Вообще сам вопрос темы в принципе решен ... и казалось бы результат устроил... все вроде бы нормально работает ...только один нюанс.
Слишком много кодовых строк получилось.
Очень длинная кодовая конструкция..... состоящая в основном из многочисленных функций и процедур подспорья. Да .. только ПОДСПОРЬЯ!!!!
В связи с чем опять понимается, сколько всего в этой супер продвинутой системе, нужно писать самому...
все писать ... без конца края .... и все это только что бы уже наконец подойти к долгожданному решению задачи. И всю эту кучу бедствия, впихнуть всего в ОДНУ КОДОВУЮ ЛИНИЮ. Для того, что бы наконец нажать на эту несчастную кнопку, под которой вписана та самая .. всего ОДНА ЛИНИЯ ))... До нажатия которой, после стольких бед, наверно уже нужно аж перекреститься smile.gifsmile.gif ))
Так что многое понимается после этого... В особенности когда ставишь точки над И... И оглянувшись видишь то количество строк кода, которое по вынужденному обстоятельству было написано до этого. Равно как и то, что если ограничивался бы только встроенными функциями системы, какое это было бы уже просто жалким зрелищем.
Вот что понимается после этого...
Но ладно ... это так ... опять делюсь "ощущениями"
А что касается вопроса темы, он в том, как оптимизировать и сократить код. И сделать его, скажем так, более удобоваримым.
Вот в чем вопрос.
И для того что бы получить рекомендации, для этого необходимо скинуть те самые мною же писанные не малые строки кода )), от которых у самого же голова идет кругом. )) Не говоря уже о тех людях которым он будет представлен.
Так что, до получения каких рекомендаций на этом сайте..., до этого ...к сожалению это необходимо.. Имею ввиду все наглядно представить.
А это если распечатать на бумаге А4, в шрифте на пример 12, займет целых две страницы ... если не больше.
А ведь участникам форума может будет не охота вникать во все это.
Именно поэтому воздерживаюсь скидывать код. И думаю так лучше пока данная тема не получит отклик. Поэтому решил только в таком случае скинуть сам код.
И если кто решит до рекомендаций, не полениться с ознакомлением с деталями вопроса то,
Буду признателен!
Вот собственно суть вопроса.
Просмотров: 71, последний комментарий от pablo   
Ошибка открытия сохраненного чека ККМ [раздел Программирование в 1С Предприятие 8.3]
Автор ukr.ray — 15.06.19, 19:18 — 1 комментариев
Добрый день, Я только начинаю осваивать навыки программирование в 1с, столкнулся с такой проблемой, при частом выключение света на торговый точках происходит следующая ошибка
Ошибка раборки XML: -1 [1.1]
Фатальная ошибка:
Document is empty
Systemld: file://C:\Users\admin\AppData\Local\Temp\OrdrBack.xml
У меня конфигурация Розница для Украины 1.0.8.1
В инте вычитал что в новых редакциях это исправили (Розница 1.0.15 и выше и Аптеки для Украины Версия 1.0.18.1)
"Исправлены ошибки:"
11. Ошибка открытия сохраненного чека ККМ. При поврежденном файле автосохранения чека ККМ «OrdrBack.xml», не запускается рабочее место кассира.

Кто может поделится кодом что бы избежать эту ошибку.

Все что есть в моей рознице 1.0.8.1
// ПРОЦЕДУРЫ И ФУНКЦИИ АВТОСОХРАНЕНИЯ ЧЕКОВ ККМ
Процедура АвтосохранениеЧекаККМ
Процедура ВосстановитьЧекККМ(
Процедура ОчиститьАвтосохраненныеЧекиККМ
Функция ПолучитьАвтосохраненныйЧекККМ
Функция ПолучитьХМLПредставление(Объект)
///////////////////////////////////////////////////////////////////////////////

ПОМОГИТЕ КТО МОЖЕТ!
Просмотров: 52, последний комментарий от andr_andrey   
номенклатура при изменении [раздел Программирование в 1С Предприятие 8.3]
Автор bodka_ua — 15.06.19, 12:06 — 1 комментариев
Бухгалтерия для Украины, редакция 1.2. (1.2.48.1)
При отладке на табло цена просчитывается, а 1с зависает. Что не так?
Процедура ТоварыНоменклатураПриИзменении(Элемент)

    СтрокаТабличнойЧасти = ЭлементыФормы.Товары.ТекущиеДанные;
СтрокаТабличнойЧасти.Цена = СтрокаТабличнойЧасти.ЦенаЗПДВ - (СтрокаТабличнойЧасти.ЦенаЗПДВ /6);


    // Выполнить общие действия для всех документов при изменении номенклатуры.
    //ОбработкаТабличныхЧастей.ПриИзмененииНоменклатурыТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);

    //ПриИзмененииНоменклатурыТоваров(СтрокаТабличнойЧасти);

    // Рассчитываем реквизиты табличной части.
    //ОбработкаТабличныхЧастей.РассчитатьСуммуТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);
    //ОбработкаТабличныхЧастей.РассчитатьСуммуНДСТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);
КонецПроцедуры
Просмотров: 50, последний комментарий от bodka_ua   
Как присвоить указанный уникальный идентификатор объекту? [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 14.06.19, 17:15 — 1 комментариев
Всем привет!
Никто не подскажет как это сделать?
Дело в чем ...
Хотя ладно .... скину часть задачи
Вот эту часть

Функция Сериализация(СоединениеCOM,СериализуемыйОбъектИлиСсылка) Экспорт
//============================
    //Многие говорят "Попытка/Исключение " это "Манера плохого тона". Но при этом не понимают, что хороший тон еще нужно заслуживать.
    //А те которые на пример написали функцию:  "ТипЗнч(Значение)" другого тона точно не зауживают.
    //Поэтому вынужден был в таком тоне....  И хороший программист итак поймет почему решил только в таком тоне.
    Попытка знОбъектИлиСсылка=СериализуемыйОбъектИлиСсылка.ПолучитьОбъект(); Исключение знОбъектИлиСсылка=СериализуемыйОбъектИлиСсылка    КонецПопытки;
//============================
    Если СоединениеCOM=Неопределено Тогда
        Дерево=СериализаторXDTO.ЗаписатьXDTO(знОбъектИлиСсылка);
        ЗаписьXML=Новый ЗаписьXML;
        ЗаписьXML.УстановитьСтроку();
        ФабрикаXDTO.ЗаписатьXML(ЗаписьXML,Дерево);  //Сообщить(Ф.Параметры);
    Иначе
        Дерево=СоединениеCOM.СериализаторXDTO.ЗаписатьXDTO(знОбъектИлиСсылка);
        ЗаписьXML = СоединениеCOM.NewObject("ЗаписьXML");
        ЗаписьXML.УстановитьСтроку();
        СоединениеCOM.ФабрикаXDTO.ЗаписатьXML(ЗаписьXML,Дерево);
    КонецЕсли;
//============================
    Возврат ЗаписьXML.Закрыть();
КонецФункции

Функция Десериализация(СоединениеCOM,ТекстXML,ВозвратСсылкаОбъект) Экспорт
//============================    
Если СоединениеCOM=Неопределено Тогда
    ПарсерXML=Новый ЧтениеXML;
    ПарсерXML.УстановитьСтроку(ТекстXML); //Сообщить(ТекстXML+Символы.ПС+Строка(ПарсерXML)+" - "+ТипЗнч(ПарсерXML));
Иначе
    ПарсерXML = СоединениеCOM.NewObject("ЧтениеXML");
    ПарсерXML.УстановитьСтроку(ТекстXML); //Сообщить(ПарсерXML);    
КонецЕсли;
//============================
    Пока ПарсерXML.Прочитать() Цикл
    Если ПарсерXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
    МетаОбъект=ПарсерXML.Имя;  //Сообщить(МетаОбъект);
    Прервать;
    КонецЕсли;
    КонецЦикла;
//============================
    Если СоединениеCOM=Неопределено Тогда
        Объект=СериализаторXDTO.ПрочитатьXML(ПарсерXML);
    Иначе
        Объект=СоединениеCOM.СериализаторXDTO.ПрочитатьXML(ПарсерXML);
    КонецЕсли;
//============================
ПарсерXML.Закрыть();
//============================
//Сообщить(МетаОбъект);
    Если Найти(МетаОбъект,"Catalog")>0 или Найти(МетаОбъект,"Document")>0 Тогда
        Если  ВозвратСсылкаОбъект="Ссылка" Тогда  Значение=Объект.Ссылка; Иначе Возврат Значение=Объект; КонецЕсли;
    Иначе
        Значение=Объект;
    КонецЕсли;
//============================
    //Сообщить(Строка(Значение)+" - "+ТипЗнч(Значение));
Возврат Значение;
КонецФункции


Дело в том, что при перезаписи имеющихся объектов в базе приема по данным объектов базы источника, нужна предварительная десериализация.
Которая осуществляется не по коду или номеру, а по уникальному идентификатору.
Поэтому если на пример у принятого из базы источника документа записанного в XML, на пример номер: "00000002". И если документ с таким же номером имеется в базе приема то команда:
Объект=СериализаторXDTO.ПрочитатьXML(ПарсерXML);

Не вернет его как Объект с номером "00000002". А вместо этого вернет пустое значение объекта.
Поэтому нужно как то при создании нового объекта принудительно записать тот идентификатор который указан в данных XML
Вот собственно и весть вопрос.
Короче ... КАК ОБЪЕКТУ ПРИСВОИТЬ УКАЗАННЫЙ ИДЕНТИФИКАТОР И ТАК ЕГО И ЗАПИСАТЬ.
Никто не подскажет как можно это сделать по быстрому.
Буду признателен!


Gigi @ Сегодня, 16:46 * ,
Молчание не всегда золото ... че нет отклика?


Gigi @ Сегодня, 17:10 * ,
Видимо уже не рабочее время...
Ладно... я тоже закруглюсь ...
Но буду признателен за отклик ..
Просмотров: 147, последний комментарий от Gigi   
Проверка на проведенность документа [раздел Программирование управляемых форм 1С 8.2]
Автор Constantus — 14.06.19, 13:34 — 2 комментариев
Приветствую, Форумчане!
1с8.3.6, БСП, самопис, УФ

Пытаюсь при проведении документа проверить проведен или нет документ:
Процедура ОбработкаПроведения(Отказ, РежимПроведения)
    // Вставить содержимое обработчика.
            Сообщить(ЭтотОбъект.Проведен);
    Если ЭтотОбъект.Проведен Тогда
        Сообщить("Документ проведен; распроведите документ для повторной отправки сообщений.");
        Отказ = Истина;
        Возврат;
    КонецЕсли;



Но он всегда выдает, что документ проведен, хотя он явно не проведен (я просто знаю об этом)

Как правильно сделать проверку на проведенность документа?

Смысл: при проведении документа срабатывают отправка СМС, чтобы пользователь при нажатии проведении не отправлял каждый раз СМС "придумал", что проверить: если проведен, то не проводить документ...
Просмотров: 85, последний комментарий от Vofka   
Открыть форму созданного и существующего документа по ДокументуОснования [раздел Программирование управляемых форм 1С 8.2]
Автор Constantus — 14.06.19, 11:02 — 1 комментариев
Приветствую, Форумчане!
1с8.2.6, БСП, самопис, УФ

В Документе есть кнопка, которая должна создавать дополнительный другой новый документ с заполнением и открытием вновь созданного документа, либо в случае, если такой документ уже существует, просто открыть его форму...

&НаКлиенте
Процедура УведомитьЗаказчикаОГотовностиСтелы(Команда)
    СоздатьОткрытьДокументУведомления();
    ОткрытьФорму("Документ.УведомлениеЗаказчикаОГотовностиСтелы.ФормаОбъекта", Новый Структура("ДокументОснование", Объект.Ссылка),ЭтотОбъект);
КонецПроцедуры


&НаСервере
Процедура СоздатьОткрытьДокументУведомления()
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    УведомлениеЗаказчикаОГотовностиСтелы.Ссылка
        |ИЗ
        |    Документ.УведомлениеЗаказчикаОГотовностиСтелы КАК УведомлениеЗаказчикаОГотовностиСтелы
        |ГДЕ
        |    УведомлениеЗаказчикаОГотовностиСтелы.ДокментОснование = &ДокментОснование";
    
    Запрос.УстановитьПараметр("ДокментОснование", Объект.Ссылка);

    Результат = Запрос.Выполнить();
    Если НЕ Результат.Пустой() Тогда
        Выборка = Результат.Выбрать();
        Выборка.Следующий();    
        ДокУведомление = Выборка.Ссылка;
    Иначе
        ДокУведомление = Документы.УведомлениеЗаказчикаОГотовностиСтелы.СоздатьДокумент();
        ДокУведомление.Дата = ТекущаяДата();
        ДокУведомление.Автор = ПараметрыСеанса.ТекущийПользователь;
        ДокУведомление.ДокментОснование = Объект.Ссылка;
        ДокУведомление.Заказчик = Объект.Заказчик;
        ДокУведомление.Записать();
    КонецЕсли;    
    
КонецПроцедуры


Докмуент создается, документОснование заполняется... Подскажите как правильно открывать формы для вновь созданных документов и для уже существующих...
Никак этот параметр открытия подобрать не могу...


Просмотров: 106, последний комментарий от fly   
Как вернуть «актуальность» уволенным сотрудникам? [раздел 1С Зарплата и Управление Персоналом 8]
Автор LoRa_2205 — 13.06.19, 15:17 — 6 комментариев
Добрый день,пользуюсь программой 1С: Предприятие 8.3 (8.3.13.1513)
При формировании табеля в него попали уволенные ( 2 месяца назад )сотрудники. Я сняла галочку напротив этих сотрудников "Актуален". Но это ситуацию с табелем не поменяло, а уволенные уже не отображались в "Списках сотрудников".
У меня возникли вопросы: Как вернуть «актуальность» уволенным сотрудникам? и из-за чего уволенные несколько месяцев назад сотрудники могут попадать в табель?
Просмотров: 157, последний комментарий от fly   
Сумма полей с отбором в общем итоге СКД. [раздел Система компоновки данных]
Автор podcast — 13.06.19, 10:23 — 4 комментариев
Здравствуйте подскажите пожалуйста, есть таблица
Тип |ОбщийИтог
Тип1|1
Тип2|2
Тип1|1
Тип2|2
Рез |???

В поле Рез нужно посчитать сумму Тип1, сам Тип1 в общем итоге рассчитывается по условию.
Просмотров: 137, последний комментарий от fly   
Как заменить фирму в документе [раздел Конфигурация "1С:Конвертация данных"]
Автор igmig65 — 12.06.19, 18:49 — 8 комментариев
Подскажите плиз. Мало работал с конвертацией. Уже есть настроенный обмен. Переносится всего один документ.
Но нужно при загрузке подменять фирму в документе, подставлять другую из базы приемника, и чтобы никаких ссылок по организации не выгружалось/загружалось.
Подскажите что и где копать. На закладке загрузка нет возможности настройки стыковки реквизитов. Наверное нужно именно в Правилах чтото настраивать. Блин некогда копаться. Все работает, только вот одна загвоздка.
Просмотров: 146, последний комментарий от igmig65   
Запросы. Получение результатов из нескольких таблиц [раздел Программирование в 1С Предприятие 8.3]
Автор FreshNew — 12.06.19, 16:40 — 5 комментариев
Дело вот в чем,

Есть два д-та "ПродажаТовара" и "ПоступлениеТовара"
В них ТЧ "Товары", в которой содержится Номенклатура и ВидТовара

Реализую отчет, который будет выводить след.:
Номенклатура | Документ (Ссылка - ПродажаТовара или ПоступлениеТовара) | ВидТовара

Если ВидТовара Номенклатуры совпадает, то в отчете выводится одна строка с перечислением вышеописанных полей.
Если ВидТовара в д-тах указан разный, то выводится Номенклатура и подстроки с указанием Документа и ВидТовара, например:

Номенклатура | Документ | ВидТовара
Шапка |ПродажаТовара | аксессуар
Кепка |ПродажаТовара | аксессуар
Кепка |ПоступлениеТовара| аксессуар на лето
и т.д.

Нет идеи как реализовать.
Использовать две ВТ, в одной из сравнивать как ПродажаТовараТовары.ВидТовара = ПоступлениеТовараТовары.ВидТовара , что бы исключить дублирование одинаковых ВидовТовара при формировании отчета
и во второй ВТ сравнивать как ПродажаТовараТовары.ВидТовара <> ПоступлениеТовараТовары.ВидТовара , что бы различать что ВидТовара не совпадает и выводить несколько значений

Но это как то глупо, не думаю, что это решение данной задачи. Если есть идеи - подскажите, заранее спасибо)
Просмотров: 101, последний комментарий от Vofka   
Не проходит возврат покупателю [раздел 1С Бухгалтерия 7.7 для Украины]
Автор sheilak — 11.06.19, 18:47 — 1 комментариев
Добрый вечер, устала уже искать на решение проблемы. Проплата была покупателем на расчетный счет (проводки Д311 К681). Акта не было и через месяц возрат поставщику частично денег. По банковской выписке проводку Д681 мне программа не дает сделать. Вопрос как сделать, чтоб программа дала мне установить эту проводку? Пожалуйста помогите
Просмотров: 108, последний комментарий от mut   
как скопировать Результат запроса в таблицу на форме [раздел Программирование в 1С Предприятие 8.3]
Автор lolmatrix — 11.06.19, 13:21 — 2 комментариев
Здравствуйте уважаемые форумчане знаю , что код кривой только начинаю изучать подскажите пожалуйста новичку как как скопировать Результат запроса в таблицу на форме
Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    простоиСписок.КодНомер КАК КодНомер,
    |    простоиСписок.машина КАК машина,
    |    простоиСписок.один КАК один,
    |    простоиСписок.два КАК два,
    |    простоиСписок.три КАК три,
    |    простоиСписок.четыре КАК четыре,
    |    простоиСписок.пять КАК пять,
    |    простоиСписок.шесть КАК шесть,
    |    простоиСписок.семь КАК семь,
    |    простоиСписок.восемь КАК восемь,
    |    простоиСписок.девять КАК девять,
    |    простоиСписок.десять КАК десять,
    |    простоиСписок.одинадцать КАК одинадцать,
    |    простоиСписок.двенадцать КАК двенадцать,
    |    простоиСписок.тринадцать КАК тринадцать,
    |    простоиСписок.четырнадцать КАК четырнадцать,
    |    простоиСписок.пятнадцать КАК пятнадцать,
    |    простоиСписок.шестнадцать КАК шестнадцать,
    |    простоиСписок.семнадцать КАК семнадцать,
    |    простоиСписок.восемнадцать КАК восемнадцать,
    |    простоиСписок.девятнадцать КАК девятнадцать,
    |    простоиСписок.двадцать КАК двадцать,
    |    простоиСписок.двадцатьОдин КАК двадцатьОдин,
    |    простоиСписок.двадцатьдва КАК двадцатьдва,
    |    простоиСписок.двадцатьТри КАК двадцатьТри,
    |    простоиСписок.двадцатьЧетыре КАК двадцатьЧетыре,
    |    простоиСписок.двадцатьПять КАК двадцатьПять,
    |    простоиСписок.двадцатьШесть КАК двадцатьШесть,
    |    простоиСписок.двадцатьСемь КАК двадцатьСемь,
    |    простоиСписок.двадцатьВосемь КАК двадцатьВосемь,
    |    простоиСписок.двадцатьДевять КАК двадцатьДевять,
    |    простоиСписок.Тридцать КАК Тридцать,
    |    простоиСписок.ТридцатьОдин КАК ТридцатьОдин,
    |    простоиСписок.СуммаЧасов КАК СуммаЧасов
    |ИЗ
    |    Документ.простои.Список КАК простоиСписок";
    Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Таб = Запрос.выполнить().выгрузить();
    Выборка = Запрос.Выполнить().выбрать();
      Таб.Скопировать(
Просмотров: 111, последний комментарий от lolmatrix   
Открыть форму с заполнением данных [раздел Программирование управляемых форм 1С 8.2]
Автор Constantus — 11.06.19, 10:09 — 3 комментариев
Приветствую, Форумчане!
1с.8.3.6, самопис, БСП, УФ

Досталось в наследство. На форме документа "ОтгрузочныйЛист" имеется кнопка, которая заполняет другой доумент "ПоступлениеИзделийВПодразделение"

Код заполнения
ОткрытьФорму("Документ.ПоступлениеИзделийВПодразделение.ФормаОбъекта", Новый Структура("Ключ", Объект.ПоступлениеИзделийВПодразделение), ЭтотОбъект,,,,, РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);



Документ открывается как новый и всё заполняет, кроме одного реквизита, который и требуется дозаполнить в этом коде.

Никак не могу отследить как этот код открывает новый документ "Поступление...", заполняет его, причем вместе с ТЧ...

Где и как происходит заполнение этого нового документа, чтобы дописать туда недостающий заполняемый реквизит? (в данном случае. "Склад" из документа "ОтгрузочныйЛист")

Я так понял данный код заполнит новый документ, если структура обоих документов будет индентична до безобразия.
У меня в "Поступлении" реквизит "Склад", в "Отгрузочном" реквизит "Склад получатель".

Как уровнять тогда в правах эти разные по наименованию реквизиты?
Просмотров: 124, последний комментарий от sava1   
как найти строки в таблице документа [раздел Программирование в 1С Предприятие 8.3]
Автор lolmatrix — 11.06.19, 7:50 — 0 комментариев
Здравствуйте, уважаемые форумчане, пытаюсь написать конфигурацию, но не получается найти строки в документе, помогите пожалуйста в чем ошибка массив найденныеСтроки получается пустой
Для каждого Строка из Список цикл
    строкаМашина = Строка.машина;
    отбор =  Новый Структура;
    Отбор.Вставить("машина", "СтрокаМашина ");
    Найденныестроки = список.НайтиСтроки(Отбор);


Спасибо вопрос решен
Просмотров: 81, оставить комментарий   
Создание документ ОперацияБух [раздел Программирование в 1С Предприятие 8.3]
Автор Юля — 10.06.19, 14:41 — 6 комментариев
Привіт, бухгалтерія 2.0 потрібно обробкою створити документ Операції введені вручну. Тобто є форма на якій розміщена кнопка створити документ і заповнити. Документ створюється, але табличну частину не можу заповнити, таблицю бачу , бачу колонки, заповнити рне можу. Підкажіть, як звернутися до строк в таблиці. Потрібно прописати рах 231 - всі його субконто, відповідно суму...
Просмотров: 194, последний комментарий от Юля   
ПриЗаписиПерепроводить = Ложь. Недоступно для записи [раздел Программирование управляемых форм 1С 8.2]
Автор Constantus — 10.06.19, 12:49 — 6 комментариев
Приветствую, Форумчане!
1с8.3.6, самапис, БСП, УФ

Нашел метод, который по-моей задумке должен просто записать документ, не проводя его...

Код
&НаКлиенте
Процедура ДокументСдан(Команда)
    
ДокументСданНаСервере();
    
    ЭтаФорма.ПриЗаписиПерепроводить = Ложь;
    Записать();
    ЭтаФорма.ПриЗаписиПерепроводить = Истина;
    
    Парам = Новый Структура(); //108470
    Парам.Вставить("Основание",Объект.Ссылка);
    Парам.Вставить("Действие","Принят");
    Форм = ОткрытьФорму("Документ.ПрохождениеДокумента.ФормаОбъекта",Парам,,,ВариантОткрытияОкна.ОтдельноеОкно,,Новый ОписаниеОповещения("ДокументСданЗавершение", ЭтотОбъект, Новый Структура("Команда", Команда)),РежимОткрытияОкнаФормы.БлокироватьВесьИнтерфейс);
    
КонецПроцедуры


Но выдает ошибку:
Цитата
Поле объекта недоступно для записи (ПриЗаписиПерепроводить)
ЭтаФорма.ПриЗаписиПерепроводить = Ложь;


Как правильно посадить эту волшебную комбинацию? На сервере, ЭтаФорма, Объект?
Просмотров: 134, последний комментарий от sava1   
Сохранить дублирующий реквизит с номером документа при записи нового документа [раздел Программирование управляемых форм 1С 8.2]
Автор Constantus — 07.06.19, 16:08 — 2 комментариев
Приветствую, Форумчане!
1с8.3.6, самопис, БСП, УФ

В документе "Заказы", есть дублирующие основные реквизиты "ДатаДок" и "НомерДок".

Как можно сделать так, чтоы при нажатии кнопки "Сохранить", документ сохранился и сохранились данные этих дублирующих реквизитов?

Понавешивал кодов на все возможные события, но сохраняет только при вторичном нажатии сохранить, т.к. сам номер документа при "первом" сохранении еще неизвестен, поэтому и сохранять его в дублирующих реквизитах нет возможности...

Одним словом, при сохранении (перед. после, над, под, сбоку) нужно как-то сохранить "НомерДок = Ссылка.Номер"

Как такое возможно?
Просмотров: 173, последний комментарий от TrasserZero   
RSS Текстовая версия Сейчас: 18.06.19, 13:32
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне