Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Помогите найти отчет "Валовая прибыль по покупателю" [раздел Программирование управляемых форм 1С 8.2]
Автор SergXP — 07.12.16, 15:34 — 0 комментариев
1С:Предприятие 8.3 (8.3.7.2008)
Управление небольшой фирмой для Украины, редакция 1.6

У пользователя есть отчет "Валовая прибыль по покупателю". В конфигураторе не могу его найти...


 ! 

Правила: 4
 
Просмотров: 16, оставить комментарий   
Консоль автоанализа запросов Gilev.ru [раздел Отчеты / Обработки]
Автор Batchir — 07.12.16, 15:32 — 0 комментариев
Авторы обработки Команда Gilev.ru
[необходимо зарегистрироваться для просмотра ссылки]
[необходимо зарегистрироваться для просмотра ссылки]

Большая часть проблем производительности 1С лежит в неоптимальных запросах. Даже многие блокировки — лишь следствие избыточного сканирования данных неоптимальными запросами. Поэтому основная задача оптимизации всегда будет в том числе в оптимизации наиболее используемых запросов.
Команда Gilev.ru представляет вашему вниманию новый уникальный инструмент быстрого автоматического анализа неоптимальности запросов, позволяющий разработчику получить возможность оперативно проанализировать свой запрос и исправить в нём ошибки, не привлекая для этого 1С Экспертов.

Инструмент позволяет автоматически проанализировать структуру выполняемого запроса, план его выполнения на MS SQL и в облачном сервисе показать рекомендации, позволяющие программисту оптимизировать исходный запрос.


За основу взята обработка версии 1.5.19.
Сделал несколько украшательств чисто для себя:
1. Переместил закладку плана запроса, так что б она показывала план на весь экран

2. Реализовал вывод признака наличия SCAN и SEEK...WHERE что б визуально сразу бросалось в глаза



3. "Причесал" вывод описания оператора + исправил вывод этого описания в метаданных 1С (использую 8.3.9.1818 и покрайней мере в ней не все данные отображались)


Прикрепленные файлы
Прикрепленный файл  GilevRu_Console_1_5_19.rar ( 598,35 килобайт ) Кол-во скачиваний: 0
 
Просмотров: 7, оставить комментарий   
Выбор в группе из списка [раздел Программирование в 1С Предприятие 8.3]
Автор avel1976 — 07.12.16, 14:32 — 0 комментариев
Добрый день!
1С:Підприємство 8.3 (8.3.7.1949) "Управление торговым предприятием для Украины", редакция 1.2.
Разработка конфигурации: "ABBYY Ukraine", 2007-2016 (1.2.38.1) Обычное приложение.

Подскажите пожалуйста, как выбрать группу из списка. Нужно, чтобы можно было выбрать несколько групп в одном запросе. Ниже приведет текст запроса.

Спасибо.


Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Хозрасчетный.Период,
        |    Хозрасчетный.Регистратор,
        |    ПРЕДСТАВЛЕНИЕ(Хозрасчетный.Регистратор),
        |    Хозрасчетный.СчетДт КАК СчетДт,
        |    ПРЕДСТАВЛЕНИЕ(Хозрасчетный.СчетДт),
        |    Хозрасчетный.СчетКт КАК СчетКт,
        |    ПРЕДСТАВЛЕНИЕ(Хозрасчетный.СчетКт),
        |    Хозрасчетный.Организация,
        |    ПРЕДСТАВЛЕНИЕ(Хозрасчетный.Организация),
        |    СУММА(Хозрасчетный.Сумма) КАК Сумма,
        |    Хозрасчетный.Регистратор.Проведен,
        |    Хозрасчетный.Регистратор.ДоговорКонтрагента.Подразделение КАК РегистраторДоговорКонтрагентаПодразделение,
        |    ПРЕДСТАВЛЕНИЕ(Хозрасчетный.Регистратор.ДоговорКонтрагента.Подразделение),
        |    Хозрасчетный.Регистратор.Контрагент КАК РегистраторКонтрагент,
        |    ПРЕДСТАВЛЕНИЕ(Хозрасчетный.Регистратор.Контрагент),
        |    Хозрасчетный.Регистратор.Ответственный,
        |    ПРЕДСТАВЛЕНИЕ(Хозрасчетный.Регистратор.Ответственный)
        |ИЗ
        |    РегистрБухгалтерии.Хозрасчетный КАК Хозрасчетный
        |ГДЕ
        |    Хозрасчетный.Период МЕЖДУ &НачПериода И &КонПериода
        |    И Хозрасчетный.СчетДт В(&БухСчет)
        |    И Хозрасчетный.Организация = &Организация
        |    И Хозрасчетный.Регистратор.Проведен = ИСТИНА
        |    И Хозрасчетный.Регистратор.ДоговорКонтрагента.Подразделение В(&Подразделение)
        |    И Хозрасчетный.Регистратор.Контрагент В ИЕРАРХИИ(&Контрагент)
        |    И Хозрасчетный.Регистратор.Контрагент В(&Контрагент)
        |
        |СГРУППИРОВАТЬ ПО
        |    Хозрасчетный.СчетДт,
        |    Хозрасчетный.СчетКт,
        |    Хозрасчетный.Период,
        |    Хозрасчетный.Регистратор,
        |    Хозрасчетный.Организация,
        |    Хозрасчетный.Регистратор.Проведен,
        |    Хозрасчетный.Регистратор.ДоговорКонтрагента.Подразделение,
        |    Хозрасчетный.Регистратор.Контрагент,
        |    Хозрасчетный.Регистратор.Ответственный
        |
        |УПОРЯДОЧИТЬ ПО
        |    РегистраторДоговорКонтрагентаПодразделение,
        |    РегистраторКонтрагент
        |ИТОГИ ПО
        |    РегистраторДоговорКонтрагентаПодразделение,
        |    РегистраторКонтрагент";
Просмотров: 18, оставить комментарий   
Требуется 1С программист 8.3 [раздел Предложения работы]
Автор Mila_01 — 06.12.16, 19:18 — 0 комментариев
Требуется 1С программист 1С 8.3, г. Киев
Уровень З/П – от 25 000 грн. (по итогам собеседования)
Информация о нас:
г. Киев, Соломенский р-н (5 минут ходьбы от метро)
Торговая компания «РадиоЛайн» – не франчайзинг, занимаемся продажей портативной электроники.


Основные требования:
• Профильное высшее образование: техническое, инженерное, математическое, IT;
• Наличие сертификата 1С разработчика;
• Желательно образование в Экономике/Финансах/Бухгалтерии;
• Опыт 1С программистом от 3-х лет с 8.2, 2+ с 8.3. в больших торговых компаниях;
• Работа в 1С франчайзи высокого уровня;
• Желателен опыт работы в команде
Знания ПК программ:
• 1С 8.3, знание и опыт работы на управляемых формах;
• Знание СКД, конфигурации конвертации данных;
• Навыки интеграции 1С с другими учетными системами;
• Знание SQL и минимальный опыт работы с распределёнными СУБД
Опыт:
• Знание бухгалтерского учета, управленческого учета;
• Опыт работы с модулями оптовой и розничной торговли;
• Опыт работы с модулем склада;
• Опыт работы в MS SQL, конфигурация настроек и поиск проблем;
• Опыт работы в СКД;
• Настройка прав пользователя с помощью RLS
Личные характеристики:
• Высокий уровень ответственности;
• Желателен навык коммуникации с людьми;
• Логическое / системное мышление: умение структурировать информацию‚ отделять главное от второстепенного;
• Ориентация на процесс в равной степени, как и на результат;
• Порядочность
• Стремление к обучению, профессиональному совершенствованию
Функциональные обязанности:
• Поддержка 1С системы;
• Доработка системы 1С согласно требованиям учета;
• Разработка новых форм, нестандартного функционала, отчетов;
• Анализ ошибок в работе модулей и пользователей системы, их устранение;
• Участие в составлении технической и методической документации;
• Консультирование пользователей по вопросам работы системы
Условия работы:
• официальное оформление после испытательного срока;
• на испытательный з/п зарплата может быть меньше. Зарплата выдаётся без задержек раз в месяц до 5 го числа. Можем платить два раза в месяц, раз в неделю – как удобно сотруднику.
• расписание работы: с 9:00-10:00 до 18.00-19:00, перерыв на обед 1 час (плавающий), возможны КПИ, часть дней работа по гибкому графику.
• испытательный срок - 3 месяца
• количество коллег программистов в коллективе - 2 человека
• сверхурочные оплачивается, обсуждается в комплексе с самим предложением
• оплачиваемый отпуск по договоренности с соискателем
• дорога с/на работу не оплачивается
• работа в офисе, командировок нет
• компенсация питания 50% в ресторане, в здании офиса

Первое собеседование в телефонном режиме со мной (HR менеджер), после – выполнение тестового задания. Обратную связь предоставляет технический специалист. В случае утверждения кандидата, назначаем собеседование в офисе.

Резюме отправлять на адрес: itsenko.l@rl.ua
HR manager, Мила, тел.: 067 31 01 888; 093 338 76 98



Просмотров: 68, оставить комментарий   
Отчет по ЕСВ (2016) с выгрузукой в *xml [раздел Отчеты / Обработки]
Автор Petre — 06.12.16, 12:05 — 1 комментариев
Отчет по ЕСВ (2016) с выгрузукой в *xml
Используются схемы версии 10 и 11 (за отчетный период с 11/2016)
Прикрепленные файлы
Прикрепленный файл  yEeSVe.zip ( 1,12 мегабайт ) Кол-во скачиваний: 14
 
Просмотров: 74, последний комментарий от Vofka   
Консоль запросов для УФ (одна из лучших) [раздел Отчеты / Обработки]
Автор Santino — 05.12.16, 15:43 — 8 комментариев
Одна из лучших консолей запросов для Управляемых Форм 1С 8.3
В наличии:
- конструктор запросов;
- вывод готового кода для созданного запроса;
- просмотр промежуточных таблиц;
- создание таблиц значений для параметров;
- проверка синтаксиса запроса и автозаполнение списка параметров;
- и многое другое...



Сам архив с обработкой (пароль стандартный):

Прикрепленный файл  КонсольЗапросовУФ_8.3.2.21.zip ( 122,38 килобайт ) Кол-во скачиваний: 30
Просмотров: 189, последний комментарий от Vofka   
Как отправить из файловой базы на sql/pgsql сервер некоторые данные [раздел Программирование обычных форм 1С 8.2]
Автор cartorys — 03.12.16, 13:00 — 17 комментариев
Задача следующая.
Есть файловая база, самописная конфигурация (кассовое место). Нужно выгружать из нее продажи на удаленный транзитный sql/pgsql сервер в интернете.
Например, передать таблицу с продажами запросом.
Что можете посоветовать под эту задачу? Клиент, компонента, com сервер?..
Спасибо.
Просмотров: 257, последний комментарий от Vofka   
Консоль запросов [раздел Прочее 1С 8]
Автор Olga_Leon — 03.12.16, 10:02 — 1 комментариев
Добрый день! Предприятие 8.3 (8.3.6.2449), "Управление торговлей для Украины", редакция 2.3.
Разработка конфигурации: "ABBYY Ukraine", 2003-2009
(2.3.12.1)
Пользуюсь консолью запросов с ИТС, где-то 12 года. Нормально отлаживалась и вдруг сегодня обнаруживаю, что консоль не читает файлы запроса sel с диска. Это только я с луны свалилась и 8.3 не читает формат sel
.Может кто-то сталкивался.
Просмотров: 132, последний комментарий от logist   
Как вернуть давальческое сырье давальцу. [раздел 1С Управление производственным предприятием 8]
Автор Наталья_К — 02.12.16, 11:08 — 5 комментариев
Помогите пожалуйста разобраться. Давальческое сырье оприходавано за 0221. Без залоговой цены. Сейчас пытаюсь вернуть часть сырья давальцу. "Возврат товара поставщику". "Из переработки". Но не получается. При возврате требует и цену и сумму.
Как из этой ситуации выйти?
Просмотров: 252, последний комментарий от logist   
Медосмотры в Компл.учет для бюджетных организаций Украины [раздел Остальные конфигурации 1С 8]
Автор victorsv — 02.12.16, 11:06 — 5 комментариев
Как реализовать в конфигурации Компл.учет для бюджетных организаций Украины 1.0(можно и для 2.0) учет медосмотров сотрудников. Чтобы можно было в конце месяця вывести список,кому нужно пройти периодический медосмотр.Я так понимаю,что для каждой профессии нужно добавить периодичность медосмотров и потом для каждого сотрудника ввести дату последнего медосмотра. И на отчет должно вывести сотрудника,дату последнего медосмотра,периодичность прохождения,дату последнего медосмотра.В идеале должен быть еще и отбор тех,у кого медосмотр уже просрочен.
Просмотров: 176, последний комментарий от victorsv   
Как получить данные из двух разных баз одним запросом? [раздел Система компоновки данных]
Автор Мичман Харитонов — 02.12.16, 10:30 — 2 комментариев
Постановка вопроса следующая:
Есть вот такой кусок кода
База2=Новый COMОбъект("V82.COMConnector");
Попытка
    База2.Connect("File=""C:\1CBase""";Usr=""login"";Pwd=""password"";");
Исключение
    Сообщить("Установить подключение не удалось, проверьте настройки");
КонецПопытки;

ЗапросКБазе2 = Новый Запрос;
ЗапросКБазе2.Текст = "
|ВЫБРАТЬ РАЗЛИЧНЫЕ
|ТоварыНаСкладахОбороты.Склад КАК Склад
|ИЗ
|РегистрНакопления.ТоварыНаСкладах.Обороты КАК ТоварыНаСкладахОбороты
|СГРУППИРОВАТЬ ПО
|ТоварыНаСкладахОбороты.Склад
|УПОРЯДОЧИТЬ ПО
|    Склад ";

СкладыСДвижением = ЗапросКБазе2.Выполнить();
СкладыНЕ = Новый ТаблицаЗначений;
СкладыНе.ЗапросКБазе2.Выгрузить();

ЗапросКБазе = Новый Запрос;
ЗапросКБазе.Текст = "
|ВЫБРАТЬ
|Склады КАК Склад,
|Склады.ПометкаУдаления
|ИЗ
|Справочник.Склады КАК Склады
|ГДЕ
|Склады.ПометкаУдаления = &Ложь
|И Склад НЕ В &СкладыНЕ
|УПОРЯДОЧИТЬ ПО
|Склад ";

ЗапросКБазе.Выполнить();
ТаблицаРезультат = Новый ТаблицаЗначений;
ТаблицаРезультат.ЗапросКБазе.Выгрузить();


Подскажите, плиз, как его переписать на СКД, чтобы к обоим базам обращаться из одного запроса?
Просмотров: 173, последний комментарий от Мичман Харитонов   
Журнал реєстрації в платформі 8 [раздел Тематическое общение]
Автор XBrut — 01.12.16, 19:34 — 4 комментариев
Товриші! Мені одному здається, що журнал реєстрації так тормозить, що в реальному житті не має смислу?
Просмотров: 177, последний комментарий от XBrut   
В світі цікавого [раздел Офф-топик]
Автор XBrut — 01.12.16, 19:01 — 23 комментариев
Мені раптово стало відомо , що хвранчайзер Х отримує 50 $ за годину при чому робота так собі ... прийти чаю попить*
______________________
* примітка чай польською буде "хербатка"

П.С.
Хлопці, у кого є рахівниця. Підрахуйте будь ласка, скільки то буде за рік. Ну гаразд. поділіть навпіл. Податки лікарняні то сё.
Просмотров: 579, последний комментарий от XBrut   
Не сворачивается Таблица значений [раздел Программирование обычных форм 1С 8.2]
Автор Alex007 — 01.12.16, 18:58 — 9 комментариев
Задача выгрузить в 3 колонки ТЗ данные из дока, и потом свернуть по первой колонке, просумировав значения в оставшихся двух. Таблица вроде бы заполняется, но не сворачивается не пойму почему. Может потому что сворачиваю по колонке в которой Ссылка на реквизит справочника?

Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.
    //ДокРозн=Документы.ОтчетОРозничныхПродажах;
    ТЗ= Новый ТаблицаЗначений;
    ТЗ.Колонки.Добавить("УТКВЭД",Новый ОписаниеТипов("СправочникСсылка.НоменклатураГТД"));
    ТЗ.Колонки.Добавить("Сумма",Новый ОписаниеТипов("Число"));
    ТЗ.Колонки.Добавить("НДС",Новый ОписаниеТипов("Число"));
    Налог= Документы.НалоговаяНакладная.СоздатьДокумент();
    Для Каждого ТекущаяСтрока Из ДокРозн.Товары Цикл
    НоваяСтрока = ТЗ.Добавить();
    НоваяСтрока["УТКВЭД"] = ТекущаяСтрока.Номенклатура.НоменклатураГТД;
    НоваяСтрока["Сумма"]=ТекущаяСтрока.Сумма;
    НоваяСтрока["НДС"]=ТекущаяСтрока.СуммаНДС;
    Сообщить(""+НоваяСтрока["УТКВЭД"]+" "+НоваяСтрока["Сумма"]+" "+НоваяСтрока["НДС"]);
КонецЦикла;
    ТЗ.Свернуть("УТКВЭД","Сумма,НДС");
    
    Сообщить("ГОТОВО!");
    Для Каждого ТекущаяСтрока Из ТЗ Цикл
        Сообщить(""+ТекущаяСтрока["УТКВЭД"]+" "+ТекущаяСтрока["Сумма"])+" "+ТекущаяСтрока["НДС"]); //отображаются такие же данные как и в первом цикле!
    КонецЦикла;    
    
    
КонецПроцедуры
Просмотров: 271, последний комментарий от logist   
Выбор нескольких счетов [раздел Программирование в 1С Предприятие 8.3]
Автор Yana.P — 01.12.16, 16:24 — 3 комментариев
Есть документ "Инвентаризация товаров на складе" в нем есть реквизит СчетУчетаОтбор по которому открывается ПланСчетов


Как можно сделать чтоб возможно было выбрать не один счет, а несколько??

Вот так выглядит запрос:

        Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.Ссылка);
    Запрос.УстановитьПараметр("СчетУчетаБУ", ЭтотОбъект.СчетУчетаОтбор);
    
    Запрос.Текст ="
    |ВЫБРАТЬ
    |    Номер,
    |    Дата,
    |    Организация,
    |    Склад.Представление КАК ПредставлениеСклада,
    |    Организация,
    |    Склад,
    |    Товары.(
    |        НомерСтроки,
    |        Номенклатура,
    |        Номенклатура."+ ТекстКодАртикул + " КАК КодАртикул,
    |        Номенклатура.НаименованиеПолное КАК Товар,
    |        Количество                      КАК Количество,
    |        КоличествоУчет                  КАК КоличествоПоУчету,
    |        ЕдиницаИзмерения.Наименование   КАК ЕдиницаИзмерения,
    |        СчетУчетаБУ КАК СубСчет,
    |        Цена,
    |        Сумма,
    |        СуммаУчет                       КАК СуммаПоУчету
    |    )
    |ИЗ
    |    Документ.ИнвентаризацияТоваровНаСкладе КАК ИнвентаризацияТоваровНаСкладе
    |
    |ГДЕ
    |    ИнвентаризацияТоваровНаСкладе.Ссылка = &ТекущийДокумент"+?(ЗначениеЗаполнено(ЭтотОбъект.СчетУчетаОтбор)," И ИнвентаризацияТоваровНаСкладе.Товары.СчетУчетаБУ = &СчетУчетаБУ","")+"
    |
    |УПОРЯДОЧИТЬ ПО
    |    Товары.НомерСтроки
    |";
    Шапка = Запрос.Выполнить().Выбрать();
Просмотров: 165, последний комментарий от Vofka   
Маска поля ввода и поиск [раздел Программирование в 1С Предприятие 8.3]
Автор Михрутка — 01.12.16, 16:16 — 3 комментариев
1С8.3 УТП
Создаю маску поля ввода для телефона (999)999-99-99. При этом точно также номер записывается и в хранилище контактной информации, например (123)123-45-67.
В другом документе пытаюсь найти покупателя с этим номером. В поле ввода аналогичная маска.
Если у покупателя номер был записан (123)123-45-67 через маску, то соответственно он находиться, а если был изменен, но при этом цифры те же 1231234567, то соответственно поиска нет, т.к. тип Поля ввода - строка.
Кроме того. Если поле пустое, то оно содержит значение "( ) - -" типа строка.
Что-то наверное я неправильно делаю?
Как сделать чтобы при одних и тех же цифрах происходил поиск независимо от того в каком виде они записаны? У меня проверка возникает в событии "При изменении" поля ввода. Можно ли сделать проверку сразу при вводе одной или нескольких цифр, до окончания ввода всего номера?
Как лучше сделать, подскажите?
Просмотров: 162, последний комментарий от logist   
Пересчет необходимого колва и суммы ТМЦ в РН (создаю программно!)) [раздел Программирование в 1С Предприятие 7.7]
Автор inna.innainna84 — 01.12.16, 2:41 — 11 комментариев
Добрый вечер. Очень давно хотела обработку по Формированию РН из ТЗОстатков. Как смогла так и настряпала. Прошу не ругать меня.
1.Сначала я выбрала в ТЗКлиенты данные по контрагентам по 361 счету с отрицательным долгом
2.Набрала ВыбДок (это излишки по остаткам ТМЦ между Бух.базой и Складом и загрузила их в Расходную накладную по продажной цене)
3.Выгрузила эти излишки в ТЗОстатки
4.СоздатьОбъект("Документ.РасходнаяНакладная") и загружаю в ТЗОстатки
5. Необходимо их обработать
а)Если докРН.СуммаДокНал>докРН.Итог("СуммаСНДС") Тогда
Сообщить ("Нехватает товара!!!");
прерываю!!!!!!!
б) Если докРН.СуммаДокНал>докРН.Итог("СуммаСНДС") Тогда
и начинается самое ТРУДНОЕ 09000000.gif как расчитать ТекКво= если ТМЦ.БазЕдиница "шт". то ОКР, если "кг" оставляем как есть ("помогите расчитать нужное колво!!!!");
Я понимаю, что нужно пробежаться по строках в документе и убрать лишнее кво и вернуть его в ТЗОстатки для создания следующей РН !!!!!! 09000000.gif help.gif help.gif
Если не трудно подскажите
Процедура СоздатьДокРН()
  //=========================не трогать====================================================================        
                           //---1---//
//==========создаем расходныйе накладный по выбраным контрагентам==========  
                                         
        ТЗКлиенты.ВыбратьСтроки();
        Пока ТЗКлиенты.ПолучитьСтроку()=1 Цикл//1  начало
        докРН = СоздатьОбъект("Документ.РасходнаяНакладная");
        докРН.Новый();
        докРН.Фирма =          глВосстановитьЗначение(,"БазФирма");
        докРН.Валюта =         Константа.ОсновнаяВалюта;  
        докРН.Курс =           докРН.Валюта.Курс.Получить(докРН.ДатаДок);        
        докРН.ВидНДС =         докРН.Фирма.СтавкаНДС;
        докРН.ДатаДок =        ТекущаяДата();         
        докРН.Контрагент =        ТЗКлиенты.Контрагент;
        докРН.СуммаДокНал=     ТЗКлиенты.Долг;
        докРН.ВидТорговли =    докРН.Контрагент.ВидТорговли;    
        докРН.СчетКонтрагента =СчетПоКоду("361");
        докРН.МестоХранения =  ВыбСклад;    
//=========================не трогать====================================================================        
                     //----2----//
//==========создаем список ТМЦ в расходных накладных по выбраным контрагентам====  
        ТЗОстатки.ВыбратьСтроки();
        Пока ТЗОстатки.ПолучитьСтроку()=1 Цикл //2 начало
        докРН.НоваяСтрока();
        докРН.ТМЦ =         ТЗОстатки.ТМЦ;      
        докРН.Ед =          ТЗОстатки.Ед;
        докРН.Коэффициент = ТЗОстатки.Коэффициент;
        докРН.Кво =         ТЗОстатки.СписатьКво;        
        докРН.ЦенаСНДС =    ТЗОстатки.ЦенаСНДС;         
        докРН.СуммаСНДС =   докРН.Кво* докРН.ЦенаСНДС;
//=========================не трогать====================================================================
                      //----3----//
         Если докРН.СуммаДокНал>докРН.Итог("СуммаСНДС") Тогда
          Сообщить ("Нехватает товара!!!");  
          возврат;      
         КонецЕсли;  
//=========================не трогать====================================================================                    
        
        
        

                      //----4----//
//    как расчитать сколько нужно списать колва в РН !!!!!!!!!!!  
        Если докРН.СуммаДокНал>докРН.Итог("СуммаСНДС") Тогда  
    
        докРН.ВыбратьСтроки();
        Пока докРН.ПолучитьСтроку()=1 Цикл //3
    
        ИзлишекСуммы=докРН.СуммаДокНал-докРН.Итог("СуммаСНДС");    
        сообщить("излишек"+    ИзлишекСуммы);
        // не обходимо пробежаться по строках в документе и убрать лишее!!!!!!    
              текКолСтрокРН = ТЗОстатки.КоличествоСтрок();
        Для ы = 1 По текКолСтрокРН Цикл      
           
            ТекКво= если ТМЦ.БазЕдиница "шт". то ОКР, если "кг" оставляем как есть ("помогите расчитать нужное колво!!!!");     
        докРН.Кво =         ТекКво;        
        докРН.ЦенаСНДС =    ТЗОстатки.ЦенаСНДС;         
        докРН.СуммаСНДС =   докРН.Кво* докРН.ЦенаСНДС;
        
       КонецЦикла;        
       КонецЦикла;
       КонецЕсли;

                //----5----//
// возращаяю в таблицу ТЗОстатки-лишее кол-во товара из РН                
                
           докРН.ВыбратьСтроки();
            Пока докРН.ПолучитьСтроку()=1 Цикл //3                 
        
            ТЗОстатки.НоваяСтрока();          
        ТЗОстатки.СписатьКво=ТЗОстатки.СписатьКво-докРН.Кво;
        ТЗОстатки.СписатьЦенаСНДС= ТЗОстатки.ЦенаСНДС;
        ТЗОстатки.СписатьСумма= ТЗОстатки.СписатьКво*ТЗОстатки.СписатьЦенаСНДС;
        КонецЦикла;
        
                        
    
    
    
//=========================не трогать====================================================================    
        
        КонецЦикла;//2 конец     
        Сообщить(докРН.Контрагент);
        Сообщить("Итого"+докРН.Итог("СуммаСНДС"));           
    
    
    //=========================не трогать====================================================================        
        докРН.Записать();
        Сообщить(докРН.ТекущийДокумент()+"Создан!");
        Если флПроводить=1  Тогда
        докРН.Провести();
        Сообщить(докРН.ТекущийДокумент()+"Проведен!");                  
        КонецЕсли;  
    //====================================================================================================        
        КонецЦикла; //1 конец        
    КонецПроцедуры  
    
    //=====================================================================
    Процедура Удалить()
        Если ТЗОстатки.СписатьКво<=0 Тогда
            ТЗОстатки.УдалитьСтроку(ТЗОстатки.НомерСтроки);
        КонецЕсли;
    КонецПроцедуры



//=========================не трогать==================================================================== Это я пишу для себя пометки, люблю сначала все поломать,а потом 3 часа вспоминать.
Просмотров: 306, последний комментарий от inna.innainna84   
Поиск по Регистру Контактная информация [раздел Программирование в 1С Предприятие 8.3]
Автор Михрутка — 30.11.16, 17:25 — 4 комментариев
1С 8.3. УТП. Стоит задача найти Контрагента по номеру телефона. Номера хранятся в регистре "Контактная информация".
Вот так получаю список телефонов:
ВЫБРАТЬ
    КонтактнаяИнформация.Представление,
    КонтактнаяИнформация.Вид,
    КонтактнаяИнформация.Объект
ИЗ
    РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
ГДЕ
    КонтактнаяИнформация.Тип = ЗНАЧЕНИЕ(Перечисление.ТипыКонтактнойИнформации.Телефон)


Не соображу как найти конкретный номер телефона?
Просмотров: 160, последний комментарий от logist   
Нумерация документов при очистке номера слетает [раздел Программирование обычных форм 1С 8.2]
Автор Gazulo — 30.11.16, 14:01 — 2 комментариев
Конфигурация УТП . 1.2.38.1. При записи документа присваеваеться новый номер, допустим ДО000000001. При перевыборе в документе той самой организации номер очищается, а при записи присваеваеться новый номер уже ДО000000002, хотя документа с номером ДО000000001 в базе уже нет.Дальше если перевыбрать организацию снова чиститься номер , а при записи присвоеться опять новый номер уже ДО000000003, хотя в базе нет документов с номером ДО000000001 и ДО000000002. и так дальшь, Подскажите как сделать. чтобы этого не было, а номер присваивался от номера последнего документа в базе. Конфигурация стандартная.Спасибо.


 ! 

Правила: 4, 5
 
Просмотров: 182, последний комментарий от Gazulo   
Конфигурация "Учет рабочего времени" [раздел Конфигурации]
Автор whtblck — 30.11.16, 11:10 — 9 комментариев
Публикация посвящена участникам программы "Учет рабочего времени" от Приватбанка.
Другим она вряд ли буден интересна.

Итак. Наше предприятие является участником данной программы.
Суть программы (кратко): банк устанавливает на предприятии терминал, каждый сотрудник, приходя/уходя с работы, отмечается своей зарплатной картой.
По концу месяца Приватбанк предоставляет отчет в файле Excel по каждоиу терминалу.

Проблема, с которой мы столкнулись: таких терминалов у нас 14. Отчетов, соответственно, также 14. Сотрудников - до 1000.
Сотрудник может (в виду рода деятельности) в одном терминале отметить вход, в другом - выход. Или вообще не отметить выход. Проанализировать, кто/когда зашел/вышел и сколько проработал, крайне затруднительно. Отчеты "неудобочитаемые", сгруппировать все в 1 файл крайне затруднительно, посортировать по ФИО, отделу, ИНН - не представляется возможным.

Решение. Была написана конфигурация на базе 1С 8.3.

Возможности:
Загрузить все файлы в систему (одновременно или по одному) в документ "Табель".
Сотрудники (ФИО, ИНН) добавляюттся сами. Кроме ФИО и ИНН данных в файле нет.
Учитывать обеденный перерыв.
Если сотрудник не отметил выход, время выхода ставится равным времени входа, подсвечивается красным.
На выходе получаем сгруппированный отчет (см. скриншот)



Решение на уникальность не претендует. Было сделано под нашу организацию с нашим видением отчета.
Можно интегрировать в Вашу конфигурацию, полученные данные (хранятся в отдельном регистре) можно использовать, скажем, при расчете ЗП.
Готов доработать под Вас.





Скачать: Прикрепленный файл  Комплект_поставки.zip ( 1,4 мегабайт ) Кол-во скачиваний: 9
Просмотров: 322, последний комментарий от whtblck   
RSS Текстовая версия Сейчас: 07.12.16, 16:24
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне