Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Управление торговлей для Украины, редакция 3.1 не работает обмен с банком [раздел Программирование в 1С Предприятие 8.3]
Автор AlexeyMalko — 27.04.17, 14:57 — 4 комментариев
Есть файл выписки с российского банка при попытке загрузить выдаёт ошибку Неверный реквизит заголовка. для украинского банка вообще нету возможности загрузить так как есть всего две галочки txt и xml формата. Что можно сделать дял того чтобы загружать выписку?
Просмотров: 41, последний комментарий от logist   
Ошибка при обмене между УТ 3.1 и Розница 2.0 для Украины [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор Father Fury — 26.04.17, 23:16 — 5 комментариев
Имеется:
1. Конфигурация: Управление торговлей для Украины (версия 3.1.5.1)
2. Конфигурация: Розница для Украины (версия 2.0.5.1)
3. Платформа 8.3.9.2170
4. СУБД: SQL 2008r2
5. Операционка Win Server 2008r2

Исходные данные:
1. Конфигурации стандартные, т.е. не изменялись.
2. В обеих конфигурациях из данных вводилось только предприятие ("Основная фирма") и 2 пользователя (Администратор, Обмен).
3. Настроен обмен между конфигурвциями (через пользователя Обмен).
4. Обмне проходит успешно как из Торговли, так и из Розницы, конфликтов нет.

Суть проблемы:
После закрытия и повторного открытия программ и попытке обмена возникает ошибка: "Превышено максимальное время ожидания предоставления блокировки"
После удаления+создания нового обмена из Торговли обмен происходит успешно.
После закрытия и повторного открытия программ - опять таже ошибка.

Подскажите, пожалуйста, в чем может быть проблема? Куда смотреть?

ЗЫ
СУБД не блокирует - проверял
Регламентные задания тут явно не при чем.

ЗЫЗЫ
Простите, если не угадал с темой.
Просмотров: 83, последний комментарий от Bernet   
Префиксы нового номера у самописных документов [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 26.04.17, 15:43 — 17 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Имеется самописный документ "СамДок"

Прописал его на подписку на событие при установке нового номера документа. Однако номер не сохраняется и прежде всего не проставляется префикс Организации.

Отладчиком обнаружил, что в
Процедура ДобавитьПрефиксОрганизации(ДокументОбъект, Префикс) Экспорт


ЗначениеЗаполнено(ДокументОбъект.Организация.Префикс)

значение не заполнено.

Хотя на форме документа присутствует реквизит Оргнизация

Понимаю, что нарушил какую-то последовательность действий. Подскажите как правильно прописать номер...

Кроме того, почему при создании нового Документа сразу прописывается номер 0000004...?
Просмотров: 170, последний комментарий от Constantus   
Инструкции для обмена с MeDoc [раздел Прочие полезности, которым не нашлось место в разделах выше]
Автор andr_andrey — 26.04.17, 11:41 — 6 комментариев
Эта и другие инструкции хранятся в каталоге help\manuals установленного MeDoc. (если установлен серверный вариант, ищите на сервере)
Прикрепленные файлы
Прикрепленный файл  MedocDocs_Help.pdf ( 442,52 килобайт ) Кол-во скачиваний: 7
Прикрепленный файл  Инструкция_по_СОМ_объектам.pdf ( 691,1 килобайт ) Кол-во скачиваний: 6
 
Просмотров: 92, последний комментарий от andr_andrey   
Руководство разработчика для MEDOC [раздел Тематическое общение]
Автор Bernet — 26.04.17, 11:25 — 9 комментариев
Всем привет.
Нужна документация с описанием структуры БД Медка.
Есть задача на допиливание функционала 1С и получении данных из Медка, а именно: нужно сверять коды УКТЗЕД поставщиков (которые ведутся у нас в базе) и те, которые приходят в входящих налоговых накладных в Медке.
Из примера медовой стыковки COM-объект с реестром входящих налоговых получил, теперь хочу пройтись по таб. части товаров каждого документа, там есть колонка "Код УКТЗЕД" - вот не знаю как её вытянуть, не хотелось бы пальцем в небо тыкать, а знать наверняка. Может кто находил нормальную документацию?

Дошел до следующего места:
        // получаем данные с МЕДКА
    App = Неопределено;
    Попытка
        App = Новый COMОбъект("Medoc.ZApplication")
    Исключение
        Возврат;
    КонецПопытки;                
    
    // Описание входящих параметров Медка:
    // ТипДокумента - "10100" - Налоговая накладная
    // ТипДокумента - "10101" - Приложение 2
    // ТипДокумента - "10100" - Входящий налоговый документ
    
    // Направление - 1 - исходящие
    // Направление - 2 - входящие
        
    prim = App.GetPrimaryDocs();
    Reestr = prim.GetPrimaryReestr("10100", 2, НачалоДня(НачалоПериода), КонецДня(КонецПериода));
    Reestr.First();
    Счетчик = Reestr.RecordCount;
    Пока Счетчик <> 0 Цикл
        
        НомерДокМед     = Reestr.Fields.Item("DOC_NUM").Value;
        ДатаДокМед      = Reestr.Fields.Item("DOC_DATE").Value;
        СуммаДокМед     = Reestr.Fields.Item("DOCSUM").Value;      
        
                // КАК ТУТ ОРГАНИЗОВАТЬ ПЕРЕБОР СТРОК ТАБ. ЧАСТИ И ВЫТЯНУТЬ КОД УКТЗЕД  С КАЖДОЙ СТРОКИ ?

        Счетчик = Счетчик-1;
          Reestr.Next();
    КонецЦикла;


P.S. [необходимо зарегистрироваться для просмотра ссылки] я не нашел того что хотел
Просмотров: 164, последний комментарий от Vofka   
Настройки отчета: ограничить снятие галочки параметра Склад [раздел Система компоновки данных]
Автор Constantus — 26.04.17, 11:23 — 0 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Отчет на СКД, форма отчета - управляемая

Основной параметр - Склад.

При открытии формы отчета в верхней части отчета появляется строка с выбором Склада и впереди галочка.

Можно ли как-то запретить снятие с параметра этой галочки, чтобы она всегда была активна и пользователь не мог ее снять?

Извините, поспешил... в параметрах СКД на этот параметр установил Использование : всегда
Просмотров: 51, оставить комментарий   
Обробка "Обмін з банком" для БУ 2.0 [раздел Отчеты / Обработки]
Автор Petre — 26.04.17, 9:57 — 1 комментариев
Обробка "Обмін з банком" для конфігурації "Бухгалтерія для України" ред. 2.0

Основні функції:
- завантаження даних банківської виписки;
- створення документів надходження та вибуття за банківським рахунком;
- створення контрагентів та банківських рахунків;
- формування шаблонів платежів для створення документів.

Додано допоміжну обробку читання файлу виписки "Аваль".

Обробка безкоштовна. Код обробки злегка обфусковано.
Обробка у стадії тестування, про помилки та пропозиції повідомляйте розробника (контакти - у "readme.txt").
Прикрепленные файлы
Прикрепленный файл  ObminZBankom31_pro1c.zip ( 70,36 килобайт ) Кол-во скачиваний: 10
 
Просмотров: 60, последний комментарий от Vofka   
При пересчете обнаружен нулевой курс [раздел 1С Управление Торговым Предприятием 8]
Автор bestnamebest — 25.04.17, 15:21 — 1 комментариев
1С:Предприятие 8.3 (8.3.10.2168)
"Управление торговым предприятием для Украины", редакция 1.2.
Разработка конфигурации: "ABBYY Ukraine", 2007-2017 (1.2.41.1)

Здравствуйте.

Документ закрытие месяца. Действие - Переоценка валютных средств.
Ругается в служебных сообщениях:
ПересчитатьИзВалютыВВалюту(): при пересчете обнаружен нулевой курс.

Валюта в регистре есть, курс указан.
В регистре бухгалтерии строка:

[необходимо зарегистрироваться для просмотра ссылки]

Я так понимаю, из-за того, что не указана валюта в первой строке, поэтому и ругается. Но узнать бы еще, исходя из какого документа, закрытие месяца делает эту проводку...
Просмотров: 104, последний комментарий от bestnamebest   
Налоговая накладная (проблема округления) [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Vidocq05 — 25.04.17, 14:58 — 3 комментариев
УТП 1.2.41.1 Платформа 8.2

Похожая тема уже подымалась но решения вроде как нет.

Привожу пример:
Выгружаю налоговую накладную в XML, в ней есть строка
Номенклатура - ТоварТакойто
Количество - 546 шт.
Сумма - 3261,23
Цена - 5,97 (Сумма/Количество = 5,972948717948718 округленное до 2-го знака после запятой)

Отправляем в налоговую.
Возвращается ошибка (дословно не помню), типа после проверки 5,97*546=3259,62, а переданная сумма 3261,23. Превышает допустимое отклонение в 1 грн.

Кто как решил?
Размышляю над разбиением строк при выгрузке в XML.
Просмотров: 95, последний комментарий от Petre   
Взаиморасчеты по документам расчетов в документе ГТД импорт [раздел 1С Управление Торговым Предприятием 8]
Автор Gazulo — 25.04.17, 14:42 — 0 комментариев
Добрый день. Конфигурация Управление торговым предприятием 1.2.41.1.
Почему документ ГТД импорт не делает проводок по регистру "Взаиморасчеты с контрагентами по документам расчетов". В конфигурации даже нет этого документа в регистраторах регистра.
Просмотров: 57, оставить комментарий   
Кнопка командной панели [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор EritikWoW — 25.04.17, 14:25 — 9 комментариев
1С:Предприятие 8.3 (8.3.6.2449)
"Управление торговлей для Украины" (2.3.25.1)

Сопсно задача создать 1 универсальную кнопку для всех документов которая изменяла бы данные общего реквезита тип булево на истину или ложъ
Создал свой общий модуль и вызываю процедуры в нем из общего модуля к которому обращаются все документы....
Теперь сама суть... если кнопке задать ту же процедуру то вылетает ошибка о том что данное имя не уникально.... я не хочу сильно грубить други модуля... хотел обойтись только вставкой одной строки на обращение к моей процедуре...

Что я хотел уточнить.... ну 1. Привести в порядок код (глазом человека который в этом шарит) что 2. Можно ли как кнопке КП передать процедуру не из формы а из моего модуля или хотя бы просто "Выгружать = Истина\ложъ" ?




Процедура ПриОткрытии (объект) Экспорт 
    
    НазваниеДокумента = Метаданные.НайтиПоТипу(ТипЗнч(объект)).Имя;
    ИндДок = Метаданные.Документы.Найти(НазваниеДокумента);
    ИмяФормы = ИндДок.Формы.ФормаДокумента.Имя;
    НД = ВРег(НазваниеДокумента);
    КолвоСим = СтрДлина(НазваниеДокумента);
    Форма = объект.ПолучитьФорму(ИмяФормы);
    КоличествоЭлементов = Форма.ЭлементыФормы.Количество();
    
    Для Каждого Док из Документы Цикл
    НазвДок = Прав(Док,КолвоСим);
    НазвДок = ВРег(НазвДок);
        Если НазвДок = НД ТОгда
            Форма1 = Док.ПолучитьФорму(ИмяФормы);
            КолЭлем = Форма1.ЭлементыФормы.Количество();
        КонецЕсли;        
    КонецЦикла;    
    
    
    
    Если Форма.ЭлементыФормы.ДействияФормы.Кнопки.Найти("Выгружать") = Неопределено Тогда
    КП = Форма.ЭлементыФормы.ДействияФормы.Кнопки;    
    инд = КП.Количество();
    ПодМенюВыгружать = КП.Вставить(инд,"Выгружать", ТипКнопкиКоманднойПанели.Подменю, "Выгружать");
    ПодМенюВыгружать.Отображение = ОтображениеКнопкиКоманднойПанели.НадписьКартинка;
        
    ДействиеКнопкиДа = Новый Действие ("ПриОткрытии");
    ДействиеКнопкиНет = Новый Действие ("УстановитьКнопкиПодменюЗаполненияТЧ");


    индкн = ПодМенюВыгружать.Кнопки.Количество();
    ПодМенюВыгружать.Кнопки.Вставить(индкн,"Да", ТипКнопкиКоманднойПанели.Действие,"Да",ДействиеКнопкиДа);
    ПодМенюВыгружать.Кнопки.Да.Картинка = БиблиотекаКартинок.Галочка;
    ПодМенюВыгружать.Кнопки.Да.Отображение = ОтображениеКнопкиКоманднойПанели.НадписьКартинка;
        
    ПодМенюВыгружать.Кнопки.Вставить(индкн+1,"Нет", ТипКнопкиКоманднойПанели.Действие,"Нет",ДействиеКнопкиНет);
    ПодМенюВыгружать.Кнопки.Нет.Картинка = БиблиотекаКартинок.Крест;
    ПодМенюВыгружать.Кнопки.Нет.Отображение = ОтображениеКнопкиКоманднойПанели.НадписьКартинка;
    КонецЕсли;
    
КонецПроцедуры    

Процедура Выгружать(Форма)Экспорт
    
    НазваниеДокумента = Метаданные.НайтиПоТипу(ТипЗнч(Форма)).Имя;
    ИндДок = Метаданные.Документы.Найти(НазваниеДокумента);
    ИмяФормы = ИндДок.Формы.ФормаДокумента.Имя;
    Форма1 = Форма.ПолучитьФорму(ИмяФормы);                                                  
    
    Форма1.Выгрузка = Истина;
    КП = Форма1.ЭлементыФормы.ДействияФормы.Кнопки;
    КП.Выгружать.Картинка = БиблиотекаКартинок.Галочка;
    
КонецПроцедуры

Процедура НеВыгружать(Форма)Экспорт
    НазваниеДокумента = Метаданные.НайтиПоТипу(ТипЗнч(Форма.ДокументОбъект.Ссылка)).Имя;
    ИндДок = Метаданные.Документы.Найти(НазваниеДокумента);
    ИмяФормы = ИндДок.Формы.ФормаДокумента.Имя;
    Форма1 = Форма.ПолучитьФорму(ИмяФормы);
    Форма1.Выгрузка = Ложь;
    
    КП = Форма1.ЭлементыФормы.ДействияФормы.Кнопки;
    КП.Выгружать.Картинка = БиблиотекаКартинок.Крест;
    
    //Shell = Новый COMОбъект("WScript.Shell");
    //НажатиеМышки = shell.run("rundll32.exe user32.dll, mouse_event 1", 1, "true");

КонецПроцедуры
Просмотров: 142, последний комментарий от EritikWoW   
рассылка документов из 1С по контрагентам [раздел Программирование в 1С Предприятие 8.3]
Автор A.Frost89 — 25.04.17, 13:56 — 4 комментариев
Добрый день. Бухгалтерия предприятия КОРП 3.0.49.23 . Есть обработка, которая отправляет документы - акт об оказании услуг, счета-фактуры, счета на оплату покупателей, контрагентам - списку либо единичным. Документы сохраняются в формате pdf, учетная запись используется 1С-ная настроенная. Все бы ничего, но при отправке документов контрагентам, сколько документов было выбрано для отправки, столько писем на почтовый адрес и приходит. Что не есть хорошо. Как сделать так, чтобы одному контрагенту, приходило одно письмо с вложенными документами, сколько бы их там не было выбрано?
p.s. Прикладываю [необходимо зарегистрироваться для просмотра ссылки].честно, она не моя. счета кое-как подправил под себя. их цепляет и отправляет. а при выборе акта, наблюдаются проблемы. видимо из-за изменения конфы. но надеюсь что подправлю со временем.
p.p.s. в программировании начинающий,так что учусь, просьба не ругаться если буду тупить. Буду рад любой помощи/подсказке/совету.
Просмотров: 135, последний комментарий от Bernet   
Залипла дата в документах [раздел Программирование управляемых форм 1С 8.2]
Автор kot488 — 25.04.17, 12:54 — 10 комментариев
Есть в самописной базе документ. В нем есть кнопка заполнить с помощью которой в него заполняются все определенные документы указанного типа. На скрине документ правильный, с правильными датами. Но дата в заголовке почему то 03.04.2017


Это под моей учетной записью.
А у некоторых пользователей, в этом документе отображается дата что документы созданы 03.04


Хотя если зайти в сам документ то в нем правильная дата, 23.04. И даже документы от 31.03 пользователю показывает как 03.04

Что за глюк? Кеш почистил


и все новые документы тоже создаются с датой 03.04
Просмотров: 133, последний комментарий от kot488   
Оплата дней командировки — по средней или дневной зарплате? [раздел 1С Управление Торговым Предприятием 8]
Автор Gazulo — 25.04.17, 11:42 — 2 комментариев
Добрый день.

При направлении работника в командировку необходимо рассчитать среднюю заработную плату за дни командировки и сравнить ее с заработной платой работника, которая была бы начислена на основании трудового или коллективного договора. Соответственно, к выплате будет подлежать большая из них.

В дневной заработок работника, который должен сравниваться со среднедневным заработком, при оплате периода командировки включаются все составляющие заработной платы, которые работник получает согласно условиям трудового, коллективного договора в месяце, в котором его направляют в командировку: оклад, доплаты, надбавки, премии, индексация и т. п.



Как это реализовано в конфигурации УТП?


 ! 

Правила: 3, 5
 
Просмотров: 85, последний комментарий от Gazulo   
Закрытие заказов покупателей: снятие с резерва [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 25.04.17, 11:30 — 7 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

На сколько я понял, автоматически снятие с резерва товаров не предусмотрено.
В связи с этим, можно ли с документом "Закрытие заказов покупателей" сделать буквально следующее:

Т.к. планируется выполнять только определенный алгоритм действий, то можно ли при открытии этого документа, если он новый,
программно настроить все опции.

Т.е. Операция: снятие с резервов.
И автоматически заполнить все заказы, требующие снятия с резервов без захода на посадку в меню "Заполнить" с выбором определенных опций.

Ну или другой вариант программирования снятия резервов со склада?
Просмотров: 104, последний комментарий от Petre   
Начисление зарплаты(Копм.обл. для бюдж. орган. 2.1) [раздел Остальные конфигурации 1С 8]
Автор Юля — 25.04.17, 11:01 — 0 комментариев
Привет, в приеме на работу сотруднику, на закладке "Оплата", ставлю оклад 2800, вид тарифного разряда "Помесячной оклад". Но когда начисляю зарплату, не рассчитывает. Но когда ставлю вид тарифного разряда "Месячной оклад по часам" , все хорошо, рассчитывает. В чем ошибка?
Просмотров: 81, оставить комментарий   
Условное оформление формы динамического списка [раздел Программирование управляемых форм 1С 8.2]
Автор RomarioMen — 24.04.17, 11:18 — 6 комментариев
1С 8.2 УНФ для Украины. Редакция 1,3.
Всем привет! Установил условное оформление дин. списка в конфигураторе, но оно работает только в пользователей с полными правами.
В ост. все красит одним цветом. Подскажите, плиз, куда смотреть?
Просмотров: 161, последний комментарий от logist   
Как определить, что база запущена на андроиде? [раздел Мобильная платформа 1С]
Автор Gavrila — 21.04.17, 23:36 — 8 комментариев
Есть самописная небольшая база. Работает на веб-клиенте.
Хочу ее адаптировать под планшет. Подскажите, как определить при запуске, программа запущена на андроиде или на веб-клиенте?
В идеале хотелось бы режим запуска сохранить в параметрах сеанса
Просмотров: 210, последний комментарий от logist   
Стоимость часа 1С-ника [раздел Тематическое общение]
Автор rotting — 21.04.17, 17:08 — 25 комментариев
Задумался не мало ли я беру денег за работу. Сам беру 450 грн/час (~$15). Хотел бы устроить небольшой опрос. Сколько вы берете за час работы (Киев)?
Просмотров: 596, последний комментарий от XBrut   
Форма выбора для формы Отбора и Сортировки [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 21.04.17, 15:39 — 4 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Для справочников, возможно создать несколько форм выбора и наложить на них какие-либо условия при открытии, например для фильтрации вывода на экран с ограничениями...

Для склада сделал 2-е формы отбора: Основная (с фильтрацией) и "ФормаВыбораВсе" (без каких либо ограничений)

Просматриваю список документов "Перемещение товаров". Там имеется склад Отправитель и склад Получатель.
На склад Отправитель поставлена форма выбора Основная (с фильтрацией), на склад Получатель - форма выбора "ФормаВыбораВсе", т.е. без ограничений с возможностью выбрать любой склад...

Это все нормально, но вот столкнулся с такой проблемой...

В списке документов Перемещений требуется открыть форму "Отбор и Сортировка" и проводить там фильтрацию по обоим типам складов.

При открытии в "Отборе и Сортировки" склада Отправитель отрабатывает основная форма выбора склада с ограничением - это так и правильно...
При открытии склада "Получатель" тоже открывается основная форма выбора, что по условиям задачи - не правильно: нужно открытие формы "ФормаВыбораВсе"...

В реквизитах и на всех формах документа Перемещения на склад Получатель поставил в свойство форма выбора - "ФормаВыбораВсе", но открывает все равно основную...

Каким образом в форме "Отбор и Сортировка" можно прописать при отборе нужную форму отбора справочников??? Я так понял, что используется основная форма отбора справочника...
Просмотров: 180, последний комментарий от Constantus   
RSS Текстовая версия Сейчас: 28.04.17, 6:14
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне