Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Автоматично зміна схеми реалізації          
Sirius83 Подменю пользователя
сообщение 09.07.20, 15:32
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 44
Спасибо сказали: 1 раз
Рейтинг: 1

Доброго дня!
Платформа 1С:Підприємство 8.3 (8.3.10.2252)
"Управление производственным предприятием для Украины", редакция 1.3 (1.3.53.1)

В документі реалізації (РеализацияТоваровУслуг) бухгалтера вручну міняють схему реалізації, прийнято рішення встановити потрібну схему ("Камінь", замість "Продукція") у регістрі відомостей.


Поміняли результат - відсутній, тобто як було Схема "Продукція" так і залишилась... Далі цікавіше..

Отладчиком дивлюсь звідки отримуємо значення і бачу, що заповнюється воно жостко в СпільнийМодуль.СчетаУчетаВДокументах
Функция ПолучитьСтруктуруСчетовУчета(Номенклатура, ТаблицаСчетовУчета, ХозяйственнаяСитуация)
    
    СтруктураСчетовУчета     = ПодготовитьСтруктуруСчетовУчета();
    
    УстановленныеСчета         = ТаблицаСчетовУчета.Найти(Номенклатура, "Номенклатура");
    
    СтруктураСчетовУчета.ХозяйственнаяСитуация = ХозяйственнаяСитуация;
    
    Если УстановленныеСчета <> Неопределено Тогда
    
        //Дополним установленными счетами
        СтруктураСчетовУчета.СчетУчетаБУ                    = УстановленныеСчета.СчетУчетаБУ;
        
        СтруктураСчетовУчета.ПринадлежностьНоменклатуры        = УстановленныеСчета.ПринадлежностьНоменклатуры;
        СтруктураСчетовУчета.СчетЗатрат                           = УстановленныеСчета.СчетЗатрат;
        СтруктураСчетовУчета.НалоговоеНазначение               = УстановленныеСчета.НалоговоеНазначение;
        СтруктураСчетовУчета.НалоговоеНазначениеДоходовИЗатрат = УстановленныеСчета.НалоговоеНазначениеДоходовИЗатрат;
        СтруктураСчетовУчета.ОпределятьИзНГЗатрат               = УстановленныеСчета.ОпределятьИзНГЗатрат;
        //Счета, зависящие от установленных        
        
        Если Не УстановленныеСчета.Номенклатура.Услуга Тогда
            
            Если ЗначениеЗаполнено(УстановленныеСчета.СчетУчетаБУ) Тогда            
                Если УстановленныеСчета.СчетУчетаБУ.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.ПроизводственныеЗапасы) или УстановленныеСчета.СчетУчетаБУ = (ПланыСчетов.Хозрасчетный.ПроизводственныеЗапасы) Тогда
                    СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.ПроизводственныеЗапасы;
                ИначеЕсли УстановленныеСчета.СчетУчетаБУ.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.Полуфабрикаты) или УстановленныеСчета.СчетУчетаБУ=(ПланыСчетов.Хозрасчетный.Полуфабрикаты) Тогда
                    СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.ПроизводственныеЗапасы;
                ИначеЕсли УстановленныеСчета.СчетУчетаБУ.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.ГотоваяПродукция) или УстановленныеСчета.СчетУчетаБУ=(ПланыСчетов.Хозрасчетный.ГотоваяПродукция) Тогда
                    СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.Продукция; [highlight][b]//Здесь полюбому почучаем Схему "Продукция"!!!!!!!???????[/b][/highlight]
                ИначеЕсли УстановленныеСчета.СчетУчетаБУ.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.МалоценныеИБыстроизнашивающиесяПредметы) или УстановленныеСчета.СчетУчетаБУ = (ПланыСчетов.Хозрасчетный.МалоценныеИБыстроизнашивающиесяПредметы) Тогда
                    СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.Товары;
                ИначеЕсли УстановленныеСчета.СчетУчетаБУ.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.Товары) Тогда
                    СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.Товары;  
                ИначеЕсли  УстановленныеСчета.СчетУчетаБУ.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.КапитальныеИнвестиции) или УстановленныеСчета.СчетУчетаБУ = (ПланыСчетов.Хозрасчетный.КапитальныеИнвестиции) Тогда
                    СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.Товары;
                КонецЕсли;
            КонецЕсли;
        Иначе
            СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.Услуги;        
        КонецЕсли;      
        
        
        //Если основной счет учета запасов - забалансовый,
        //то он будет использоваться в качестве счета учета принятых товаров.
        Если БухгалтерскийУчетПовтИсп.ЗабалансовыйСчет(СтруктураСчетовУчета.СчетУчетаБУ) Тогда
            СтруктураСчетовУчета.ПринятыеСчетУчетаБУ = СтруктураСчетовУчета.СчетУчетаБУ;
            СтруктураСчетовУчета.СчетУчетаДавСырья  = СтруктураСчетовУчета.СчетУчетаБУ;
        КонецЕсли;        
        
    КонецЕсли;
    
    Возврат СтруктураСчетовУчета;
    
КонецФункции


Це ще не все. Коли розраховую вираз "Справочники.СхемыРеализации" отримуємо:


А де решту записів довідника з першого скріна???
Допоможіть розібратися.

Сообщение отредактировал Vofka - 09.07.20, 16:04

denis84 Подменю пользователя
сообщение 09.07.20, 15:45
Сообщение #2

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 161
Из: Украина
Спасибо сказали: 42 раз
Рейтинг: 42

Sirius83 @ Сегодня, 16:32 * ,
Добрий день! Зараз в себе в УПП 1.3 (демо). Поставивив, як у Вас на першому скрині для продукції (рахунок 26) схему реалізації відміну від "продукція" і в мене сформовані проводки по моїй схемі реалізації. Чи я Вас не правильно зрозумів?

Одне,що можу сказати конфігурація застара 1.3.15.6, а платформа 8.3.13.1513.

Сообщение отредактировал denis84 - 09.07.20, 15:50

Vofka Подменю пользователя
сообщение 09.07.20, 16:09
Сообщение #3

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13374
Из: Киев
Спасибо сказали: 4123 раз
Рейтинг: 3265.6

Цитата(Sirius83 @ 09.07.20, 16:32) *
А де решту записів довідника з першого скріна???

Тут показываются только предопределенные элементы.

Макс1С Подменю пользователя
сообщение 09.07.20, 21:13
Сообщение #4

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 163
Из: Днепр
Спасибо сказали: 53 раз
Рейтинг: 50.6

Sirius83 @ Сегодня, 16:32 * ,
После смены схемы реализации новая будет подставляться только в новые документы. Если и в новые подставляется "Продукция", нужно смотреть более уточненные записи в регистре: например если есть такая же запись, но с заполненными складом/организацией/конкретной номенклатурой, то сработает та запись в которой большинство полей совпадает с документом, а не стоит <Для всех...>

Sirius83 Подменю пользователя
сообщение 10.07.20, 7:53
Сообщение #5

Общительный
**
Группа: Пользователи
Сообщений: 44
Спасибо сказали: 1 раз
Рейтинг: 1

Цитата(denis84 @ 09.07.20, 16:45) *
Одне,що можу сказати конфігурація застара 1.3.15.6, а платформа 8.3.13.1513.

В новій платформі та конфігурації теж саме (поставив паралельно).

Цитата(Vofka @ 09.07.20, 17:09) *
Тут показываются только предопределенные элементы.

Ось не можу зрозуміти чому відображаються тільки предопределенные елементи??? Довідник має і інші елементи.

Цитата(Макс1С @ 09.07.20, 22:13) *
После смены схемы реализации новая будет подставляться только в новые документы.

Не буде проставлятись в нових документах нова схема, оскільки при фрормуванні документа РеализауияТоваровУслуг в коді жостко получаемо назву схеми незалежно що заповнено в регістрі.
 СтруктураСчетовУчета.СхемаРеализации = Справочники.СхемыРеализации.Продукция; //Здесь полюбому почучаем Схему "Продукция"!!!!!!!


Vofka Подменю пользователя
сообщение 10.07.20, 8:22
Сообщение #6

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13374
Из: Киев
Спасибо сказали: 4123 раз
Рейтинг: 3265.6

Цитата(Sirius83 @ 10.07.20, 8:53) *
Ось не можу зрозуміти чому відображаються тільки предопределенные елементи??? Довідник має і інші елементи.

А понимаете почему в конфигураторе только к предопределенному элементу можно обратиться через Справочники.СхемыРеализации.Товары?

TohaMonster Подменю пользователя
сообщение 10.07.20, 8:44
Сообщение #7

Общительный
**
Группа: Пользователи
Сообщений: 34
Спасибо сказали: 17 раз
Рейтинг: 17

В УПП есть прикол, связанный с документом "УстановкаПараметровУчетаНоменклатуры". Вот если он у Вас в системе заведен, то Ваши настройки счетов в регистре до лампочки. Некоторые подробности - [необходимо зарегистрироваться для просмотра ссылки]. Общий смысл: "С даты первого проведенного документа «Установка параметров учета номенклатуры» будет действовать режим определения счетов при проведении документов.". Причем, в этом документе нет схемы реализации, но Система считает, что она её и так определит (в указанной Вами процедуре)
В модуле СчетаУчетаВДокументах ето зашито примерно тут:
Функция ПолучитьСчетаУчетаНоменклатурыИзНастроек(Организация, Номенклатура, Склад, Дата, ХозяйственнаяСитуация = "") Экспорт

    Если ИспользоватьОпределениеСчетовПриПроведенииДокументов(Дата) Тогда
        
        УстановленныеСчета         = ПолучитьСчетаУчетаНоменклатурыИзДокумента(Организация, Дата, Номенклатура);
        СтруктураСчетовУчета    = ПолучитьСтруктуруСчетовУчета(Номенклатура, УстановленныеСчета, ХозяйственнаяСитуация);
        
    Иначе
        
...            
            УстановленныеСчета     = ПолучитьСчетаУчетаНоменклатурыИзРегистраСведений(Организация, Номенклатура, Склад);
            
...
    
    КонецЕсли;
    
    Возврат СтруктураСчетовУчета;
    
КонецФункции

Нужные нам счета из регистра сведений получаются, если не срабатывает "ИспользоватьОпределениеСчетовПриПроведенииДокументов"

Лично я считаю эту фишку вредной и никогда не использую

Совет такой:
1. Убедитесь, что у Вас в системе есть документ "УстановкаПараметровУчетаНоменклатуры". Перенесите его на какую-то дату, которая больше даты Вашего документа
2. Перезайдите в Базу(!это нужно сделать, параметр кэшируется). Попробуйте в документе перевыбрать Номенклатуру. Должна подставиться нужная Вам схема реализации
3. Если нет такого документа или не подставилась схема, тогда я не знаю smile.gif

denis84 Подменю пользователя
сообщение 10.07.20, 8:45
Сообщение #8

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 161
Из: Украина
Спасибо сказали: 42 раз
Рейтинг: 42

Sirius83 @ Вчера, 16:32 * ,

Добрый день! В новых документах при выборе номенклатуры со счетом учета 26 и с выбранной схемой реализации в УПП (демо) все работает. Как сказал Макс1С, у Вас в регистре значит есть ещё какие-то записи для продукции.

Вот мой регистр сведений счета учета:


Вот документ:


Вот проводки по этой схеме:


Sirius83 Подменю пользователя
сообщение 13.07.20, 10:42
Сообщение #9

Общительный
**
Группа: Пользователи
Сообщений: 44
Спасибо сказали: 1 раз
Рейтинг: 1

Цитата(TohaMonster @ 10.07.20, 9:44) *
Совет такой:
1. Убедитесь, что у Вас в системе есть документ "УстановкаПараметровУчетаНоменклатуры". Перенесите его на какую-то дату, которая больше даты Вашего документа
2. Перезайдите в Базу(!это нужно сделать, параметр кэшируется). Попробуйте в документе перевыбрать Номенклатуру. Должна подставиться нужная Вам схема реализации

Таки так - є документ, щоправда думав, що він регулює автозаповнення в документах по рахунку, а не схему реазізації. Адже, в ньому ніде не вказується відповідність схеми реалізації до виду номенклатури.

Цитата(denis84 @ 10.07.20, 9:45) *
В новых документах при выборе номенклатуры со счетом учета 26 и с выбранной схемой реализации в УПП (демо) все работает. Как сказал Макс1С, у Вас в регистре значит есть ещё какие-то записи для продукции.


Всі записи регістру відображені в 1-му пості на скріншоті. В дійсності документ "Установка параметров учета номенклатуры" встановлює не тільки автозаповнення: виду номенклатури, податкове призначення, але ще й фіксує предопределенные значення схем реалізації.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 31.10.20, 12:05
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!