Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Значение реквизита формы (флажок - булево)          
DartRomanius Подменю пользователя
сообщение 21.02.11, 11:23
Сообщение #1

Ветеран
Иконка группы
Группа: Местный
Сообщений: 824
Из: Запорожье
Спасибо сказали: 145 раз
Рейтинг: 72

Доброго времени суток.

Есть управляемая форма
на ней есть реквизит (булево) в виде ПолеФлажка

Вопрос: как узнать состояние флажка. Лезть на сервер к данным, или в управляемой форме как-то можно получить?

ЗЫ: Мозги уже в гипсу от 8.2 smile.gif

Спасибо.


Signature
-----------------------------------------------------------------------------------
Единственный, интуитивно понятный интерфейс - мамкина сиська!
Всему остальному надо учиться! (с) Не знаю кто....


DartRomanius Подменю пользователя
сообщение 21.02.11, 12:28
Сообщение #2

Ветеран
Иконка группы
Группа: Местный
Сообщений: 824
Из: Запорожье
Спасибо сказали: 145 раз
Рейтинг: 72

Пока решил таким методом.
&НаСервере
Функция ВозвратФлага()
    Возврат Объект.Флаг;
КонецФункции


&НаКлиенте
Процедура УстановитьВидимость()
    
    Если ВозвратФлага() Тогда
        Элементы.Группа1.Видимость = Истина;
    Иначе
        Элементы.Группа1.Видимость = Ложь;
    КонецЕсли;
КонецПроцедуры


но при изменении 2 обращения к серверу. sad.gif
И как его победить?


Signature
-----------------------------------------------------------------------------------
Единственный, интуитивно понятный интерфейс - мамкина сиська!
Всему остальному надо учиться! (с) Не знаю кто....

pablo Подменю пользователя
сообщение 23.02.11, 13:55
Сообщение #3

Старейшина
********
Группа: Команда (модераторы)
Сообщений: 1116
Из: Одесса-Луганск
Спасибо сказали: 191 раз
Рейтинг: 148.9

Реквизит чей? Объекта, которому принадлежит форма или самой формы?


Signature
Правильно поставленный вопрос содержит до 90% ответа.

DartRomanius Подменю пользователя
сообщение 23.02.11, 14:38
Сообщение #4

Ветеран
Иконка группы
Группа: Местный
Сообщений: 824
Из: Запорожье
Спасибо сказали: 145 раз
Рейтинг: 72

Цитата(pablo @ 23.02.11, 14:55) *
Реквизит чей? Объекта, которому принадлежит форма или самой формы?


Реквизита объекта.
Но этот реквизит так-же выводится на форму в виде Поле-Флажка.

Вопрос стоял в том как получить значение этого самого флажка, чтоб не обращаться на сервер
за значением самого реквизита объекта.

Как-то так...


Signature
-----------------------------------------------------------------------------------
Единственный, интуитивно понятный интерфейс - мамкина сиська!
Всему остальному надо учиться! (с) Не знаю кто....

DartRomanius Подменю пользователя
сообщение 23.02.11, 14:42
Сообщение #5

Ветеран
Иконка группы
Группа: Местный
Сообщений: 824
Из: Запорожье
Спасибо сказали: 145 раз
Рейтинг: 72

Цитата(DartRomanius @ 23.02.11, 15:38) *
Реквизита объекта.
Но этот реквизит так-же выводится на форму в виде Поле-Флажка.

Вопрос стоял в том как получить значение этого самого флажка, чтоб не обращаться на сервер
за значением самого реквизита объекта.

Как-то так...


В догонку.

Если есть реквизит (формы) ссылающийся на реквизит (объекта) другого типа, там где есть строковые данные,
то доступно свойство реквизита (формы) "ТекстРедактирования". Мне его как правило достаточно, а в данном случае....


Signature
-----------------------------------------------------------------------------------
Единственный, интуитивно понятный интерфейс - мамкина сиська!
Всему остальному надо учиться! (с) Не знаю кто....

pablo Подменю пользователя
сообщение 23.02.11, 15:27
Сообщение #6

Старейшина
********
Группа: Команда (модераторы)
Сообщений: 1116
Из: Одесса-Луганск
Спасибо сказали: 191 раз
Рейтинг: 148.9

Вообще-то форме, принадлежащей объекту, доступен сам Объект и его реквизиты. Другое дело, когда нужен доступ к реквизитам реквизитов, тогда нужно обращаться на сервер. Применительно же к Вашему случаю, достаточно такого кода:

  Если Объект.Флаг Тогда
        Элементы.Группа1.Видимость = Истина;
    Иначе
        Элементы.Группа1.Видимость = Ложь;
    КонецЕсли;


Signature
Правильно поставленный вопрос содержит до 90% ответа.

Спасибо сказали: DartRomanius,

DartRomanius Подменю пользователя
сообщение 23.02.11, 15:45
Сообщение #7

Ветеран
Иконка группы
Группа: Местный
Сообщений: 824
Из: Запорожье
Спасибо сказали: 145 раз
Рейтинг: 72

Цитата(pablo @ 23.02.11, 16:27) *
Вообще-то форме, принадлежащей объекту, доступен сам Объект и его реквизиты. Другое дело, когда нужен доступ к реквизитам реквизитов, тогда нужно обращаться на сервер. Применительно же к Вашему случаю, достаточно такого кода:

Если Объект.Флаг Тогда
Элементы.Группа1.Видимость = Истина;
Иначе
Элементы.Группа1.Видимость = Ложь;
КонецЕсли;


Технически вышло где-то так:
&НаКлиенте
Процедура БлаБла()
     Элементы.Группа1.Видимость = Объект.Флаг;
КонецПроцедуры


Вроде на сервак не бегаеть... smile.gif
Спасибо.


Signature
-----------------------------------------------------------------------------------
Единственный, интуитивно понятный интерфейс - мамкина сиська!
Всему остальному надо учиться! (с) Не знаю кто....

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 17.09.21, 14:12
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!