Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Запретить очистку поля ввода, если ссылка в поле не помечена на удаление          
Constantus Подменю пользователя
сообщение 01.06.20, 14:45
Сообщение #1

Ветеран
*******
Группа: Пользователи
Сообщений: 903
Спасибо сказали: 7 раз
Рейтинг: 6

Приветствую, Форумчане!
1с8.3.12, самопис, УФ

Имеется некая форма с реквизитом "ЗаказОснование"
На форме оформлен полем ввода

Требуется запретить провести очистку этого поля (кнопка Х), есди "ЗаказОснование" не помечен на удаление"

Поробовал код:

&НаКлиенте
Процедура ЗаказОснованиеОчистка(Элемент, СтандартнаяОбработка)
    ЗаказОснованиеОчисткаНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗаказОснованиеОчисткаНаСервере()
    // Вставить содержимое обработчика.
    СтандартнаяОбработка = Ложь;
    Док = Объект.ЗаказОснование.ПолучитьОбъект();
    Если НЕ Док.ПометкаУдаления Тогда
        Сообщить("Удаление не возможно, т.к. документ заказа создан и не помечен на удаление...");
        Объект.ЗаказОснование = Док;
    Иначе
        
    КонецЕсли;    
    
КонецПроцедуры


Как бы работает, но естественно некорректно.
Как правильно запретить очистку поля, если ссылка в этом поле не помечена на удаление

sava1 Подменю пользователя
сообщение 01.06.20, 14:53
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2295
Из: Проскуров
Спасибо сказали: 547 раз
Рейтинг: 534.4

запоминать занчение - При Изменении - проверять - восстанавливать значение, которое запомнили

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 08.07.20, 2:42
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!