Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Вывод факсимилей и печати на каждом листе печатной формы документа          
denis84 Подменю пользователя
сообщение 08.11.22, 14:05
Сообщение #1

Оратор
Иконка группы
Группа: Местный
Сообщений: 315
Из: Украина
Спасибо сказали: 93 раз
Рейтинг: 93

Доброго дня! Занимаюсь разработкой ВПФ договора из документа "Реализация товаров и услуг" в конфигурации "Бухгалтерия для Украины 2.0.22.1. Добавил 2 картинки куда помещаються печать и подпись организации.

В макете есть области "телодоговора" и "подвал" так вот в подвале выводит, а вот в "телодоговора" не отображает эти картинки! Подскажите, как это побороть?

Bernet Подменю пользователя
сообщение 08.11.22, 17:42
Сообщение #2

Ветеран
Иконка группы
Группа: Местный
Сообщений: 848
Из: Місто щасливих людей
Спасибо сказали: 296 раз
Рейтинг: 245.9

denis84 @ Сегодня, 14:05 * ,
Проверьте влазит ли картинка в вашу область (не выходит ли за рамки области)


Signature
Дописываю конфигурации на платформе 8.х.
- Управление торговым предприятием для Украины
- Управление производственным предприятием для Украины
- Управление небольшой фирмой для Украины
- Бухгалтерия для Украины;
- Общепит для Украины
- Ресторан (Рарус)
- Розница

denis84 Подменю пользователя
сообщение 09.11.22, 9:52
Сообщение #3

Оратор
Иконка группы
Группа: Местный
Сообщений: 315
Из: Украина
Спасибо сказали: 93 раз
Рейтинг: 93

Цитата(Bernet @ 08.11.22, 17:42) *
Проверьте влазит ли картинка в вашу область (не выходит ли за рамки области)

не выходят за рамки области.

В макете всего 2 области "ТелоДоговора" и "ПечатьИПодписи". в области "ПечатьИПодписи" 2 картинки "печать" и "подпись" организации. Хочу добиться чтобы на каждом листе договора выводило эти картинки. ПроверитьВывод почему то не дает результата, выводит на последнем листе.

Вот код:

ТабличныйДокумент = Новый ТабличныйДокумент;
    ТабличныйДокумент.АвтоМасштаб            = Истина;
    ТабличныйДокумент.ОриентацияСтраницы    = ОриентацияСтраницы.Портрет;

    Макет = ПолучитьМакет("ПФ_MXL_ДоговорБезНДС");

    ПервыйДокумент = Истина;
    
    Для каждого Ссылка Из МассивОбъектов Цикл    
        
        Если Не ПервыйДокумент Тогда
            ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;
        ПервыйДокумент = Ложь;
        // Запомним номер строки, с которой начали выводить текущий документ.
        НомерСтрокиНачало = ТабличныйДокумент.ВысотаТаблицы + 1;
        
        ЗапросШапка.УстановитьПараметр("ТекущийДокумент", Ссылка);
        Шапка = ЗапросШапка.Выполнить().Выбрать();
        Шапка.Следующий();
        
        УчитыватьНДС = УчетнаяПолитика.ПлательщикНДС(Шапка.Организация, Шапка.Дата);
        ОбластьТелоДоговора    = Макет.ПолучитьОбласть("ТелоДоговора");

        ОбластьТелоДоговора.Параметры.НомерДок        = Формат(Шапка.ДоговорКонтрагента.Номер,"Л=uk; ДЛФ=DD" );
        ОбластьТелоДоговора.Параметры.ДатаРеализации      = Формат(Шапка.ДоговорКонтрагента.Дата,"Л=uk; ДЛФ=DD" );

        СведенияОПоставщике = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата,,,);
        СведенияОПокупателе = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Покупатель, Шапка.Дата,,,);
        
        ОбластьТелоДоговора.Параметры.НаимПокупателя        = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПокупателе, "/,ПолноеНаименование,",,);
        ОбластьТелоДоговора.Параметры.НаимОрганизации    = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПоставщике, "/,ПолноеНаименование,",,);
        
        РуководителиОрганизации = ОтветственныеЛицаБП.ОтветственныеЛица(Шапка.Организация, Шапка.Дата);
        РуководителиКонтрагента = ОтветственныеЛицаБП.ОтветственныеЛицаКонтрагента(Шапка.Покупатель, Шапка.Дата);
        
        Если ЗначениеЗаполнено(РуководителиОрганизации.РуководительФИО) Тогда
            ОбластьТелоДоговора.Параметры.ФИОРуководитель             = ОбщегоНазначенияБПВызовСервера.ПолучитьФамилиюИмяОтчество(РуководителиОрганизации.РуководительФИО.Фамилия,
                                                                                                                            РуководителиОрганизации.РуководительФИО.Имя, РуководителиОрганизации.РуководительФИО.Отчество, Ложь);
        КонецЕсли;
        Если ЗначениеЗаполнено(РуководителиКонтрагента.РуководительФИО) Тогда
            ОбластьТелоДоговора.Параметры.ФИОРуководительПокупателя  = ОбщегоНазначенияБПВызовСервера.ПолучитьФамилиюИмяОтчество(РуководителиКонтрагента.РуководительФИО.Фамилия,
                                                                                                                             РуководителиКонтрагента.РуководительФИО.Имя, РуководителиКонтрагента.РуководительФИО.Отчество, Ложь);
        КонецЕсли;

        ОбластьТелоДоговора.Параметры.ПочтаОрганизации    = БухгалтерскийУчетПереопределяемый.ПолучитьEmailИзКонтактнойИнформации(Шапка.Организация);
        ОбластьТелоДоговора.Параметры.ПочтаПокупателя    = БухгалтерскийУчетПереопределяемый.ПолучитьEmailИзКонтактнойИнформации(Шапка.Покупатель);        

        ОбластьТелоДоговора.Параметры.НаимПокупателя            = Шапка.Покупатель.Наименование;
        ОбластьТелоДоговора.Параметры.НаимОрганизации            = Шапка.Организация.Наименование;

        ОбластьТелоДоговора.Параметры.ПочтовыйАдресПокупателя    = БухгалтерскийУчетПереопределяемый.ПолучитьАдресИзКонтактнойИнформации(Шапка.Покупатель,"Почтовый");
        ОбластьТелоДоговора.Параметры.ПочтовыйАдрес            = БухгалтерскийУчетПереопределяемый.ПолучитьАдресИзКонтактнойИнформации(Шапка.Организация,"Почтовый");
        
        ОбластьТелоДоговора.Параметры.ЮрАдресПокупателя        = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПокупателе, "/,ЮридическийАдрес,",,);
        ОбластьТелоДоговора.Параметры.ЮрАдрес                = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПоставщике, "/,ЮридическийАдрес,",,);
        ОбластьТелоДоговора.Параметры.ЕДРПОУПокупателя        = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПокупателе, "/,КодПоЕДРПОУ,",,);
        ОбластьТелоДоговора.Параметры.ЕДРПОУ                          = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПоставщике, "/,КодПоЕДРПОУ,",,);
        
        ОбластьТелоДоговора.Параметры.БанкПокупателя          = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПокупателе,  "/,НомерСчета,Банк,МФО,",,);
        ОбластьТелоДоговора.Параметры.Банк                            = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПоставщике,  "/,НомерСчета,Банк,МФО,",,);
        
        ОбластьТелоДоговора.Параметры.Телефон                = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПокупателе,  "/,Телефоны,",,);

        ОбластьТелоДоговора.Параметры.ИПН                    = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПокупателе,  "/,ИНН,",,);
        ОбластьТелоДоговора.Параметры.ИПНПокупателя           = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПоставщике,  "/,ИНН,",,);
        
        ОбластьТелоДоговора.Параметры.ПочтаОрганизации        = БухгалтерскийУчетПереопределяемый.ПолучитьEmailИзКонтактнойИнформации(Шапка.Организация);
        ОбластьТелоДоговора.Параметры.ПочтаПокупателя        = БухгалтерскийУчетПереопределяемый.ПолучитьEmailИзКонтактнойИнформации(Шапка.Покупатель);        
        //ТабличныйДокумент.Вывести(ОбластьТелоДоговора);
        
        ОбластьПодписи          = Макет.ПолучитьОбласть("ПечатьИПодпись");

        ДанныеКартинкиПечать  = РаботаСФайламиСлужебныйВызовСервера.ПолучитьДанныеФайлаИДвоичныеДанные(Шапка.ФайлФаксимильнаяПечать);
        ДанныеКартинкиПодпись = РаботаСФайламиСлужебныйВызовСервера.ПолучитьДанныеФайлаИДвоичныеДанные(Шапка.ФайлФаксимильнаяПодпись);
    
        Если Не ДанныеКартинкиПечать = Неопределено Тогда
            ОбластьПодписи.Области.Печать.Картинка = Новый Картинка(ДанныеКартинкиПечать.ДвоичныеДанные);    
        КонецЕсли;
        
        Если Не ДанныеКартинкиПодпись = Неопределено Тогда
            ОбластьПодписи.Области.Подпись.Картинка    = Новый Картинка(ДанныеКартинкиПодпись.ДвоичныеДанные);
        КонецЕсли;

        Если ЗначениеЗаполнено(РуководителиОрганизации.РуководительФИО) Тогда
            ОбластьПодписи.Параметры.Руководитель             = Лев(РуководителиОрганизации.РуководительФИО.Имя,1)+". "+Лев(РуководителиОрганизации.РуководительФИО.Отчество,1)+". "+РуководителиОрганизации.РуководительФИО.Фамилия;
        КонецЕсли;
        
        Если ЗначениеЗаполнено(РуководителиКонтрагента.РуководительФИО) Тогда
            ОбластьПодписи.Параметры.РуководительПокупателя  = Лев(РуководителиКонтрагента.РуководительФИО.Имя,1)+". "+Лев(РуководителиКонтрагента.РуководительФИО.Отчество,1)+". "+РуководителиКонтрагента.РуководительФИО.Фамилия;
        КонецЕсли;            
                
        СтрокаСПодвалом = Новый Массив; // создадим массив для проверки вывода
        СтрокаСПодвалом.Добавить(ОбластьТелоДоговора);
        СтрокаСПодвалом.Добавить(ОбластьПодписи);
        
        Если  НЕ ТабличныйДокумент.ПроверитьВывод(СтрокаСПодвалом)  Тогда
            ТабличныйДокумент.Вывести(ОбластьТелоДоговора);

            ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;
        УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабличныйДокумент,НомерСтрокиНачало, ОбъектыПечати, Ссылка);
    КонецЦикла;
    Возврат ТабличныйДокумент


натолкните на мысль. Знаю одно что, что-то делаю не так

Сообщение отредактировал denis84 - 09.11.22, 9:58

andreydv87 Подменю пользователя
сообщение 09.11.22, 15:55
Сообщение #4

Говорящий
***
Группа: Пользователи
Сообщений: 71
Спасибо сказали: 13 раз
Рейтинг: 11.3

denis84 @ Сегодня, 10:52 * ,
Не вижу у вас ВЫВОД - ОбластьПодписи, только ТелоДоговора

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 07.12.22, 5:44
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!