Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Вопрос по структуре данные МеДок Firebird          
Squall84 Подменю пользователя
сообщение 02.04.21, 12:43
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 6
Спасибо сказали: 0 раз
Рейтинг: 0

Доброго времени суток. Нужно подключиться к базе Медка и получить только зарегистрированные налоговые накладные.

Я подключился к базе FireBird. Получаю список НН. Тут все работает без проблем.

Но не могу понять откуда получить признак - зарегистрирован или нет. Если подключаться по API методом OpenDocumentByExDocID(), то можно указать статус документа. Т.е. принят, не принят, зарегистрирован и т.п. Но в основной таблице в базе я не вижу этого признака.

Есть подозрение, что этот статус хранится в другой таблице. Половину таблиц перебрал, не вижу, где может храниться этот статус.

Возможно кто-то делал подобное и может подсказать?

29a Подменю пользователя
сообщение 12.04.21, 14:06
Сообщение #2

Говорящий
***
Группа: Пользователи
Сообщений: 69
Спасибо сказали: 18 раз
Рейтинг: 18.5

Squall84 @ 02.04.21, 13:43 * ,
            СтрокаПодключения = "Driver={"+СокрЛП(ПараметрыПодключенияSQL.Драйвер)+"};Server="+СокрЛП(ПараметрыПодключенияSQL.Сервер)+";Database="+СокрЛП(ПараметрыПодключенияSQL.База)+";User ID="+СокрЛП(ПараметрыПодключенияSQL.Пользователь)+";Password="+СокрЛП(ПараметрыПодключенияSQL.Пароль)+";";
            
            ADODBConnection = Новый COMОбъект("ADODB.Connection");
            ADODBConnection.ConnectionString = СтрокаПодключения;
            ADODBConnection.CursorLocation= 3;
            ADODBConnection.Open();
            
            ADODBCommand = Новый COMObject("ADODB.Command");
            ADODBCommand.ActiveConnection = ADODBConnection;
            ADODBCommand.CommandTimeOut = 10000;
            
            ADODBCommand.CommandText = ТекстЗапроса;                    
            
            RS = Новый COMОбъект ("ADODB.RecordSet");
            
            Попытка
                RS = ADODBCommand.Execute();
            Исключение
                Сообщить(ОписаниеОшибки(), СтатусСообщения.Важное);
                Продолжить;
            КонецПопытки;
            
            ВсегоЗаписей = RS.RecordCount;
            
            Пока RS.EOF() = 0 Цикл
                //запись
                Инд = 0;
                Структура = Новый Структура;
                //все ее поля
                Для Каждого П Из RS.Fields Цикл
                    Если RS.fields(Инд).Value = Null Тогда
                        Структура.Вставить(П.Name, "");
                    Иначе    
                        Структура.Вставить(П.Name, RS.fields(Инд).Value);
                    КонецЕсли;    
                    Инд = Инд + 1;
                КонецЦикла;
                //REGDATE - дата регистрации документа в налоговой, если не пустая значит зарегистрирован
            КонецЦикла;

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 09.05.21, 20:59
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!