Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> УНФ загрузка внешный данных          
burza Подменю пользователя
сообщение 13.03.24, 12:39
Сообщение #1

Оратор
*****
Группа: Пользователи
Сообщений: 313
Спасибо сказали: 1 раз
Рейтинг: 1

в УНФ штатная загрузка внешных данных, делаю загрузку из ексель. В справочники номенклатуры добавил поле КатегорияОбмена- ведет на другой справочник(поле выбора). При загрузке все показывает а когда создаеться номен то поле пустое.Если поле простое строка то все ок, а если там стоит выбор то не как. Вроде по аналогии добавил в модули но ничего. Может кто-то сталкивался.
Это в менеджере Номенклатуры
ЗагрузкаДанныхИзВнешнегоИсточника.ДобавитьПолеОписанияЗагрузки(ТаблицаПолейЗагрузки, "КатегорияОбмена", "КатегорияОбмена", ОписаниеТиповСтрока25,ОписаниеТиповКолонка,"Номенклатура",2,,Истина);

 ЗагрузкаДанныхИзВнешнегоИсточникаПереопределяемый.СопоставитьНоменклатуруКатегорияОбмена(СтрокаТаблицыФормы.КатегорияОбмена);


Это в общем
Процедура СопоставитьНоменклатуруКатегорияОбмена(КатегорияОбмена) Экспорт
     ЗначениеБылоСопоставлено = Ложь;
    
    Если НЕ ЗначениеБылоСопоставлено И ЗначениеЗаполнено(КатегорияОбмена) Тогда
        
        СправочникСсылка = Справочники.КатегорияОбмена.НайтиПоНаименованию(КатегорияОбмена);
        Если НЕ СправочникСсылка.Пустая() Тогда
            
            
            ЗначениеБылоСопоставлено = Истина;
            Номенклатура = СправочникСсылка.Наименование;
            
        КонецЕсли;
        
    КонецЕсли;
        
КонецПроцедуры


Отладка туда не пускает,ничего не происходит(

burza Подменю пользователя
сообщение 13.03.24, 16:03
Сообщение #2

Оратор
*****
Группа: Пользователи
Сообщений: 313
Спасибо сказали: 1 раз
Рейтинг: 1

burza @ Сегодня, 12:39 * ,
сопоставление не происходит

takefive Подменю пользователя
сообщение 14.03.24, 15:53
Сообщение #3

Говорящий
***
Группа: Пользователи
Сообщений: 62
Из: Днепропетровск
Спасибо сказали: 22 раз
Рейтинг: 23.2

попробуйте так...
КатегорияОбмена = СправочникСсылка;


Signature
без свинга нет музыки...

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 13.07.24, 19:30
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!