Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Средства мультимедиа в мобильном клиенте          
DrLivsi Подменю пользователя
сообщение 02.02.21, 19:20
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 143
Из: Киев
Спасибо сказали: 18 раз
Рейтинг: 18

Всем привет, помогите разобраться, пытаюсь сделать фото с мобильного устройства в мобильном клиенте.
Вот код:
&НаКлиенте
Функция ПолучитьДанныеФотоСнимка()

         Данные = Неопределено;

         #Если МобильноеПриложениеКлиент Тогда
            
         Попытка  
             Данные = СредстваМультимедиа.СделатьФотоснимок();
         исключение
             Сообщить(ОписаниеОшибки());
         КонецПопытки;

               Возврат Данные;
              
   #КонецЕсли

КонецФункции


но ничего не происходит, начал копать и выяснилось что отладчик не заходит в #Если МобильноеПриложениеКлиент Тогда
проверил на следующем коде, не попадает ни в одно условие, хотя в Активных сеансах пишет "Мобильный клиент"
        #Если МобильноеПриложение Тогда 
        Сообщить("МобильноеПриложение");
    #ИначеЕсли МобильноеПриложениеКлиент Тогда
        Сообщить("МобильноеПриложениеКлиент");
    #ИначеЕсли МобильноеПриложениеСервер Тогда
        Сообщить("МобильноеПриложениеСервер");
    #КонецЕсли

В чем может быть проблема? Платформа 8.3.16 1502, мобильный клиент 8.3.17.76

DrLivsi Подменю пользователя
сообщение 08.02.21, 4:32
Сообщение #2

Завсегдатай
****
Группа: Пользователи
Сообщений: 143
Из: Киев
Спасибо сказали: 18 раз
Рейтинг: 18

Может кому то будет полезно, проблему не победил, но убрал инструкцию препроцессору
 #Если МобильноеПриложениеКлиент Тогда

и сохранил с ошибкой.
Все работает. Наверное глюк платформы...

Спасибо сказали: Vofka,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 13.04.21, 20:47
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!