Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Расчетные листки организаций , Печать - Расчетные листки организаций 2 страниц V   1 2 >          
Xmdrug Подменю пользователя
сообщение 11.02.21, 9:26
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

Конфигурация 1С:Підприємство 8.3 (8.3.9.2309), Управление торговым предприятием для Украины", редакция 1.2. (1.2.41.1)
Стандартный отчёт "Расчетные листки организаций". Нужно сделать, чтобы один расчетный листок выводился на один лист. (Отчет формируется со всеми сотрудниками организации, нужно каждого на отдельный лист). Помогите.

DartRomanius Подменю пользователя
сообщение 11.02.21, 9:50
Сообщение #2

Ветеран
Иконка группы
Группа: Местный
Сообщений: 802
Из: Запорожье
Спасибо сказали: 144 раз
Рейтинг: 71

Xmdrug @ Сегодня, 10:26 * ,

Это редактировать вывод отчета надо,

В конфигураторе:

Отчет - РасчетныеЛисткиОрганизаций - Модуль объекта - Процедура СформироватьОтчет

После строки
ВременныйТабличныйДокумент.Вывести(ОбластьПодвал);
, добавить строку
ДокументРезультат.ВывестиГоризонтальныйРазделительСтраниц();


Signature
-----------------------------------------------------------------------------------
Единственный, интуитивно понятный интерфейс - мамкина сиська!
Всему остальному надо учиться! (с) Не знаю кто....

Спасибо сказали: Xmdrug,

Xmdrug Подменю пользователя
сообщение 11.02.21, 10:02
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

DartRomanius @ Сегодня, 10:50 * ,

// Формирует отчет в табличный документ
//
// Параметры:
//  Результат         - табличный документ куда будет сформирован отчет
//  ДанныеРасшифровки - данные расшифровки отчета схемы компоновки данных
//  ВыводВФормуОтчета - признак вывода отчета в форму  
//
Функция СформироватьОтчет(Результат = Неопределено, ДанныеРасшифровки = Неопределено, ВыводВФормуОтчета = Истина) Экспорт
    
    Возврат ТиповыеОтчеты.СформироватьТиповойОтчет(ЭтотОбъект, Результат, ДанныеРасшифровки, ВыводВФормуОтчета);
    
    
    
КонецФункции //СформироватьОтчет()


Не нашол такого

Сообщение отредактировал Vofka - 11.02.21, 11:08

DartRomanius Подменю пользователя
сообщение 11.02.21, 10:22
Сообщение #4

Ветеран
Иконка группы
Группа: Местный
Сообщений: 802
Из: Запорожье
Спасибо сказали: 144 раз
Рейтинг: 71

Xmdrug @ Сегодня, 11:02 * ,

Видимо в более поздних версиях изменили вывод отчета, скинте мне цф-файл, у меня самая ранняя 1,2,44,2


Signature
-----------------------------------------------------------------------------------
Единственный, интуитивно понятный интерфейс - мамкина сиська!
Всему остальному надо учиться! (с) Не знаю кто....

Xmdrug Подменю пользователя
сообщение 11.02.21, 10:34
Сообщение #5

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

////////////////////////////////////////////////////////////////////////////////
// ПЕРЕМЕННЫЕ МОДУЛЯ

Перем СохраненнаяНастройка Экспорт;
Перем Расшифровки          Экспорт;

#Если Клиент ИЛИ ВнешнееСоединение Тогда
    
////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ И ФУНКЦИИ ОБЩЕГО НАЗНАЧЕНИЯ

// Формирует отчет в табличный документ
//
// Параметры:
//  Результат         - табличный документ куда будет сформирован отчет
//  ДанныеРасшифровки - данные расшифровки отчета схемы компоновки данных
//  ВыводВФормуОтчета - признак вывода отчета в форму  
//
Функция СформироватьОтчет(Результат = Неопределено, ДанныеРасшифровки = Неопределено, ВыводВФормуОтчета = Истина) Экспорт
    
    Возврат ТиповыеОтчеты.СформироватьТиповойОтчет(ЭтотОбъект, Результат, ДанныеРасшифровки, ВыводВФормуОтчета);
    
КонецФункции //СформироватьОтчет()
    
// В процедуре можно доработать компоновщик перед выводом в отчет
//
// Параметры:
//  Нет.
//
Процедура ДоработатьКомпоновщикПередВыводом() Экспорт
    
    
КонецПроцедуры //ДоработатьКомпоновщикПередВыводом()

#КонецЕсли

#Если Клиент Тогда

// Настройка отчета
//
// Параметры:
//  Отбор                              - отбор компоновки данных
//  КомпоновщикНастроекОсновногоОтчета - компоновщик настроек
//
Процедура Настроить(Отбор, КомпоновщикНастроекОсновногоОтчета = Неопределено) Экспорт
    
    ТиповыеОтчеты.НастроитьТиповойОтчет(ЭтотОбъект, Отбор, КомпоновщикНастроекОсновногоОтчета);
    
КонецПроцедуры //Настроить()

// Сохраняет настройки отчета
//
// Параметры:
//  Нет.
//
Процедура СохранитьНастройку() Экспорт
    
    СтруктураНастроек = ТиповыеОтчеты.ПолучитьСтруктуруПараметровТиповогоОтчета(ЭтотОбъект);
    СохранениеНастроек.СохранитьНастройкуОбъекта(СохраненнаяНастройка, СтруктураНастроек);
    
КонецПроцедуры //СохранитьНастройку()

// Заполняет параметры отчета по элементу справочника из переменной "СохраненнаяНастройка".
//
// Параметры:
//  Нет.
//
Процедура ПрименитьНастройку() Экспорт
    
    Если СохраненнаяНастройка.Пустая() Тогда
        Возврат;
    КонецЕсли;
    
    СтруктураПараметров = СохраненнаяНастройка.ХранилищеНастроек.Получить();
    ТиповыеОтчеты.ПрименитьСтруктуруПараметровОтчета(ЭтотОбъект, СтруктураПараметров);
    
КонецПроцедуры //ПрименитьНастройку()

// Инициализация отчета
//
// Параметры:
//  Нет.
//              
Процедура ИнициализацияОтчета() Экспорт
    
    ТиповыеОтчеты.ИнициализацияТиповогоОтчета(ЭтотОбъект);
    
КонецПроцедуры //ИнициализацияОтчета()

Расшифровки = Новый СписокЗначений;

НастройкаПериода = Новый НастройкаПериода;

#КонецЕсли



Вот весь модуль данного отчета

Сообщение отредактировал Vofka - 11.02.21, 11:08

DartRomanius Подменю пользователя
сообщение 11.02.21, 10:42
Сообщение #6

Ветеран
Иконка группы
Группа: Местный
Сообщений: 802
Из: Запорожье
Спасибо сказали: 144 раз
Рейтинг: 71

Xmdrug @ Сегодня, 11:34 * ,

Так, отчет на СКД?


Signature
-----------------------------------------------------------------------------------
Единственный, интуитивно понятный интерфейс - мамкина сиська!
Всему остальному надо учиться! (с) Не знаю кто....

Xmdrug Подменю пользователя
сообщение 11.02.21, 10:51
Сообщение #7

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

DartRomanius @ Сегодня, 11:42 * ,
Возможно, я полный ноль пока в этом

DartRomanius Подменю пользователя
сообщение 11.02.21, 11:38
Сообщение #8

Ветеран
Иконка группы
Группа: Местный
Сообщений: 802
Из: Запорожье
Спасибо сказали: 144 раз
Рейтинг: 71

Xmdrug @ Сегодня, 11:51 * ,

Нет, скачал 1,2,41,1
Там так, как я и говорил (писал) выше.

Вы уверены что у вас УТП для Украины 1,2,41,1?


Signature
-----------------------------------------------------------------------------------
Единственный, интуитивно понятный интерфейс - мамкина сиська!
Всему остальному надо учиться! (с) Не знаю кто....

Xmdrug Подменю пользователя
сообщение 11.02.21, 11:39
Сообщение #9

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

"Управление торговым предприятием для Украины", редакция 1.2. (1.2.41.1) (http://1c.ua/v8/RegionalSolutions_UA_UTP.php)
Copyright © Molenari OU, 2017-2019. All rights reserved

29a Подменю пользователя
сообщение 11.02.21, 11:48
Сообщение #10

Говорящий
***
Группа: Пользователи
Сообщений: 60
Спасибо сказали: 16 раз
Рейтинг: 17.5

DartRomanius @ Сегодня, 10:42 * ,
Обычный отчет, так и есть, нужно добавить ДокументРезультат.ВывестиГоризонтальныйРазделительСтраниц();

З.Ы.
пользуйтесь...
[необходимо зарегистрироваться для просмотра ссылки]


 ! 

Правила: 1
 


Сообщение отредактировал Vofka - 11.02.21, 15:31

Спасибо сказали: Xmdrug,

DartRomanius Подменю пользователя
сообщение 11.02.21, 11:56
Сообщение #11

Ветеран
Иконка группы
Группа: Местный
Сообщений: 802
Из: Запорожье
Спасибо сказали: 144 раз
Рейтинг: 71

Xmdrug @ Сегодня, 12:39 * ,
Ответ ниже(выше?) - ссылка, это вам! ))

29a @ Сегодня, 12:48 * ,

Сообщение № 5????

Сообщение отредактировал DartRomanius - 11.02.21, 11:52


Signature
-----------------------------------------------------------------------------------
Единственный, интуитивно понятный интерфейс - мамкина сиська!
Всему остальному надо учиться! (с) Не знаю кто....

Спасибо сказали: Xmdrug,

Xmdrug Подменю пользователя
сообщение 11.02.21, 13:19
Сообщение #12

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

Цитата(29a @ 11.02.21, 12:48) *
DartRomanius @ Сегодня, 10:42 ,
Обычный отчет, так и есть, нужно добавить ДокументРезультат.ВывестиГоризонтальныйРазделительСтраниц();

Куда добавить??? Сорри за тупость

DartRomanius Подменю пользователя
сообщение 11.02.21, 13:29
Сообщение #13

Ветеран
Иконка группы
Группа: Местный
Сообщений: 802
Из: Запорожье
Спасибо сказали: 144 раз
Рейтинг: 71

Xmdrug @ Сегодня, 14:19 * ,

Файл - Открыть


Signature
-----------------------------------------------------------------------------------
Единственный, интуитивно понятный интерфейс - мамкина сиська!
Всему остальному надо учиться! (с) Не знаю кто....

Спасибо сказали: Xmdrug,

Xmdrug Подменю пользователя
сообщение 11.02.21, 13:35
Сообщение #14

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

DartRomanius @ Сегодня, 14:29 * ,
Что мне надо скопировать из отправленого модуля в мой??? Он все рабочий, просто надо добавить, чтоб каждого на отдельный лист

DartRomanius Подменю пользователя
сообщение 11.02.21, 13:47
Сообщение #15

Ветеран
Иконка группы
Группа: Местный
Сообщений: 802
Из: Запорожье
Спасибо сказали: 144 раз
Рейтинг: 71

Xmdrug @ Сегодня, 14:35 * ,

А судя по всему заменить отчет, лучше все-таки скиньте cf-файл
Конфигуратор - Конфигурация - Сохранить конфигурацию в файлы


Signature
-----------------------------------------------------------------------------------
Единственный, интуитивно понятный интерфейс - мамкина сиська!
Всему остальному надо учиться! (с) Не знаю кто....

Спасибо сказали: Xmdrug,

Xmdrug Подменю пользователя
сообщение 11.02.21, 15:37
Сообщение #16

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

Цитата(DartRomanius @ 11.02.21, 14:47) *
все-таки скиньте cf-файл

Неразрешили скинуть

DartRomanius Подменю пользователя
сообщение 11.02.21, 16:14
Сообщение #17

Ветеран
Иконка группы
Группа: Местный
Сообщений: 802
Из: Запорожье
Спасибо сказали: 144 раз
Рейтинг: 71

Xmdrug @ Сегодня, 16:37 * ,

Мне не нужен файл с данными(DT), а только файл конфигурации(CF).


Signature
-----------------------------------------------------------------------------------
Единственный, интуитивно понятный интерфейс - мамкина сиська!
Всему остальному надо учиться! (с) Не знаю кто....

Xmdrug Подменю пользователя
сообщение 11.02.21, 16:18
Сообщение #18

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

по другому никак? модуль я же скинул

DartRomanius Подменю пользователя
сообщение 11.02.21, 16:28
Сообщение #19

Ветеран
Иконка группы
Группа: Местный
Сообщений: 802
Из: Запорожье
Спасибо сказали: 144 раз
Рейтинг: 71

Xmdrug @ Сегодня, 17:18 * ,
Модуль вообще непонятно как взялся, там такого не должно быть


Signature
-----------------------------------------------------------------------------------
Единственный, интуитивно понятный интерфейс - мамкина сиська!
Всему остальному надо учиться! (с) Не знаю кто....

Спасибо сказали: Xmdrug,

29a Подменю пользователя
сообщение 11.02.21, 16:36
Сообщение #20

Говорящий
***
Группа: Пользователи
Сообщений: 60
Спасибо сказали: 16 раз
Рейтинг: 17.5

Xmdrug @ Сегодня, 16:18 * ,
можно просто, зайти в конфигуратор, найти отчет, вызвать контекстное меню, выбрать "Заменить на внешнюю обработку, отчет...", выбрать исправленный отчет.


Цитата(Xmdrug @ 11.02.21, 15:37) *
Неразрешили скинуть

ИМХО, что тогда заморачиваться?... Пусть ищут программиста, который придет и сделает все бесплатно на месте. )))

Спасибо сказали: Xmdrug,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


2 страниц V   1 2 >
Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 26.02.21, 15:00
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!