Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Проведения документа по ссылке , В шапке документа есть ссылка на другой документ.как его провести          
kostya77 Подменю пользователя
сообщение 14.11.22, 15:15
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 23
Спасибо сказали: 1 раз
Рейтинг: 0

Добрый день. В шапке документа есть ссылка на другой документ.как его провести при проведении родительского документа?

denis84 Подменю пользователя
сообщение 14.11.22, 15:53
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 315
Из: Украина
Спасибо сказали: 93 раз
Рейтинг: 93

kostya77 @ Сегодня, 15:15 * ,
Иногда необходимо при проведении документа, перепровести связанные с текущим, другие документы. В 1С:7.7 существует ограничение на проведение документов из модуля проведения, обойти ограничение можно следующим образом:
Иногда необходимо при проведении документа, перепровести связанные с текущим, другие документы. В 1С:7.7 существует ограничение на проведение документов из модуля проведения, обойти ограничение можно следующим образом:

    
//документ с которого хотим провести другой
Процедура ОбработкаПроведения()

Док = СоздатьОбъект("Документ");
Если Док.НайтиДокумент(ДокументОснование) = 1 Тогда
       ОткрытьФормуМодально(Док.ТекущийДокумент(),"ПровестиИЗакрыть",0);
КонецЕсли;

КонецПроцедуры

//Документ2, Модуль формы документа основание

Процедура ПриОткрытии()
       Если Форма.Параметр="ПровестиИЗакрыть" Тогда
         Провести();
         СтатусВозврата(0)
       КонецЕсли;
КонецПроцедуры


Сообщение отредактировал denis84 - 14.11.22, 16:09

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 07.12.22, 4:45
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!