Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Предприятие 7.7 Возможность передать все содержимое обработки в список значений          
Sharzem Подменю пользователя
сообщение 03.08.15, 16:21
Сообщение #1

Оратор
Иконка группы
Группа: Местный
Сообщений: 274
Спасибо сказали: 85 раз
Рейтинг: 84.6

Любая конфигурация.

Имеется обработка с кучей всякого барахла на форме, кто нить может подсказать как возможно все это собрать в список значений для последующего сохранения в файл. Смысл в последующем восстановлении для продолжения неоконченной работы.

Я понимаю что можно каждый реквизит перечислить, но может есть какие-то идеи что-бы как-то это универсализировать.

PS: Есть и ТЗ, и СЗ, и флажки с переключателями, и програмно добаленные закладки (хотя это тоже СЗ)...


Signature
То, что для одного человека константа, для другого - переменная. (Алан.Дж.Перлис)

TipsyKID Подменю пользователя
сообщение 03.08.15, 17:06
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 408
Из: Киев
Спасибо сказали: 160 раз
Рейтинг: 0

Использовать стороннюю библиотеку : FormEx.dll

ПолучитьСледующийАтрибут / GetNextAttrib

Синтаксис: ПолучитьСледующийАтрибут()

Возвращает: тип: Число. В случае успеха поиска возвращает 1, иначе - 0.

Описание: Метод предназначен для поиска следующего атрибута в соответствии с параметрами, установленными ранее методом НайтиАтрибут / FindAttrib.

Пример:

ФормаРасш = СоздатьОбъект("РасширениеФормы");
р = ФормаРасш.НайтиАтрибут(5,"Основной");
Пока р = 1 Цикл
        Сообщить(ФормаРасш.ТекущийАтрибут().Заголовок);
        р = ФормаРасш.ПолучитьСледующийАтрибут();
КонецЦикла;


Сообщение отредактировал TipsyKID - 03.08.15, 17:07


Signature
Специалист : Технологическая платформа 8.х, Бухгалтерия для Украины, Управление торговлей для Украины, Зарплата и Управление Персоналом для Украины

Спасибо сказали: Sharzem,

Sharzem Подменю пользователя
сообщение 03.08.15, 18:31
Сообщение #3

Оратор
Иконка группы
Группа: Местный
Сообщений: 274
Спасибо сказали: 85 раз
Рейтинг: 84.6

Цитата
Использовать стороннюю библиотеку : FormEx.dll

32542460.gif

Нет слов.... с его помощью этакая "зверюка" и построена... А про метод забыл...

Итак, маленькое решение:
лпСписокЗнач = СоздатьОбъект("СписокЗначений");
лпРасшФорма = СоздатьОбъект("РасширениеФормы");
лпРасшФорма.УстановитьФорму(Форма);
Для лпСч = 0 по лпРасшФорма.КоличествоАтрибутов()-1 Цикл
    лпИдентификатор = лпРасшФорма.ПолучитьАтрибут(лпСч).Идентификатор;
    лпЗначение = лпРасшФорма.ПолучитьАтрибут(лпСч).Значение;
    Если ПустаяСтрока(лпИдентификатор) = 0 Тогда//Меня интересуют только с идентификаторами
        лпСписокЗнач.Установить(лпИдентификатор,лпЗначение);
    КонецЕсли;
КонецЕсли;

Все остальное, уже далее мелочи...

TipsyKID, спс за пенок в нужную сторону.


Signature
То, что для одного человека константа, для другого - переменная. (Алан.Дж.Перлис)

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 26.11.20, 11:16
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!