Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> ПОМОГИТЕ , Касается отрицания рабочей даты          
Danaza Подменю пользователя
сообщение 05.11.19, 23:05
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 1
Спасибо сказали: 0 раз
Рейтинг: 0

Помогите, пожалуйста.
Я не профи.
Есть раздел где появляется таблица, в ней период чисел от и до на выбор и кнопка сформировать цены за этот период. А мне нужно сделать так, чтоб, если период касается сегодняшнего числа - появлялось окно в стиле "Вы уверенны?" и если вдруг да, то продолжались действия. 1Cv7

andrew76 Подменю пользователя
сообщение 06.11.19, 2:49
Сообщение #2

Оратор
*****
Группа: Пользователи
Сообщений: 301
Из: Узбекистан
Спасибо сказали: 18 раз
Рейтинг: 18

Danaza @ Сегодня, 2:05 * ,

Синтаксис:
Вопрос(<Текст_вопроса>,<Режим>,<Таймаут>)
Назначение:
Вывести окно вопроса и получить ответ.
Возвращает ответную реакцию в виде числа или строки, в соответствии с заданием параметра <Режим>:
-1 или 'Таймаут' ('Timeout'), если закончилось время ожидания ответа;
1 или 'ОК' ('ОК'), если если нажата кнопка OK;
2 или 'Отмена' ('Cancel'), если нажата кнопка Отмена;
3 или 'Стоп' ('Abort'), если нажата кнопка Стоп;
4 или 'Повтор' ('Retry'), если нажата кнопка Повтор;
5 или 'Пропустить' ('Ignore'), если нажата кнопка Пропустить;
6 или 'Да' ('Yes'), если нажата кнопка Да;
7 или 'Нет' ('No'), если нажата кнопка Нет.
Параметры:
<Текст_вопроса> - cтрока текста вопроса;
<Режим> - определяет набор кнопок диалога в виде числа или строки (в скобках английское написание):
0 или 'ОК' ('ОК') - кнопка OK;
1 или 'ОК+Отмена' ('OK+Cancel') - кнопки OK и Отмена;
2 или 'Стоп+Повтор+Пропустить' ('Abort+Retry+Ignore') - кнопки Стоп, Повтор, Пропустить;
3 или 'Да+Нет+Отмена' ('Yes+No+Cancel') - кнопки Да, Нет, Отмена;
4 или 'Да+Нет' ('Yes+No') - кнопки Да, Нет;
5 или 'Повтор+Отмена' ('Retry+Cancel') - кнопки Повтор, Отмена;
(любое другое значение или отсутствие параметра равносильно 0);
<Таймаут> - число секунд времени ожидания ответа (если опущен или 0, то без ограничения).
Подробнее см. в документации, глава 'Системные процедуры и функции'



Если Вопрос("Вы уверены ?","Да+Нет")="Да"  Тогда
       //нужные действия
      Иначе
         Возврат;
КонецЕсли;

Макс1С Подменю пользователя
сообщение 07.11.19, 11:55
Сообщение #3

Говорящий
***
Группа: Пользователи
Сообщений: 94
Из: Днепр
Спасибо сказали: 30 раз
Рейтинг: 26

andrew76 @ Вчера, 2:49 * ,
Телепат, прочитав 1е сообщение, не сразу понял в чём проблема 12201689.gif
Да и заголовок темы - огонь ))))

andrew76 Подменю пользователя
сообщение 07.11.19, 12:16
Сообщение #4

Оратор
*****
Группа: Пользователи
Сообщений: 301
Из: Узбекистан
Спасибо сказали: 18 раз
Рейтинг: 18

Макс1С @ Сегодня, 14:55 * ,

Та якiй там телепат ? Я кстати на вопрос не ответил толком.

Если КакаятоПеременная=ТекущаяДата() Тогда
       Если Вопрос("Вы уверены ?","Да+Нет")="Да"  Тогда
              //нужные действия
       Иначе
             Возврат;
       КонецЕсли;
КонецЕсли;

Vofka Подменю пользователя
сообщение 09.11.19, 23:39
Сообщение #5

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13151
Из: Киев
Спасибо сказали: 3994 раз
Рейтинг: 3124.4

Тема едет в корзину.


 ! 

Правила: 3, 4, 7
 

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 21.11.19, 23:00
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!