Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 7, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Перезапонение выбранных документов          
Constantus Подменю пользователя
сообщение 13.02.20, 10:48
Сообщение #1

Ветеран
*******
Группа: Пользователи
Сообщений: 867
Спасибо сказали: 6 раз
Рейтинг: 5

Приветствую, Форумчане!
1с8.3.12, самопис, УФ

Имеется некий документ. На форме документа имеется кнопка, которая заполняет табличную часть кодом

  ДокументОбъект = РеквизитФормыВЗначение("Объект");
    ДокументОбъект.ЗаполнитьЦены();
    ЗначениеВРеквизитФормы(ДокументОбъект, "Объект");
    
    Модифицированность = Истина;


ЗаполнитьЦены(); - заполняет ТЧ ценами и т.д.

Теперь в форме списка нужно расположить некую кнопку, которая этим же кодом перезаполняет ТЧ несколько выбранных документов.
Поставил кнопку на список с кодом:

&НаКлиенте
Процедура ПерезаполнитьЦены(Команда)
    
    ВыделенныеСтроки = Элементы.Список.ВыделенныеСтроки;
    ИзменитьЦены(ВыделенныеСтроки);    
    
КонецПроцедуры


&НаСервере //БезКонтекста
Процедура ИзменитьЦены(ВыделенныеСтроки);
    
       Для Каждого Строка Из ВыделенныеСтроки Цикл
                Об = Строка.ПолучитьОбъект();
        Об.ТабличнаяЧасть.Очистить();
    
        Сообщить(Объект.Ссылка);
            
    КонецЦикла;
    
КонецПроцедуры




Никак не могу сообразить как правильно, а главное оптимально в этот код установить срабатывание кода в модуле объекта

Процедура ЗаполнитьЦены() Экспорт


Посоветуйте...

sava1 Подменю пользователя
сообщение 13.02.20, 11:49
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2210
Из: Проскуров
Спасибо сказали: 531 раз
Рейтинг: 518.2

в модуле менеджера прописать процедуру заполнения

в форме списка

Для каждого строка из список.Выделенныестроки цикл
     док = строка.ссылка;
     документы.НекийДокумент.ЗаполнитьЦены(док);
Конеццикла


Сообщение отредактировал Vofka - 13.02.20, 12:18

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 19.02.20, 18:20
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!