Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Печать присоединенного файла из справочника          
kostya77 Подменю пользователя
сообщение 31.10.23, 13:56
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 139
Спасибо сказали: 5 раз
Рейтинг: 4

Добрый день. В справочнике НоменклатураПрисоедененныеФайлы хранится картинка в фомате jpg. Подскажите, как получить ссылку на этот файл для дальнейшей печати?

Сообщение отредактировал Vofka - 01.11.23, 11:43

Slon747 Подменю пользователя
сообщение 31.10.23, 14:10
Сообщение #2

Говорящий
***
Группа: Пользователи
Сообщений: 53
Спасибо сказали: 1 раз
Рейтинг: 1

kostya77 @ Сегодня, 13:56 * ,

Если нужно сначала сохранить файл на диск, то можно так (работает на УНФ):
Картинка = Новый Картинка(ПолучитьДвоичнаяКартинка(СсылкаЭлемента));
Картинка.Записать(ИмяФайла);

&НаСервере
Функция ПолучитьДвоичнаяКартинка(Ссылка)
    Возврат ПрисоединенныеФайлы.ПолучитьДвоичныеДанныеФайла(Ссылка);
КонецФункции

kostya77 Подменю пользователя
сообщение 31.10.23, 14:16
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 139
Спасибо сказали: 5 раз
Рейтинг: 4

Разбрался.

Функция ПолучитьИзображение(Присоединенныйфайл)
КартинкаПоумолчанию = Неопределено;

Если ТипЗнч(Присоединенныйфайл) = Тип("СправочникСсылка.НоменклатураПрисоединенныеФайлы") Тогда
    Запрос = Новый Запрос;
    Запрос.Текст ="ВЫБРАТЬ
        | Присоединенныефайлы.Хранимыйфайл
        |ИЗ
        | РегистрСведений.Присоединенныефайлы КАК Присоединенныефайлы
        |ГДЕ
        | Присоединенныефайлы.Присоединенныйфайл = &Присоединенныйфайл";
    Запрос.УстановитьПараметр("Присоединенныйфайл", Присоединенныйфайл);
    Результат = Запрос.Выполнить();
    Если НЕ Результат.Пустой() Тогда
        Выборка = Результат.Выбрать();
        Выборка.Следующий(); // Получаем двоичные данные катинки
        Возврат Новый Картинка(Выборка.Хранимыйфайл.Получить(), Истина);
    Иначе // Если.панные отсутствуют, получаем стандартное изображение из
        // дополнительного макета внешнего отчета
        Возврат Новый Картинка(ПолучитьМакет("НетКартинки"));
    КонецЕсли;
КонецЕсли;

Возврат КартинкаПоумолчанию;
КонецФункции


Сообщение отредактировал Vofka - 01.11.23, 11:43

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 19.06.24, 21:13
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!