Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Отправка писем через 1с(ukr.net)          
Pashaboston Подменю пользователя
сообщение 14.01.20, 20:02
Сообщение #1

Говорящий
***
Группа: Пользователи
Сообщений: 80
Спасибо сказали: 1 раз
Рейтинг: 1

Конфигурация УТП для Украины версия 1.2.54.1 платформа 8.3.15.1489. Настроил встроиный почтовый клиент проверка через 1с, проверк проходит нормально, отправка писем проходит но письмо до адресата не доходит.
Почта ukr.net, работает через IMAP, настройки на самой почте сделал.Немного переделал стандартній механизм но не получается.
Профиль = Новый ИнтернетПочтовыйПрофиль;
    //Pawa
    Если УчетнаяЗапись.ТипСервера = "POP3" Тогда
        Профиль.АдресСервераPOP3    = УчетнаяЗапись.POP3Сервер;
        Профиль.ПортPOP3            = УчетнаяЗапись.ПортPOP3;
        Профиль.Пользователь        = УчетнаяЗапись.Логин;
        Профиль.Пароль                = УчетнаяЗапись.Пароль;
    Иначе
        Профиль.АдресСервераIMAP    = УчетнаяЗапись.POP3Сервер;
        Профиль.ПользовательIMAP    = УчетнаяЗапись.Логин;
        Профиль.ПарольIMAP            = УчетнаяЗапись.Пароль;
        Профиль.ПортIMAP            = УчетнаяЗапись.ПортPOP3;
    КонецЕсли;

        
    Профиль.АдресСервераSMTP = УчетнаяЗапись.SMTPСервер;
    Если УчетнаяЗапись.ВремяОжиданияСервера > 0 Тогда
        Профиль.ВремяОжидания = УчетнаяЗапись.ВремяОжиданияСервера;
    КонецЕсли;
    Профиль.ПортSMTP         = УчетнаяЗапись.ПортSMTP;
    
    Если УчетнаяЗапись.ТребуетсяSMTPАутентификация Тогда
        Профиль.АутентификацияSMTP = СпособSMTPАутентификации.ПоУмолчанию;
        Профиль.ПарольSMTP         = УчетнаяЗапись.ПарольSMTP;
        Профиль.ПользовательSMTP   = УчетнаяЗапись.ЛогинSMTP;
    Иначе
        Профиль.АутентификацияSMTP = СпособSMTPАутентификации.БезАутентификации;
        Профиль.ПарольSMTP         = "";
        Профиль.ПользовательSMTP   = "";
    КонецЕсли;
    
    Профиль.ИспользоватьSSLSMTP = Истина;
    Профиль.ИспользоватьSSLPOP3 = Истина;
    Профиль.ИспользоватьSSLIMAP = Истина;
    Профиль.POP3ПередSMTP = Ложь;
    

    
    СистемнаяИнформация = Новый СистемнаяИнформация;
    Если СтроковыеФункцииКлиентСервер.СравнитьВерсии(СистемнаяИнформация.ВерсияПриложения, "8.3.1.0") > 0 Тогда
        Профиль.ИспользоватьSSLPOP3 = УчетнаяЗапись.ИспользоватьЗащищенноеСоединениеДляВходящейПочты;
        Профиль.ИспользоватьSSLSMTP = УчетнаяЗапись.ИспользоватьЗащищенноеСоединениеДляИсходящейПочты;
    КонецЕсли;
    
    Возврат Профиль;

и вот здесь
Если УчетнаяЗапись.ТипСервера = "IMAP" Тогда
                    ИнтернетПочта.Подключиться(Профиль,ПротоколИнтернетПочты.IMAP);
                    //ИнтернетПочта.ТекущийПочтовыйЯщик = "Отправленные";
                Иначе
                    ИнтернетПочта.Подключиться(Профиль);
                КонецЕсли;

Ошыбок никаких не выдает, пишет что отправило а на деле письма приходят на ту учетную запись с какой отправлялись(.

andr_andrey Подменю пользователя
сообщение 15.01.20, 6:04
Сообщение #2

Почти ветеран
Иконка группы
Группа: Местный
Сообщений: 517
Спасибо сказали: 120 раз
Рейтинг: 96.5

Цитата(Pashaboston @ 14.01.20, 20:02) *
Ошыбок никаких не выдает, пишет что отправило а на деле письма приходят на ту учетную запись с какой отправлялись(.

Адрес получателя случайно не совпадает с адресом отправителя?


Signature
#define private public
enum BOOL { FALSE, TRUE, FILENOTFOUND } is made my day

Pashaboston Подменю пользователя
сообщение 15.01.20, 9:57
Сообщение #3

Говорящий
***
Группа: Пользователи
Сообщений: 80
Спасибо сказали: 1 раз
Рейтинг: 1

Pashaboston @ Вчера, 20:02 * ,
Получатель на gmail в отладчике видно, а отправитель ukr.net


Отправка так же переделал через IMAP
Если УчетнаяЗапись.ТипСервера = "IMAP" Тогда
    ИнтернетПочта.Послать(ПочтовоеСообщение,,ПротоколИнтернетПочты.IMAP);
Иначе
    ИнтернетПочта.Послать(ПочтовоеСообщение);
КонецЕсли;


volodya1122 Подменю пользователя
сообщение 15.01.20, 10:32
Сообщение #4

Оратор
Иконка группы
Группа: Местный
Сообщений: 276
Из: Тернопіль
Спасибо сказали: 108 раз
Рейтинг: 110.1

Pashaboston @ Сегодня, 9:57 * ,

А почему бы Вам не завести почту оправителя на GMAIL ? и не иметь этих проблем?

Pashaboston Подменю пользователя
сообщение 15.01.20, 10:42
Сообщение #5

Говорящий
***
Группа: Пользователи
Сообщений: 80
Спасибо сказали: 1 раз
Рейтинг: 1

volodya1122 @ Сегодня, 10:32 * ,
Задача у клиента стоит настроить именно на ukr.net.

Пробую через Shtunnel тоже ничего не выходит. Выдает ошибку :
Ошибка при вызове метода контекста (Подключиться): Произошла ошибка при работе с SMTP. Код ошибки: 25 (Отказ в установлении соединения со стороны сервера.)
Вот настройки Shtunnel :
[ukr.net-imap]
client = yes
accept = 127.0.0.1:143
connect = imap.ukr.net:993
verifyChain = yes
CAfile = ca-certs.pem
checkHost = imap.ukr.net
OCSPaia = yes

[ukr.net-smtp]
client = yes
accept = 127.0.0.1:25
connect = smtp.ukr.net:465
verifyChain = yes
CAfile = ca-certs.pem
checkHost = smtp.ukr.net.com
OCSPaia = yes

sava1 Подменю пользователя
сообщение 15.01.20, 11:17
Сообщение #6

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2295
Из: Проскуров
Спасибо сказали: 547 раз
Рейтинг: 534.4

а у них не платній вариант СМТП ?

Vofka Подменю пользователя
сообщение 15.01.20, 11:49
Сообщение #7

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13289
Из: Киев
Спасибо сказали: 4079 раз
Рейтинг: 3222.1

Pashaboston, а если отправлять не с ukr.net, то работает как положено?

Pashaboston Подменю пользователя
сообщение 15.01.20, 18:18
Сообщение #8

Говорящий
***
Группа: Пользователи
Сообщений: 80
Спасибо сказали: 1 раз
Рейтинг: 1

Vofka @ Сегодня, 11:49 * ,
C gmail все ок


Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 05.07.20, 19:22
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!