Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Ошибка печатати товарного чека          
Максон Подменю пользователя
сообщение 10.11.22, 20:30
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 12
Спасибо сказали: 0 раз
Рейтинг: 0

1cпредприятие 7.70.027. Конфигурация Торговля и склад 7.70.101 beta, Разработчик конфигурации Lexoftech 2006.
Когда перенес базу на другой компьютер, после открытия периода перестал печататься товарный чек, сразу выдает ошибку "Файл товарный чек не найден". После в окне сообщений пишет "Таб.ИсходнаяТаблица(ПечФорма);{Документ.РасходнаяНакладная.Форма.Модуль(693)}: Неверное имя Товарный чеку
Подскажите пожалуйста в чем причина и как с этим побороться.

denis84 Подменю пользователя
сообщение 10.11.22, 20:56
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 315
Из: Украина
Спасибо сказали: 93 раз
Рейтинг: 93

Максон @ Сегодня, 20:30 * ,
Отсутствкет файл печатной формы. Посмотрите в конфигураторе. На строку 693. Надо смотреть модуль документа. Больше всего что печатная форма чека подключалась как внешняя

Сообщение отредактировал denis84 - 10.11.22, 21:07

Максон Подменю пользователя
сообщение 11.11.22, 8:14
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 12
Спасибо сказали: 0 раз
Рейтинг: 0

denis84 @ Вчера, 20:56 * ,
Форма печати открывалась до открытия нового периода. Как только открыл сразу перестала. Интересно что теперь подключаю эту базу с не открытым периодом а ошибка остается.

denis84 Подменю пользователя
сообщение 11.11.22, 8:23
Сообщение #4

Оратор
Иконка группы
Группа: Местный
Сообщений: 315
Из: Украина
Спасибо сказали: 93 раз
Рейтинг: 93

Максон @ Сегодня, 8:14 * ,
Надо смотреть в колнфигуратор что там напсано, в модуле документа

Максон Подменю пользователя
сообщение 11.11.22, 8:24
Сообщение #5

Общительный
**
Группа: Пользователи
Сообщений: 12
Спасибо сказали: 0 раз
Рейтинг: 0

denis84 @ Вчера, 20:56 * ,
Подскажи пожалуйста это в константах глобальный модуль? Как узнать номер строки?

denis84 Подменю пользователя
сообщение 11.11.22, 8:33
Сообщение #6

Оратор
Иконка группы
Группа: Местный
Сообщений: 315
Из: Украина
Спасибо сказали: 93 раз
Рейтинг: 93

Максон @ Сегодня, 8:24 * ,
Сначала смотрите в модуле формы документа РасходнаяНакладная.

Pepe Подменю пользователя
сообщение 11.11.22, 8:44
Сообщение #7

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1423
Из: Ужгород
Спасибо сказали: 756 раз
Рейтинг: 225

Если чайник в 1С, лучше туда не лезть. Если есть возможность - выложите файл конфигурации (.MD) на обменник, Вам помогут.

Максон Подменю пользователя
сообщение 11.11.22, 9:32
Сообщение #8

Общительный
**
Группа: Пользователи
Сообщений: 12
Спасибо сказали: 0 раз
Рейтинг: 0

denis84 @ Сегодня, 8:23 * ,
//ПечФорма = "Накладная";
  ПечФорма = ИмяТабл;
  Язык = глЯзык(ПечФорма);  
  Таб.ИсходнаяТаблица(ПечФорма); ‐---‐--------------    строка 693
  глУстПропись(Валюта,Язык);
                  
  ПечОснование=глСтрокаОснование(Контекст,Договор,ДокументОснование);  
  
  Фирма.ИспользоватьДату(ДатаДок,1);
  Таб.ВывестиСекцию("Шапка");
  Ном = 1;
  ВСоставе = 0;
  ВыбратьСтроки();
  Пока ПолучитьСтроку()=1 Цикл                
    Если Набор.Выбран()=1 Тогда
      Если ПустоеЗначение(ВСоставе)=1 Тогда
        Таб.ВывестиСекцию("ВСоставе");
        ВСоставе=Набор;
      ИначеЕсли ВСоставе<>Набор Тогда
        Таб.ВывестиСекцию("ВСоставе");
        ВСоставе=Набор;
      КонецЕсли;
    Иначе
      Если ПустоеЗначение(ВСоставе)=0 Тогда
        ВСоставе=0;
      КонецЕсли;
    КонецЕсли;
//beg******ALEX 23.06.2006
    //ПечЦена = глФРМ(глПересчет(ЦенаБезНДС,Валюта,Курс,ВП,ДатаДок),ВП,0);
    //ПечСумма = глФРМ(глПересчет(СуммаБезСкидки,Валюта,Курс,ВП,ДатаДок),ВП,0);
    //Таб.ВывестиСекцию("Строка");
    //Ном = Ном+1;
    мояСкидка = глПересчет(СуммаСкидки,Валюта,Курс,ВП,ДатаДок);
    ПечЦена = глФРМ(глПересчет(ЦенаБезНДС,Валюта,Курс,ВП,ДатаДок) - (мояСкидка / Количество),ВП,0);
    ПечСумма = глФРМ(глПересчет(СуммаБезСкидки,Валюта,Курс,ВП,ДатаДок) - мояСкидка,ВП,0);
    Таб.ВывестиСекцию("Строка");
    Ном = Ном+1;
//end******ALEX 23.06.2006
  КонецЦикла;
//beg******ALEX 23.06.2006
  //Если Итог("СуммаСкидки")<>0 Тогда
  //  ПечСкидка = глФРМ(глПересчет(Итог("СуммаСкидки"),Валюта,Курс,ВП,ДатаДок),ВП,0);
  //  Таб.ВывестиСекцию("Скидка");    
  //КонецЕсли;    
//end******ALEX 23.06.2006
  ПечБезНДС = глФРМ(глПересчет(Итог("СуммаБезНДС"),Валюта,Курс,ВП,ДатаДок),ВП,0);  
  ПечНДС = глФРМ(глПересчет(Итог("СуммаСНДС") - Итог("СуммаБезНДС"),Валюта,Курс,ВП,ДатаДок),ВП,0);
  ПечСНДС = глФРМ(глПересчет(Итог("СуммаСНДС"),Валюта,Курс,ВП,ДатаДок),ВП,0);  
  ПечНДСПропись = " "+Формат(глПересчет(Итог("СуммаСНДС") - Итог("СуммаБезНДС"),Валюта,Курс,ВП,ДатаДок),"Ч12.2")+" "+ВП.Кратко;
  ПечСНДСПропись = глСуммаПрописью(глПересчет(Итог("СуммаСНДС"),Валюта,Курс,ВП,ДатаДок),ВП);  
  ПечБезНДСПропись = глСуммаПрописью(глПересчет(Итог("СуммаБезНДС"),Валюта,Курс,ВП,ДатаДок),ВП);  
  Таб.ВывестиСекцию("Дно");  
  Если БыстраяПечать = 1 Тогда
    Таб.ПараметрыСтраницы(,,,,,,,,,1,,);
    Таб.КоличествоЭкземпляров(Константа.ПечКолЭкзНакладнойПриБыстройПродаже);
    Таб.Напечатать(глОтладка);
  Иначе  
    Таб.Защита(Константа.ФлагЗащитыТаблиц);
    Таб.ТолькоПросмотр(1);
    Таб.Опции(0,0,,);    
//beg******ALEX 23.06.2006    
    //Таб.Показать("ПЕЧАТЬ: Расходная накладная","");
    Если ИмяТабл = "Накладная" Тогда
        Таб.Показать("ПЕЧАТЬ: Расходная накладная","");
    ИначеЕсли ИмяТабл = "Акт" Тогда
        Таб.Показать("ПЕЧАТЬ: Акт выполненных работ","");
    Иначе
        Таб.Показать("ПЕЧАТЬ: Гарантийный талон","");
    КонецЕсли;    
//end******ALEX 23.06.2006  
  КонецЕсли;
КонецПроцедуры
                
// ===============================
Процедура Печать(БыстраяПечать=0)
  Варианы= СоздатьОбъект("СписокЗначений");
  Варианы.ДобавитьЗначение("накладной");
  Варианы.ДобавитьЗначение("акта выполненных работ");
  Варианы.ДобавитьЗначение("гарантийного талона");
  Варианы.ДобавитьЗначение("товарного чека");
  Результат = 0;
  Если Варианы.ВыбратьЗначение(,,Результат,,1)=1 Тогда
      Если Результат = 1 Тогда
      ПечатьНАГ(БыстраяПечать,"Накладная")
    ИначеЕсли Результат = 2 Тогда
      ПечатьНАГ(БыстраяПечать,"Акт")
    ИначеЕсли Результат = 3 Тогда
      ПечатьНАГ(БыстраяПечать,"Гарантия")
    ИначеЕсли Результат = 4 Тогда
      ПечатьНАГ(БыстраяПечать,"Товарный чек")
      КонецЕсли;
  КонецЕсли;

КонецПроцедуры


Сообщение отредактировал Vofka - 11.11.22, 15:21

denis84 Подменю пользователя
сообщение 11.11.22, 10:02
Сообщение #9

Оратор
Иконка группы
Группа: Местный
Сообщений: 315
Из: Украина
Спасибо сказали: 93 раз
Рейтинг: 93

Максон @ Сегодня, 9:32 * ,
скиньте файл 1с7.md (это чисто конфигурации, без данных) с каталога вашей конфигурации на почту vdv1984@i.ua

Pepe Подменю пользователя
сообщение 11.11.22, 10:56
Сообщение #10

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1423
Из: Ужгород
Спасибо сказали: 756 раз
Рейтинг: 225

Если чайник в 1С, лучше туда не лезть. Если есть возможность - выложите файл конфигурации (.MD) на обменник, Вам помогут.
Цитата(Максон @ 11.11.22, 10:32) *
ПечФорма = ИмяТабл;

В переменной "ИмяТабл" возможно содержится инфа о файле печатной формы. Это может быть и константа, и глобальная переменная, реквизит. надо смотреть она где инициализируется.
Из приведенного фрагмента кода ничего не видно, без МД никак.

denis84 Подменю пользователя
сообщение 11.11.22, 10:57
Сообщение #11

Оратор
Иконка группы
Группа: Местный
Сообщений: 315
Из: Украина
Спасибо сказали: 93 раз
Рейтинг: 93

Pepe @ Сегодня, 10:56 * ,
та что-то Максон конфигурацию не хочет дать, а то по тексту тяжело понять

Pepe Подменю пользователя
сообщение 11.11.22, 11:07
Сообщение #12

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1423
Из: Ужгород
Спасибо сказали: 756 раз
Рейтинг: 225

Цитата(denis84 @ 11.11.22, 11:57) *
та что-то Максон конфигурацию не хочет дать, а то по тексту тяжело понять

Мы предложили, это в его интересах, а так баба з воза...

denis84 Подменю пользователя
сообщение 11.11.22, 11:51
Сообщение #13

Оратор
Иконка группы
Группа: Местный
Сообщений: 315
Из: Украина
Спасибо сказали: 93 раз
Рейтинг: 93

Pepe @ Сегодня, 11:07 * ,
так, то й так

Сообщение отредактировал denis84 - 11.11.22, 11:52

Максон Подменю пользователя
сообщение 11.11.22, 14:38
Сообщение #14

Общительный
**
Группа: Пользователи
Сообщений: 12
Спасибо сказали: 0 раз
Рейтинг: 0

denis84 @ Сегодня, 8:33 * ,
Ошибка ушла, похоже я делал изменения в базе с не открытым периодом. Сейчас сразу открыл период и начал редактировать, вроде ошибок пока нет.




Еще вопросик возник, если не трудно, подскажите как редактировать шапку печатной формы. Сами формы похоже встроены в базу, отдельно я их не нашел. Спасибо за ответы!

denis84 Подменю пользователя
сообщение 11.11.22, 15:15
Сообщение #15

Оратор
Иконка группы
Группа: Местный
Сообщений: 315
Из: Украина
Спасибо сказали: 93 раз
Рейтинг: 93

Максон @ Сегодня, 14:38 * ,
В конфигураторе. Находите свой документ. Открываете его форму и там есть макеты печатных форм. И там уже их правите, как хотите. Но если не сильно ориентируетеся в 1с, лучше обращаться к программистам 1с

Сообщение отредактировал denis84 - 11.11.22, 15:17

Спасибо сказали: Максон,

Максон Подменю пользователя
сообщение 11.11.22, 15:26
Сообщение #16

Общительный
**
Группа: Пользователи
Сообщений: 12
Спасибо сказали: 0 раз
Рейтинг: 0

denis84 @ Сегодня, 15:15 * ,
Спасибо большое. Нашел.
Хочется самому разобраться в простом. В программирование пока не лезу.

denis84 Подменю пользователя
сообщение 11.11.22, 15:53
Сообщение #17

Оратор
Иконка группы
Группа: Местный
Сообщений: 315
Из: Украина
Спасибо сказали: 93 раз
Рейтинг: 93

Максон @ Сегодня, 15:26 * ,
для спасибо есть специальная кнопка

Спасибо сказали: Максон,

Максон Подменю пользователя
сообщение 29.11.22, 22:25
Сообщение #18

Общительный
**
Группа: Пользователи
Сообщений: 12
Спасибо сказали: 0 раз
Рейтинг: 0

denis84 @ 11.11.22, 15:15
Теперь не могу найти форму печати фискального чека прро, нужно обновить данные фирмы. Подскажите пожалуйста если сталкивались с настройкой таких вещей.

Vofka Подменю пользователя
сообщение 30.11.22, 9:24
Сообщение #19

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13836
Из: Киев
Спасибо сказали: 4418 раз
Рейтинг: 3538

Максон, правила, пункт 6. Эту тему закрываю.

Спасибо сказали: Максон,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Тема закрыта Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 07.12.22, 4:49
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!