Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Оновити обробку в "Додаткових звітах та обробках" (програмно          
Inkognito Подменю пользователя
сообщение 29.09.22, 8:57
Сообщение #1

Ветеран
*******
Группа: Пользователи
Сообщений: 908
Из: Україна
Спасибо сказали: 446 раз
Рейтинг: 13.5

BAS Бухгалтерія 2.1
Необхідно оновити обробку в переліку "Додаткових звітів та обробок" програмно (додавання реалізовано, але необхідно саме оновленнія, якщо версія поточна вище):

Код

&НаКлиенте
Процедура Тест()
ОбработкаСсылка = ПолучитьСсылкуОбработки();

Если НЕ ОбработкаСсылка.Пустая() Тогда            
         знВерсии= УзнатьВерсиюОбработки(ОбработкаСсылка);
        
         Если знВерсии<АктуальнаяВерсия Тогда
//???
//припустимо, нова обробка тут: КаталогВременыхФайлов() + "ВнешняяОбработка2";
КонецЕсли;
КонецЕсли;


&НаСервере
Функция ПолучитьСсылкуОбработки()
    
    Возврат Справочники.ДополнительныеОтчетыИОбработки.НайтиПоРеквизиту("ИмяФайла", "ВнешняяОбработка1");

КонецФункции

&НаСервере
Функция УзнатьВерсиюОбработки(ОбработкаСсылка)
    
    Возврат ОбработкаСсылка.Версия;
    
КонецФункции


Сообщение отредактировал Vofka - 29.09.22, 9:05

Gazulo Подменю пользователя
сообщение 30.09.22, 12:13
Сообщение #2

Оратор
*****
Группа: Пользователи
Сообщений: 268
Спасибо сказали: 44 раз
Рейтинг: 44

Inkognito @ Вчера, 9:57 * ,
Для чого це потрібно, обробка зараз не працює?

Inkognito Подменю пользователя
сообщение 02.10.22, 13:59
Сообщение #3

Ветеран
*******
Группа: Пользователи
Сообщений: 908
Из: Україна
Спасибо сказали: 446 раз
Рейтинг: 13.5

Gazulo
Обробка наразі оновлюється в кожного користувача окремо на диску, а якщо вона буде в "Додаткових звітах та обробках", то можна завантажити 1 раз, і більше не буде (оскільки зміниться номер версії і вона стане актуальною). Якщо поточна версія працює некоректно, адмін може просто замінити її в "Додаткових звітах і обробках", а не скидати кожному користувачу для заміни файлу.
Не бачу методу "ПолучитьОбъект()", є декілька схожих, але як їх використовувати незрозуміло. Пошук по конфігуратору, щоб знайти приклади використання, не дав результатів.

Gazulo Подменю пользователя
сообщение 03.10.22, 9:04
Сообщение #4

Оратор
*****
Группа: Пользователи
Сообщений: 268
Спасибо сказали: 44 раз
Рейтинг: 44

Inkognito @ Вчера, 14:59 * ,
То хай адмін зайде замінить раз в "Додаткових звітах і обробках" і для всіх поміняється

sava1 Подменю пользователя
сообщение 03.10.22, 9:44
Сообщение #5

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2588
Из: Проскуров
Спасибо сказали: 639 раз
Рейтинг: 617.2

Цитата(Inkognito @ 02.10.22, 14:59) *
Не бачу методу "ПолучитьОбъект()", є декілька схожих, але як їх використовувати незрозуміло. Пошук по конфігуратору, щоб знайти приклади використання, не дав результатів.


Для ОФ - спр.ВнешниеОбработки - ФормаЭлемента - Процедура КоманднаяПанельФайлаИсточникаЗаменитьФайл(Элемент)



в КОРП - спр.Дополнит..ОтчетыИОбработки - ФормаЭлемента - Процедура ЗагрузитьИзФайла(Команда) которая сводится к
РезультатРегистрации = ДополнительныеОтчетыИОбработки.ЗарегистрироватьОбработку(ОбъектСправочника, ПараметрыРегистрации);




Inkognito Подменю пользователя
сообщение 03.10.22, 16:48
Сообщение #6

Ветеран
*******
Группа: Пользователи
Сообщений: 908
Из: Україна
Спасибо сказали: 446 раз
Рейтинг: 13.5

sava1
Оновлення не відбулось. Просто додалась ще одна версія обробки. Тепер їх стало дві (стара і нова версії).

sava1 Подменю пользователя
сообщение 04.10.22, 8:05
Сообщение #7

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2588
Из: Проскуров
Спасибо сказали: 639 раз
Рейтинг: 617.2

Параметры - правильно заполнены ?

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 01.12.22, 15:02
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!