Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> окно на весь екран          
4andriy Подменю пользователя
сообщение 16.10.23, 12:35
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 177
Спасибо сказали: 1 раз
Рейтинг: 1

1с 7.7
при открытии формы надо всегда нажимать "на весь екран" (квадратик)
а как сделать что-бы форма всегда открывалась на весь екран?
причем все формы открываются не на весь екран(

нашел такие варианты но они не работают:

вариант 1:

Если Форма.МодальныйРежим() = 1 Тогда 
  Окна = СоздатьОбъект("Окна");
  Окна.Максимизировать(Форма);
КонецЕсли;


вариант 2:

WSHShell = СоздатьОбъект("WScript.Shell"); 
WSHShell.SendKeys("%");
WSHShell.SendKeys("{LEFT}{DOWN 5}{ENTER}");

sava1 Подменю пользователя
сообщение 16.10.23, 13:48
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2699
Из: Проскуров
Спасибо сказали: 684 раз
Рейтинг: 663.3

по п.1
срр / формекс есть ?
закомментировать ЕСЛИ / КонецЕсли

denis84 Подменю пользователя
сообщение 16.10.23, 13:51
Сообщение #3

Оратор
Иконка группы
Группа: Местный
Сообщений: 445
Из: Украина
Спасибо сказали: 146 раз
Рейтинг: 147.5

4andriy @ Сегодня, 13:35 * ,
Процедура глМаксимизироватьОкно() Экспорт
   Попытка
       WSHShell = СоздатьОбъект("WScript.Shell");
       WSHShell.SendKeys("%");
       WSHShell.SendKeys("{LEFT}{DOWN}{DOWN}{DOWN}{DOWN}{DOWN}{ENTER}");
   Исключение
   КонецПопытки;
КонецПроцедуры


Вызывать в конце процедуры "ПриОткрытии" из модуля формы

а если есть формекс, то есть такой вариант:

Процедура ПослеОткрытия()
   ФормаРасш = СоздатьОбъект("РасширениеФормы");
   ФормаРасш.Maximize = 1;
КонецПроцедуры // ПослеОткрытия()


Сообщение отредактировал denis84 - 16.10.23, 13:52

Спасибо сказали: andrew76,

4andriy Подменю пользователя
сообщение 16.10.23, 13:54
Сообщение #4

Завсегдатай
****
Группа: Пользователи
Сообщений: 177
Спасибо сказали: 1 раз
Рейтинг: 1

denis84 @ Сегодня, 14:49 * ,
проблема в том, что если нажать эти кнопки без скрипта выходит такое меню (нажать Alt + пробел) :

Restore - активно (скидает окно)
Move - не активно
Size - не активно
Minimize - активно
Mazimize - не активно

denis84 Подменю пользователя
сообщение 16.10.23, 14:00
Сообщение #5

Оратор
Иконка группы
Группа: Местный
Сообщений: 445
Из: Украина
Спасибо сказали: 146 раз
Рейтинг: 147.5

4andriy @ Сегодня, 14:54 * ,
какие кнопки, я модуле формы документа у себя проверил оба варианта. у меня документ разворачивает на весь экран

4andriy Подменю пользователя
сообщение 16.10.23, 14:07
Сообщение #6

Завсегдатай
****
Группа: Пользователи
Сообщений: 177
Спасибо сказали: 1 раз
Рейтинг: 1

denis84 @ Сегодня, 15:00 * ,
я перепутал - это журнал ОБЩИЙ открывается не на весь екран

denis84 Подменю пользователя
сообщение 16.10.23, 14:18
Сообщение #7

Оратор
Иконка группы
Группа: Местный
Сообщений: 445
Из: Украина
Спасибо сказали: 146 раз
Рейтинг: 147.5

4andriy @ Сегодня, 15:07 * ,
Я только что вставил эту процедуру в форму списка "полного журнала"

Процедура глМаксимизироватьОкно() Экспорт
   Попытка
       WSHShell = СоздатьОбъект("WScript.Shell");
       WSHShell.SendKeys("%");
       WSHShell.SendKeys("{LEFT}{DOWN}{DOWN}{DOWN}{DOWN}{DOWN}{ENTER}");
   Исключение
   КонецПопытки;
КонецПроцедуры

// ===============================
Процедура ПриОткрытии()                                        
    // Определение был ли быстрый отбор
    ТекСтр = глВосстановитьЗначение(ИмяФормы, "ВидОтбораЖурнала", 1);
    Если ТекСтр > ВидОтбора.РазмерСписка() Тогда
        ТекСтр = ВидОтбора.РазмерСписка();
    КонецЕсли;
    ВидОтбора.ТекущаяСтрока(ТекСтр);
    
    ПриОткрытииИЛИПереоткрытииЖурнала("Открытие");
    
    // будем отслеживать только реальные изменения этих реквизитов
    Форма.ВидОтбора.ВыполнятьФормулуТолькоПриИзменении(1);

    глМаксимизироватьОкно();
КонецПроцедуры


и у меня журнал открылся на весь экран

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 13.07.24, 18:46
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!