Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Не работает выборка документов          
4andriy Подменю пользователя
сообщение 23.09.22, 12:41
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 177
Спасибо сказали: 1 раз
Рейтинг: 1

при выборке документов така ошибка:

Цитата
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: СуммаБезНДС = Документ.РасходнаяНакладная. <<?>> СуммаБезНДС;
Запрос[7] : Неверно заданный путь 'СуммаБезНДС'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: СуммаСНДС = Документ.РасходнаяНакладная. <<?>> СуммаСНДС;
Запрос[8] : Неверно заданный путь 'СуммаСНДС'
СУММАБЕЗНДС<<?>>
Переменная не определена (СУММАБЕЗНДС)
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: Функция СуммаБезНДС_ = Сумма(СуммаБезНДС <<?>> );
Запрос[9] : Ошибка в выражении 'СуммаБезНДС'
СУММАСНДС<<?>>
Переменная не определена (СУММАСНДС)
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: Функция СуммаСНДС_ = Сумма(СуммаСНДС <<?>> );
Запрос[10] : Ошибка в выражении 'СуммаСНДС'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: Условие(Фирма в ВыбФирма <<?>> );
Запрос[14] : Ошибка в условии
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{: Условие(Контрагент в список <<?>> );
Запрос[15] : Ошибка в условии


Сообщение отредактировал Vofka - 26.09.22, 8:32

denis84 Подменю пользователя
сообщение 23.09.22, 13:32
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 445
Из: Украина
Спасибо сказали: 146 раз
Рейтинг: 147.5

4andriy @ Сегодня, 13:41 * ,
Это сами ошибки! Запрос сам покажите.

Сообщение отредактировал denis84 - 23.09.22, 13:33

4andriy Подменю пользователя
сообщение 23.09.22, 13:52
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 177
Спасибо сказали: 1 раз
Рейтинг: 1

denis84 @ Сегодня, 14:32 * ,
//======================================================================
Процедура ЗаповнитиТаблицю()
    
    СтворитиСтруктуруТаблиці();
    
    ВидДок = спВидиДокументів.ПолучитьЗначение(спВидиДокументів.ТекущаяСтрока());
    
    ТекстЗапроса = "
    |Период с НачДата по КонДата;
    |ДатаДок = Документ.*.ДатаДок;
    |НомерДок = Документ.*.НомерДок;
    |Фирма = Документ.*.Фирма;
    |Контрагент = Документ.*.Контрагент;";
    Если ВидДок = "Приложение2" Тогда
        ТекстЗапроса = ТекстЗапроса + "
        |ИзмСуммыБезНДС = Документ.Приложение2.ИзмСуммыБезНДС;
        |ИзмНДС = Документ.Приложение2.ИзмНДС;
        |Функция СуммаБезНДС_ = Сумма(ИзмСуммыБезНДС);
        |Функция НДС_ = Сумма(ИзмНДС);
        |Функция СуммаСНДС_ = Сумма(ИзмСуммыБезНДС+ИзмНДС);";
    Иначе
        ТекстЗапроса = ТекстЗапроса + "
        |СуммаБезНДС = Документ.*.СуммаБезНДС;
        |СуммаСНДС = Документ.*.СуммаСНДС;
        |Функция СуммаБезНДС_ = Сумма(СуммаБезНДС);
        |Функция СуммаСНДС_ = Сумма(СуммаСНДС);";
        Если (ВидДок = "Т_РасходнаяНакладная") или (ИдентификаторКонфигурации = "UOUTK") Тогда
            ТекстЗапроса = ТекстЗапроса + "
            |Функция НДС_ = Сумма(СуммаСНДС-СуммаБезНДС);";
        Иначе
            ТекстЗапроса = ТекстЗапроса + "
            |НДС = Документ.*.НДС;
            |Функция НДС_ = Сумма(НДС);";
        КонецЕсли;
    КонецЕсли;
    
    ТекстЗапроса = ТекстЗапроса + "
    |Группировка Документ;
    |Условие(Фирма в ВыбФирма);
    |Условие(Контрагент в список);";    
    
    Если НеПоказуватиЗареєстровані = 1 Тогда
        Если (ВидДок = "НалоговаяНакладная") или (ВидДок = "Приложение2") Тогда
            ТекстЗапроса = ТекстЗапроса + "
            |ЕРНН = Документ.*.ЕРНН;
            |Условие(ЕРНН = 0);";
        КонецЕсли;
    КонецЕсли;
            
    ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "*", ВидДок);
    Запрос = СоздатьОбъект("Запрос");
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
    
    табл.УдалитьСтроки();
    
    НомерСтроки = 0;
    Пока Запрос.Группировка(1) = 1 Цикл
        НомерСтроки = НомерСтроки + 1;
        табл.НоваяСтрока();
        табл.ДатаДокумента = Запрос.ДатаДок;
        табл.НомерДокумента = Запрос.НомерДок;
        табл.Контрагент = Запрос.Контрагент;
        табл.КонтрагентИНН = табл.Контрагент.ИНН;
        табл.СуммаБезНДС = Запрос.СуммаБезНДС_;
        табл.НДС = Запрос.НДС_;
        табл.СуммаСНДС = Запрос.СуммаСНДС_;
        табл.Документ = Запрос.Документ;
        Если Метаданные.Документ(табл.Документ.Вид()).РеквизитШапки("ЕРНН").Выбран() = 1 Тогда
            табл.ЕРНН = ?(табл.Документ.ЕРНН = 1,2,1);
            табл.Пометка = ?(табл.ЕРНН = 2,1,2);
        Иначе
            табл.Пометка = 2;
        КонецЕсли;
        табл.ДокИД = РозрахуватиДокИД(Запрос.Документ);
        табл.Результат = "Документ з бази 1С";
        
        Для і = 1 По спРекв.РазмерСписка() Цикл
            Если спРекв.Пометка(і) = 0 Тогда
                Продолжить;
            КонецЕсли;
            табл.УстановитьЗначение(НомерСтроки, спРекв.ПолучитьЗначение(і), табл.Документ.ПолучитьАтрибут(спРекв.ПолучитьЗначение(і)));
        КонецЦикла;
        
    КонецЦикла;
    
    ЗаповнитиСтатусиДокументів(1);
    
    Если Форма.Закладки.ТекущаяСтрока() = 1 Тогда
        Форма.Закладки.ТекущаяСтрока(2);
        Форма.ИспользоватьСлой("Загальний, Таблиця", 2);
    КонецЕсли;
    
КонецПроцедуры

denis84 Подменю пользователя
сообщение 23.09.22, 15:44
Сообщение #4

Оратор
Иконка группы
Группа: Местный
Сообщений: 445
Из: Украина
Спасибо сказали: 146 раз
Рейтинг: 147.5

4andriy @ Сегодня, 14:52 * ,
исходя из ошибок, то получается. Что у вас в расходной накладной нет реквизита "СуммаБезНДС" и далее по тексту.


Сообщение отредактировал denis84 - 23.09.22, 15:45

Спасибо сказали: 4andriy,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 21.07.24, 11:27
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!