Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Не попадают данные с запроса в текстовые документ , выгрузка данных в текстовый документ          
lina1982 Подменю пользователя
сообщение 03.10.21, 5:36
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 14
Спасибо сказали: 1 раз
Рейтинг: 1

Здравствуйте, Кнфигурация:
1С:Предприятие 8.3 (8.3.16.1063)
Бухгалтерия предприятия, редакция 3.0 - (1.3.10.150)

&НаСервере
Процедура ВыгрузитьНаСервере()
    
    
    Текст = Новый ТекстовыйДокумент;
    
    СтрокаТекст = "1CClientBankExchange";
    Текст.ДобавитьСтроку(СтрокаТекст);
    СтрокаТекст = "ВерсияФормата = 1.01";
    Текст.ДобавитьСтроку(СтрокаТекст);
    СтрокаТекст = "Кодировка = Windows";
    Текст.ДобавитьСтроку(СтрокаТекст);

            
        Запрос = Новый Запрос;
        
        
        Запрос.Текст =
        "ВЫБРАТЬ
        |    ПлатежноеПоручениеИсходящее.Ссылка,
        |    ПлатежноеПоручениеИсходящее.БанковскийСчет,
        |    ПлатежноеПоручениеИсходящее.Контрагент,
        |    ПлатежноеПоручениеИсходящее.БанковскийСчетПолучателя,
        |    ПлатежноеПоручениеИсходящее.СуммаДокумента
        |ИЗ
        |    Документ.ПлатежноеПоручениеИсходящее КАК ПлатежноеПоручениеИсходящее
        |ГДЕ
        |    ПлатежноеПоручениеИсходящее.Ссылка = &Ссылка";
                
        Запрос.УстановитьПараметр("Ссылка",  Ссылка);


        РезультатЗапроса = Запрос.Выполнить();
    
    ТЗ = РезультатЗапроса.Выбрать();
    Стр = ТЗ.БанковскийСчет;
    Текст.ДобавитьСтроку(Стр);
    Стр = ТЗ.Контрагент;
    Текст.ДобавитьСтроку(Стр);
    Стр =  ТЗ.БанковскийСчетПолучателя;
   Текст.ДобавитьСтроку(Стр);

    
        
        
    //КонецЦикла;
    АдресФайла = Объект.Файл;
    // Текст.Записать("D:\30_03_2021\гог.txt");
    Текст.Записать(АдресФайла);
    
    
    
    
    
КонецПроцедуры



&НаКлиенте
Процедура Выгрузить(Команда)
    ВыгрузитьНаСервере();
КонецПроцедуры



До запроса информацию выгружает, а сам запрос не видит... и ругается на:
Запрос.УстановитьПараметр("Ссылка",  Ссылка);


Не могу понять как из запроса записать данные в текстовый документ.
Помогите, пожалуйтста!


denis84 Подменю пользователя
сообщение 04.10.21, 7:20
Сообщение #2

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 245
Из: Украина
Спасибо сказали: 66 раз
Рейтинг: 66

lina1982 @ Вчера, 6:36 * ,

Ссылку выбераете на форме?

Напишите так:

ЭтотОбъект.Ссылка


Vofka Подменю пользователя
сообщение 04.10.21, 8:30
Сообщение #3

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13607
Из: Киев
Спасибо сказали: 4255 раз
Рейтинг: 3411.8

Цитата
ТЗ = РезультатЗапроса.Выбрать();

Это не ТЗ, а выборка из результата запроса. Что бы по ней двигаться, надо вызывать метод Следующий() на ней.

Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
   Стр = Выборка.БанковскийСчет;
КонецЦикла;

lina1982 Подменю пользователя
сообщение 06.10.21, 11:03
Сообщение #4

Общительный
**
Группа: Пользователи
Сообщений: 14
Спасибо сказали: 1 раз
Рейтинг: 1

Vofka @ 04.10.21, 8:30 * ,
Благодарю! У меня все получилось!

lina1982 Подменю пользователя
сообщение 06.10.21, 16:02
Сообщение #5

Общительный
**
Группа: Пользователи
Сообщений: 14
Спасибо сказали: 1 раз
Рейтинг: 1

denis84 @ 04.10.21, 8:20 * ,
Спасибо большое за помощь!

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 23.10.21, 20:04
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!