Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Не получается получить доступ к реквизиту формы , реквизит типа Документ          
Eskin Подменю пользователя
сообщение 11.09.21, 22:39
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

Доброго времени суток.

1С:Предприятие 8.3 (8.3.16.1224)
Управление небольшой фирмой для Украины, редакция 1.6 (1.6.11.1)

Слабо знаком с управляемыми формами, поэтому прошу помощи.
Если коротко, то задача состоит вот в чем: необходимо из формы внешней обработки редактировать некоторые реквизиты документа ЗаказПокупателя с дальнейшей записью документа. Создал две формы во внешней обработки (для списка и документа), в форме "документа" создал реквизит Заказ типа ДокументСсылка.ЗаказПокупателя и Комментарий типа Строка.

Вот так я получаю данные конкретного документа:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если Параметры.Свойство("ЗаказДанные") Тогда

         Заказ = Документы.ЗаказПокупателя.НайтиПоНомеру(Параметры.ЗаказДанные.Номер, Параметры.ЗаказДанные.Дата);
        
    КонецЕсли;
КонецПроцедуры


А вот в процедуре
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ПриОткрытииНаСервере();

    Комментарий = Заказ.Комментарий;
    
КонецПроцедуры


выдает ошибку "Поле объекта не обнаружено (Комментарий)".

В процедуре На сервере в отладчике я полностью вижу объект Заказ - могу отрыть плюсик и увидеть все данные, но после выхода из процедуры плюсик пропадает. Видимо я чего-то не знаю при работе с УФ. Подскажите, где я туплю. Заранее спасибо.

Сообщение отредактировал Vofka - 12.09.21, 14:24


assist2erp Подменю пользователя
сообщение 12.09.21, 6:53
Сообщение #2

Молчаливый
*
Группа: Пользователи
Сообщений: 6
Из: Україна
Спасибо сказали: 1 раз
Рейтинг: 1

В процедуре ПриСозданииНаСервере на входе у вас есть ссылка. По ссылке с помощью ОбщегоНазначения.ЗначенияРеквизитовОбъекта получаете все реквизиты документа которые вам необходимы на форме. Производите ваши действия на форме, в обработчике команды записи проверяете введенные значения, собираете все нужные вам данные в структуру и передаете в процедуру модуля обработки и там записываете измененные данные документа.

Тяжело переходить с 77 на 8, и тем более на УФ.wink.gif
Это нужно понять один раз разделение на клиент/сервер, и дальше будет все ОК

Vofka Подменю пользователя
сообщение 12.09.21, 14:25
Сообщение #3

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13571
Из: Киев
Спасибо сказали: 4237 раз
Рейтинг: 3394.6

Eskin, а почему вы не заполняете комментарий в ПриСозданииНаСервере?
На клиенте нельзя обратиться через точку к реквизитам ссылки.

Сообщение отредактировал Vofka - 12.09.21, 14:26

Eskin Подменю пользователя
сообщение 13.09.21, 8:14
Сообщение #4

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

assist2erp @ Вчера, 7:53 * ,

Благодарю! Это ценная инфа.

Vofka @ Вчера, 15:25 * ,

Это решение было настолько простым, что я до него не додумался. Спасибо!

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 18.09.21, 0:28
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!