Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> НачалоВыбора или НачалоВыбораизСписка ? (1c 8.3 УФ) , проблема с обработкой выбора при вводе данных на управляемой форме          
andrew76 Подменю пользователя
сообщение 10.07.24, 11:24
Сообщение #1

Оратор
*****
Группа: Пользователи
Сообщений: 445
Из: Казахстан
Спасибо сказали: 43 раз
Рейтинг: 43

Добрый день !

Имеется справочник Насосные с табличной частью Резервуары.
На форме форме (управляемой) ввода данных имеются поля ввода данных:
насосная,номер резервуара.
Пользователь сначала выбирает насосную.
Далее мне необходимо при выборе номера резервуара,сделать так ,чтобы в этом поле ввода появился список номеров резервуаров,
привязанных именно к насосной выбранной выше.На простых формах я это делал через событие НачалоВыбораИзСписка.
Как это сделать на упраляемых формах - затрудняюсь.

AnryMc Подменю пользователя
сообщение 10.07.24, 11:48
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 376
Спасибо сказали: 103 раз
Рейтинг: 103.6

andrew76 @ Сегодня, 12:24 * ,

Возможно как то так:

&НаКлиенте
//Замена стандартного выбора элементов
Процедура ХХХХХХХХХХХХХХХНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;

ВариантыВыбора = СписокМоихЗачений();

    Оповещение = Новый ОписаниеОповещения("ВыполнитьПослеВыбораНужного", ЭтотОбъект,  Элемент);

        ПоказатьВыборИзСписка(Оповещение, ВариантыВыбора, Элемент);

//*************

&НаКлиенте
Процедура ВыполнитьПослеВыбораНужного(РезультатВыбора, ДополнительныеПараметры) Экспорт
    
    Если РезультатВыбора = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
    Объект.МойРеквизит= РезультатВыбора.Значение;
    
КонецПроцедуры

&НаСервер
Функция СписокМоихЗачений()
    
    ВариантыВыбора = Новый СписокЗначений();

//заполнить как надо - например запросом
    
    ВариантыВыбора.Добавить(НужноеМнеЗначение_1, "Представление нужного мне значения № 1 для отображения при выборе");

    Возврат ВариантыВыбора;
    
КонецФункции


Сообщение отредактировал AnryMc - 10.07.24, 11:52

Спасибо сказали: andrew76,

andrew76 Подменю пользователя
сообщение 10.07.24, 12:49
Сообщение #3

Оратор
*****
Группа: Пользователи
Сообщений: 445
Из: Казахстан
Спасибо сказали: 43 раз
Рейтинг: 43

AnryMc @ Сегодня, 14:48 * ,

А саму форму элемента справочника Насосных нельзя открыть программно ? Я пытаюсь,но открывается форма ввода нового элемента.

&НаКлиенте
Процедура РезервуарНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
        
СтандартнаяОбработка = Ложь;
Структура = Новый Структура("Насосная", Объект.Насосная);
ОткрытьФорму("Справочник.Насосная.Форма.ФормаЭлемента", Структура);


AnryMc @ Сегодня, 14:48 * ,

Большое Вам Спасибо ! Все работает !

DariaDaria Подменю пользователя
сообщение 12.07.24, 10:35
Сообщение #4

Молчаливый
*
Группа: Пользователи
Сообщений: 1
Спасибо сказали: 0 раз
Рейтинг: 0

А почему бы просто не воспользоваться такой штукой как СвязиПараметровВыбора? Прямо в свойствах реквизита или в свойствах элемента формы

AnryMc Подменю пользователя
сообщение 14.07.24, 10:04
Сообщение #5

Оратор
Иконка группы
Группа: Местный
Сообщений: 376
Спасибо сказали: 103 раз
Рейтинг: 103.6

Цитата(DariaDaria @ 12.07.24, 11:35) *
А почему бы просто не воспользоваться такой штукой как СвязиПараметровВыбора? Прямо в свойствах реквизита или в свойствах элемента формы

Связь даст весь список
А если нужны дополнительные отборы???

//заполнить как надо - например запросом


Сообщение отредактировал AnryMc - 14.07.24, 10:05

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 18.07.24, 3:05
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!