Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Как загрузить номенклатуру из внешнего файла (Excel и др.) в 1С 8.3 штатными средствами? , чуть-чуть подпилить конфигурацию и можно загружать номенклатуру          
glavkomnn Подменю пользователя
сообщение 30.11.19, 23:23
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 8
Спасибо сказали: 2 раз
Рейтинг: 2.6

Коллеги приветствую!

Подавляющее большинство не знает, что разработчики оставили лазейку - возможность загрузить справочники в базу самостоятельно. Но оставить-то оставили, да не совсем. Ряд справочников доступен для загрузки, а некоторые стратегически важные, такие, как, например, Номенклатура - недоступны. Но путем нехитрых действий с расширениями можно добиться того, чтобы типовая загрузка могла загрузить в базу также и справочник Номенклатура. В данном видео описан порядок действий, чтобы этого достичь.

Неожиданно для себя наткнулся на то, что оказывается МОЖНО загрузить номенклатуру штатными средствами, встроенной загрузкой из файла в конфигурации УТ 11. Если немного подпилить её расширением.

Может кому пригодится, делюсь лайфхаком, записал на видео, как это можно сделать

В модуле менеджера обработки "ЗагрузкаИзВнешнегоФайла" надо в функции "СправочникСодержитРеквизитИсключение" закомментировать код:

Для каждого Реквизит Из Справочник.ТабличныеЧасти Цикл
        Если Реквизит.Имя <> "КонтактнаяИнформация"
            И Реквизит.Имя <> "ДополнительныеРеквизиты"
            И Реквизит.Имя <> "СертификатыШифрования" Тогда
                Возврат Истина;
        КонецЕсли;
    КонецЦикла;
    
    Для каждого Реквизит Из Справочник.Реквизиты Цикл
        Для каждого ТипРеквизита Из Реквизит.Тип.Типы() Цикл
            Если ТипРеквизита = Тип("ХранилищеЗначения") Тогда
                Возврат Истина;
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;


Тогда справочник "Номенклатура" будет доступен в списке загрузки
И собственно вопрос
Вы не разбирались, по какой причине разработчики зашили такое ограничение - не загружать "Доп. реквизиты" и "Хранилище значения". Это намеренный ход или случайное совпадение, что самый стратегически загружаемый справочник, содержащий такие реквизиты, оказался за пределами возможностей загрузки?

Сообщение отредактировал Vofka - 02.12.19, 10:42

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 06.12.19, 15:32
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!