Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Как програмно установить шрифт в форматированом документе          
kostya77 Подменю пользователя
сообщение 02.05.24, 13:34
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 139
Спасибо сказали: 5 раз
Рейтинг: 4

Добрый день. Есть код который из текста делает HTML

Если Объект.ОписаниеВФорматеHTML Тогда 
        Если Найти(Объект.Описание, "</html>") = 0 Тогда
            _ОписаниеHTML = "<html>" + Объект.Описание + "</html>";    
        Иначе    
            _ОписаниеHTML = Объект.Описание;    
        КонецЕсли;
        ОписаниеHTML.УстановитьHTML(_ОписаниеHTML, Новый Структура);
    КонецЕсли;


Подскажите, как програмно установить шрифт?

Сообщение отредактировал Vofka - 03.05.24, 7:57

denis84 Подменю пользователя
сообщение 02.05.24, 14:08
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 440
Из: Украина
Спасибо сказали: 144 раз
Рейтинг: 145.5

kostya77 @ Сегодня, 14:34 * ,
//Обработка элементов форматированного документа, входящего в состав параграфа, может оказаться полезной в том случае, 
//если нужно, например, убрать все оформление в виде курсива или полужирного шрифта.

//Пример:

Полужирный = Новый Шрифт(, , Истина);
Курсив = Новый Шрифт(, , , Истина);
Обычный = Новый Шрифт;
Для каждого Элемент Из Параграф.Элементы Цикл
     Если ТипЗнч(Элемент) = Тип("ПереводСтрокиФорматированногоДокумента") Тогда        
           Продолжить;
     КонецЕсли;
     Если Элемент.Шрифт = Полужирный Или Элемент.Шрифт = Курсив Тогда          
           Элемент.Шрифт = Обычный
     КонецЕсли;
КонецЦикла;

Спасибо сказали: kostya77,

kostya77 Подменю пользователя
сообщение 02.05.24, 14:32
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 139
Спасибо сказали: 5 раз
Рейтинг: 4

denis84 @ Сегодня, 15:08 * ,
Это помогло. А как еще установить свой шрифт, например roboto

denis84 Подменю пользователя
сообщение 02.05.24, 15:46
Сообщение #4

Оратор
Иконка группы
Группа: Местный
Сообщений: 440
Из: Украина
Спасибо сказали: 144 раз
Рейтинг: 145.5

kostya77 @ Сегодня, 15:32 * ,
//Новый Шрифт(<ИмяШрифта>, <Размер>, <Полужирный>, <Наклонный>, <Подчеркнутый>, <Зачеркнутый>, <Масштаб>)

Шрифт = Новый Шрифт("robota", 11, Истина);

Элемент.Шрифт = Шрифт;


Сообщение отредактировал denis84 - 02.05.24, 15:57

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 14.06.24, 7:35
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!