Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Как получить всех родителей элемента справочника?          
kostya77 Подменю пользователя
сообщение 15.02.24, 14:23
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 125
Спасибо сказали: 5 раз
Рейтинг: 4

Добрый день. Подскажиет как получить всех родетелей елемента справочника

Сообщение отредактировал Vofka - 16.02.24, 9:58

AnryMc Подменю пользователя
сообщение 15.02.24, 15:28
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 328
Спасибо сказали: 96 раз
Рейтинг: 97.6

kostya77 @ Сегодня, 15:23 * ,

ПолныйКод()

Синтаксис:
ПолныйКод()
Назначение:
Возвращает строку, содержащую полный код выбранного элемента справочника со всеми вышестоящими уровнями, разделенными символом /.

Спасибо сказали: kostya77,

volodya1122 Подменю пользователя
сообщение 19.02.24, 16:21
Сообщение #3

Оратор
Иконка группы
Группа: Местный
Сообщений: 336
Из: Тернопіль
Спасибо сказали: 133 раз
Рейтинг: 135.7

kostya77 @ 15.02.24, 14:23 * ,

Якщо потрібно ссилки на кожнного родителя

       // ЭлСправ- ссилка на конкректний елемент справочника 
    Если Метаданные.Справочники.МойСправочник.ОграничиватьКоличествоУровней тогда
        МаксимумУровней=Метаданные.Справочники.МойСправочник.КоличествоУровней;
    иначе    
        МаксимумУровней=100; // хватає з великим запасорв в реальних базах
    КонецЕсли;
    Сообщить(ЭлСправ.ПолныйКод());
    Ел1=ЭлСправ;
    Для к=1 по МаксимумУровней цикл
        Ел1=Ел1.Родитель; // по ссилці
        Если Ел1=Справочники.МойСправочник.ПустаяСсылка() тогда
            Прервать;
        КонецЕсли;
        Сообщить("-"+к+"-"+Ел1.Наименование);
    КонецЦикла;


Сообщение отредактировал volodya1122 - 19.02.24, 16:21

andrew76 Подменю пользователя
сообщение 20.02.24, 17:57
Сообщение #4

Оратор
*****
Группа: Пользователи
Сообщений: 443
Из: Казахстан
Спасибо сказали: 43 раз
Рейтинг: 43

Этот код от 1С 8.

andrew76 @ Сегодня, 20:06 * ,


Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Обрабатывать НеПомеченныеНаУдаление;
|Период с  ДатаАкт по ДатаАкт;
|Сотр      = Справочник.Сотрудники.ТекущийЭлемент;
|Без итогов;
|группировка Сотр;
|"//}}ЗАПРОС
;
      

// Если ошибка в запросе, то выход из процедур
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
     Возврат;
КонецЕсли;


Пока Запрос.Группировка() = 1 Цикл              
     Сообщить(Запрос.Сотр.ПолныйКод());
КонецЦикла;

takefive Подменю пользователя
сообщение 22.02.24, 17:19
Сообщение #5

Говорящий
***
Группа: Пользователи
Сообщений: 62
Из: Днепропетровск
Спасибо сказали: 22 раз
Рейтинг: 23.2

    Родитель = СсылкаНаОбъект.Родитель;
    Пока Родитель.Выбран() = 1 Цикл
        Сообщить(Родитель);
        Родитель = Родитель.Родитель;
    КонецЦикла;


Signature
без свинга нет музыки...

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 14.04.24, 4:20
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!