Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Googel аутентификация OAuth          
SV71 Подменю пользователя
сообщение 16.04.20, 12:50
Сообщение #1

Говорящий
***
Группа: Пользователи
Сообщений: 80
Спасибо сказали: 3 раз
Рейтинг: 3

Всем здравствовать!

Самописная конфигурация на платформе 1С:Предприятие 8.3 (8.3.3.721) управляемые формы.

По статье в интернет создал внешнюю обработку с формой:
.

Для кнопки "Авторизация" создал такую же команду.

Содержание модуля взял из той же статьи:
&НаКлиенте
Процедура Авторизация(пОписаниеДействия = Неопределено)
    ПараметрыФормы = новый структура("Адрес", АдресСтраницыАутентификации());
    ОО = Новый ОписаниеОповещения("ОбработатьAccessToken", ЭтаФорма, пОписаниеДействия);        
    ОткрытьФорму("ВнешняяОбработка.АутентификацияGoogle.Форма.ФормаАутентификации", ПараметрыФормы, Элементы.Авторизоваться, ,,,ОО, РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
КонецПроцедуры

&НаКлиентеНаСервереБезКонтекста
Функция АдресСтраницыАутентификации()

    ПараметрыURL = Новый Структура;
    Адрес = "https://accounts.google.com/o/oauth2/v2/auth";
    ПараметрыURL.Вставить("client_id", "<ваш уникальный идентификатор приложения из Google API console>.apps.googleusercontent.com");
    ПараметрыURL.Вставить("redirect_uri", "http://localhost");
    ПараметрыURL.Вставить("scope", "https://www.googleapis.com/auth/calendar.readonly https://www.googleapis.com/auth/calendar.events.readonly  https://www.googleapis.com/auth/calendar");
    ПараметрыURL.Вставить("response_type", "code");
    ПараметрыURL.Вставить("prompt", "consent"); //Пользователю отображается только окно разрешения доступа к его пользовательским данным
    Возврат Адрес(Адрес, ПараметрыURL);

КонецФункции // ПолучитьAuthToken()


При сохранении выдает ошибку:
Цитата
{Обработка.Google.Форма.Данные.Форма(20,10)}: Процедура или функция с указанным именем не определена (Адрес)
Возврат <<?>>Адрес(Адрес, ПараметрыURL); (Проверка: Сервер)
{Обработка.Google.Форма.Данные.Форма(20,10)}: Процедура или функция с указанным именем не определена (Адрес)
Возврат <<?>>Адрес(Адрес, ПараметрыURL); (Проверка: Тонкий клиент)


Предполагаю что в статье не дали код функции "Адрес".

Есть у специалистов предположение, что в этой функции или может это функция из какой-нибудь библиотеки?

Vofka Подменю пользователя
сообщение 16.04.20, 13:18
Сообщение #2

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13402
Из: Киев
Спасибо сказали: 4143 раз
Рейтинг: 3290.4

Вроде вот:

&НаСервереБезКонтекста
Функция Адрес(Знач URL, Знач ПараметрыURL)
    
    Перем МассивПараметров;
    МассивПараметров = Новый Массив;
    Для каждого Параметр Из ПараметрыURL Цикл
        МассивПараметров.Добавить(Параметр.Ключ + "=" + Параметр.Значение);
    КонецЦикла;
    URL = СокрП(URL);
    URL = ?(СтрЗаканчиваетсяНа(URL, "/"), URL, URL + "/");
    Возврат URL + "?" + КодироватьСтроку(СтрСоединить(МассивПараметров, "&"),    СпособКодированияСтроки.URLВКодировкеURL);

КонецФункции

Спасибо сказали: andreykyiv@bigmir.net, SV71,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 27.11.20, 13:24
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!