Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Выбор минимальной даты в ТаблицеЗначений 1С 7.70.003 торговля склад для Украины?          
ZUBR Подменю пользователя
сообщение 25.06.20, 13:14
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 217
Из: Київ
Спасибо сказали: 4 раз
Рейтинг: 3

Здравствуйте. Есть таблица значений, в которой есть колонка ДатаПриема. Нужно из этой колонки выбрать минимальную дату.

Расх=СоздатьОбъект("Документ.РасходнаяНакладная");
ТЗ=СоздатьОбъект("ТаблицаЗначений");
ТЗ.НоваяКолонка("ДатаПриема");
...................................................................
..................................................................
Расх.ВыбратьДокументы(НачДата, КонДата);
Пока Расх.ПолучитьДокумент()=1 цикл
ТЗ.ДатаПриема=Расх.ДатаПриема;
................................................
....................................................
КонецЦикла;

МинДата=???????????


Как определить из таблицы значений минимальную дату из всех значений ДатаПриема?
Спасибо!

denis84 Подменю пользователя
сообщение 25.06.20, 14:18
Сообщение #2

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 142
Из: Украина
Спасибо сказали: 39 раз
Рейтинг: 39

ZUBR @ Сегодня, 14:14 * ,
Добрый день! Отсортировать ТЗ по возрастанию и получить значение из первой строки.

Если не ошибаюсь вот так:
ТЗ.Сортировать("+ номер или идентификатор колонки");
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку() = 1 Цикл
    МинДата = ТЗ.ПолучитьЗначение(номерСтроки,номер или идентификатор колонки);
        Сообщить(МинДата);
КонецЦикла;


denis84 @ Сегодня, 14:46 * ,

Цикл не нуженsad.gifкод вписал чуть не тот(невнимательно))
ТЗ.Сортировать("+ номер или идентификатор колонки");
МинДата = ТЗ.ПолучитьЗначение(номерСтроки,номер или идентификатор колонки);
Сообщить(МинДата);


Сообщение отредактировал denis84 - 25.06.20, 14:06

Sharzem Подменю пользователя
сообщение 25.06.20, 15:08
Сообщение #3

Оратор
Иконка группы
Группа: Местный
Сообщений: 269
Спасибо сказали: 80 раз
Рейтинг: 80.6

denis84 @ Сегодня, 14:18 * ,
Результат той самий. Добавити лише Прервать. Сам так роблю іноді.
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку() = 1 Цикл
    МинДата = ТЗ.ПолучитьЗначение(номерСтроки,номер или идентификатор колонки);
    Сообщить(МинДата);
    Прервать;
КонецЦикла;

На ДБФ відпрацює однаково. Мала затримка на виборці.
Можна ще так:
ТЗ.ВыбратьСтроки();
Если ТЗ.ПолучитьСтроку() = 1 Тогда
    МинДата = ТЗ.ПолучитьЗначение(номерСтроки,номер или идентификатор колонки);
    Сообщить(МинДата);
КонецЕсли;


Сообщение отредактировал Sharzem - 25.06.20, 15:10


Signature
То, что для одного человека константа, для другого - переменная. (Алан.Дж.Перлис)

Спасибо сказали: ZUBR,

denis84 Подменю пользователя
сообщение 25.06.20, 15:16
Сообщение #4

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 142
Из: Украина
Спасибо сказали: 39 раз
Рейтинг: 39

Цитата(Sharzem @ 25.06.20, 16:08) *
На ДБФ відпрацює однаково. Мала затримка на виборці.

Согласен

Спасибо сказали: ZUBR,

andrew76 Подменю пользователя
сообщение 26.06.20, 18:53
Сообщение #5

Оратор
*****
Группа: Пользователи
Сообщений: 346
Из: Узбекистан
Спасибо сказали: 36 раз
Рейтинг: 36

Цитата(ZUBR @ 25.06.20, 16:14) *
Отсортировать ТЗ по возрастанию и получить значение из первой строки.


Цикл строить не надо.

ТЗ.Сортировать("+ДатаПриема");
Сообщить(ТЗ.ПолучитьЗначение(1,"ДатаПриема")); //минимальное значение

Спасибо сказали: ZUBR,

ZUBR Подменю пользователя
сообщение 27.06.20, 13:19
Сообщение #6

Завсегдатай
****
Группа: Пользователи
Сообщений: 217
Из: Київ
Спасибо сказали: 4 раз
Рейтинг: 3

Всем спасибо! Все верно! Сортировка! Совсем вылетело из головы!

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 11.07.20, 6:46
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!