Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> быстрый поиск документа          
4andriy Подменю пользователя
сообщение 13.05.20, 18:46
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 111
Спасибо сказали: 0 раз
Рейтинг: 0

1с 7.7 Предприятие
создаю документ, например счет. в счете добавил кнопку сохранения ссылки на документ
Процедура быстросохранить()
Если ПустоеЗначение(ТекущийЭлемент())=1 Тогда
Возврат;
КонецЕсли;  
Если ТекущийЭлемент().ЭтоГруппа()=1 Тогда
Возврат;
КонецЕсли;        
Элемент=СоздатьОбъект("Справочник.Контрагенты");
Элемент.найтиЭлемент(ТекущийЭлемент());
//сдесь не работает
вар 1) Элемент.быстдоступ=ТекущийДокумент();
вар 2) Элемент.быстдоступ=ТекущийЭлемент();
вар 3) Элемент.быстдоступ=этотдокумент();
//
КонецПроцедуры


как мне передать реквизиту "быстдоступ" ссылку на этот документ который открыт, причем вручную сам документ могу выбрать их всего журнала, а програмно нет

denis84 Подменю пользователя
сообщение 13.05.20, 19:12
Сообщение #2

Говорящий
***
Группа: Пользователи
Сообщений: 98
Из: Украина
Спасибо сказали: 28 раз
Рейтинг: 27

4andriy @ Сегодня, 19:46 * ,
А реквизит быстдоступ какого типа?

4andriy Подменю пользователя
сообщение 13.05.20, 19:18
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 111
Спасибо сказали: 0 раз
Рейтинг: 0

denis84 @ Сегодня, 20:12 * ,
тип значение Документ.счет но сейчас даже со счетом не работает в трех вариантах

denis84 Подменю пользователя
сообщение 13.05.20, 19:22
Сообщение #4

Говорящий
***
Группа: Пользователи
Сообщений: 98
Из: Украина
Спасибо сказали: 28 раз
Рейтинг: 27

4andriy @ Сегодня, 20:18 * ,
Если не ошибаюсь документ этот надо записать,а потом передать ссылку на этот документ. Элемент.быстдоступ= ТекущийДокумент();

4andriy Подменю пользователя
сообщение 13.05.20, 19:45
Сообщение #5

Завсегдатай
****
Группа: Пользователи
Сообщений: 111
Спасибо сказали: 0 раз
Рейтинг: 0

denis84 @ Сегодня, 20:22 * ,
добавил
Записать();


4andriy @ Сегодня, 20:24 * ,
проблема в передаче параметра документа в реквизит

Функция не обнаружена (ТекущийДокумент)


4andriy @ Сегодня, 20:28 * ,
да, после записи работает лучше... но как записать открытый документ програмно

denis84 Подменю пользователя
сообщение 13.05.20, 19:48
Сообщение #6

Говорящий
***
Группа: Пользователи
Сообщений: 98
Из: Украина
Спасибо сказали: 28 раз
Рейтинг: 27

4andriy @ Сегодня, 20:28 * ,
Элемент это справочник контрагентов?

4andriy Подменю пользователя
сообщение 13.05.20, 19:48
Сообщение #7

Завсегдатай
****
Группа: Пользователи
Сообщений: 111
Спасибо сказали: 0 раз
Рейтинг: 0

denis84 @ Сегодня, 20:48 * ,
да, я в справочник контрагентов добавил реквизит

denis84 Подменю пользователя
сообщение 13.05.20, 19:54
Сообщение #8

Говорящий
***
Группа: Пользователи
Сообщений: 98
Из: Украина
Спасибо сказали: 28 раз
Рейтинг: 27

4andriy @ Сегодня, 20:48 * ,
в справочнике контрагентов после счет.Записать(); Написать быстдоступ=счет.ТекущийДокумент():- это будет ссылка в справочнике на ваш созданный документ счёт. Ссылка появится только записи самого документа. Завтра попробую у себя,если у Вас не получится,то сообщу результат. Счёт через создать объект создаёте?

Спасибо сказали: 4andriy,

4andriy Подменю пользователя
сообщение 13.05.20, 20:15
Сообщение #9

Завсегдатай
****
Группа: Пользователи
Сообщений: 111
Спасибо сказали: 0 раз
Рейтинг: 0

denis84 @ Сегодня, 20:54 * ,
нет, вручную
после записи документа начинает работать ТекущийДокумент, но програмно не делает запись

4andriy @ Сегодня, 20:59 * ,
уже понял, Записать(); не там написал) тестирую

4andriy @ Сегодня, 21:04 * ,
заработало)

denis84 Подменю пользователя
сообщение 13.05.20, 20:23
Сообщение #10

Говорящий
***
Группа: Пользователи
Сообщений: 98
Из: Украина
Спасибо сказали: 28 раз
Рейтинг: 27

4andriy @ Сегодня, 21:15 * ,
Ок. Значит все получилось?

Спасибо сказали: 4andriy,

4andriy Подменю пользователя
сообщение 13.05.20, 20:54
Сообщение #11

Завсегдатай
****
Группа: Пользователи
Сообщений: 111
Спасибо сказали: 0 раз
Рейтинг: 0

denis84 @ Сегодня, 21:23 * ,
да, спасибо)

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 02.06.20, 17:15
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!