Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Расшифровка - из отчета в табличную часть документа , Конфигурация самописная          
DiMart Подменю пользователя
сообщение 05.02.20, 10:58
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

Отчет формирует список документов по конкретному товару. При двойном нажатии мыши на ячейке отчета с конкретным документом - последний открывается. Вопрос: как сделать так, чтобы активировалась строка табличной части открытого документа с выбранным в отчете товаре?

sava1 Подменю пользователя
сообщение 05.02.20, 11:44
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2233
Из: Проскуров
Спасибо сказали: 535 раз
Рейтинг: 522.8

самому прописать обработку расшифровки

DiMart Подменю пользователя
сообщение 05.02.20, 12:13
Сообщение #3

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

sava1 @ Сегодня, 11:44 * ,
Обработка прописана, документ открывается. Цель: нужно, чтобы в открытом документе активизировалась строка в табличной части с выбранным товаром

CobraS Подменю пользователя
сообщение 05.02.20, 12:46
Сообщение #4

Говорящий
Иконка группы
Группа: Местный
Сообщений: 85
Спасибо сказали: 80 раз
Рейтинг: 68.6

DiMart @ Сегодня, 12:13 * ,
1. Передать ссылку на товар через параметр в форму документа.
2. В процедуре ПриОткрытии() написать активизацию строки с переданным товаром.

Спасибо сказали: DiMart,

denis84 Подменю пользователя
сообщение 05.02.20, 13:04
Сообщение #5

Говорящий
***
Группа: Пользователи
Сообщений: 57
Из: Украина
Спасибо сказали: 9 раз
Рейтинг: 9

DiMart,

Что типа такого:
Процедура ОбработкаЯчейкиТаблицы(ЗначЯч, Флаг, ТекТаб, Адрес)
//--- переход на форму док -------------
Если ЗначЯч = "НомерДок" Тогда
Если ДокПП.НайтиПоНомеру(СокрЛП(ТабОтч.Область(Адрес).Текст), ДатаДок) = 1 Тогда
ОткрытьФорму(ДокПП.ТекущийДокумент());
///а тут уже обрабоатывать чере активизироватьстроку с переметром номенклатуры

Иначе
Предупреждение("Док с номером "+СокрЛП(ТабОтч.Область(Адрес).Текст)+" не найдено!");
КонецЕсли;
КонецЕсли;
КонецПроцедуры

Спасибо сказали: DiMart,

anatol1c Подменю пользователя
сообщение 06.02.20, 19:07
Сообщение #6

Молчаливый
*
Группа: Пользователи
Сообщений: 4
Из: Погребище
Спасибо сказали: 2 раз
Рейтинг: 2

Цитата(denis84 @ 05.02.20, 13:04) *
///а тут уже обрабоатывать чере активизироватьстроку с переметром номенклатуры

В процедуре ПриОткрытии:
Если ТипЗначенияСтр(Форма.Параметр) = "Число" Тогда  
        Если Число(Форма.Параметр) > 0 Тогда  
             АктивизироватьСтроку(Число(Форма.Параметр));
        КонецЕсли;
    КонецЕсли;


Сообщение отредактировал Vofka - 07.02.20, 11:01

Спасибо сказали: DiMart,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 28.03.20, 17:10
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!