Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику Talkman ::: Спасибо сказали: 9 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
24.10.23, 13:39 Заняты все кода номенклатуры
Была похожая проблема. Возникает, когда код текстовый и расширяют разрядность кода, когда уже пошла нумерация без перенумерации. Посмотрите, после последнего разряда в коде идут пробелы? Если идут - нужна перенумерация. Я бы на верочку сделал бы хенд мейд обработкой.
awp, ZenBi,
14.09.23, 10:50 Реалізація дабл кліка на запису в ТЗ
Talkman @ Вчера, 16:06 * ,
Вирішено. Трохи не туди поліз зпочатку. Треба лізти в обробник таблиці значень, а не елемента введеня колонки ТЗ. Обробник "Выбор" + прапорець "только просмотр" на колонку "Номенклатура". Дякую за увагу smile.gif
Vofka,
26.04.23, 14:42 Подписка на событие для отчетов
andreydv87 @ Сегодня, 10:36 * ,
Слишком много ролей прийдется создавать для различных отчетов.
Сейчас сделал в процедуре ПередОткрытием вызов функции поиска справочника с реквизитом имени отчета, смотрю есть ли там открывающий отчет пользователь и возвращаю Ложь или Истина. Минус в том, что для всех отчетов нужно прописывать процедуру перед открытием. Что то типа такого.
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    Отказ = УправлениеОтчетами.ОграничениеДоступаПользоватем(ЭтотОбъект);
    Если Отказ Тогда
        Предупреждение("Отказано в доступе!")  
    КонецЕсли;
КонецПроцедуры


Функция ОграничениеДоступаПользоватем(Объект) Экспорт

    Отчет = Объект.Метаданные().Имя;
    Доступ = Справочники.ДоступыКОтчетам.НайтиПоРеквизиту("Отчет",Отчет);
    ТекПользователь = ПараметрыСеанса.ТекущийПользователь;
    
    Если НЕ Доступ.Пустая() Тогда
        Для каждого ЗапП Из Доступ.Пользователи Цикл
            Если ЗапП.Пользователь = ТекПользователь Тогда
                Возврат Ложь;          
            КонецЕсли;             
        КонецЦикла;
        Возврат Истина;
    КонецЕсли;
    
    Возврат Ложь;

КонецФункции //


andreydv87,
10.04.23, 10:46 Посадова інструкція розробника програмного забезпечення 1С
Доброго дня. Якщо хтось зіштовхувався з гарно складеною посадовою інструкцією програміста 1С поділіться будь-ласка. Такою, щоб без пунктів накшталт "адміністрування системного та мережевого забезпечення локальних та глобальних обчислювальних мереж". Дякую.

Знайшов таку. Може комусь знадобиться.

I. Загальні положення
1. Головним завданням Програміста 1С є конфігурування та розробка 1С: підприємство.
2. Програміст 1С безпосередньо підпорядковується начальнику відділу інформаційних технологій.
3. Програміст 1С призначається та звільняється з посади наказом Генерального директора.
4. У своїй діяльності керується:
- законодавством України,
- наказами, розпорядженнями, вказівками генерального директора,
- правилами, інструкціями та ін. документами, що регулюють роботу відділу інформаційних технологій Програміста 1С,
- поточною посадовою інструкцією,
- політикою в галузі якості.
5. Програміст 1С повинен знати:
- постанови, розпорядження, накази, інші керівні та нормативні документи вищих та інших органів щодо методів використання обчислювальної техніки при обробці інформації;
- техніко-експлуатаційні характеристики, конструктивні особливості, призначення та режими роботи обладнання, правила його технічної експлуатації;
- правила внутрішнього трудового розпорядку;
- правила та норми охорони праці, техніки безпеки, виробничої санітарії та протипожежного захисту.

II. Посадові обов’язки

Програміст 1С виконує такі функціональні обов'язки:
1. Програмний супровід конфігурацій 1С-Підприємства.
2. Модифікація та оновлення існуючих документів, звітів, обробок бухгалтерського, оперативного та управлінського обліку.
3. Створення нових документів, звітів, обробок бухгалтерського, оперативного та управлінського обліку.
4. Розробка методів та форм ведення обліку товарообігу
5. Навчання персоналу компанії та віддалених підрозділів компанії роботі з існуючими та новостворюваними документами та звітами.
6. Виконання разових службових завдань, доручень та вказівок Генерального директора, Виконавчого директора та начальника відділу інформаційних технологій, що входять до сфери діяльності Програміста 1С.

III. Права

Програміст 1С має право:
1. Вносити на розгляд безпосередньому керівнику компетентні та обґрунтовані пропозиції з питань, що входять до його компетенції.
2. Вимагати забезпечення нормальними умовами праці (робочим місцем, засобами праці та ін.).
3. Користування затвердженими Генеральним директором Інструкціями, наказами, розпорядженнями, Правилами та ін. документами, що регламентують роботу Програміста 1С та відділу інформаційних технологій.


zay,
17.01.23, 16:43 Не сохраняются настройки положения колонок ТЧ документа
"Управление торговлей для Украины", редакция 2.3. Платформа 8.3.16.1659. Трехзвенка. Клиент толстый, обычные формы.

Перестала работать настройка положения колонок в документе УстановкаЦенНоменклатуры. Отладка показала, что строка в строке параметров часть строки заместь слов "Да" и "Нет" появились "Так" и "Ні". Все произошло после после форс мажора, когда пришлось переставить систему на сервере терминалов, с которого работает часть пользователей 1С. Поставили 1С Предприятие, но при установке видимо выбрали где то в настройках язык "українська". Все менюшки стали на украинском, конфигуратор на укр, дерево конфигурации на укр. В той же конфигурации, но с другого сервера терминалов, где платформа на русском все работает. Вопрос. Как поменять язык платформы на рус. Спасибо.
Система Windows Server 2022 Datacenter. Настройка региональных стандартов на двух серверах одинаковая. Інформаційна база: російська (Україна), Сеанс: російська (Україна) и Информационная база: русский (Украина), Сеанс: русский (Украина)
Вопрос конечно шире. Может не из за этого не работает настройка положения колонок, но все вроде ведет к языку платформы.

Решено.
C:\Program Files\1cv8\conf\conf.cfg

Строка должна быть "SystemLanguage=System" для моих настроек базы + должен быть установлен русский язык платформы при установке. У меня стоял только укр и eng. Спасибо за внимание. Может у кого то тоже подобная тупая ситуация будет.
nik389, Vofka,
04.06.15, 11:35 Ошибка открытия DBF файла
Доброго времени суток. Суть проблемы. При попытке открытия файла объектом XBase, выскакивает ошибка 200 "File is not a Data file". ДБФник вьювером открывается без проблем. До меня умные люди открывали его Экселем, и само собой из этого Экселя и пересохранили. Исходника нет. Можно ли какими то танцами с бубном работать с имеющимся файлом средствами 1С? Может перекодировать его как то? Спасибо.
Домовик,
13.02.15, 11:35 Слетели шрифты в 1С
Проблему локализировали. Слетели не сами шрифты, а драйвер их отображения. Win32k.sys. Решено путем востановления данного файла из рабочей системы и заменой его на нормальный в System32 b Systel32\DLLcash

Только вот что странно. Система то не обновляется...
Домовик,

RSS Текстовая версия Сейчас: 25.02.24, 3:13
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!