Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику Naghual ::: Спасибо сказали: 21 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
12.10.20, 16:02 Как программно сохранять базу данных? 1С 7.70.003 торговля склад для Украины?
Пишется батник, который запускается с задержкой, при опции по выходу из программы.
Батник делает архив.
ZUBR,
13.05.20, 10:32 Файлы хранения конфигурации 1С
НЕЛЬЗЯ!
Не изобретайте велосипед. Учите матчасть.
Maxymoff,
01.04.20, 14:12 Как узнать какая кнопка нажата
Форма.АктивныйЭлемент()
Возвращает строковое значение - идентификатор активного элемента диалога.
4andriy,
31.03.20, 12:51 Передача реквизитов между формами
Используйте глобальную переменную.
4andriy,
05.07.19, 23:07 Где находится форма расходной накладной в 1С 7.70.003 торговля склад для Украины?
В открытой Форме документа, на панели инструментов "Редактор диалогов" ищите кнопку "Слои". В диалоге управления слоями их можно делать видимыми/скрытыми.
ZUBR,
15.05.19, 12:01 Будет ли отличаться работа 1С на Exppress от работы на полной SQL?
Имелись в виду ограничения, накладываемые на размер максимальный БД.
Это вы должны знать размер ваше базы и достаточно ли для нее будет версии Express
NAGor4ik,
10.01.19, 18:46 Редактирование проводки в документа Модернизация необоротного актива
Если мне не изменяет память, там уже сть колонка Кол-во.

Что и зачем Вы пытаетесь сделать?!
chel_iz_naroda,
04.01.19, 16:49 По результатам запроса: Ошибка - Объект не может быть перепозиционирован!
Потому-что нельзя изменять объект, полученный запросом.
Вместо строк:
Запрос.Пациенты.Родитель = Архив; 
Запрос.Пациенты.Записать();

Напишите что-то типа:
Если СпрПацыки.НайтиЭлемент(Запрос.Пациенты) = 1 Тогда
  СпрПацыки.Родитель = Архив;
  СпрПацыки.Записать();
КонецЕсли;

Ну и в начале не забудьте:
СпрПацыки = СоздатьОбъект("Справочник.Пациенты");


П.С. Писал на скору руку, за синтаксис не отвечаю )
leonid_gun,
26.11.18, 0:01 отдельный журнал из справочника в 1с
К сожалению, Вы не слышите меня.
Журнал - это объект для отображения Документов!

А то что Вы хотите можно решить различными способами: Отчет, дополнительная Форма Списка справочника, Обработка, Печатная форма существующей Формы Списка...

4andriy,
27.02.18, 16:37 При попытке прочтения ячейки #Н/Д вываливается ошибка "Несовпадение типов" и виснет клиент
Цитата(Zaval @ 27.02.18, 17:35) *
Тоді треба аналізувати "на тій стороні" - засобами Екселя. Або модифікувати там.

Саме таке рішення я і запропонував:
 Если Excel.IsError(Лист.Cells(НомерСтроки, Колонка)) = -1 Тогда
l2d808,
27.02.18, 16:25 При попытке прочтения ячейки #Н/Д вываливается ошибка "Несовпадение типов" и виснет клиент
Excel.DisplayAlerts = 0;
Пока НомерСтроки < 40 Цикл
    Если Excel.IsError(Лист.Cells(НомерСтроки, Колонка)) = -1 Тогда
        НомерСтроки = НомерСтроки + 1;
        Продолжить;
    КонецЕсли;
    Попытка
        Значение = Лист.Cells(НомерСтроки, Колонка).Value;
        Сообщить(Значение);
    КонецПопытки;
    НомерСтроки = НомерСтроки + 1;
КонецЦикла;


Цитата(Zaval @ 27.02.18, 17:23) *
Я б спробував конструкцію "Попытка - Исключение"

Не спрацює, бо помилка виникає на стороні ОЛЄ-Сервера.
mister-x,
12.07.17, 22:35 Работа с результатом отчета
Так и обращайТЕСЬ к уже существующему объекту Таб. УбериТЕ первые две строки - не создавайТЕ по новой объект.


 ! 

Правила: 1
 
Yoja,
31.10.16, 17:24 НазначитьВид OLE com
ТМЦ - это реквизит документа или его многострочной части? Если последнее, то его необходимо позиционировать для начала (новая строка, получить строку...)
Описание исключения есть? Без этого непонятно.
Acid,
07.09.16, 21:37 Не присваивается значение реквизиту табличной части
Перед заполнением строки ТЧ необходимо-бы эту строку добавить.
НоваяСтрока()
sanytch,
02.05.16, 15:50 Хранилище дополнительной Табличной части в документе
А как эта часть сохраняеться/читается? Ведь в 1С 7.7 в документе возможно штатными средствами иметь только одну табличную часть.

Нужно использовать собственный механизм.
Домовик,
17.12.15, 13:38 Нужен справочник "Русско-украинский словарь" из 7.7 ЗиК
Я не так давно реализовывал автоматический перевод через АПИ Яндекс Переводчик.
Могу поделиться в личке.
nysysimara,
15.09.15, 16:50 Последнее поступление товара.
можно так:
|Условие(ТМЦ В СЗ);

Но более правильно будет так:
|Условие(СЗ.Принадлежит(ТМЦ)=1);
Sede,
07.08.15, 14:51 Считать/заменить заголовок флажка
А что, стандартные методы уже не работают?
Сообщить(Форма.флаг.Заголовок());
Форма.флаг.Заголовок("привет!");
Сообщить(Форма.флаг.Заголовок());
Sede,
28.07.15, 15:53 Работа с множеством одинаковы елементов
Цитата(Sede @ 28.07.15, 13:59) *
массово снять флажок(или установить)

smile.gif На том и стоим! icon_beer17.gif

Наше дело научить (научится?) возможностям реализации.
А конкретную реализацию уже пусть сам топикстартер делает.
Sede,
28.07.15, 15:29 Работа с множеством одинаковы елементов
Решение чуть проще и чуть быстрее БЕЗ СпискаЗнаачений

Перем индФлаги[6];

Функция Задать(Чему,Что)
    Чему = Что; Возврат "";
КонецФункции

Процедура ИзмФлаги(ИмяЭлемента)
    Перем чЗначенияДругих;
    
    чЗначенияДругих = 1 - Число(Шаблон("["+ИмяЭлемента+"]"));
    Для чИнд = 1 По 6 Цикл
        Если индФлаги[чИнд] <> ИмяЭлемента Тогда
            Шаблон("[Задать("+индФлаги[чИнд]+","+чЗначенияДругих+")]");
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры

Процедура ПриОткрытии()
    индФлаги[1] = "флАльфа";
    индФлаги[2] = "флБета";
    индФлаги[3] = "флГамма";
    индФлаги[4] = "флЗета";
    индФлаги[5] = "флФита";
    индФлаги[6] = "флПета";
КонецПроцедуры


А в строку Формула в свойствах флажка пишем такой вызов процедуры: ИзмФлаги(Форма.АктивныйЭлемент())
И в данном примере абсолютно не важна последовательность флажков.
Sede,
02.06.10, 21:39 Удалить товар из справочника
У тебя там еще зависимость от справочника ОбъектыУчета. В нем подчисть сначала.
oxygene,

RSS Текстовая версия Сейчас: 16.09.21, 23:47
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!