Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику inna.innainna84 ::: Спасибо сказали: 2 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
04.12.16, 14:34 Пересчет необходимого колва и суммы ТМЦ в РН (создаю программно!))
Спасибо за "спасибо". С первым меня "Спасибо." XBrut @ Сегодня, 9:18 * ,
cos12,
03.12.16, 16:16 Пересчет необходимого колва и суммы ТМЦ в РН (создаю программно!))
                  //----4----//  
            
//=========================не трогать====================================================================
    Если ДокРН.Итог("СуммаСНДС")<ДокРН.СуммаДокНал  Тогда//   **начало
        сообщить ("Не хватает товара!!");  
    иначе
        
        //правим суммы    
        Ном = ДокРН.КоличествоСтрок();
        Если Ном > 0 Тогда   //**1
            Пока  Ном > 0 Цикл
                ДокРН.ПолучитьСтрокуПоНомеру(Ном);
                Если ДокРН.Итог("СуммаСНДС")>ДокРН.СуммаДокНал  Тогда //**2                 
                    Дельта2=    ДокРН.Итог("СуммаСНДС")-ДокРН.СуммаДокНал;
                ДокРН.СуммаСНДС=ДокРН.Суммасндс-Дельта2;
                    
                    Если ДокРН.СуммаСНДС=0 Тогда
                        ДокРН.Удалитьстроку();
                    КонецЕсли;
                    
                    //**выбрает вессой или штучный товар и правим кво с условием                 
                    Если ДокРН.ТМЦ.Весовой = 0 тогда                          
                        ДокРН.Кво=Окр(ДокРН.СуммаСНДС/ДокРН.ЦенаСНДС);                         
                    иначе
                        ДокРН.Кво=ДокРН.СуммаСНДС/ДокРН.ЦенаСНДС;                             
                    КонецЕсли;//**выбрала
                    
                    ДокРН.ЦенаСНДС= ДокРН.СуммаСНДС/ДокРН.Кво;      
        
                    ДокРН.СуммаБезНДС=Формат(ДокРН.СуммаСНДС/1.2,"Ч12.2");                         
                    ДокРН.НДС= Формат(ДокРН.СуммаСНДС-ДокРН.СуммаБезНДС,"Ч12.2");
                    ДокРН.СуммаБезСкидки=ДокРН.СуммаБезНДС;                     
                КонецЕсли; //**2
                Ном = Ном-1;
                
            КонецЦикла;
        КонецЕсли; //**1         
    КонецЕсли; //*** начало

алгоритм подбора кол-ва и подгонка суммы в документе на согласно указанной ДокРН.СуммаДокНал (СуммаДокНал-это сумма переплаты по покупателю)
XBrut,

RSS Текстовая версия Сейчас: 26.11.20, 13:53
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!