Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику nysysimara ::: Спасибо сказали: 109 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
21.11.19, 7:55 Как сделать, чтобы таблица отчета открывалась с конца? 1С 7.70.003 торговля склад для Украины?
Цитата(ZUBR @ 20.11.19, 19:00) *
таблица этого отчета

если это ТаблицаЗначений на форме отчета, то
Тз.ТекущаяСтрока(Тз.КоличествоСтрок());


Цитата
ТекущаяСтрока(<?>);
Синтаксис:
ТекущаяСтрока(<Строка>)
Назначение:
Установить/определить текущую строку таблицы в элементе диалога типа ''ТаблицаЗначений''. Возвращает число, соответствующее индексу текущей строки поля диалога (до его изменения), или 0, если текущей строки нет.
Параметры:
<Строка> - необязательный параметр. Числовое выражение с задаваемым индексом строки для элемента диалога типа ''ТаблицаЗначений'', на которую требуется установить курсор. Если параметр не задан, то положение курсора в поле диалога не меняется.
ZUBR,
14.11.19, 7:50 Как изменить программно дату документа при проведении 1С 7.70.003 торговля склад для Украины?
ZUBR @ Вчера, 23:18 * ,
Точка актуальности
ZUBR,
28.10.19, 7:52 Как текст на форме сделать невидимым? Проблема 1С 7.70.003 торговля склад для Украины?
Цитата(ZUBR @ 28.10.19, 0:09) *
не знаходить таку процедуру

сама процедура Сплачено() должна располагаться до своего вызова
или в начале после описания переменных добавить строку
Процедура Сплачено() Далее

ZUBR,
23.10.19, 12:36 Как текст на форме сделать невидимым? Проблема 1С 7.70.003 торговля склад для Украины?
видимость и доступность реквизитов нужно прописать в процедуре ПриВыбореЗакладки()
примерно так:
 Процедура ПриВыбореЗакладки(Номер,Значение)
    Если Значение = "Основной" Тогда
        Форма.ИспользоватьСлой("Совместный,Основной",2);
                //если реквизиты на слое Основной
                Если  ПолноеИмяПользователя() <> "Simeon" Тогда
                      Форма.Спл.Видимость(0);
                      Форма.Спл.Доступность(0);
                      Форма.СПЛАЧЕНО.Доступность(0);
                КонецЕсли;  
                Если Спл=0 тогда  
                      Форма.СПЛАЧЕНО.Видимость(0);
                Иначе
                      Форма.СПЛАЧЕНО.Видимость(1);
                КонецЕсли;
    ИначеЕсли Значение = "Доверенность" Тогда
        Форма.ИспользоватьСлой("Совместный,Доверенность",2);

и обязательно в процедуре ПриОткрытии после
Форма.ИспользоватьЗакладки(1);
    Форма.Закладки.ДобавитьЗначение("Основной","Основной");
    Форма.Закладки.ДобавитьЗначение("Доверенность","Доверенность");

прописать
ПриВыбореЗакладки(1,"Основной");
ZUBR,
23.10.19, 7:10 Как в документе создать кнопку, доступную только админу? в 1С 7.70.003 торговля склад для Украины?
используйте
ИмяПользователя()
ZUBR,
23.10.19, 7:03 Как текст на форме сделать невидимым? Проблема 1С 7.70.003 торговля склад для Украины?
У вас случайно не закладки(слои) на форме?
Если да, то видимость элементов текущего слоя нужно прописывать при смене закладок
ZUBR,
06.08.19, 8:15 Не подсвечивается цветом ТЗ в 1С 7.70.003 торговля склад для Украины?
Судя по коды в вашей талице Тз 5 колонок,
значит при каждом
    Тз.НоваяСтрока();

Прописываете
 ТЗ.Цвет = "()(BRUSH[13160660])(BRUSH[13160660])(BRUSH[13160660])(BRUSH[13160660])(BRUSH[13160660])";

в данном случае все будут серыми

каждая скобка - это цвет каждой колонки,
если в скобках пусто - автоматически закрашивается как предыдущая
если BRUSH[NONE] - без цвета

Это все для таблицы, которая выводится на форму,
а для печатной формы - это совсем другая песня.
Если ячейку независимо от значения нужно подкрасить, свойства ячейки, закладка "Узор", поле "Фон".
Если в зависимости от значения, то вам поможет метод ЦветОбласти.

ZUBR,
05.08.19, 10:35 Не подсвечивается цветом ТЗ в 1С 7.70.003 торговля склад для Украины?
У меня работает приблизительно так:
Тд.НоваяКолонка("FormEx_ПланРаскраски",,,,"FormEx_ПланРаскраски",);  //обязательно первая
Тд.НоваяКолонка("
//... и т.д.
Тд.ВидимостьКолонки("FormEx_ПланРаскраски",0);

Тд.FormEx_ПланРаскраски = "()()()()()()(BRUSH[13160660])()(BRUSH[NONE])(BRUSH[13160660])()()()()()(BRUSH[NONE])(BRUSH[13160660])";

ZUBR,
01.08.19, 6:56 Как автоматически прописывать в документ телефон при выборе покупателя из справочника? 1С 7.70.003 торговля склад для Украины?
ZUBR @ Вчера, 17:45 * ,
В семерке (в отличии от восьмерки) может быть только одна табличная часть у документа, и ни одной у справочника ((
Для справочника можно реализовать через подчиненный справочник, или
ЗначениеВСтрокуВнутр(СписокТелефонов)
и хранить это безобразие в строке, но строки неограниченной длины - это зло.
По-моему, самый оптимальный вариант - это строка ограниченной длины, в которой телефоны указаны через запятую или другой разделитель
ZUBR,
31.07.19, 6:43 Как автоматически прописывать в документ телефон при выборе покупателя из справочника? 1С 7.70.003 торговля склад для Украины?
ZUBR @ Вчера, 23:20 * ,
На форме в свойсвах поля ввода "Клиент" на вкладке Дополнительно в поле Формула прописываем процедуру, которая будет вызыватся при изменении реквизита Клиент.
Например КлиентприИзменении()
В модуле формы создаем процедуру КлиентприИзменении(),
а в ней прописываем както так
Телефон = Клиент.Телефон;

в завизимости от
Цитата(ZUBR @ 30.07.19, 23:20) *
Там же записаны его телефоны.

ZUBR,
24.07.19, 6:43 Как программно открыть форму создаваемого документа 1с 7.7 конф 7.7.00
ZUBR @ Вчера, 23:37 * ,
ОткрытьФорму(АктПр.ТекущийДокумент());


Цитата
ОткрытьФорму(<?>,,)
Синтаксис:
ОткрытьФорму(<Документ>,<КонтекстФормы>,<РежимПросмотра>)
Назначение:
Открывает визуальную форму существующего документа или элемента/группы справочника.
Возвращает: 1 - если действие выполнено, 0 - иначе.
Параметры:
<Документ> - выражение со значением типа 'документ';
<КонтекстФормы> - имя переменной, куда можно задать значение любого типа для передачи в открываемую форму. Данное значение будет доступно в открытой форме как атрибут Форма.Параметр. После исполнения данного метода система вернет в данную переменную контекст открытой формы (необязателен);
<РежимПросмотра> - необязательный параметр. Числовое выражение: 1 - открыть форму в режиме только просмотра; 0 - открыть форму в режиме редактирования; -1 (минус единица) - в этом случае используется вариант, предусмотренный текущим значением параметра ''Режим открытия объектов'', установленным пользователем интерактивно.
Замечание:
Пока форма открыта, тип значения параметра <КонтекстФормы> равен 100, когда закрыта - 0.
ZUBR,
27.12.18, 8:58 Как получить доступ к документам?
В конфигураторе "Поиском во всех текстах" поискать фразу "Данное действие запрещено полтикой предприятия",
а тогда уже два решения - или переписывать код, или расширять права
ObamaUA,
25.01.18, 15:20 Печать QR-кодов
делала с Ocvita,
только не помню для 8.2 или 8.1
хорошая компонента, к тому же бесплатная, была по крайней мере несколько лет назад
Bernet,
17.01.18, 7:36 Ошибка при открытии обработки личной карточки.
К обработке было описание?
Возможно она написана под другую конфигурацию (не ЗиК)
или требуются доработки этой конфигурации.
Судя по сообщению, вам нужно добавить новую константу "НазваниеОрганизации"
diagnoz,
09.11.17, 15:49 Отчет по двум запросам
ranis @ Сегодня, 15:31 * ,
взамен
ТабОбщ.Сортировать("ДатаДок,НомерДок");

так
ТабОбщ.Сортировать("ДатаДок,НомерДок,Расчет,Расчет1");


взамен кода
ТабОбщ.НоваяКолонка("СкидкаКДоходамДляСтраховыхВзносов1","Число");

Пока Запрос1.Группировка(1) = 1 Цикл
    ДатаДок1 = Запрос1.ДатаДок1;
    ТабОбщ.НоваяСтрока();
    ТабОбщ.ДатаДок = ДатаДок1;
    ТабОбщ.СкидкаКДоходамДляСтраховыхВзносов1 = Запрос1.СкидкаКДоходамДляСтраховыхВзносов1;
    Пока Запрос1.Группировка(2) = 1 Цикл
        Расчет1 = Запрос1.Расчет1;
        ТабОбщ.НоваяСтрока();
        ТабОбщ.ДатаДок = ДатаДок1;
        ТабОбщ.Расчет1 = Расчет1;
        ТабОбщ.СкидкаКДоходамДляСтраховыхВзносов1 = Запрос1.СкидкаКДоходамДляСтраховыхВзносов1;
        Пока Запрос1.Группировка(3) = 1 Цикл
            ТабОбщ.НоваяСтрока();
            ТабОбщ.ДатаДок = ДатаДок1;
            ТабОбщ.НомерДок = Запрос1.НомерДок1;
            ТабОбщ.Расчет1 = Расчет1;
            ТабОбщ.СкидкаКДоходамДляСтраховыхВзносов1 = Запрос1.СкидкаКДоходамДляСтраховыхВзносов1;
        КонецЦикла;
    КонецЦикла;
КонецЦикла;

ТабОбщ.Свернуть("ДатаДок,НомерДок,Расчет,Расчет1","СкидкаКДоходамДляСтраховыхВзносов,СкидкаКДоходамДляСтраховыхВзносов1");


этот
ТабОбщ.НоваяКолонка("СкидкаКДоходамДляСтраховыхВзносовСумма1","Число");

Пока Запрос1.Группировка(1) = 1 Цикл
    ДатаДок1 = Запрос1.ДатаДок1;
    ТабОбщ.НоваяСтрока();
    ТабОбщ.ДатаДок = ДатаДок1;
    ТабОбщ.ССкидкаКДоходамДляСтраховыхВзносовСумма1 = Запрос1.СкидкаКДоходамДляСтраховыхВзносовСумма1;
    Пока Запрос1.Группировка(2) = 1 Цикл
        Расчет1 = Запрос1.Расчет1;
        ТабОбщ.НоваяСтрока();
        ТабОбщ.ДатаДок = ДатаДок1;
        ТабОбщ.Расчет1 = Расчет1;
        ТабОбщ.СкидкаКДоходамДляСтраховыхВзносовСумма1 = Запрос1.СкидкаКДоходамДляСтраховыхВзносовСумма1;
        Пока Запрос1.Группировка(3) = 1 Цикл
            ТабОбщ.НоваяСтрока();
            ТабОбщ.ДатаДок = ДатаДок1;
            ТабОбщ.НомерДок = Запрос1.НомерДок1;
            ТабОбщ.Расчет1 = Расчет1;
            ТабОбщ.СкидкаКДоходамДляСтраховыхВзносовСумма1 = Запрос1.СкидкаКДоходамДляСтраховыхВзносовСумма1;
        КонецЦикла;
    КонецЦикла;
КонецЦикла;

ТабОбщ.Свернуть("ДатаДок,НомерДок,Расчет,Расчет1","СкидкаКДоходамДляСтраховыхВзносовСумма,СкидкаКДоходамДляСтраховыхВзносовСумма1");


и в таблице заменить
ТабОбщ.СкидкаКДоходамДляСтраховыхВзносов на ТабОбщ.СкидкаКДоходамДляСтраховыхВзносовСумма
ТабОбщ.СкидкаКДоходамДляСтраховыхВзносов1 на ТабОбщ.СкидкаКДоходамДляСтраховыхВзносовСумма1
ranis,
09.11.17, 13:35 Отчет по двум запросам
Таблицы обязательно должны быть параллельные?

Нужны ли строки с итоговыми значениями по Дате и по Расчету?
ranis,
09.11.17, 10:26 Отчет по двум запросам
ranis @ Сегодня, 9:20 * ,
тогда вам в стол заказов
ranis,
16.06.17, 10:09 Чи можливо за номером документу відкрити його візуальну форму
если у вас в коде присутствует фраза
ЧтоТо.Записать();

то должен сработать метод
ОткрытьФорму(ЧтоТо.ТекущийДокумент());


или
ДокументАкциз = СоздатьОбъект("Документ.Акциз");
Если ДокументАкциз.НайтиПоНомеру(НомерДляПоиска,ТекущаяДата)=1 Тогда
    ОткрытьФорму(ДокументАкциз.ТекущийДокумент());
КонецЕсли
leo10k10,
23.05.17, 13:51 Нужно чтобы доставало значения из второй строки табличной части
NeFess @ Сегодня, 9:48 * ,
Цитата
ПолучитьСтрокуПоНомеру(<?>);
Синтаксис:
ПолучитьСтрокуПоНомеру(<НомерСтроки>)
Назначение:
Получить строку таблицы значений по номеру. Указанная строка становится текущей.
Параметры:
<НомерСтроки> - номер строки, на которую следует переместиться.

NeFess,
12.05.17, 10:34 Групповое создание актов
СпрКонтрагенты    = СоздатьОбъект("Справочник.Контрагенты");
Если СпрКонтрагенты.НайтиПоРеквизиту("ЕДРПОУ",<ваш код из таблицы>,1)= 1 Тогда
    текущийКонтрагент    = СпрКонтрагенты.ТекущийЭлемент();
КонецЕсли;

и вынесите строки
Док = СоздатьОбъект("Документ.ОказаниеУслуг");
Спр = СоздатьОбъект("Справочник.Контрагенты");
до цикла по таблице
axelk,
28.04.17, 12:35 Запрос к бухгалтерским итогам
SergXP @ Сегодня, 11:49 * ,
нужно два запроса: один к счету учета 10, другой - к счету 13,
обходите первый запрос, внутри по ОС получаете износ из второго запроса.
Только следует помнить, если ОС у вас во множественном числе, то износ нужно брать пропорционально
пример кода здесь
SergXP,
24.03.17, 15:55 Создание нового документа и проверка на наличие уже созданого. Подскажите пожалуйста что не так я делаю.
попробуйте:
Процедура СоздаемПЛ() 
    
    ДокПЛ=СоздатьОбъект("Документ.ПутевойЛистГрузовой");    
    
    ТЗ.ВыбратьВтроки();
    Пока ТЗ.ПолучитьСтроку()=1 Цикл
        БудемРедактироватьСуществующий = 0;
        ДокПЛ.ВыбратьДокументы(Дата1,Дата2);
        Пока ДокПл.ПолучитьДокумент()=1 Цикл
            Если ДокПЛ.ПометкаУдаления() = 0 Тогда // проверяем все кроме помеченных!!
                Если (ДокПЛ.Автомобиль=ТЗ.Автомобиль.ТекущийЭлемент()) и (ДокПЛ.ДатаДок=ТЗ.ДатаДок) Тогда                  
                    Если Вопрос("ПЛ № "+ДокПЛ+" уже записан (№ "+ДокПЛ.Номердок+"). РЕДАКТИРОВАТЬ?", "Да+Нет") =  "Да" Тогда  
                        Если ДокПЛ.Проведен()=1 Тогда                            
                            ДокПЛ.СделатьНеПроведенным();                            
                        КонецЕсли;
                        БудемРедактироватьСуществующий = 1;
                    КонецЕсли;
                    Прервать;
                КонецЕсли;                  
            КонецЕсли;            
        КонецЦикла;  
        Если БудемРедактироватьСуществующий=0 Тогда
            ДокПЛ.Новый();          
            глЗаполнитьШапку(ДокПЛ);
            ДокПЛ.ДатаДок = ТЗ.ДатаДок;  
            ДокПЛ.Автомобиль = ТЗ.Автомобиль.ТекущийЭлемент();  
        КонецЕсли;
        ДокПЛ.ПоказанияСпидометраНаНачало=ТЗ.КоличествоНачПокСпид;
        ДокПЛ.ПоказанияСпидометраНаКонец=ТЗ.КоличествоКонПокСпид;
        ДокПЛ.ПробегGPS=ТЗ.GPS;
        ДокПЛ.ПробегНорма=ТЗ.Км;
        ДокПЛ.СуммаЗаправки=ТЗ.ПоступилоСумма;
        ДокПЛ.ПоступилоГСМ=ТЗ.ПоступилоЛитр;
        ДокПЛ.Автор=глПользователь;
        Попытка
            ДокПЛ.Записать();
        Исключение
        КонецПопытки;
    КонецЦикла
КонецПроцедуры

и еще проверьте, что у вас в ТЗ
inna.innainna84,
24.03.17, 10:58 Создание нового документа и проверка на наличие уже созданого. Подскажите пожалуйста что не так я делаю.
inna.innainna84 @ Сегодня, 10:29 * ,
предложение по коду:
1) вначале проверить на наличие необходимого документа,
если он есть и дано согласие на редактирование - отменяем проведение,
иначе - ДокМ.Новый();
2) использовать один объект "Документ.ПутевойЛистГрузовой"
и соответственно один блок заполнения реквизитов

inna.innainna84,
28.10.16, 11:05 вывести отчет по реквизиту
nik389 @ Сегодня, 10:48 * ,
да, так правильней
|НалогОбл = Справочник.Контрагенты.<Имя реквизита налогоображения>;

копипаст подвел ))
4andriy,
04.08.16, 6:35 Обращение к значению реквизита шапки документа
если
Цитата(sanytch @ 03.08.16, 16:18) *
обычная Бухгалтерия для Украины

то в отчете "ЭкспортНалоговойНакладной" есть глобальная переменная стрДокумент,
т.е:
текущееЗначениеАКЦ = стрДокумент.АКЦ;


sanytch,

4 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 26.11.20, 10:52
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!