Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



2 страниц V   1 2 >

>  Открытие формы при старте системы
BeLuY
Отправлено: 16.06.21, 11:00


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Цитата(logist @ 15.06.21, 20:18) *
Если 1с ничего не придумала за последние пару лет - то никак. Есть библиотеки разные, например WindowEx, но они все как правило работают с какими-то косяками.

Сделал так, не знаю насколько это правильно, но пока работает:

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    // Разворачиваем форму "на весь экран"
    Попытка
        WSHShell = Новый COMОбъект("WScript.Shell");
        WSHShell.SendKeys("% ");
        WSHShell.SendKeys("{UP}{UP}{ENTER}");
    Исключение КонецПопытки;
КонецПроцедуры

Цитата(logist @ 15.06.21, 20:18) *
вместо ПолучитьФорму().Открыть() лучше использовать ОткрытьФорму()

Спасибо, исправил)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #173697 · Ответов: 10 · Просмотров: 460
 

>  Открытие формы при старте системы
BeLuY
Отправлено: 15.06.21, 14:24


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


UPD:
Цитата(sava1 @ 15.06.21, 13:48) *
в общих модулях, экспортная


Получилось спасибо, только для этого в общем модуле необходимо установить "птички" в настройках Сервер и Вызов сервера:



Неудобно, что нельзя редактировать старые сообщения...


Цитата(logist @ 14.06.21, 21:56) *
И сразу там же открыть окно со свойством "Блокировать весь интерфейс"

А можно как-то открыть форму, чтобы она была развернута на весь экран? В обычных формах был режим рабочего стола, а как в управляемых?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #173691 · Ответов: 10 · Просмотров: 460
 

>  Открытие формы при старте системы
BeLuY
Отправлено: 15.06.21, 12:58


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Цитата(sava1 @ 15.06.21, 13:48) *
в общих модулях, экспортная



Цитата(sava1 @ 15.06.21, 13:48) *
вооще-то в БСП есть функция РолиДоступны(



На клиенте тоже не работает
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #173690 · Ответов: 10 · Просмотров: 460
 

>  Открытие формы при старте системы
BeLuY
Отправлено: 15.06.21, 12:34


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Цитата(sava1 @ 15.06.21, 11:18) *
Форму открыть на сервере - для кого ?

Не совсем корректно обозвал процедуру, потому как форма должна открываться на клиенте, а роль проверятся на сервере crazy.gif

Цитата(sava1 @ 15.06.21, 11:18) *
чтобы получить доступность роли - Вызывайте процедуру, компилируемую на Сервере, которая возвращает Булево

В этом случае получаю ошибку "Процедура или функция с указанным именем не определена"



Из модуля управляемого приложения не выполняются серверные методы, видимо, не тот модуль я ковыряю wacko.gif
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #173688 · Ответов: 10 · Просмотров: 460
 

>  Открытие формы при старте системы
BeLuY
Отправлено: 15.06.21, 10:11


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Повторюсь, знаний работы в управляемом режиме очень мало...

Цитата(logist @ 14.06.21, 21:56) *
В глобальном модуле, вызов проверки в ПриНачалеРаботыСистемы

Насколько я понимаю, модуль управляемого приложения работает лишь на стороне клиента, а процедура РольДоступна() работает на сервере. Если я напишу такой код:
Процедура ПриНачалеРаботыСистемы()    
    ...
    ОткрытьФормуНаСервере();
КонецПроцедуры

&НаСервере
Процедура ОткрытьФормуНаСервере()
    Если РольДоступна("Роль") Тогда
    ...
КонецПроцедуры

пишет, что процедура ОткрытьФормуНаСервере() не найдена. Если данную процедуру вынести в отдельный глобальный модуль - ничего не меняется... Каким образом можно выполнить проверку, как вызвать данную процедуру на стороне сервера?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #173685 · Ответов: 10 · Просмотров: 460
 

>  Открытие формы при старте системы
BeLuY
Отправлено: 14.06.21, 15:22


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Хм, в настройке конфигурации, в разделе "Совместимость" нашел параметр Режим использования модальности, значение которого установил как Использовать - теперь форма стала открываться модально
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #173672 · Ответов: 10 · Просмотров: 460
 

>  Открытие формы при старте системы
BeLuY
Отправлено: 14.06.21, 14:03


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Добрый день. В управляемом приложении необходимо сделать автоматическое открытие формы при запуске программы в зависимости от наличия определенной роли. Форму необходимо открыть модально. Знаю, что в обычном приложении это можно сделать в Модуле обычного приложения, в процедуре ПриНачалеРаботыСистемы(), но в управляемом так не работает:

    Если РольДоступна("Роль") Тогда        
        Форма = ПолучитьФорму("Обработка.НоваяОбработка.Форма");        
        Рез = Форма.ОткрытьМодально();        
        
        // Если не удалось
        Если Рез = Ложь Тогда
            // Закрываем программу
            ЗавершитьРаботуСистемы(Ложь);
        КонецЕсли;    
    КонецЕсли;

Это не работает, потому как:
  1. Ругается на глобальный метод РольДоступна(), так как он доступен только на сервере
  2. Модально открыть не получается - выводит ошибку "Использование модальных окон в данном режиме запрещено!"

Опыта работы с управляемыми формами очень мало, но я понимаю, что метод РольДоступна() доступен на сервере, а ПолучитьФорму() на клиенте, и они должны быть, как минимум в разных процедурах (или не всегда? =)), но код я взял из обычного приложения (почти весь) и привел для примера.

Зачем это нужно: Есть мобильное устройство, если заходить в программу с него под пользователем, у которого указана определенная роль, необходимо на весь экран запустить определенную форму с несколькими кнопками, адаптированную под экран мобильного устройства. Так у меня сейчас работает в обычном приложении.

Так вот, как можно решить данный вопрос? Как и где в управляемом приложении описать процедуру проверки доступности роли и модальное открытие окна? Или может мой способ в корне неверный и есть другой, более правильный механизм?

Спасибо)

Конфигурация: BAS Роздрібна торгівля
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #173668 · Ответов: 10 · Просмотров: 460
 

>  Ошибка перехода на BAS Agro
BeLuY
Отправлено: 09.06.21, 10:33


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Вопрос снят, как оказалось - прислали не ту поставку (мда, и такое бывает...)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #173604 · Ответов: 13 · Просмотров: 241
 

>  Ошибка перехода на BAS Agro
BeLuY
Отправлено: 09.06.21, 9:33


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Добрый день. Уже второй день пытаемся выполнить переход с конфигурации "1С:Бухгалтерія сільськогосподарського підприємства для України" на BAS Agro, но безуспешно. Согласно файлу-описанию обновления: "Для перехода на версию 2.1.13 необходимо использовать версию конфигурации "Бухгалтерія сільськогосподарського підприємства" не ниже 2.0.28.1.". Версия, с которой выполняем переход, 2.0.28.1, но при попытке выполнения обновления из конфигуратора получаем сообщение "Файл не содержит доступных обновлений". Комплект поставки взяли с портала ИТС. Из-за чего может такое происходить?

Версия платформы: 8.3.16.1063

Спасибо



  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #173600 · Ответов: 13 · Просмотров: 241
 

>  Флажок в табличной части
BeLuY
Отправлено: 26.05.21, 12:00


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Нашел решение:

1. В таблицу на форме добавляем колонку, назовем ее "Выбор", ЭлементУправления устанавливаем "Поле выбора"
2. В таблице на форме (в моем случае Товары) создаем обработчики ПриВыводеСтроки и ПриИзмененииФлажка
3. В модуль формы, в раздел оглашения глобальных переменных добавляем переменную ВыбраннаяНоменклатура, в самом конце модуля инициализируем эту переменную ВыбраннаяНоменклатура = Новый Соответствие

В итоге, модуль формы должен содержать:

// Глобальные переменные
Перем ВыбраннаяНоменклатура;

//------------------------------------------------------

// Описание обработчика "ПриВыводеСтроки"
Процедура ТоварыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    // Отображаем флажок в ячейке с именем "Выбор"
    ОформлениеСтроки.Ячейки.Выбор.ОтображатьФлажок = Истина;    
    
    // Производим поиск соответствия "ВыбраннаяНоменклатура" текущей строки    
    Если ВыбраннаяНоменклатура[ДанныеСтроки] = Неопределено Тогда
        // Если соответствие не найдено - флажок снят
        ОформлениеСтроки.Ячейки.Выбор.Флажок = Ложь;
    Иначе
        // Иначе устанавливаем флажок
        ОформлениеСтроки.Ячейки.Выбор.Флажок = ВыбраннаяНоменклатура[ДанныеСтроки];
    КонецЕсли;    
КонецПроцедуры

// Описание обработчика "ПриИзмененииФлажка"
Процедура ТоварыПриИзмененииФлажка(Элемент, Колонка)
    // Если состояние флажка меняется в ячейке с именем "Выбор"
    Если Колонка.Имя = "Выбор" Тогда
        // Производим поиск соответствия "ВыбраннаяНоменклатура" текущей строки
        Если ВыбраннаяНоменклатура[Элемент.ТекущаяСтрока] = Неопределено Тогда
            // Если соответствие не найдено - создаем новое соотвотствие
            ВыбраннаяНоменклатура[Элемент.ТекущаяСтрока] = Истина;
        Иначе
            // Иначе, если соответствие найдено - удаляем его
            ВыбраннаяНоменклатура.Удалить(Элемент.ТекущаяСтрока);
        КонецЕсли;    
    КонецЕсли;    
КонецПроцедуры

//------------------------------------------------------

// Инициализация глобальной переменной
ВыбраннаяНоменклатура = Новый Соответствие;


Немного колхоз, но мне помогло)

Спасибо за внимание)

PS: к модератору - а я могу данное решение внести в первое сообщение темы? Кнопка "Редактировать" отсутствует...
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #173444 · Ответов: 3 · Просмотров: 247
 

>  Флажок в табличной части
BeLuY
Отправлено: 26.05.21, 10:03


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


denis84 @ Сегодня, 10:55 * ,

Данный документ уже был подвержен доработкам, так что ничего страшного, если доработать еще немного. А писать дополнительные обработки - это не совсем то, что нам нужно
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #173442 · Ответов: 3 · Просмотров: 247
 

>  Флажок в табличной части
BeLuY
Отправлено: 26.05.21, 9:18


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Добрый день. Есть необходимость добавить колонку в таблицу на форме документа - некий признак (флажок) выбора необходимых строк для дальнейшей обработки, но данное значение хранить не нужно. Как можно добавить этот флажок, чтобы не создавать реквизит в табличной части? Даже если создать необходимый реквизит, то при установке флажка будут изменятся данные документа и, при закрытии документа, будет запрашивать сохранение.

Другими словами: необходима возможность открытия документа, выбора необходимых запчастей и перемещение их в производство. После чего закрыть документ без каких-либо сохранений

Платформа 8.3.8, Обычное приложение.

Спасибо!

26.05.2021: нашел решение.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #173440 · Ответов: 3 · Просмотров: 247
 

>  Выравнивание элементов на форме
BeLuY
Отправлено: 08.02.21, 14:24


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


sava1 @ Сегодня, 10:36 * ,



Или это я что-то не понимаю? smile.gif
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170474 · Ответов: 14 · Просмотров: 709
 

>  Выравнивание элементов на форме
BeLuY
Отправлено: 08.02.21, 14:16


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


alx389d @ Сегодня, 11:03 * ,

Странно, но не работает. Платформа 8.3.10.2772 (может в этом дело?)

Свойства групп:




Свойство формы:

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170472 · Ответов: 14 · Просмотров: 709
 

>  Выравнивание элементов на форме
BeLuY
Отправлено: 08.02.21, 10:33


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


sava1 @ Сегодня, 10:06 * ,
В этом случае и двоеточие смещается
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170467 · Ответов: 14 · Просмотров: 709
 

>  Выравнивание элементов на форме
BeLuY
Отправлено: 08.02.21, 9:43


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Moloko @ 06.02.21, 11:09 * ,
Меню "Форма" в Главном меню?


alx389d @ Вчера, 8:09 * ,
К сожалению, не работает...

fly @ 06.02.21, 13:59 * ,
Спасибо, надеялся, что все же есть какой-то метод выравнивания

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170464 · Ответов: 14 · Просмотров: 709
 

>  Выравнивание элементов на форме
BeLuY
Отправлено: 05.02.21, 16:45


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961




Здравствуйте! Есть форма, на которой расположены четыре группы, в каждой из которых по два реквизита. Подскажите, пожалуйста, что нужно сделать, чтобы все поля ввода можно было выровнять по красной линии как на скрине?

Заранее спасибо!

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170408 · Ответов: 14 · Просмотров: 709
 

>  Количество знаков в поле "Количество" налоговой накладной
BeLuY
Отправлено: 13.10.20, 14:22


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Цитата(sava1 @ 13.10.20, 14:51) *
в поле Формат есть значок лупы ?


Снимаю шляпу! Я и подумать не мог, что в том поле тоже может быть "разделение по языкам", вот и не удосужился посмотреть...

Спасибо большое за помощь - все получилось =))
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167323 · Ответов: 8 · Просмотров: 383
 

>  Количество знаков в поле "Количество" налоговой накладной
BeLuY
Отправлено: 13.10.20, 13:05


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Цитата(RedCat77 @ 13.10.20, 13:36) *
Если конфигурация поддерживает несколько языков формирования печатных форм, форматы вывода нужно прописывать для каждого языка.


Если подразумевается описание заголовков, синонимов объектов, текстов и прочего на разных, поддерживаемых языках - это понятно, А что касаемо формата вывода данных, к примеру, как в моем вопросе, где я, казалось бы, указываю в конфигураторе формат вывода числа в виде "ЧЦ=12; ЧДЦ=6; ЧН=' '", но получаю печатную форму с форматом "ЧЦ=12; ЧДЦ=3; ЧН=' '" (хочу в макете печатной формы получить значение, в котором будет точность шесть знаков дробной части, но в итоге, ничего не меняется), какое отношение имеет язык вывода?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167317 · Ответов: 8 · Просмотров: 383
 

>  Количество знаков в поле "Количество" налоговой накладной
BeLuY
Отправлено: 13.10.20, 11:35


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Цитата(RedCat77 @ 13.10.20, 12:10) *
Зависит


Тогда можете подсказать как, а то что-то не совсем понимаю...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167314 · Ответов: 8 · Просмотров: 383
 

>  Количество знаков в поле "Количество" налоговой накладной
BeLuY
Отправлено: 13.10.20, 11:06


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


sava1 @ Сегодня, 11:57 * ,

Не понял? Формат данных ведь не зависит от языка
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167312 · Ответов: 8 · Просмотров: 383
 

>  Количество знаков в поле "Количество" налоговой накладной
BeLuY
Отправлено: 13.10.20, 10:30


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Добрый день! Возникла необходимость в документе НалоговаяНакладная, в табличных частях Товары и Услуги, в реквизите Количество выводить шесть знаков после запятой. В макете (имя макета ПФ_MXL_UK_НалоговаяНакладная2018Альбом), формат параметра Количество указан как "ЧЦ=12; ЧДЦ=6; ЧН=' '". Но, при печати налоговой накладной, значение параметра Количество печатается как ЧЦ=12; ЧДЦ=3; ЧН=' ' (три знака после запятой). В процедуре печати (ПечатьДокументаНалоговыйКодекс2018) прошелся отладчиком, значение параметра записывается в формате "ЧЦ=12; ЧДЦ=6; ЧН=' '" (шесть знаков после запятой), но пользователю выводится в формате "ЧЦ=12; ЧДЦ=3; ЧН=' '" (три знака). Может ли кто-то подсказать, в каком месте переназначается формат значения для этого поля?

Конфигурация Business automation software for accounting CORP, edition 2.1 (2.1.7.1)

Как выводится на печать:


Как в документе:


Как в конфигураторе указан формат:


Спасибо!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167310 · Ответов: 8 · Просмотров: 383
 

>  Запрос к удаленной базе 1Сv8.3 через COM
BeLuY
Отправлено: 11.08.20, 13:43


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Добрый день! Пытаюсь сформировать запрос к удаленной базе 1Сv8.3. Делаю так:

    // ----------------------------------------------------------
    // Подключение к БД БУ
    // ----------------------------------------------------------
    
    ПараметрыПодключения = "Srvr=""server"";Ref=""buh"";Usr=""Администратор"";Pwd=""123"";";
    Подключение = Неопределено;
    
    Попытка
        V83COMCon = Новый COMОбъект("V83.COMConnector");
        Подключение = V83COMCon.Connect(ПараметрыПодключения);
    Исключение
         Сообщить("Ошибка подключения к БД: " + ОписаниеОшибки());
         Возврат;
     КонецПопытки;    
    
    // ----------------------------------------------------------
    // Загрузка данных в табличную часть
    // ----------------------------------------------------------
    Попытка
        ЗапросБУ = Подключение.NewObject("Запрос");
        
        ЗапросБУ.Текст = "ВЫБРАТЬ
                        |    ПлатежноеПоручениеВходящее.Контрагент.КодПоЕДРПОУ,
                        |    ПлатежноеПоручениеВходящее.СуммаДокумента
                        |ИЗ
                        |    Документ.ПлатежноеПоручениеВходящее КАК ПлатежноеПоручениеВходящее
                        |ГДЕ
                        |    ПлатежноеПоручениеВходящее.Проведен = ИСТИНА
                        |    И ПлатежноеПоручениеВходящее.Дата = &Дата";
                        
        ЗапросБУ.УстановитьПараметр("Дата", Дата);
        
        РезультатБУ = ЗапросБУ.Выполнить.Выбрать();
        
        Пока РезультатБУ.Следующий() Цикл
            //......
        КонецЦикла;
        
    Исключение
        Сообщить("Ошибка при выполнении запроса к удаленной БД: " + ОписаниеОшибки());    
    КонецПопытки;

При выполнении запроса получаю ошибку в строке
РезультатБУ = ЗапросБУ.Выполнить.Выбрать();

Текст ошибки:
Цитата
Ошибка при получении значения атрибута контекста (Выполнить): Метод не найден


Подскажите что я делаю не так?

PS: Код не закончен - прошу сильно не

Спасибо!

//----------------------------------------------------------------------------------

Блииин, пропустил скобки в методе Выполнить() wacko.gif icon_cuss.gif

РезультатБУ = ЗапросБУ.Выполнить().Выбрать();


Можно удалить тему? 26000000.gif
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #165506 · Ответов: 0 · Просмотров: 293
 

>  Как получить доступ к ячейке табличной части на форме
BeLuY
Отправлено: 03.06.20, 11:15


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


kooperdj @ Сегодня, 11:44 * ,

Вижу, что ничего другого не остается... Но все же, хотелось бы понять как получить доступ к данной ячейке smile.gif
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #163562 · Ответов: 8 · Просмотров: 748
 

>  Как получить доступ к ячейке табличной части на форме
BeLuY
Отправлено: 03.06.20, 10:28


Общительный
**

Группа: Пользователи
Сообщений: 30
Регистрация: 22.09.15
Пользователь №: 45961


Упс, ошибся, не в процедуре ПриОткрытии()

Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок)
    дкТоварыПриПолученииДанных(ЭтаФорма, Элемент, ОформленияСтрок, Права);
    
    // ..........................................        
        
    Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
               ДанныеСтроки = ОформлениеСтроки.ДанныеСтроки;

        // ..........................................                
            
        Если Элемент.Колонки.ЦенаСтарая.Видимость Тогда
            Если (НЕ ДанныеСтроки.Номенклатура.Пустая()) И (НЕ ТипЦен.Пустая()) тогда
                ОформлениеСтроки.Ячейки.ЦенаСтарая.ОтображатьТекст=Истина;
                // получим предыдущую цену
                ЦенаСтарая = ПолучитьСтаруюЦену(ДанныеСтроки);
                ОформлениеСтроки.Ячейки.ЦенаСтарая.Текст=Формат(ЦенаСтарая,"ЧЦ=15; ЧДЦ=2");
                
                // ..........................................
                    
            КонецЕсли;

        // ..........................................
        
    КонецЦикла;
КонецПроцедуры
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #163558 · Ответов: 8 · Просмотров: 748
 

2 страниц V   1 2 >

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 02.08.21, 15:33
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!