Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




>  Программное нажатие на кнопку из командного интерфейса "перейти"
vlad_
Отправлено: 21.03.17, 18:01


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 10.10.16
Пользователь №: 52146


помогите пожалуйста!! нужно программно нажать на одну из кнопок командного интерфейса "перейти" упр.формы.
к примеру: мы находимся в документе реализация. там есть наша кнопка и нам нужно по нажатию на эту кнопку вызвать событие которое откроет (к примеру мы передаем туда номенклатуру) штрихкод номенклатуры. или же..(см.скрин)

как вообще можно обратиться к стандартным командам закладки "перейти"?

есть приблизительное направление поиска:
НавСсылка = "e1cib/command/ОбщаяКоманда.мояКоманда";
ПерейтиПоНавигационнойСсылке(НавСсылка);

но всё время навссылка не верна..
как именно искать не знаю

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #124463 · Ответов: 2 · Просмотров: 1392
 

>  Нажатие на картинку
vlad_
Отправлено: 30.11.16, 17:09


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 10.10.16
Пользователь №: 52146


Vofka @ Сегодня, 10:52 * ,

Не зависимо от кода открывается окошко
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #119979 · Ответов: 3 · Просмотров: 2572
 

>  Нажатие на картинку
vlad_
Отправлено: 29.11.16, 18:43


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 10.10.16
Пользователь №: 52146


Всем привет! Помогите пожалуйста... На упр форме есть поле картинки, гиперссылка - истина. При нажатию на картинку открывается другая форма, но кроме этого появляется окно 1с с именем (путем к файлу) картинки.. как можно его заблокировать??




 ! 

Правила: 8
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #119922 · Ответов: 3 · Просмотров: 2572
 

>  Вывести картинку с библиотеки в поле на форме
vlad_
Отправлено: 09.11.16, 17:01


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 10.10.16
Пользователь №: 52146


logist @ Сегодня, 16:46 * ,

Спасибо большое... вот только можно как нибудь убрать "крестик" с поля "номер строки", который добавляется автоматически??




Извините... Последний скрин - это моя ошибка... всё получилось
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #118922 · Ответов: 3 · Просмотров: 1640
 

>  Вывести картинку с библиотеки в поле на форме
vlad_
Отправлено: 09.11.16, 15:30


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 10.10.16
Пользователь №: 52146


Здравствуйте.. Никак не получается... Есть таб часть товары, в ней реквизит "удалить" с типом поле картинки.. нужно, чтобы при добавлении товаров этот реквизит заполнялся картинкой с библиотеки "удалить" как на фото в шапке реквизита

09000000.gif
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #118908 · Ответов: 3 · Просмотров: 1640
 

>  Настройка группы на управляемой форме
vlad_
Отправлено: 24.10.16, 12:22


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 10.10.16
Пользователь №: 52146


Может кто нибудь сталкивался с проблемой: на форме розмещена группа страниц, в ней есть обычная группа.. В этой группе розмещается 3 группы с дикорациями и картинкой.. Так вот, не могу выставить выравнивание общей группы по низу.. как только добавляется текст в декорацию - сразу эта группа в основной опускется вниз.. хотя по идеи все 3 группы должны выровняться внизу
Заранее спасибо!!!
.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #118097 · Ответов: 0 · Просмотров: 1104
 

>  Вывод картинки товара в поле картинки
vlad_
Отправлено: 12.10.16, 11:23


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 10.10.16
Пользователь №: 52146


TipsyKID @ Вчера, 19:12 * ,

Большое спасибо!!!!!! Выручили сильно!!!!!!


vlad_ @ Сегодня, 11:43 * ,
немного модернизировал код.. процедура Перед записью не нужна, так как с серверной процедуры это доступно..
&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    
    //инд = 1;
    Для Каждого СтрокаТовары Из ТекущийОбъект.Товары Цикл
        СсылкаНаКартинку = Объект.Товары[СтрокаТовары.НомерСтроки - 1].АдресКартинки; //ПараметрыЗаписи["СтрокаТовары" + Формат(инд,"ЧГ=0")];
        Если ЭтоАдресВременногоХранилища(СсылкаНаКартинку) Тогда
            СтрокаТовары.ХранилищеИзображения = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(СсылкаНаКартинку));
        КонецЕсли;
        //инд = инд + 1;
    КонецЦикла;
    
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #117619 · Ответов: 3 · Просмотров: 1421
 

>  Вывод картинки товара в поле картинки
vlad_
Отправлено: 11.10.16, 16:51


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 10.10.16
Пользователь №: 52146


вот скрин формы



  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #117578 · Ответов: 3 · Просмотров: 1421
 

>  Вывод картинки товара в поле картинки
vlad_
Отправлено: 11.10.16, 13:25


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 10.10.16
Пользователь №: 52146


В справочнике есть табличная часть "товары".. в ней реквизит номенклатура. кроме того в таб части реквизит "ХранилищеИзображения" с типом ХранилищеЗначения.. Ещё на форме поле "АдресКартинки" с типом поле картинки и кнопка "Добавить изображение".. При нажатии на кнопку для активной строки номенклатуры должна происходить загрузка картинки. при активизации любой строки из ТЧ картинка должна выводиться в поле "АдресКартинки".. у меня загружается но при смене строки пропадает с поля.. в чём ошибка??? помогите пожалуйста..


// процедура нажатие на кнопку "Добавить изображение"
//
&НаКлиенте
Процедура ДобавитьИзображение(Команда)
    
    ТекСтрока = Элементы.Товары.ТекущиеДанные;
    
    Если ТекСтрока = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
    Режим = РежимДиалогаВыбораФайла.Открытие;
    ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
    ДиалогОткрытияФайла.ПолноеИмяФайла = "";
    Фильтр = "Изображения(*.bmp,*.jpg,*.png,*.jpeg)|*.bmp;*.jpg;*.png;*.jpeg";
    ДиалогОткрытияФайла.Фильтр = Фильтр;
    ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
    ДиалогОткрытияФайла.Заголовок = "Выберите файл для загрузки";
    
    Если Не ДиалогОткрытияФайла.Выбрать() Тогда
        
        Возврат;
        
    КонецЕсли;
    
    ПолноеИмяФайла = ДиалогОткрытияФайла.ПолноеИмяФайла;
    
    АдресКартинки = ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(ПолноеИмяФайла), ЭтотОбъект.УникальныйИдентификатор);
    
    ДобавитьИзображениеНаСервере(ТекСтрока.НомерСтроки - 1, АдресКартинки);  
    
КонецПроцедуры

&НаСервере
Процедура ДобавитьИзображениеНаСервере(ИдСтроки,  АдресКартинки);    
    
    
    ТекОбъект = РеквизитФормыВЗначение("Объект");
    текСтрока = ТекОбъект.Товары[ИдСтроки];
    
    ДвоичныеДанные = ПолучитьИзВременногоХранилища(АдресКартинки);
    текСтрока.ХранилищеИзображения = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных(9));
    
    
    ЗначениеВРеквизитФормы(ТекОбъект, "Объект");
        
КонецПроцедуры


//процедура при создании формы на сервере
//
&НаСервере                                                          
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    ТекСтрока = Элементы.Товары.ТекущаяСтрока;
    
    
    ТекОбъект = РеквизитФормыВЗначение("Объект");
    АдресКартинки = ПолучитьНавигационнуюСсылку(ТекОбъект.Ссылка, "Товары.ХранилищеИзображения", ТекСтрока);
        
КонецПроцедуры

//Отображение картинки при переходе по строкам
//
&НаКлиенте
Процедура ТоварыПриАктивизацииСтроки(Элемент)
    
    ТекСтрока = Элемент.ТекущиеДанные;
    Если ТекСтрока = Неопределено Тогда
        Возврат;
    КонецЕсли;    
    
    АдресКартинки = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "Товары.ХранилищеИзображения", ТекСтрока.НомерСтроки-1);
    
    ТоварыПриАктивизацииСтрокиНаСервере(ТекСтрока.НомерСтроки-1);
        
КонецПроцедуры

&НаСервере
Процедура ТоварыПриАктивизацииСтрокиНаСервере(ИдСтроки)
    
    ТекОбъект = РеквизитФормыВЗначение("Объект");
    АдресКартинки = ПолучитьНавигационнуюСсылку(ТекОбъект, "Товары.ХранилищеИзображения", ИдСтроки);
    
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #117557 · Ответов: 3 · Просмотров: 1421
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 30.11.20, 7:32
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!