Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику AnryMc ::: Спасибо сказали: 50 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
26.01.23, 8:54 Чудеса использования полнотекстового поиска
РЕШЕНО: Когда удалил индекс и построил заново - заработало...

Т.е. при добавлении словаря полнотекстового поиска он не индексируется работающими регламентными задания "обновления" и "слияния" - только новое полное построение...
Vofka,
19.01.23, 8:16 Не сохраняются настройки положения колонок ТЧ документа
1) При инсталляции платформы выбрать язык не "по умолчанию / системный", а "русский"
2) Проверить что при инсталляции стоит "галочка" у интерфейса "русский"
или
3) При старте в настройках подключения базы: "Дополнительные параметры запуска" указать: /L ru
nik389,
19.12.22, 15:54 Создание регламентного задания
Довольно часто достаточно "пепеввести" расписание выполнения под пользователем в режиме Предприятия...

Цитата(Talkman @ 19.12.22, 15:21) *
Попытался найти консоль регламентных заданий, там покопаться, но пока не нашел.



Консоль

З.Ы. https://pro1c.org.ua/index.php?showtopic=6894
Talkman,
02.11.22, 11:52 Открытие второго экземпляра списка документов.
Talkman @ Сегодня, 10:57 * ,

Цитата
ПолучитьФорму(<Форма>, <Владелец>, <КлючУникальности>)
Параметры:

<КлючУникальности> (необязательный)
Тип: Произвольный.
В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм.
При поиске учитываются значения свойств открытых форм соответствующим значениям параметров метода. Если найдена открытая форма (по совпадению всех параметров), то она будет возвращена вместо новой формы.
Если из некой формы (один и тот же владелец) требуется открывать новые экземпляры другой формы, то при каждом вызове метода значение данного параметра должно быть уникально (в рамках соответствующих значений свойств открытых форм).
Значение параметра присваивается свойству открываемой формы КлючУникальности.
Следует учитывать, что при получении формы из "объекта" система получает форму для конкретного экземпляра объекта с учетом совокупности переданных параметров, в то время как для "ссылки" всегда существует только один объект в базе данных и форма получается одна (для одинаковой совокупности параметров).

Talkman,
12.08.22, 9:38 Відбір на списку форми документа по додаткових реквізитах
bandrah @ 10.08.22, 21:59 * ,

Практически все списки документов формируются запросом, добавьте в него выборку доп. реквизитов и сделайте по ним условие...
При СозданииНаСервере устанавливайте нужное значение параметра для условия...

AnryMc @ Сегодня, 10:17 * ,


Туплю я с утра однако...

ПриСозданииНаСервере программно напишите нужный отбор по "ДополнительныеРеквизиты"

Туплю я с утра однако...

ПриСозданииНаСервере программно напишите нужный отбор по "ДополнительныеРеквизиты"

А ещё проще: общий модуль "ОбщегоНазначенияКлиентСервер"
- Процедура УстановитьЭлементОтбора
- Процедура УстановитьЭлементОтбораДинамическогоСписка
- Процедура УстановитьПараметрДинамическогоСписка
- Процедура УдалитьЭлементыГруппыОтбораДинамическогоСписка

Пример кода "альтернативного" поиска по наименованию
&НаКлиенте
Процедура СтрокаДляПоискаПриИзменении(Элемент)
    
    Если ЗначениеЗаполнено(СтрокаДляПоиска) Тогда
        
        УстановитьМойОтбор(СтрокаДляПоиска);
        
    Иначе
        
        УдалитьМойОтбор();
        
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура СтрокаДляПоискаОчистка(Элемент, СтандартнаяОбработка)
    
    УдалитьМойОтбор();
        
КонецПроцедуры

&НаКлиенте
Процедура СтрокаДляПоискаОткрытие(Элемент, СтандартнаяОбработка)
    
    СтандартнаяОбработка = ЛОЖЬ;
    
    Если ЗначениеЗаполнено(Элемент.ТекстРедактирования) Тогда
        
        УстановитьМойОтбор(Элемент.ТекстРедактирования);
        
    //Иначе
    //    
    //    УдалитьМойОтбор();
        
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура УстановитьМойОтбор(СДП)
    
    ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбораДинамическогоСписка(Список, "Наименование", СДП, ВидСравненияКомпоновкиДанных.Содержит,,Истина);
    
КонецПроцедуры

&НаКлиенте
Процедура УдалитьМойОтбор()
    
    ОбщегоНазначенияКлиентСервер.УдалитьЭлементыГруппыОтбораДинамическогоСписка(Список, "Наименование");
    
КонецПроцедуры
bandrah,
05.08.22, 10:55 Язык отчета на СКД
РЕШЕНО!!!

Рабочий код:

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    
    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
    
    Настройки = ЭтотОбъект.КомпоновщикНастроек.ПолучитьНастройки();
    
    МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
    
    ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
    
    ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, , ДанныеРасшифровки, Истина);  
    
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    
    ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
    
    ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);
    
    Ячейка = 1;
    
    Пока Ячейка <> Неопределено Цикл
        
        Ячейка = ДокументРезультат.НайтиТекст("Итого");
        
        Если Ячейка <> Неопределено Тогда
            
            Ячейка.Текст = "Разом";
            
        КонецЕсли;
        
    КонецЦикла;
    
    //***Запишем в журнал событий
    ЗаписьЖурналаРегистрации("МоеСобытие.Отчет."+СокрЛП(ЭтотОбъект.Метаданные().Имя),
    УровеньЖурналаРегистрации.Информация,
    ,
    СокрЛП(ЭтотОбъект.Метаданные().Имя),
    "Открыт "+СокрЛП(ПараметрыСеанса.ТекущийПользователь)+" "+СокрЛП(ТекущаяДата()));
    
КонецПроцедуры


Работает со всеми настройками (настойками, пользовательскими настройками, фиксированными настройками) - отборы, оформления, ....
pony95,
06.01.22, 15:52 ВПФ Счет покупателю с QR-кодом - реквизиты платежа (Сумма, iBAN, получатель, назначение платежа
Внешняя печатная форма (ВПФ) - регистрируется в программе и добавляет ещё одну печатную форму для документа "Счет для оплаты Покупателю"
В отличии от стандартной - формирует дополнительно QR-код для формирования оплаты по стандарту НБУ:
"П О С Т А Н О В А
01 лютого 2021 року м. Київ № 11
Про внесення змін до Правил формування та використання QR-коду
для здійснення кредитових переказів"

Проверял на: Monobank и Приват24

P.S. Приват24 на момент проверки не "подхватывал" наименование Получателя. Monobank - всё нормально.
P.P.S. В качестве "назначения платежа" в QR-код берется "Комментарий"

Файл создавался для BAS бух корп., но должен работать и в других конфигурациях этой "линейки".
Для конфигураций: "... для Украины" - нужна небольшая переработка...
denis84, idef, MATEVI, nik389, Vofka,
13.01.21, 15:52 Справочник налоговых инспекций andr_andrey, kasper232, skip69, Vofka,
17.07.18, 10:54 Новая декларация по НДС
mister-x @ 09.07.18, 11:31 * ,

17.07.2018 11:14 Выпущены комплекты регламентированной отчетности за 2 квартал 2018 г. для конфигураций на платформе 1С:Предприятие 7.7
Выпущены комплекты регламентированной отчетности за 2 квартал 2018 г.

Выпуск 1 для конфигураций на платформе 1С:Предприятие 7.7:

Бухгалтерский учет для Украины;
Комплексная конфигурация для Украины.
KriAn, nysysimara,
08.01.13, 16:50 Поиск аутсорсинговой компании для внедрения 1С
Цитата(Ardi @ 08.01.13, 13:24) *
А что с ним?


Специалисты у них хорошие. Но бизнес ориентирован на разовое почасовое внедрение... И если требуется командная работа то как у Райкина:
"- К пуговицам притензии есть?
- Нет пришиты намертво - не оторвешь
... А за качество никто не отвечает"


Я конечно понимаю, что любая фирма создается для получения прибыли, но не до такой же степени...
Ardi,
26.12.12, 9:56 Внешние обработки,отчеты
1) Удаление и/или копирование сохраненных в 1С настроек (например настроек печати табличных форм)
http://infostart.ru/public/150007/

2) Сохранение - восстановление настроек отчета через файл
http://infostart.ru/public/77702/

alex040269,
19.12.12, 11:21 Отбор документов в "Журнале документов"
В первом примере:
Если ТекущаяСтраница = 0 тогда
Отбор.Проведен.Использование=Истина;
ИначеЕсли ТекущаяСтраница = 1 тогда

Вы "включили" отбор но не передали ему значение
ИначеЕсли ТекущаяСтраница = 2 тогда
Отбор.Проведен.Использование=Ложь;
Отбор.Проведен.Значение=Истина;
КонецЕсли;

Вы отключили отбор, зачем значение?

А где вообще вид сравнения? Типа равно, неравно....

Работающий код:

Процедура ПриОткрытии()
    
    ТЗ_Все.Отбор.Проведен.Использование=Ложь;
    
    ТЗ_Проведенные.Отбор.Проведен.Использование=Истина;
    ТЗ_Проведенные.Отбор.Проведен.ВидСравнения=ВидСравнения.Равно;
    ТЗ_Проведенные.Отбор.Проведен.Значение=Истина;
    
    ТЗ_Непроведенные.Отбор.Проведен.Использование=Истина;
    ТЗ_Непроведенные.Отбор.Проведен.ВидСравнения=ВидСравнения.Равно;
    ТЗ_Непроведенные.Отбор.Проведен.Значение=Ложь;

КонецПроцедуры


На форме три страницы на которые вставлено три таблицы: ТЗ_Все, ТЗ_Проведенные, ТЗ_Непроведенные
Для всех таблиц установлен ТипЗначения - ДокументСписок.ХХХ


 ! 

Правила, п.12
 
Vozdyh,
07.12.12, 11:51 При закриті місяця видає помилку: Ділення на "0"?
Я бы поискал в оборотно-сальдовой ведомости по счету (по которым идет переоценка) остаток гривень без количества
Юля,
21.11.12, 15:37 Ведение списка формулировок платежа без изменения конфигурации
Ведение списка шаблонов формулировок платежей (текстовых и программных) без изменения конфигурации и без снятия с поддержки...
Для вставки в поле "Назначение платежа"

Данная обработка позволяет вести произвольный список формулировок для поля "Назначение платежа" (текстовых и программных шаблонов) документа "Платежное поручение исходящее".

Реализовано на основании механизма "внешних печатных форм" c авторегистрацией

Позволяет сохранять (восстанавливать) настройки через файл.

Вызывается из меню "печать" документа.

ДЕТАЛЬНЕЕ (и чтобы правильно настроить) - см. справку в обработке.

Тестировалось на украинских конфигурациях, но должна работать на всех (если что - пишите, доделаю).
bogdan3112,
20.11.12, 11:34 Подорожній лист вантажного автомобіля (міжнародні перевезення)
Выложил в хранилище

http://pro1c.org.ua/index.php?showtopic=9849
gavrisholga, onsamuy, pumbaE, vbi, Vofka,
20.11.12, 10:02 Подорожній лист вантажного автомобіля у міжнародному сполученні. Типова форма N 1 (міжнародна)
Подорожній лист вантажного автомобіля у міжнародному сполученні. Типова форма N 1 (міжнародна)

В xls и mxl форматах
mvk2000, sv111, Unia, vadim007, vbi, Дмитрий Дмитриевич Костен, Хом45,
08.11.12, 9:58 Нумерация строк в справочнике
Форма списка - Событие: ОбновлениеОтображения


Построитель = Новый ПостроительОтчета;
Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(СправочникСписок);
Выборка = Построитель.Результат.Выбрать();
колвоДокументов = Выборка.Количество();

ЭлементыФормы.Надпись1.Значение=колвоДокументов;

//!!! Отображает количество "видимых" строк с учетом иерархии.!!!
Ardi, bereznoy,
08.11.12, 8:26 Информация об ошибках... :)
Бухгалтерия для Украины. Версия 1.2.9.1. Информация об ошибках
...
Код ошибки: 19375
Дата публикации: 13 октября 2006 г.
Описание: Документ "Поступление товаров и услуг - при выборе номенклатуры, по которой установлено налоговое назначение "Хоз. деят-ть, не облаг. НДС", автоматически не заполняется значение рекизита "Налоговое назначение" и не устанавливается флажок "НДС включен в себестоимость"
logist,
08.10.12, 8:12 Как удалить организацию из справочника?
Цитата(KriAn @ 07.10.12, 22:44) *
Ситуация такая: установил чистую конфигурацию и перенес данные из 1С Бухгалтерии 7.7., в результате в справочнике Организации получилось две организации - Наша организация и та, которую перенес. Нашу организацию нужно удалить, при удалении показывает, что есть две ссылки на другие объекты и удалять не хочет. Ссылки такие: ГраницыЗапретаРедактированияДанных - Наша организация, НастройкиПользователей - Не авторизтрован.Основна організація. Подскажите как их убрать? Спасибо!!!

Меню - Операции - регистры сведений - границы запрета изменения данных
KriAn,
11.05.12, 8:59 Технологическая платформа 8.3
Информация о планируемом релизе
Номер 8.3.1
Ориентировочная дата выхода 31.05.2012
Дата обновления плановых данных 10.05.2012

Пора делать на форуме новый раздел...
5_kopeek, Batchir, Vofka, yur, Егор Динин,
12.03.12, 6:09 1С 7.7 vs Windows 7 ???
Обычно предварительный просмотр не работает если 1С не может найти в Винде "принтер по умолчанию".
Если он стоит, то стоит для сетевого принтера поставить весь комплект программного обеспечения, а не только дрова.
FLORIL,
11.03.12, 18:03 При формировании "тяжелого" отчета 1С вылетает
Не шутка:
Если видео от Intel - обновить дрова. Если не помогло - отключить аппаратное ускорение.

Агтивирус??? Если Norton - снести нафиг.
Ardi, sash-88,
09.12.11, 9:53 Новая форма налоговой накладной
Не успели украинские бухгалтера и программисты освоить все тонкости заполнения НН...

Приказ Минфина N 1379 от 01.11.2011 "Об утверждении формы налоговой накладной и порядка заполнения налоговой накладной" (зарегистрирован в Минюсте 22 ноября 2011 р. N 1333/20071) вступает в силу с момента опубликования....

Из новшеств: Колонка 4 "Код товару згідно з УКТ ЗЕД"
tttbuh, Vladal,
30.09.11, 19:14 сортировка 1С и Windows7
Вариант 1:
1. Запустить конфигурацию в режиме «Конфигуратор».
2. Выбрать в разделе «Администрирование» команду «Кодовая страница таблиц
ИБ…».
3. Выбрать последний пункт «+ Текущая системная установка».
4. Щелкнуть по кнопке «ОК».

Вариант 2: (отключить контроль кодовой страницы в 1С)
1. Войдите в директорию программы (например, «C:\Program Files\1Cv77\BIN»);
2. Вызовите контекстное меню щелчком правой кнопкой мыши и выберите в
пункте «Создать» подпункт «Текстовой документ».
3. Задайте файлу имя «OrdNoChk.» и смените расширение созданного файла с txt
на prm.
4. На вопрос системы подтвердите смену расширения файла щелчком по кнопке
«ОК». Вами будет создан файл с конечным именем «OrdNoChk.prm».

Вариант 3:
1) «C:\Program Files\1Cv77\BIN\1cv7......exe» правый клик Свойства
2) Закладка Совместимость - Установить совместимость с ХР
pav_velux,
19.07.11, 5:22 Регламентированная отчетность 11q3 -А что с кнопкой "Заполнить"?
(1) 1C намекает не на что-нибудь (1С-Звит, ...) а на то что ИНСТРУКЦИИ по заполнению декларации о прибыли нет. Официально есть только форма - они её и сделали. А по заполнению есть досужие домыслы аудиторов, бухгалтеров.... Вот заполнят её люди как им кажется надо, а тут налоговая... И забудет налоговая о штрафах в 1-ну гривню - бюджет пополнять то надо...
Ardi,

RSS Текстовая версия Сейчас: 04.02.23, 11:48
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!