Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



13 страниц V   1 2 3 > » 

>  Загрузка EXEL c сервера через COM
burza
Отправлено: 21.03.24, 12:35


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


Slon747 @ Сегодня, 11:58 * ,
он стоит как администратор. то думаю да.

burza @ Сегодня, 12:16 * ,
https://forum.infostart.ru/forum9/topic132619/

Спасибо кто на мысль натолкнул)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178628 · Ответов: 12 · Просмотров: 857
 

>  Загрузка EXEL c сервера через COM
burza
Отправлено: 21.03.24, 11:52


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


Slon747 @ Сегодня, 11:46 * ,
на сервере,там где скул и 1С.учетка кластера админ
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178626 · Ответов: 12 · Просмотров: 857
 

>  Загрузка EXEL c сервера через COM
burza
Отправлено: 21.03.24, 11:43


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


Slon747 @ Сегодня, 11:41 * ,
туплю, вы правы! Приложению Microsoft Excel не удается получить доступ к файлу. куда копать?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178624 · Ответов: 12 · Просмотров: 857
 

>  Загрузка EXEL c сервера через COM
burza
Отправлено: 21.03.24, 11:19


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


Slon747 @ Сегодня, 11:17 * ,
код в общем модуле лежит, по регламенту нужно делать
Функция Bastion() Экспорт
    
    Таб = Новый ТаблицаЗначений;
    Таб.Колонки.Добавить("Наименование");
    Таб.Колонки.Добавить("Производитель");
    Таб.Колонки.Добавить("Артикул");
    Таб.Колонки.Добавить("Цена");
    Таб.Колонки.Добавить("НаличиеОдесса");
    Таб.Колонки.Добавить("Наличиефилиалы");
    Таб.Колонки.Добавить("Спецпредложение");
    Таб.Колонки.Добавить("Полтава");
    Таб.Колонки.Добавить("Черкассы");
    Таб.Колонки.Добавить("Днепр");
    Таб.Колонки.Добавить("Львов");
    Таб.Колонки.Добавить("ИваноФранковс");
    Таб.Колонки.Добавить("Харьков");
    Таб.Колонки.Добавить("Винница");
    Таб.Колонки.Добавить("Тернополь");
    Таб.Колонки.Добавить("Николаев");
    Таб.Колонки.Добавить("Херсон");
    Таб.Колонки.Добавить("Кропивницкий");
    Таб.Колонки.Добавить("Запорожье");
    Таб.Колонки.Добавить("Киев");
    Таб.Колонки.Добавить("Черновцы");
    
    
         файл = "D:\1C\Mail\bas\bastion.csv";
        
        Попытка    
        Excel = Новый COMОбъект("Excel.Application");
        WB   =  Excel.Workbooks.Open(файл);
        WS = WB.Worksheets(1);
        arr = WS.UsedRange.Value;
        WB.Close(0);        
        Исключение    
        КонецПопытки;
        
        
        МассивКолонок = arr.Выгрузить();
        ВсегоСтрок = (МассивКолонок.Получить(0).Количество()) - 1;
    

          Для СтрокаТП = 59 По ВсегоСтрок Цикл        
        Стр = Таб.Добавить();        
        Стр.Наименование = СокрЛП(МассивКолонок.Получить(0).Получить(СтрокаТП));
        Стр.Производитель = СокрЛП(МассивКолонок.Получить(1).Получить(СтрокаТП));
        Стр.Артикул = СокрЛП(МассивКолонок.Получить(3).Получить(СтрокаТП));
        Стр.Цена = СокрЛП(МассивКолонок.Получить(5).Получить(СтрокаТП));
        Стр.НаличиеОдесса = СокрЛП(МассивКолонок.Получить(6).Получить(СтрокаТП));
        Стр.Наличиефилиалы = СокрЛП(МассивКолонок.Получить(7).Получить(СтрокаТП));
        Стр.Спецпредложение = СокрЛП(МассивКолонок.Получить(8).Получить(СтрокаТП));
        Стр.Полтава = СокрЛП(МассивКолонок.Получить(9).Получить(СтрокаТП));
        Стр.Черкассы = СокрЛП(МассивКолонок.Получить(10).Получить(СтрокаТП));
        Стр.Днепр = СокрЛП(МассивКолонок.Получить(11).Получить(СтрокаТП));
        Стр.Львов = СокрЛП(МассивКолонок.Получить(12).Получить(СтрокаТП));
        Стр.ИваноФранковс = СокрЛП(МассивКолонок.Получить(13).Получить(СтрокаТП));
        Стр.Харьков = СокрЛП(МассивКолонок.Получить(14).Получить(СтрокаТП));
        Стр.Винница = СокрЛП(МассивКолонок.Получить(15).Получить(СтрокаТП));
        Стр.Тернополь = СокрЛП(МассивКолонок.Получить(16).Получить(СтрокаТП));
        Стр.Николаев = СокрЛП(МассивКолонок.Получить(17).Получить(СтрокаТП));
        Стр.Херсон = СокрЛП(МассивКолонок.Получить(18).Получить(СтрокаТП));
        Стр.Кропивницкий = СокрЛП(МассивКолонок.Получить(19).Получить(СтрокаТП));
        Стр.Запорожье = СокрЛП(МассивКолонок.Получить(20).Получить(СтрокаТП));
        Стр.Киев = СокрЛП(МассивКолонок.Получить(21).Получить(СтрокаТП));
        Стр.Черновцы = СокрЛП(МассивКолонок.Получить(22).Получить(СтрокаТП));                
        КонецЦикла;
КонецФункции
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178622 · Ответов: 12 · Просмотров: 857
 

>  Загрузка EXEL c сервера через COM
burza
Отправлено: 21.03.24, 11:10


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


Slon747 @ Сегодня, 10:49 * ,
Значение не является значением объектного типа (Выгрузить)

burza @ Сегодня, 10:53 * ,
Обычный старый код чтения xls ))
     файл = "D:\1C\Mail\bas\123.csv";
        
        Попытка    
        Excel = Новый COMОбъект("Excel.Application");
        WB   =  Excel.Workbooks.Open(файл);
        WS = WB.Worksheets(1);
        arr = WS.UsedRange.Value;
        WB.Close(0);        
        Исключение    
        КонецПопытки;
        
        
        МассивКолонок = arr.Выгрузить();
        ВсегоСтрок = (МассивКолонок.Получить(0).Количество()) - 1;
    

          Для СтрокаТП = 59 По ВсегоСтрок Цикл        
        Стр = Таб.Добавить();        
        Стр.Наименование = СокрЛП(МассивКолонок.Получить(0).Получить(СтрокаТП));
        Стр.Производитель = СокрЛП(МассивКолонок.Получить(1).Получить(СтрокаТП));
        Стр.Артикул = СокрЛП(МассивКолонок.Получить(3).Получить(СтрокаТП));
        Стр.Цена = СокрЛП(МассивКолонок.Получить(5).Получить(СтрокаТП));
        Стр.НаличиеОдесса = СокрЛП(МассивКолонок.Получить(6).Получить(СтрокаТП));
        Стр.Наличиефилиалы = СокрЛП(МассивКолонок.Получить(7).Получить(СтрокаТП));
        Стр.Спецпредложение = СокрЛП(МассивКолонок.Получить(8).Получить(СтрокаТП));
        Стр.Полтава = СокрЛП(МассивКолонок.Получить(9).Получить(СтрокаТП));
        Стр.Черкассы = СокрЛП(МассивКолонок.Получить(10).Получить(СтрокаТП));
        Стр.Днепр = СокрЛП(МассивКолонок.Получить(11).Получить(СтрокаТП));
        Стр.Львов = СокрЛП(МассивКолонок.Получить(12).Получить(СтрокаТП));
        Стр.ИваноФранковс = СокрЛП(МассивКолонок.Получить(13).Получить(СтрокаТП));
        Стр.Харьков = СокрЛП(МассивКолонок.Получить(14).Получить(СтрокаТП));
        Стр.Винница = СокрЛП(МассивКолонок.Получить(15).Получить(СтрокаТП));
        Стр.Тернополь = СокрЛП(МассивКолонок.Получить(16).Получить(СтрокаТП));
        Стр.Николаев = СокрЛП(МассивКолонок.Получить(17).Получить(СтрокаТП));
        Стр.Херсон = СокрЛП(МассивКолонок.Получить(18).Получить(СтрокаТП));
        Стр.Кропивницкий = СокрЛП(МассивКолонок.Получить(19).Получить(СтрокаТП));
        Стр.Запорожье = СокрЛП(МассивКолонок.Получить(20).Получить(СтрокаТП));
        Стр.Киев = СокрЛП(МассивКолонок.Получить(21).Получить(СтрокаТП));
        Стр.Черновцы = СокрЛП(МассивКолонок.Получить(22).Получить(СтрокаТП));                
        КонецЦикла;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178620 · Ответов: 12 · Просмотров: 857
 

>  Загрузка EXEL c сервера через COM
burza
Отправлено: 21.03.24, 10:43


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


На клиенте данные загружает, когда процедуру переношу на сервер, ругается на МассивКолонок = arr.Выгрузить(); именно Выгрузить, что нужно сделать?)

я знаю что есть код для сервера другой я и сам им удачно пользуюсь, но нужен именно этот по причинам.

        
Попытка    
        Excel = Новый COMОбъект("Excel.Application");
        WB   =  Excel.Workbooks.Open(файл);
        WS = WB.Worksheets(1);
        arr = WS.UsedRange.Value;
        WB.Close(0);
        
        Исключение    
        КонецПопытки;
        
        МассивКолонок = arr.Выгрузить();
        ВсегоСтрок = (МассивКолонок.Получить(0).Количество()) - 1;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178618 · Ответов: 12 · Просмотров: 857
 

>  УНФ загрузка внешный данных
burza
Отправлено: 13.03.24, 16:03


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


burza @ Сегодня, 12:39 * ,
сопоставление не происходит
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178571 · Ответов: 2 · Просмотров: 321
 

>  УНФ загрузка внешный данных
burza
Отправлено: 13.03.24, 12:39


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


в УНФ штатная загрузка внешных данных, делаю загрузку из ексель. В справочники номенклатуры добавил поле КатегорияОбмена- ведет на другой справочник(поле выбора). При загрузке все показывает а когда создаеться номен то поле пустое.Если поле простое строка то все ок, а если там стоит выбор то не как. Вроде по аналогии добавил в модули но ничего. Может кто-то сталкивался.
Это в менеджере Номенклатуры
ЗагрузкаДанныхИзВнешнегоИсточника.ДобавитьПолеОписанияЗагрузки(ТаблицаПолейЗагрузки, "КатегорияОбмена", "КатегорияОбмена", ОписаниеТиповСтрока25,ОписаниеТиповКолонка,"Номенклатура",2,,Истина);

 ЗагрузкаДанныхИзВнешнегоИсточникаПереопределяемый.СопоставитьНоменклатуруКатегорияОбмена(СтрокаТаблицыФормы.КатегорияОбмена);


Это в общем
Процедура СопоставитьНоменклатуруКатегорияОбмена(КатегорияОбмена) Экспорт
     ЗначениеБылоСопоставлено = Ложь;
    
    Если НЕ ЗначениеБылоСопоставлено И ЗначениеЗаполнено(КатегорияОбмена) Тогда
        
        СправочникСсылка = Справочники.КатегорияОбмена.НайтиПоНаименованию(КатегорияОбмена);
        Если НЕ СправочникСсылка.Пустая() Тогда
            
            
            ЗначениеБылоСопоставлено = Истина;
            Номенклатура = СправочникСсылка.Наименование;
            
        КонецЕсли;
        
    КонецЕсли;
        
КонецПроцедуры


Отладка туда не пускает,ничего не происходит(
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178570 · Ответов: 2 · Просмотров: 321
 

>  Фото в отчете номенклатуры
burza
Отправлено: 08.03.24, 12:17


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


burza @ Сегодня, 10:10 * ,
Никто не знает?))
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178556 · Ответов: 2 · Просмотров: 419
 

>  Фото в отчете номенклатуры
burza
Отправлено: 08.03.24, 10:10


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


Здравствуйте. Задача стоит вывести всю номен с ее фото в отчет. У меня ошибка где-то . Когда вывожу один товар всё ок, а когда все то картинка растягиваеться на всю номен а не отдельно на каждую строку.Что не так подскажите?

Запрос
ВЫБРАТЬ
    Номенклатура.Ссылка КАК Ссылка,
    Номенклатура.ФайлКартинки КАК ФайлКартинки
ИЗ
    Справочник.Номенклатура КАК Номенклатура
ГДЕ
    Номенклатура.КатегорияНоменклатуры.Родитель.Наименование = &Наименование

И сам модуль
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь; // отключаем стандартный вывод отчета - будем выводить программно         
    Настройки = КомпоновщикНастроек.Настройки;// Получаем настройки отчета  
    
    //ketr
    НастройкиОтчета = КомпоновщикНастроек.ПолучитьНастройки();
    
    ПараметрПериод = НастройкиОтчета.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ДатаОстатка"));
    Если ПараметрПериод <> Неопределено
        И ПараметрПериод.Использование
        И ЗначениеЗаполнено(ПараметрПериод.Значение) Тогда
        
        ПараметрПериод.Значение = КонецДня(ПараметрПериод.Значение);
    КонецЕсли;

     ПараметрыОтчета = ПодготовитьПараметрыОтчета(НастройкиОтчета);

    //ketr
    
    
    // Устанавливаем настройки отбора в соответствии с пользовательскими настройками
    ТаблицаОтборов = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
    Для Каждого ЭлементОтбора Из КомпоновщикНастроек.Настройки.Отбор.Элементы Цикл        
        НайденнаяПользовательскаяНастройка =
            ТаблицаОтборов.Найти(ЭлементОтбора.ИдентификаторПользовательскойНастройки);        
        Если НайденнаяПользовательскаяНастройка <> Неопределено Тогда
            ЭлементОтбора.ВидСравнения = НайденнаяПользовательскаяНастройка.ВидСравнения;
            ЭлементОтбора.Использование = НайденнаяПользовательскаяНастройка.Использование;
            ЭлементОтбора.ПравоеЗначение = НайденнаяПользовательскаяНастройка.ПравоеЗначение;
        КонецЕсли;        
    КонецЦикла;
    
    ДанныеРасшифровки = Новый ДанныеРасшифровкиКомпоновкиДанных; // Создаем данные расшифровки             
    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных; // Создаем компоновщик макета        
    // Инициализируем макет компоновки используя схему компоновки данных
    // и созданные ранее настройки и данные расшифровки
    СхемаКомпоновкиДанных = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
    МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, НастройкиОтчета, ДанныеРасшифровки);
    
    // Скомпонуем результат
    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновки.Инициализировать(МакетКомпоновки, , ДанныеРасшифровки);
    
    ДокументРезультат.Очистить();
    
    // Выводим результат в табличный документ
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ДокументРезультат);    
    //....
    ПроцессорВывода.Вывести(ПроцессорКомпоновки);
    

    // Заполняем рисунки для полей, в данных расшифровки которых находятся элементы справочника
    // "НоменклатураПрисоединенныеФайлы"
    КоличествоКолонокТаблицы = ДокументРезультат.ШиринаТаблицы; // Количество колонок в отчете
    КоличествоСтрокТаблицы = ДокументРезультат.ВысотаТаблицы;     // Количество строк в отчете
    Рис1 = 0;
    стПерв = 0;
    Номен = "";
    // Обходим все ячейки отчета
    Для Кл = 1 По КоличествоКолонокТаблицы Цикл         
        Для Ст = 1 По КоличествоСтрокТаблицы Цикл              
            ТекОбласть = ДокументРезультат.Область(Ст, Кл);  
            // Если имеется расшифровка ячейки, то проверям наличие полей расшифровки
            Если ТекОбласть.Расшифровка <> Неопределено Тогда
                ПоляРасшифровки = ДанныеРасшифровки.Элементы[ТекОбласть.Расшифровка].ПолучитьПоля();
                Если ПоляРасшифровки.Количество() > 0 Тогда
                    // Если тип значения поля расшифровки соответствует справочнику прикрепленных файлов, то
                    // выводим связанную картинку
                                    
    
                    Рисунок = ПолучитьИзображение(ПоляРасшифровки.Получить(0).Значение);
                    Если Рисунок <> Неопределено  Тогда
                        Если ДокументРезультат.Область(ст, 4, Ст, 4).Текст <> Номен и стПерв <> 0  Тогда
                            ТекОбласть = ДокументРезультат.Область(стПерв, Кл, Ст-1,Кл);
                            Если  Ст - стПерв = 1 Тогда
                                ТекОбласть.ВысотаСтроки = 20.5*9;
                            Иначе
                                ТекОбласть.ВысотаСтроки = 20.5*9/ (Ст - стПерв);
                            КонецЕсли;
                            
                            Рис = ДокументРезультат.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
                            Рис.РазмерКартинки = РазмерКартинки.Пропорционально;
                            Рис.Картинка = Рис1;
                            Рис.Расположить(ТекОбласть);
                            Рис1 = Рисунок;
                            стПерв = ст;                                
                            Номен = ДокументРезультат.Область(ст, 4, Ст, 4).Текст;
                        ИначеЕсли  стПерв = 0 Тогда
                            стПерв = ст;
                            Рис1 = Рисунок;
                            Номен = ДокументРезультат.Область(ст, 4, Ст, 4).Текст;

                        КонецЕсли;
                                            
                    КонецЕсли;
                КонецЕсли;
            КонецЕсли;              
        КонецЦикла;  
        
        Если Рисунок <> Неопределено  Тогда
            ТекОбласть = ДокументРезультат.Область(стПерв, Кл, Ст-1,Кл);
            Если  Ст - стПерв = 1 Тогда
                ТекОбласть.ВысотаСтроки = 20.5*9;
            Иначе
                ТекОбласть.ВысотаСтроки = 20.5*9/ (Ст - стПерв);
            КонецЕсли;
            
            Рис = ДокументРезультат.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
            Рис.РазмерКартинки = РазмерКартинки.Пропорционально;
            Рис.Картинка = Рис1;
            Рис.Расположить(ТекОбласть);
        КонецЕсли;

    КонецЦикла;
            
КонецПроцедуры

Функция ПолучитьИзображение(ПрисоединенныйФайл)
    
    КартинкаПоумолчанию = Неопределено;
    
    Если ТипЗнч(ПрисоединенныйФайл) =
            Тип("СправочникСсылка.НоменклатураПрисоединенныеФайлы") Тогда                
        Запрос = Новый Запрос;
        Запрос.Текст =
        "ВЫБРАТЬ
        |    НоменклатураПрисоединенныеФайлы.Ссылка КАК ХранимыйФайл
        |ИЗ
        |    Справочник.НоменклатураПрисоединенныеФайлы КАК НоменклатураПрисоединенныеФайлы
        |ГДЕ
        |    НоменклатураПрисоединенныеФайлы.Наименование = &ПрисоединенныйФайл";         
        Запрос.УстановитьПараметр("ПрисоединенныйФайл", ПрисоединенныйФайл.Наименование);         
        Результат = Запрос.Выполнить();
        Если НЕ Результат.Пустой() Тогда
            Выборка = Результат.Выбрать();
            Выборка.Следующий(); // Получаем двоичные данные катинки
            Если НЕ ЗначениеЗаполнено(Выборка.ХранимыйФайл) Тогда
                Возврат Новый Картинка(ПолучитьМакет("НетКартинки"));
            Иначе
                ДанныеФайла = РаботаСФайлами.ДвоичныеДанныеФайла(Выборка.ХранимыйФайл, Неопределено);
                Возврат Новый Картинка(ДанныеФайла);
            КонецЕсли;
        Иначе //// Если данные отсутствуют, получаем стандартное изображение из
              // дополнительного макета внешнего отчета
            Возврат Новый Картинка(ПолучитьМакет("НетКартинки"));
        КонецЕсли;
    КонецЕсли;
    
    Возврат КартинкаПоумолчанию;
    
КонецФункции


burza @ Сегодня, 10:01 * ,
сам отчет https://dropmefiles.com.ua/ua/zN8hv52w
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178552 · Ответов: 2 · Просмотров: 419
 

>  Ошибка COM при обмене
burza
Отправлено: 06.03.24, 17:21


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


alex-l1904 @ Сегодня, 8:54 * ,
да вы были правы, не стояло. тупанул не про тот модуль сразу полумал. Не теперь в мутабельность сваливаеться(

по причине:
Произошла исключительная ситуация (1C:Enterprise 8.3.19.1522): Ошибка при выполнении обработчика - 'ПередЗаписью'
Попытка передачи с клиента на сервер мутабельного значения 1-го параметра метода ПередЗаписьюДокумента ().
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178538 · Ответов: 7 · Просмотров: 480
 

>  Ошибка COM при обмене
burza
Отправлено: 06.03.24, 11:34


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


alex-l1904 @ Сегодня, 11:10 * ,
Коментував цю строку і нічого. Дивно що в файловій версії все ок, нічого не треба роботи.
Процедура ОбсужденияПередЗаписью(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
    
    Если Источник.ОбменДанными.Загрузка Тогда
        Возврат;
    КонецЕсли;
    
    Если Отказ Тогда
        Возврат;
    КонецЕсли;
    
    Если Источник.ЭтоНовый() Тогда
        Источник.ДополнительныеСвойства.Вставить("ЭтоНовый", Истина);
        Возврат;
    КонецЕсли;
    
    Если ОбщегоНазначения.ЭтоДокумент(Источник.Метаданные()) Тогда
        Сообщение = ОбсужденияСравнитьОбъектыДокумент(Источник, РежимЗаписи, РежимПроведения);
    ИначеЕсли ОбщегоНазначения.ЭтоСправочник(Источник.Метаданные()) Тогда
        Сообщение = ОбсужденияСравнитьОбъектыСправочник(Источник);
    КонецЕсли;
    
    Если НЕ ПустаяСтрока(Сообщение) Тогда
        ДобавитьСообщение(
        Сообщение,
        Источник.Ссылка,
        ,
        Истина);
    КонецЕсли;
    
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178533 · Ответов: 7 · Просмотров: 480
 

>  Ошибка COM при обмене
burza
Отправлено: 06.03.24, 10:30


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


alex-l1904 @ Сегодня, 8:54 * ,
это не модуль я обработка там все на форме. точно такая же в Бух БАС выгружает все ок.

sava1 @ Сегодня, 9:14 * ,
ничего


ЗАказ покупателя снял. а ошибка осталась.
burza @ Вчера, 17:37 * ,
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178531 · Ответов: 7 · Просмотров: 480
 

>  Ошибка COM при обмене
burza
Отправлено: 05.03.24, 17:37


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


Делаю обмен через COM между базами, когда делаю через файловую версию всё ок через сервер вот такое вылазит.Помогите уже не знаю куда смотреть.

Лазил в обсужение ОбсужденияПередЗаписьюДокумента удалил оттуда документ, всеровно ошибка.

Произошла исключительная ситуация (1C:Enterprise 8.3.19.1522): При подписке ОбсужденияПередЗаписьюДокумента на событие ПередЗаписью произошла ошибка. Обработчик события не найден.
{Обработка.ОбменСДана.Форма.Форма1.Форма(800)}: ДокументБух = ПоступленияТУБух.СоздатьДокумент();
{Обработка.ОбменСДана.Форма.Форма1.Форма(861)}: ОбменЗаказНаСервере();

по причине:
Произошла исключительная ситуация (1C:Enterprise 8.3.19.1522): При подписке ОбсужденияПередЗаписьюДокумента на событие ПередЗаписью произошла ошибка. Обработчик события не найден.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178528 · Ответов: 7 · Просмотров: 480
 

>  8.3.24 Web Клиент ошибка при формировании отчета
burza
Отправлено: 20.02.24, 16:47


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


AnryMc @ Сегодня, 16:42 * ,
у меня обычный скд без формы вообще. не совсем понял куда нужно поставить галочку

И висит бескончно такая форме нету логина и пароля что может быть?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178445 · Ответов: 4 · Просмотров: 721
 

>  8.3.24 Web Клиент ошибка при формировании отчета
burza
Отправлено: 20.02.24, 15:06


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


или когда отчет или печать вылазит такая ошибка! и еще такая Cannot read properties of undefined (reading 'prefix'). при открытие любого отчета
стояла 8.3.12 всё было ок. Это баги платформы или?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178442 · Ответов: 4 · Просмотров: 721
 

>  Как выгрузить большой объём данных постранично в json?
burza
Отправлено: 20.02.24, 12:44


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


Vofka @ Сегодня, 12:06 * ,
Понял, сейчас гляну, спасибо!
и еще вопрос не по теме ну чтобы уже не создавть


 ! 

Правила: 6
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178438 · Ответов: 12 · Просмотров: 11682
 

>  Как выгрузить большой объём данных постранично в json?
burza
Отправлено: 20.02.24, 10:46


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


Vofka @ Сегодня, 9:41 * ,
сейчас пробну
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178427 · Ответов: 12 · Просмотров: 11682
 

>  Как выгрузить большой объём данных постранично в json?
burza
Отправлено: 19.02.24, 19:33


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


Vofka @ Сегодня, 15:05 * ,
делать Автоинкремент и пробывать запросами через саму sql делать? ну уже тоже так решил, ибо через 1С я так понял это ника как не решить

burza @ Сегодня, 18:55 * ,
что-то такое SELECT * FROM dbo.Table_1 ORDER BY Id OFFSET 1 ROWS FETCH NEXT 10 ROWS ONLY

как запросом через 1С получить данные и разобрать?)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178422 · Ответов: 12 · Просмотров: 11682
 

>  Как выгрузить большой объём данных постранично в json?
burza
Отправлено: 19.02.24, 15:02


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


burza @ 17.02.24, 16:18 * ,
подскажите что как быть)?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178417 · Ответов: 12 · Просмотров: 11682
 

>  Как выгрузить большой объём данных постранично в json?
burza
Отправлено: 17.02.24, 16:18


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


Vofka @ 12.02.24, 13:54 * ,
забыл упомянуть что лежит на sql. то есть АВТОНОМЕРЗАПИСИ() не работает через внешние источники. как быть?
внутри да всё ок работает как вы подсказали.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178410 · Ответов: 12 · Просмотров: 11682
 

>  Выполнить действия после закрытия документа
burza
Отправлено: 15.02.24, 17:17


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


sava1 @ Сегодня, 16:59 * ,
дякую))
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178405 · Ответов: 2 · Просмотров: 1231
 

>  Выполнить действия после закрытия документа
burza
Отправлено: 15.02.24, 16:48


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


После закрытия документа нужно делать рассылку по электронной почте программно, сформировать документ расходной в екселе. Написал общий модуль туда все запихнул. Ну а вот дальше беда, на форме после закрытие на срабатывает ибо я делаю печатную форму накладной. работает только когда документ полностью закрыт. Как передать документ уже после всего закрытого на общий модуль?

&НаСервере
Процедура ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи)

mail.ОтправкаПочты(ТекущийОбъект);

Функция ОтправкаПочты(Док)  экспорт   
    
    
        Пар = Новый ТаблицаЗначений;    
        Пар.Колонки.Добавить("Идентификатор");
        Пар.Колонки.Добавить("МенеджерПечати");
        Пар.Колонки.Добавить("УникальныйИдентификатор");
        Пар.Колонки.Добавить("ДополнительныеПараметры");            
        НоваяСтрока = Пар.Добавить();
        НоваяСтрока.Идентификатор = "Накладная";
        НоваяСтрока.МенеджерПечати = "Документ.РасходнаяНакладная";
        НоваяСтрока.УникальныйИдентификатор = "07691C8060031E8CDD5BDFEA5C8E31D8";         
        НоваяСтрока.ДополнительныеПараметры = Новый Структура;
        НоваяСтрока.ДополнительныеПараметры.Вставить("ДополнитьКомплектВнешнимиПечатнымиФормами", ложь);                    
        Для каждого Стр Из Пар Цикл      
        КомандыПечати = Новый Массив();
        КомандыПечати.Добавить(Стр);          
        КонецЦикла;

                    
        СписокОбъектов = Новый Массив();
        СписокОбъектов.Добавить(Док);
                                    
        
        МассивXLS = Новый Массив();
        МассивXLS.Добавить("XLSX");        
        НастройкиСохранения = Новый Структура;
        НастройкиСохранения.Вставить("ФорматыСохранения", МассивXLS);
        НастройкиСохранения.Вставить("ПодписьИПечать", ложь);
        НастройкиСохранения.Вставить("ПереводитьИменаФайловВТранслит", ложь);
        НастройкиСохранения.Вставить("УпаковатьВАрхив", ложь);
    
    СформированныеФайлы = УправлениеПечатью.НапечататьВФайл(КомандыПечати, СписокОбъектов, НастройкиСохранения);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178403 · Ответов: 2 · Просмотров: 1231
 

>  Как выгрузить большой объём данных постранично в json?
burza
Отправлено: 12.02.24, 16:23


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


Vofka @ Сегодня, 13:54 * ,
АВТОНОМЕРЗАПИСИ() на ссылку делаю. таблица временая


burza @ Сегодня, 15:59 * ,
Всё ок) лохонулся
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178391 · Ответов: 12 · Просмотров: 11682
 

>  Как выгрузить большой объём данных постранично в json?
burza
Отправлено: 12.02.24, 12:51


Оратор
*****

Группа: Пользователи
Сообщений: 312
Регистрация: 02.08.15
Пользователь №: 45113


подскажите как выгрузить большой объём данных постранично в json . В каждую страницу по 10 000. как через page передавать типо первая страница 10 000. вторая начиная с 10 001 по 20 000 и т.д

    ПараметрыИзЗапроса = Новый Структура;
    ПараметрыИзЗапроса.Вставить("token", Запрос["ПараметрыURL"].Получить("token"));
    //ПараметрыИзЗапроса.Вставить("page", Запрос["ПараметрыURL"].Получить("page"));


  Если ПараметрыИзЗапроса.token = "fxGXX13iRkE5y0f0NvQAz9mjrAFtF4sRT9QRqZXhifgypLGAF" тогда     
        
    ////Прайс //////////////////////////////////
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    dbo_Table_1.Артикул КАК Артикул,
        |    dbo_Table_1.Производитель КАК Производитель,
        |    dbo_Table_1.Наименование КАК Наименование,
        |    dbo_Table_1.Валюта КАК Валюта,
        |    dbo_Table_1.Поставщик КАК Поставщик,
        |    dbo_Table_1.Цена КАК Цена,
        |    dbo_Table_1.Наличие
        |ИЗ
        |    ВнешнийИсточникДанных.Price.Таблица.dbo_Table_1 КАК dbo_Table_1
        |
        |СГРУППИРОВАТЬ ПО
        |    dbo_Table_1.Артикул,
        |    dbo_Table_1.Цена,
        |    dbo_Table_1.Наименование,
        |    dbo_Table_1.Производитель,
        |    dbo_Table_1.Наличие,
        |    dbo_Table_1.Валюта,
        |    dbo_Table_1.Поставщик";
    

    РезультатЗапроса = Запрос.Выполнить();
    
    Выборка = РезультатЗапроса.Выбрать();
    
       МассивУслуг = Новый Массив;


    Пока Выборка.Следующий() Цикл

            МассивУслуг.Добавить(Новый Структура("Артикул, Производитель, Цена, Наименование, Наличие", Выборка.Артикул, Выборка.Производитель , Выборка.Цена, Выборка.Наименование, Выборка.Наличие));
        
    
        КонецЦикла;    

    
    ЗаписьJSON = Новый ЗаписьJSON;
    ЗаписьJSON.УстановитьСтроку();
    
    ЗаписатьJSON(ЗаписьJSON, МассивУслуг);


    
    СтрокаДляОтвета = ЗаписьJSON.Закрыть();

    
    Ответ = Новый HTTPСервисОтвет(200);    
    Ответ.Заголовки.Вставить("Content-type", "application/json;  charset=utf-8");
    
    Ответ.УстановитьТелоИзСтроки(СтрокаДляОтвета, КодировкаТекста.UTF8, ИспользованиеByteOrderMark.НеИспользовать);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #178385 · Ответов: 12 · Просмотров: 11682
 

13 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 20.05.24, 14:33
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!