Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику kserg2012 ::: Спасибо сказали: 3 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
02.09.21, 8:33 Как вывести некое значение, не имеющее отношение к данным отчета?
Цитата(lolmatrix @ 31.08.21, 16:48) *
как это цеплять к основному отчету?

у меня получилось реализовать 2 способами
1) в запросе СКД добавил подзапрос, в котором получаю Сумму оплаты поставщикам, и далее чеоез ЛЕВОЕ СОЕДИНЕНИЕ по условию связи ИСТИНА данное значение добавляю в основной запрос.
Далее описываю это значение как ресурс с агрегатной функцией МАКСИМУМ(СуммаОплатыПоставщикам) и выводом в 2-х группировках данных (в самой верхней и в ОбщиеИтоги)

Решение приемлемое, но мне не очень понравилось, к тому же у клиента появилась "хотелка" - прикрутить к этому подзапросу небольшой отбор... Поэтому сделал вторым способом - более наглядно

2) В запросе вместо значения СуммаОплатыПоставщикам из подзапроса подставил 0 (чтобы организовать саму колонку в данных СКД)
а само значение-число вывожу как наименование этой колонки в шапке - получилось типа "Оплата поставщикам 272 000 USD"
(вывод в группировках теперь не нужен)

реализовано это в Процедуре ПриКомпоновкеРезультата
-получаю обычным запросом значение СуммаОплатыПоставщикам и затем через ДоступноеПолеВыбора нахожу и меняю заголовок этой колонки


kserg2012 @ Сегодня, 9:27 * ,

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    
    Запрос = Новый Запрос;
    Запрос.Текст=
    ...
    тзВрем = Запрос.Выполнить().Выгрузить();
    
    //изменим заголовок Доступного поля
    ЗаголовкиПолей = Новый Соответствие;
    Для Каждого ДоступноеПолеВыбора Из КомпоновщикНастроек.Настройки.ДоступныеПоляВыбора.Элементы Цикл
        Если Лев(ДоступноеПолеВыбора.Заголовок,10) = "Оплата пос" Тогда
            ЗаголовкиПолей.Вставить(ДоступноеПолеВыбора.Поле, "Оплата поставщикам" + Символы.ПС + тзВрем[0].ОплатаПоставщикамUSD+" USD");
            Прервать;
        КонецЕсли;
    КонецЦикла;

    Для Каждого ВыбранноеПоле Из КомпоновщикНастроек.Настройки.Выбор.Элементы Цикл
        НовыйЗаголовок = ЗаголовкиПолей.Получить(ВыбранноеПоле.Поле);
        Если НовыйЗаголовок <> Неопределено Тогда
            ВыбранноеПоле.Заголовок = НовыйЗаголовок;
            Прервать;
        КонецЕсли;
    КонецЦикла;
lolmatrix,
23.06.20, 10:08 Передача данных из 8.3 в M.E.DOC данных для своего шаблона
Цитата(kserg2012 @ 18.06.20, 11:17) *
Подскажите пож-та, как понять в чем заключается ошибка

Решил дополнить, возможно кому то пригодиться.

Причина была в моем "корявом" шаблоне, причем в чем был этот глюк так и не понял.
Как выяснил этот момент: подставил в алгоритме типовой шаблон

Бланк="1С82ВНБ";

Проблемная команда отработала без ошибки (т.е. проблема была в структуре полей моего шаблона или в оформлении макета)
Doc = pd.OpenOrCreateDocument(orgId, Бланк, , , ИД, 0);

Шаблон пришлось еще раз создать и оформить по новой.
И только после этого передача данных заработала.

kserg2012 @ Сегодня, 11:04 * ,
к сожалению, в инете очень мало инф-ции по нюансам создания и работы со своими шаблонами

единственно что мне удалось найти - это такое вот упонимание в инструкции
Цитата
Щоб мати змогу відправляти документ контрагенту, у формі обов’язково повинно бути поле «SIDE_EDRPOU_K» (ЄДРПОУ контрагента) з групи Контрагент


Если у кого-либо имеется подобная инф-ция прошу поделиться ссылками

Спасибо
Vofka,
04.03.19, 8:44 Обробка "Обмін з банком" для БУ 2.0
yura_l @ Вчера, 20:38 * ,
Добрый день, коллеги
Возможно вы знаете, но всё же напомню - движок 1с при работе с файлами DBF имеет ограничение на длину имени 8 символов.
Сам сталкивался с таким, когда иной разу забудешь и затем в ступоре смотришь на "непонятную" ошибку smile.gif

yura_l,

RSS Текстовая версия Сейчас: 20.09.21, 4:51
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!