Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику denis84 ::: Спасибо сказали: 146 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
15.06.24, 8:21 Поделитесь обработкой "формирование налоговых накладных"
Pav24lina,
Для спасибі є спеціальна кнопка
Pav24lina,
14.06.24, 14:48 Поделитесь обработкой "формирование налоговых накладных"
Pav24lina @ Сегодня, 11:58 * ,

Доброго дня! З таким матеріалом ознайомлювалися?

https://www.youtube.com/watch?v=sVv2ESWF5FU

https://www.youtube.com/watch?v=q5G76TR9QO4
Pav24lina,
04.06.24, 14:12 Добавить в форму цену
kayfatuch @ Сегодня, 14:23 * ,
Добавьте реквизит в документ "Цена старая", т.к. "цена" периодический реквизит и в ТиС есть такое понятие как "категория цен". То при изменении товара -

        
    спр=СоздатьОбъект("Справочник.Цены");
    спр.ИспользоватьВладельца(Товар);
    Цена    = 0;
    Если спр.НайтиПоРеквизиту("КатегорияЦены",ВыбКатегорияЦен,0)=1 Тогда   // пишите например сюда "Учетная" или там какую хотите получать цену
           ЦенаСтарая=спр.Цена.Получить(ДатаДок);                         // или например НачМесяца(Датадок) будем получать цену на начало месяца 01/06/2024 и т.д.
    КонецЕсли;


Пробуйте
kayfatuch,
14.05.24, 10:10 Руководство пользователя для BAS for small company (Малий бізнес)
barabambler @ Сегодня, 10:49 * ,
а ну спробуйте за цим посиленням: https://turbobita.net/download/folder/23372...domain=turbo.to

перший пункт побачите - "BAS SmallCompany.dokum.zip"
f12,
08.05.24, 10:39 Вызвать фоновое задание с методом в модуле внешней обработки
AnryMc @ Сегодня, 11:20 * ,
вот такой вариант еще нащел:
//Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.
//Не буду растекаться мыслью по дереву и тянуть кота за все известные места, так как надеюсь, все согласятся, что фоновое выполнение это хорошо. Есть простой путь запускать любой код в фоне. Специалисты скорее //всего такой способ используют, но что-то в инете я описания не встретил, решил выложить.

//Перво-наперво создаем общий модуль с именем например "ФоновоеВыполнение" с галкой "Сервер". Добавим туда пару процедур:

Функция ЗапуститьФоновоеВыполнение(ТекстПроцедуры,СтруктураПараметров=Неопределено) Экспорт
    УникальныйИдентификатор = Новый УникальныйИдентификатор;
    ПараметрыВыполнения = Новый Массив;
    ПараметрыВыполнения.Добавить(ТекстПроцедуры);
    ПараметрыВыполнения.Добавить(СтруктураПараметров);
    
    ФоновыеЗадания.Выполнить("ФоновоеВыполнение.ФоноваяПроцедура",ПараметрыВыполнения,УникальныйИдентификатор);
    Возврат УникальныйИдентификатор;
КонецФункции

Процедура ФоноваяПроцедура(ТекстМодуля,ПараметрыВыполнения) Экспорт
    ПолныйТекстМодуля = "";
    Для Каждого ТекПараметр Из ПараметрыВыполнения Цикл
        ПолныйТекстМодуля = ПолныйТекстМодуля+ТекПараметр.Ключ+"=ПараметрыВыполнения."+ТекПараметр.Ключ+";"+Символы.ПС;
    КонецЦикла;
    ПолныйТекстМодуля = ПолныйТекстМодуля + ТекстМодуля;
    Выполнить(ПолныйТекстМодуля);
КонецПроцедуры
//И готово!

//Теперь для выполнения когда в любой момент мы можем поместить любую процедуру в текстовую переменную:

ТекстФоновойПроцедуры = "
|//Тут передаем текст фоновой процедуры, это может быть вызов каких то процедур или полноценный код
|//вызов процедур проще, т.к. тупо легче отлаживать, т.к. код в этой процедуре обычной отладке не поддастся,
|//а при вызове процедуры или функции мы ставим там точку останова и включаем в отладке автоматическое
|//подключение  фоновых заданий. Запускать можно любые методы для выполнения на сервере.
|
|ОбщийМодульСервер.ВыполнитьНужнуюЗадачу(Парметр1,Парметр2);"
И вызывать ее выполнение:

ФоновоеВыполнение.ЗапуститьФоновоеВыполнение(ТекстФоновойПроцедуры,Новый Структура("Параметр1,Параметр2",Параметр1,Параметр2));
AnryMc, kserg2012,
08.05.24, 9:52 Вызвать фоновое задание с методом в модуле внешней обработки
AnryMc @ Сегодня, 9:20 * ,
Я делал когда-то обработку в фоновом режиме "корректировка ответственных в документах РТиУ"
Может и не то что Вам надо, но делал так и подключал в 1с 8 в фоновых заданиях запуск обработки по времени(получилось, то что надо заказчику;
Функция СведенияОВнешнейОбработке() Экспорт
    ВерсияБСП = СтандартныеПодсистемыСервер.ВерсияБиблиотеки();
    ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке(ВерсияБСП);
    ПараметрыРегистрации.Информация = НСтр("Корректировка Ответственных в документах");
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
    ПараметрыРегистрации.Версия = "2.0";
    ПараметрыРегистрации.БезопасныйРежим = Ложь;
    
    Команда = ПараметрыРегистрации.Команды.Добавить();
    Команда.Представление = НСтр("Корректировка Ответственных в документах");
    Команда.Идентификатор = "КорректировкаОтветственныхВДокументах";
    Команда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
    Команда.ПоказыватьОповещение = Ложь;
    Команда.Модификатор = "";
    
    Возврат ПараметрыРегистрации;
КонецФункции

Процедура ВыполнитьКоманду(Идентификатор,ОбъектыНазначения) Экспорт
    Если Идентификатор =   "КорректировкаОтветственныхВДокументах" ТОгда
        КорректировкаОтветственныхВДокументах();
    КонецЕсли;    
КонецПроцедуры

&НаСервере
Процедура КорректировкаОтветственныхВДокументах() Экспорт
              //тут был текст запросов и т.д.
КонецПроцедуры
AnryMc,
02.05.24, 14:08 Как програмно установить шрифт в форматированом документе
kostya77 @ Сегодня, 14:34 * ,
//Обработка элементов форматированного документа, входящего в состав параграфа, может оказаться полезной в том случае, 
//если нужно, например, убрать все оформление в виде курсива или полужирного шрифта.

//Пример:

Полужирный = Новый Шрифт(, , Истина);
Курсив = Новый Шрифт(, , , Истина);
Обычный = Новый Шрифт;
Для каждого Элемент Из Параграф.Элементы Цикл
     Если ТипЗнч(Элемент) = Тип("ПереводСтрокиФорматированногоДокумента") Тогда        
           Продолжить;
     КонецЕсли;
     Если Элемент.Шрифт = Полужирный Или Элемент.Шрифт = Курсив Тогда          
           Элемент.Шрифт = Обычный
     КонецЕсли;
КонецЦикла;
kostya77,
24.04.24, 13:58 Off: Часто ли Вам приходилось переписывать учёт ОС в типовых конфигурациях?
AnryMc @ Сегодня, 14:35 * ,
Доброго дня! В 1с 8 нічого не змінював. А ось в 1с:7.7, яка і досі в нас працює на підприємстві, багато чого доробляли але все під забаганки нашоїх бухгалтерії (нові документи, зміна проводок і таке інше).
AnryMc,
12.04.24, 8:26 УФ после выбора из списка задать вопрос - не работает
AnryMc @ Вчера, 16:35 * ,
Працює - платформа 8.3.16.1148, конфігурація Business automation software for accounting CORP, edition 2.1 (2.1.9.2)
AnryMc,
12.04.24, 7:46 УФ после выбора из списка задать вопрос - не работает
AnryMc @ Вчера, 16:35 * ,


Вам не задавалося питання?
AnryMc,
01.04.24, 9:03 раскраска строки FormEX
4andriy @ Сегодня, 9:05 * ,
Доброго дня, в журналі документів розфарбована ТЧ за ознакою "КонтрольДокументів", якщо контролюємо контрагента:
//==========================================
Функция ПроверитьВид()
    Если ПустоеЗначение(ТекущийДокумент) = 0 Тогда
        //Если ТекущийДокумент.ЗапретРедактирования = 1 Тогда
        //    Возврат "BRUSH["+глПолучитьЦвет(204,204,204)+"]";      //серый фон
        Если ((ТекущийДокумент.Контрагент.КонтрольДокументов = 1) И (ТекущийДокумент.Проверен = 1)) Тогда
            Возврат "FONT["+глПолучитьЦвет(0,0,0)+"] BRUSH["+глПолучитьЦвет(255,255,255)+"]"; //белый  фон
        ИначеЕсли ((ТекущийДокумент.Контрагент.КонтрольДокументов = 1) И (ТекущийДокумент.Проверен = 0)) Тогда
            Возврат "FONT["+глПолучитьЦвет(0,0,0)+"] BRUSH["+глПолучитьЦвет(255, 222, 179)+"]"; //красный  фон
        КонецЕсли;
    КонецЕсли;
    Возврат "";
КонецФункции
4andriy,
28.03.24, 8:52 список элементов без каталогов
4andriy @ Вчера, 17:45 * ,
Если Сотрудники.ЭтоГруппа() = 0 Тогда
       СписокЭлементов.ДобавитьЗначение(Сотрудники.ТекущийЭлемент());
КонецЕсли;
4andriy, takefive,
12.02.24, 20:01 Нумерация документов в зависимости от вида операции
kostya77 @ Сегодня, 18:21 * ,
Описать свой алгоритм. У меня например в 1с 7 была организована нумерация от номера склада.
kostya77,
12.02.24, 14:35 При нажатии на кнопку программно заполнить реквизит Формы
url_2l @ Сегодня, 14:31 * ,
Для "дякую" там є спеціальна кнопочка.
url_2l,
12.02.24, 13:42 При нажатии на кнопку программно заполнить реквизит Формы
url_2l @ Сегодня, 13:14 * ,
Доброго дня! Є такий приклад в моїй конфігурації. В документі списання на виробництво - при зміні реквизиту "підрозділ у шапці документу, заповнюємо підрозділ в рядках документу
    текОтвет = Вопрос("У документі змінено реквізит підрозділу. Заповнити підрозділ по рядкам документу?","Да+Нет");
    Если текОтвет = "Да" Тогда
        ВыбратьСтроки();
        Пока ПолучитьСтроку()=1 Цикл
            СтрУчасток = Подразделение;
        КонецЦикла;
    КонецЕсли;


//або ось так: якщо заповнено реквізит "разрешил" в документі "заказ", то ставимо "да" для "готов к получению"
    Если ПустоеЗначение(Разрешил)=0 Тогда
        ГотовКПолучению = Перечисление.ДаНет.Да;
    Иначе
        ГотовКПолучению = Перечисление.ДаНет.Нет;        
    КонецЕсли;
url_2l,
09.02.24, 13:48 Как в форму выбора справочника передать параметр?
kostya77 @ Сегодня, 12:08 * ,
https://pro1c.org.ua/index.php?showtopic=4042
andrew76, kostya77,
09.02.24, 13:20 Аптечний облік
barokko23 @ Сегодня, 10:52 * ,
Це не до мене! Відкрию Вам секрет,це не я викладав файл!!! Я Вам тільки сказав де взяти пароль

І мене все чудово вдалося розархівувати. Перевірти розкладку клавіатури. пароль вводимо на англ.розкладці клавіатури
barokko23,
08.02.24, 16:49 1Cv7.MD Неисправимая ошибка. Неправильный формат файла
andrew76 @ Сегодня, 16:08 * ,
а счета забалансового учета. Они есть даже в нашем плане счетов

Dmitrij19631025,
07.02.24, 13:24 Аптечний облік
barokko23 @ Сегодня, 11:38 * ,
пароль до архівів описаний в правилах форуму. Він однаковий для всіх архівів
barokko23,
06.02.24, 10:33 1Cv7.MD Неисправимая ошибка. Неправильный формат файла
Платформа 1с 7.70.027 должна у Вас быть. И попробуй из этого мд-файла в конфигураторе сделать: "загрузить измененную конфигурацию" в меню конфигурация - загрузить измененную конфигурацию. У Вас проблема для некоторых субконто (материалы и что-то еще) изменено "предсталение".

https://pro1c.org.ua/topic/1c-7-7-02770-70-...mp;p=29304&

https://pro1c.org.ua/index.php?showtopic=3953
Dmitrij19631025,
05.02.24, 20:03 1Cv7.MD Неисправимая ошибка. Неправильный формат файла
Dmitrij19631025 @ Вчера, 19:50 * ,
Цікаво, завтра гляну Вашу проблему
Dmitrij19631025,
04.02.24, 15:01 Загрузка курсов валют НБУ для 1с 7.7
ArinaBuhgalter @ Сегодня, 13:40 * ,
В правилах форуму є. Цей пароль, для всіх архівів один.
ArinaBuhgalter,
02.02.24, 10:49 УПП 1.3.82.1 какой релиз режима совместимости?
kserg2012 @ Вчера, 14:47 * ,
Доброго дня! Користувався платформою 1С:Предприятие 8.3.13.1513, потім ставив 8.3.16.1148. Все наче було стабільно на різних конфігураціях. Але ніколи "не ганявся" за плаформами, поставив - працює все, що мені треба і ОК,
kserg2012,
15.12.23, 10:51 Установка новой версии платформы 1С. Работоспособность базы.
Talkman @ Сегодня, 10:41 * ,
ну я наче не зустрічав проблем. Що можу сказати треба діяти! Тільки так зможете щось виявити.
Talkman,
06.12.23, 8:08 Создание нового элемента справочника
kostya77 @ Сегодня, 7:44 * ,
Доброго ранку! Через vpn відкрити посилання https://forum.infostart.ru/forum9/topic232203/

або тут https://forum.mista.ru/topic.php?id=749413, https://forum.mista.ru/topic.php?id=856738
kostya77,

6 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 20.06.24, 18:39
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!