Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




>  Выгрузка из Store house 5 в 1с общепит
Nikitaje
Отправлено: 24.02.21, 14:27


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


Цитата(29a @ 22.02.21, 17:04) *
кусок кода ни о чем, вырван из контекста...

Меня смущает строка

ПараметрыСоединения.СтрокаСоединения = "DRIVER={SQL Server};SERVER="+НРег(СерверRK)+";DATABASE="+БазаRK+";LANGUAGE=russian";

Но база не sql
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170996 · Ответов: 5 · Просмотров: 265
 

>  Выгрузка из Store house 5 в 1с общепит
Nikitaje
Отправлено: 22.02.21, 12:50


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


sava1 @ Сегодня, 13:24 * ,
Логин и пароль точно верны
В ручную это как ? Можете немного по продробнее?


 ! 

Правила: 1
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170935 · Ответов: 5 · Просмотров: 265
 

>  Выгрузка из Store house 5 в 1с общепит
Nikitaje
Отправлено: 22.02.21, 11:50


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


1С:Предприятие 8.3 (8.3.18.1334)

1С:Предприятие 8. Общепит КОРП (3.0.89.38) (https://solutions.1c.ru/catalog/public-catering-corp/features)
Copyright © ООО "1С-Софт", 2009 - 2021. Все права защищены
(http://www.1c.ru)

Всем привет друзья.
Нужно выгрузить данные о номенклатуре из SH5 в 1с Общепит.
Есть обработка встроенная.
Может кто уже делал подобное. Есть опыт. Потому что у Меня подключение не проходит.

Захожу в код вижу

Если ЭтоLinuxКлиент Тогда
            //Linux
            ПараметрыСоединения.СтрокаСоединения = "DRIVER={ODBC Driver 17 for SQL Server};SERVER="+НРег(СерверRK)+";DATABASE="+БазаRK+";LANGUAGE=russian";
        Иначе
            //Windows
            //ПараметрыСоединения.СтрокаСоединения = "DRIVER={SQL Server};SERVER="+НРег(СерверRK)+";DATABASE="+БазаRK+";LANGUAGE=русский";
            ПараметрыСоединения.СтрокаСоединения = "DRIVER={SQL Server};SERVER="+НРег(СерверRK)+";DATABASE="+БазаRK+";LANGUAGE=russian";
        КонецЕсли;
    Иначе
        ПараметрыСоединения.СтрокаСоединения = СтрокаСоединения;
    КонецЕсли;
    ПараметрыСоединения.СУБД = "MSSQLServer";





 ! 

Правила: 8
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170932 · Ответов: 5 · Просмотров: 265
 

>  Пауза на форме
Nikitaje
Отправлено: 22.02.21, 11:40


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


Цитата(logist @ 20.02.21, 3:43) *
p.s. Вы если не читаете или не воспринимаете, что вам пишут - сообщите как-то об этом, чтобы люди зря не напрягались.

Я просто не могу понять что не понятно.
Давайте по порядку.
форма при выполнении блокирует выполнение вообще каких либо операций. Все встало.
Пользователь говорит, надо сделать кнопку пауза. Чтобы можно было дальше работать.
Это возможо сделать?
И как лучше, придумывать что то с паузой или проще сделать все фоновым заданием
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170928 · Ответов: 22 · Просмотров: 637
 

>  Пауза на форме
Nikitaje
Отправлено: 20.02.21, 2:28


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


Цитата(fly @ 17.02.21, 15:15) *
можно сделать и паузу - только сущность в том, что паузу нужно сделать на чем то,

Паузу в форме нашей обработки.
ЧТобы было понятнее.
ЗАпустили обработку.
ЗАгрузка пошла, дальше вот хочется паузу сделать. Приостановить действия обработки. Действия пользователя Мне кажется не нуждаются в дополнении.
Пользователь захотел сделать паузу, хочет чтобы форма разблокировалась, он мог делать любые действия какие хочет. ФОрмировать отчеты, заполнять номенклатуру.
Паузу требуется сделать, чтобы форма разморозилась для выполнения других действий на платформе. Каких? Да разных. Это суть задачи не меняет никак
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170887 · Ответов: 22 · Просмотров: 637
 

>  Пауза на форме
Nikitaje
Отправлено: 15.02.21, 11:44


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


Цитата(fly @ 13.02.21, 12:33) *
"выпустить отчет" - тут как бы странно звучит, так как отчет "выпускается" = берет данные из БД и отображает на форме или в Табличный документ, или Таблицу и т.п.. Он служит для отображения данных в БД в удобном виде для анализа - своя классификация, группирока и т.п. Смысла его не выпускать как бы нет - ты или формируешь отчет или нет, и принимается решение до момента "выпустить".

Может быть неправильно выразился. Сформировать.
Цитата(fly @ 13.02.21, 12:33) *
ама задача ну явно не расскрыта - что приводит к правильностилюбого из выбранных вариантов.


Есть обработка, она считывается xml файлы, создает на основе этого докуметы записывается проводит.
Иногда это затягивается и выполняется долго, и нужна другая работа. Формировать отчеты, списывать что нибудь.
Пользователь попросил "Сделать паузу", создать кнопку по ней нажал все остановилось. Поработал, включил дальше
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170711 · Ответов: 22 · Просмотров: 637
 

>  Пауза на форме
Nikitaje
Отправлено: 13.02.21, 10:19


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


Цитата(logist @ 13.02.21, 5:34) *
У вас в топике написано - "пользователь увидел какую-то ошибку", теперь выясняется что надо делать что-то другое в базе, через пару дней узнаем еще какие-то подробности, которые в корне меняют суть проблему?

Да Я пидумываю действия. Пользователю нужна кнопка пауза.
Варианты действий зачем разные, заполнить что другое, выпустить отчет да что угодно.

Я правильно вас понимаю, сделать эту обработку как фоновую и не думать вообще об кнопках паузы?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170661 · Ответов: 22 · Просмотров: 637
 

>  Пауза на форме
Nikitaje
Отправлено: 13.02.21, 5:06


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


Цитата(logist @ 13.02.21, 0:04) *
Контроль чего? Заложите условия проверки в код, флажок "Останавливаться по ошибке", цикл, по ошибке останавливается, далее кнопка продолжить. Предварительно загружаете файл в таблицу, чтобы понимать какие строки уже обработались.
Если пользователь хочет в процессе что-то визуально контролировать, то это утопия, для таких случаев создают визуальную таблицу куда всё грузят, пользователь просматривает и потом выполняется загрузка данных.

Что делать в случае, что документов много и они грузяться замораживая. Форма замерзла а нужно выполнить какие то работы?
Как быть в этом случае.
Операция длиться 15 минут, после 5 минут выполнения к пользователю пришли сказали нужно кое что сделать.
А операция как необратимая термоядерная реакция уже идет.
Я бы хотел внедрить что нибудь, что могло приостановить выполнение.
Ну как на C#. При копировании можно поставить паузу, и код запуститься с того момета где Я поставил паузу
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170658 · Ответов: 22 · Просмотров: 637
 

>  Пауза на форме
Nikitaje
Отправлено: 12.02.21, 23:12


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


logist @ Сегодня, 17:01 * ,
Пользователю нужен контроль при выполнении.
Есть ли варианты вообще как можно поставить на паузу или нет?
Я пока такого не встречал, вот и хотелось понять и уточнить
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170640 · Ответов: 22 · Просмотров: 637
 

>  Пауза на форме
Nikitaje
Отправлено: 12.02.21, 16:45


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


logist @ Сегодня, 16:18 * ,
Хорошо отошли от фонового задания.
Внешняя обработка, выполняет какой то код. Пошли писать документы.
На десятом документе пользователь хочет нажать паузу и сделать другие документы.
Но форма уже замерзла, Я не могу в ней нажимать

Или это задача не решается?

Задача,
есть обработка она выполняет код. Пишет документы из xml.
Пока пишет все вкладки встали, пришел клиент говорит Мне надо что то там сделать. Вкладки уже все в заморозке сделать ничего нельзя, можно вызвать прирывания пользователя, но нужно начать с того места где Мы остановились

Nikitaje @ Сегодня, 16:37 * ,
Обработка
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170638 · Ответов: 22 · Просмотров: 637
 

>  Пауза на форме
Nikitaje
Отправлено: 12.02.21, 15:05


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


sava1 @ Сегодня, 14:37 * ,
Идет перебор XML, на основании их пишеться документ.
Я хочу добавить кнопку "Пауза"
Паузу поставил кое что сделал. Продолжил. Идет дальше перебор

Вот только что пришла в голову идея.

Добавляем кнопку пауза.

В цикле когда все пишеться добавляем условие, проверяет нажатие нопки пауза, при нажатии кнопки пауза флаг ставиться истина его и проверяем.
еще цикл - ресурсозатрадо но для развития мысли пойдет.
это бессконечный цикл который проверфяет стоит флаг истина или нет. Но тогда форма замерзнет.
Делать еще фоновое задание с бессконечным циклом. А есловия выхода ну, придумать осталось


Nikitaje @ Сегодня, 14:41 * ,

Придумал. Поправте если не так.
Создаем реквизит формы булево
Создаем кнопку на форме пауза.
Кнопка нажата истина нажата повторно ложь

Фоновое задание началось.
Длительный цикл

Начало

код

условие если кнопка нажата
бессконечный цикл
начало
условие проверки этого реквизита если ложь тогда заканчиваем цикл идем дальше по коду.

Конец

код

конец


Как считаете, нормально или можно сднлать по лучше?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170634 · Ответов: 22 · Просмотров: 637
 

>  Пауза на форме
Nikitaje
Отправлено: 12.02.21, 14:30


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


Всем привет друзья. Конфа самописная. Управляемые формы 8.3
Выполняется фоновое задание, процесс идет польователь работает. при ходи выполнение пишуться документы.
Пользователь увидел ошибку, и хочет приостановить задание сделать ручные дейтвия и возобновить с момента остановки.
Скажите пожалуйста это возможно вообще?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #170632 · Ответов: 22 · Просмотров: 637
 

>  Не заходит в процедуру созданую в модуле формы
Nikitaje
Отправлено: 17.12.20, 1:44


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


TohaMonster @ Вчера, 14:16 * ,
То есть всегда будет работать одна процедура?
ЗАчем тогда и в модуле формы и в модуле объекта по одинаковой?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #169145 · Ответов: 6 · Просмотров: 309
 

>  Не заходит в процедуру созданую в модуле формы
Nikitaje
Отправлено: 16.12.20, 9:42


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


DartRomanius @ Сегодня, 10:33 * ,
Да конечно. Даже пересоздавал
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #169114 · Ответов: 6 · Просмотров: 309
 

>  Не заходит в процедуру созданую в модуле формы
Nikitaje
Отправлено: 16.12.20, 9:29


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


Здравствуйте друзья. 1с 8.3 обычные формы.
На форме создаю процедуру

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
            // Вставить содержимое обработчика.
    //Оповестить("ОбработкаОповещения",Вагоны,ЭтаФОрма);
    Сообщить(123);
    Если (ЭтаФорма.ТолькоПросмотр=Истина) Тогда
          Отказ=Истина;
          Предупреждение("Документ только для ПРОСМОТРА!!!  Запись отменена");
    КонецЕсли;

КонецПроцедуры

Записать(РежимЗаписиДокумента.Запись);


Ставлю точку останова не заходит.
В модуле есть точно такая же процедура, в нее заходит код выполняется. В чем может быть причина?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #169112 · Ответов: 6 · Просмотров: 309
 

>  Очистка кэша 1С из 1С
Nikitaje
Отправлено: 14.10.20, 4:04


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


Vofka @ 19.07.13, 15:55 * ,
Добавлю от себя еще проще.
Процедура Кнопка1Нажатие(Элемент)
    файл = Новый ТекстовыйДокумент;
    scr = КаталогВременныхФайлов()+"clear1c.ps1";
    файл.УстановитьТекст("echo 'Подготовка к запуску, дождитесь окончания работы этого скрипта.'
    |timeout.exe /T 4 /NOBREAK
    |echo 'Не запускайте 1С.'
    |Get-childitem -Path $ENV:Userprofile\appdata\Roaming\1c\1cv8*\* -Exclude *.pfl,def.usr,tmplts | Remove-item -recurse
    |Get-childitem -Path $ENV:Userprofile\appdata\Local\1c\1cv8*\* -Exclude *.pfl,tmplts | Remove-item -recurse
    |echo 'КОНЕЦ!'
    |echo 'Если не пробегало красное, значит все нормально. Можно запускать 1С.'
    |timeout.exe /T 5 /NOBREAK");
    файл.Записать(scr,КодировкаТекста.Системная);
    Сообщить(scr);
    ЗапуститьПриложение("powershell -executionpolicy unrestricted -command "+scr,,Ложь);
    ПрекратитьРаботуСистемы(Ложь, "/ClearCache");
    
КонецПроцедуры

  Форум: 1С:Предприятие 8.2 · Просмотр сообщения: #167342 · Ответов: 1 · Просмотров: 6387
 

>  Загрузка в базу PDF
Nikitaje
Отправлено: 04.08.20, 7:59


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


Здравствуйте Друзья.
Конфигурация самописная с нуля, 8.3, обычные формы
Хочу записывать файлы ПДФ в 1с.
Создал Справочник с реквизитом "ФайлПДФ" тип ХранилищеЗначений.

Попытка
        ДиалогФыбораФайла                             = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
        ДиалогФыбораФайла.Заголовок                   = "Выберите файл";                                        
        ДиалогФыбораФайла.ПредварительныйПросмотр     = Истина;
        Если ДиалогФыбораФайла.Выбрать() Тогда
            ИмяФайла         = СтрЗаменить(ДиалогФыбораФайла.ПолноеИмяФайла,ДиалогФыбораФайла.Каталог,"");
            ОписаниеФайла     = ИмяФайла;
            РасширениеФайла = Прав(ИмяФайла,СтрДлина(ИмяФайла)-Найти(ИмяФайла,"."));            
            АдресВХранилище = ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(ДиалогФыбораФайла.ПолноеИмяФайла));
            //Если бы нужно было сохранить именно в реквизит базы с типом хранилище значений тогда нужно писать
            ФайлПДФ = Новый ХранилищеЗначения(Новый ДвоичныеДанные(ДиалогФыбораФайла.ПолноеИмяФайла));
            Файл = ОписаниеФайла;
            
            
            //МойФайл = Новый ДвоичныеДанные(ДиалогФыбораФайла.ПолноеИмяФайла);
            //ФайлПДФ = Новый ХранилищеЗначения(МойФайл);
        КонецЕсли;
        ОбновитьИнтерфейс();
    Исключение
        ПоказатьОповещениеПользователя("Файл не записан!");        
    КонецПопытки;

Попытка поместить туда. Не знаю на сколько верно но вроде все как по учебнику.
Дальше Мне нужно прочитать что там есть. Заархивировать. Ну а дальше делать что в голову придет.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165309 · Ответов: 1 · Просмотров: 321
 

>  Расшифровка поля отчета другим отчетом обычные формы
Nikitaje
Отправлено: 17.06.20, 9:27


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


sava1 @ 15.06.20, 11:16 * ,
Да действительно вы были правы
  Форум: Система компоновки данных · Просмотр сообщения: #163949 · Ответов: 12 · Просмотров: 552
 

>  Расшифровка поля отчета другим отчетом обычные формы
Nikitaje
Отправлено: 15.06.20, 7:48


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


sava1 @ Сегодня, 7:47 * ,
Используется ниже
РасшифровкаМакетКомпоновки = РасшифровкаКомпоновщикМакета.Выполнить(РасшифровкаСхемаКомпоновкиДанных, РасшифровкаНастройки, РасшифровкаДанныеРасшифровки, МакетОформленияКомпоновкиДанных);
  Форум: Система компоновки данных · Просмотр сообщения: #163869 · Ответов: 12 · Просмотров: 552
 

>  Расшифровка поля отчета другим отчетом обычные формы
Nikitaje
Отправлено: 15.06.20, 2:45


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


Nikitaje @ Сегодня, 2:38 * ,
Процедура ДобавитьЗначениеПараметраРасшифровки(Параметр, Значение)
    
    Для Каждого ЭлементПараметр из РасшифровкаСхемаКомпоновкиДанных.Параметры Цикл
        Если ЭлементПараметр.Имя = Параметр Тогда
            ЭлементПараметр.Значение = Значение;
        КонецЕсли;
    КонецЦикла;    

КонецПроцедуры
  Форум: Система компоновки данных · Просмотр сообщения: #163867 · Ответов: 12 · Просмотров: 552
 

>  Расшифровка поля отчета другим отчетом обычные формы
Nikitaje
Отправлено: 15.06.20, 1:38


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


sava1 @ 12.06.20, 12:29 * ,

1)в модуле формы расшифровке отчета.


https://drive.google.com/file/d/1L7VZ72oncB...iew?usp=sharing
  Форум: Система компоновки данных · Просмотр сообщения: #163866 · Ответов: 12 · Просмотров: 552
 

>  Расшифровка поля отчета другим отчетом обычные формы
Nikitaje
Отправлено: 12.06.20, 2:39


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


Vofka @ Вчера, 10:00 * ,
Реквизиты на форме ну и параметры в запросе также завутся
  Форум: Система компоновки данных · Просмотр сообщения: #163803 · Ответов: 12 · Просмотров: 552
 

>  Расшифровка поля отчета другим отчетом обычные формы
Nikitaje
Отправлено: 11.06.20, 8:55


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


Vofka @ Сегодня, 8:31 * ,
Интересно конечно. Но Суть в том что Мне надо с одной формы взять вагон + даты и передать в другую ну а там запустить отчет.
  Форум: Система компоновки данных · Просмотр сообщения: #163765 · Ответов: 12 · Просмотров: 552
 

>  Расшифровка поля отчета другим отчетом обычные формы
Nikitaje
Отправлено: 11.06.20, 6:26


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


Всем привет друзья. Сталкнулся с проблемой и не могу понять как сделать правильно.
Предприятие 1С:Предприятие 8.3 (8.3.16.1063). Конфигурация самописная с нуля
Задача:
Сделать расшифровку поля другим отчетом, запрос такой же лишь Меняются параметры. Пользуясь гуглом и собирая код из разных частей сделал так
Приведу код ниже.
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
    
    Поле = ДанныеРасшифровки.Элементы[Расшифровка].ПолучитьПоля()[0];
    ТипРасшифровки = Поле.Поле;
    
    Если ТипРасшифровки = "Вагон" Тогда
        
        //ОчиститьСообщения();
        
        СтандартнаяОбработка = Ложь;
        СтруктураРасшифровки = Новый Структура;

        //Значения всех вышестоящих группировок        
        ВывестиЗначениеГруппировки(Расшифровка, СтруктураРасшифровки);
        
        ФормаРасшифровки = ПолучитьФорму("ФормаРасшифровки");
        ФормаРасшифровки.Открыть();
        ФормаРасшифровки.СформироватьОтчетРасшифровки("СхемаКомпоновкиДанныхРасшифровки",
            СтруктураРасшифровки,
            "Расшифровка ячейки """ + ТипРасшифровки + """");
        
    ИначеЕсли ТипРасшифровки = "Справочник" Тогда
        
        СтандартнаяОбработка = Ложь;
        ОткрытьЗначение(Поле.Значение);

    КонецЕсли;


Вывод отчета

Процедура СформироватьОтчетРасшифровки(ИмяМакета, СтруктураРасшифровки, Заголовок = "Расшифровка ячейки") Экспорт  
    
    Результат = ЭлементыФормы.Результат;
    Результат.Очистить();
    
    РасшифровкаСхемаКомпоновкиДанных = ПолучитьМакет(ИмяМакета);
    
    //Отборы
    Для Каждого Значение ИЗ СтруктураРасшифровки Цикл
        ДобавитьЗначениеОтбораРасшифровки(Значение.Ключ, Значение.Значение, , ВидСравненияКомпоновкиДанных.ВИерархии);
    КонецЦикла;
    
    //Параметры
    ДобавитьЗначениеПараметраРасшифровки("НачалоПериода",НачалоДня(НачалоПериода));
    ДобавитьЗначениеПараметраРасшифровки("КонецПериода",КонецДня(КонецПериода));
    
    //Заголовок
    ДобавитьЗначениеПараметраВыводаРасшифровки("Заголовок",Заголовок);
    
    //Получаем оформление из макета
    МакетОформленияКомпоновкиДанных = ПолучитьМакет("МакетОформленияКомпоновкиДанныхПесок");
    
    РасшифровкаДанныеРасшифровки = Новый ДанныеРасшифровкиКомпоновкиДанных;
    РасшифровкаНастройки = РасшифровкаСхемаКомпоновкиДанных.НастройкиПоУмолчанию;
    
    РасшифровкаКомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
    РасшифровкаМакетКомпоновки = РасшифровкаКомпоновщикМакета.Выполнить(РасшифровкаСхемаКомпоновкиДанных, РасшифровкаНастройки, РасшифровкаДанныеРасшифровки, МакетОформленияКомпоновкиДанных);

    РасшифровкаПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
    РасшифровкаПроцессорКомпоновкиДанных.Инициализировать(РасшифровкаМакетКомпоновки, , РасшифровкаДанныеРасшифровки);

    РасшифровкаПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    РасшифровкаПроцессорВывода.УстановитьДокумент(Результат);
    РасшифровкаПроцессорВывода.Вывести(РасшифровкаПроцессорКомпоновкиДанных);
    
    Результат.Защита = Истина;
    
КонецПроцедуры

Ошибка
Цитата
Ошибка получения данных
по причине:
Ошибка создания набора данных "НаборДанных1"
по причине:
Ошибка при исполнении запроса набора данных
по причине:
{(15, 55)}: Не задано значение параметра "КонецПериода"
ЖДНакладнаяВагоны.Ссылка.Д ата МЕЖДУ &НачалоПериода И <<?>>&КонецПериода

Может кто делал подобное на обычных формах и может поделиться опытом?
В расшифровку должны попасть 3 параметра, НАчало и конец даты + номер вагона по которому делается расшифровка
Форма отчета и макет компановки данных для расшифровски создан отдельно
  Форум: Система компоновки данных · Просмотр сообщения: #163762 · Ответов: 12 · Просмотров: 552
 

>  Не отображается счет
Nikitaje
Отправлено: 08.12.16, 5:06


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 08.12.16
Пользователь №: 53150


Выполняю сборку отчета. Хочу чтобы отображался счет Кт. Со связью получилось , отображается. А вот с удержаниеям по исполнительному листу. Задаю счет на дополнительных данных физ.лица, через свойства. Но в конечном итоге он все ровно пустой. Ниже код функции и скриншоты для наглядности.





Функция СоздатьСтрокуПромежуточнойТаблицы
Функция СоздатьСтрокуПромежуточнойТаблицы(ДанныеУчета, ПромежуточнаяТаблица, ПустойСчет, ПодразделениеФизлица = Неопределено)

    СтрокаДанных = ПромежуточнаяТаблица.Добавить();
//Добавлено СС

    СтрокаДанных.ВидРасчета    =  ДанныеУчета.ВидРасчета;
//КонецДобавлено

//Добавлено Ва.
    Если  СтрокаДанных.ВидРасчета.Наименование = "Удержания за сотовую связь сверхлимита" или СтрокаДанных.ВидРасчета.Наименование = "Удержания за междугородние разговоры" Тогда
        ЛицСчета = РегистрыСведений.ЗначенияСвойствОбъектов.СоздатьНаборЗаписей();
        ЛицСчета.Отбор.Объект.Установить(ДанныеУчета.ФизЛицо);
        
        //ЛицСчета.Отбор.Свойство.Установить(ПланыВидовХарактеристик.СвойстваОбъектов.УдержИспЛисты);

        ЛицСчета.Отбор.Свойство.Установить(ПланыВидовХарактеристик.СвойстваОбъектов.УдержЗаСотовСвязьСверхЛимита);
        ЛицСчета.Прочитать();
        Если ЛицСчета.Количество()=0 Тогда
            Сообщить("У сотрудника: "+ДанныеУчета.ФизЛицо+" не указан лицевой счет удержания за сотовую связь!");
        //    Сообщить("У сотрудника: "+ДанныеУчета.ФизЛицо+" не указан лицевой счет удержания по исп. листу!");
        Иначе
            СчетКредитаСотр = ЛицСчета[0].Значение;
        КонецЕсли;
        
        
    ИначеЕсли СтрокаДанных.ВидРасчета.Наименование = "Удержания по исполнительным листам сотрудников" тогда //или СтрокаДанных.ВидРасчета.Наименование = "Удержания по исполнительным листам сотрудников" Тогда
        ЛицСчета = РегистрыСведений.ЗначенияСвойствОбъектов.СоздатьНаборЗаписей();
        ЛицСчета.Отбор.Объект.Установить(ДанныеУчета.ФизЛицо);
        ЛицСчета.Отбор.Свойство.Установить(ПланыВидовХарактеристик.СвойстваОбъектов.УдержИспЛисты);
        //ЛицСчета.Отбор.Свойство.Установить(ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоКоду("0011"));
        ЛицСчета.Прочитать();
        Если ЛицСчета.Количество()=0 Тогда
            Сообщить("У сотрудника: "+ДанныеУчета.ФизЛицо+" не указан лицевой счет удержания по исп. листу!");
        Иначе
            СчетКредитаСотр = ЛицСчета[0].Значение;
        КонецЕсли;
    КонецЕсли;    
//КонецДобавлено
    СтрокаДанных.СчетДт            = ДанныеУчета.СчетДт;
    
//Добавлено Ва.
    Если  СтрокаДанных.ВидРасчета.Наименование = "Удержания за сотовую связь сверхлимита" или СтрокаДанных.ВидРасчета.Наименование = "Удержания за междугородние разговоры" или СтрокаДанных.ВидРасчета.Наименование = "Удержания по исполнительным листам сотрудников" Тогда
        СтрокаДанных.СчетКт        = СчетКредитаСотр;
    Иначе        
        СтрокаДанных.СчетКт        = ДанныеУчета.СчетКт;
    КонецЕсли;    
//Добавлено Ва.

    СтрокаДанных.СубконтоДт1    = ДанныеУчета.СубконтоДт1;
    СтрокаДанных.СубконтоДт2    = ДанныеУчета.СубконтоДт2;
    СтрокаДанных.СубконтоДт3    = ДанныеУчета.СубконтоДт3;
    СтрокаДанных.СубконтоКт1    = ДанныеУчета.СубконтоКт1;
    СтрокаДанных.СубконтоКт2    = ДанныеУчета.СубконтоКт2;
    СтрокаДанных.СубконтоКт3    = ДанныеУчета.СубконтоКт3;
    
    СтрокаДанных.Сумма            = ДанныеУчета.Результат;
    
    Если мЗаполнятьДанныеНУ Тогда
        Если мЗаполнятьСчетаНУ Тогда
            СтрокаДанных.СчетДтНУ        = ДанныеУчета.СчетДтНУ;
            СтрокаДанных.СчетКтНУ        = ДанныеУчета.СчетКтНУ;
            СтрокаДанных.СубконтоДтНУ1    = ДанныеУчета.СубконтоДтНУ1;
            СтрокаДанных.СубконтоДтНУ2    = ДанныеУчета.СубконтоДтНУ2;
            СтрокаДанных.СубконтоДтНУ3    = ДанныеУчета.СубконтоДтНУ3;
            СтрокаДанных.СубконтоКтНУ1    = ДанныеУчета.СубконтоКтНУ1;
            СтрокаДанных.СубконтоКтНУ2    = ДанныеУчета.СубконтоКтНУ2;
            СтрокаДанных.СубконтоКтНУ3    = ДанныеУчета.СубконтоКтНУ3;
        Иначе
            СтрокаДанных.СуммаНУ = СтрокаДанных.Сумма;
        КонецЕсли;
    КонецЕсли;
    
    СтрокаДанных.ОтражениеВУСН    = ДанныеУчета.ОтражениеВУСН;    
    
    Если мИП_ОСН Тогда
        СтрокаДанных.ВидНачисленияУдержания = ДанныеУчета.ИПВидНачисленияУдержания;    
    КонецЕсли;
    
    // выполним автозаполнение субконто если это предусмотрено способом отражения в бухучете
    Если ДанныеУчета.СчетДт <> ПустойСчет Тогда
        Если ДанныеУчета.НомерСубконтоРаботникиДт <> 0
            И НЕ ЗначениеЗаполнено(ДанныеУчета["СубконтоДт" + ДанныеУчета.НомерСубконтоРаботникиДт]) Тогда
            СтрокаДанных["СубконтоДт" + ДанныеУчета.НомерСубконтоРаботникиДт] = ДанныеУчета.Физлицо;
        КонецЕсли;
    КонецЕсли;
    Если ДанныеУчета.СчетКт <> ПустойСчет Тогда
        Если ДанныеУчета.НомерСубконтоРаботникиКт <> 0
            И НЕ ЗначениеЗаполнено(ДанныеУчета["СубконтоКт" + ДанныеУчета.НомерСубконтоРаботникиКт]) Тогда
            СтрокаДанных["СубконтоКт" + ДанныеУчета.НомерСубконтоРаботникиКт] = ДанныеУчета.Физлицо;
        КонецЕсли;
        Если ДанныеУчета.НомерСубконтоКонтрагентыКт <> 0
            И НЕ ЗначениеЗаполнено(ДанныеУчета["СубконтоКт" + ДанныеУчета.НомерСубконтоКонтрагентыКт]) Тогда
            СтрокаДанных["СубконтоКт" + ДанныеУчета.НомерСубконтоКонтрагентыКт] = ДанныеУчета.Контрагент;
        КонецЕсли;
        Если ДанныеУчета.НомерСубконтоПодразделениеКт <> 0
            И НЕ ЗначениеЗаполнено(ДанныеУчета["СубконтоКт" + ДанныеУчета.НомерСубконтоПодразделениеКт]) и ПодразделениеФизлица <> Неопределено Тогда
            СтрокаДанных["СубконтоКт" + ДанныеУчета.НомерСубконтоПодразделениеКт] = ПодразделениеФизлица;
        КонецЕсли;
    КонецЕсли;
      
    Возврат СтрокаДанных;
КонецФункции // СоздатьСтрокуПромежуточнойТаблицы



1С:Предприятие 8.2 (8.2.19.130)
Зарплата и Управление Персоналом, редакция 2.5 (2.5.108.1)
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #120322 · Ответов: 0 · Просмотров: 931
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 13.06.21, 14:13
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!