Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



36 страниц V   1 2 3 > » 

>  Создание связи товаров в справочнике
5_kopeek
Отправлено: 09.06.15, 10:55


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Да, действительно, упустила этот момент.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #99826 · Ответов: 46 · Просмотров: 6325
 

>  Создание связи товаров в справочнике
5_kopeek
Отправлено: 09.06.15, 10:52


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Можно сделать для элементов справочника Товары реквизит с таким же типом, в котором хранить ссылку на основной товар. Установить для реквизита признак отбор и сортировка и потом легко и быстро можно получать сопутствующие товары. Такой подход обеспечивает минимальное вмешательство в структуру метаданных.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #99824 · Ответов: 46 · Просмотров: 6325
 

>  Ошибки на форуме
5_kopeek
Отправлено: 18.05.12, 9:43


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Думаю, проблема в слишком длинной строчке кода -- такие лучше разбивать на несколько строк. Попробуйте ползунок переместить в самое крайнее правое положение. Возможно, будет сюрпрайз smile.gif
  Форум: http://pro1c.org.ua/ · Просмотр сообщения: #50402 · Ответов: 166 · Просмотров: 50853
 

>  Снятие с резерва. Не работает
5_kopeek
Отправлено: 02.05.12, 21:37


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Текст ошибки тот же? Тогда проверяйте, что передается в переменную НачДата. Если не умеете пользоваться отладчиком, можете перед строкой, в которой возникает ошибка добавить:
Сообщить("НачДата = "+НачДата+" Тип /"+ТипЗначенияСтр(НачДата)+"/");

И скажите, что напишет.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #49546 · Ответов: 18 · Просмотров: 7082
 

>  Снятие с резерва. Не работает
5_kopeek
Отправлено: 02.05.12, 19:29


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Напишите так:
ПрошлоДней=Число(НачДата-Дата('03.01.1994'));
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #49544 · Ответов: 18 · Просмотров: 7082
 

>  Перенос данных при нажатии "ок"
5_kopeek
Отправлено: 02.05.12, 19:26


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Так и не поняла, Вам нужно перенести только итог по колонке вес или значения веса во всех строках? Если только итог, тогда зачем передавать в качестве параметра всю табличную часть? Передавайте только Итог("Вес"). И совсем не обязательно открывать форму в модальном режиме, просто открывайте через ОткрытьФорму().
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #49543 · Ответов: 36 · Просмотров: 10915
 

>  Перенос данных при нажатии "ок"
5_kopeek
Отправлено: 01.05.12, 10:19


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Цитата(ZhenyaYa @ 30.04.12, 22:47) *
а у "вес" в многострочной части или в шапке документа? у меня в многострочной части, может в этом дело?

Если Вам нужно заполнить реквизит в многострочной части документа, то перед присваиванием значения нужно спозиционироваться на той строке документа, в которой необходимо установить полученное через параметр значение.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #49501 · Ответов: 36 · Просмотров: 10915
 

>  Отчет по Накл в разрезе оплат
5_kopeek
Отправлено: 17.04.12, 21:59


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Перем Док;

//*********************************************************************
Функция ПолучитьОплату(ТекДок)
    ПодчиненныеДокументы = "";
    Док.ВыбратьПодчиненныеДокументы(,,ТекДок);
    Пока Док.ПолучитьДокумент()=1 Цикл
        Если (Док.Вид() <> "ПриходныйКассовый") Тогда
            Продолжить;
        КонецЕсли; // (Док.Вид() неравно "ПКО")
        ПодчиненныеДокументы=ПодчиненныеДокументы+Док.ДатаДок+", "+Док.СуммаСНДС+"; ";
    КонецЦикла;
    Возврат ПодчиненныеДокументы;
КонецФункции //ПолучитьОплату

//*********************************************************************
// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |РасходнаяРеализатора = Документ.РасходнаяРеализатора.ТекущийДокумент;
    |Контрагент = Документ.РасходнаяРеализатора.Контрагент;
    |СуммаСНДС = Документ.РасходнаяРеализатора.СуммаСНДС;
    |Оплачено = Документ.РасходнаяРеализатора.Оплачено;
    |Функция Сумма = Сумма(СуммаСНДС);
    |Функция РасходнаяРеализатораОплаченоСумма = Сумма(РасходнаяРеализатора.Оплачено);
    |Группировка РасходнаяРеализатора упорядочить по РасходнаяРеализатора.Контрагент, РасходнаяРеализатора.ДатаДок, РасходнаяРеализатора.НомерДок, РасходнаяРеализатора.Оплачено, РасходнаяРеализатора.ДолгПоНакл, РасходнаяРеализатора.Город, РасходнаяРеализатора.Улица все ВошедшиеВЗапрос;
    |Условие(Контрагент в ВыбКонтрагент);
    |"//}}ЗАПРОС
;
    
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
    
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Док=СоздатьОбъект("Документ");
    Пока Запрос.Группировка(1) = 1 Цикл
        // Заполнение полей РасходнаяРеализатора
        ТекДок=Запрос.РасходнаяРеализатора;
        ПодчиненныеДокументы=ПолучитьОплату(ТекДок);
        Таб.ВывестиСекцию("РасходнаяРеализатора");
    КонецЦикла;
    // Заполнение полей "Итого"
    Таб.ВывестиСекцию("Итого");
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #48783 · Ответов: 10 · Просмотров: 3601
 

>  Как изменить макет документа
5_kopeek
Отправлено: 17.04.12, 12:45


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Цитата(Ziam @ 17.04.12, 11:51) *
Меньше проблем потом при обновлениях.

А для 8.1 до сих пор выпускаются обновления?
  Форум: Программирование в 1С Предприятие 8.1 (8.0) · Просмотр сообщения: #48733 · Ответов: 5 · Просмотров: 4914
 

>  Письмо АББИИ №57 от 28/02
5_kopeek
Отправлено: 12.04.12, 16:32


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Цитата(mister-x @ 12.04.12, 17:05) *
так, це "намек" щодо переходу на 8-ку

А у 8-ці все гаразд із новими звітами, взагалі без нюансів?
  Форум: Платформа 7.7 · Просмотр сообщения: #48559 · Ответов: 119 · Просмотров: 34512
 

>  Письмо АББИИ №57 от 28/02
5_kopeek
Отправлено: 12.04.12, 14:44


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Цитата(-=VJ=- @ 12.04.12, 15:26) *
Они и так за деньги были - ИТС нужен был.

Для тех, кто купил программу до 01.07.08 обновления были без покупки ИТС, т.е. бесплатны. А теперь будут платны для всех.
  Форум: Платформа 7.7 · Просмотр сообщения: #48545 · Ответов: 119 · Просмотров: 34512
 

>  Письмо АББИИ №57 от 28/02
5_kopeek
Отправлено: 12.04.12, 10:49


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Будет, но за деньги.
  Форум: Платформа 7.7 · Просмотр сообщения: #48520 · Ответов: 119 · Просмотров: 34512
 

>  Flexy, с днюхой!
5_kopeek
Отправлено: 09.04.12, 14:01


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Поздравляю! Побольше кайфа от жизни и денег от работодателей! 07000000.gif
  Форум: Офф-топик · Просмотр сообщения: #48291 · Ответов: 12 · Просмотров: 4226
 

>  Внесение кетамина в список особо опасных психотропных веществ приостановлено
5_kopeek
Отправлено: 09.04.12, 0:38


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Цитата(Pepe @ 08.04.12, 14:23) *
еще многое другое, способное принести вред человеку.

Например, рождение.
  Форум: Бухгалтерский учет, налоги, последние изменения... · Просмотр сообщения: #48260 · Ответов: 17 · Просмотров: 5108
 

>  Внесение кетамина в список особо опасных психотропных веществ приостановлено
5_kopeek
Отправлено: 07.04.12, 17:47


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Цитата(Pepe @ 07.04.12, 18:23) *
И бедным зверюшкам которых резали без наркоза...

... жлобы-ветеринары с садистскими наклонностями, которым было лень вести официальный учет этого препарата.
  Форум: Бухгалтерский учет, налоги, последние изменения... · Просмотр сообщения: #48218 · Ответов: 17 · Просмотров: 5108
 

>  Опять новая декларация по НДС!?!
5_kopeek
Отправлено: 06.04.12, 14:41


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Цитата(Andrij-ko @ 06.04.12, 15:15) *
Нова форма діє з квітня, тобто за березень по новій формі.

Вы правы. Беру свои слова обратно. В заблуждение ввели аудиторы, которые вчера проводили семинар. Уточнение информации в налоговой: за март нужна новая декларация.
  Форум: Бухгалтерский учет, налоги, последние изменения... · Просмотр сообщения: #48180 · Ответов: 16 · Просмотров: 8615
 

>  Опять новая декларация по НДС!?!
5_kopeek
Отправлено: 06.04.12, 13:30


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


За март по старой.
  Форум: Бухгалтерский учет, налоги, последние изменения... · Просмотр сообщения: #48177 · Ответов: 16 · Просмотров: 8615
 

>  добавление нового элемента
5_kopeek
Отправлено: 06.04.12, 3:18


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


С длиной строки и длиной кода все в порядке? Не вводите в новыкод никаких знаков препинания и служебных символов?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #48154 · Ответов: 8 · Просмотров: 4964
 

>  форма журнала документа
5_kopeek
Отправлено: 06.04.12, 2:41


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


док -- это номер? И дату указывать необходимо. И вид документа нужно задавать "ПриходнаяНакладная" или создавать объект определенного вида:
докус = СоздатьОбъект("Документ.ПриходнаяНакладная");

И прекращайте использовать одинаковые имена для переменных и функций.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #48153 · Ответов: 2 · Просмотров: 1612
 

>  Не обнаружено работников, по которым еще не вводились данные об индивидуальном графике!
5_kopeek
Отправлено: 04.04.12, 15:55


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Так, может, табель уже создан и заполнен?
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #48048 · Ответов: 6 · Просмотров: 9851
 

>  Куда уезжают 1с-ники.
5_kopeek
Отправлено: 04.04.12, 14:29


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Цитата(Ardi @ 04.04.12, 12:54) *
В Польшу - 1 штука.
В Арабские эмираты - 1 штука.
В Донецк - 1 штука.
В Россию и обратно в Украину - 1 штука.
На кладбище - 2 штуки.

Шансы попасть не на кладбище 2:3. Не так уж плохо.
  Форум: Офф-топик · Просмотр сообщения: #48038 · Ответов: 8 · Просмотров: 3149
 

>  бухгалтеские итоги в режиме запроса
5_kopeek
Отправлено: 03.04.12, 12:18


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


                
Если глИТост.ПолучитьСубконто(1,,ТекущийЭлемент()) = 1 Тогда
    Ост = глИТост.СКД("К");
КонецЕсли;
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #47978 · Ответов: 8 · Просмотров: 2924
 

>  World1С, с днюхой!
5_kopeek
Отправлено: 03.04.12, 10:40


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


С юбилеем! 07000000.gif
  Форум: Офф-топик · Просмотр сообщения: #47966 · Ответов: 7 · Просмотров: 2303
 

>  форма списка справочника
5_kopeek
Отправлено: 02.04.12, 11:11


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Цитата(uanr81 @ 01.04.12, 21:39) *
Подскажите , каким способом убирается на форме списка справочника при интерактивном выборе группы, реквизиты элемента справочника не относящиеся к группе??? Спасибо

Сделайте отдельную форму списка для выбора групп, в которой оставьте только нужные реквизиты. И используйте ее при выборе групп.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #47897 · Ответов: 5 · Просмотров: 2857
 

>  31 марта наступит апокалипсис всемирной паутины.
5_kopeek
Отправлено: 31.03.12, 1:02


Ветеран
*******

Группа: Пользователи*
Сообщений: 940
Регистрация: 11.02.11
Пользователь №: 7274


Хм. Пока не наступил.
  Форум: Офф-топик · Просмотр сообщения: #47824 · Ответов: 6 · Просмотров: 2584
 

36 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 27.01.20, 2:59
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!