Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Возврат параметра при закрытии формы          
AnryMc Подменю пользователя
сообщение 11.04.24, 10:07
Сообщение #1

Оратор
Иконка группы
Группа: Местный
Сообщений: 362
Спасибо сказали: 99 раз
Рейтинг: 100.6

Капитально туплю сегодня - помогите!!!

Форма Обработки 1
Программно открывается Обработка 2
&НаКлиенте
    
    ПараметрыФормы = Новый Структура("", "");
    
    ОписаниеОповещения = Новый ОписаниеОповещения("ЗакрытаФормаОбработки2", ЭтотОбъект, ПараметрыФормы);
    
    ОткрытьФорму("Обработка.Обработка2.Форма", ПараметрыФормы,,,,,ОписаниеОповещения);


В Обработке 2 устанавливается НужныйРеквизит

Форма Обработки 2 - закрывается

В Обработке 1 выполняется Оповещение
&НаКлиенте
Процедура ЗакрытаФормаОбработки2(Результат, ДополнительныеПараметры) Экспорт
    
    ...
//Как здесь узнать установленный в Обработке 2 НужныйРеквизит
    
КонецПроцедуры


КАК???



andr_andrey Подменю пользователя
сообщение 11.04.24, 13:10
Сообщение #2

Почти ветеран
Иконка группы
Группа: Местный
Сообщений: 628
Спасибо сказали: 167 раз
Рейтинг: 132.1

AnryMc @ Сегодня, 11:07 * ,
Потрібно вказати в параметрах закриття при закритті форми:

Закрыть(<ПараметрЗакрытия>)

<ПараметрЗакрытия> (необязательный)
Тип: Произвольный.
Параметр закрытия формы, открытой в модальном режиме. Это значение будет возвращено как результат метода, открывающего форму модально.
В режиме отказа от модальности параметр передается в процедуру, описанную параметром ОписаниеОповещенияОЗакрытии метода ОткрытьФорму или свойством формы ОписаниеОповещенияОЗакрытии.


Signature
#define private public
enum BOOL { FALSE, TRUE, FILENOTFOUND } is made my day

AnryMc Подменю пользователя
сообщение 11.04.24, 14:44
Сообщение #3

Оратор
Иконка группы
Группа: Местный
Сообщений: 362
Спасибо сказали: 99 раз
Рейтинг: 100.6

Цитата(andr_andrey @ 11.04.24, 14:10) *
Закрыть(<ПараметрЗакрытия>)



А где это "всунуть" в Обработке 2, и как поймать в Обработке 1 в обработке Оповещения?

takefive Подменю пользователя
сообщение 11.04.24, 15:22
Сообщение #4

Говорящий
***
Группа: Пользователи
Сообщений: 62
Из: Днепропетровск
Спасибо сказали: 22 раз
Рейтинг: 23.2

Вариант с оповещением...
//процедуры нужно привязать к событиям, действиям...
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    //Сообщить("ИмяСобытия: " + ИмяСобытия + ", тип: " + ТипЗнч(ИмяСобытия));
    //Сообщить("Параметр: "   + Параметр   + ", тип: " + ТипЗнч(Параметр));
    //Сообщить("Источник: "   + Источник   + ", тип: " + ТипЗнч(Источник));
    Если ИмяСобытия = "ДиалогФорм" Тогда
        Объект.Дата = Параметр.Дата;
    КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ОповеститьВладельцаФормы(Команда)
    Если ВладелецФормы = Неопределено Тогда
        Сообщить("Не найдена форма - получатель...");
        Возврат;
    КонецЕсли;
    Данные = Новый Структура;
    Данные.Вставить("Дата", Объект.Дата);
    ИмяСобытия = "ДиалогФорм";
    Параметр = Данные;
    Источник = ЭтаФорма;
    Оповестить(ИмяСобытия, Параметр, Источник);
КонецПроцедуры

//Нужно указать владельца формы - третий параметр
&НаКлиенте
Процедура ОткрытьНастройки(Команда)
    ФормаНастроек = ПолучитьФорму("ВнешняяОбработка.ДвеФормы.Форма.ФормаНастройки",,ЭтаФорма);
    ФормаНастроек.Открыть();
КонецПроцедуры


Signature
без свинга нет музыки...

AnryMc Подменю пользователя
сообщение 11.04.24, 15:59
Сообщение #5

Оратор
Иконка группы
Группа: Местный
Сообщений: 362
Спасибо сказали: 99 раз
Рейтинг: 100.6



Цитата(AnryMc @ 11.04.24, 11:07) *
Капитально туплю сегодня - помогите!!!


Цитата(takefive @ 11.04.24, 16:22) *
Вариант с оповещением...


Что и где?

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
2 чел. читают эту тему (гостей: 2, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 14.06.24, 7:02
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!